Présentation des calques

Les calques sont les éléments qui constituent une composition. Lorsqu’elle ne comporte aucun calque, la composition n’est qu’un cadre vide. Une composition peut comporter autant de calques que nécessaire. Certaines compositions comportent des milliers de calques, d’autres un seul.

Les calques After Effects sont semblables aux pistes Adobe Premiere Pro. La principale différence vient du fait que chaque calque After Effects ne peut comporter qu’un métrage source, alors qu’une piste Premiere Pro comprend en général de nombreuses séquences. Les calques After Effects sont également proches des calques Photoshop, bien que l’interface des deux applications soit différente. L’utilisation de calques dans le panneau Montage d’After Effects est semblable à l’utilisation de calques dans le panneau Calques de Photoshop.

Vous pouvez créer plusieurs types de calques :

  • Calques vidéo et audio basés sur des métrages importés (images fixes, films et pistes audio par exemple)

  • Calques créés dans After Effects qui ont une fonction spéciale (calques de caméras, de lumières, d’effets et calques nuls par exemple)

  • Calques de couleur unie basés sur des métrages de couleur unie créés dans After Effects

  • Calques synthétiques qui conservent les éléments visuels créés dans After Effects (calques de forme et de texte)

  • Calques de précomposition, dont les métrages sources sont des compositions

Lorsque vous modifiez un calque, son métrage source n’est pas modifié. Vous pouvez utiliser un même métrage en tant que source de plusieurs calques, voire même l’utiliser différemment à chaque fois (voir la section Importation et interprétation de métrages).

Le fait de modifier un calque n’a pas d’incidence sur les autres calques, à moins que les calques n’aient été délibérément liés entre eux. Vous pouvez par exemple déplacer, faire pivoter et dessiner des masques pour un calque sans toucher aux autres calques de la composition.

After Effects affecte automatiquement un numéro à tous les calques d’une composition. Ces numéros sont affichés, par défaut, en regard du nom du calque dans le panneau Montage. Ce numéro correspond à la position du calque dans l’ordre d’empilement. Si vous modifiez l’ordre d’empilement, After Effects réactualise les numéros en conséquence. L’ordre d’empilement des calques a une incidence sur l’ordre de rendu et donc sur le rendu de la composition pour les prévisualisations et la sortie finale (voir la section Ordre de rendu et condensation des transformations).

Calques dans les panneaux Calque, Composition et Montage

Après l’ajout d’un calque dans une composition, vous pouvez repositionner le calque dans le panneau Composition. Dans le panneau Montage, vous pouvez modifier la durée et le point de départ d’un calque ainsi que sa place dans l’ordre d’empilement des calques. Vous pouvez également changer les propriétés d’un calque dans le panneau Montage (voir la section Propriétés des calques dans le panneau Montage).

Vous pouvez effectuer de nombreuses opérations (dessiner des masques par exemple) dans le panneau Composition ou le panneau Calque. En revanche, d’autres tâches telles que le suivi de mouvement et l’utilisation des outils de peinture doivent être effectuées dans le panneau Calque.

Dans le panneau Calque, un calque avant transformation s’affiche. Par exemple, le panneau Calque n’affiche pas le résultat de la modification de la propriété Echelle d’un calque. Pour visualiser un calque dans son contexte, avec d’autres calques, et les transformations effectuées, utilisez le panneau Composition.

Les calques qui ne sont pas basés sur un métrage source sont des calques synthétiques. Les calques de texte et de forme sont des calques synthétiques. Vous ne pouvez pas ouvrir un calque synthétique dans le panneau Calque. En revanche, vous pouvez précomposer un calque synthétique et ouvrir la précomposition dans le panneau Calque.

Remarque :

Pour afficher les modifications apportées à un calque (masques ou effets par exemple) dans le panneau Calque, sélectionnez l’option Rendu dans le panneau. Désélectionnez-la pour afficher le calque d’origine, non modifié.

Ouverture de calques et sources de calque

  • Pour ouvrir un calque autre qu’un calque de précomposition dans le panneau Calque, cliquez deux fois sur le calque ou sélectionnez-le puis choisissez Calque > Ouvrir le calque.

  • Pour ouvrir la composition source d’un calque de précomposition dans le panneau Composition, cliquez deux fois sur le calque ou sélectionnez-le puis choisissez Calque > Ouvrir la composition.

  • Pour ouvrir l’élément de métrage source d’un calque, cliquez deux fois sur le calque tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée, ou sélectionnez-le et choisissez Calque > Ouvrir la source des calques.

Remarque :

Si vous cliquez sur un calque avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), vous pouvez choisir la commande Ouvrir le métrage ou Ouvrir la composition pour ouvrir l’élément source du calque.

  • Pour ouvrir un calque de précomposition dans le panneau Calque, cliquez deux fois sur le calque tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée, ou sélectionnez-le et choisissez Calque > Ouvrir le calque.

Création de calques à partir d’éléments de métrage ou modification d’un calque source

Vous pouvez créer un calque à partir de n’importe quel métrage du panneau Projet, y compris une autre composition. Une fois le métrage ajouté à la composition, vous pouvez modifier et animer le calque correspondant.

Lorsque vous ajoutez une composition à une autre, vous créez un calque qui utilise comme source la composition ajoutée (voir la section Précomposition, imbrication et prérendu).

La préférence Métrage fixe (Préférences > Importer) permet de modifier la durée par défaut des calques dont les sources sont des métrages fixes. Lorsque vous créez un calque dont la source est une image fixe, la durée du calque correspond par défaut à celle de la composition. Vous pouvez modifier la durée d’un calque en effectuant un raccordement.

Remarque :

par défaut, les nouveaux calques commencent au début de la durée de la composition. Si vous préférez que les nouveaux calques commencent à l’instant présent, désactivez la préférence Créer des calques à l’instant de début de la composition (Édition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS)).

Une fois le calque ajouté à la composition, vous devez normalement le positionner et le redimensionner pour l’adapter à l’image (voir la section Mise à l’échelle ou basculement d’un calque).

Création de calques à partir d’un ou de plusieurs métrages

Lorsque vous créez des calques à partir de plusieurs métrages, les calques figurent dans l’ordre d’empilement des calques du panneau Montage, selon l’ordre dans lequel ils ont été sélectionnés dans le panneau Projet.

  1. Sélectionnez un ou plusieurs métrages et dossiers dans le panneau Projet.
  2. Utilisez l’une des méthodes suivantes :
    • Faites glisser les métrages sélectionnés vers le panneau Composition.

    Remarque :

    Maintenez la touche Maj enfoncée tout en faisant glisser l’élément pour aligner le calque sur le centre ou les bords de la composition.

    • Faites glisser les métrages sélectionnés vers le panneau Montage. Lorsque vous faites glisser l’élément vers la liste des calques, une barre indique l’apparence du calque lorsque vous relâchez le bouton de la souris. Si vous amenez l’élément sur le graphique temporel, un repère temporel indique la position du point d’entrée du calque lorsque vous relâchez le bouton de la souris.

    Remarque :

    Maintenez la touche Maj enfoncée tout en faisant glisser l’élément pour aligner le point d’entrée sur le repère d’instant courant.

    • Faites glisser les métrages sélectionnés vers le nom ou l’icône de la composition dans le panneau Projet, ou appuyez sur les touches Ctrl + / (Windows) ou Commande + / (Mac OS). De nouveaux calques sont créés immédiatement au-dessus d’un calque sélectionné et au centre de la composition. Si aucun calque n’est sélectionné, des nouveaux sont créés en haut de la pile de calques.

Création d’un calque à partir d’un métrage raccordé

Vous pouvez raccorder le métrage d’une image animée dans le panneau Métrage avant d’insérer un calque basé sur ce métrage dans une composition.

  1. Double-cliquez sur un élément de métrage dans le panneau Projet afin de l’ouvrir dans le panneau Métrage. (Voir la section Visualisation d’un élément de métrage dans le panneau Métrage).

  2. Déplacez le repère d’instant courant dans le panneau Métrage sur l’image à utiliser comme point d’entrée du calque, puis cliquez sur le bouton Définir le point d’entrée en bas du panneau Métrage.

  3. Déplacez le repère d’instant courant dans le panneau Métrage sur l’image que vous souhaitez utiliser comme point de sortie du calque, puis cliquez sur le bouton Définir le point de sortie en bas du panneau Métrage.
  4. Pour créer un calque à partir de ce métrage raccordé, cliquez sur un des boutons de modification en bas du panneau Métrage :

    Modifier recouvrir

    Crée le calque en haut de l’ordre d’empilement des calques en définissant le point d’entrée à l’instant courant dans le panneau Montage.

    Modifier Insérer Raccorder

    Cette option crée également le calque en haut de l’ordre d’empilement des calques en définissant le point d’entrée à l’instant courant dans le panneau Montage, mais il scinde aussi tous les autres calques. Les nouveaux calques scindés sont déplacés vers un point ultérieur, de sorte que leur point d’entrée corresponde avec le point de sortie du calque inséré.

Remplacement de la source d’un calque par une référence à un autre métrage

  1. Sélectionnez un ou plusieurs calques dans le panneau Montage.
  2. Maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée tout en faisant glisser un métrage du panneau Projet vers un calque sélectionné du panneau Montage.

Calques et métrages de couleur unie

Vous pouvez créer un calque à partir de n’importe quelle couleur unie et choisir la taille qui vous convient (jusqu’à 30 000 x 30 000 pixels). Les calques de couleur unie ont comme source des métrages de couleur unie. Les calques et métrages de couleur unie sont généralement désignés sous le nom de solides.

Les métrages de couleur unie fonctionnent comme les autres : vous pouvez ajouter des masques, modifier les propriétés de transformation et appliquer des effets à un calque dont la source est un métrage de couleur unie. Les solides permettent d’assigner une couleur à un arrière-plan et peuvent servir de base à un calque de paramètres pour créer un effet complexe ou des objets graphiques simples.

Les métrages de couleur unie sont automatiquement stockés dans le dossier Solides du panneau Projet.

Pour savoir comment modifier le dossier des solides pour une meilleure organisation de projet, voir Organisation améliorée du dossier des solides.

Jeff Almasol propose, sur son site Web redefinery, un script permettant de renommer les éléments de métrage solides sélectionnés dans le panneau Projet. Vous pouvez utiliser ce script, par exemple, pour inclure les dimensions en pixels, le format et les valeurs des couleurs RVB dans le nom.

Remarque :

Dans After Effects CS6 et versions ultérieures, les nouveaux calques de couleur unie sont gris à 17 % (45/255), de manière à offrir un bon contraste avec la luminosité par défaut plus foncée de l’interface utilisateur.

Création d’un calque ou d’un métrage de couleur unie

  • Pour créer un métrage de couleur unie sans calque dans une composition, choisissez Fichier > Importer > Solides.
  • Pour créer un métrage de couleur unie avec un calque dans la composition actuelle, sélectionnez Calque > Nouveau > Solide ou appuyez sur les touches Ctrl + Y (Windows) ou Commande + Y (Mac OS).

    Pour créer un calque de couleur unie de même taille que la composition, choisissez la commande Créer taille de la composition lors de la création du calque.

Modification des paramètres d’un calque ou d’un métrage de couleur unie

  • Pour modifier les paramètres du calque ou du métrage de couleur unie sélectionné, choisissez Calque > Réglage uni.

    Pour appliquer les modifications à tous les calques de couleur unie qui utilisent ce métrage, sélectionnez l’option « Appliquer à tous les calques utilisant ce solide ». Si vous ne sélectionnez pas cette option, vous créez un métrage qui devient la source du calque sélectionné.

Calques d’effets

Lors de l’application d’un effet à un calque, seul ce calque est affecté par l’effet. Un effet peut néanmoins être indépendant si vous lui créez un calque d’effets spécifique. Lorsque des effets sont appliqués à un calque d’effets, tous les calques qui figurent sous ce dernier dans l’ordre d’empilement des calques sont concernés. Un calque d’effets situé en dernière position dans l’ordre d’empilement ne présente aucun résultat visible.

Les effets d’un calque d’effets s’appliquent à tous les calques situés sous ce dernier. Ils sont donc particulièrement utiles pour l’application simultanée d’effets à plusieurs calques. Le comportement d’un calque d’effets est en tout autre point identique à celui des autres calques. Ainsi, vous pouvez utiliser des images clés ou des expressions avec n’importe quelle propriété de calque d’effets.

Remarque :

plus précisément, le calque d’effets applique l’effet au composite créé à partir de tous les calques sous le calque d’effets dans l’ordre d’empilement des calques. Pour cette raison, l’application d’un effet à un calque d’effets améliore les performances de rendu par rapport à l’application du même effet séparément à chacun des calques sous-jacents.

Remarque :

Si vous voulez appliquer un effet ou une transformation à un groupe de calques, vous pouvez précomposer les calques, puis appliquer l’effet ou la transformation au calque de précomposition (voir la section Précomposition de calques).

Vous pouvez utiliser des masques sur le calque d’effets pour appliquer un effet uniquement à certaines parties des calques sous-jacents. Vous pouvez animer des masques pour suivre le mouvement d’objets animés dans les calques sous-jacents.

  • Pour créer un calque d’effets, choisissez Calque > Nouveau > Calque d’effets, ou appuyez sur Ctrl + Alt + Y (Windows) ou Commande + Option + Y (Mac OS).
  • Pour transformer des calques en calques d’effets, sélectionnez l’option Calque d’effets des calques du panneau Montage ou choisissez Calque > Options > Calque d’effets.

Remarque :

vous pouvez désactiver l’option Calque d’effets d’un calque pour le transformer en un calque normal.

Ressources en ligne relatives aux calques d’effets

Sur son site Web Video Copilot, Andrew Kramer propose un didacticiel vidéo dans lequel il explique comment utiliser un calque d’effets pour appliquer un effet à des parties spécifiques d’un film, pour une courte durée.

Sur le site Web Creative COW, Eran Stern propose un didacticiel vidéo illustrant l’utilisation de lumières comme calques d’effets, dans le but de contrôler avec précision les calques affectés par les différentes lumières.

Lloyd Alvarez propose, sur son site Web After Effects Scripts, un script qui crée un calque d’effets au-dessus de chaque calque sélectionné ; chaque nouveau calque d’effets étant conformé à la durée du calque sélectionné.

Création d’un calque et d’un métrage Photoshop

Lorsque vous créez un fichier Adobe Photoshop dans After Effects, Photoshop démarre et crée un fichier PSD. Ce fichier se compose d’un calque vide ayant les mêmes dimensions que votre composition et contenant les repères admissibles appropriés pour le titre et pour l’action. Le codage des couleurs du fichier PSD est identique à celui du projet After Effects.

Le nouveau fichier PSD est automatiquement importé dans After Effects en tant que métrage. Toute modification enregistrée dans Photoshop est visible au niveau du métrage dans After Effects.

  • Pour créer un métrage Photoshop et l’utiliser en tant que source d’un nouveau calque dans la composition en cours, choisissez Calque > Nouveau > Fichier Adobe Photoshop. Le calque Photoshop est ajouté à la composition en tant que calque de niveau supérieur.
  • Pour créer un métrage Photoshop ayant les paramètres de la dernière composition ouverte, sans l’ajouter à une composition, choisissez Fichier > Nouveau > Fichier Adobe Photoshop.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne