À propos de la précomposition et de l’imbrication

Pour regrouper des calques qui se trouvent déjà dans une composition, vous pouvez les précomposer. Cette opération consiste à placer les calques dans une nouvelle composition, ce qui permet de remplacer les calques de la composition d’origine. La nouvelle composition imbriquée devient la source d’un seul calque dans la composition d’origine. La nouvelle composition apparaît dans le panneau Projet. Elle est prête pour le rendu ou pour une utilisation dans une autre composition. Vous pouvez imbriquer des compositions en ajoutant une composition existante à une autre. L’opération est identique à celle qui consiste à ajouter un métrage à une composition. Précomposer un calque unique permet d’ajouter des propriétés de transformation à un calque et d’influencer l’ordre de rendu des éléments d’une composition.

L’imbrication consiste à inclure une composition dans une autre. La composition imbriquée apparaît sous la forme d’un calque dans la composition réceptrice.

Dans certains cas, la composition imbriquée est désignée sous le nom de précomposition, parfois abrégée en précomp ou pré-comp. Lorsque vous utilisez une précomposition comme métrage source pour un calque, ce dernier est désigné sous le nom de calque de précomposition.

Pendant le rendu, les données de l’image et les autres informations s’écoulent en quelque sorte de chaque composition imbriquée vers la composition qui les contient. Pour cette raison, les compositions imbriquées sont parfois désignées comme étant en amont des compositions qui les contiennent. Les compositions réceptrices sont situées en aval des compositions imbriquées. L’ensemble des compositions associées par imbrication constitue un réseau de compositions. Vous pouvez parcourir un réseau de compositions à l’aide du navigateur de compositions et du mini-organigramme (voir Ouverture et navigation dans les compositions imbriquées).

Les précompositions dans After Effects s’apparentent aux objets dynamiques dans Adobe Photoshop.

Champs d’application de la précomposition et de l’imbrication

La précomposition et l’imbrication sont très utiles pour gérer et organiser les compositions complexes. Grâce à la précomposition et à l’imbrication, vous pouvez :

  • Apporter des modifications complexes à l’ensemble d’une composition : vous pouvez créer une composition contenant plusieurs calques, l’imbriquer dans une composition parente, puis animer et appliquer des effets à la composition imbriquée, de sorte que tous les calques adoptent les mêmes modifications sur la même période.
  • Recycler une compilation : vous pouvez réaliser une animation dans sa propre composition, puis amener cette composition dans d’autres compositions, autant de fois que vous le souhaitez.
  • Effectuer une mise à jour en une seule étape : lorsque vous modifiez une composition imbriquée, la modification s’applique à chaque composition qui l’utilise. De même, la modification d’un métrage source s’applique à chaque composition qui l’utilise.
  • Modifier l’ordre de rendu par défaut d’un calque : vous pouvez configurer After Effects afin que le rendu d’une transformation (une rotation, par exemple) précède le rendu d’un effet de sorte que celui-ci s’applique au métrage pivoté.
  • Ajouter un autre groupe de propriétés de transformation à un calque : le calque qui représente la composition a des propriétés qui lui sont propres, outre les propriétés des calques qu’il contient. Vous pouvez ainsi ajouter un autre ensemble de transformations à un calque ou à un ensemble de calques.

Préférences et paramètres de composition affectant les compositions imbriquées

La précomposition étant un calque en soi, vous pouvez contrôler son comportement à l’aide des options de calque et de composition du panneau Montage. Vous pouvez décider de propager ou non les modifications apportées aux options de la composition réceptrice à la composition imbriquée. Pour éviter que les compositions imbriquées ne soient affectées par les options de calque, choisissez Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS), puis décochez la case Les modifications affectent les compositions imbriquées.

Dans l’onglet Avancé de la boîte de dialogue Paramètres de composition (Composition > Paramètres de composition), choisissez Préserver la résolution (compositions imbriquées) ou Préserver la cadence (compositions imbriquées ou en file d’attente de rendu) si vous voulez que la composition conserve sa résolution ou sa cadence d’images et qu’elle n’hérite pas des paramètres de la composition réceptrice. Par exemple, si vous avez délibérément utilisé une cadence faible pour obtenir un résultat saccadé, animé à la main, mieux vaut conserver la cadence de cette composition après imbrication. De même, si une rotoscopie adopte une cadence ou une résolution différente, le résultat n’est pas garanti. Utilisez de préférence ce paramètre (l’effet Postérisation temporelle est moins efficace).

Remarque :

Sur son site Web redefinery, Jeff Almasol propose un script permettant d’activer et de désactiver plus facilement le paramètre de préférence Préserver la résolution (compositions imbriquées) ou Préserver la cadence (compositions imbriquées ou en file d’attente de rendu).

Si vous modifiez l’instant courant d’un panneau, l’instant courant des autres panneaux associés à cette composition est mis à jour. Par défaut, l’instant courant est également mis à jour dans toutes les compositions liées par imbrication à la composition active. Pour éviter que l’instant présent des compositions liées par imbrication ne se mette à jour lorsque vous modifiez l’instant présent d’une composition, désélectionnez l’option Synchroniser le temps de tous les éléments concernés (Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS)).

Ressources en ligne sur la précomposition et l’imbrication

Chris et Trish Meyer partagent des conseils sur la configuration d’une hiérarchie de composition afin de faciliter la modification d’un projet dans cet article sur le site Web ProVideo Coalition.

Vous trouverez sur cette page du site Webaescripts le script Un-Precompose, qui extrait les calques d’uneprécomposition.

Vous trouverez sur cette page du site Webaescripts le script Zorro-The Layer Tagger, qui vous permet d’associer les calques dans votre composition à l’aide de balises plutôt que d’une précomposition.

Précomposition de calques

Cette opération consiste à placer les calques dans une nouvelle composition (parfois appelée précomposition), ce qui permet de remplacer les calques de la composition originale. Précomposer un calque unique permet d’ajouter des propriétés de transformation à un calque et d’influencer l’ordre de rendu des éléments d’une composition.

  1. Sélectionnez les calques dans le panneau Montage, puis choisissez Calque > Précomposition ou appuyez sur les touches Ctrl + Maj + C (Windows) ou Commande + Maj + C (Mac OS).
  2. Sélectionnez l’une des options suivantes :

    Laisser tous les attributs dans

    Cette option permet de conserver les propriétés et les images clés du calque précomposé dans la composition originale. Elles sont appliquées au nouveau calque qui représente la précomposition. Les dimensions de l’image de la nouvelle composition sont identiques à celles du calque sélectionné. Cette option n’est pas disponible lorsque vous sélectionnez plusieurs calques, un calque de texte ou un calque de forme.

    Transférer tous les attributs vers la nouvelle composition

    Cette option déplace les propriétés et les images clés des calques précomposés d’un niveau vers le bas dans la hiérarchie de la composition. Lorsque vous utilisez cette option, les modifications apportées aux propriétés des calques affectent les calques de façon individuelle au sein de la précomposition. Les dimensions de l’image de la nouvelle composition sont identiques à celles de la composition originale.

Les effets peuvent inclure les masques et effets d’autres calques

Les effets qui utilisent des calques comme entrée, tels que Appliquer un cache et Dispersion, peuvent cibler les masques et les effets du calque d’entrée. Vous pouvez utiliser ces calques sans leur appliquer de précomposition afin qu’ils soient référencés par un effet. 

La commande est semblable à la fonction du menu Afficher au bas du panneau Visualiseur de calques qui vous permet d’effectuer le rendu du calque à partir de différentes positions dans l’ordre de rendu : à partir de sa source, à partir de ses masques ou à partir de ses effets individuels.
Dans le cas des effets avec propriétés de calque, ouvrez le menu Paramètre d’entrée à droite de la sélection du calque, puis choisissez le calque d’entrée cible, tel que :
 

  • Source : cible uniquement la source du calque. Les masques et les effets sont ignorés.
  • Masques : cible le calque après l’application de ses masques. Les effets sont ignorés.
  • Effets et masques : cible le calque après l’application de ses masques et effets.

 

Ouverture et navigation dans les compositions imbriquées

Les compositions imbriquées sont parfois désignées comme étant en amont des compositions qui les contiennent. Les compositions réceptrices sont situées en aval des compositions imbriquées. La composition racine est la dernière en aval, alors que la composition la plus imbriquée est la première en amont. Les compositions liées les unes aux autres par imbrication forment une sorte de chaîne. Lorsqu’il s’agit de l’ensemble complet des compositions ainsi liées entre elles, on parle de réseau de compositions.

After Effects propose diverses méthodes pour ouvrir une composition imbriquée (précomposition) :

  • Cliquez deux fois sur l’entrée correspondant à la composition dans le panneau Projet.
  • Cliquez deux fois sur un calque de précomposition dans le panneau Montage. Alt + double-clic (Windows) ou Option + double-clic (Mac OS) pour ouvrir le calque de précomposition en tant que calque dans le panneau Calque.

Remarque :

si vous double-cliquez sur un calque de précomposition alors qu’un outil de peinture ou l’outil Roto-pinceau est actif, il s’ouvre dans le panneau Calque.

  • Pour ouvrir la dernière composition active appartenant au même réseau de compositions que la composition actuellement active, appuyez sur Maj + Echap.

  • Utilisez le navigateur de compositions.

  • Utilisez le mini-organigramme des compositions.

Navigateur de compositions

Le navigateur de compositions se présente comme une barre située le long du bord supérieur du panneau Composition. Il montre la composition active dans ce visualiseur, par rapport aux autres compositions du même réseau. Les compositions affichées sont les dernières activées dans la chaîne à laquelle appartient la composition actuellement active.

Navigateur de compositions
A. Composition active (courante) B. Flèche permettant d’ouvrir le mini-organigramme des compositions C. Bouton de menu du panneau D. Points de suspension 

Les flèches entre les noms des compositions représentent le flux des données de pixels dans cette chaîne. Par défaut, le navigateur affiche les compositions en aval sur le côté gauche de la barre et les compositions en amont sur le côté droit. Ce mode d’affichage dépend de l’option Flux de droite à gauche qui figure dans le menu du panneau Composition. Si vous préférez afficher les compositions dans l’autre sens, choisissez l’option Flux de gauche à droite. Il s’agit d’une préférence globale qui s’applique à toutes les compositions. Elle influe également sur la vue du mini-organigramme de compositions.

Le nom des compositions en aval apparaît en grisé pour indiquer que leur contenu n’est pas utilisé ou visible dans la composition active.

  • Pour afficher ou masquer la barre du navigateur de compositions, choisissez Afficher le navigateur de la composition.

  • Pour activer une composition visible dans la barre du navigateur, il suffit de cliquer sur son nom.

  • Si la chaîne des compositions est trop longue pour figurer en entier dans le panneau Composition, un bouton contenant des points de suspension s’affiche sur le côté gauche ou droit de la barre du navigateur. En cliquant sur ce bouton, vous pouvez afficher la totalité de la chaîne pendant un court laps de temps.

Remarque :

Pour faire défiler un long chemin d’accès, placez le pointeur sur un bouton de composition dans le navigateur de la composition et actionnez la molette de défilement de la souris.

Mini-organigramme des compositions

Vous pouvez afficher temporairement ce mini-organigramme pour simplifier la navigation au sein d’un réseau de compositions. Il présente les compositions les plus proches de celle sélectionnée, aussi bien en amont qu’en aval.

Les couleurs utilisées dans le mini-organigramme dépendent des libellés associés aux compositions dans le panneau Projet. Si dans une composition, vous imbriquez plusieurs fois de suite une même composition, les diverses instances de cette dernière sont représentées par une seule entrée, avec leur nombre indiqué entre parenthèses.

Pour ouvrir le mini-organigramme, utilisez l’une des méthodes suivantes :

Mini-organigramme des compositions
A. Indicateur signalant qu’il n’existe aucun flux en sortie pour la composition B. Sens du flux C. Composition active (courante) 
  • Appuyez brièvement sur la touche de tabulation lorsqu’un panneau Composition, Calque ou Montage est actif.
  • Cliquez sur la flèche situé à droite du nom d’une composition dans la barre du navigateur de compositions.

  • Choisissez l’option Mini-organigramme des compositions dans le menu Composition, le menu du panneau Composition ou le menu du panneau Montage.

  • Cliquez sur le bouton du mini-organigramme des compositions dans la partie supérieure du panneau Montage.

Vous pouvez choisir le sens d’affichage du flux (de gauche à droite ou inversement), comme dans le navigateur de compositions. Les flèches représentent la direction du flux. Si au lieu d’une flèche, le programme affiche à côté d’une composition, cela signifie qu’il n’existe aucun flux pour cette composition, en entrée ou en sortie.

Dans le mini-organigramme, les compositions en amont sont classées de haut en bas par ordre alphabétique ou dans l’ordre des calques. Pour passer d’un mode de tri à l’autre, appuyez sur la touche S lorsque le mini-organigramme des compositions est ouvert. Si vous optez pour l’ordre des calques, la position d’une composition utilisée plusieurs fois correspond à l’instance la plus haut placée dans l’ordre de superposition. Les compositions en aval sont toujours classées par ordre alphabétique.

Pour naviguer dans le mini-organigramme et sélectionner des compositions, servez-vous des touches Flèche ou cliquez sur les boutons Flèche ou situés de part et d’autre de chaque composition. Pour activer la composition sélectionnée, appuyez sur la barre d’espace ou la touche Entrée (Windows) ou sur la touche Retour (Mac OS). Pour refermer le mini-organigramme des compositions sans effectuer aucune opération, appuyez sur la touche Echap, appuyez brièvement sur la touche Maj ou cliquez à l’extérieur du mini-organigramme.

Sur le site Web After Effects Portal, Rich Young propose des informations supplémentaires sur le panneau Organigramme et le mini-organigramme des compositions.

Prérendu d’une composition imbriquée

Le rendu d’une composition imbriquée complexe peut exiger davantage de temps, tant pour les prévisualisations que pour la sortie finale. Si vous ne souhaitez plus retravailler une composition imbriquée, vous pouvez gagner du temps lors des opérations de rendu en effectuant un prérendu de la composition imbriquée dans un film et en remplaçant la composition par le film rendu. La composition imbriquée originale étant toujours répertoriée dans le panneau Projet, rien ne vous empêche de la modifier. Si vous apportez une importante modification à la composition imbriquée originale, il vous suffit d’effectuer à nouveau son rendu.

Le prérendu d’une composition imbriquée présente une grande utilité lorsque cette composition est utilisée plusieurs fois dans un projet.

Remarque :

appliquez vos paramètres de sortie définitifs pour le prérendu de la composition imbriquée.

  1. Sélectionnez la composition dans le panneau Projet ou Composition.
  2. Sélectionnez Composition > Prérendu.

    La commande Prérendu ajoute la composition à la file d’attente de rendu et stipule que l’action de postrendu Importer & remplacer utilisation consiste à remplacer la composition par le film rendu.

  3. Dans le panneau File d’attente de rendu, faites les réglages nécessaires et cliquez sur le bouton Rendu pour procéder au rendu de votre composition.

Visionnez ce didacticiel vidéo sur le site Web Video2Brain pour savoir comment gagner du temps en prérendant et en utilisant des doublures dans After Effects.

Remarque :

plutôt que de remplacer la composition par le film, vous pouvez aussi utiliser le film rendu en tant que doublure de la composition imbriquée.

Ordre de rendu et condensation des transformations

Une composition consiste en une superposition de calques dans le panneau Montage. Lorsque vous procédez au rendu de votre composition, pour faire une prévisualisation ou une sortie finale, le calque inférieur est rendu en premier. Au niveau de chaque calque pixellisé (non vectorisé), les éléments sont appliqués dans l’ordre suivant : masques, effets, transformations et styles de calque. Dans le cas de calques vectorisés, pixellisés en continu, l’ordre de rendu par défaut est le suivant : masques, transformations, puis effets.

Les transformations constituent une modification des propriétés regroupées dans la catégorie Transformation, dans le panneau Montage (Point d’ancrage, Position, Echelle, Rotation et Opacité par exemple). Le résultat de l’opération de rendu (avant l’application des transformations) apparaît dans le panneau Calque.

Remarque :

pour maîtriser d’avantage le moment d’application des transformations, vous pouvez appliquer l’effet Transformation et modifier son ordre d’apparition dans la liste des effets.

Dans un groupe d’effets ou de masques, les éléments sont utilisés dans un ordre déterminé (du premier, en haut, au dernier). Par exemple, si vous appliquez l’effet Cercle, puis l’effet Loupe, le cercle est agrandi. Vous pouvez toutefois faire glisser l’effet Loupe au-dessus de l’effet Cercle dans le panneau Effets ou Montage, le cercle est alors tracé après l’agrandissement (il n’est pas agrandi).

Une fois un calque rendu, le rendu du calque suivant commence. Un calque rendu peut servir d’entrée pour le rendu du calque suivant (par exemple, pour déterminer le résultat d’un mode de fusion).

Lorsqu’une composition comprend d’autres compositions imbriquées, le rendu de la composition imbriquée précède celui des autres calques dans la composition réceptrice.

Remarque :

certains effets ignorent les masques du calque auquel ils sont appliqués. Pour que ce type d’effet fonctionne sur un calque masqué, précomposez le calque auquel le masque est appliqué, puis appliquez l’effet au calque précomposé (Voir la section À propos de la précomposition et de l’imbrication).

Condensation des transformations

Si l’option Condenser les transformations est sélectionnée pour une composition imbriquée, les transformations de la composition imbriquée sont effectuées après le rendu des masques et des effets de la composition réceptrice. Ainsi, les transformations de la composition imbriquée et de la composition réceptrice peuvent être associées (ou condensées) et réalisées en même temps. Il en va de même des calques vectorisés, non pixellisés en continu.

Remarque :

l’option Condenser les transformations n’existe pas pour les calques vectorisés qui bénéficient par contre de l’option Pixellisation (située au même endroit). Les calques vectorisés comprennent : les calques de forme et de texte et les calques avec fichiers d’images vectorielles en tant que métrage source. Les calques de texte et de forme sont toujours pixellisés en continu.

La condensation des transformations permet, par exemple, de préserver la résolution lorsqu’un calque est réduit de moitié dans une composition imbriquée et que cette dernière est multipliée par un facteur de deux dans la composition réceptrice. Dans ce cas, plutôt que de réaliser les deux transformations au risque de perdre des données d’image, vous pouvez effectuer une seule transformation (sans rien faire puisque les transformations individuelles s’annulent entre elles).

Si les transformations ne sont pas condensées, le rendu d’une composition imbriquée contenant des Calques 3D est effectué en tant qu’image 2D d’un agencement 3D, à l’aide de la caméra par défaut de la composition. Cela permet d’éviter toute intersection entre la composition imbriquée et les Calques 3D, la projection d’ombres entre les Calques 3D et la composition réceptrice. D’autre part, la composition imbriquée n’est pas influencée par les caméras et les lumières de la composition réceptrice.

Si des transformations sont condensées, les propriétés 3D des calques de la composition imbriquée sont visibles dans la composition réceptrice. Ainsi, il peut y avoir intersection entre la composition imbriquée et les Calques 3D et projection d’ombres entre les Calques 3D et la composition réceptrice. La caméra et les lumières de la composition réceptrice peuvent également contrôler la composition imbriquée.

En substance, la condensation des transformations pour une composition imbriquée empêche After Effects d’aplatir et de recadrer les calques dans la précomposition. Dans la mesure où un calque d’effets opère sur le composite de tous les calques de la même composition qui lui sont inférieurs, un calque d’effets dans une composition imbriquée contenant des transformations condensées déclenchera l’aplatissement et le recadrage que la condensation des transformations empêcherait habituellement.

Lorsque vous appliquez un masque fermé (mode de masquage non défini sur Aucun), un style de calque ou un effet à une composition imbriquée avec transformations condensées, l’application commence par effectuer le rendu des calques de la composition imbriquée, puis elle applique les masques et les effets, et enfin elle combine le résultat obtenu avec la composition principale. Cette méthode de rendu signifie que les modes de fusion des calques imbriqués ne sont pas appliqués aux calques sous-jacents de la composition principale et que les Calques 3D qui se trouvent au-dessus ou en dessous du calque condensé ne peuvent pas entrer en intersection, ni projeter des ombres entre eux.

Ressources en ligne

Chris et Trish Meyer expliquent la condensation des transformations et la pixellisation en continu dans cet article disponible sur le site Web ProVideo Coalition.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne