Jeff Almasol propose, sur son site Web redefinery, un script permettant de procéder au rendu et à l’exportation de chacun des calques sélectionnés séparément. Par exemple, utilisez ce script si les calques représentent différentes versions ou parties d’un effet dont vous souhaitez effectuer le rendu en passes distinctes pour apporter une certaine flexibilité à la manière dont leur montage est effectué.

Affichage et modification des informations sur un calque

  • Pour renommer un groupe de calques ou de propriétés, Utilisez l’une des méthodes suivantes :
    • Sélectionnez l’élément dans le panneau Montage, appuyez sur la touche Entrée (Windows) ou Retour (Mac OS), puis saisissez le nouveau nom.

    • Dans le panneau Montage, cliquez sur l’élément avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), choisissez Renommer, puis saisissez le nouveau nom.

  • Pour afficher alternativement le nom du métrage source d’un calque sélectionné et celui du calque dans le panneau Montage, cliquez sur l’en-tête de la colonne Nom des calques/Nom des sources du panneau Montage.

Remarque :

lorsque le nom du calque et le nom du métrage source sont identiques, le nom du calque apparaît entre crochets, comme ceci : [nom du calque].

  • Pour afficher le nom du fichier de métrage source d’un calque donné dans le panneau Info, appuyez sur les touches Ctrl + Alt + E (Windows) ou Commande + Option + E (Mac OS).
  • Pour connaître le métrage source d’un calque, cliquez avec le bouton droit de la souris (Windows) ou en maintenant la touche Ctrl enfoncée (Mac OS) sur le calque, dans le panneau Montage, et sélectionnez la commande Afficher la source des calques dans le projet.

Le métrage source est sélectionné dans le panneau Projet.

Vous pouvez filtrer des calques dans le panneau Montage pour n’afficher que les calques dont les propriétés correspondent à la chaîne de recherche ou à d’autres caractéristiques. Pour en savoir plus, reportez-vous aux sections Recherche et filtrage dans les panneaux Montage, Projet et Effets et paramètres prédéfinis et Affichage des propriétés et des groupes dans le panneau Montage (raccourcis clavier).

Jeff Almasol propose, sur son site Web redefinery, un script qui écrit automatiquement des informations précises sur des éléments de métrage ou des calques dans les champs de commentaire pour les éléments correspondants du panneau Projet ou Montage.

Sur son site Web, Christopher Green propose un script (Selected_Layers_Renamer.jsx) qui permet de renommer plusieurs calques sélectionnés dans le panneau Métrage. Vous avez la possibilité de rechercher et de remplacer le texte dans les noms, d’annexer des caractères au début ou à la fin des noms, de supprimer un nombre spécifique de caractères au début ou à la fin des noms ou de remplacer les noms d’une série par des nombres.

Options de calques et colonnes du panneau Montage

Les options de calques, qui sont classées par colonne dans le panneau Montage, définissent la plupart des caractéristiques des calques. Par défaut, la colonne Fonctions A/V apparaît à gauche du nom du calque et les colonnes Options et Modes (Modes de fusion) à droite. Vous pouvez cependant afficher les colonnes dans un ordre différent (voir Colonnes).

Pour afficher ou masquer des colonnes dans le panneau Montage, cliquez sur le bouton Options de calque , Options de transfert ou Entrée/Sortie/Durée/Extension dans l’angle inférieur gauche du panneau Montage. Appuyez sur les touches Maj + F4 pour afficher ou masquer la colonne Parent. Appuyez sur la touche F4 pour basculer entre les colonnes Options et Modes.

Le résultat de certains paramètres d’options de calque dépend des paramètres des options de composition, qui se trouvent en haut à droite de la liste de calques dans le panneau Montage.

Remarque :

Pour modifier rapidement le paramétrage d’une option pour plusieurs calques, cliquez sur le bouton d’option d’un calque, puis faites-le glisser vers le bas ou vers le haut de cette colonne pour les calques adjacents.

Jeff Almasol propose, sur son site Web redefinery, un script qui crée un panneau permettant d’enregistrer et de restaurer les paramètres d’options de calque pour tous les calques d’une composition.

Options de la colonne Fonctions A/V

Audio

Active ou désactive le son du calque.

Solo

Affiche le calque actif dans les prévisualisations et les rendus, ignore les calques pour lesquels cette option est désactivée (voir Isolation d’un calque.)

Verrouiller

Verrouille le contenu du calque, empêchant ainsi toute modification (voir Verrouillage ou déverrouillage d’un calque).

Options de la colonne Options

Discret

Masque le calque actif lorsque l’option Masquer calques discrets est sélectionnée (voir Affichage et masquage des calques dans le panneau Montage).

Condenser transform./Pixellisation

Condense les transformations si le calque est une précomposition ; pixellise en continu si le calque est un calque de forme, un calque de texte ou qu’il contient un fichier de graphiques vectoriels (fichier Adobe Illustrator, par exemple) en tant que métrage source. Lorsque cette option est sélectionnée pour un calque contenant un fichier de graphiques vectoriels, After Effects repixellise le calque pour chaque image, ce qui améliore la qualité de l’image, mais ralentit la prévisualisation et le rendu (voir Ordre de rendu et condensation des transformations et Pixellisation en continu d’un calque contenant des images vectorielles.)

Qualité

Permet de passer de l’option Optimale à l’option Ebauche pour sélectionner la qualité de rendu du calque, y compris le rendu à l’écran des prévisualisations (voir Qualité d’image d’un calque et positionnement des sous-pixels.)

Effet

Sélectionnez cette option pour obtenir un rendu avec effets. L’option n’a aucune incidence sur le paramétrage de chaque effet au niveau du calque (voir Suppression ou désactivation d’effets et d’animations prédéfinies).

Interpolation d’images

Définit l’option d’interpolation sur l’un des trois états suivants : Fusion d’images , Déplacement des pixels ou désactivée. Si l’option d’activation de l’interpolation n’est pas sélectionnée, le paramètre d’interpolation du calque n’est pas pertinent (voir Interpolation.)

Flou de mouvement

Active ou désactive le flou de mouvement du calque. Si l’option Activer le flou de mouvement n’est pas sélectionnée, le paramètre de flou de mouvement du calque n’est pas pertinent (voir Flou de mouvement.)

Calque d’effets

Identifie le calque en tant que calque d’effets (voir Calques d’effets).

Calque 3D

Identifie le calque en tant que calque 3D. Si le calque est un calque 3D qui comprend des sous-Calques 3D (calque de texte avec propriétés 3D par caractère, par exemple), l’icône de l’option est la suivante : . (voir Présentation des Calques 3D et ressources associées).

Activation ou désactivation de la visibilité ou l’influence d’un calque ou d’un groupe de propriétés

Le bouton d’option Vidéo (œil) d’un calque contrôle si les informations visuelles d’un calque sont rendues pour les prévisualisations ou la sortie finale. Si le calque est un calque d’effets, le bouton d’option Vidéo contrôle si les effets sur le calque sont appliqués au composite des calques sous-jacents. Si le calque est une caméra ou une lumière, le bouton d’option Vidéo contrôle si le calque est activé ou désactivé.

Plusieurs composants de calques (par exemple les tracés de peinture, les opérations de tracé dans les calques de forme et les animateurs de texte dans les calques de texte) ont leurs propres boutons d’option Vidéo. Vous pouvez utiliser le bouton d’option Vidéo pour activer ou désactiver la visibilité et l’influence de ces éléments individuellement.

  • Pour désactiver la visibilité d’un calque, désélectionnez le bouton d’option Vidéo du calque.
  • Pour sélectionner l’option Vidéo pour tous les calques, choisissez Calque > Options > Afficher toutes les vidéos.
  • Pour désélectionner l’option Vidéo pour tous les calques sauf les calques sélectionnés, choisissez Calque > Options > Masquer les autres vidéos.

Isolation d’un calque

Pour animer, prévisualiser ou effectuer le rendu de calques, vous pouvez les séparer des autres calques en les isolant. L’isolation exclut du rendu tous les autres calques du même type (à la fois lors de la prévisualisation dans le panneau Composition et du rendu final). Par exemple, lorsque vous isolez un calque vidéo, l’opération n’affecte pas les calques de lumière ou audio. Ainsi, ces derniers s’affichent lorsque vous prévisualisez la composition, ou lorsque vous en effectuez le rendu. En revanche, les autres calques vidéo ne sont pas visibles.

  • Pour isoler un ou plusieurs calques, sélectionnez-les dans le panneau Montage et cliquez sur l’icône Solo à gauche du nom des calques.
  • Pour isoler un seul calque, cliquez sur l’icône Solo (à gauche du nom) tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

L’option Vidéo des autres calques apparaît en grisé lorsqu’un calque est isolé. Les autres calques ne sont donc pas visibles.

Sur son site Web After Effects Scripts, Lloyd Alvarez propose un script grâce auquel vous pouvez marquer des calques, puis les sélectionner, les rendre discrets et les isoler en fonction de leur marquage. Le marquage est ajouté aux commentaires dans la colonne Commentaires du panneau Montage.

Verrouillage ou déverrouillage d’un calque

L’option de verrouillage empêche la modification accidentelle des calques. Lorsqu’un calque est verrouillé, il n’est pas possible de le sélectionner dans les panneaux Composition et Montage. Si vous tentez de sélectionner ou de modifier un calque verrouillé, ce dernier s’illumine dans le panneau Montage.

Lorsqu’un calque est verrouillé, l’icône de verrouillage s’affiche dans la colonne Fonctions A/V qui, par défaut, se trouve à gauche du nom de calque dans le panneau Montage.

  • Pour verrouiller ou déverrouiller un calque, cliquez sur l’option Verrouiller du calque dans le panneau Montage.
  • Pour déverrouiller tous les calques de la composition active, choisissez Calque > Options > Déverrouiller tous les calques.

Couleurs de libellés pour les calques, les compositions et les éléments de métrage

Dans les panneaux Projet et Montage, vous pouvez utiliser des libellés (cases de couleur de la colonne Libellé) pour classer et gérer les compositions, métrages et calques. Les différentes couleurs indiquent, par défaut, différents types de métrage. Vous pouvez modifier à votre guise la correspondance entre les couleurs et les catégories.

Remarque :

Renommez les groupes de libellés pour simplifier l’organisation et le classement par catégorie des calques et des éléments de métrage. Pour voir les noms de libellés dans la colonne Libellé, élargissez la colonne à une dimension supérieure à la largeur par défaut.

  • Pour sélectionner tous les calques utilisant la même couleur de libellé, sélectionnez un calque de cette couleur, puis choisissez Edition > Libellé > Sélectionner un groupe de libellés.
  • Pour modifier la couleur de libellé d’un calque, cliquez sur le libellé dans le panneau Montage et sélectionnez une couleur.
  • Pour modifier la couleur de libellé de tous les calques utilisant la même couleur, sélectionnez l’un des calques du groupe, choisissez Edition > Libellé > Sélectionner un groupe de libellés, puis choisissez Edition > Libellé > [nom de couleur].
  • Pour changer les noms et les couleurs par défaut des libellés, sélectionnez Edition > Préférences > Libellés (Windows) ou After Effects > Préférences > Libellés (Mac OS).
  • Pour modifier les associations par défaut entre la couleur de libellé et le type de source, sélectionnez Edition >Préférences > Libellés (Windows) ou After Effects > Préférences > Libellés (Mac OS).
  • Pour désactiver l’utilisation de la couleur de libellé d’un calque pour les poignées de calque et les trajectoires, sélectionnez Edition > Préférences > Aspect (Windows) ou After Effects > Préférences > Aspect (Mac OS) et désélectionnez l’option Utiliser couleurs libellés pour poignées du calque et chemins.
  • Pour désactiver l’utilisation de la couleur de libellé d’un calque, d’un élément de métrage ou d’une composition dans les onglets des panneaux correspondants, sélectionnez Edition > Préférences > Aspect (Windows) ou After Effects > Préférences > Aspect (Mac OS) et désélectionnez l’option Utiliser les couleurs des libellés pour les onglets connexes.

Remarque :

par défaut, les couleurs de libellé d’un panneau ne réagissent pas à l’option Luminosité dans les préférences Aspect. Pour que l’option Luminosité se répercute sur les couleurs de libellé d’un panneau, sélectionnez l’option Affecte les couleurs des libellés dans les préférences Aspect.

Affichage et masquage des calques dans le panneau Montage

Vous pouvez rendre un calque discret, puis utiliser le bouton Masquer calques discrets situé en haut du panneau Montage pour masquer tous les calques discrets répertoriés dans la liste de calques de ce panneau. L’utilisation de calques discrets permet de disposer de plus d’espace dans le panneau Montage, ce qui facilite l’affichage des calques et des propriétés de calques à modifier.

Dans la colonne Options, une icône indique si le calque est discret ou affiché .

Vous pouvez effectuer le rendu des calques discrets (lors des prévisualisations et du rendu final). Pour masquer des calques lors des prévisualisations ou du rendu final, utilisez l’option Vidéo ou transformez le calque en calque repère.

  • Pour passer de l’état discret à l’état affiché d’un calque, cliquez sur le bouton d’option Discret du calque, ou sélectionnez le calque dans le panneau Montage et choisissez Calque > Options > Cacher.
  • Pour basculer entre le masquage et l’affichage de tous les calques discrets, cliquez sur le bouton Masquer calques discrets situé en haut du panneau Montage pour sélectionner ou désélectionner cette option, ou choisissez la commande Masquer calques discrets dans le menu de ce panneau.

Vous pouvez également filtrer des calques dans le panneau Montage pour n’afficher que les calques dont les propriétés correspondent à la chaîne de recherche ou à d’autres caractéristiques Pour en savoir plus, reportez-vous aux sections Recherche et filtrage dans les panneaux Montage, Projet et Effets et paramètres prédéfinis et Affichage des propriétés et des groupes dans le panneau Montage (raccourcis clavier).

Sur son site Web After Effects Scripts, Lloyd Alvarez propose un script grâce auquel vous pouvez marquer des calques, puis les sélectionner, les rendre discrets et les isoler en fonction de leur marquage. Le marquage est ajouté aux commentaires dans le champ Commentaires du panneau Montage.

Qualité d’image d’un calque et positionnement des sous-pixels

La qualité d’un calque détermine la précision du rendu et a une incidence sur la précision d’autres calculs liés au calque (suivi de mouvement, par exemple) et l’utilisation du calque en tant que calque de paramètres pour un effet complexe.

Les calques dupliqués ou scindés conservent le paramètre de qualité du calque d’origine.

Vous avez le choix entre trois options de qualité : Optimale, Ébauche et Filaire. Lorsque vous sélectionnez l’option Optimale, vous avez le choix entre un échantillonnage bilinéaire ou bicubique, dont vous trouverez une description à la section suivante.

Pour basculer entre les qualités Optimale (échantillonnage bilinéaire), Ébauche et Optimale (échantillonnage bicubique) pour les calques sélectionnés, cliquez sur le bouton Qualité dans le panneau Montage. Pour faire votre choix parmi ces options, plus l’option Filaire, sélectionnez Calque > Qualité :

Optimale

Pour l’affichage et le rendu d’un calque, l’application utilise diverses options de positionnement des sous-pixels, de lissage, d’ombrage 3D et effectue un calcul complet des effets appliqués, le cas échéant. L’option Optimale ralentit le rendu au maximum, à la fois pour les prévisualisations et le résultat final.

Ebauche

Le calque s’affiche tel que vous le voyez, avec une qualité brouillon. Aucune option de lissage ni de positionnement des sous-pixels n’est utilisée lors de l’affichage et du rendu avec une qualité Ebauche, et le calcul de certains effets est approximatif.

Filaire

Le calque s’affiche sous la forme d’un cadre sans contenu. Les images filaires du calque sont affichées et rendues plus rapidement que les calques rendus avec le paramètre Optimale ou Ebauche.

Échantillonnage bilinéaire ou bicubique

Pour les calques dont la qualité est définie sur Optimale, vous avez le choix entre l’échantillonnage bicubique ou bilinéaire. Ce paramètre au niveau de chaque calque détermine la manière dont les pixels sont échantillonnés pour des transformations telles que la mise à l’échelle.

Les raccourcis clavier par défaut pour définir la méthode d’échantillonnage des calques sélectionnés sont Alt + B (Windows) ou Option + B (Mac OS) pour Optimale/Bilinéaire et Alt + Maj + B (Windows) et Option + Maj + B (Mac OS) pour Optimale/Bicubique.

L’échantillonnage bicubique est légèrement plus gourmand en ressources processeur que l’échantillonnage bilinéaire. De plus, il ne s’agit pas de l’option offrant la meilleure qualité dans tous les cas de figure. Dans certains cas, l’apparition d’artefacts est bien visible avec l’échantillonnage bicubique. Elle se manifeste sous la forme d’artefacts « annulaires » et de débordements au niveau d’une transition brutale entre deux couleurs. L’échantillonnage bicubique semble être la meilleure option lorsque la transition entre deux couleurs est plus graduelle, comme c’est le cas avec la quasi-totalité des images photographiques réelles, mais pas nécessairement pour les graphiques à contours nets. L’échantillonnage bicubique s’avère plus efficace dans le cas d’un agrandissement que d’une réduction.

Remarque :

Les textures du système de rendu 3D avec lancer de rayon n’utilisent pas l’échantillonnage bicubique ; elles utilisent toujours l’échantillonnage bilinéaire. Les transformations opérées dans les effets utilisent également toujours l’échantillonnage bilinéaire, à moins que l’effet applique spécifiquement une autre méthode (comme c’est le cas avec un effet de module externe de mise à l’échelle dédié ou un effet de distorsion).

Positionnement du sous-pixel

Les valeurs de propriétés d’After Effects (telles que Position et Point d’ancrage) ne doivent plus nécessairement être des nombres entiers. Cela permet une animation plus fluide, dans la mesure où une valeur est interpolée d’une image clé vers une autre. Par exemple, si une valeur Position s’étend de [0,0,0] au niveau d’une image clé à l’instant 0 à une valeur de [0,0,80] à 1 seconde dans une composition en 25 i/s, la valeur à l’image 1 est [0,0,3.2].

After Effects calcule toutes les valeurs spatiales, telles que Position et les points de contrôle de l’effet, avec une précision de 1/65536 de pixel. C’est ce que l’on désigne sous le nom de précision de sous-pixel.

Si les pixels d’un calque ne sont pas positionnés directement sur les limites de pixels de la composition, un léger flou apparaît ; très semblable au lissage. Ce flou ne constitue pas à proprement parler un problème pour les objets mobiles, en raison du flou de mouvement qui les caractérise, mais il risque d’atténuer certains détails sur une image statique. En outre, si une image se déplace lentement ou à une vitesse incorrecte, elle peut donner l’impression d’osciller entre netteté et flou.

Le point d’ancrage par défaut d’un calque est le centre d’un objet. Aussi, les objets de taille impaire ont-ils des points d’ancrage non entiers et présentent-ils un aspect lisse lorsqu’ils sont positionnés à des valeurs entières. Pour réduire l’effet de flou et atténuer l’oscillation entre une image nette et floue, tenez compte des recommandations suivantes :

  • Créez des images avec des dimensions paires ou impaires, sur la base des dimensions de la composition. Par exemple, dans le cas d’une composition de 640x480 pixels, créez des images ayant des dimensions paires (100x100 pixels, par exemple) ; avec une composition de 99x99 pixels, optez pour des dimensions impaires (75x53 pixels, par exemple).

  • Définissez les informations de position des images (y compris les images clés de maintien et de position finale) sur des nombres entiers.

Pixellisation en continu d’un calque contenant des images vectorielles

Lorsque vous importez des images vectorielles, After Effects les pixellise automatiquement. Toutefois, si vous souhaitez redimensionner un calque contenant des images vectorielles à une échelle supérieure à 100 %, vous devez alors pixelliser le calque en continu pour conserver la qualité de l’image. Vous pouvez pixelliser en continu les images vectorielles dans des calques provenant des fichiers Illustrator, SWF, EPS et PDF. La pixellisation en continu permet à After Effects de pixelliser le fichier selon les besoins en fonction de la transformation de chaque image. Un calque pixellisé en continu donne généralement un résultat de haute qualité, mais son rendu risque d’être plus lent.

Les calques de forme et de texte sont toujours pixellisés en continu.

Lorsque vous appliquez un effet à un calque pixellisé en continu, vous n’obtenez pas nécessairement les mêmes résultats que lorsque le calque n’est pas pixellisé en continu. Cette différence de résultats est due à l’ordre par défaut dans lequel le rendu des modifications des calques s’effectue. L’ordre de rendu par défaut d’un calque non pixellisé en continu indique d’abord les masques, puis les effets et enfin les transformations. En revanche, celui d’un calque pixellisé en continu présente les masques, suivis des transformations, puis des effets.

Si vous affichez et effectuez le rendu d’une composition en qualité Optimale, After Effects lisse les images vectorielles, que vous activiez ou non la fonction de pixellisation en continu.

Vous ne pouvez pas ouvrir de calque pixellisé en continu, ni interagir avec ce calque, dans un panneau Calque. Cette limitation a notamment pour conséquence que vous ne pouvez pas peindre directement sur un calque pixellisé en continu. Vous pouvez toutefois copier et coller les contours de peinture des autres calques.

Image d’un fichier Illustrator importé avec un calque pixellisé
Image d’un fichier Illustrator importé

A. Original B. Agrandissement avec l’option de pixellisation en continu désactivée C. Agrandissement avec l’option de pixellisation en continu activée 
  1. Dans le panneau Montage, cliquez sur l’option Pixellisation du calque , qui correspond à l’option « Condenser transform. » des calques de précomposition.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne