Lees dit artikel voor informatie over hoe u Git gebruikt om uw bestanden en broncode in Dreamweaver CC te beheren.

Dreamweaver CC ondersteunt Git, een gedistribueerd open-source versiebeheersysteem om broncode te beheren. Door de integratie van Git in Dreamweaver kunt u overal onafhankelijk aan uw code werken en uw wijzigingen later samenvoegen in een centrale Git-opslagplaats. Git houdt alle wijzigingen in een bestand bij en u kunt ook altijd terugkeren naar een vorige versie.

Git-opslagplaatsen zijn ook erg handig wanneer u als team werkt, omdat u met Git de mogelijkheid hebt om eenvoudig vertakkingen te maken en te onderhouden. Als u bijvoorbeeld een ontwerper bent en wilt werken aan een wijziging in het ontwerp van uw site, terwijl een ander teamlid wijzigingsaanvragen voor dezelfde site verwerkt, kunt u beiden onafhankelijk werken met behulp van Git. In dit geval kunt u beide onafhankelijk van elkaar een vertakking maken en uw wijzigingen aanbrengen in uw eigen lokale opslagplaats. De lokale opslagplaats bevat de volledige geschiedenis van alle wijzigingen die u in de bron aanbrengt. U kunt op elk gewenst moment pauzeren en uw wijzigingen samenvoegen met de centrale opslagplaats. Samenvoegen zorgt ervoor dat de centrale opslagplaats altijd de nieuwste code met wijzigingen van beide gebruikers bevat.

Lees verder voor meer informatie over hoe u Git kunt gaan gebruiken in Dreamweaver.

Aan de slag met Git in Dreamweaver

Als u een nieuwe Git-gebruiker bent, moet u eerst een Git-client downloaden en een Git-account maken. Een Git-client is essentieel voordat u Git vanuit Dreamweaver gebruikt.

Als u al een Git-account hebt, meldt u zich aan bij uw account. Zorg ervoor dat u de Git-client op uw systeem hebt gedownload. 

Voer de volgende stappen uit om aan de slag te gaan met Git in Dreamweaver:

  1. Download de Git-client voor uw besturingssysteem.

  2. Maak een account voor uw Git-client.

    Als u al een Git-account hebt, geeft u uw aanmeldingsgegevens op om u aan te melden bij uw Git-client.

Het wordt aanbevolen de Git-client te installeren met de standaardconfiguratie-instellingen. Dreamweaver kiest vervolgens automatisch het pad naar het uitvoerbare bestand.

U kunt Dreamweaver nu starten en uw site koppelen aan een Git-opslagplaats.

Het deelvenster Git

Dreamweaver ondersteunt Git-bewerkingen via het deelvenster Git (Venster > Git). Als Dreamweaver-gebruiker kunt u dit deelvenster gebruiken om veelvoorkomende Git-bewerkingen uit te voeren, zoals doorvoeren (commit), push, pull, ophalen (fetch) enzovoort.

Opmerking:

U kunt dit deelvenster alleen in Dreamweaver weergeven nadat u de Git-client naar uw computer hebt gedownload.

Het deelvenster Git in Dreamweaver CC
Deelvenster Git in Dreamweaver

A. Doorvoeren B. Alle externe sites ophalen en tellers vernieuwen C. Git-pull D. Git-push E. Geschiedenis van opslagplaats weergeven F. Bestandsgeschiedenis weergeven G. Tag maken H. Bash/terminalconsole openen I. Meer handelingen J. Zoeken K. Diff L. Bestand terugdraaien 

Uw site koppelen aan Git

Als u Git wilt gaan gebruiken in Dreamweaver, moet u eerst uw Dreamweaver-site koppelen aan een Git-opslagplaats. Een Git-opslagplaats is vergelijkbaar met een map die u maakt om u te helpen wijzigingen in bestanden bij te houden. U kunt elk gewenst aantal Git-opslagplaatsen op uw computer hebben staan. Elke opslagplaats op uw systeem is onafhankelijk van de rest. Dat betekent dat wijzigingen die zijn opgeslagen in de ene Git-opslagplaats, niet van invloed zijn op de inhoud van een andere opslagplaats.

U kunt uw website koppelen aan een opslagplaats door een nieuwe opslagplaats te maken of door een bestaande opslagplaats te klonen. Wanneer u een nieuwe opslagplaats initialiseert of maakt, wordt er een lege Git-opslagplaats gemaakt in de huidige werkmap, met in die map een .gitignore-bestand.

Wanneer u echter een bestaande Git-opslagplaats kloont, worden alle bestanden in de bovenliggende opslagplaats gekloond naar uw lokale systeem.

Lees verder als u wilt weten hoe u een Git-opslagplaats initialiseert of een opslagplaats kloont.

Een Git-opslagplaats initialiseren

Wanneer u begint te werken met Git in Dreamweaver, kunt u het beste eerst een nieuwe opslagplaats maken. Wanneer u een Git-opslagplaats voor uw site initialiseert, maakt u een nieuwe Git-opslagplaats waaraan u de bestanden kunt toevoegen die zijn gekoppeld aan uw Dreamweaver-site.

  1. Als Dreamweaver-gebruiker kunt u aan de slag gaan met een nieuwe site of werken aan een bestaande site die u wilt koppelen aan een Git-opslagplaats. Volg in beide gevallen deze procedure om een Git-opslagplaats te initialiseren.

    • Klik op Site > Nieuwe site als u een nieuwe Dreamweaver-site wilt koppelen.
    • Klik op Site > Sites beheren als u een bestaande Dreamweaver-site wilt koppelen. Dubbelklik in het dialoogvenster Sites beheren op de site die u aan een Git-opslagplaats wilt koppelen.
  2. Als u een nieuwe site maakt, geeft u een naam op voor de site.

    Als u een map hebt met bestanden voor uw site, verwijst u het veld Map voor lokale site naar die map.

    Geef de naam en de maplocatie voor de nieuwe Dreamweaver-site op.
    Geef de naam en de maplocatie voor de nieuwe Dreamweaver-site op.

    Als u een nieuwe site aan een bestaande Git-opslagplaats wilt koppelen, moet u ervoor zorgen dat de lokale sitemap naar de juiste Git-opslagplaats verwijst.

  3. Schakel het selectievakje Een Git-opslagruimte koppelen aan deze site in. Selecteer vervolgens de optie Initialiseren als een Git-opslagplaats.

    Een Git-opslagplaats initialiseren in Dreamweaver
    Een Git-opslagplaats initialiseren voor uw nieuwe Dreamweaver-site
  4. Klik op Opslaan.

    Zoals u ziet, zijn de bestanden van uw lokale map nu zichtbaar in het deelvenster Bestanden (Git-weergave). De bestanden hebben de status Niet-gevolgd. Dat betekent dat deze bestanden nog niet zijn doorgevoerd in uw Git-opslagplaats.

    U kunt blijven werken aan uw bestanden en de bestanden later doorvoeren of het deelvenster Git openen (Vensters > Git) en de bestanden doorvoeren in de opslagplaats. Raadpleeg Wijzigingen bijhouden en doorvoeren als u wilt weten hoe u bestanden doorvoert in Git.

Een bestaande opslagplaats klonen

Als u al werkt met een bestaande Git-opslagplaats die wordt gehost op Github, Bitbucket of een andere populaire hostingservice, kunt u de volgende procedure uitvoeren om de opslagplaats te klonen vanuit Dreamweaver. Wanneer u een bestaande opslagplaats kloont, maakt u een kopie van de doelopslagplaats op uw lokale systeem.

  1. Klik op Site > Nieuwe site.

  2. Schakel in het dialoogvenster Site-instelling het selectievakje Een Git-opslagruimte koppelen aan deze site in. Selecteer vervolgens Bestaande Git-opslagplaats klonen met behulp van URL.

  3. Voer de URL in van de opslagplaats die u wilt klonen.

    Zorg ervoor dat de https-URL van de doelopslagplaats die u invoert, geldig is. Als u wilt testen of de URL geldig is, klikt u op de knop Testen in dit dialoogvenster. Een ongeldige URL leidt tot fouten tijdens het klonen en bij het uitvoeren van handelingen zoals een Git-ophaalbewerking of Git-pull.

    Een Git-opslagplaats klonen vanuit Dreamweaver
    Een Git-opslagplaats klonen vanuit Dreamweaver

    Opmerking:

    Het klonen van een URL die een SSH-sleutel met wachtwoordzin gebruikt, wordt momenteel niet ondersteund in Dreamweaver. De velden voor de gebruikersnaam en het wachtwoord zijn uitgeschakeld.

  4. Als u de ingevoerde aanmeldingsgegevens wilt opslaan, schakelt u het selectievakje Referenties opslaan in. U hoeft uw aanmeldingsgegevens dan niet telkens opnieuw in te voeren wanneer u externe bewerkingen uitvoert, zoals Git-push of -pull.

  5. Klik op Opslaan.

    Nadat u een opslagplaats hebt gekloond, wordt een lokale kopie van de oorspronkelijke opslagplaats gemaakt. U kunt de lokale bestanden bekijken en bewerken vanuit Dreamweaver.

    De momentopname van de originele opslagplaats die wordt gekloond, wordt weergegeven via Origin in de rechterbovenhoek van het deelvenster Git.

    Let op de opslagplaats 'origin' in het deelvenster Git
    Let op de opslagplaats 'origin' in het deelvenster Git

Git gebruiken voor versiebeheer

Nu u uw Dreamweaver-site hebt gekoppeld aan een Git-opslagplaats, kunt u de bestanden in Git weergeven in het deelvenster Bestanden (Git-weergave). Git categoriseert de bestanden in uw lokale opslagplaats als:

  • Niet-gevolgde bestanden: bestanden die u niet hebt doorgevoerd in de Git-opslagplaats. Nadat u een Git-opslagplaats hebt geïnitialiseerd, worden de bestanden pas gevolgd nadat u ze hebt doorgevoerd.
  • Ongewijzigde bestanden: bestanden die niet zijn gewijzigd.
  • Gewijzigde bestanden: bestanden die zijn bewerkt.
  • Voorbereide bestanden: bestanden die zijn gewijzigd en die klaar staan om te worden doorgevoerd.

Met Git kunt u wijzigingen in bestanden bijhouden. Wanneer u de bestanden in uw lokale systeem wijzigt, worden de gewijzigde bestanden in een andere kleur weergegeven in het deelvenster Bestanden. Wanneer u dubbelklikt op het bestand en het bestand opent in de codeweergave, ziet u een markering in de marge voor de regels die zijn gewijzigd. U kunt doorgaan en de gewijzigde bestanden in Git doorvoeren om de wijzigingen te synchroniseren.

Wanneer u bestanden doorvoert, biedt Git u de mogelijkheid logberichten in te voeren voor elke doorvoerbewerking en de wijzigingen te controleren met behulp van de diff-functie. U kunt ook de versiegeschiedenis voor elk bestand en voor de hele opslagplaats bekijken.

Lees verder voor meer informatie over het bijhouden van bewerkingen in Dreamweaver en het doorvoeren van uw wijzigingen in Git.

Bewerkingen bijhouden in Git

In het deelvenster Bestanden in Dreamweaver ziet u het Git-pictogram waarmee u kunt schakelen tussen de FTP-weergave en de Git-weergave. Klik op het Git-pictogram om de Git-weergave in of uit te schakelen.

Als u een Git-opslagplaats hebt geïnitialiseerd en uw bestanden niet hebt doorgevoerd, blijven de bestanden niet-gevolgd. Als u uw bestanden echter hebt doorgevoerd nadat u de opslagplaats hebt geïnitialiseerd, worden de bestanden door Git herkend.

Niet-gevolgde bestanden weergeven in het deelvenster Bestanden
Niet-gevolgde bestanden weergeven in het deelvenster Bestanden
Bestanden nadat ze zijn doorgevoerd in de Git-opslagplaats
Doorgevoerde bestanden die door Git zijn herkend weergeven

Als u al uw bestanden uit een andere opslagplaats hebt gekloond, worden de bestanden opnieuw door Git herkend.

Wanneer u een bestand wijzigt en op Opslaan klikt, wordt het gewijzigde bestand in een andere kleur weergegeven in het deelvenster Bestanden. Dubbelklik op het gewijzigde bestand om de exacte wijzigingen weer te geven in de codeweergave.

Let op de markering in de marge in de codeweergave
Let op de markering in de marge in de codeweergave

Een markering in de marge geeft de regels aan waarin wijzigingen zijn aangebracht. Een groene markering geeft aan dat nieuwe code is toegevoegd. Een gele markering geeft gewijzigde code aan, terwijl een rode markering aangeeft dat een coderegel is verwijderd.

De markeringen in de marge weergeven om wijzigingen in de code in Dreamweaver te zien
De markeringen in de marge weergeven om wijzigingen in de code te zien

Wanneer u klikt op de gele markering in de marge, wordt de verwijderde coderegel rood weergegeven en wordt onlangs toegevoegde code groen weergegeven.

Let op het R-symbool in de linkerhoek van de verwijderde coderegels. Klik op dit R-symbool als u de verwijderde code weer aan het bestand wilt toevoegen.

Klik op het R-symbool om de verwijderde code toe te voegen in Dreamweaver Git
Klik op het R-symbool om de verwijderde code toe te voegen

Gebruik de markeringen in de marge om de verschillen te bekijken en uw wijzigingen te controleren voordat u de wijzigingen doorvoert in de Git-opslagplaats.

Verschillen voor gewijzigde bestanden weergeven

Wanneer u het deelvenster Git opent, ziet u een lijst met gewijzigde bestanden. U kunt klikken op een bestand in deze lijst en de wijzigingen bekijken die in het bestand zijn aangebracht na de vorige doorvoerbewerking (diff). Als u de verschillen voor een bestand wilt weergeven, voert u een van de volgende handelingen uit in het deelvenster Git:

  • Klik op elk bestand om de bewerkingen te bekijken. De rood gemarkeerde items geven de vorige versie aan, terwijl de groen gemarkeerde items de wijziging aangeven die u zojuist hebt aangebracht.
  • Selecteer het bestand waarvoor u de verschillen wilt weergeven. Klik op (Diff-pictogram). Het dialoogvenster Git-diff wordt weergegeven, waarbij de wijzigingen rood en groen zijn gemarkeerd.
Verschillen voor gewijzigde bestanden weergeven
Verschillen voor gewijzigde bestanden weergeven

Wijzigingen doorvoeren

Als u alle wijzigingen in uw lokale opslagplaats wilt vastleggen, moet u de wijzigingen in uw bestanden doorvoeren. U kunt als volgt uw wijzigingen doorvoeren in Git:
  1. Selecteer in het deelvenster Git het bestand of de bestanden die u wilt doorvoeren.

    Wijzigingen in de lokale Git-opslagplaats doorvoeren
    Wijzigingen in de lokale Git-opslagplaats doorvoeren
  2. Klik op  (pictogram Doorvoeren).

    Wanneer u op Doorvoeren klikt, wordt het dialoogvenster Git-commit weergegeven. In dit dialoogvenster worden bestanden met wijzigingen weergegeven.

    U kunt op elk bestand klikken om de wijzigingen te bekijken voordat u de bestanden doorvoert.

  3. Als u de bestanden wilt doorvoeren, voert u een doorvoerbericht in het berichtvak in en klikt u op OK.

    Nadat de bestanden zijn doorgevoerd, worden ze ook uit het deelvenster Git verwijderd.

    Uw wijzigingen doorvoeren in Git
    Uw wijzigingen doorvoeren in Git

Wijzigingen terugdraaien

Als u uw wijzigingen al hebt doorgevoerd en wilt terugkeren naar de vorige versie van een bestand, gaat u als volgt te werk:

  1. Selecteer in het deelvenster Git het bestand of de bestanden die u wilt terugdraaien.

  2. Klik op het sandwichpictogram in het deelvenster Git en selecteer Wijzigingen sinds laatste doorvoerbewerking terugdraaien.

    De vorige versie van de bestanden wordt hersteld in de lokale opslagplaats. U kunt de herstelde bestanden nu bekijken via het deelvenster Bestanden.

    Wijzigingen terugdraaien nadat u bestanden hebt doorgevoerd
    Wijzigingen terugdraaien nadat u bestanden hebt doorgevoerd

    Opmerking:

    Als u een bestand wilt terugdraaien nadat dit is doorgevoerd, moet u het bestand ten minste tweemaal hebben doorgevoerd.

  3. Als u wijzigingen wilt terugdraaien voordat u ze doorvoert, voert u de volgende stappen uit:

    Als u de laatst doorgevoerde versie van het bestand wilt behouden voordat u het bestand doorvoert:

    1. Open het deelvenster Git.
    2. Selecteer het bestand dat u wilt behouden en klik op het pictogram Vernieuwen.
    3. Klik op OK in het bevestigingsvenster.

    Het bestand dat u hebt geselecteerd, wordt gewist uit de lijst met gewijzigde bestanden en de vorige versie van het bestand wordt hersteld.

    Bestand terugdraaien voordat u de wijzigingen doorvoert in Git
    Bestand terugdraaien voordat u de wijzigingen doorvoert

Tags maken

U kunt tags maken wanneer u uw wijzigingen in Git doorvoert. U kunt tags gebruiken om belangrijke doorgevoerde wijzigingen te markeren, bijvoorbeeld wanneer u bestanden incheckt voor een belangrijke wijziging die is aangevraagd door uw klant. De tags fungeren als verwijzing naar een specifieke doorvoerbewerking.

  1. Als u een tag wilt maken, klikt u op (pictogram Tag maken) in het deelvenster Git.

  2. Geef in het dialoogvenster Tag maken een naam op voor de tag. Klik op OK.

    Een tag maken voor uw doorvoerbewerking
    Een tag maken voor uw doorvoerbewerking

    De tag die u maakt, wordt gekoppeld aan de doorvoerbewerking.

    Als u een tag maakt nadat u een doorvoerbewerking hebt uitgevoerd, wordt de tag automatisch gekoppeld aan de laatste doorvoerbewerking.

Bestandsgeschiedenis bekijken

Telkens wanneer u een bestand doorvoert in Git, kunt u de geschiedenis van het bestand bekijken, samen met de details van de doorvoerbewerking. Met deze functionaliteit kunt u belangrijke doorvoerbewerkingen opsporen en tags die zijn gekoppeld aan doorvoerbewerkingen.

  1. Voer een van de volgende handelingen uit in het deelvenster Git:
  • Selecteer het gewenste bestand en klik op  (pictogram Bestandsgeschiedenis weergeven).
  • Klik met de rechtermuisknop op het bestand in het deelvenster Bestanden en selecteer Bestandsgeschiedenis.

De Git-bestandsgeschiedenis van het geselecteerde bestand wordt weergegeven. U kunt de details van de doorvoerbewerking voor dit bestand ook bekijken in hetzelfde dialoogvenster.

De bestandsgeschiedenis weergeven in Git
De bestandsgeschiedenis weergeven in Git

Geschiedenis van opslagplaats weergeven

U kunt niet alleen de geschiedenis van een bestand in Git weergeven, maar ook de wijzigingen bekijken die zijn aangebracht op het niveau van de opslagplaats. U kunt alle wijzigingen en doorvoerbewerkingen bekijken die zijn uitgevoerd op het niveau van de opslagplaats. Als u de geschiedenis van de opslagplaats wilt weergeven, voert u de volgende stappen uit:

  1. Klik in het deelvenster Git op het pictogram Geschiedenis van opslagplaats weergeven. De geschiedenis van de Git-opslagplaats wordt weergegeven met de details over alle doorvoerbewerkingen.

  2. U kunt het doorvoerbericht bekijken, de datum en tijd waarop de bestanden zijn doorgevoerd, tags die zijn gekoppeld aan een doorvoerbewerking en details over de gebruiker die de bestanden heeft doorgevoerd.

  3. De geschiedenis van de opslagplaats geeft gewoonlijk een lijst weer met bestanden die zijn doorgevoerd op het niveau van de opslagplaats. U kunt op elk bestand klikken om de geschiedenis van wijzigingen op bestandsniveau te bekijken.

Git gebruiken voor samenwerking

Een van de opvallendste functies van Git betreft vertakkingen. In tegenstelling tot bij de meeste systemen voor versiebeheer kan een Git-vertakking worden gezien als een afzonderlijke tak met al uw gekoppelde bestanden of code. Standaard heeft uw opslagplaats één tak met de naam 'master'. De master-vertakking is de hoofdtak of definitieve tak. U kunt vertakkingen maken vanaf de hoofdtak en wijzigingen in elke vertakking aanbrengen.

U kunt ook een vertakking maken vanaf een andere vertakking, waarbij u een kopie van de bovenliggende tak maakt. U kunt onafhankelijk werken aan beide vertakkingen in dezelfde Git-opslagplaats. U kunt bijvoorbeeld werken aan een nieuwe functie voor uw site in de ene vertakking, terwijl u een aantal wijzigingsaanvragen verwerkt in een andere vertakking.

Git biedt ook de mogelijkheid vertakkingen samen te voegen als u de wijzigingen van de huidige vertakking wilt opnemen in een doelvertakking. Wanneer u twee vertakkingen samenvoegt, blijven beide vertakkingen onafhankelijk van elkaar bestaan. U kunt blijven werken met de bovenliggende vertakking en de doelvertakking.

Wanneer ontwikkelaars en ontwerpers in Dreamweaver samen aan een site werken, kan iedere gebruiker een vertakking maken vanaf de hoofdtak en afzonderlijk wijzigingen aanbrengen. Desgewenst kunnen ze hun wijzigingen eenvoudig samenvoegen met een andere vertakking en doorwerken aan beide vertakkingen.

Als u meer wilt weten over het maken en beheren van vertakkingen in Git, leest u de volgende secties:

Vertakkingen maken in Git

  1. Selecteer in het deelvenster Bestanden de vervolgkeuzelijst met alle vertakkingen.

  2. Klik op Vertakkingen beheren.

    Een vertakking maken in Git
    Een vertakking maken in Git
  3. Klik op het plusteken (+), linksonder in het dialoogvenster Vertakkingen beheren.

    Klik op het plusteken onder in het dialoogvenster Vertakkingen beheren
    Klik op het plusteken onder in het dialoogvenster Vertakkingen beheren
  4. Selecteer in het dialoogvenster Nieuwe vertakking maken de oorspronkelijke vertakking waarvan u een kopie wilt maken.

    Als dit de eerste vertakking is die u maakt, is de oorspronkelijke vertakking de hoofdtak (master).

    Selecteer de oorspronkelijke vertakking
    Selecteer de oorspronkelijke vertakking

  5. Geef in het veld Naam vertakking een naam op voor de nieuwe vertakking.

  6. Klik op OK.

Vertakkingen samenvoegen

  1. Selecteer in het deelvenster Bestanden de vervolgkeuzelijst met al uw vertakkingen.

  2. Klik op Vertakkingen beheren. Selecteer in het dialoogvenster Vertakkingen beheren de vertakking die u wilt samenvoegen.

  3. Klik op (pictogram Vertakking samenvoegen) onderaan in het dialoogvenster.

  4. Selecteer de doelvertakking in het dialoogvenster Vertakking samenvoegen. Deze vertakking is de doelopslagplaats waarmee u de vertakking wilt samenvoegen.

    Voer desgewenst een bericht in voor deze samenvoegbewerking.

  5. Klik op OK om uw vertakking samen te voegen met de doelvertakking.

    Vertakkingen samenvoegen in Git
    Vertakkingen samenvoegen in Git

    Als bestandswijzigingen van de ene doorvoerbewerking een conflict veroorzaken met wijzigingen van een andere vertakking, wordt het samenvoegproces onderbroken. Het systeem toont een conflictbericht, samen met de bestanden die het conflict veroorzaken.

    In het deelvenster Git worden ook de bestanden weergegeven die een conflict hebben. Let op het pictogram dat aangeeft dat er sprake is van een conflict.

    Git-deelvenster met bestanden waarin een conflict is opgetreden tijdens het samenvoegen
    Git-deelvenster met bestanden waarin een conflict is opgetreden tijdens het samenvoegen

    Als u de samenvoeging wilt vervolgen, moet u het conflict oplossen met behulp van de optie Rebase of met de optie voor geen fast-forward.

  6. Als u een samenvoegconflict aantreft, kiest u een van de volgende opties:

    • Rebase gebruiken: Als u de rebase-optie selecteert, worden bij conflicten in de doelvertakking uw huidige wijzigingen toegepast. Nadat u rebase hebt gekozen en op OK hebt geklikt, opent u het deelvenster Git om de bestanden weer te geven die nog moeten worden doorgevoerd. Vervolgens kunt u de rebasebewerking afbreken of opnieuw starten. Als u de rebasebewerking afbreekt, wordt deze gestopt en worden geen wijzigingen toegepast in de doelvertakking. Wanneer u de rebasebewerking opnieuw start, worden bij conflicten in de doelvertakking uw wijzigingen overgeslagen.
    • Een samengevoegde doorvoerbewerking creëren, zelfs als de samenvoeging wordt omgezet als een fast-forward: U kunt uw doorvoerbewerking ook samenvoegen ondanks conflicten tussen uw vertakking en de doelvertakking. In dit geval wordt de samenvoegbewerking afgedwongen, waarbij uw wijzigingen de wijzigingen in de doelvertakking overschrijven.

    Voor meer informatie over rebase in Git raadpleegt u Rebasing in Git.

Werken met externe opslagplaatsen

Externe opslagplaatsen in Git zijn versies van een project die worden gehost in een ander netwerk. U kunt toegang krijgen tot externe opslagplaatsen door een verbinding te maken met de opslagplaats. Afhankelijk van de toegangsrechten die zijn opgegeven in de externe opslagplaats, kunt u alleen-lezen toegang of schrijftoegang hebben tot die opslagplaats.

Wanneer u in een team werkt, helpen externe opslagplaatsen u gegevens te sturen naar (push) en op te halen uit (pull) andere opslagplaatsen. Via het deelvenster Git in Dreamweaver kunt u een externe verbinding maken, verschillende Git-bewerkingen uitvoeren, zoals Ophalen, Git-push, Git-pull en Extern vernieuwen.

Lees de volgende stappen voor informatie over hoe u externe opslagplaatsen maakt en beheert.

Een externe opslagplaats toevoegen

U kunt een externe opslagplaats toevoegen om bestanden en uw voortgang te delen en om toegang te krijgen tot uw projectbestanden die worden gehost in een ander netwerk. Door een externe opslagplaats toe te voegen, creëert u een externe verbinding met de doelopslagplaats. In Dreamweaver kunt u externe opslagplaatsen maken via het deelvenster Git.

Voordat u een externe opslagplaats toevoegt, moet u ervoor zorgen dat voor de andere opslagplaats openbare instellingen zijn ingeschakeld.

  1. Klik in het deelvenster Git op Externe site maken.

  2. Geef een naam op voor de externe opslagplaats.

  3. Voer de URL en de aanmeldingsgegevens voor de externe opslagplaats in.

    Als u wilt controleren of u een geldige URL hebt ingevoerd toen u een externe opslaglocatie toevoegde, klikt u op Testen nadat u de URL hebt ingevoerd. Wanneer u op Testen klikt, wordt getest of de URL geldig is.

    Deze test kan niet worden gebruikt om de aanmeldingsgegevens te valideren.

    Een externe opslagplaats toevoegen in Dreamweaver
    Een externe opslagplaats toevoegen

    Let op:

    Als u geen geldige URL of aanmeldingsgegevens invoert, krijgt u fouten wanneer u Git-pull, Git-push, Ophalen en dergelijke uitvoert.

  4. Klik op OK.

    Wanneer u een externe opslagplaats toevoegt, ziet u de opslagplaats in de vervolgkeuzelijst boven in het deelvenster Git. U kunt ook meer pictogrammen weergeven voor Git-push en Git-pull, externe opslagplaats ophalen en tellers vernieuwen.

    Externe opslagplaatsen toevoegen in Git
    Externe opslagplaatsen toevoegen in Git

Externe opslagplaatsen beheren

Nadat u een externe opslagplaats hebt toegevoegd en een verbinding tot stand hebt gebracht, kunt u de bestanden van de externe opslagplaats ophalen en naar uw lokale opslagplaats pushen. U kunt uw bestanden ook verzenden naar de externe opslagplaats. U moet echter eerst bestanden ophalen uit de externe opslagplaats voordat u voor het eerst een Git-pushbewerking kunt uitvoeren.

Denk eraan dat u alle bestanden in de lokale opslagplaats moet doorvoeren voordat u probeert uw bestanden te pushen. Als de lokale opslagplaats voorbereide bestanden bevat, mislukt Git-push. 

U kunt de volgende Git-bewerkingen uitvoeren vanuit Dreamweaver:

Alles ophalen

Klik op  om alle bestanden van al uw externe verbindingen op te halen (fetch). Het wordt aanbevolen een Git-ophaalbewerking uit te voeren voordat u Git-push of Git-pull uitvoert. Bij deze handeling worden alleen de bestanden van de externe opslagplaats opgehaald en wordt de lokale opslagplaats niet gewijzigd.

Bestanden van een externe opslagplaats ophalen (pull)

U kunt wijzigingen ophalen (pull) vanaf één opslagplaats of vanaf een groep opslagplaatsen. Wanneer u klikt op het pictogram Git: pull, wordt het dialoogvenster Git: pull weergegeven met diverse opties.

  1. Klik in het deelvenster Git op (pictogram Git: pull) om de gewijzigde bestanden van de externe opslagplaats op te halen en de wijzigingen samen te voegen met uw lokale opslagplaats.

  2. Selecteer in het dialoogvenster Git: pull de gevolgde vertakking, geef aan of u wijzigingen wilt ophalen van de huidige vertakking of van een andere vertakking en configureer de gewenste instellingen.

    Een Git-pull uitvoeren vanuit externe opslagplaatsen
    Een Git-pull uitvoeren vanuit externe opslagplaatsen

  3. Standaard is Standaardsamenvoeging geselecteerd. In dit geval worden de bestanden van de externe opslagplaats opgehaald naar de lokale opslagplaats en worden de wijzigingen lokaal samengevoegd.

  4. U kunt ook een van de volgende opties kiezen:

    • Handmatig samenvoegen vermijden: Selecteer deze optie als u het handmatig samenvoegen van bestanden wilt uitschakelen.
    • Samenvoegen zonder doorvoeren: Selecteer deze optie als u de samenvoeging met de externe opslagplaats wilt vervolgen zonder voorbereide bestanden door te voeren.
    • Rebase gebruiken: Selecteer deze optie als u een rebase wilt uitvoeren. Als u rebase gebruikt, worden de wijzigingen in uw huidige vertakking opnieuw toegepast op de geschiedenis van de vertakking waarvan u bestanden ophaalt. De laatste doorgevoerde geschiedenis van uw vertakking wordt herschreven, zodat de bestanden overeenkomen met de versies in de doelvertakking waaruit u de bestanden ophaalt. Hoewel een rebasebewerking een opgeschoonde Git-geschiedenis voor uw vertakking produceert, moet u voorzichtig zijn wanneer u kiest voor de optie Rebase gebruiken.
    • Zachte reset gebruiken: Selecteer deze optie als u een reset of zachte rebase wilt uitvoeren. U kunt de optie Zachte reset gebruiken kiezen als u de bestanden voor het eerst uit een externe opslagplaats ophaalt (pull). In dit geval fungeert de externe opslagplaats als een bovenliggende opslagplaats waarvan de lokale opslagplaats alle wijzigingen ontvangt. De wijzigingen in de lokale opslagplaats blijven echter behouden. Bestanden die niet aanwezig zijn in de externe opslagplaats, maar wel in de lokale opslagplaats, worden niet herkend door Git. Deze bestanden worden weergegeven als verwijderde bestanden nadat u een zachte reset hebt uitgevoerd. Als u ervoor kiest om deze bestanden in uw lokale opslagplaats te behouden, gaan de externe wijzigingen verloren.

    Let op:

    Als u doorgaat met de zachte reset, worden de niet-herkende bestanden verwijderd.

Bestanden naar de externe opslagplaats pushen

Nadat u verbinding hebt gemaakt met externe opslagplaatsen en de gewijzigde bestanden wijzigt en doorvoert, legt Git deze wijzigingen vast. Het pictogram Git: push in het deelvenster Git geeft direct het aantal bestanden aan dat is gewijzigd. Deze bestanden kunnen nu naar de externe opslagplaats worden gepusht.

Wanneer u een Git-push uitvoert, worden de doorvoerbewerkingen die u hebt uitgevoerd in de lokale opslagplaats, gepusht naar de externe opslagplaats.

Uw bestanden vanuit Dreamweaver pushen:

  1. Klik in het deelvenster Git op het pictogram Git: push.

    Het dialoogvenster Git: push wordt weergegeven. U kunt uw doorvoerbewerkingen pushen naar de huidige gevolgde vertakking of naar een andere vertakking die u opgeeft.

    De lokale doorvoerbewerkingen pushen naar een externe Git-opslagplaats
    De lokale doorvoerbewerkingen pushen naar een externe Git-opslagplaats

  2. In dit dialoogvenster kunt u ook de pushinstellingen opgeven. Standaard is de optie Standaardpush geselecteerd.

  3. U kunt ook de volgende opties selecteren:

    • Gedwongen push: Selecteer deze optie als u uw wijzigingen wilt pushen naar de externe opslagplaats, ondanks mogelijke conflicten.
    • Externe vertakking verwijderen: Selecteer deze optie als u de bestaande externe vertakking wilt verwijderen en uw lokale bestanden wilt pushen naar de externe opslagplaats.
  4. Schakel desgewenst het selectievakje Tags verzenden in als u uw tags wilt pushen naar de externe opslagplaats.

  5. Klik op OK.

    Als er conflicten zijn tussen uw lokale doorvoerbewerkingen en de doorvoerbewerkingen die zijn aangebracht in de externe opslagruimte, wordt het aanbevolen om eerst alle conflicten op te lossen voordat u uw wijzigingen pusht. 

    In dit geval moet u de wijzigingen eerst ophalen (pull) uit de externe opslagplaats, vervolgens de conflicten oplossen en daarna de bestanden zonder conflicten pushen.

Bestanden zoeken in het deelvenster Git

Met de zoekbalk in het deelvenster Git kunt u bestanden zoeken op bestandsnaam. Dit is met name handig wanneer u een groot aantal bestanden aan uw site hebt gekoppeld.

Als u een bestand zoekt, typt u eenvoudig de bestandsnaam in de zoekbalk. De bestanden die uw zoektermen bevatten, worden direct weergegeven.

Bestanden toevoegen die Git moet negeren

Als u wilt dat Git een bestand niet verwerkt, kunt u het bestand toevoegen aan .gitignore. Git negeert de bestanden in deze map wanneer u een handeling uitvoert, inclusief doorvoeren, push en pull. U moet het .gitignore-bestand doorvoeren in de opslagplaats, zodat een gebruiker die de opslagplaats kloont, ook op de hoogte is van de bestanden in de map .gitignore.

Als u bestanden wilt toevoegen aan .gitignore, gaat u naar het deelvenster Bestanden in Dreamweaver. Selecteer het bestand dat Git moet negeren, klik erop met de rechtermuisknop en selecteer Git > Toevoegen aan .gitignore.

Bestanden toevoegen aan .gitignore
Bestanden toevoegen aan .gitignore

Als u op enig moment een bestand wilt verwijderen uit .gitignore, selecteert u het bestand in het deelvenster Bestanden. Klik erop met de rechtermuisknop en selecteer Git > Verwijderen uit .gitignore.

Zorg dat u het .gitignore-bestand doorvoert in de lokale en externe opslagplaatsen nadat u dit bestand hebt gewijzigd.

Toegang krijgen tot Git via de opdrachtregel

In de vorige secties van dit artikel hebt u gelezen hoe u het deelvenster Git (interface) gebruikt om taken uit te voeren zoals een Git-opslagplaats aan uw site koppelen, externe verbindingen maken en beheren, bestanden naar een opslagplaats verzenden (push) of bestanden uit een opslagplaats ophalen (pull). U kunt deze en andere handelingen ook uitvoeren met behulp van git-opdrachten.

Ga op een van de volgende manieren te werk als u een Git-bewerking wilt uitvoeren met de terminal:

  • Klik op Venster > Git en klik op het pictogram Bash/terminalconsole openen.
  • Schakel in het deelvenster Bestanden over naar de Git-weergave. Klik op het pictogram Git-terminal openen naast de vervolgkeuzelijst met opslagplaatsen.

Voor een overzicht van algemene git-opdrachten raadpleegt u Git Cheat Sheet

Opmerking:

Sommige handelingen, zoals git-stash en doorvoerbewerkingen combineren na push, zijn momenteel alleen mogelijk via de opdrachtregel.

Wanneer u bepaalde bewerkingen, zoals een Git-opslagplaats initialiseren, uitvoert via de opdrachtregel, worden deze bewerkingen ook weerspiegeld in de Dreamweaver-interface.

Als u echter bestanden wijzigt via de opdrachtregel terwijl Dreamweaver niet is geopend, ziet u het volgende bericht wanneer u Dreamweaver de volgende keer opent:

Bericht wanneer bestanden zijn gewijzigd via de opdrachtregel
Bericht wanneer bestanden zijn gewijzigd via de opdrachtregel

Git-voorkeuren instellen in Dreamweaver

Via de Git-voorkeuren in Dreamweaver kunt u een aantal instellingen voor het gebruik van Git in Dreamweaver opgeven. U kunt het dialoogvenster Voorkeuren gebruiken om Git-voorkeuren in te stellen zoals het pad naar de terminal, time-outinstellingen enzovoort.

  1. Selecteer Bewerken > Voorkeuren.

  2. Selecteer Git in het dialoogvenster Voorkeuren.

  3. Stel het volgende in via het dialoogvenster Git-voorkeuren:

    • Pad naar uitvoerbaar Git-bestand: het .exe-bestand van uw Git-client. Als het uitvoerbare bestand is opgeslagen op een andere locatie, bladert u naar de locatie waar u het .exe-bestand van Git hebt opgeslagen.
    • Standaardtime-out voor Git-bewerking: geef de time-out in seconden voor elke externe Git-bewerking op.
    • Pad naar terminal: het volledige pad naar het uitvoerbare bestand om de Git-terminal te openen en te gebruiken.
    • Opdrachtargumenten: geef eventueel opdrachtargumenten op voor uw Git-opdrachten.
    Voorkeuren voor Git instellen in Dreamweaver
    Voorkeuren voor Git instellen in Dreamweaver

  4. Klik op Toepassen om uw instellingen op te slaan.

Opmerking:

Start Dreamweaver opnieuw op om uw bijgewerkte voorkeuren toe te passen.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid