You can use various other Adobe applications to enhance or modify the assets used in a Premiere Pro project. Also, you can use Premiere Pro to edit projects begun in other applications.

Edit a clip in its original application

In Premiere Pro, the Edit Original command opens clips in the applications associated with their file types. You can edit clips in the associated applications. Premiere Pro automatically incorporates the changes into the current project without replacing files. Similarly, Premiere Pro sequences placed in other applications, such as Adobe After Effects can be opened with the host product’s Edit Original command.

  1. Select a clip in either the Project panel or Timeline panel.
  2. Choose Edit > Edit Original.

    Note:

    You can export a movie from Premiere Pro with the data necessary for the Edit Original command. In the Export Movie Settings dialog box, choose Project from the Embedding options menu.

Copy between After Effects and Premiere Pro

  • From the After Effects Timeline panel, you can copy layers based on audio or video footage items (including solids) and paste them into the Adobe Premiere Pro Timeline panel.

  • From the Adobe Premiere Pro Timeline panel, you can copy assets (any items in a track) and paste them into the After Effects Timeline panel.

  • From either After Effects or Adobe Premiere Pro, you can copy and paste footage items to the other’s Project panel.

    note: You can’t, however, paste footage items from the After Effects Project panel into the Adobe Premiere Pro Timeline panel.

If you want to work with all clips or a single sequence from an Adobe Premiere Pro project, use the Import command instead to import the project into After Effects.

Note:

Use Adobe Dynamic Link to create dynamic links, without rendering, between new or existing compositions in After Effects and Adobe Premiere Pro. For more information, see Adobe Dynamic Link.

 

Copy from After Effects to Adobe Premiere Pro

You can copy a layer based on a footage item from an After Effects composition and paste it into an Adobe Premiere Pro sequence. Adobe Premiere Pro converts these layers to clips in the sequence and copies the source footage item to its Project panel. If the layer contains an effect that is also used by Adobe Premiere Pro, Adobe Premiere Pro converts the effect and all of its settings and keyframes.

You can also copy nested compositions, Photoshop layers, solid-color layers, and audio layers. Adobe Premiere Pro converts nested compositions to nested sequences, and solid-color layers to color mattes. You cannot copy shape, text, camera, light, or adjustment layers to Adobe Premiere Pro.

  1. Start Adobe Premiere Pro (you must start Adobe Premiere Pro before you copy the layer in After Effects).
  2. Select a layer (or layers) from the After Effects Timeline panel.

    Note:

    If you select multiple layers and the layers don’t overlap in After Effects, they’re placed on the same track in Adobe Premiere Pro. On the other hand, if the layers overlap in After Effects, the order in which you select them determines the order of their track placement in Adobe Premiere Pro. Each layer is placed on a separate track, and the last selected layer appears on Track 1. For example, if you select layers from top to bottom, the layers appear in the reverse order in Adobe Premiere Pro, with the bottom-most layer on Track 1.

  3. Choose Edit > Copy.
  4. In Adobe Premiere Pro, open a sequence in the Timeline panel.
  5. Move the current-time indicator to the desired location, and choose either Edit > Paste or Edit > Paste Insert.

Results of pasting into Premiere Pro

When you paste a layer into an Adobe Premiere Pro sequence, keyframes, effects, and other properties in the copied layer are converted as follows:

After Effects item

Converted to in Adobe Premiere Pro

Notes

Audio volume property

Channel Volume filter

Blending modes

Blending modes supported by Adobe Premiere Pro are converted

Effect properties and keyframes

Effect properties and keyframes, if the effect also exists in Adobe Premiere Pro

Adobe Premiere Pro lists unsupported effects as offline in the Effect Controls panel. Some After Effects effects have the same names as those in Adobe Premiere Pro, but since they’re actually different effects, they aren’t converted.

Expressions

Not converted

Layer markers

Clip markers

Masks and mattes

Not converted

Stereo Mixer effect

Channel Volume filter

Time Remap property

Time Remapping effect

Time Stretch property

Speed property

Speed and time stretch have an inverse relationship. For example, 200% stretch in After Effects converts to 50% speed in Adobe Premiere Pro.

Transform property values and keyframes

Motion or Opacity values and keyframes

The keyframe type—Bezier, Auto Bezier, Continuous Bezier, or Hold—is retained.

Source settings for R3D source files

Source settings for R3D source files

Copy from Adobe Premiere Pro to After Effects

You can copy a video or audio asset from an Adobe Premiere Pro sequence and paste it into an After Effects composition. After Effects converts assets to layers and copies the source footage items into its Project panel. If the asset contains an effect that is also used by After Effects, After Effects converts the effect and all of its settings and keyframes.

You can copy color mattes, stills, nested sequences, and offline files, too. After Effects converts color mattes into solid-color layers and converts nested sequences into nested compositions. When you copy a Photoshop still image into After Effects, After Effects retains the Photoshop layer information. You cannot paste Adobe Premiere Pro titles into After Effects, but you can paste text with attributes from the Adobe Premiere Titler into After Effects.

  1. Select an asset from the Adobe Premiere Pro Timeline panel.
  2. Choose Edit > Copy.
  3. In After Effects, open a composition in the Timeline panel.
  4. With the Timeline panel active, choose Edit > Paste. The asset appears as the topmost layer in the Timeline panel.

    Note:

    To paste the asset at the current-time indicator, place the current-time indicator and press Ctrl+Alt+V (Windows) or Command+Option+V (Mac OS).

Results of pasting into After Effects

When you paste an asset into an After Effects composition, keyframes, effects, and other properties in a copied asset are converted as follows:

Adobe Premiere Pro asset

Converted to in After Effects

Notes

Audio track

Audio layers

Audio tracks that are either 5.1 surround or greater than 16‑bit aren’t supported. Mono and stereo audio tracks are imported as one or two layers.

Bars and tone

Not converted

Blending modes

Converted

Clip marker

Layer marker

Color mattes

Solid-color layers

Crop filter

Mask layer

Frame Hold

Time Remap property

Motion or Opacity values and keyframes

Transform property values and keyframes

Keyframe type—Bezier, Auto Bezier, Continuous Bezier, or Hold—is retained.

Sequence marker

Markers on a new solid-color layer

To copy sequence markers, you must either copy the sequence itself or import the entire Adobe Premiere Pro project as a composition.

Speed property

Time Stretch property

Speed and time stretch have an inverse relationship. For example, 50% speed in Adobe Premiere Pro is converted to 200% stretch in After Effects.

Time Remapping effect

Time Remap property

Titles

Not converted

Universal counting leaders

Not converted

Video and audio transitions

Opacity keyframes (Cross dissolve only) or solid-color layers

Video effect properties and keyframes

Effect properties and keyframes, if the effect also exists in After Effects

After Effects doesn’t display unsupported effects in the Effect Controls panel.

Volume and Channel Volume audio filters

Stereo mixer effect

Other audio filters are not converted.

Source settings for R3D source files

Source settings for R3D source files

Note:

When you import a Premiere Pro project into After Effects, features are converted in the same manner as they are converted when copying from Premiere Pro to After Effects.

Working with Photoshop and Premiere Pro

If you use Photoshop to create still images, you can use Premiere Pro to make them move and change. You can animate an entire image or any of its layers.

You can edit individual frames of video and image sequence files in Photoshop. In addition to using any Photoshop tool to edit and paint on video, you can also apply filters, masks, transformations, layers styles, and blending modes. You can paint using the Clone Stamp, Pattern Stamp, Healing Brush, or Spot Healing Brush. You can also edit video frames using the Patch tool.

In Photoshop, with the Clone Stamp, you can sample a frame from a video layer and paint with the sampled source onto another video frame. As you move to different target frames, the source frame changes relative to the frame from which you initially sampled.

After making edits, you can save the video as a PSD file, or you can render it as a QuickTime movie or image sequence. You can import any of these back into Premiere Pro for further editing.

If you use Premiere Pro to create movies, you can use Photoshop to refine the individual frames of those movies. In Photoshop, you can do any of the following:

  • Remove unwanted visual elements.

  • Draw on individual frames.

  • Use the superior selection and masking tools to divide a frame into elements for animation or compositing.

Video tutorials for Premiere Pro and Photoshop workflow

  • Learn how Photoshop makes it super-easy to produce graphic and photographic content for video editing in this tutorial.
  • Watch this tutorial to learn how to work with unflattened Photoshop files in your video projects.
  • This video tutorial explains how to import a Photoshop file into Premiere Pro and access individual layers to work on selective animation and effects.

Comparative advantages for specific tasks

The strengths of Premiere Pro lie in its numerous video editing features. You can use it to combine Photoshop files with video clips, audio clips, and other assets. You can use the Photoshop files, for example, as titles, graphics, and masks.

In contrast, Photoshop has excellent tools for painting, drawing, and selecting portions of an image. The Photoshop Quick Selection tool and Magnetic Lasso tool make it easy to create a mask from a complex shape. Rather than hand-drawing a mask in Premiere Pro, consider doing this work in Photoshop. Similarly, if you are applying several paint strokes by hand to get rid of dust, consider using the Photoshop paint tools.

The animation and video features in Photoshop Extended include simple keyframe-based animation. Premiere Pro, however, provides quite a bit more keyframe control over various properties.

Exchanging still images

Premiere Pro can import and export still images in many formats. For greatest versatility, however, use the native Photoshop PSD format when transferring individual frames or still image sequences from Photoshop to Premiere Pro.

When you import a PSD file into Premiere Pro, you can choose whether to import it as a flattened image, or with its layers separate and intact.

It is often a good idea to prepare a still image in Photoshop before importing it into Premiere Pro. Examples of such preparation include correcting color, scaling, and cropping. It is often better to change a source image in Photoshop than to have Premiere Pro perform the same operation many times per second as it renders each frame for previews or final output.

In Photoshop, you can create a PSD document that is set up correctly for a specific video output type. From the New File dialog box, select a Film & Video preset. In Premiere Pro, you can create a PSD document that matches your composition and sequence settings. Choose File > New > Photoshop File.

Exchanging movies

You can no longer exchange PSD video files with Photoshop, however, you can render a movie directly from Photoshop and then import it back into Premiere Pro. For example, you can create a QuickTime movie from Photoshop that can then be imported into Premiere Pro.

Color

Premiere Pro works internally with colors in an RGB (red, green, blue) color space. If you want to edit video clips you create in Photoshop in Premiere Pro, create the clips in RGB.

If you want to broadcast the final movie it is best to ensure, in Photoshop, that the colors in your image are broadcast-safe. Assign the appropriate destination color space—for example, SDTV (Rec. 601)—to the document in Photoshop.

Create and edit Photoshop files

You can create a still Photoshop file that automatically inherits the pixel and frame aspect ratio settings of your Premiere Pro project. You can also edit any still image file in a Premiere Pro project in Photoshop.

Create a Photoshop file in a project

  • Choose File > New > Photoshop File.

    Photoshop opens with a new blank still image. The pixel dimensions match the project’s video frame size, and image guides show the title-safe and action-safe areas for the project.

Edit a still image file in Photoshop

From within a project, you can open an image file in most formats that Adobe Photoshop supports. Premiere Pro does not import files in CMYK or LAB color formats.

  1. Select a still-image clip in either the Project panel or Timeline panel.
  2. Choose Edit > Edit In Adobe Photoshop.

    The file opens in Photoshop. When you save the file, changes are available in the Premiere Pro project.

Working with SpeedGrade and Premiere Pro

Adobe SpeedGrade is a color grading application that brings advanced color-grading capabilities to your footage.

You can color grade a Premiere Pro project directly in SpeedGrade using the Direct-Link feature. Or you can use a roundtrip workflow to send your video sequences from Premiere Pro to SpeedGrade for color grading, and bring them back to Premiere Pro.

For more information, see Direct Link workflow between Premiere Pro and SpeedGrade.

Working with Adobe Story and Premiere Pro

The Adobe Story panel in Premiere Pro CC lets you import scripts created in Adobe Story, along with associated metadata to guide your editing.

From within the Adobe Story panel, you can access all the scripts you have in your Story account.

To open the Adobe Story panel from within Premiere Pro, select Window > Adobe Story.

You can quickly navigate to specific scenes, locations, dialogue, and characters as you work. You can also attach an Adobe Story scene directly to clips in Premiere Pro by following these steps:

  1. Select Window > Adobe Story to open the Adobe Story panel from within Premiere Pro.

  2. Drag the scene that you want to attach from the Adobe Story panel and drop it on the required clip in the Project panel.

Script-based video editing with Story

Script-based video editing with Story
Learn a quick and easy way to connect scripts from Adobe Story with video clips using the Adobe Story panel in Premiere Pro.
Maxim Jago

For an overview of all the features in Adobe Story, see this video.

Working with Encore and Premiere Pro

Using Adobe Encore CS6 and Adobe Premiere Pro, you can burn a single sequence to DVD or Blu-ray Disc. You can burn each sequence in your project to a separate DVD or Blu-ray Disc. First, add all the content you want to include on a disc into a sequence. After you edit the sequence, perform the following tasks:

Add Encore chapter markers

You can add Encore chapter markers in a Adobe Premiere Pro sequence. You can send the Encore chapter markers, along with the sequence to Encore.

In Encore, if you create an AutoPlay DVD, the Encore chapter markers become scene markers. When viewing the DVD, pressing the Previous button or Next button on the remote control skips backward or forward to the next of these markers. If you create a DVD or Blu-ray Disc with menus, you can link scene buttons on the menus to the Encore chapter markers.

Send to Encore or to an MPEG-2 file

You can send a whole sequence, or any portion of a sequence, from Adobe Premiere Pro to Encore. From Encore, you can burn the sequence directly to a DVD without menus, or add menus and buttons before burning. From Encore, you can export the project in any of the following forms:

  • you can burn the project to disc,
  • you can save the project to a DVD image file,
  • you can save the project to a set of DVD folders,
  • you can save the project to DVD master files on DLT tape.
  • you can export the project to a SWF file for posting on the web.

Alternatively, using the MPEG2-DVD format, you can export a DVD-compliant MPEG-2 file from Adobe Premiere Pro. You can use the MPEG-2 file in most DVD-authoring applications.

Choose a menu template

Encore templates are predesigned menus that come in several styles. Buttons on the templates automatically link to chapter markers placed in the sequence. Encore creates additional submenus as necessary to accommodate all the chapter markers in a sequence.

Note:

AutoPlay DVDs do not have menus. Do not choose a template for AutoPlay DVDs.

Customize the menu template

Edit titles, change graphics, or add video for background in Encore. You can also use video in button thumbnails by specifying a section of a clip to play in the button.

Preview the disc

Check the functionality and the look of your DVD or Blu-ray Disc menus in the Preview DVD window.

Burn the disc

With a DVD or Blu-ray Disc burner installed or connected, you can burn your content to disc. You can save the compressed files to a folder for playback from a computer hard drive. You can also save an ISO image to distribute or burn to a DVD.

Note:

Encore creates DVDs that conform to DVD-video format. It does not create data or audio DVDs.

Working with Apple Final Cut Pro and Adobe Premiere Pro

You can import Final Cut Pro project XML files into Premiere Pro. For more information, see Importing XML project files from Final Cut Pro. You can export Premiere Pro project files as Final Cut Pro XML files.

For more information, see Export a Final Cut Pro project XML file.

For more information about workflows possible between Final Cut Pro and Premiere Pro, see Open workflows with Final Cut Pro and Avid software.

Joost van der Hoeven provides a video tutorial on the Adobe website that demonstrates exchanging information between Final Cut Pro and Premiere Pro using XML projects.

Note:

Premiere Pro and Final Cut Pro 7 (and earlier) can share Final Cut Pro XML files for data exchange. To exchange information between Final Cut Pro X and Premiere Pro, you can use a third party tool called "Xto7." For more information on using this tool, see here.

See this page for several documents that make the transition from Final Cut Pro to Premiere Pro easier.

Note:

An exported XML file from Premiere Pro can be imported into some versions of Final Cut Express, as well.

Working with Avid Media Composer and Adobe Premiere Pro

For information about the workflows possible between Premiere Pro and Avid Media Composer, see Open workflows with Final Cut Pro and Avid software.

In this video tutorial, Maxim Jago presents the round-tripping workflow with Avid Media Composer.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy