Supported file formats

Premiere Pro can import many video and audio formats. Premiere Pro can import files in the formats listed here, provided the codec used to generate a specific file is installed locally. Most of these software modules are installed automatically with Premiere Pro.

For a list of file formats supported for import in Premiere Pro, see Supported file formats.

About transferring files

Transferring projects from other computers

When transferring project files, such as After Effects project files, Premiere Pro project files, or Final Cut Pro project files from another computer to the computer on which you import those project files into Premiere Pro, make sure that you transfer all the assets associated with the project files. Keep the project files, and their associated assets, on the destination computer in folders that have names and folder structures identical with files on the computer of their origin.

Transferring assets from file-based media

It is possible to edit assets residing on file-based media, such as P2 cards, XDCAM cartridges, SxS cards, or DVDs. However, Premiere Pro performs faster if you first transfer the assets to a local hard disk. Using Windows File Explorer (Windows) or Finder (Mac OS), transfer files from file-based acquisition media. Then, import the files on the hard disk into Premiere Pro projects.

When transferring files to hard disk from file-based media, transfer the folder containing all related files and its subfolders. Keep the folder structure intact. For example, when transferring files from AVCHD file-based media, transfer the BDMV folder and all its contents. When transferring files from DVCPRO HD media, transfer the CONTENTS folder and all its contents. When transferring files from XDCAM EX media, transfer the BPAV folder and all its contents. When transferring files from DVD, transfer all the contents of the VIDEO_TS folder, and if it exists, all the contents of the AUDIO_TS folder.


Transfer video files from file-based media into the same folder you specify for captured video with the project scratch disk settings.

The folder structure for AVCHD assets
The folder structure for AVCHD assets

The folder structure for DVCPRO HD assets
The folder structure for DVCPRO HD assets

The folder structure for XDCAM EX assets
The folder structure for XDCAM EX assets

The folder structure for DVD-Video assets
The folder structure for DVD-video assets

About importing files

Importing is different from capturing. The Import command brings files that are already on your hard disk or other connected storage device into your project. Importing files makes them available to a Premiere Pro project. Premiere Pro lets you import numerous types of video, still images, and audio. Finally, you can export a Premiere Pro project from After Effects, and import it into Premiere Pro.

You can import video, audio, and still files in various file formats into a Premiere Pro project. You can import a single file, multiple files, or an entire folder. Frame sizes cannot exceed 16 megapixels.

If you have spanned clips, be sure to import them via the Media Browser instead of importing them through the File menu.


If the software you use to create art doesn’t let you specify pixels as a unit of measure, try specifying points.

In Premiere Pro, you can import files by using the Media Browser or the Import command.

Premiere Pro indexes certain types of files and transcodes others after importing them. You cannot edit these types fully until these processes are completed. The filename of a clip appears in the Project panel in italics until it has been fully indexed or transcoded.

To import files that Premiere Pro does not support natively, install the appropriate capture card or third-party plug-in software. For more information, check the manual that came with the installed card or plug-in.


You can also import files and folders by dragging them from Windows Explorer (Windows) or Finder (Mac OS) into the Project panel. On Windows Vista, if the User Account Control (UAC) is activated, Windows disables drag-and-drop from Windows Explorer, or any program, to any program running in Administrator mode. You run Premiere Pro in Administrator mode for plug-in activation, special disk access, and network permissions. To enable drag-and-drop while running Premiere Pro in Administrator mode, disable the UAC. In Windows Control Panel, select User Accounts. Disable UAC for the selected user.

Watch this tutorial to learn how to import audio and video files in Premiere Pro.

Import files with the Media Browser

The Media Browser makes it easy to browse to files, and to find them by their type. Unlike the Import dialog box, the Media Browser can be left open, and docked, like any other panel. Also, you can import multiple Media Browser panels within the same workspace, and edit or reuse existing clips from different projects.

The Media Browser gives you quick access to all your assets while you edit. Also, you can use the Media Browser to import clips copied from video storage media such as P2 cards, SxS cards, XDCAM disks, and DVDs. When you import an asset Premiere Pro leaves it in its current location, and creates a clip in the Project panel that points to it. By default, Premiere Pro writes XMP files to the directory where the media files are located, but you can turn off this behavior in Preferences. For best performance, first transfer files from their file-based media to a local hard disk. Then, import them into Premiere Pro projects from the hard disk.

  1. Select Window > Media Browser.
  2. To browse to the desired files, do one of the following:
    • To open a folder recently opened, click the triangle in the Recent Directories menu, and select the folder.
    • In the list of hard drives and folders in the Media Browser, click the triangles next to folder names to open them.
  3. To view only files of certain types, click the triangle in the Files Of Type menu, and select a file type. To select an additional type, open the menu again and make another selection. Repeat until all desired types have been selected.
  4. Select one or more files from the list of files. To select more than one non-contiguous file, Ctrl-click (Windows) or Command-click (Mac OS) the filenames. To select more than one contiguous file, Shift-click the filenames.
  5. Do one of the following:
    • Select File > Import From Browser, or right-click the file in the Media Browser and select Import. Alternatively, you can drag the file from the Media Browser into the Project panel, or drag the file from the Media Browser into a Timeline.

    The Media Browser imports the file into the Project panel.

    • Right-click the file in the Media Browser and select Open In Source Monitor. Alternatively, double-click the file in the Media Browser to open it in the Source Monitor.

    The Media Browser opens the file in the Source Monitor.

Import files with the Import commands


While you can import clips directly from file-based media connected to your computer, it is best to first transfer clips from these media to a hard disk. Then, import them from the hard disk. 

  • Choose File > Import. You can select multiple files.
  • To import a recently imported file, choose File > Import Recent File > [filename]. (The filename doesn’t appear if Premiere Pro preferences have been reset.)
  • To import a folder of files, choose File > Import. Locate and select the folder, and then click Import Folder. The folder, with its contents, is added as a new bin in the Project panel.
  • For instructions on importing a numbered still-image sequence as a clip, see Importing numbered still-image sequences as one clip.

Channel support

Premiere Pro supports four-channel assets. Every processed pixel in the render pipeline uses four channels. When Premiere Pro processes a three-channel asset, such as DV, HDV, or MPEG footage, Premiere Pro automatically converts it to a four-channel asset. Premiere Pro converts a three-channel asset when you add an effect or transition to the asset.

Premiere Pro supports 10-bit color depth, sometimes useful for editing standard and high-definition footage.

Edit While Ingest

The Premiere Pro Media Browser panel allows you to ingest media automatically in the background while you begin editing. 

Use the ingest check box in the Media Browser panel to toggle the automatic ingest behavior setting to on/off. A settings button next to it opens the Project Settings dialog, where you can adjust the ingest settings. A similar ingest check box in the Project Settings dialog is kept in sync with the Media Browser panel’s setting. When toggled on, users can choose one of four following operations to kick off automatically when files get imported into the project. You can continue to edit while the ingest process completes in the background.

  • Copy - You can copy the media to a new location. Copying is typically used to transfer camera footage from removable media onto your local hard drive. The Primary Destination option available in the Settings transfer path is the same as the Primary Destination option available in Settings. After the media has finished copying, the clips in the project point to these copies of the files.   
  • Transcode - You can transcode the media to a new format in a new location. Transcoding can be used to transcode original camera footage to a specific format used within a post-production facility. The filename path is the same as the Primary Destination option available in Settings, and the format is specified by the chosen preset. After the media gets transcoded, the clips in the project point to these transcoded copies of the files. 
  • Create Proxy - Use this option to create and attach proxies to the media. You can use this option to create lower-resolution clips for increased performance during editing, which can be switched back to the original full resolution files for final output. The filename path where the proxies are generated is the same as the Proxy Destination option available in the settings, and this format is specified by the chosen preset. After the proxies get generated, they are automatically attached to the clips in the project.
  • Copy and Create Proxy - Use this option to copy media and create proxies, as covered in the earlier steps.  

All four options come with a set of default presets, which have the file destinations set to 'Same as Project'. Alternatively, you can also choose a custom destination or your Creative Cloud Files folder, which syncs the files automatically to the cloud.  Use Adobe Media Encoder to create your own 'Ingest' presets.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy