Note:

Premiere Pro CC now provides an enhanced, dynamic user interface with a new task-oriented workspaces layout, tabbed panels, and other improvements. If you are using a version earlier than the 2015 release of Premiere Pro CC, you cannot find some of the panels and tools as described in this article.

About workspaces

Adobe video and audio applications provide a consistent, customizable workspace. Although each application has its own set of panels (such as Project, Metadata, and Timeline), you move and group panels in the same way across products.

The main window of a program is the application window. Panels are organized in this window in an arrangement called a workspace. The default workspace contains groups of panels and panels that stand alone.

You customize a workspace by arranging panels in the layout that best suits your working style. As you rearrange panels, the other panels resize automatically to fit the window. You can create and save several custom workspaces for different tasks—for example, one for editing and one for previewing.

Example workspace
Example workspace

A. Application window B. Grouped panels C. Individual panel 

Note:

You can use floating windows to create a workspace more like workspaces in previous versions of Adobe applications, or to place panels on multiple monitors.

Import a workspace with a project

Workspace selections and customizations made in a project are saved in the project file. By default, Premiere Pro opens projects in the current workspace. However, you can instead open a project in the workspace last used with it. This option is helpful if you often rearrange the workspace for each project.

 

Note:

If you import a project and the workspace is empty, close the project. Deselect Import Workspace From Projects. Import the project again, and select an existing workspace for the project.

  • Before opening a project, select Window > Workspace > Import Workspace From Projects.

Customizing workspaces

Choose a workspace

Each Adobe video and audio application includes several predefined workspaces that optimize the layout of panels for specific tasks. When you choose one of these workspaces, or any custom workspaces you’ve saved, the current workspace is redrawn accordingly.

In Premiere Pro, Workspace buttons in the Workspaces panel provide you one-click access to default or custom workspaces. 

Workspaces
  • Switch to the different layouts by clicking the names at the top of the workspace
  • Click the Chevron icon (>>) to open the Overflow menu. The Overflow menu includes workspace layouts that are not displayed in the Workspace panel. 
  • Drag the vertical divider next to the Chevron icon to control whether a workspace is displayed or hidden in the overflow menu.

Note:

Older custom workspaces do not have the Workspaces panel open at the top of the workspace. You can open the Workspaces panel, dock it at the top and save the change into the workspace.

You can also open a Workspace from the Window menu:

  • Open the project you want to work on, choose Window > Workspace, and select the desired workspace.

Modify the order of workspaces or delete workspaces

You can change the order in which workspaces are displayed, move a workspace to the Overflow menu, or hide a workspace so that it is not displayed in the Workspaces panel. You can also delete a workspace from the panel. 

  1. Click the Workspace menu icon, which appears next to the currently active workspace.

    Workspace menu icon
    A. Workspace menu icon 
  2. In the Workspace menu that is displayed, click Edit Workspaces.

    Edit Workspaces

    Note:

    You can also access the Edit Workspaces dialog through Window > Workspaces > Edit Workspaces.

  3. The Edit Workspaces dialog is displayed. Here you can reorder workspaces, move them into the Overflow menu or hide them. You can also delete a workspace.

    To revert any change that you made, click Cancel. 

    Edit Workspaces dialog

Save or reset workspaces

Save a custom workspace

As you customize a workspace, the application tracks your changes, storing the most recent layout. To store a specific layout more permanently, save a custom workspace. Saved custom workspaces appear in the Workspace menu, where you can return to and reset them.

  • Arrange the groups and panels as desired, and then do one of the following: 

    • Click the Workspace menu icon and select Save as New Workspace.
    Save as New Workspace
    • Or, choose Window > Workspace > Save as New Workspace

     

Save changes to default workspaces

Note:

Once changes to the original default layouts are saved, the only way to recover them is to delete the workspace config file from your Layouts folder

To save the changes made to default workspaces, do one of the following:

  • Click the Workspace menu icon and select Save Changes to this Workspace
  • Select Window > Workspaces > Save Changes to this Workspace

Reset a workspace

Reset the current workspace to return to its original, saved layout of panels.

  • Do one of the following:

    • Click the Workspace menu icon and select Reset to Saved Layout
    • Choose Window > Workspace > Reset to Saved Layout.

Default workspaces in Premiere Pro CC November 2015 release

In the Premiere Pro CC November 2015 release, all the default workspaces have been revised. In addition, two new workspaces have been added: Titles and All Panels. The Titles workspace presents the Titling tools in a right-side column of stacked panels, with the Title Designer in the same frame as the Program monitor. Every panel is open in the All Panels workspace.

The new default workspaces may only be visible if the application was installed on a clean system (no previous Premiere user folder in the configuration) or after the Layouts folder is manually deleted, then automatically restored by the application.

Similarly, if you use Sync Settings the older default workspaces in your settings files 
overwrite the new workspaces. To use both the new default workspaces and preserve your custom workspaces, do the following:

  1. Make sure that your custom workspaces do not use the same name as any of the default workspaces. If necessary, rename and save them with custom names.
  2. Make sure the preference to Import workspace from project (Window>Workspaces submenu) is toggled on.
  3. Save a Premiere project with your custom workspace in use (selected). If you have more than one custom workspace, create a separate project for each of these other custom workspaces.
  4. Copy the current Layouts folder as a backup to revert back.
  5. Delete the Layouts folder (this folder will be re-created with the new default workspaces the next time you launch Premiere Pro).
  6. Launch Premiere Pro to see the new workspaces.
  7. Open the project you saved with your custom workspace in use. It is imported and made available along with the new default workspaces.
  8. If you had more than one custom workspace, open the other projects. Each of those custom workspaces is also imported.

Dock, group, or float panels

You can dock panels together, move them into or out of groups, and undock them so they float above the application window. As you drag a panel, drop zones—areas onto which you can move the panel—become highlighted. The drop zone you choose determines where the panel is inserted, and whether it docks or groups with other panels.

Docking zones

Docking zones exist along the edges of a panel, group, or window. Docking a panel places it near the existing group, resizing all groups to accommodate the new panel.

Dragging panel (A) onto docking zone (B) to dock it (C)
Dragging panel (A) onto docking zone (B) to dock it (C)

Grouping zones

Grouping zones exist in the middle of a panel or group, and along the tab area of panels. Dropping a panel on a grouping zone stacks it with other panels.

Dragging panel (A) onto grouping zone (B) to group it with existing panels (C)
Dragging panel (A) onto grouping zone (B) to group it with existing panels (C)

Dock or group panels

  1. If the panel you want to dock or group is not visible, choose it from the Window menu.

  2. Drag the required panel onto the desired drop zone. The application docks or groups according to the type of drop zone.

    Press the Ctrl key while dragging the panel to make the panel free-floating.

     

    You can choose to present panels in a panel group in a stacked state or in a tabbed state. Stacked panels are expanded and collapsed with a single click of the mouse on the panel header, or a tap of the finger when using a touch surface. Choose the desired option from Panel Group Settings. 

Undock a panel in a floating window

When you undock a panel in a floating window, you can add panels to the window and modify it similarly to the application window. You can use floating windows to use a secondary monitor, or to create workspaces like the workspaces in earlier versions of Adobe applications.

  • Select the panel you want to undock (if it’s not visible, choose it from the Window menu), and then do one of the following:

    • Choose Undock Panel or Undock Panel Group from the panel menu. Undock Panel Group undocks the panel group.

    • Hold down Ctrl (Windows®) or Command (Mac OS®), and drag the panel or group from its current location. When you release the mouse button, the panel or group appears in a new floating window.

    • Drag the panel or group outside the application window. (If the application window is maximized, drag the panel to the Windows taskbar.)

Resize panel groups

When you position the pointer over dividers between panel groups, resize icons appear. When you drag these icons, all groups that share the divider are resized. For example, suppose that your workspace contains three panel groups stacked vertically. If you drag the divider between the bottom two groups, they are resized, but the topmost group doesn’t change.

Note:

To quickly maximize a panel beneath the pointer, press the accent key. (Do not press Shift.) Press the accent key again to return the panel to its original size.

  1. Do either of the following:
    • To resize either horizontally or vertically, position the pointer between two panel groups. The pointer becomes a double‑arrow .
    • To resize in both directions at once, position the pointer at the intersection between three or more panel groups. The pointer becomes a four-way arrow .
  2. Hold down the mouse button, and drag to resize the panel groups.
    Dragging divider between panel groups to resize them horizontally
    Dragging divider between panel groups to resize them horizontally

    A. Original group with resize icon B. Resized groups 

Open, close, and scroll to panels

When you close a panel group in the application window, the other groups resize to use the newly available space. When you close a floating window, the panels within it close, too.

  • To open a panel, choose it from the Window menu.
  • To close a panel or window, press Control-W (Windows) or Command-W (Mac OS), or click its Close button .
  • To see all the panel tabs in a narrow panel group, drag the horizontal scroll bar.
  • To bring a panel to the front of a group of panels, do one of the following:
    • Click the tab of the panel you want in front.

    • Hover the cursor above the tab area, and turn the mouse scroll wheel. Scrolling brings each panel to the front, one after another.

    • Drag tabs horizontally to change their order.

  • To reveal panels hidden in a narrow panel group, drag the scroll bar above the panel group.
Drag horizontal scroll bar to see all panels in narrow group
Drag horizontal scroll bar to see all panels in narrow group

Working with multiple monitors

To increase the available screen space, use multiple monitors. When you work with multiple monitors, the application window appears on one monitor, and you place floating windows on the second monitor. Monitor configurations are stored in the workspace.

Brighten or darken the interface

You can lower the brightness, as when working in a darkened editing suite or when making color corrections. Changing the brightness affects panels, windows, and dialog boxes but does not affect scroll bars, title bars, and menus that aren’t inside panels. In addition, the change doesn’t affect the application background on Windows.

  1. Choose Edit > Preferences > Appearance (Windows) or Premiere Pro > Preferences > Appearance (Mac OS).
  2. Drag the User Interface Brightness slider to the left or right. Click Default to restore the default brightness level.

Video tutorial - Premiere Pro CC (2014)

Overview of the interface

Learn how to use Premiere Pro panels and tools in your video editing workflow.


This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy