Captioning in Premiere Pro

Premiere Pro provides a full set of captioning features that let you edit captions, create your own, and export them for display for all supported formats.

You can import and display closed captions and edit the text, color, background, and the timing quickly and easily. Once you're done editing, you can export the closed captions files as a "sidecar" file, embed them in a QuickTime movie or MXF file, or burn the captions into a video. 

Besides closed captions, Premiere Pro also supports importing open caption files that you can burn in as subtitles.

Import and display captions

Premiere Pro lets you import files that have closed captions embedded in them, or closed caption “sidecar” files.

You can import the files into your project in Premiere Pro just like you would import any other file by using one of the following options:

  • Select File > Import to import embedded caption files or caption "sidecar" files
  • Import through the Media Browser using the file's context menu

Display captions in the Source Monitor and Program Monitor

When you import caption clips into a project, the captions are displayed as caption blocks in the Captions panel.

To display the captions in the Source Monitor and Program Monitor, do one of the following:

  • Click "+" at the lower right of a monitor to open the button editor, select the Captions Display button, and click OK. Or, add the Closed Caption button to the button bar by dragging it from the button editor. You can also assign keyboard shortcuts to those commands.
  • In the Source or Program Monitor panel pop-up menu, click the Wrench icon and select Captions Display > Enable.
Displaying closed captions in the Source Monitor and Program Monitor
Displaying closed captions in the Source Monitor and Program Monitor

Important notes

  • You can toggle captions display on and off.
  • You can select the captioning standard for a caption clip loaded in the Source Monitor. In the Source Monitor, click the Wrench icon and select Captions Display > Settings. For example, you can select CEA-608 or CEA-708 closed captioning standards, and also set the channel or service you want to display.
  • A caption clip when linked to video behaves similar to a linked audio channel clip. The text clip is represented in the Timeline's source indicators, and can be enabled/disabled or linked to any video track like other video clips.
  • When a track is expanded, the caption blocks in a caption clip are visible, along with End Of Caption (EOC) indicators that denote where the caption blocks begin and end.

Create or edit captions

Captions panel in Premiere Pro
Captions panel in Premiere Pro

A. Filter caption content  B. Formatting toolbar C. Editable text blocks D. Add, delete caption blocks 

Create captions

Premiere Pro lets you create captions from scratch. You can add text, apply formatting, and specify position and color.

  1. Select File > New Captions.

    The New Captions dialog box appears displaying the video settings. Premiere Pro matches the caption video settings to the open sequence. Accept the default video settings and click OK.


    Ensure that the frame rate of the caption file that you are creating matches the frame rate of the sequence that you want to use it in.

  2. In the New Captions dialog box, choose the appropriate caption standard and stream. Premiere Pro adds a new caption file in the Project panel.

  3. To add text to the caption file, double-click the caption file in the Project panel. You can also open the Captions panel by selecting Window > Captions.

  4. In the Captions panel, type the caption text as desired. Use the formatting tools to specify the position, change the text color and background color for the caption. You can also apply formatting effects such as underlining and italicizing.

  5. To add more caption blocks, click Add Caption (+) in the bottom right-side of the Captions panel. To delete a caption block, select the caption block and click Delete Caption (-).

  6. Drag the caption file onto the source sequence in the Timeline over the required source clip in the sequence.

Edit captions

Consider a scenario where you have a program that already contains closed captions. You may need to create a different version of the program, say with a shorter duration, to add more commercials.

Follow these steps to edit a caption file in Premiere Pro:

  1. Select the caption file to edit in the Timeline panel.

  2. Open the Captions panel (Window > Captions) to display the captions.

  3. In the Captions panel, you can make word-level edits of existing caption clips. You can also make changes to the timing and formatting, like, text alignment and color, from an intuitive user interface.

  4. The text clips are also visible from the Timeline. From there, you can adjust the captions to be in proper sync with the media after any trims, ripple deletes, and rearranging of segments.

Export captions

After you finish editing or creating caption files, you can export the sequence containing the captions through Premiere Pro or Adobe Media Encoder using the Export Settings dialog box. Or, you can export the sequence containing captions to tape using third-party hardware that supports closed caption encoding.

Export captions using Premiere Pro or Adobe Media encoder

  1. Load a closed caption asset in the Source Monitor or select it in the Project panel. You can also select a sequence in the Project panel, or have the Timeline panel in focus.

  2. Select File > Export > Media.

  3. In the Export Settings dialog box, specify the following options under the Captions tab.

    Export Options

    Select one of the following export options:

    • Create Sidecar File
    • Burn Captions Into Video
    • Embed in Output File   

    File Format

    Select one of the following file formats to export the closed caption data:

    • Scenarist Closed Caption File (.scc)
    • MacCaption VANC File (.mcc)
    • SMPTE Timed Text (.xml)
    • EBU N19 Subtitle (.stl)

    Note: The default option for NTSC regions is SMPTE Timed Text, and for PAL regions is EBU N19.

    You can also export closed caption data to an open caption file (SRT file format):

    • SubRip Subtitle Format (.srt)

    Frame Rate

    Depending on the format that you select, a list of supported frame rates is displayed in the Frame Rate pop-up menu. A default frame rate is chosen based on the known frame rate of the sequence that you are exporting.

    Click Export to export the video with the caption data.  

Handle embedded captions

Premiere Pro supports support importing and decoding embedded captions in MOV and MXF files.

Importing media with embedded captions

You can import media containing embedded captions just like you would import any other media by selecting File > Import or by importing through the Media Browser. Premiere Pro imports the embedded closed caption data automatically into the project.   

For example, when you import a QuickTime clip that contains embedded captions, the captions are automatically imported. If a QuickTime clip has an accompanying "sidecar" caption file, then import the "sidecar" file just like you import any other file.

To detect and automatically import embedded caption data in a media file, select the Include Captions On Import check box under the Media section in the Preferences dialog box.


Premiere Pro optimizes performance by scanning the media for caption data only for the first time you open that file. Premiere Pro does not rescan for caption data when you open that file later.

Editing embedded captions

Follow the same steps to edit an embedded caption file in Premiere Pro as you do to create a separate caption file. When you edit an embedded caption file, the edits are applied only within the project and the source file is not modified.

Exporting media with embedded captions

While exporting, you can choose to keep the captions embedded or split the captions into a separate sidecar file.

To export only the captions as a separate sidecar file, select the caption file in the Project panel, and choose File > Export > Captions.

To export media with embedded captions, select the target sequence selected in the Timeline, and choose File > Export > Media. Premiere Pro opens the Export Settings dialog box.

In the Export Settings dialog box, select the Format as either QuickTime or MXF. In the Captions tab, select the Export Options as Embed In Output File.

Handle burned-in captions

Premiere Pro lets you burn in permanent captions into your video. Burned-in captions are always visible regardless of whether closed captioning is enabled on your television or streaming device or not.

Premiere Pro supports burning in both closed captions and open captions while exporting your video.

When you import SRT files and XML files that  have open caption data in them, Premiere Pro automatically converts these files to CEA-708 CC1 closed caption files. You can then edit these files and burn in the captions as subtitles while exporting using Premiere Pro or Adobe Media Encoder.

In the Export Settings dialog box, select the Export Format as Burn Captions Into Video.


You cannot edit captions that are burned into the video.

Create captions using third-party applications

If you are using any third-party captioning applications to create captions, here is a typical workflow that you can follow:

Step 1: Export the sequence to a third-party captioning application

After you complete the video and audio editing in Premiere Pro, you export the sequence as a reference movie to a third-party Captioning application.

This movie can be sent to a Captioning service bureau or a Captioning specialist, where the movie is used as a reference to create a closed caption track from scratch. A third-party captioning application, like MacCaption from CPC, lets you create the closed caption track from scratch, and then encodes the closed captioning data in the necessary format.

Step 2: Import closed caption files into Premiere Pro

Once you receive the Closed Caption file from a third-party Captioning application, you can import the file into your project in Premiere Pro. Premiere Pro supports importing Closed Captioning files in .mcc, .scc, .xml, or .stl filename formats.

When you import a Closed Caption sidecar file into your project, a video-only clip is created containing the Closed Caption text blocks. You can make any further adjustments to the text blocks to keep it in sync with your media, as required.

A Closed Caption sidecar file contains multiple caption streams: for example, CC1, CC2. When such a clip containing multiple caption streams is added to a sequence, the Timeline shows separate track items for each stream. To switch among different caption streams, in the Captions tab, select a stream from the Caption Stream pop-up menu.

Step 3: Export the edited video

Once the closed captions are in sync with the media, you can export the edited video along with the Closed Caption file. You can export closed caption sidecar files and embedded QuickTime movies (QuickTime 608 captions) through Premiere Pro, as well as through Adobe Media Encoder.


Supported formats

Closed captioning

Sidecar files

  • SCC
  • MCC
  • XML
  • STL

XML files

  • W3C TTML (also known as DFXP)
  • EBU-TT


For XML files, besides viewing the captions in the Captions panel, the captions are also viewable from a text editor.

Premiere Pro supports embedding into and decoding from the following file formats:  

  • MOV
  • DNxHD MXF Op1a
  • MXF Op1a

Open captioning

Premiere Pro allows editors to create Open Captions, also known as subtitles, which are captions burned into the video stream (as opposed to Closed Captions which can be toggled on or off by the viewer). Users can create new Open Captions or import caption formatted XML and SRT files. In the Captions panel, you can create caption blocks, add text, and change the text formatting (color, size, position and background color).

You can export Open Captions as Open Caption formatted SRT and XML files and also convert single stream sidecar and embedded single stream files to Open Caption in Premiere Pro. This includes embedded MOV and MXF caption files. Using the value area next to Size you can make changes by mouse-down right/left interaction, or numerical input.

  1. Select Open Captions to create the required open caption.
  2. Use the Select Font Family and Select Font Weight to change the font type and characteristics.
  3. To change the the text and background text box color of Open Captions use a color picker eyedropper, or by clicking on the Color Picker to the left of it. 
  4. Open Caption text automatically burns in to Video when placed in the Sequence and exported, similar to the behavior of Sequence, Titles. You can also use the track toggle output to control Burn In of Open Captions.
Open Captioning

Video : How to add subtitles (Open Captions)

Learn how to add subtitles (open captions) to your video with flexible options for font color, size, and position. (Watch, 7 min) 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy