You can import individual still images into Premiere Pro or import a series of still images as a sequence. You can import still images from Adobe applications such as Photoshop and Illustrator. For information about the still-image formats that Premiere Pro imports, see File formats supported for import.

An imported still image uses the duration specified in the Still Image preferences. You can change the duration of a still image in a sequence.

The maximum frame size that can be imported for still images and movies is 256 megapixels, with a maximum dimension of 32,768 pixels in either direction. For more information, see this post on the Premiere Pro Work Area blog.

Preparing still images before importing

Before you import a still image into Premiere Pro, prepare it as completely as possible to reduce rendering time. It’s usually easier and faster to prepare a file in its original application. Consider doing the following:

  • Make sure that the file format is supported by the operating system you plan to use.

  • Set the pixel dimensions to the resolution you will use in Premiere Pro. If you plan to scale the image over time, set image dimensions that provide enough detail at the largest size the image has in the project.

  • For best results, create files with a frame size at least as large as the frame size of the project so that you don’t have to scale up the image in Premiere Pro. Scaling an image larger than its original size can cause loss of sharpness. If you plan to scale up an image, prepare it at a larger frame size than the project’s. For example, if you plan to scale up an image 200%, prepare the image at double the project frame size before you import it.

  • Crop the parts of the image that you don’t want to be visible in Premiere Pro.

  • If you want to designate areas as transparent, create an alpha channel or use the transparency tools in applications such as Photoshop or Illustrator.

  • If final output will be shown on standard television screens, avoid using thin horizontal lines (such as 1-pixel lines) for images or text. These may flicker as a result of interlacing. If you must use thin lines, add a slight blur so that the lines appear in both video fields. See Interlaced video, noninterlaced video, and progressive scanning.

  • Save the file using the correct naming convention. For example, if you plan to import the file into Premiere Pro in Windows, use a three-character filename extension.

  • When you prepare still images in applications that support color management, such as Photoshop, colors may appear more consistent between the application and Premiere Pro if you prepare images in a video-friendly color space, such as sRGB or NTSC RGB.

Importing Photoshop and Illustrator files

You can import files from Adobe Photoshop 3.0 or later, or from Adobe Illustrator. You can control how layered files are imported. Empty (transparent) areas of nonflattened files are transparent when imported into Premiere Pro, because the transparency is stored as an alpha channel. This lets you import graphics and superimpose them over clips in other tracks with no extra effort.

You can import layered Photoshop files either with selected layers imported as individual clips into a bin, with selected layers imported as individual clips into a bin and sequence, or with selected layers merged into a single video clip.

Also, you can import Photoshop files that contain video or animations if they are saved from Photoshop in timeline animation mode.

Note:

Individual layers moved from a Photoshop composition into a Premiere Pro project may not behave as expected.

Import a layered Photoshop file

When you import a layered file saved in Photoshop file formats, you can choose how to import the layers in the Import Layered File dialog box.

Note:

Some Photoshop layer attributes aren’t supported, such as special blending modes and the Knockout option. For best results, use basic transparency and opacity in Photoshop. Adobe Premiere Pro does support most Photoshop blending modes.

Premiere Pro imports attributes that were applied in the original file, including position, opacity, visibility, transparency (alpha channel), layer masks, adjustment layers, common layer effects, layer clipping paths, vector masks, and clipping groups. Photoshop exports a white background as opaque white, whereas it exports a checkerboard background as a transparent alpha channel when exporting to a format that supports alpha channels.

Importing layered Photoshop files makes it easy to use graphics created in Photoshop. When Premiere Pro imports Photoshop files as unmerged layers, each layer in the file becomes an individual clip in a bin. Each clip’s name consists of the layer name followed by the name of the file that contained it. Each layer is imported with the default duration you select for still images in Preferences.

You can import Photoshop files containing video or animations like any other Photoshop file. Since each layer is imported at the default still-image duration, the imported video or animation may play back at a speed different from that of its source in the Photoshop file. To make the speed match, change the still image default duration before importing the Photoshop file. For example, if the Photoshop animation was created at 30 fps and the Premiere Pro sequence frame rate is 30 fps, set the still image default duration in Premiere Pro to 30 frames in Preferences.

The options you select in the Import Layered File dialog box determine how the layers in the video or animation are interpreted on import into Premiere Pro.

From the Import dialog box, when you select a Photoshop file containing layers for import, the Import Photoshop Document dialog box opens. The Import As menu gives you these options for ways to import the file:

Merge All Layers

Merges all layers, importing the file into Premiere Pro as a single flattened PSD clip.

Merged Layers

Merges only the layers you select into Premiere Pro as a single, flattened, PSD clip.

Individual Layers

Imports only the layers you select from the list into a bin containing one clip for each source layer.

Sequence

Imports only the layers you select, each as a single clip. Premiere Pro also creates a sequence containing each clip on a separate track, and deposits all these into their own bin in the Project panel. Choosing Sequence allows you to select one of the following options from the Footage Dimensions menu:

  • Document Size Changes the frame size of the clips to match the frame size specified in the Sequence Settings dialog box.

  • Layer Size Matches the frame size of the clips to the frame size of their source layers in the Photoshop file.

Note:

When you import one layer as a single clip, its name in the Project panel consists of the layer name followed by the original filename.

Importing Illustrator images

You can import an Adobe Illustrator still-image file directly into a Premiere Pro project. Premiere Pro converts path-based Illustrator art into the pixel-based image format used by Premiere Pro, a process known as rasterization. Premiere Pro automatically anti-aliases, or smooths, edges of the Illustrator art. Premiere Pro also converts all empty areas into an alpha channel, so that empty areas become transparent.

If you want to define the dimensions of the Illustrator art when it is rasterized, use Illustrator to set crop marks in the Illustrator file. For information about setting crop marks, see Illustrator Help.

Even though the layers in Illustrator are merged in Premiere Pro you can edit the layers by selecting the clip and choosing Edit > Edit Original.

Import images as an image sequence

You can import an animation contained in a single file, such as an animated GIF. You can also import a sequence of still-image files, such as a TIFF sequence, and automatically combine them into a single video clip; each still image becomes one frame of video. Importing a sequence is useful for animations exported as an image sequence by applications like After Effects. The images in the series cannot include layers. For information on layers and flattening, see the application’s documentation.

  1. Set the framerate for the still-image sequence. Select Edit > Preferences > Media (Windows), or Premiere Pro > Preferences > Media (Mac OS). Then, select a framerate from the Indeterminate Media Timebase menu. Click OK.

  2. Make sure that each still-image filename contains an equal number of digits at the end and has the correct file extension—for example, file000.bmp, file001.bmp, and so forth.
  3. Choose File > Import.
  4. Locate and select the first numbered file in the sequence, select Image Sequence, and click Open (Windows) or Import (Mac OS). When Image Sequence is selected, Premiere Pro interprets each of the numbered files as a single frame in a video clip.

Resizing imported images

Imported images usually have a higher resolution than imported videos, so they appear cropped when viewed on the Timeline in Premiere Pro.

You can individually adjust the scale of the clips to match the sequence frame size. Or you can use the Set to Frame Size command to quickly resize the image.

When you use the Set To Frame Size command, the native pixel resolution of the image is preserved, letting you see the sharpest resolution when you zoom in on an image.

  1. Right-click (Windows) or Control-click (Mac OS) an image in a Timeline.

You can select multiple images in the Timeline at once by pressing Shift and clicking the images.

  1. Select Set To Frame Size.

When you select the Set To Frame Size command, the Scale To Frame Size setting is toggled off for improved playback performance.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy