用户指南 取消(C)

创建 PDF 索引

  1. Acrobat 用户指南
  2. Acrobat 简介
    1. 从桌面、移动设备和 Web 访问 Acrobat
    2. Acrobat 的新增功能
    3. 键盘快捷键
    4. 系统要求
  3. 工作区
    1. 工作区基础知识
    2. 打开和查看 PDF
      1. 打开 PDF
      2. 导览 PDF 页面
      3. 查看 PDF 首选项
      4. 调整 PDF 视图
      5. 启用 PDF 缩略图预览
      6. 在浏览器中显示 PDF
    3. 使用联机存储帐户
      1. 从 Box 访问文件
      2. 从 Dropbox 访问文件
      3. 从 OneDrive 访问文件
      4. 从 SharePoint 访问文件
      5. 从 Google Drive 访问文件
    4. Acrobat 和 macOS
    5. Acrobat 通知
    6. PDF 中的网格、参考线和测量
    7. PDF 中的亚洲文本、古斯拉夫文本和从右至左文本
  4. 创建 PDF
    1. PDF 创建概览
    2. 使用 Acrobat 创建 PDF
    3. 使用 PDFMaker 创建 PDF
    4. 使用 Adobe PDF 打印机
    5. 将网页转换为 PDF
    6. Creating PDFs with Acrobat Distiller
    7. Adobe PDF 转换设置
    8. PDF 字体
  5. Editing PDFs
    1. 编辑 PDF 中的文本
    2. 编辑 PDF 中的图像或对象
    3. 旋转、移动、删除和重新编号 PDF 页面
    4. 编辑扫描的 PDF
    5. 增强使用移动设备摄像头拍摄的文档照片
    6. 优化 PDF
    7. PDF 属性和元数据
    8. PDF 中的链接和附件
    9. PDF 图层
    10. PDF 中的页面缩略图和书签
    11. 动作向导 (Acrobat Pro)
    12. 转换为网页的 PDF
    13. 为演示文稿设置 PDF
    14. PDF 文章
    15. 地理空间 PDF
    16. 将动作和脚本应用于 PDF
    17. 更改添加文本的默认字体
    18. 从 PDF 中删除页面
  6. 扫描和 OCR
    1. 将文档扫描为 PDF
    2. 增强文档照片
    3. 对使用 Acrobat 进行扫描时出现的扫描仪问题进行疑难解答
  7. 表单
    1. PDF 表单基础知识
    2. 在 Acrobat 中从头开始创建表单
    3. 创建和分发 PDF 表单
    4. 填写 PDF 表单
    5. PDF 表单域属性
    6. 填写和签名 PDF 表单
    7. 在 PDF 表单中设置动作按钮
    8. 发布交互 PDF Web 表单
    9. PDF 表单域基础知识
    10. PDF 条形码表单域
    11. 收集和管理 PDF 表单数据
    12. 关于表单追踪器
    13. PDF 表单帮助
    14. 使用电子邮件或内部服务器将 PDF 表单发送给收件人
  8. 合并文件
    1. 将多个文件组合或合并为单个 PDF
    2. 旋转、移动、删除和重新编号 PDF 页面
    3. 向 PDF 中添加页眉、页脚以及 Bates 编号
    4. 裁剪 PDF 页面
    5. 向 PDF 中添加水印
    6. 向 PDF 中添加背景
    7. 处理 PDF 包中的组件文件
    8. 发布并共享 PDF 包
    9. PDF 包概览
    10. 创建和自定义 PDF 包
  9. 共享、审阅和添加注释
    1. 在线共享和追踪 PDF 文件
    2. 使用编辑标记文本
    3. 准备 PDF 审阅
    4. 开始 PDF 审阅
    5. 在 SharePoint 或 Office 365 站点上托管共享的审阅
    6. 参与 PDF 审阅
    7. 向 PDF 中添加注释
    8. 向 PDF 中添加图章
    9. 审批工作流程
    10. 管理注释 | 查看、回复、打印
    11. 导入和导出注释
    12. 追踪和管理 PDF 审阅
  10. 保存和导出 PDF
    1. 保存 PDF
    2. 将 PDF 转换为 Word
    3. 将 PDF 转换为 JPG
    4. 将 PDF 转换或导出为其它文件格式
    5. PDF 导出的文件格式选项
    6. 重新使用 PDF 内容
  11. 安全性
    1. PDF 的增强的安全性设置
    2. 使用密码保护 PDF
    3. 管理数字身份证
    4. 使用证书保护 PDF
    5. 打开受保护的 PDF
    6. 从 PDF 中删除敏感内容
    7. 设置 PDF 的安全性策略
    8. 为 PDF 选择安全性方法
    9. 打开 PDF 时发生安全警告
    10. 使用 Adobe Experience Manager 保护 PDF
    11. 适用于 PDF 的“受保护视图”功能
    12. Acrobat 和 PDF 的安全性概览
    13. PDF 中 JavaScript 的安全性风险
    14. 附件作为安全风险
    15. Allow or block links in PDFs
  12. 电子签名
    1. 签名 PDF 文档
    2. 将您的签名捕捉到移动版应用程序中并应用在各个地方
    3. 发送文档以供电子签名
    4. 关于证书签名
    5. 基于证书的签名
    6. 验证数字签名
    7. Adobe Approved Trust List
    8. 管理可信任身份
  13. 打印
    1. 基本 PDF 打印任务
    2. 打印小册子和 PDF 包
    3. 高级 PDF 打印设置
    4. 打印为 PDF
    5. 打印彩色 PDF (Acrobat Pro)
    6. 按照自定义大小打印 PDF
  14. 辅助工具、标签和重排
    1. 创建和验证 PDF 辅助工具
    2. PDF 中的辅助工具功能
    3. PDF 的“阅读顺序”工具
    4. 阅读具有重排和辅助工具功能的 PDF
    5. 使用“内容”和“标签”面板编辑文档结构
    6. 创建具有辅助工具的 PDF
  15. 搜索和索引
    1. 创建 PDF 索引
    2. 搜索 PDF
  16. 多媒体和 3D 模型
    1. 在 PDF 中添加音频、视频和交互对象
    2. 向 PDF 中添加 3D 模型 (Acrobat Pro)
    3. 在 PDF 中显示 3D 模型
    4. 与 3D 模型进行交互
    5. 测量 PDF 中的 3D 对象
    6. 在 PDF 中设置 3D 视图
    7. 启用 PDF 中的 3D 内容
    8. 向 PDF 中添加多媒体
    9. 在 PDF 中为 3D 设计添加注释
    10. 在 PDF 中播放视频、音频和多媒体格式
    11. 将注释添加到视频
  17. 印刷制作工具 (Acrobat Pro)
    1. Print production tools overview
    2. 打印机标记和调整细线
    3. 预览输出
    4. 透明度拼合
    5. 颜色转换和油墨管理
    6. 陷印颜色
  18. 印前检查 (Acrobat Pro)
    1. 符合 PDF/X、PDF/A 和 PDF/E 规范的文件
    2. 印前检查配置文件
    3. 高级印前检查
    4. 印前检查报告
    5. 查看印前检查结果、对象和资源
    6. PDF 中的输出方法
    7. 使用“印前检查”工具更正问题区域
    8. 使用快捷批处理或印前检查动作自动分析文档
    9. 使用“印前检查”工具分析文档
    10. “印前检查”工具中的其他检查
    11. 印前检查库
    12. 印前检查变量
  19. 色彩管理
    1. 保持颜色一致
    2. 颜色设置
    3. 对文档进行色彩管理
    4. 处理色彩配置文件
    5. 了解色彩管理

创建和管理 PDF 中的索引

您可以通过在文档中嵌入词的索引来减少搜索长 PDF 的时间。比起搜索文档,Acrobat 搜索索引的速度会更快。嵌入索引包括在已分发或已共享的 PDF 副本中。用户使用嵌入索引搜索 PDF 和他们不使用嵌入索引搜索完全一样;不需要额外的步骤。

注意:

在 Acrobat 和 Acrobat Reader 2018 年 12 月版中,不再使用 PDF 中的嵌入索引来进行搜索。如果您仍希望为搜索启用索引,请参阅如何为搜索启用 PDF 中的嵌入索引

添加索引到 PDF

  1. 在 Acrobat 中打开文档,选择工具 > 索引

    “索引”工具集将显示在辅助工具栏中。

  2. 在辅助工具栏中,单击管理嵌入索引

  3. 在“管理嵌入索引”对话框中,单击嵌入索引

  4. 阅读出现的消息,并单击

    注意:

    在 Outlook 和 Lotus Notes 中,当您将电子邮件或文件夹转换为 PDF 时可以选择嵌入索引。特别建议针对文件夹包含很多电子邮件时使用。

更新或删除 PDF 中的嵌入索引

  1. 选择工具 > 索引

    “索引”工具集将显示在辅助工具栏中。

  2. 在辅助工具栏中,单击管理嵌入索引

  3. 单击更新索引删除索引

关于编录功能 (Acrobat Pro)

您可以将特定的一组 PDF 定义为“编录”,并为整个集合的文档创建统一的索引。当用户搜索已编录的 PDF 的特定信息时,索引可以加快搜索处理。

当在 CD 上分发集合时,您可以在 PDF 中包含索引。

您可以编录罗马、中文、日文或韩文字符的文档。您可以编录的项目包括文档文本、注释、书签、表单域、标签、对象和文档元数据、附件、文档信息、数字签名、图像 XIF(扩展图像文件格式)元数据和自定义文档信息。

准备 PDF 来构建索引 (Acrobat Pro)

首先,请创建文件夹来将所需构建索引的 PDF 包含到其中。所有 PDF 应该内容和电子功能完整,例如链接、书签和表单域。如果要构建索引的文件包含扫描文档,请确保文本可搜索。将长文档分割成短文档,按章节分割文档,可以增加搜索效率。您还可以添加信息到文件的文档属性来增加文件的可搜索性。

在您为文档集合构建索引之前,您必须在硬盘驱动器或网络服务器卷上设置文档结构并验证跨平台文件名。在跨平台搜索中,文件名可能会被截断而难以检索。要防止这种问题,请注意以下几点:

  • 使用 MS-DOS 文件命名规则(8 个或 8 个以下字符的文件名加 3 个字符的扩展名)重命名文件、文件夹和索引(尤其在您要使用 ISO 9660 格式的 CD-ROM 光盘发送文档集合和索引时)。

  • 删除文件和文件夹名称中的扩展字符,例如重音字符和某些非英文字符。(“编录”功能使用的字体不支持字符编码 133 到 159。)

  • 对于将由 Mac OS 用户搜索的索引,不要使用多层嵌套文件夹或者大于 256 个字符的路径名称。

  • 如果您在 OS/2 LAN 服务器中使用 Mac OS,请配置 IBM®LAN Server Macintosh (LSM) 来强制执行 MS-DOS 文件命名规则,或者仅为 FAT(文件分配表)卷构建索引。(HPFS [高性能文件系统] 卷可包含不可检索的长文件名。)

    如果文档结构中包含您不想构建索引的子目录,可以在构建索引过程中排除它们。

添加元数据到文档属性 (Acrobat Pro)

要使 PDF 便于搜索,您可以添加被称为“元数据”的文件信息到文档属性。(您可以通过选择文件 > 属性,然后单击说明标签来查看当前打开的 PDF 的属性。)

当添加文档属性数据时,请考虑以下建议:

  • 请在“标题”域中使用说明准确的标题。文档的文件名会显示在“搜索结果”对话框中。

  • 请总是为相似信息使用相同选项(栏位)。例如,为文档添加重要项目时,不要在某些文档中添加到主题选项,而在其他文档中则添加到关键字选项。

  • 请为相同的信息使用单一、统一的项目。例如,不要为一些文档使用生物学,而为另一些使用生命科学

  • 请使用作者选项来标识文档的负责方。例如,雇佣方案文档的作者可能是“人力资源部”。

  • 如果您使用文档部件号,请将它们添加为关键字。例如,通过将 doc#=m234 添加到关键字,可以在数百份有关某一特定主题的文档中指定这份特定的文档。

  • 请单独或同时使用主题关键字选项来按类型对文档分类。例如,您可以使用状态报告 告作为“主题”项目,并使用每月每周作为单个文档的“关键字”项目。

    如果对 Adobe PDF 非常熟悉,您可以在创建索引时定义自定义数据域,例如“文档类型”、“文档编号”和“文档标识符”。这项建议仅适用于高级用户,而且未在 Acrobat 完整帮助中加以说明。

为集合创建索引 (Acrobat Pro)

当您构建新的索引时,Acrobat 创建“.pdx”扩展名的文件和新的支持目录,其中包含了一个或多个“.idx”扩展名的文件。IDX 文件包含索引条目。所有这些文档必须对要搜索索引的用户可用。

  1. 选择工具 > 索引

    “索引”工具集将显示在辅助工具栏中。

  2. 在辅助工具栏中,单击编录全文索引

    此时将显示“编录”对话框。

  3. 编录对话栏中,单击新建索引

    此时将显示“新建索引定义”对话框。

    Acrobat 中的“新建索引定义”
    “新建索引定义”对话框。

  4. 索引标题中,键入索引文件名。

  5. 索引描述中,键入一些关于索引类型或其用途的词语。

  6. 单击选项,选择您希望应用到索引的任意高级选项,然后单击确定

    Acrobat 中的“选项”对话框
    在“选项”对话框中,您可以为新索引指定高级选项。

  7. 包含这些目录下,单击添加,选择要构建索引的部分或全部 PDF 文件所在的文件夹,然后单击确定。要添加其它文件夹,请重复此步骤。

    注意:

    任何包含文件夹下的子文件夹也会包含在构建索引的处理中。如果您不打算移动索引或任何文档集合中项目,您就可以从多个服务器或磁盘驱动添加文件夹。

  8. 排除这些子目录下,单击添加,然后选择不希望构建索引的 PDF 文件所在的任何嵌套文件夹。单击确定,然后根据需要重复此步骤。

  9. 审阅您的选择。要编辑将要包括或排除的文件夹列表,请选择要更改的文件夹,然后单击删除

  10. 单击构建,然后指定索引文件的位置。单击保存,然后:

    • 当索引构建完成后,单击关闭

    • 单击停止以取消索引构建过程。

    注意:

    如果您停止索引构建过程,则您无法再重新开始该索引构建会话,但是您无需重复上述工作。选项和文件夹选择仍然完整保留。您可以单击“打开索引”选择部分完成的索引,进行修改。

    注意:

    如果在“包含这些目录”和“排除这些子目录”选项中,长路径名被截断,请将指针悬停到每个省略号 (...) 上方,直到出现工具提示,其中显示了包含或排除的文件夹的完整路径。

“索引选项”对话框

不包含数字

选择本选项可以从索引中排除文档中出现的全部数字。排除数字可以明显减少索引大小,从而加快搜索速度。

添加 ID 到 Adobe PDF v1.0 文件

如果您的集合中包含使用 Acrobat 2.0 之前的应用程序(不会自动添加识别数字)创建的 PDF,请选择本选项。当长的 Mac OS 文件名在转换为 MS-DOS 文件名过程中被缩短时,需要使用 ID 数字。Acrobat 2.0 或更高版本会自动添加标示符。

搜索时对已更改的文档不要进行警告

如果未选择该选项,当您搜索自上次构建索引已更改的文档时,会自动出现警告消息。

自定义属性

使用本选项可在索引中包含自定义文档属性;只有要构建索引的 PDF 中已存在的自定义文档属性会被构建索引。键入属性,从“类型”菜单选择选项,然后单击“添加”。当您搜索生成的索引时,这些属性会作为搜索选项显示在“搜索 PDF”窗口的附加条件弹出菜单中。例如,如果您输入自定义属性“文档名称”,并从“类型”菜单选择字符串属性,搜索索引的用户即可以在自定义属性中搜索,方法是从“使用这些附加条件”菜单中选择“文档名称”。

注意:

当您使用 Microsoft Office 应用程序(在 PDFMaker 应用程序中选中了“转换文档信息”选项)创建自定义域时,该域会传输到您创建的任何 PDF 中。 

XMP 栏位

使用本选项可包含自定义 XMP 栏位。自定义 XMP 栏位将被构建索引并且出现在附加条件菜单中以便在选择的索引中搜索。

忽略单词

用于从索引搜索结果中排除特定的单词(最大 500)。键入单词,单击“添加”,如果需要请重复本步骤。排除单词可使索引缩小 10% 到 15%。一个排除单词最多可以包含 128 个字符并区分大小写。

注意:

要防止用户试图搜索包含这些单词的短语,请在“编录自述”文件中列出没有构建索引的单词。

结构标签

使用本选项可使特定的页元素标签节点在含有标签逻辑结构的文档中可搜索。

注意:

“自定义属性”、“忽略单词”和“结构标签”设置仅应用于当前索引。要应用这些设置到您创建的所有索引,您可以在“首选项”对话框“编录”面板中更改“自定义属性”、“忽略单词”和“结构标签”的默认设置。 

编录自述文件 (Acrobat Pro)

通常,创建独立的自述文件并将其与索引放在同一文件夹中是比较好的方法。本自述文件可以包含关于索引的详细信息,例如:

  • 文档索引类型。

  • 支持的搜索选项。

  • 遇到问题时的联系人或联系电话号码。

  • 排除在索引之外的数字或单词列表。

  • 在基于 LAN 的索引中包含文档的文件夹列表,或在基于磁盘索引中的文档列表。您可能还要包含每个文件夹或文档内容的简要说明。

  • 每个文档的相应值的列表,如果您指定了“文档信息”域值。

    如果编录含有的文档数量非常大,请考虑包含显示每个文档值的表。该表可以包含在自述文件中,或为独立文档。当生成索引时,您可以使用该表来保持一致性。

修改索引(Acrobat Pro)

您可以更新、重建或清空现有的索引。

  1. 选择工具 > 索引

    “索引”工具集将显示在辅助工具栏中。

  2. 在辅助工具栏中,单击编录全文索引

    此时将显示“编录”对话框。

  3. 编录对话框中,单击打开索引

  4. 找到并选择索引的索引定义文件 (PDX),然后单击打开

  5. 如果索引是使用 Acrobat 5.0 或更低版本创建的,请选择创建副本来创建新索引(不覆盖先前版本),或者选择覆盖旧索引来覆盖先前的索引。

  6. 索引定义对话框中,根据需要进行更改,然后单击您希望 Acrobat 执行的功能:

    构建

    使用现有信息新建 IDX 文件,并通过添加新项目并将更改的或过期的项目标记为无效来进行更新。如果您做了大量的更改,或者重复使用本选项,而不是新建索引,搜索时间可能会增加。

    重建

    新建索引,替换现有的索引文件夹和其内容(IDX 文件)。

    清空

    删除索引内容(IDX 文件),而不删除索引文件本身(PDX)。

“编录”首选项 (Acrobat Pro)

您可以为构建索引设置首选项,以后它将应用于您构建的所有索引。您可以在索引定义过程中选择不同设置来使个别索引忽略其中的某些首选项。

首选项对话框中的类别下,选择编录。许多选项的描述与索引构建工程中的完全一致。

注意:

如果您在为文档构建索引时不想将长的 PDF 文件名更改为 MS-DOS 文件名,“在文件夹上强制使用 ISO 9660 规范”将十分有用。尽管如此,您仍然必须使用 MS-DOS 文件命名规则来命名文件夹名称(不超过 8 个字符),但文件名可以不使用此规则。

定时更新索引 (Acrobat Pro)

使用“编录”功能和编录批 PDX 文件 (.bpdx) 来安排自动建立,重建,更新和清空索引的时间和频率。BPDX 文件是一个文本文件,它包含平台相关的编录索引文件路径和标记的列表。您可以使用日程安排应用程序(如 Windows Scheduler),将 BPDX 文件显示在 Acrobat 中。Acrobat 会按照 BPDX 文件中的标记重新创建索引。

注意:

要使用 BPDX 文件,请在“编录”下的“首选项”对话框中,选择“允许运行编录批处理文件 (.bpdx)”。

移动集合及其索引 (Acrobat Pro)

您可以在本地磁盘驱动上生成和测试建立索引的文档集合,然后将完成的文档集合移动到网络服务器或磁盘上。索引定义包含索引定义文件(PDX)相对于含有已构建索引文档的文件夹的相对路径。如果这些相对路径未更改,您无须在移动已构建索引文档集合后重建索引。如果 PDF 文件和含有已构建索引文档的文件夹在同一文件夹中,您只需移动该文件夹即可保持相对路径。

如果相对路径被更改,您必须在移动已构建索引文档集合后新建索引。但是,您仍然可以使用原始的 PDX 文件。要使用原始的 PDF 文件,首先请移动已构建索引的文档。然后将 PDF 文件复制到您要新建索引的文件夹,按照需要编辑包含目录和排除子目录列表。

如果在磁盘或服务器卷上索引与其对应的集合任何部分分开放置,移动集合或索引都将使索引无效。如果您打算将文档集合移动到另一网络位置或 CD 上,请在集合同一位置创建和构建索引。

Adobe 徽标

登录到您的帐户