Procesamiento automático con Aerender

El archivo ejecutable aerender.exe es un programa que cuenta con una interfaz de línea de comandos con la cual se puede automatizar el procesamiento. El archivo ejecutable se ubica en la misma carpeta que la aplicación principal de After Effects. Las ubicaciones predeterminadas de este archivo son:

  • Windows: \Archivos de programa\Adobe\Adobe After Effects CC\Support Files

  • Mac OS: /Aplicaciones/Adobe After Effects CC

La aplicación aerender se puede utilizar para realizar operaciones de procesamiento en varios equipos como parte de una granja de procesamiento, o bien, se puede emplear en un solo equipo como parte de una operación por lotes.

Se puede utilizar el programa introduciendo el comando aerender en la línea de comandos (o en una secuencia de comandos por lotes), seguido por una serie de argumentos adicionales. Algunos de los argumentos son opciones muy sencillas que no tienen argumentos por sí mismas (por ejemplo, -reuse), mientras que otras incluyen argumentos propios (como -project project_path).

Nota:

Introduzca el comando aerender -help para mostrar la información de uso.

La versión y el número de la publicación de la aplicación se escriben la salida estándar (stdout).

El procesamiento puede realizarse con una instancia de After Effects que ya esté en ejecución o mediante una instancia iniciada recientemente. De manera predeterminada, aerender inicia una nueva instancia de After Effects, aunque ya haya una abierta. Si desea utilizar la instancia que ya tiene abierta, utilice el argumento –reuse.

Este comando de ejemplo indica a After Effects que procese los fotogramas del 1 al 10 de Composition_1 de project_1.aep en una secuencia numerada de archivos de Photoshop utilizando un procesamiento con múltiples equipos:

aerender -project c:\projects\project_1.aep -comp "Composition_1" -s 1 -e 10 
-RStemplate "Multi-Machine Settings" -OMtemplate "Multi-Machine Sequence" 
-output c:\output\project_1\frames[####].psd

Para procesar solo Composition_1 en un archivo especificado, introduzca este comando:

aerender -project c:\projects\project_1.aep -comp "Composition_1" -output c :\output\project_1\project_1.avi

Para procesar todos los elementos de la cola de procesamiento con los ajustes actuales del archivo de proyecto, introduzca el siguiente comando:

aerender -project c:\projects\project_1.aep

Argumento

Descripción

–help

Imprime el mensaje de uso.

–versión

Muestra el número de versión de aerender en la consola. No realiza el procesamiento.

–v verbose_flag

verbose_flag especifica el tipo de mensajes enviados:

ERRORS: Informa únicamente de errores y problemas graves.

ERRORS_AND_PROGRESS: (predeterminado) Informa de errores y del progreso del procesamiento.

–reuse

Reutiliza la instancia de After Effects que está actualmente en ejecución (si la encuentra) para llevar a cabo el procesamiento. Cuando se emplea una instancia que ya estaba en ejecución, aerender guarda las preferencias en el disco cuando finaliza el procesamiento, pero no sale de After Effects. Si no se emplea este argumento, aerender inicia una nueva instancia de After Effects, aunque ya haya una en ejecución. Cierra la instancia cuando termina el procesamiento y no guarda las preferencias.

–mem_usage image_cache_percentmax_mem_percent

image_cache_percent especifica el porcentaje máximo de memoria utilizada para guardar en la caché las imágenes y el material de archivo procesados. max_mem_percent especifica el porcentaje total de memoria que utilizará After Effects. Para ambos valores, si la RAM instalada es inferior a la cantidad especificada (n gigabytes), el valor es un porcentaje de la RAM instalada y, de lo contrario, sería un porcentaje de n. El valor de n es 2 GB para Windows de 32 bits, 4 GB para Windows 64 bits y 3,5 GB para Mac OS.

–project project_path

project_path es una ruta de archivos o URI que especifica el archivo de proyecto que se va a abrir. Si no se utiliza este argumento, aerender trabajar con el proyecto que haya abierto en ese momento. Si no se especifica ningún proyecto y tampoco hay ninguno abierto, se produce un error.

–comp comp_name

comp_name especifica la composición que debe procesarse. Si la composición ya está en la cola de procesamiento, se procesa la primera instancia de esa composición que se encuentre en la cola. Si la composición está en el proyecto pero no en la cola de procesamiento, se agrega a la cola y se procesa. Si no se utiliza este argumento, aerender procesa toda la cola. En ese caso, solo se emplean los argumentos –project, –log, –output, –v, –mem_usagey –close. Todos los demás se omiten.

–s start_frame

start_frame es el primer fotograma que se va a procesar. Si no se emplea este argumento, aerender utiliza el primer fotograma del archivo.

–e end_frame

end_frame es el último fotograma que se va a procesar. Si no se especifica este argumento, aerender utiliza el último fotograma del archivo.

–i increment

increment es el número de fotogramas que se avanza antes de procesar otro fotograma. Con el valor 1 (predeterminado) se aplica el procesamiento normal a todos los fotogramas. Valores superiores significan que se procesa un fotograma y se utiliza increment veces en la salida y, a continuación, se saltan increment fotogramas para comenzar el ciclo de nuevo. Los valores más altos dan lugar a procesamientos más rápidos pero el resultado es un movimiento más agitado.

–OMtemplate output_module_template

output_module_template es el nombre de una plantilla que se aplicará al módulo de salida. Si la plantilla no existe, con el uso de este argumento se produce un error. Si no se emplea este argumento, aerender utilizar la plantilla que ya se ha definido para el módulo de salida.

–RStemplate render_settings_template

render_settings_template es el nombre de una plantilla que se aplicará al elemento de procesamiento. Si la plantilla no existe, con el uso de este argumento se produce un error. Si el argumento no se utiliza, aerender utiliza la plantilla de procesamiento ya definida para el procesamiento.

–output output_path

output_path es una ruta de archivo o URI que especifica el destino del archivo de salida final. Si no se emplea este argumento, aerender utiliza la ruta definida en el archivo del proyecto.

–log log_file_path

log_file_path es una ruta de archivo o URI que especifica la ubicación del archivo de registro. Si no se utiliza este archivo, aerender utiliza la salida estándar (stdout).

–sound sound_flag

Si sound_flag está en ON, se reproduce un sonido cuando finaliza el procesamiento. La opción predeterminada es OFF.

–close close_flag

close_flag especifica si se debe cerrar el proyecto cuando finalice el procesamiento y si se deben guardar los cambios:

DO_NOT_SAVE_CHANGES: (predeterminado) Se cierra el proyecto sin guardar los cambios.

SAVE_CHANGES: Se guardan los cambios y se cierra el proyecto.

DO_NOT_CLOSE: Se deja el proyecto abierto si se está empleando una instancia de After Effects que ya estaba abierta. (Las instancias nuevas de After Effects deben cerrarse siempre al terminar).

-rqindex index_in_render_queue

-rqindex funciona igual que -comp, con la excepción de que no crea automáticamente un elemento de procesamiento a partir de la composición.

-mp

Pueden crearse más procesos para procesar varios fotogramas al mismo tiempo, dependiendo de la configuración del sistema y de los ajustes de las preferencias. (Consulte Preferencias de memoria y multiprocesamiento).

-continueOnMissingFootage

La operación de procesamiento continuará incluso si falta algún elemento de material de archivo de origen.

En su sitio web de secuencias de comando para After Effects, Lloyd Alvarez ofrece una secuencia de comandos que selecciona los elementos de la cola de procesamiento que están listos para procesar y los envía para su procesamiento en segundo plano con aerender.

Procesamiento en red con carpetas de inspección y motores de procesamiento

Utilizando varios equipos conectados a través de una red, se pueden procesar una o más composiciones de un proyecto en una fracción del tiempo que necesitaría un solo equipo. Para el procesamiento en red es necesario copiar el proyecto y los archivos de origen en una carpeta de red y, a continuación, iniciar el procesamiento del proyecto. Una red de sistemas utilizados de forma conjunta para procesar una sola composición se denomina en ocasiones granja de procesamiento.

El procesamiento en granja es el uso de una red de sistemas de forma conjunta para procesar una sola composición. Puede configurarlo para que funcione con versiones de solo procesamiento de After Effects denominadas motores de procesamiento.

Los motores de procesamiento pueden instalarse de la misma forma que la versión completa de la aplicación. Para ejecutar el motor de procesamiento, use el acceso directo del motor de procesamiento de Adobe After Effects en la carpeta Adobe After Effects CC. Para obtener más información, vea la Configuración e instalación de la misma composición.

No se puede utilizar una carpeta de inspección y varios motores de procesamiento para procesar simultáneamente un archivo de película único. Sin embargo, con el procesamiento en granja se pueden utilizar varios motores para procesar una película como una secuencia de archivos de imágenes fijas. Posteriormente se puede utilizar una acción de postprocesamiento para crear un único archivo de película a partir de la secuencia de imágenes fijas. Para obtener más información, consulte Acciones de postprocesamiento.

Consideraciones acerca de la red

Cuando trabaje con varios motores de procesamiento en múltiples sistemas, tenga en cuenta las siguientes directrices:

  • Siempre que sea posible, identifique las carpetas utilizando rutas de archivo absolutas para que se puedan identificar correctamente para todos los motores de búsqueda. Si identifica las carpetas con rutas de archivo absolutas, puede significar asignar unidades de red en una letra de unidad particular para todos los equipos (por ejemplo, H:\renders\watch\). Evite utilizar rutas relativas (por ejemplo, \\renders\watch).

  • Todos los equipos Macintosh que supervisan la carpeta de inspección deben tener un nombre único. Los nombres predeterminados de los equipos a menudo son idénticos, por lo que debería cambiar el nombre de sus equipos para que no utilicen el nombre predeterminado.

  • Asegúrese de que todos los servidores y los clientes (equipos que supervisan la carpeta de inspección) tienen discos duros con nombres únicos.

  • No utilice el mismo equipo para prestar servicio a una carpeta de inspección y para ejecutar After Effects en modo Carpeta de inspección. Utilice un servidor dedicados que sea accesible para todos motores de procesamiento que prestan servicio a la carpeta de inspección.

  • No realice el procesamiento en modo Carpeta de inspección ni lo inicie en la raíz de un volumen o en un carpeta compartida que aparezca como raíz cuando se visualiza desde otro equipo. En su lugar especifique una subcarpeta. Tampoco debe utilizar caracteres ASCII superior ni guiones en los nombres de archivo. En caso de procesamiento en múltiples equipos, After Effects incluye una plantilla de muestreo de varios equipos que se puede utilizar como punto de partida.

Nota:

Al procesar en una red que incluye volúmenes que utilizan diferentes redes o sistemas operativos, como Windows, Mac OS, Novell y UNIX, asegúrese de especificar archivos de salida utilizando una convención de nombres de archivo compatible con todos los volúmenes de procesamiento o de destino.

Consideraciones acerca del proyecto

Asegúrese de que instala todas las fuentes, los efectos y los codificadores (compresores) utilizados en el proyecto en todos los equipos que supervisan la carpeta de inspección. Si un equipo que supervisa la carpeta de inspección no puede encontrar fuentes, efectos o codificadores utilizados en un proyecto, se producirá un error en el procesamiento.

Cuando se instala un motor de procesamiento de After Effects en un equipo, este contiene todos los plugins incluidos en After Effects. Si una composición utiliza un plugin de otro fabricante, este deberá estar presente en todos los sistemas que procesen la composición. Sin embargo, la compatibilidad con el procesamiento en red varía entre los distintos fabricantes de plugins. Antes de configurar una red para procesar efectos creados mediante plugins de terceros, consulte la documentación del plugin o póngase en contacto con el fabricante para obtener respuestas a las siguientes preguntas:

  • ¿El contrato de licencia del plugin permite instalar varias copias en una red para procesamiento?

  • ¿Existe alguna limitación o consejo adicional que se aplique al uso de ese plugin para procesamiento en red?

Consideraciones acerca de la carpeta Recopilar archivos

Cuando se utiliza el comando Archivo > Recopilar archivos, los archivos relacionados con un proyecto se copian en una misma carpeta. Esta carpeta incluye una copia del proyecto, un archivo de control de renderización (RCF) y otros archivos, en función de las opciones que se hayan seleccionado en el cuadro de diálogo Recopilar archivos. Si guarda la carpeta Recopilar archivo en un equipo en red que no sea un servidor, no ejecute un motor de procesamiento en ese equipo. Evite guardar la carpeta Recopilar archivos en un disco local, el nivel raíz de un disco (tal como C: en Windows o el disco duro de Macintosh en Mac OS), o en una carpeta compartida, ya que para cada motor de procesamiento puede significar una ubicación diferente. Todos los motores de procesamiento deben interpretar la ruta de la misma forma.

Nota:

Una vez que los archivos recopilados aparecen en la carpeta de inspección, todos los motores de procesamiento de supervisión iniciarán el procesamiento automáticamente. Si lo prefiere, puede utilizar el comando Recopilar archivos para almacenar composiciones y el material de archivo de origen en una ubicación especificada y, a continuación, iniciar el procesamiento de la carpeta de inspección más adelante. De este modo los proyectos se procesan en orden alfabético en lugar de hacerlo en el orden en el que se guardaron en la ubicación.

Control de dependencias de procesamiento de una carpeta de inspección

Cuando el procesamiento se realiza a través de una red se pueden controlar las dependencias de procesamiento mediante la definición de las opciones de Acción de postprocesamiento. Cuando se definen estas opciones, After Effects confirma que todos los elementos que se deben procesar están preparados y disponibles. Por ejemplo, si un elemento depende de otro para procesarse, y el primero no ha terminado de procesarse o ha recibido un error, el segundo no se procesará.

Este proceso se puede utilizar para procesar una única película QuickTime o AVI desde el procesamiento de una carpeta de inspección. La película se crea en un solo sistema.

Nota:

En este procedimiento se supone que ya ha creado una carpeta de inspección de múltiples sistemas.

  1. En el panel Cola de procesamiento, arrastre el módulo de salida al panel Proyecto. After Effects crea un marcador de posición para la salida de ese elemento.
  2. Vuelva a arrastrar el marcador al panel Cola de procesamiento.
  3. Defina los ajustes de procesamiento y los ajustes del módulo de salida para el marcador, y haga clic en Procesar.

Inicio en el modo carpeta de inspección

El modo carpeta de inspección solo se aplica al procesamiento desde una carpeta del equipo local.

  • Para iniciar After Effects automáticamente en modo carpeta de inspección, guarde un proyecto con el nombre de archivo Watch This Folder.aep. After Effects inspecciona la carpeta que contenga el proyecto al abrir ese proyecto.
  • Para iniciar After Effects en modo carpeta de inspección al arrancar el equipo, cree un método abreviado (MS Windows) o alias (Mac OS) en el proyecto Watch This Folder.aep y muévalo a la carpeta Inicio (MS Windows) o a la carpeta Items de Arranque (Mac OS). After Effects inspecciona la carpeta que contenga el proyecto al abrir ese proyecto.
  • (Solo Windows) Para iniciar After Effects en modo carpeta de inspección desde la línea de comandos, seleccione Inicio > Ejecutar y, a continuación, escriba el comando siguiente (modifique la ruta de la aplicación con el nombre exacto de la carpeta donde se instaló After Effects y sustituya C:\[temp] por la ruta de la carpeta de inspección): "C:\Archivos de programa\Adobe\Adobe After Effects CC\Support Files\afterfx.exe" -wf C:\[temp]

Nota:

Para iniciar el motor de procesamiento de After Effects en lugar de la versión completa de la aplicación, utilice la opción -re con el comando.

Nota:

También puede usar esta línea de comandos en archivos por lotes.

Procesamiento en granja: procesamiento de una secuencia de imágenes fijas en varios sistemas

El procesamiento en granja es el uso de una red de sistemas de forma conjunta para procesar una sola composición. Puede configurarlo para que funcione con versiones de solo procesamiento de After Effects denominadas motores de procesamiento. El procesamiento en granja ayuda a reducir el tiempo que un solo sistema tarda en exportar una composición. Se pueden emplear varios sistemas y varias copias de After Effects para procesar una composición en una red. Se pueden emplear varios sistemas para procesar solo secuencias de imágenes fijas, pero no se pueden emplear para procesar una única película.

Aharon Rabinowitz incluye un tutorial en vídeo en el sitio web de Creative COW, que explica los pasos necesarios para procesar una secuencia de imagen fija con varios sistemas.

Configurar la red

Siga el procedimiento que se muestra en la imagen para comprender los requisitos de configuración de la red.

Configuración de procesamiento en red
A. Sistema con una versión completa de After Effects B. Guarda un proyecto y todos sus archivos fuente en una carpeta de un servidor C. Sistemas con el motor de procesamiento instalado D. Abre el proyecto, procesa una secuencia de fotogramas fijos y guarda el resultado en una carpeta de salida designada en el servidor 

Puede utilizar varios equipos para el procesamiento. En general, como más equipos utilice, más rápido será el procesamiento. Sin embargo, si se utilizan demasiados sistemas en una red ocupada, el tráfico de la red puede retardar todo el proceso. Se puede detectar una desaceleración de la red mediante la observación del tiempo dedicado a la etapa Compresión y escritura en la sección Procesamiento actual del panel Cola de procesamiento.

Nota:

Adobe no proporciona asistencia técnica para configuración general de la red; consulte con el administrador de la red.

Procesamiento de una secuencia de imágenes fijas con varios sistemas

Aspectos importantes en el proceso de una secuencia de imágenes fijas con varios sistemas: 

  • Para procesar una secuencia de imágenes fijas con varios sistemas, puede utilizar el número de sistemas que desee. 
  • Al procesar una secuencia de imágenes fijas con varios sistemas, el procesamiento comienza aproximadamente al mismo tiempo en cada copia de After Effects. 
  • Si los elementos de procesamiento en cola están establecidos en Omitir archivos existentes (una opción de configuración del procesamiento), el proceso omite el fotograma o fotogramas existentes en curso. 
  • Varios sistemas pueden procesar el proyecto simultáneamente, escribiendo la secuencia de imágenes fijas en una misma carpeta.

Para procesar una secuencia de imágenes fijas, siga estos pasos:

  1. Instale After Effects en todos los sistemas utilizados para procesar el proyecto. Asegúrese de que están instaladas las mismas fuentes en todos los sistemas.

    Nota:

    No se deben compartir plugins en una red. Asegúrese de que dispone de una copia de la carpeta de plugins en todos los sistemas que están ejecutando After Effects. Cuando esté utilizando plugins de terceros, asegúrese de que están disponibles los mismos plugins en todos los sistemas y que tiene suficientes licencias para los plugins.

  2. Abra el proyecto en un sistema y seleccione Composición > Añadir a la cola de procesamiento.

  3. En el panel Cola de procesamiento, especifique un formato en el área Módulo de salida y seleccione una carpeta en el área Salida a. Esta carpeta debe estar disponible para los todos sistemas que estén realizando procesamiento.

  4. En el panel Cola de procesamiento, seleccione Omitir archivos existentes (permitir procesamiento en varios sistemas) en la sección Ajustes de procesamiento para evitar que varios sistemas procesen los mismos fotogramas. Si utiliza Omitir archivos existentes, no use varios módulos de salida para un elemento de procesamiento.

  5. Guarde el proyecto en el sistema en el que lo haya abierto en el paso 2.
  6. En cada sistema que esté realizando procesamiento, abra y guarde el proyecto. De este modo se garantiza que After Effects registre las nuevas rutas relativas en todos los sistemas en el paso siguiente.
  7. A menos que la red pueda gestionar transferencias de archivos grandes rápidamente, copie el archivo del proyecto y todo el material de archivo de origen en cada sistema que esté realizando el procesamiento.
  8. Abra el panel Cola de procesamiento en cada sistema y haga clic en Procesar. No es necesario iniciar el procesamiento en todos los sistemas simultáneamente, pero para asegurarse de que la carga de trabajo sea igual, inícielos aproximadamente al mismo tiempo. Cuando cada sistema termina de procesar un fotograma, After Effects busca en la carpeta Salida el siguiente fotograma sin procesar e inicia de nuevo el procesamiento.

  9. Puede detener e iniciar un sistema en cualquier momento. Sin embargo, si detiene un sistema y no lo vuelve a iniciar, es posible que no se termine de procesar el fotograma que estaba en curso. Si se detienen uno o varios sistemas durante el procesamiento, iniciar uno de ellos asegura que se procesen todos los fotogramas de la secuencia.

Ejecutar Aerender en el modo sin derechos de autor

After Effects CS5.5 tuvo que serializarse en equipos de solo procesamiento debido a problemas con las licencias. En After Effects CS6 y versiones posteriores, ahora puede ejecutar Aerender o utilizar las carpetas de inspección en el modo sin derechos de autor, para lo que no se requiere la serialización.

Para asegurarse de que After Effects se está ejecutando en el modo sin derechos de autor, coloque un archivo vacío llamado ae_render_only_node.txt en la siguiente ubicación:

  1. Instale After Effects en el equipo de solo procesamiento.

    • Ubicaciones de Mac:

      /Usuarios/<username>/Documentos/

      /Usuarios/Compartido/Adobe/

    • Ubicaciones de Windows:

      C:\Usuarios\<username> \Documentos

      C:\Usuarios\Public\Documentos\Adobe

Ajustes de segmentos

Los ajustes de segmentos se encuentran en la categoría de preferencias de salida.

Nota:

Seleccione Edición > Preferencias > Salida (MS Windows) o After Effects > Preferencias > Salida (Mac OS).

After Effects puede procesar archivos de película y secuencias en segmentos que se limitan a un número especificado de archivos o mediante tamaño de archivo. Esto resulta útil a la hora de preparar una película para un medio como, por ejemplo, CD-ROM, para el que puede ser necesario limitar el tamaño de archivo o carpeta en bloques de 650 MB o menos. Utilice el valor Segmentar archivos de película de solo vídeo en para definir el tamaño máximo de los segmentos en megabytes. Utilice Segmentar secuencias en para definir el número máximo de archivos de imágenes fijas que deben guardarse en una carpeta.

Si va a exportar una película que supera el tamaño de archivo máximo para el esquema de formato del disco duro, puede definir el valor Segmentar archivos de película de solo vídeo en, en un valor inferior a este máximo. Los discos duros formateados para Windows se pueden formatear con los esquemas FAT, FAT32 o NTFS. El tamaño de archivo máximo del esquema FAT es 2 GB, y el tamaño de archivo máximo en el esquema FAT32 es 4 GB. El tamaño máximo para un archivo para NTFS es grande (aproximadamente 16 terabytes), así que es poco probable que alcance este límite con una sola película.

Únicamente se pueden segmentar las películas que no contienen audio. Si un módulo de salida incluye audio, la preferencia Segmentar archivos de película de solo vídeo en se omite para ese elemento.

La preferencia Segmentar secuencias en se omite para todos los elementos de procesamiento para los que la opción Omitir archivos existentes está seleccionada en los ajustes de procesamiento. (Consulte Referencia de ajustes de procesamiento).

Nota:

After Effects no procesará ni exportará una película segmentada en el directorio raíz (p. ej., C:\). Para procesar y exportar una película segmentada, seleccione un directorio de salida distinto al directorio raíz. (Consulte Especificación de nombres de archivo y ubicaciones para el resultado del procesamiento).

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea