Visualización o edición de un valor de fotograma clave

Antes de cambiar un fotograma clave, asegúrese de que el indicador de tiempo actual está colocado en un fotograma clave existente. Si cambia un valor de propiedad y el indicador de tiempo actual no está en un fotograma clave existente, After Effects agregará un nuevo fotograma. Sin embargo, si hace doble clic en un fotograma clave para modificarlo, la localización del indicador de tiempo actual no es relevante, ni cuando realice cambios en el método de interpolación del fotograma clave.

  • Mueve el indicador de tiempo actual hasta el final del fotograma clave. El valor de la propiedad aparece junto al nombre, donde puede ser editado.
  • Haga clic con el botón derecho (Windows) o presione Control y haga clic (Mac OS) en el fotograma clave. Aparece el valor del fotograma clave en la parte superior del menú contextual que se muestra. Si lo desea, elija Editar valor para modificar el valor.
  • Coloque el puntero sobre un fotograma clave en el modo de barra de capa para ver el tiempo y el valor del fotograma.
  • Sitúe el puntero en un fotograma clave en modo Editor de gráficos para ver el nombre de la capa, el nombre de la propiedad, el tiempo y el valor del fotograma clave. Sitúe el puntero sobre un segmento entre los fotogramas clave para ver la información correspondiente en cualquier momento.
  • Haga clic en un fotograma clave en modo de barra de capa para mostrar el método de interpolación y el tiempo del fotograma clave en el panel Información.
  • Haga clic en un fotograma clave o un segmento entre fotogramas clave en modo Editor de gráficos para mostrar los valores máximos y mínimos de una propiedad, así como la velocidad en el tiempo actual en el panel Información.
  • Presione Alt (Windows) u Opción (Mac OS) y haga clic en los dos fotogramas clave en modo de barra de capa para ver el tiempo entre ambos en el panel Información.

Jeff Almasol incluye una secuencia de comandos en su sitio Web redefinery, que crea nuevos marcadores de capa (en la capa seleccionada o en una nueva capa nula) con comentarios que ofrecen información sobre los fotogramas claves con los mismos tiempos.

Copia y pegado fotogramas clave

Puede copiar fotogramas clave de una sola capa cada vez. Cuando se pegan fotogramas clave en otra capa, aparecen en la propiedad correspondiente del efecto de la capa de destino. El primer fotograma clave aparecerá en el tiempo actual y los demás seguirán en orden relativo. Los fotogramas clave permanecen seleccionados después de pegarlos, por lo que puede moverlos seguidamente en la capa de destino.

Puede copiar fotogramas clave entre capas de la misma propiedad (como Posición) o entre diferentes propiedades que utilicen el mismo tipo de datos (por ejemplo, entre Posición y Punto de anclaje).

Nota:

Cuando copie y pegue entre propiedades idénticas, puede copiar de más de una propiedad a más de una propiedad a la vez. Sin embargo, cuando copie y pegue en propiedades distintas, solo podrá copiar de una propiedad a una propiedad a la vez.

  1. En el panel Línea de tiempo, muestre la propiedad de capa que contiene los fotogramas clave que desea copiar.
  2. Seleccione uno o varios fotogramas clave.
  3. Seleccione Editar > Copiar.
  4. En el panel Línea de tiempo que contenga la capa de destino, mueva el indicador de tiempo actual hasta el punto en el tiempo en el que desee que aparezcan los fotogramas clave.
  5. Realice una de las acciones siguientes:
    • Para pegar en la misma propiedad de los fotogramas clave copiados, seleccione la capa de destino.

    • Para pegar en una propiedad diferente, seleccione la propiedad de destino.

  6. Elija Edición > Pegar.

Edición de los valores de fotograma clave con una hoja de cálculo o un editor de textos

Se pueden copiar y pegar datos de fotogramas clave como texto delimitado por tabulaciones para ser utilizado en un programa de hojas de cálculo (como Microsoft Excel) u otro programa de edición de texto. Puede utilizar un programa de hojas de cálculo para realizar análisis numéricos en datos de fotogramas claves o crear o editar valores de fotograma clave.

Se pueden copiar y pegar la mayoría de las propiedades, incluyendo propiedades de Transformación (como pueda ser la Posición y Opacidad), propiedades de Opciones de Material y rastreadores de movimiento.

Nota:

Se puede utilizar la herramienta de seguimiento de movimiento para realizar un seguimiento del movimiento de un objeto en una capa, y pegar dichos datos de movimiento en una hoja de cálculo con el fin de llevar a cabo análisis numéricos de los datos.

Ciertas aplicaciones de utilidades, como Imagineer Systems Mocha para After Effects (mocha-AE), copian los datos de fotograma clave al portapapeles para poder pegarlos en la capa adecuada de After Effects.

Puede copiar fotogramas clave de una sola capa cada vez como texto delimitado por tabulaciones.

  1. En el panel Línea de tiempo, seleccione fotogramas clave para una o más propiedades de la misma capa. Para seleccionar todos los fotogramas clave de una propiedad, haga clic en el nombre de la propiedad.
  2. Desplace el indicador de tiempo al primer fotograma clave seleccionado.

    Nota:

    Sitúe un marcador de composición en el tiempo del primer fotograma clave seleccionado de forma que pueda saber dónde pegar los fotogramas clave modificados en el último paso. (Consulte Marcadores de capa y marcadores de posición).

  3. Con los fotogramas clave seleccionados, seleccione Editar > Copiar.
  4. Pegue los datos del fotograma clave en la hoja de cálculo. Suponiendo que la primera columna en la hoja de cálculo se denomine A y la primera fila sea 1, debería pegarlos en la celda A1. Los números de fotograma aparecen en la columna B. Los valores de propiedad aparecen en las columnas C, D y E, dependiendo de las dimensiones de la propiedad. (Posición en una capa 3D tiene valores en las tres columnas; Opacidad tiene solo un valor en la columna C.)
  5. Edite la información numérica para los fotogramas clave. No cambie datos que no sean los números de fotograma y los valores de propiedad.
  6. Seleccione las celdas que contienen sus datos. La celda superior izquierda de la selección debería ser A1. La última fila de la selección debería ser la fila que contiene el texto Fin de datos de Fotograma clave.

  7. Copie los datos desde la hoja de cálculo.
  8. En After Effects, mueva el indicador de tiempo actual al tiempo en el cual quiera pegar los nuevos datos de fotograma clave. Este deberá ser normalmente el tiempo del primer fotograma clave que se seleccionó y se copió al comienzo de este procedimiento.
  9. Elija Edición > Pegar.

Mover fotogramas clave en el tiempo

Puede mover los fotogramas clave en el tiempo, de forma individual o como grupo.

Jeff Almasol incluye una secuencia de comandos versátil en su sitio web redefinery, que crea un panel con controles para mover distintas combinaciones de elementos en el tiempo: punto de inicio de la capa, punto final de la capa, fotogramas de origen de capas, fotogramas clave y marcadores.

Desplazamiento de fotogramas clave a otra posición en el tiempo

Con varios fotogramas clave seleccionados, puede copiarlos o borrarlos simultáneamente o moverlos juntos sin cambiar sus posiciones con respecto a los demás.

  1. Seleccione uno o varios fotogramas clave.
  2. Arrastre cualquiera de los iconos de fotograma clave seleccionados hasta la posición de tiempo deseada. Si selecciona varios fotogramas clave, todos los fotogramas clave seleccionados mantendrán su distancia relativa respecto al fotograma que arrastre.

Nota:

También puede mover los fotogramas clave seleccionados en el tiempo (un fotograma antes o después), presionando la tecla Alt (Windows) u Opción (Mac OS) con la tecla de flecha derecha o izquierda.

Desplazamiento de un fotograma clave a una posición de tiempo específica

  1. Mueva el indicador de tiempo actual hasta el tiempo deseado.
  2. Realice una de las acciones siguientes:
    • En el modo de barra de capa, mantenga presionada la tecla Mayús después de comenzar a arrastrar un icono de fotograma clave al indicador del tiempo actual.

    • En el modo Editor de gráficos, arrastre un fotograma clave al indicador de tiempo actual.

    Si lo arrastra sobre el indicador de tiempo actual, el fotograma clave se ajustará al indicador de tiempo actual.

Expansión o contracción de un grupo de fotogramas clave en el modo de barra de capa

  1. Seleccione al menos tres fotogramas clave.
  2. Mantenga presionada la tecla Alt (Windows) u Opción (Mac OS) y arrastre el primer o el último fotograma clave seleccionado hasta la posición de tiempo que desee.

Desplazamiento de la barra de duración de una capa sin desplazar sus fotogramas clave

  1. Sitúe un marcado de composición en el tiempo en el que aparece el primer fotograma clave. (Consulte Marcadores de composición).
  2. En el contorno de la capa, haga clic en el nombre de una o más propiedades de capa que contengan los fotogramas clave que desee mantener en esos tiempos.
  3. Seleccione Edición > Cortar.
  4. Mueva o amplíe la barra de duración de la capa a sus nuevos puntos de inicio y de fin.
  5. Mueva el indicador de tiempo actual en el marcador de composición hasta el tiempo en el que apareció el primer fotograma clave antes de cortar los fotogramas clave.
  6. Elija Edición > Pegar.

Cambio de varios valores de fotogramas clave a la vez

Puede cambiar los valores de varios fotogramas clave de diversas capas de una vez; sin embargo, todos los fotogramas clave que seleccione deberán pertenecer a la misma propiedad de capa. La forma de cambiar los valores seleccionados depende del método que utilice para realizar los cambios:

  • Si cambia un valor numérico, todos los fotogramas clave seleccionados utilizarán el nuevo valor exactamente. En otras palabras, realizará un cambio absoluto. Por ejemplo, si selecciona varios fotogramas clave de Posición en un trazado de movimiento y especifica numéricamente un valor de Posición para uno de ellos, todos los fotogramas clave seleccionados cambiarán al mismo valor de posición.

  • Si cambia un valor arrastrando el valor subrayado, todos los fotogramas clave seleccionados cambiarán la misma cantidad. En otras palabras, realizará un cambio relativo. Por ejemplo, si selecciona varios fotogramas clave de Posición en un trazado de movimiento y arrastra el valor subrayado de uno de ellos, todos los valores de fotogramas clave seleccionados cambiarán la misma cantidad.

  • Si cambia gráficamente un valor en el panel Composición o Capa, todos los fotogramas clave seleccionados cambiarán utilizando la diferencia entre los valores viejos y los nuevos, no los valores en sí mismos. En otras palabras, realizará un cambio relativo. Por ejemplo, si selecciona diversos fotogramas clave de Posición en un trazado de movimiento y los arrastra aproximadamente 10 píxeles hacia la izquierda, todos los fotogramas se desplazarán 10 píxeles a la izquierda de su posición original.

También puede cambiar el valor de varias capas de una sola vez en el modo de barra de capas emparentándolas.

Mathias Möhl incluye el script KeyTweak en su (disponible en la página After Effects Extension), con la que se podrán modificar diversos fotogramas clave en una propiedad de forma simultánea. Con KeyTweak, es posible modificar algunos fotogramas clave manualmente y el script modifica los fotogramas clave restantes de forma correspondiente. KeyTweak resulta especialmente útil para los fotogramas clave Mask Path en un flujo de trabajo de rotoscopia. (Consulte Recursos e introducción a la rotoscopia).

Movimiento o cambio de fotogramas clave en el Editor de gráficos

Un gráfico de valores en el Editor de gráficos muestra los valores de cada fotograma clave y los valores interpolados entre ellos. Cuando el gráfico de valores de una propiedad de capa está estable, el valor de la propiedad no cambia entre fotogramas clave. Cuando el gráfico de valores sube o baja, el valor de una propiedad de capa aumenta o disminuye entre fotogramas clave.

Movimiento o cambio de fotogramas clave en el Editor de gráficos
Gráfico Valor

A. Fotograma clave. B. Un gráfico de valores estable indica valores sin cambios. C. Un gráfico ascendente indica valores en aumento. D. Un gráfico descendente indica valores que se reducen. 

Puede cambiar los valores de propiedades de capa moviendo los puntos (fotogramas clave) del gráfico de valores hacia arriba o hacia abajo. Por ejemplo, puede aumentar el valor del fotograma clave de Rotación arrastrando un marcador del fotograma clave que esté en el gráfico de valores de la propiedad Rotación hacia arriba en el gráfico.

Nota:

Los valores correspondientes al Punto de anclaje, Trazado de máscara, puntos de control de efecto, Orientación 3D y propiedades de Posición son valores espaciales, por lo que de manera predeterminada utilizan gráficos de velocidad en lugar de gráficos de valores.

Modificación de un solo fotograma en el Editor de gráficos

  1. En el panel Línea de tiempo, muestre una propiedad temporal de una capa.
  2. Si fuera necesario, haga clic en el botón Editor de gráficos o presione Mayús+F3 para tener acceso al modo Editor de gráficos.
  3. Si es necesario, agregue un fotograma clave al punto de tiempo en el que desea que se produzca el cambio.
  4. Arrastre el fotograma clave hacia arriba o hacia abajo para definir un nuevo valor para la propiedad de la capa.

Modificación de varios fotogramas clave en el Editor de gráficos

Puede editar y mover simultáneamente varios fotogramas clave utilizando el Editor de gráficos. Si selecciona varios fotogramas clave con el botón Mostrar el cuadro de transformación seleccionado, un cuadro delimitador de transformación libre rodeará los fotogramas clave seleccionados y aparecerá un punto de anclaje en el centro del cuadro delimitador para señalar el punto central de la transformación. Puede mover los fotogramas clave seleccionados en el tiempo o el valor arrastrando el cuadro delimitador o sus controles. También puede cambiar la posición del punto de anclaje.

Al ajustar un cuadro delimitador de transformación libre en un gráfico de valor, se moverán los fotogramas clave seleccionados en el tiempo y el valor. Al ajustar un cuadro delimitador de transformación libre en un gráfico de velocidad, se moverán los fotogramas clave seleccionados solo en el tiempo.

Modificación de varios fotogramas clave en el Editor de gráficos
Si selecciona varios fotogramas clave en el Editor de gráficos, aparecerá un cuadro delimitador de transformación libre.

  1. Cambie la vista Editor de gráficos y muestre los fotogramas clave que desee ajustar.
  2. Con la herramienta Selección, realice uno de los siguientes procedimientos:
    • Para seleccionar fotogramas clave, haga clic en los fotogramas clave mientras mantiene presionada la tecla Mayús o dibuje un marco alrededor de dichos fotogramas clave.

    • Para seleccionar todos los fotogramas clave de una propiedad, haga clic en un segmento entre dos fotogramas clave mientras presiona la tecla Alt (Windows) u Opción (Mac OS).

  3. Realice cualquiera de las acciones siguientes:
    • Para mover los fotogramas clave en el tiempo o el valor, sitúe el puntero dentro del cuadro delimitador y arrástrelo. Con la tecla Mayús presionada, arrastre el elemento y limite el movimiento horizontal o verticalmente.

    • Para mover fotogramas clave en el tiempo o el valor escalando el cuadro delimitador, sitúe el puntero sobre un control del cuadro. Si el puntero cambia a una flecha de dos puntas recta , arrastre el cuadro delimitador a un nuevo tamaño. Mantenga presionada la tecla Mayús mientras arrastra para limitar la proporción de anchura a altura. Presione Ctrl (Windows) o Comando (Mac OS) y arrastre para escalar alrededor del punto de anclaje del cuadro delimitador. Si arrastra un control de borde, mantenga presionada la tecla Alt (Windows) o la tecla Opción (Mac OS) para mover solo ese control.

    Nota:

    Aplique una escala de valores negativos para invertir los fotogramas clave en el tiempo.

    Para estrechar verticalmente valores de fotogramas clave, presione la combinación de teclas Ctrl+Alt (Windows) o Comando+Opción (Mac OS) mientras arrastra. Al estrechar valores de fotogramas clave podrá reducir o expandir la amplitud de una animación repetida.

    Para mover un lado del cuadro delimitador hacia arriba o hacia abajo, presione la combinación de teclas Ctrl+Alt+Mayús (Windows) o Comando+Opción+Mayús (Mac OS) mientras arrastra.

    Para mover el punto de anclaje del cuadro delimitador, coloque la herramienta Selección sobre el punto de anclaje hasta que la herramienta cambie a Mover punto de anclaje y arrastre.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea