Guía del usuario Cancelar

Mejora del rendimiento

  1. Guía del usuario de After Effects
  2. Versiones beta
    1. Descripción general del programa beta
    2. Comunidad beta de After Effects
    3. Funciones de la versión beta
      1. Panel Propiedades (beta)
      2. Importación de modelos 3D (Beta)
      3. Gestión de color de OpenColorIO y ACES (Beta)
  3. Introducción
    1. Introducción a After Effects
    2. Novedades de After Effects 
    3. Notas de la versión | After Effects
    4. Requisitos del sistema para After Effects
    5. Métodos abreviados de teclado en After Effects
    6. Formatos de archivo admitidos | After Effects
    7. Recomendaciones de hardware
    8. After Effects para Apple Silicon
    9. Planificación y configuración
  4. Espacios de trabajo
    1. Elementos generales de la interfaz de usuario
    2. Familiarización con la interfaz de After Effects
    3. Flujos de trabajo
    4. Espacios de trabajo, paneles y visores
  5. Proyectos y composiciones
    1. Proyectos
    2. Conceptos básicos sobre composiciones
    3. Precomposición, anidamiento y preprocesamiento
    4. Ver información de rendimiento detallada con el Perfilador de composición
    5. Procesador de composición de Cinema 4D
  6. Importación de material de archivo
    1. Preparación e importación de imágenes fijas
    2. Importación desde After Effects y Adobe Premiere Pro
    3. Importación e interpretación de vídeo y de audio
    4. Preparación e importación de archivos de imagen 3D
    5. Importación e interpretación de elementos de material de archivo
    6. Uso de elementos de material de archivo
    7. Detección de puntos de edición con Detección de edición de escena
    8. Metadatos XMP
  7. Texto y gráficos
    1. Texto
      1. Formato de caracteres y el panel Carácter
      2. Efectos de texto
      3. Creación y edición de capas de texto
      4. Aplicación de formato a párrafos y el panel Párrafo
      5. Extrusión de capas de texto y formas
      6. Animación del texto
      7. Ejemplos y recursos para animación de texto
      8. Plantillas de texto interactivo
    2. Gráficos animados
      1. Trabajar con plantillas de gráficos animados en After Effects
      2. Uso de expresiones para crear listas desplegables en plantillas de gráficos animados
      3. Trabajo con propiedades esenciales para crear plantillas de gráficos animados
      4. Reemplazo de imágenes y vídeos en plantillas de gráficos animados y propiedades esenciales
  8. Dibujo, pintura y trazados
    1. Descripción general de las capas de forma, trazados y gráficos vectoriales
    2. Herramientas de pintura: Pincel, Tampón de clonar y Borrador
    3. Estrechar trazos de forma
    4. Atributos de forma, operaciones de pintura y operaciones de trazado para capas de forma
    5. Uso del efecto de forma Desplazar trazados para modificar formas
    6. Creación de formas
    7. Creación de máscaras
    8. Elimine objetos de sus vídeos desde el panel Relleno según el contenido
    9. Pincel tipo rotoscopia y Perfeccionar mate
  9. Capas, marcadores y cámara
    1. Selección y organización de capas
    2. Modos de fusión y estilos de capas
    3. Capas 3D
    4. Propiedades de capa
    5. Creación de capas
    6. Administración de capas
    7. Marcadores de capa y marcadores de composición
    8. Cámaras, luces y puntos de interés
  10. Animación, fotogramas clave, seguimiento del movimiento y efecto de clave
    1. Animación
      1. Conceptos básicos sobre animaciones
      2. Animación con herramientas de marioneta
      3. Administración y animación de trazados de formas y máscaras
      4. Animación de formas de Sketch y Capture con After Effects
      5. Herramientas de animación varias
      6. Trabajo con animación basada en datos
    2. Fotograma clave
      1. Interpolación de fotogramas clave
      2. Ajuste, selección y eliminación de fotogramas clave
      3. Edición, desplazamiento y copia de fotogramas clave
    3. Seguimiento de movimiento
      1. Seguimiento y estabilización del movimiento
      2. Seguimiento de caras
      3. Seguimiento de máscara
      4. Referencia de máscara
      5. Velocidad
      6. Ampliación del tiempo y reasignación del tiempo
      7. Unidades de visualización de tiempo y código de tiempo
    4. Incrustación
      1. Incrustación
      2. Efectos de incrustación
  11. Transparencia y composición
    1. Descripción general y recursos sobre composición y transparencia
    2. Canales alfa y mates
    3. Mates de seguimiento y mates móviles
  12. Ajuste del color
    1. Conceptos básicos sobre colores
    2. Gestión de color
    3. Efectos de corrección de color
  13. Ajustes preestablecidos de animación y efectos
    1. Información general de efectos y ajustes preestablecidos de animación
    2. Lista de efectos
    3. Efectos de simulación
    4. Efectos de Estilizar
    5. Efectos de audio
    6. Efectos de distorsión
    7. Efectos de perspectiva
    8. Efectos de canal
    9. Efectos de generación
    10. Efectos de transición
    11. El efecto Reparación de obturación de desplazamiento
    12. Efectos Desenfocar y Enfocar
    13. Efectos de canal 3D
    14. Efectos de utilidad
    15. Efectos mate
    16. Efectos Ruido y Granulado
    17. Efecto Mejora de conservación de detalles
    18. Efectos obsoletos
  14. Expresiones y automatización
    1. Expresión
      1. Conceptos básicos sobre expresiones
      2. Comprensión del lenguaje de expresión
      3. Uso de los controles de expresión
      4. Diferencias de sintaxis entre los motores de expresiones de JavaScript y ExtendScript heredado
      5. Edición de expresiones
      6. Errores de expresiones
      7. Uso del editor de expresiones
      8. Uso de expresiones para editar y acceder a las propiedades de texto
      9. Referencia del lenguaje de expresión
      10. Ejemplos de expresiones
    2. Automatización
      1. Automatización
      2. Scripts
  15. Vídeo inmersivo, RV y 3D
    1. Construcción de entornos de RV en After Effects
    2. Aplicar efectos de vídeo envolvente
    3. Herramientas de composición para vídeos de VR/360
    4. Seguimiento del movimiento de la cámara 3D
    5. Trabajo en espacios de diseño 3D
    6. Herramientas de transformación Gizmo 3D
    7. Haga más cosas con la animación 3D
    8. Previsualización de los cambios en diseños 3D en tiempo real con el motor Mercury 3D
    9. Adición de diseño interactivo a los gráficos 
  16. Vistas y previsualizaciones
    1. Previsualización
    2. Previsualización de vídeo con Mercury Transmit
    3. Modificación y utilización de vistas
  17. Procesamiento y exportación
    1. Principios básicos del procesamiento y la exportación
    2. Codificación H.264 en After Effects
    3. Exportación de un proyecto de After Effects como un proyecto de Adobe Premiere Pro
    4. Conversión de películas
    5. Procesamiento de varios fotogramas
    6. Procesamiento automático y en red
    7. Procesamiento y exportación de imágenes fijas y secuencias de imágenes fijas
    8. Uso del códec de GoPro CineForm en After Effects
  18. Uso de otras aplicaciones
    1. Dynamic Link y After Effects
    2. Uso de After Effects y otras aplicaciones
    3. Sincronización de la configuración en After Effects
    4. Bibliotecas Creative Cloud en After Effects
    5. Plugins
    6. CINEMA 4D y Cineware
  19. Colaboración: Frame.io y Team Projects
    1. Colaboración en Premiere Pro y After Effects
    2. Frame.io
      1. Instalar y activar Frame.io
      2. Utilizar Frame.io con Premiere Pro y After Effects
      3. Preguntas frecuentes
    3. Team Projects
      1. Introducción a Team Projects
      2. Creación de un proyecto de equipo
      3. Colaboración con Team Projects
  20. Memoria, almacenamiento y rendimiento
    1. Memoria y almacenamiento
    2. Cómo maneja After Effects los problemas de poca memoria durante la previsualización
    3. Mejora del rendimiento
    4. Preferencias
    5. Requisitos de la GPU y del controlador de la GPU para After Effects

Puede mejorar el rendimiento optimizando el sistema informático, After Effects, el proyecto y el flujo de trabajo. Algunas de las sugerencias aquí indicadas mejoran el rendimiento al no aumentar la velocidad de procesamiento y reducir el tiempo que requieren otras operaciones como, por ejemplo, la apertura de un proyecto.

Nota:

Hasta el momento, la mejor forma de mejorar el rendimiento general es la planificación, la ejecución de pruebas iniciales de flujo de trabajo y de la canalización de salida y la confirmación de que lo que se entrega al cliente es lo que realmente desea y espera. (Consulte Planificación del trabajo).

Mejora del rendimiento antes de iniciar After Effects

  • Asegúrese de que tiene instalada la última versión de After Effects, incluidas las actualizaciones disponibles. Para comprobar e instalar actualizaciones, seleccione Ayuda > Actualizaciones.
  • Asegúrese de haber instalado las últimas versiones de los controladores y plugins, especialmente en el caso de los controladores de la tarjeta de vídeo. Para descargar actualizaciones de controladores y plugins, diríjase al sitio web de su proveedor.
  • Asegúrese de que el sistema tiene memoria RAM suficiente. El rendimiento óptimo se obtiene con sistemas de informáticos de al menos 2 GB de RAM instalada por núcleo de procesador. Para obtener información detallada sobre la RAM instalada y el modo de instalar RAM, consulte la documentación del sistema operativo y del equipo.
  • Salga de las aplicaciones que no son necesarias para su trabajo. Si se ejecutan aplicaciones, con las que After Effects comparte un almacenamiento de memoria, que son diferentes y no se asigna la memoria adecuada a las demás aplicaciones, el rendimiento se puede ver muy reducido cuando el sistema operativo intercambia RAM en el disco duro.
  • Detenga o pause las operaciones de otras aplicaciones que requieran muchos recursos, p. ej., la previsualización de vídeos en Adobe Bridge.
  • Si es posible, mantenga los archivos del proyecto en una unidad de disco local rápida. Si los archivos del material de archivo de origen están en una unidad de disco lenta (o se transmiten con una conexión de red lenta), el rendimiento será pequeño. Como mejor opción, utilice unidades de disco locales rápidas e independientes para los archivos de material de archivo de origen y la salida procesada.
  • Lo ideal es un disco rápido independiente (o matriz de discos) para asignar la carpeta de la caché de disco. Debido a su velocidad, los SSD funcionan bien para esta función.

Mejora del rendimiento al optimizar la configuración de la memoria caché

  • Asigne memoria suficiente para las demás aplicaciones.
  • Habilite el almacenamiento en la caché de fotogramas en disco para previsualizaciones, seleccionando la preferencia Activar caché de disco. En After Effects, asigne tanto espacio como sea posible a la carpeta Caché de disco (en una unidad de disco rápido independiente) para obtener el mejor rendimiento.

Consulte las Preferencias de memoria para obtener más información.

Mejora del rendimiento con la Caché de rendimiento global | CC, CS6

Importe los proyectos de After Effects 5.5 y anteriores en After Effects CS para aprovechar las ventajas de la Caché de rendimiento global.

La caché de disco persistente mejora el rendimiento, conservando los fotogramas almacenados en la caché de disco entre las sesiones, lo que permite ahorrar tiempo de procesamiento cuando trabaja en un proyecto o en otros proyectos que utilizan los mismos fotogramas almacenados en caché.

Mejora del rendimiento mediante la simplificación del proyecto

Si se simplifica y divide un proyecto, se puede evitar que After Effects utilice memoria y otros recursos para procesar elementos con los que no se esté trabajando. Asimismo, al controlar cuándo After Effects debe realizar determinadas operaciones de procesamiento, se puede mejorar en gran medida el rendimiento general. Así, por ejemplo, se evita repetir una acción que debe suceder una sola vez, o se puede posponer una acción hasta el momento más oportuno.

  • Elimine los elementos del proyecto que no utilice. Consulte Quitar elementos de un proyecto.
  • Divida los proyectos complejos en proyectos más sencillos y vuelva a combinarlos antes de procesar la película terminada. Para volver a combinar proyectos, importe todos los proyectos en un solo proyecto. Consulte Importación de un proyecto de After Effects.
  • Antes del procesamiento, sitúe todos los archivos de material de archivo de origen en un disco local rápido, no en el que se está realizando el procesamiento y la exportación. Para esta operación se recomienda el uso del comando Recopilar archivos. Consulte Recopilación de archivos en una ubicación.
  • Preprocese las composiciones anidadas. Procese la composición terminada como película de manera que After Effects no vuelva a procesar la composición cada vez que se muestra. Consulte Preprocesamiento de una composición anidada.
  • Sustituya un proxy de baja resolución o imagen fija por un elemento de origen cuando no trabaje directamente con ese elemento. Consulte Marcadores de posición y proxies.
  • Disminuya la resolución de la composición. Consulte Resolución.
  • Aísle la capa en la que trabaja mediante el definidor Solo. Consulte Conversión a una capa Solo.

Mejora del rendimiento modificando la salida de pantalla

Es posible mejorar el rendimiento de muchas maneras que no influyen en la forma en que After Effects trata los datos del proyecto, sino en la forma en que se dibuja la salida en la pantalla mientras se trabaja. Aunque a menudo es útil ver determinados elementos e información a medida que se avanza, After Effects utiliza memoria y recursos de procesador para actualizar los datos, por lo que se recomienda ser selectivo en cuanto a lo que se muestra mientras se trabaja. Es probable que necesite ver diferentes aspectos del proyecto en distintos puntos del flujo de trabajo, de manera que puede aplicar las siguientes sugerencias en diversas combinaciones y en etapas diferentes.

  • Desactive la gestión de color de visualización y la simulación de salida cuando no se necesiten. Consulte Simular cómo aparecerán los colores en un dispositivo de salida diferente. La velocidad y la calidad de la gestión de color para las previsualizaciones se controla mediante las preferencias de la calidad del visualizador. Consulte Preferencias de la calidad del visualizador.
  • Habilite la aceleración de hardware de previsualizaciones, que utiliza la GPU para ayudarle a dibujar previsualizaciones en la pantalla. Elija Editar > Preferencias > Pantalla (Windows) o After Effects > Preferencias > Pantalla (macOS) y seleccione los paneles Composición de aceleración de hardware, Capa y Material de archivo.
  • Cierre los paneles que no necesite. After Effects debe utilizar memoria y recursos de procesador para actualizar los paneles abiertos, lo que puede ralentizar el trabajo que se esté realizando en otro panel.
  • Creación de una región de interés. Si está trabajando en una pequeña parte de la composición, limite la parte de la composición que se procesa en la pantalla durante las previsualizaciones. Consulte Región de interés (ROI).
  • Anule la selección de la opción Mostrar indicadores de caché en el menú del panel Cronología para que After Effects no muestre barras verdes y azules en la regla de tiempo para indicar los fotogramas almacenados en caché.
  • Anule la selección de la opción Mostrar el procesamiento en curso en el panel Información y en el diagrama de flujo para evitar que se escriban en pantalla los detalles de las operaciones de procesamiento de cada fotograma. Consulte Preferencias de visualización.
  • Oculte los detalles del procesamiento actual en el panel Cola de procesamiento haciendo clic en el triángulo situado al lado de Detalles de procesamiento actual en el panel Cola de procesamiento. Consulte Información mostrada para las operaciones actuales de procesamiento.
  • Presione Bloq Mayús para que After Effects no actualice los paneles Material de archivo, Capa o Composición. Si realiza algún cambio que, en otro caso, aparecería en un panel, After Effects agrega una barra roja con un texto recordatorio en la parte inferior del panel. After Effects sigue actualizando los controles del panel, como los trazados de movimiento, los puntos de anclaje y los contornos de máscara, a medida que se desplazan. Para reanudar las actualizaciones del panel y mostrar todos los cambios, vuelva a presionar Bloq Mayús.
Nota:

Al presionar Bloq Mayús se suspenden las actualizaciones (se deshabilita la actualización) de las vistas previas en los visualizadores durante el procesamiento del resultado final, aunque no aparece ninguna barra recordatoria roja.

  • Disminuya la calidad de visualización de una capa como Borrador. Consulte Calidad de imagen de capa y posicionamiento de subpíxeles.
  • Seleccione Borrador 3D en el menú del panel Cronología, que deshabilita todas las luces y sombras que se proyectan sobre las capas 3D. También se deshabilita el desenfoque de la profundidad de campo de una cámara.
  • Utilice el modo de borrador rápido durante la disposición y previsualización de una composición 3D con trazo de rayo mediante la selección de una opción que no sea Desactivado en el botón Previsualizaciones rápidas.
  • Anule la selección de Actualización en directo en el menú del panel Cronología para que After Effects no actualice las composiciones de forma dinámica. Consulte Preferencias de modos de previsualización y Previsualizaciones rápidas.
  • Muestre formas de onda de audio en el panel Cronología solo cuando es necesario. Consulte Visualización de propiedades y grupos en el panel Cronología (métodos abreviados de teclado).
  • Deshabilite la corrección de proporción de píxeles haciendo clic en el botón Conmutar corrección de proporción de píxeles en la parte inferior del panel Composición, Capa o Material de archivo. La velocidad y la calidad de la corrección de proporción de píxeles y otras escalas para previsualizaciones se controlan mediante las preferencias de Calidad de visor. Consulte Preferencias de Calidad de visor.
  • Anule la selección Reflejar en el monitor del equipo cuando previsualice imágenes de vídeo en un monitor de vídeo externo. Consulte Previsualización en un monitor de vídeo externo.
  • Oculte los controles de capa, como las máscaras, los ejes de referencia 3D y los controles de capa. Consulte Mostrar u ocultar los controles de capa en el panel Composición.
  • Disminuya el aumento de una composición. Cuando After Effects muestra los paneles Composición, Capa y Material de archivo con un aumento superior al 100 %, disminuye la velocidad con la que se vuelve a dibujar en la pantalla. (Consulte Aplicación de zoom a una imagen para previsualización).
  • Establezca el valor Resolución/submuestreo de la composición en Automático en el panel Composición, lo cual evita el procesamiento innecesario de filas o columnas de píxeles que no se dibujan en pantalla con niveles bajos de zoom. Consulte Resolución.

Mejora del rendimiento cuando se utilizan efectos

Algunos efectos, como los desenfoques y las distorsiones, requieren grandes cantidades de memoria y recursos del procesador. Si limita la frecuencia y la forma en que utiliza estos efectos, mejorará mucho el rendimiento en general.

  • Aplicación posterior de efectos que consuman muchos recursos de memoria y procesador Anime las capas y aquello que requiera previsualizaciones en tiempo real antes de aplicar efectos que consuman muchos recursos de memoria y procesador (como resplandores y desenfoques) cuya previsualización sea más lenta que la previsualización en tiempo real.
  • Desactive los efectos temporalmente para aumentar la velocidad de las previsualizaciones. Consulte Eliminación o deshabilitación de efectos y ajustes preestablecidos de animación.
  • Limite el número de objetos generados mediante los efectos de objeto. Consulte Efectos de simulación.
  • En lugar de aplicar el mismo efecto con la misma configuración a varias capas, aplique el efecto a una capa de ajuste. Cuando un efecto se aplica a una capa de ajuste, se procesa una sola vez, en el compuesto de todas las capas bajo el mismo. Consulte Creación de una capa de ajuste.
Logotipo de Adobe

Inicia sesión en tu cuenta