Guía del usuario Cancelar

Trabajo con animación basada en datos

  1. Guía del usuario de After Effects
  2. Versiones beta
    1. Descripción general del programa beta
    2. Comunidad beta de After Effects
  3. Introducción
    1. Introducción a After Effects
    2. Novedades de After Effects 
    3. Notas de la versión | After Effects
    4. Requisitos del sistema para After Effects
    5. Métodos abreviados de teclado en After Effects
    6. Formatos de archivo admitidos | After Effects
    7. Recomendaciones de hardware
    8. Planificación y configuración
    9. Configuración e instalación
  4. Espacios de trabajo
    1. Elementos generales de la interfaz de usuario
    2. Familiarización con la interfaz de After Effects
    3. Flujos de trabajo
    4. Espacios de trabajo, paneles y visores
  5. Proyectos y composiciones
    1. Proyectos
    2. Conceptos básicos sobre composiciones
    3. Precomposición, anidamiento y preprocesamiento
    4. Ver información de rendimiento detallada con el Perfilador de composición
    5. Procesador de composición de Cinema 4D
  6. Importación de material de archivo
    1. Preparación e importación de imágenes fijas
    2. Importación desde After Effects y Adobe Premiere Pro
    3. Importación e interpretación de vídeo y de audio
    4. Preparación e importación de archivos de imagen 3D
    5. Importación e interpretación de elementos de material de archivo
    6. Uso de elementos de material de archivo
    7. Metadatos de XMP
  7. Uso de texto y gráficos
    1. Texto
      1. Formato de caracteres y el panel Carácter
      2. Efectos de texto
      3. Creación y edición de capas de texto
      4. Aplicación de formato a párrafos y el panel Párrafo
      5. Extrusión de capas de texto y formas
      6. Animación del texto
      7. Ejemplos y recursos para animación de texto
      8. Plantillas de texto interactivo
    2. Gráficos animados
      1. Trabajar con plantillas de gráficos animados en After Effects
      2. Uso de expresiones para crear listas desplegables en plantillas de gráficos animados
      3. Trabajo con propiedades esenciales para crear plantillas de gráficos animados
      4. Reemplazo de imágenes y vídeos en plantillas de gráficos animados y propiedades esenciales
  8. Dibujo, pintura y trazados
    1. Descripción general de las capas de forma, trazados y gráficos vectoriales
    2. Herramientas de pintura: Pincel, Tampón de clonar y Borrador
    3. Estrechamiento de trazos de forma
    4. Atributos de forma, operaciones de pintura y operaciones de trazado para capas de forma
    5. Uso del efecto de forma Desplazar trazados para modificar formas
    6. Creación de formas
    7. Creación de máscaras
    8. Elimine objetos de sus vídeos desde el panel Relleno según el contenido
    9. Pincel tipo rotoscopia y Perfeccionar mate
  9. Uso de capas
    1. Selección y organización de capas
    2. Modos de fusión y estilos de capas
    3. Capas 3D
    4. Propiedades de capa
    5. Creación de capas
    6. Administración de capas
    7. Marcadores de capa y marcadores de composición
    8. Cámaras, luces y puntos de interés
  10. Animación, fotogramas clave, seguimiento del movimiento y efecto de clave
    1. Animación
      1. Conceptos básicos sobre animaciones
      2. Animación con herramientas de marioneta
      3. Administración y animación de trazados de formas y máscaras
      4. Animación de formas de Sketch y Capture con After Effects
      5. Herramientas de animación varias
      6. Trabajo con animación basada en datos
    2. Fotograma clave
      1. Interpolación de fotogramas clave
      2. Ajuste, selección y eliminación de fotogramas clave
      3. Edición, desplazamiento y copia de fotogramas clave
    3. Seguimiento de movimiento
      1. Seguimiento y estabilización del movimiento
      2. Seguimiento de caras
      3. Seguimiento de máscara
      4. Referencia de máscara
      5. Velocidad
      6. Ampliación del tiempo y reasignación del tiempo
      7. Unidades de visualización de tiempo y código de tiempo
    4. Incrustación
      1. Incrustación
      2. Efectos de incrustación
  11. Transparencia y composición
    1. Descripción general y recursos sobre composición y transparencia
    2. Canales alfa, máscaras y mates
  12. Ajuste del color
    1. Conceptos básicos sobre colores
    2. Uso de la extensión Temas de Adobe Color
    3. Gestión de color
    4. Efectos de corrección de color
  13. Ajustes preestablecidos de animación y efectos
    1. Visión general de efectos y ajustes preestablecidos de animación
    2. Lista de efectos
    3. Efectos de simulación
    4. Efectos de Estilizar
    5. Efectos de audio
    6. Efectos de distorsión
    7. Efectos de perspectiva
    8. Efectos de canal
    9. Efectos de generación
    10. Efectos de transición
    11. El efecto Reparación de obturación de desplazamiento
    12. Efectos Desenfocar y Enfocar
    13. Efectos de canal 3D
    14. Efectos de utilidad
    15. Efectos mate
    16. Efectos Ruido y Granulado
    17. Efecto Mejora de conservación de detalles
    18. Efectos obsoletos
  14. Expresiones y automatización
    1. Expresión
      1. Conceptos básicos sobre expresiones
      2. Comprensión del lenguaje de expresión
      3. Uso de los controles de expresión
      4. Diferencias de sintaxis entre los motores de expresiones de JavaScript y ExtendScript heredado
      5. Edición de expresiones
      6. Errores de expresiones
      7. Uso del editor de expresiones
      8. Uso de expresiones para editar y acceder a las propiedades de texto
      9. Referencia del lenguaje de expresión
      10. Ejemplos de expresiones
    2. Automatización
      1. Automatización
      2. Scripts
  15. Vídeo inmersivo, RV y 3D
    1. Construcción de entornos de RV en After Effects
    2. Aplicar efectos de vídeo envolvente
    3. Herramientas de composición para vídeos de VR/360
    4. Seguimiento del movimiento de la cámara 3D
    5. Trabajo en espacios de diseño 3D
    6. Previsualización de los cambios en diseños 3D en tiempo real con el motor en tiempo real
    7. Adición de diseño interactivo a los gráficos 
  16. Vistas y previsualizaciones
    1. Previsualización
    2. Previsualización de vídeo con Mercury Transmit
    3. Modificación y utilización de vistas
  17. Procesamiento y exportación
    1. Principios básicos del procesamiento y la exportación
    2. Exportación de un proyecto de After Effects como un proyecto de Adobe Premiere Pro
    3. Conversión de películas
    4. Procesamiento de varios fotogramas
    5. Procesamiento automático y en red
    6. Procesamiento y exportación de imágenes fijas y secuencias de imágenes fijas
    7. Uso del códec de GoPro CineForm en After Effects
  18. Uso de otras aplicaciones
    1. Dynamic Link y After Effects
    2. Uso de After Effects y otras aplicaciones
    3. Sincronización de la configuración en After Effects
    4. Colaborar con Proyectos de equipo
    5. Uso compartido y administración de cambios con los colaboradores del Team Project
    6. Bibliotecas Creative Cloud en After Effects
    7. Plugins
    8. Cinema 4D y Cineware
  19. Memoria, almacenamiento y rendimiento
    1. Memoria y almacenamiento
    2. Mejora del rendimiento
    3. Preferencias
    4. Requisitos de la GPU y del controlador de la GPU para After Effects

Use el documento para aprender a trabajar con animaciones basadas en datos

Las animaciones basadas en datos se crean con datos en vivo recopilados de varias fuentes que generan animaciones en la composición. Puede utilizar datos de múltiples fuentes. Los datos pueden ser estáticos o variables en el tiempo. Puede importar los datos al proyecto de After Effects y utilizarlos como entrada para animar gráficos, personajes, efectos visuales de control, títulos de películas y otros gráficos animados.

Ejemplo de animación basada en datos
Ejemplo de animación basada en datos

Fuentes de datos

Puede utilizar datos de casi cualquier origen posible, como:

  • Archivos de datos generados por un dispositivo: datos de dispositivos, como los medidores de ejercicio, que registran la actividad por medio de sensores y la guardan en distintos formatos de archivo. Son datos variables en el tiempo que incluyen: velocidad, altitud, distancia, ritmo cardíaco y otros parámetros de la actividad del usuario.
  • Datos estáticos generados por el usuario: datos estáticos globales, como los resultados de una encuesta, que se pueden cambiar para generar gráficos. Un archivo de datos creado por el usuario podría proporcionar un flujo de trabajo para datos globales.
  • URL: datos en vivo de sitios web, como la ruta de entrada y salida de un usuario que navega por un sitio web.
  • Metadatos: datos incrustados en metadatos de archivos de vídeo.

Formatos de entrada

Puede importar archivos de datos en los siguientes formatos:

  • JSON
  • MGJSON
  • CSV
  • TSV

Si tiene archivos de datos en otros formatos, conviértalos a cualquiera de los formatos de archivo de importación admitidos e impórtelos en el proyecto After Effects. Existen diferentes herramientas para convertir archivos de datos en formatos compatibles con After Effects.

Animación basada en datos

Compatibilidad con JSON estándar (.json)

Puede importar un archivo JSON estándar en After Effects como material de archivo y los archivos de datos funcionan en segundo plano. After Effects hace referencia directamente a los datos en estos archivos de datos para dar vida a las animaciones en los proyectos. El material de archivo JSON no se representa como flujos de datos en el panel Línea de tiempo. Puede hacer referencia a los datos utilizando expresiones como un objeto JSON evaluado.

Puede modificar las expresiones para cambiar cómo se hace referencia a los datos. Puede escribir los datos en un editor de texto, al que After Effects hace referencia para dar vida a las animaciones. La compatibilidad de JSON se basa en el esquema JSON, que especifica y define cómo una aplicación utiliza y modifica los datos JSON.

Los tipos de datos básicos de JSON son:

  • Número: un número decimal firmado.
  • Cadena: una secuencia de cero o más caracteres Unicode.
  • Booleano: los valores true o false.
  • Matriz: una lista ordenada de cero o más valores.
  • Objeto: un conjunto sin ordenar de pares de nombres o valores donde los nombres (claves) son cadenas.
  • Nulo: un valor vacío que usa la palabra “null”.

Uso de archivos JSON en After Effects

Use los pasos que se indican a continuación para trabajar con un archivo JSON estándar:

  1. Seleccione Archivo > Importar.

  2. Para importar, seleccione un archivo . archivo JSON y haga clic en Abrir.

  3. El archivo se añade a la ventana del proyecto. Cree una composición con el material de archivo.

  4. Añada un sólido a la composición. Para añadir un sólido, seleccione Capa > Sólida.

  5. En el panel Línea de tiempo, gire para abrir las propiedades de la capa sólida y haga Alt+clic en el parámetro Opacidad.

  6. Cambie los datos de la expresión para modificar la animación. Es posible controlar los datos JSON. Además, se hace referencia a los datos desde el archivo de datos donde se almacena toda la información.

  7. También puede sustituir el archivo JSON por otro archivo JSON para cambiar los datos a los que se hace referencia. Para ello, seleccione Reemplazar material de archivo > Archivo y abra el nuevo archivo en el equipo.

Para utilizar los datos, puede aplicar una expresión en la propiedad que desea que los datos activen y, a continuación:

  1. Utilice el atributo sourceData para leer los datos de un archivo .JSON. Por ejemplo:

    var sampleData = footage("sample.json").sourceData;
  2. Para devolver su valor, haga referencia a la propiedad específica dentro de los datos del JSON. Por ejemplo,

    myData.engineData.RPM or myData.latitude.value.

Compatibilidad con JSON de gráficos animados (.mgjson)

Puede importar un archivo de datos MGJSON como material de archivo al proyecto. Cuando agrega material de archivo de datos a una composición, los flujos de propiedad de datos se agrupan en un grupo de nivel superior “Data”. El grupo Data muestra los datos de material de archivo como propiedades. Cada propiedad en el grupo de datos está vinculada mediante una expresión al archivo de material de archivo que accede al valor del archivo de datos mediante la expresión footage(“foo.mgjson”).dataValue(N). Aquí, N es la ruta al flujo de datos en el archivo. MGJSON funciona según un esquema, que está diseñado para simplificar la referencia e importación de flujos de datos en After Effects.

Cada propiedad de datos individual tiene aplicada una expresión que vincula dicha propiedad a los datos del archivo MGJSON. Si se modifica el archivo MGJSON de origen, los valores de propiedad de los datos se actualizan automáticamente.

En el panel Línea de tiempo, puede girar para abrir las capas de datos y utilizar el icono espiral para vincular parámetros a otros parámetros. Los cambios se rellenan automáticamente.

Uso de material de archivo MGJSON en After Effects

Siga los pasos que se indican a continuación para trabajar con un archivo MGJSON:

  1. Seleccione Archivo > Importar.

  2. Para importar, seleccione un archivo MGJSON y haga clic en Abrir.

  3. El archivo se añade a la ventana del proyecto. Cree una composición con el material de archivo.

  4. Importe un recurso al proyecto y añádalo a la composición.

  5. En el panel Línea de tiempo, gire para abrir las propiedades del material de archivo.

  6. Use el icono espiral para vincular una de las propiedades del recurso, por ejemplo, Rotación, a uno de los flujos de datos de la capa de datos. Ahora, la propiedad del recurso hace referencia a los datos de la capa de datos. Cada flujo de datos reflejado tiene una expresión que obtiene su valor del archivo de material de archivo.

  7. Cuando previsualiza el material de archivo, el recurso se anima según el flujo de datos de la capa de datos.

También se pueden convertir las muestras de datos del archivo de datos en fotogramas clave. Para convertir en fotogramas clave, siga estos pasos:

  1. Importe el archivo MGJSON al proyecto y arrástrelo al panel Línea de tiempo.

  2. Haga clic con el botón derecho en la capa de datos y seleccione Asistente de fotogramas clave > Crear fotogramas clave a partir de datos en el menú Asistente de capas y fotogramas clave.

  3. Si quiere ver los fotogramas clave, gire la capa de datos para abrirla.

Nota:

Tras la conversión de los fotogramas clave, los datos ya no se muestran en vivo ni se hace referencia a ellos desde el archivo de datos.

También puede ver los datos en vivo en forma de gráfico en el Editor de gráficos. Para ello, haga clic en el icono Editor de gráficos del panel Línea de tiempo.

La animación basada en datos utiliza la referencia de expresión. Para obtener más información, consulte Animación basada en datos (referencia de expresión).

Alineación de un video en el tiempo con datos mgJSON

El comando Capa > Tiempo > Alinear vídeo con datos desplaza las capas de vídeo por varios fotogramas, tal y como se especifica en un archivo mgJSON. Puede utilizar este comando para alinear un vídeo en el tiempo con muestras de datos almacenadas en un archivo mgJSON coincidente. Por ejemplo, si capturó datos durante una carrera, pero la hora de inicio del vídeo no coincide con la hora de inicio de los datos capturados, puede especificar el desplazamiento para que los datos se alineen automáticamente.

Para alinear un vídeo en el tiempo con datos mgJSON, siga los siguientes pasos:

  1. agregue el archivo mgJSON a una composición que también contenga las capas de destino.
  2. Seleccione la capa .mgJSON y las capas de destino.
  3. Seleccione Capa > Tiempo > Alinear vídeo con datos.

Para realizar este trabajo, el archivo mgJSON debe tener un grupo videoSyncTimeList que contenga:

  • El nombre de una o más capas de destino (nombredearchivo).
  • El número de fotogramas (numerodefotogramas) para desplazar las capas desde el inicio de la capa de datos.

Por ejemplo:

“videoSyncTimeList”: [
  {
    “nombredearchivo”: “sample1.mp4”,
    “numerodefotogramas”: 1000
  },

  {
    “nombredearchivo”: “sample2.mp4”,
    “numerodefotogramas”: -1000
  }

El valor de un nombredearchivo debe ser el nombre de capa de una capa seleccionada, no el nombre de origen de la capa. Si cambia el nombre de una capa con un origen en su composición, por ejemplo, si cambia el nombre de la capa “sample1.mp4” por “Cámara de carrera 1”, también deberá cambiar el valor nombredearchivo en el archivo mgJSON para que coincidan. Las capas a las que se hace referencia con nombredearchivo no tienen que ser elementos de material de archivo con un archivo de origen; también pueden ser composiciones sólidas y anidadas u otros tipos de capas.

Los valores positivos de numerodefotogramas desplazan la capa de destino hacia la izquierda (delante de la capa de datos). Los valores negativos de numerodefotogramas desplazan la capa de destino hacia la derecha (detrás de la capa de datos). Un valor numerodefotogramas que sea 0 alinea el inicio de la capa de destino con el inicio de la capa de datos.

Compatibilidad con CSV (.csv) y TSV (.tsv o .txt)

Puede importar archivos de valores separados por comas (.csv) y valores separados por tabulaciones (.tsv o.txt) como material de archivo a After Effects y utilizarlos como fuentes de datos.  Los archivos CSV y TSV almacenan datos tabulares en formato de texto plano con valores separados por comas o tabuladores. Los archivos de datos CSV y TSV funcionan de forma similar a los archivos JSON.

Para utilizar archivos de datos CSV o TSV en After Effects, siga estos pasos:

  1. Importe un archivo CSV o TSV en el proyecto como material de archivo, de forma similar a cómo importa un archivo de vídeo, audio u otro. Utilice cualquiera de los siguientes métodos para importar sus archivos como material de archivo:
    • Seleccione Archivo > Importar.
    • Haga clic con el botón derecho en el panel Proyectos y seleccione Importar > Tipo de archivo.
    • Haga doble clic en el panel Proyectos.
  2. El archivo se agrega a la ventana del proyecto. Cree una composición con el archivo.

  3. En el panel Línea de tiempo, gire para abrir las propiedades del material de archivo. Vincule las propiedades de datos de la capa en la composición a otra capa con la expresión icono espiral o el icono espiral de vínculo de propiedades. Para abrir el campo de texto de expresiones, mantenga presionada la tecla Mayús y haga clic en el icono del temporizador junto al nombre de la capa. También puede enlazar las propiedades de los datos mediante el comando Edición > Copiar con vínculos de propiedades.

    Para obtener más información acerca de las propiedades de datos de capa en la línea de tiempo, consulte Conceptos básicos de las propiedades de datos.

  4.  Para hacer referencia al archivo de material de archivo de datos, utilice una expresión en la propiedad que desea que los datos generen. Utilice el atributo de material de archivo dataValue() para leer los datos de una fila o columna en concreto. Las filas y las columnas se indexan desde cero. Por ejemplo, footage(“muestra.tsv”).dataValue([15,1]) devuelve el valor de la fila 16 de la segunda columna.

Conceptos básicos de las propiedades de datos

Cuando se agrega un archivo JSON, CSV o TSV a una composición y se abren las propiedades, estas contendrán solo un grupo de propiedades de datos, en vez del grupo de propiedades Transformar. El grupo de propiedades de datos contiene la jerarquía de datos tal y como se definen en el archivo.

Grupo de propiedades de datos JSON en el panel Línea de tiempo

Grupo de propiedades de datos CSV y TSV en el panel Línea de tiempo

Este grupo de datos es similar a la forma en la que After Effects trata los archivos de gráficos animados JSON (.mgJSON). La diferencia es que JSON, CSV y TSV solo pueden contener valores de datos estáticos, mientras que mgJSON puede contener datos dinámicos (datos que cambian con el tiempo).

Cada propiedad de datos individual tiene aplicada una expresión que vincula dicha propiedad a los datos del archivo JSON, CSV o TSV.  Si cambia el archivo de datos de origen, este cambio se reflejará en los valores de propiedad de los datos.

Vinculación de propiedades con el icono espiral de vínculo de propiedades

Si no desea escribir expresiones complejas, puede utilizar el icono espiral de vínculo de propiedades o el comando Edición > Copiar con vínculos de propiedades para vincular las propiedades de los datos a las propiedades de otras capas. A medida que vincula las capas, el icono espiral de vínculo de propiedades escribe automáticamente las expresiones por usted.

Bibliotecas de funciones de expresión personalizadas: JSX

En After Effects 15.0, era posible importar un archivo JSON que definía funciones JavaScript personalizadas y que se podía utilizar como biblioteca de funciones de expresión personalizadas. En After Effects 15.1, los objetos de JavaScript no son sintaxis legal para JSON. After Effects 15.1 utiliza un analizador JSON diferente que es estricto y no permite la importación de un archivo JSON con sintaxis ilegal.

Si intenta importar un archivo JSON con una función JavaScript definida en After Effects 15.1 o abrir un proyecto que contenga dicho archivo, en After Effects se muestra un error.

Para evitar este problema, puede importar un archivo de extensión de sintaxis de JavaScript (.jsx) a After Effects 15.1. El contenido del archivo JSX puede ser el mismo que el de un archivo JSON importado a After Effects 15.0. Únicamente tiene que cambiar la extensión del nombre del archivo a.jsx. Si abre un proyecto existente que contiene un archivo JSON que no funciona, utilice Archivo > Reemplazar material de archivo para sustituir el archivo JSON por el archivo JSX. Las referencias de expresión al archivo JSON se sustituyen por referencias al archivo JSX.

Problemas conocidos de la animación basada en datos

Al trabajar con animaciones basadas en datos en After Effects, pueden surgir algunos problemas. Para ver una lista completa, consulte Problemas conocidos de las animaciones basadas en datos.

Logotipo de Adobe

Inicia sesión en tu cuenta