Learn how to work simultaneously in shared projects within the Adobe video applications, and use deep collaboration features like version control and smart conflict resolution for Adobe Premiere Pro CC, After Effects CC, and Adobe Prelude CC.

What is Team Projects (Beta)?

Team Projects is a hosted collaboration service for CC enterprise users that allows editors and motion graphics artists to work simultaneously in shared team projects within Adobe Premiere Pro CC, After Effects CC and Adobe Prelude CC. It includes deep collaboration features like version control and smart conflict resolution. Instead of creating local project files, collaborators can work together in a shared team project that can be opened by Premiere Pro, After Effects or Prelude. The data in Team Projects is securely hosted in the cloud. Media files referenced by Team Projects can be locally stored source files, or lightweight proxies shared via Creative Cloud or another cloud service or on-premise storage location.

Sharing projects across workgroups and workstations has never been easier with Team Projects. To learn more, see www.adobe.com/go/teamprojects.

Who can access the Team Projects (Beta) service?

Team Projects is available for Creative Cloud for enterprise customers and Creative Cloud for teams customers with All Apps, Premiere Pro Single App, or After Effects Single app subscriptions. To know more, see Manage your Creative Cloud for teams membership or Upgrade or change your Creative Cloud plan. The service is compatible with the CC 2017 versions of Premiere Pro, After Effects, and Prelude. You must have CC services enabled and your computer must be connected to the Internet.

Connecting to the Team Projects service

To access the Team Projects service, you must be connected to the Internet and logged in to the Creative Cloud desktop application using your Creative Cloud Adobe ID and password. 

  1. Launch the CC 2017 version of Premiere Pro CC, After Effects CC, or Prelude CC.

  2. In the application, choose Help > Sign In.

  3. Sign in to Creative Cloud using your Creative Cloud Adobe ID and password.

Creating a team project

Team Project is a multiuser, multi-application alternative to an application-specific project file like a .prproj or .aep file.  Multiple users can work in a team project simultaneously. When a collaborator opens a Team Project, the Team Project service automatically makes a 'clone' of the current state of the team project for the user and opens it in a private session.

To create a Team Project:

  1. Click the New Team Project button in the Start screen of Adobe Premiere Pro CC, Prelude CC, or After Effects CC. You can also create a Team Project via the File menu by selecting  File > New > Team Project.

    Creating a team project
    Creating a team project

  2. Enter a name for the Team Project (required) and a description (optional). You can invite collaborators to join the Team Project now, or wait and invite them later once you have added content.

  3. To invite collaborators now, click the Edit button. In the pop-up screen, enter the email address of the
    people you want to collaborate with. This email address must be the one they have associated with their Adobe ID.

  4. Click the Invite button. The user receives an invitation to collaborate that appears in the Creative Cloud desktop application and under the Invite Tab of the Open Team Projects screen. 

Adding media to a team project

Team Projects collaboration data (metadata and media references associated with the project) are hosted in Adobe’s Creative Cloud. The media used in your Team Project must be available on each collaborator’s machine, either on network shared storage, copied to a local disk, or synchronized via cloud storage such as a shared Creative Cloud directory.

Your collaborators on a Team Project must all have access to, or their own copies of, the media used in the Team Project, otherwise the media appears offline. While collaborators want access to the media, it does not have to be in the same location. 

To import media into a Team Project:

  1. Choose File > Import or use the media browser panel. 

    Adding media to Team Project
    Adding media to Team Project

  2. Import media from your local drives, network drives, or from the media you have available in the
    Creative Cloud sync folders on your desktop. 

  3. Browse to the correct folder, select the media you want to add, and from the context menu, select Import from the context menu.

Inviting collaborators to your Team Project

To invite other users to join a Team Project:

  1. Add collaborators directly in the Team Projects panel clicking the sign next to the Collaborator image thumbnails.

  2. Alternatively, in the File menu, select File > Team Project Settings.

  3. Choose Edit. In the pop-up screen, enter the email address of the people you want to collaborate with. This email address must be the one they have associated with their Adobe ID. Click Invite.

    Inviting collaborators to your Team Project
    Inviting collaborators to your Team Project

Adding your profile picture to your collaborator icon

To add a profile picture to your Collaborator icon by updating your Creative Cloud profile:    

  1. In the Creative Cloud desktop application, click the gear icon in the upper right corner.  

  2. Select Manage Account

  3. Log in to your Creative Cloud account on the web. Click Profile and add or update your photo.

Accepting an invitation to collaborate

If you have been invited to collaborate on a Team Project, you receive an invitation notification in the Creative Cloud desktop application. There are two ways you can choose to accept or reject an invitation.

  1. Click Accept to accept the invitation in the CC desktop application. 

    Accepting an invitation
    Accepting an invitation

  2. To view Team Projects invitations that you have not yet accepted, choose File > Open Team Project > Invites. You can select and accept or reject any invitations you have received here as well.

Removing collaborators from a team project

To remove collaborators from a Team Project:

  1. Select the Team Project settings available under File > Team Project Settings

  2. Select Edit to select the user's email address you want to remove and click Remove.

Sharing changes

Instead of saving changes to a local project file, the Team Projects service saves your changes automatically in your local copy of the team project. When you are ready for your collaborators to see the changes that you have made, you can share them.

Sharing your changes with collaborators on the Team Project is easy. The Team Project service examines your private view of the Team Project, verifies that there are no conflicts with the work others have shared, and incorporates your changes into the current version of the shared Team Project. The updated version with your changes is immediately made available to your collaborators. There are two ways to share a change.

  • Click the up arrow available in the lower right corner of the left panel. 
  • Choose Edit > Team Project > Share My Changes.

You can see a screen that prompts you to enter a comment about the changes that have been made. Click Share to make your changes available to your Collaborators.

Get latest changes from collaborators

You are notified whenever collaborators share changes via a small badge on the assets thumbnail either when you are using the icon view or the Status column available in List view. At the same time, the Get Latest Changes icon in the Team Project panel lights up. You can either click the Get Latest Changes arrow or choose Edit > Team Project > Get Latest Changes. Any changes made by your collaborators are then synchronized and made available to you in a new version in your sandbox.

Resolving editing conflicts

With multiple collaborators working on a Team Project simultaneously, it is possible that some of the media that you have edited has conflicts with the changes that have been recently shared. If there are conflicts after you get the latest changes and then attempt to share your work, you get presented with a conflict resolution dialog and must resolve them before you are allowed to share. You can resolve them by using the conflict resolution screen, which shows you three conflict resolution options.

  • You can choose to keep your version.
  • You can choose to keep the shared version.
  • You can choose to copy and rename your version before accepting the shared version.

You can also decide whether to resolve all conflicts individually or collectively by selecting all the media.

Resolving editing conflicts
Resolving editing conflicts

Using the media management feature when collaborators add new media

If a collaborator adds media to a Team Project to which they have access in a different location than you (for example, they could be accessing media on a local drive and you have the same media in another folder) those files appear as offline media to you. To have these media available online, map the media location on your machine. Your collaborators on a Team Project want access to all assets in a shared location, or their own copies of the Team Project's assets. Otherwise, the media remains offline.   

  1. Choose Edit > Team Project > Media Management

    Media management
    Media management

  2. Click down to find the missing media.  

  3. Select one of the media and click the New Media Mapping button.  

  4. Navigate to the folder location where you have stored the media.  

  5. Select the correct media and click Choose.  

  6. Repeat the steps for remaining media.

  7. Click Close after you map all the missing media.

  8. The media now appears online and you can begin or continue working.

Interrupted Connection mode

Recognizing that the reliability of Internet connectivity varies across different geographies, Team Projects includes an Interrupted Connection mode feature that allows you to continue working in a Team Project even if your Internet connection gets temporarily interrupted. You would not be able to share your changes or Get Latest Changes from other collaborators, but you can continue working in a Team Project, and have your edits saved locally.

You get notified that the Internet connection has been interrupted and collaboration features are unavailable, but that you can continue working locally. Notification messages would vary based on your action. When you are reconnected to the Internet, collaboration features including Get Latest Changes and the Share button are enabled again.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy