Zusammenführen von Daten über das Variablenbedienfeld

  1. Illustrator-Benutzerhandbuch
  2. Illustrator kennenlernen
    1. Einführung in Illustrator
      1. Neue Funktionen in Illustrator
      2. Häufige Fragen
      3. Systemanforderungen für Illustrator
      4. Illustrator für Apple-Chip
    2. Arbeitsbereich
      1. Arbeitsbereich – Grundlagen
      2. Erstellen von Dokumenten
      3. WerkzeugeStandard-Tastaturbefehle | Illustrator
      4. Anpassen von Tastaturbefehlen
      5. Zeichenflächen
      6. Anpassen des Arbeitsbereichs
      7. Eigenschaftenbedienfeld
      8. Festlegen von Voreinstellungen
      9. Touch-Arbeitsbereich
      10. Unterstützung des Microsoft Surface Dial in Illustrator
      11. Wiederherstellen, Rückgängigmachen und Automatisierung
      12. Drehen der Ansicht
      13. Lineale, Raster und Hilfslinien
      14. Barrierefreiheit in Illustrator
      15. Abgesicherter Modus
      16. Anzeigen von Bildmaterial
      17. Verwenden der Touch Bar in Illustrator
      18. Dateien und Vorlagen
      19. Synchronisieren von Einstellungen über Adobe Creative Cloud
    3. Werkzeuge in Illustrator
      1. Auswahl
        1. Übersicht
        2. Auswahl
        3. Direktauswahl
        4. Lasso
      2. Navigation
        1. Übersicht
        2. Zoom
        3. Drehen der Ansicht
      3. Farbe
        1. Übersicht
        2. Verlauf
        3. Formerstellung
      4. Text
        1. Übersicht
        2. Text
        3. Pfadtext
  3. Illustrator auf dem iPad
    1. Einführung in Illustrator auf dem iPad
      1. Illustrator auf dem iPad – Übersicht
      2. Häufige Fragen zu Illustrator auf dem iPad
      3. Systemanforderungen | Illustrator auf dem iPad
      4. Funktionsumfang von Illustrator auf dem iPad
    2. Arbeitsbereich
      1. Arbeitsbereich von Illustrator auf dem iPad
      2. Touch-Kurzbefehle und Gesten
      3. Tastaturbefehle für Illustrator auf dem iPad
      4. Verwalten von App-Einstellungen
    3. Dokumente
      1. Arbeiten mit Dokumenten in Illustrator auf dem iPad
      2. Importieren von Photoshop- und Fresco-Dokumenten
    4. Auswählen und Anordnen von Objekten
      1. Erstellen von Wiederholungsobjekten
      2. Angleichen von Objekten
    5. Zeichnen
      1. Zeichnen und Bearbeiten von Pfaden
      2. Zeichnen und Bearbeiten von Formen
    6. Text
      1. Arbeiten mit Text und Schriftarten
      2. Erstellen von Text-Designs entlang eines Pfads
      3. Hinzufügen eigener Schriften
    7. Arbeiten mit Bildern
      1. Arbeiten mit Bildern
    8. Farben
      1. Anwenden von Farben und Farbverläufen
  4. Cloud-Dokumente
    1. Grundlagen
      1. Arbeiten mit Illustrator-Cloud-Dokumenten
      2. Freigeben und gemeinsame Bearbeitung von Illustrator-Cloud-Dokumenten
      3. Upgraden des Cloud-Speicherplatzes für Adobe Illustrator
      4. Illustrator-Cloud-Dokumente | Häufige Fragen
    2. Fehlerbehebung
      1. Fehlerbehebung beim Erstellen oder Speichern von Problemen für Illustrator-Cloud-Dokumente
      2. Beheben von Problemen mit Illustrator-Cloud-Dokumenten
  5. Hinzufügen und Bearbeiten von Inhalten
    1. Zeichnen
      1. Zeichnen – Grundlagen
      2. Bearbeiten von Pfaden
      3. Zeichnen pixelgenauer Grafiken
      4. Zeichnen mit dem Zeichenstift-, Krümmungs- oder Buntstift-Werkzeug
      5. Zeichnen von einfachen Linien und Formen
      6. Bildnachzeichner
      7. Vereinfachen von Pfaden
      8. Definieren von Perspektivenrastern
      9. Symbol-Werkzeuge und Symbolsätze
      10. Anpassen von Pfadsegmenten
      11. Zeichnen einer Blume in fünf einfachen Schritten
      12. Perspektivisches Zeichnen
      13. Symbole
      14. Zeichnen von an Pixeln ausgerichteten Pfaden für Web-Workflows
    2. 3D-Effekte und Adobe Substance-Materialien
      1. Grundlagen von 3D‑Effekten in Illustrator
      2. Erstellen von 3D‑Grafiken
      3. Erstellen von 3D-Objekten
      4. Erstellen von 3D-Text
    3. Farben
      1. Wissenswertes zu Farben
      2. Auswählen von Farben
      3. Verwenden und Erstellen von Farbfeldern
      4. Anpassen von Farben
      5. Verwenden des Bedienfelds „Adobe Color-Schemata“
      6. Farbgruppen (Harmonien)
      7. Color-Schemata-Bedienfeld
      8. Bildmaterial neu färben
    4. Malen
      1. Wissenswertes zum Malen
      2. Malen mit Flächen und Konturen
      3. Interaktive Malgruppen
      4. Verläufe
      5. Pinsel
      6. Transparenz und Füllmethoden
      7. Anwenden einer Kontur auf ein Objekt
      8. Erstellen und Bearbeiten von Mustern
      9. Gitter
      10. Muster
    5. Auswählen und Anordnen von Objekten
      1. Auswählen von Objekten
      2. Ebenen
      3. Gruppieren und Umwandeln von Objekten
      4. Verschieben, Ausrichten und Verteilen von Objekten
      5. Übereinanderlegen von Objekten    
      6. Sperren, Ausblenden und Löschen von Objekten
      7. Duplizieren von Objekten
      8. Drehen und Spiegeln von Objekten
    6. Ändern der Form von Objekten
      1. Freistellen von Bildern
      2. Transformieren von Objekten
      3. Kombinieren von Objekten
      4. Ausschneiden, Aufteilen und Zuschneiden von Objekten
      5. Formgitter
      6. Skalieren, Verbiegen und Verzerren von Objekten
      7. Angleichen von Objekten
      8. Verformen mit Hüllen
      9. Ändern der Form von Objekten mit Effekten
      10. Erstellen neuer Formen mit den Shaper- und Formerstellungswerkzeugen
      11. Verwenden von interaktiven Ecken
      12. Verbesserte Workflows zum Ändern von Formen mit Touch-Unterstützung
      13. Bearbeiten von Schnittmasken
      14. Interaktive Formen
      15. Erstellen von Formen mit dem Formerstellungswerkzeug
      16. Globale Bearbeitung
    7. Text
      1. Erstellen von Text
      2. Schriftarten und Typografie
      3. Formatieren von Text
      4. Importieren und Exportieren von Text
      5. Formatieren von Absätzen
      6. Sonderzeichen
      7. Erstellen von Pfadtext
      8. Zeichen- und Absatzformate
      9. Registerkarten
      10. Text und Schrift
      11. Suchen von fehlenden Schriftarten (Typekit-Workflow)
      12. Aktualisieren von Text aus Illustrator 10
      13. Arabische und hebräische Schrift
      14. Schriftarten | Häufige Fragen und Tipps zur Fehlerbehebung
      15. Erstellen eines 3D-Texteffekts
      16. Kreative Typografie-Designs
      17. Skalieren und Drehen von Text
      18. Zeilen- und Zeichenabstand
      19. Silbentrennung und Zeilenumbrüche
      20. Textverbesserungen
      21. Rechtschreibungs- und sprachspezifische Wörterbücher
      22. Formatieren asiatischer Zeichen
      23. Setzer für asiatische Schriften
      24. Erstellen von Textdesigns mit Angleichungsobjekten
      25. Erstellen eines Textposters mithilfe des Bildnachzeichners
    8. Erstellen von Spezialeffekten
      1. Arbeiten mit Effekten
      2. Grafikstile
      3. Erstellen von Schlagschatten
      4. Aussehen-Attribute
      5. Erstellen von Zeichnungen und Mosaiken
      6. Schlagschatten, Schein und weiche Kanten
      7. Übersicht der Effekte
    9. Webgrafiken
      1. Empfehlungen zum Erstellen von Webgrafiken
      2. Diagramme
      3. SVG
      4. Erstellen von Animationen
      5. Slices und Imagemaps
  6. Importieren, Exportieren und Speichern
    1. Importieren
      1. Importieren von Bildmaterialdateien
      2. Importieren von Bitmap-Bildern
      3. Importieren von Bildmaterial aus Photoshop
      4. Platzieren mehrerer Dateien | Illustrator CC
      5. Einbettung von Bildern aufheben
      6. Importieren von Adobe PDF-Dateien
      7. Importieren von EPS-, DCS- und AutoCAD-Dateien
      8. Verknüpfungsinformationen
    2. Creative Cloud-Bibliotheken in Illustrator 
      1. Creative Cloud-Bibliotheken in Illustrator
    3. Speichern
      1. Speichern von Bildmaterial
    4. Exportieren
      1. Exportieren von Bildmaterial
      2. Sammeln von Elementen und Exportieren in Stapeln
      3. Dateien verpacken
      4. Erstellen von Adobe PDF-Dateien
      5. CSS extrahieren | Illustrator CC
      6. Adobe PDF-Optionen
      7. Dateiinformationen und Metadaten
  7. Drucken
    1. Vorbereitung für den Druck
      1. Einrichten von Dokumenten zum Drucken
      2. Ändern von Seitenformat und Ausrichtung
      3. Festlegen von Schnittmarken für das Zuschneiden oder Ausrichten
      4. Erste Schritte mit großen Arbeitsflächen
    2. Drucken
      1. Überdrucken
      2. Drucken mit Farbmanagement
      3. Drucken von PostScript-Dateien
      4. Druckvorgaben
      5. Druckermarken und Anschnitt
      6. Drucken und Speichern von transparentem Bildmaterial
      7. Überfüllen
      8. Drucken von Farbseparationen
      9. Drucken von Verläufen, Gittern und Farbübergängen
      10. Weiß überdrucken
  8. Automatisieren von Aufgaben
    1. Zusammenführen von Daten über das Variablenbedienfeld
    2. Automatisieren mit Skripten
    3. Automatisieren mit Aktionen
  9. Fehlerbehebung 
    1. Absturzprobleme beim Start
    2. Wiederherstellen von Dateien nach Absturz
    3. Dateiprobleme
    4. Probleme mit GPU-Gerätetreibern
    5. Probleme mit Wacom-Geräten
    6. Probleme mit DLL-Dateien
    7. Arbeitsspeicherprobleme
    8. Probleme mit der Voreinstellungendatei
    9. Schriftprobleme
    10. Druckerprobleme
    11. Absturzbericht an Adobe senden

Mit dem Variablenbedienfeld in Illustrator können Sie ganz einfach mehrere Variationen Ihres Bildmaterials erstellen, indem Sie eine Datenquelldatei (CSV- oder XML-Datei) mit einem Illustrator-Dokument zusammenführen. Zum Beispiel können Sie anstatt der manuellen Veränderung von Objekten in einer Vorlage die Datenzusammenführungsfunktion verwenden, um Hunderte von Vorlagen-Variationen für verschiedene Ausgabeoberflächen schnell und präzise zu erstellen. In ähnlicher Weise können Sie die Namen der Teilnehmer auf Veranstaltungsausweisen oder Bilder auf Webbannern und Postkarten ändern, ohne Ihr Bildmaterial neu erstellen zu müssen. Erstellen Sie einfach ein Design und erzeugen dann schnell Variationen, indem Sie die Namen oder die Bilder aus einer Datenquelldatei importieren.

Erstellen Sie über das Variablenbedienfeld individuelle Variationen Ihrer Designvorlagen für verschiedene Projekte, wie z. B. druckbare Poster, Webbanner oder Veranstaltungsausweise.

Voraussetzungen

Alles, was Sie für Datenzusammenführung benötigen, ist eine Datenquelldatei und ein Zieldokument. 

  • Die Datenquelldatei enthält die Informationen, die in den einzelnen Ausfertigungen des Zieldokuments jeweils unterschiedlich sind, wie z. B. die Namen, Bilder und Adressen der Empfänger eines Serienbriefs. Eine Datenquelldatei kann eine kommagetrennte Datei (.csv) oder eine Extensible Markup Language-Datei (.xml) sein.
  • Das Zieldokument ist ein Illustrator-Dokument, das die Grundlage für die Verwendung als Vorlage enthält. Dieses Dokument kann den Datenbankplatzhalter und die Gegenstände enthalten, die bei jeder Iteration des zusammengeführten Dokuments unverändert bleiben.

Zugriff auf die Datenzusammenführungsfunktion

Die Datenzusammenführung ist vom Variablenbedienfeld in Illustrator (Fenster > Variablen) zu erreichen. Jede Variable, die im Dokument enthalten ist, ist mit ihrem Typ und ihrem Namen im Bedienfeld aufgeführt. Wenn die Variable mit einem Objekt verknüpft ist, wird in der Spalte „Objekte“ der Name des gebundenen Objekts so angezeigt, wie er im Ebenenbedienfeld erscheint. Sie können die Reihenfolge der Zeilen anpassen, indem Sie auf Objekte in der Überschriftenleiste klicken. Sortieren Sie sie nach Variablenname, Objektname oder Variablentyp.

Variablenbedienfeld

A. Datensatz B. Bedienfeldmenü C. Wechseln zwischen Datensätzen D. Name des gebundenen Objekts E. Variablenname F. Variablentyp G. Variablen sperren H. Objekt dynamisch machen I. Sichtbarkeit dynamisch machen J. Variablenbindung lösen K. Erstellen von Variablen L. Löschen von Variablen 

Schnelle Schritte zum Zusammenführen von Daten

  1. Erstellen Sie ein Illustrator-Dokument, um es als Vorlage zu verwenden.

  2. Erstellen Sie Ihre Datenquelldatei im CSV- oder XML-Format. Weitere Informationen finden Sie unter Vorbereiten einer Datenquelldatei.

  3. Importieren Sie eine Datenquelldatei in Illustrator über das Variablenbedienfeld. Weitere Informationen finden Sie unter Importieren einer Datenquelldatei.

  4. Verknüpfen Sie eine Variable mit einem Objekt in Ihrer Vorlage. Weitere Informationen finden Sie unter Verknüpfen von Variablen mit Objekten.

  5. Zeigen Sie das Dokument mit den einzelnen Datensätzen in der Vorschau an, bevor Sie alle Dateien exportieren. Weitere Informationen finden Sie unter Vorschau des Dokuments mit den einzelnen Datensätzen in der anzeigen.

  6. Exportieren Sie mehrere Dateien aus den Daten über das Aktionenbedienfeld in Illustrator. Weitere Informationen finden Sie unter Exportieren von Dateien über das Aktionenbedienfeld.

Vorbereiten einer Datenquelldatei

Datenquelldateien sollten im CSV- (kommagetrennte Liste) oder XML-Format (Extensible Markup Language) gespeichert werden.

Einrichten Ihrer CSV-Quelldateien

In einer kommagetrennten Textdatei (.CSV) sind Datensätze durch Absatzmarken und Felder durch Kommata oder Tabulatoren voneinander abgetrennt. Die Datenquelldatei kann auch Text oder Pfade enthalten, die auf Bilder auf einem Datenträger verweisen. Führen Sie vor dem Importieren einer CSV-Datei die folgenden Schritte aus, damit Illustrator den Variablentyp identifizieren kann.

  1. Öffnen Sie Ihre Tabelle.

  2. Geben Sie Ihren Datenfeldnamen in der ersten Zeile Ihrer Tabelle an. Dann gehen Sie wie folgt vor:

    • Geben Sie direkt vor dem Namen des Datenfelds ein „At“-Symbol (@) ein, um Text oder Pfade einzufügen, die auf Bilddateien verweisen. Das @-Symbol muss nur in der ersten Zeile eingegeben werden. Die darauf folgenden Zeilen müssen die Pfade zu den Bildern enthalten.
    • Geben Sie analog dazu direkt am Anfang des Datenfeldnamens ein Prozentsatzsymbol (%) für Diagramme und ein Rautezeichen (#) für Sichtbarkeit ein.
    Hinweis:
    • Die Datenfeldnamen in Ihrer Tabelle dürfen keine Leerzeichen enthalten. Zum Beispiel können Sie das Datenfeld als Firmen_name anstelle von Firmennameangeben.
    • Ebenso sollten die Pfade, die sich auf Bild- und Diagrammdateien beziehen, keine Leerzeichen enthalten. Zum Beispiel sollte der Pfad einer Bilddatei C:\\Bilder\BillTucker statt C:\Bilder\Bill Tucker lauten.
    • Alle Diagrammdateien aus Ihrer Datenquelle sollten als kommagetrennte Dateien (.csv) gespeichert werden.
    • Wenn Sie beim Eingeben des @-Symbols am Anfang des Feldes eine Fehlermeldung erhalten, geben Sie vor dem @-Symbol einen Apostroph (') ein (z. B. '@Bilder), um die Funktion zu validieren. Bei einigen Anwendungen, wie z. B. Microsoft Excel, ist das @-Symbol für Funktionen reserviert.

    (Windows) Beispiel für Bild- und Diagrammverweise in der Datenquelldatei

    Name

    Alter

    @Bilder

    %Diagramme

    Bill Tucker

    36

    C:\Bilder\BillTucker.jpg

    C:\Bilder\BillTucker.csv

    Dat Nguyen

    53

    C:\Eigene Dateien\dat.jpg

    C:\Eigene Dateien\dat.csv

    Maria Ruiz

    26

    C:\Bilder\Ruiz.jpg

    C:\Bilder\Ruiz.csv

    (macOS) Beispiel für Bild- und Diagrammverweise in der Datenquelldatei

    Name

    Alter

    @Bilder

    %Diagramme

    Bill Tucker

    36

    /Benutzer/Bilder/BillTucker.jpg

    /Benutzer/Bilder/BillTucker.csv

    Dat Nguyen

    53

    /Benutzer/Familie/Bilder/dat.jpg

    /Benutzer/Familie/Bilder/dat.csv

    Maria Ruiz

    26

    /Benutzer/alpha/Bilder/Ruiz.jpg

    /Benutzer/alpha/Bilder/Ruiz.csv

  3. Geben Sie Ihre Daten in die Tabelle ein.

  4. Führen Sie einen der folgenden Schritte durch:

    • Speichern Sie Tabellen, die mit der neuesten Version von Microsoft Excel (2016) erstellt wurden, in folgenden Dateiformaten:
      • CSV (Kommagetrennt) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Speichern Sie Tabellen, die mit Apple Numbers erstellt wurden, im CSV-Format mit Unicode-Kodierung (UTF-8).
    Hinweis:

    Zur Zeit werden in den oben erwähnten Formaten exportierte CSV-Dateien im Illustrator unterstützt. Andere CSV-Dateiformate, wie z. B. kommagetrennte Dateien (.csv) von Macintosh, werden für die Datenzusammenführung nicht unterstützt.

Vorbereiten einer XML-Datei

  1. Definieren Sie eine Variable in Ihrem Dokument. Weitere Informationen finden Sie unter Verknüpfen von Variablen mit Objekten.

  2. Klicken Sie auf die Schaltfläche „Datensatz erfassen“ () im Variablenbedienfeld. Sie können auch im Menü des Variablenbedienfelds die Option Datensatz erfassen auswählen.

  3. Wählen Sie nach der Erstellung der gewünschten Anzahl von Datensätzen Variablen-Bibliothek speichern aus dem Variablenbedienfeldmenü, um die Datensätze als XML-Datei zu speichern. Geben Sie einen Dateinamen und einen Speicherort an und klicken Sie auf Speichern.

    Exportieren der von Ihnen in Illustrator erstellten Variablen als XML-Datei

  4. Editieren Sie nun die XML-Datei in einer Textbearbeitungsanwendung wie Notepad++ (Windows) oder TextWrangler (macOS), um Ihre Datensätze in diese Datei einzubinden.

    Beispiel: die Bearbeitung einer XML-Datei mit Hilfe einer Textbearbeitungsanwendung.

    A. Ersetzen des Pfads des Bildes B. Ersetzen der Textzeichenfolge 

  5. Um Ihre XML-Datei in Illustrator zu importieren, wählen Sie Variablen-Bibliothek laden aus dem Variablenbedienfeldmenü. Wählen Sie die XML-Datei aus und klicken Sie auf Öffnen.

    Variablen in Illustrator importieren

Importieren einer Datenquelldatei

Um Variablen mit den gewünschten Daten zu verknüpfen, importieren Sie im Variablenbedienfeld eine Datenquelle. Pro Dokument kann immer nur eine Datenquelldatei ausgewählt werden.

  1. Wählen Sie Fenster > Variablen.

  2. Klicken Sie im Variablenbedienfeld auf Importieren.

    Importieren einer Datenquelldatei über das Variablenbedienfeld

  3. Wählen Sie im Dialogfeld „Variablen-Bibliothek laden“ eine Datenquelldatei im CSV- oder XML-Format und klicken Sie auf Öffnen.

    Auswählen einer CSV- oder XML-Datenquelldatei

  4. (Optional) Sie können die Daten später bearbeiten, umbenennen oder löschen, indem Sie sie zuerst vom Datensatz- Dropdown-Menü auswählen und ihre Optionen bearbeiten.

    • Wählen Sie zum Wechseln zwischen den Datensätzen einen Datensatz aus der Datensatzliste im Variablenbedienfeld aus. Sie können auch auf die Schaltflächen „Vorheriger Datensatz“ () und „Nächster Datensatz“ () klicken.
    • Wählen Sie zum Anwenden der Daten auf der Zeichenfläche auf den aktuellen Datensatz die Option Datensatz aktualisieren aus dem Variablenbedienfeld.
    • Soll ein Datensatz umbenannt werden, bearbeiten Sie den Text direkt im Datensatz- Textfeld. Doppelklicken Sie alternativ auf das Wort Datensatz (links neben dem Datensatz- Textfeld), geben Sie einen neuen Namen ein und klicken Sie auf OK.
    • Um einen Datensatz zu löschen, klicken Sie auf das Symbol „Löschen“. Wählen Sie alternativ Datensatz löschen im Menü des Variablenbedienfelds.

Verknüpfen von Variablen mit Objekten

Mit Variablen definieren Sie, welche Elemente einer Vorlage Sie ändern möchten. Sie können vier Variablentypen definieren: Variable „Sichtbarkeit“, Variable „Textzeichenfolge“, Variable „Verknüpfte Datei“ und Variable „Diagrammdaten“. Welche Objektattribute verändert werden können, hängt vom ausgewählten Variablentyp ab. Jede Variable, die im Dokument enthalten ist, ist mit ihrem Typ und ihrem Namen im Bedienfeld aufgeführt. Wenn die Variable mit einem Objekt verknüpft ist, wird in der Spalte „Objekte“ der Name des verknüpften Objekts so angezeigt, wie er im Ebenenbedienfeld erscheint.

Variablentyp

Symbol zum Anzeigen des Variablentyps

Definition

Sichtbarkeitsvariablen

Bildmaterial ein- oder ausblenden.

Textzeichenfolge-Variablen

Textzeichenfolge ersetzen.

Verknüpfte Datei-Variablen

Objekt auf der Zeichenfläche mit einem Objekt aus einer anderen Datei ersetzen.

Diagrammdaten-Variablen

Werte in einem Diagramm werden ersetzt.

Variable ohne Typ (nicht gebunden)

Nicht mit einem Objekt verknüpft.

Führen Sie zum Definieren von Variablen in Illustrator die folgenden Schritte aus:

  1. Wählen Sie ein Objekt aus.

  2. Wählen Sie im Variablenbedienfeld (Fenster > Variablen), die Variable aus, mit der Sie das Objekt verknüpfen möchten.

  3.  Führen Sie zum Verknüpfen des Objekts mit der Variable einen der folgenden Schritte aus:

    • Klicken Sie auf die Schaltfläche „Objekt dynamisch machen“ ().
    • Wählen Sie aus dem Bedienfeldmenü die Option Objekt dynamisch machen.

Führen Sie zum Erstellen einer Variablen ohne Verknüpfung mit einem Objekt einen der folgenden Schritte aus:

  1. Klicken Sie im Variablenbedienfeld auf die Schaltfläche „Neue Variable“ () oder wählen Sie im Bedienfeldmenü die Option Neue Variable.

  2. Soll die Variable nachträglich an ein Objekt gebunden werden, wählen Sie das Objekt und die Variable aus und klicken Sie auf die Schaltfläche „Sichtbarkeit dynamisch machen“ () bzw. „Objekt dynamisch machen“ (). Wählen Sie alternativ eine der folgenden Optionen aus dem Bedienfeldmenü.

Arbeiten mit Variablen

Sie können im Variablenbedienfeld den Namen oder Typ einer Variablen bearbeiten, eine Variablenbindung lösen und Variablen sperren.

Wenn Sie die Bindung der Variablen lösen, wird die Verknüpfung zwischen der Variablen und ihrem Objekt aufgehoben. Sind die Variablen gesperrt, können weder Variablen erstellt oder gelöscht noch Variablenoptionen bearbeitet werden. An gesperrte Variablen können jedoch weiterhin Objekte gebunden werden und diese Bindungen können auch weiterhin gelöst werden.

Ändern des Namens oder Typs einer Variablen

  1. Doppelklicken Sie im Variablenbedienfeld auf die Variable. Sie können auch die Variable im Variablenbedienfeld und anschließend aus dem Menü des Variablenbedienfelds die Option Variablen-Optionen auswählen.

Lösen einer Variablenbindung

  1. Klicken Sie im Variablenbedienfeld auf die Schaltfläche „Variablenbindung lösen“ () oder wählen Sie im Menü des Variablenbedienfelds die Option Variablenbindung lösen.

Sperren oder Entsperren aller Variablen in einem Dokument

  1. Klicken Sie auf die Schaltfläche zum Sperren/Entsperren von Variablen  oder  im Variablenbedienfeld.

Löschen von Variablen

Wenn Sie eine Variable löschen, wird sie aus dem Variablenbedienfeld entfernt. War die gelöschte Variable an ein Objekt gebunden, wird das Objekt statisch (es sei denn, das Objekt ist noch an eine Variable eines anderen Typs gebunden).

  1. Wählen Sie eine Variable aus, die Sie löschen möchten.

  2. Führen Sie einen der folgenden Schritte durch:

    • Klicken Sie im Variablenbedienfeld auf die Schaltfläche „Variable löschen“ () oder wählen Sie im Menü des Variablenbedienfelds die Option Variable löschen.

    • Soll die Variable ohne Bestätigung gelöscht werden, ziehen Sie sie auf die Schaltfläche „Variable löschen“ ().

Bearbeiten von dynamischen Objekten

Die mit einer Variablen verbundenen Daten können Sie ändern, indem Sie das Objekt bearbeiten, an das die Variable gebunden ist. Wenn Sie beispielsweise mit einer Variablen „Sichtbarkeit“ arbeiten, können Sie den Sichtbarkeitsstatus des Objekts im Ebenenbedienfeld ändern. Das Bearbeiten von dynamischen Objekten erlaubt es Ihnen, mehrere Datensätze zur Verwendung in der Vorlage erstellen.

  1. Wählen Sie auf der Zeichenfläche ein dynamisches Objekt aus, oder führen Sie einen der folgenden Schritte aus, um ein dynamisches Objekt auszuwählen:

    • Klicken Sie im Variablenbedienfeld bei gedrückter Alt- (Windows) bzw. Wahltaste (Mac OS) auf eine Variable.

    • Wählen Sie eine Variable im Variablenbedienfeld aus und wählen Sie dann aus dem Menü des Variablenbedienfelds Gebundenes Objekt auswählen.

    • Sollen alle dynamischen Objekte ausgewählt werden, wählen Sie im Menü des Variablenbedienfelds die Option „Alle gebundenen Objekte auswählen“.

  2. Bearbeiten Sie die mit dem Objekt verbundenen Daten wie folgt:

    • Handelt es sich um ein Textobjekt, bearbeiten Sie die Textfolge auf der Zeichenfläche.

    • Handelt es sich um eine verknüpfte Datei, ersetzen Sie das Bild über das Verknüpfungenbedienfeld oder den Befehl Datei > Platzieren.

    • Handelt es sich um ein Diagramm, bearbeiten Sie die Daten im Dialogfeld „Diagrammdaten“.

    • Handelt es sich um ein Objekt mit dynamischer Sichtbarkeit, ändern Sie den Sichtbarkeitsstatus für das Objekt im Ebenenbedienfeld.

Identifizieren von dynamischen Objekten mit XML-IDs

Im Variablenbedienfeld werden die Namen der dynamischen Objekte so angezeigt, wie sie im Ebenenbedienfeld erscheinen. Wenn Sie eine Vorlage im SVG-Format speichern, um sie in anderen Adobe-Produkten zu verwenden, müssen diese Objekte den XML-Namenskonventionen entsprechen. XML-Namen müssen beispielsweise mit einem Buchstaben, Unterstrich oder Doppelpunkt beginnen und dürfen keine Leerzeichen enthalten.

Illustrator weist jedem von Ihnen erstellten dynamischen Objekt automatisch eine gültige XML-ID zu. Sollen Objektnamen mithilfe von XML-IDs angezeigt, bearbeitet und exportiert werden, wählen Sie „Bearbeiten“ > „Voreinstellungen“ > „Einheit“ (Windows) bzw. „Illustrator“ > „Voreinstellungen“ > „Einheit“ (Mac OS) und dann die Option „XML-ID“ aus.

Zeigen Sie das Dokument mit den einzelnen Datensätzen in der Vorschau an

Wenn Sie sehen möchten, wie die endgültigen Grafiken aussehen werden, können Sie alle Dateien vor dem Exportieren in der Vorschau anzeigen. Verwenden Sie die Pfeiltasten neben „Datensatz“ im Variablenbedienfeld, um zum gewünschten Datensatz in Ihrem Dokument zu navigieren und diesen in der Vorschau anzuzeigen.

Exportieren von Dateien mit dem Aktionenbedienfeld

Wenn Sie Variablen sowie mindestens einen Datensatz definiert haben, können Sie Bildmaterial mit den Datensatzwerten im Stapelverarbeitungsmodus ausgeben. Führen Sie die folgenden Schritte durch:

  1. Zeichnen Sie mit dem Aktionenbedienfeld (Fenster > Aktionen), eine Aktion auf, um Ihr Dokument im gewünschten Format zu speichern. Weitere Informationen finden Sie unter Automatisieren mit Aktionen.

  2. Wählen Sie aus dem Aktionenbedienfeld die Option Stapelverarbeitung aus und wählen Sie die Aktion aus, die Sie im vorherigen Schritt erstellt haben.

  3. Wählen Sie als Quelle Datensätze, um die Aktion auf jeden Datensatz in der aktuellen Datei anzuwenden.

  4. Geben Sie unter „Ziel“ ein, was mit den verarbeiteten Dateien geschehen soll. Sie können die Dateien geöffnet lassen, ohne die Änderungen zu speichern („Ohne“), die Dateien schließen und am aktuellen Speicherort speichern („Speichern und Schließen“) oder die Dateien an einem anderen Speicherort speichern („Ordner“).

    Je nach ausgewählten Zieloptionen können Sie zusätzliche Optionen für das Speichern der Dateien auswählen. Weitere Informationen finden Sie unter Anwenden einer Aktion auf mehrere Dateien.

  5. Klicken Sie auf OK.

Speichern Sie eine Vorlage für die Datenzusammenführung

Wenn Sie in einem Illustrator-Dokument Variablen definieren, erstellen Sie eine Vorlage für Datenzusammenführung. Sie können die Vorlage im SVG-Format speichern, damit sie in anderen Adobe-Produkten verwendet werden kann, z. B. in Adobe® Graphics Server. Beispielsweise kann ein Entwickler mit Adobe Graphics Server die Variablen in der SVG-Datei direkt mit einer Datenbank oder einer anderen Datenquelle verknüpfen.

  1. Wählen Sie Datei > Speichern unter, geben Sie einen Dateinamen ein, wählen Sie das SVG-Format als Dateityp aus und klicken Sie auf Speichern.

  2. Klicken Sie auf Mehr Optionen und wählen Sie Adobe Graphics Server-Daten einbeziehen. Mit dieser Option werden alle Informationen einbezogen, die für die Variablenersetzung in der SVG-Datei erforderlich sind.

  3. Klicken Sie auf OK.

Haben Sie Probleme beim Importieren Ihrer CSV-Datei?

Wenn Sie beim Hochladen einer CSV-Datei-Datei die folgende Fehlermeldung erhalten: Die Bibliothek für eingehende Variablen ist ungültig, überprüfen Sie Folgendes:

  • Ihre CSV-Datei ist nicht leer.
  • Die Tabellen, die Sie mit der neuesten Version von Microsoft Excel erstellt haben, sind im CSV-Format (kommagetrennt) (*.csv) oder als CSV (MS-DOS) (*.csv) gespeichert und mit Apple Numbers erstellte Dateien sind im CSV-Format mit Unicode (UTF-8)-Zeichencodierung gespeichert. Datenquelldateien, die in einem anderen Dateiformat gespeichert werden, wie z. B. Macintosh (kommagetrennt) (*.csv), werden bei der Datenzusammenführung nicht unterstützt.
  • Alle Spalten haben einen Datenfeldnamen. Zum Beispiel zeigt Illustrator die Fehlermeldung, wenn eine Spalte in Ihrer Datenquelle Daten enthält, aber keinen Datenfeldnamen hat.
  • Die Datenquelldatei hat keine leere Spalte zwischen ausgefüllten Spalten. Zum Beispiel zeigt Illustrator die Fehlermeldung, wenn Spalte B und D in Ihrer Datenquelldatei Daten enthalten, Spalte C jedoch leer ist.
Beispiel: Fehler bei der Einrichtung einer CSV-Quelldatei für die Datenzusammenführung

A. Der Datenfeldname fehlt für eine Spalte B. Es gibt eine leere Spalte zwischen gefüllten Spalten. 

  • Die Datenfeldnamen in Ihrer Tabelle dürfen keine Leerzeichen enthalten.
  • Die Pfade, die sich auf Bild- und Diagrammdateien in Ihrer Quelldatei beziehen, enthalten keine Leerzeichen.
  • Die in Ihrer Datenquelldatei verlinkten Diagrammdateien werden als kommagetrennte (.csv) Dateien gespeichert.
Adobe-Logo

Bei Ihrem Konto anmelden