Learn how to work simultaneously in shared projects within the Adobe video applications, and use deep collaboration features like version control and smart conflict resolution for Adobe Premiere Pro CC, After Effects CC, and Adobe Prelude CC.

New features in Team Projects 

Watch this video to learn about the new features in Team Projects.

Using Team Projects (Beta)

Team Projects is a hosted collaboration service for CC enterprise and CC teams users that allows editors and motion graphics artists to work simultaneously in shared team projects within Adobe Premiere Pro CC, After Effects CC and Adobe Prelude CC. It includes deep collaboration features like version control and smart conflict resolution. Instead of creating local project files, collaborators can work together in a shared team project that you can open using Premiere Pro, After Effects or Prelude. The data in Team Projects is securely hosted in the cloud. You can store media files referenced by Team Projects as locally stored source files, or lightweight proxies shared via Creative Cloud or another cloud service or on-premise storage location.

Sharing projects across workgroups and workstations has never been easier with Team Projects. To learn more, see www.adobe.com/go/teamprojects.

Accessing the Team Projects (Beta) service

Team Projects is available for Creative Cloud for enterprise customers and Creative Cloud for teams customers with All Apps, Premiere Pro Single App, or After Effects Single app subscriptions. To know more, see Manage your Creative Cloud for teams membership or Upgrade or change your Creative Cloud plan. The service is compatible with the CC 2017 versions of Premiere Pro, After Effects, and Prelude. You must have CC services enabled and your computer must be connected to the Internet.

Connecting to the Team Projects service

To access the Team Projects service, you must be connected to the Internet and logged in to the Creative Cloud desktop application using your Creative Cloud Adobe ID and password. 

  1. Launch the CC 2017 version of Premiere Pro CC, After Effects CC, or Prelude CC.

  2. In the application, choose Help > Sign In.

  3. Sign in to Creative Cloud using your Creative Cloud Adobe ID and password.

Creating a team project

Team Project is a multiuser, multi-application alternative to an application-specific project file like a .prproj or .aep file.  Multiple users can work in a team project simultaneously. When a collaborator opens a Team Project, the Team Project service automatically makes a 'clone' of the current state of the team project for the user and opens it in a private session.

To create a Team Project:

  1. Click New Team Project in the Start screen of Adobe Premiere Pro CC, Prelude CC, or After Effects CC. You can also create a Team Project from the File menu by selecting File > New > Team Project.

    Creating a team project
    Creating a team project

  2. Enter a name for the Team Project (required) and a description (optional). You can invite collaborators to join the Team Project now, or wait and invite them later once you have added content.

  3. To invite collaborators now, click Edit. In the pop-up screen, enter the email address of those people you want to collaborate with. This email address must be the one they have associated with their Adobe ID.

  4. Click Invite. The user receives an invitation to collaborate that appears in the Creative Cloud desktop application under the Invite Tab of the Open Team Projects screen. 

Adding media to a team project

Team Projects collaboration data (metadata and media references associated with the project) are hosted in Adobe’s Creative Cloud. The media used in your Team Project must be available on each collaborator’s machine, either on network shared storage, copied to a local disk, or synchronized via cloud storage such as a shared Creative Cloud directory.

Your collaborators on a Team Project must all have access to, or their own copies of, the media used in the Team Project, otherwise the media appears offline. While collaborators want access to the media, it does not have to be in the same location. 

To import media into a Team Project:

  1. Choose File > Import or use the media browser panel. 

    Adding media to Team Project
    Adding media to Team Project

  2. Import media from your local drives, network drives, or from the media you have available in the Creative Cloud sync folders on your desktop. 

  3. Browse to the correct folder, select the media you want to add, and from the context menu, select Import from the context menu.

Converting a Premiere Pro Project to a Team Project

You cannot convert an After Effects or Prelude Project automatically to a Team Project. You can, however, import an After Effects composition into a Team Project.

 

  1. To convert a Premiere Project to a Team Project, open the Project and select Edit>Team Project>Convert Project to Team Project…

    Converting a Premiere Pro project to a Team Project
    Converting a Premiere Pro project to a Team Project

  2. Enter the name of your Team Project and a text description. You can add collaborators at this point or wait until later. Click OK.

    Entering the name and description
    Entering the name and description

Inviting collaborators to your Team Project

To invite other users to join a Team Project:

  1. Add collaborators directly in the Team Projects panel clicking the sign next to the Collaborator image thumbnails.

  2. Alternatively, in the File menu, select File > Team Project Settings.

  3. Choose Edit. In the pop-up screen, enter the email address of the people you want to collaborate with. This email address must be the one they have associated with their Adobe ID. You can also enter text and select known email addresses from a pop-up menu. Click Invite.

    Note:

    Collaborators must have a Creative Cloud for teams or enterprise license and have downloaded the CC 2017 versions of Premiere Pro, Prelude or After Effects to use the Team Projects service. 

    Inviting collaborators to your Team Project
    Inviting collaborators to your Team Project

Adding your profile picture to your collaborator icon

To add a profile picture to your Collaborator icon by updating your Creative Cloud profile:    

  1. In the Creative Cloud desktop application, click the gear icon in the upper right corner.  

  2. Select Manage Account

  3. Log in to your Creative Cloud account on the web. Click Profile and add or update your photo.

Accepting an invitation to collaborate

If you have been invited to collaborate on a Team Project, you receive an invitation notification in the Creative Cloud desktop application. There are two ways you can choose to accept or reject an invitation.

  1. Click Accept to accept the invitation in the CC desktop application. 

    Accepting an invitation
    Accepting an invitation

  2. To view Team Projects invitations that you have not yet accepted, choose File > Open Team Project > Invites. You can select and accept or reject any invitations you have received here as well.

    Note:

    If you want to remove yourself from a team project, you cannot have that team project currently open. 

Removing collaborators from a team project

To remove collaborators from a Team Project:

  1. Select the Team Project settings available under File > Team Project Settings

  2. Select Edit to select the user's email address you want to remove and click Remove.

Sharing changes

Instead of saving changes to a local project file, the Team Projects service saves your changes automatically in your local copy of the team project. When you are ready for your collaborators to see the changes that you have made, you can share them.

Sharing your changes with collaborators on the Team Project is easy. The Team Project service examines your private view of the Team Project, verifies that there are no conflicts with the work others have shared, and incorporates your changes into the current version of the shared Team Project. The updated version with your changes is immediately made available to your collaborators. There are two ways to share a change.

  • Click the up arrow available in the lower right corner of the left panel. 
  • Choose Edit > Team Project > Share My Changes.

You can see a screen that prompts you to enter a comment about the changes that have been made. Click Share to make your changes available to your Collaborators.

Get latest changes from collaborators

You are notified whenever collaborators share changes via a small badge on the assets thumbnail either when you are using the icon view or the Status column available in List view. At the same time, the Get Latest Changes icon in the Team Project panel lights up. You can either click the Get Latest Changes arrow or choose Edit > Team Project > Get Latest Changes. Any changes made by your collaborators are then synchronized and made available to you in a new version in your sandbox.

When another collaborator shares changes for any asset with you, a corresponding "shared" badge gets added to the item in the Team Project Panel, the Timeline, and the Program Monitor or Source Monitor. 

  1. You can see a yellow badge if another collaborator shares a new version, but the current user does not make any edits to it. The current user now knows that any edit made to this asset creates a conflict.

    New version shared by another collaborator
    New version shared by another collaborator

  2. If you have edited the asset and another collaborator shares a new version, a red badge is displayed.

    Badge denoting your edits to the asset that indicates when another collaborator shares a new version
    Badge denoting your edits to the asset that indicates when another collaborator shares a new version

  3. If you alone have edited the asset, a white "pencil" badge is displayed.

    Badge indicating projects edited only by you
    Badge indicating projects edited only by you

Resolving editing conflicts

With multiple collaborators working on a Team Project simultaneously, it is possible that some of the media that you have edited has conflicts with the changes that have been recently shared. If there are conflicts after you get the latest changes and then attempt to share your work, you get presented with a conflict resolution dialog and must resolve them before you are allowed to share. You can resolve them by using the conflict resolution screen, which shows you three conflict resolution options.

  • You can choose to keep your version.
  • You can choose to keep the shared version.
  • You can choose to copy and rename your version before accepting the shared version.

You can also decide whether to resolve all conflicts individually or collectively by selecting all the media.

Resolving editing conflicts
Resolving editing conflicts

Using the media management feature when collaborators add new media

If a collaborator adds media to a Team Project to which they have access in a different location than you (for example, they could be accessing media on a local drive and you have the same media in another folder) those files appear as offline media to you. To have these media available online, map the media location on your machine. Your collaborators on a Team Project want access to all assets in a shared location, or their own copies of the Team Project's assets. Otherwise, the media remains offline.   

  1. Choose Edit > Team Project > Media Management

    Media management
    Media management

  2. Click down to find the missing media.  

  3. Select one of the media and click New Media Mapping.  

  4. Navigate to the folder location where you have stored the media.  

  5. Select the correct media and click Choose.  

  6. Repeat the steps for remaining media.

  7. Click Close after you map all the missing media.

  8. The media now appears online and you can begin or continue working.

Interrupted Connection mode

Recognizing that the reliability of Internet connectivity varies across different geographies, Team Projects includes an Interrupted Connection mode feature that allows you to continue working in a Team Project even if your Internet connection gets temporarily interrupted. You would not be able to share your changes or Get Latest Changes from other collaborators, but you can continue working in a Team Project, and have your edits saved locally.

sync_network_Fail

You get notified that the Internet connection is interrupted and collaboration features are unavailable, but you can continue working locally. Notification messages would vary based on your action. 


sync_network_OK

When you are reconnected to the Internet, collaboration features including Get Latest Changes and Share option get enabled again.


Viewing Team Project history

Each time you share your changes, the server stores a new version of the Team Project. Versions are a permanent and easy way to maintain the history of a Team Project. You can easily view or go back to a previously shared version.

  1. To view previous versions of a Team Project, open the Media Browser in the Team Project panel.

    Viewing previous versions
    Viewing previous versions

  2. Select the Team Project that you want to see history for, by double clicking. Toggle the Team History Project Slider on. You can now drag the slider from top to bottom and see different versions of the Team Project.  

    Using the Team Project history slider
    Using the Team Project history slider

  3. To view the Team Project History as a list, right click your specific Team Project in the media browser and click Team Projects History…

    Viewing Team Project history as a list
    Viewing Team Project history as a list

  4. You can view a new screen that shows a list of comments and committed changes to the Team Project. If you select a particular version and click Browse, that version gets opened in the project history panel. 

    Note:

    Since Prelude does not have a media browser, you cannot do history modifications directly from within that application. 

Converting a Team Project to a Premiere Pro Project

  1. To convert a Team Project back into a Premiere Project select Edit>Team Project>Convert Team Project to Project….

    Converting a Team Project into a Premiere Pro project
    Converting a Team Project into a Premiere Pro project

  2. Enter the name of your Premiere Pro Project and any other settings for the format codec, and click OK.

    Entering the settings for your Premiere Pro project
    Entering the settings for your Premiere Pro project

Enter the name of your Premiere Pro Project and any required other settings for the format codec and click OK.

Converting a Team Project to an Adobe After Effects Project

To convert your Team Project to a local Adobe After Effects Project (.aep), select Edit > Team Project > Convert Team Project to Project.

Convert a Team Project to an Adobe After Effects Project
Convert a Team Project to an Adobe After Effects Project

Archiving a Team Project

When a Team Project gets archived, all collaborators who used the Team Project no longer have access. When you are a collaborator who gets removed from a Team Project, you can no longer access local copies of that Team Project.

 

  1. To archive a Team Project, select File ->Open Team Project (Beta)…

    Archiving a Team Project
    Archiving a Team Project

  2. Click the Team Project that you want to archive out of the list of projects that get displayed.

    Selecting the Archive option
    Selecting the Archive option

  3. You can now see a message that asks you to select Archive. Select Archive

    Moving Team Projects to Archive
    Moving Team Projects to Archive

When a Team Project gets Archived, all collaborators who the Team Project was shared with no longer get access. When you are a collaborator who gets removed from a Team Project, you can no longer access local copies of that Team Project.

Restoring an archived Team Project

  1. To restore an archived Team Project, select File ->Open Team Project (Beta).. 

  2. Open the Archive tab, select the Team Project you want to restore and click Restore

To restore an archived Team Project, go to File ->Open Team Project (Beta)... Open the Archive tab and select the Team Project you want to restore. Click Restore. 

Deleting an archived Team Project

  1. To delete an archived Team Project, choose the Archive tab of the Manage Team Projects panel.

    Deleting an archived Team Project
    Deleting an archived Team Project

  2. Select the Team Project you want to delete and click Delete

    Selecting the archived Team Project for deletion
    Selecting the archived Team Project for deletion

  3. Select Delete to permanently delete your Team Project from the system.

    Permanently deleting your Team Project
    Permanently deleting your Team Project

Editing layers with audio in a Team Project

You can edit layers with audio in your Team Project composition with the Edit > Edit in Adobe Audition command. The Edit in Adobe Audition command takes your layers with audio in to Adobe Audition for editing.

Editing layers with audio in a Team Project
Editing layers with audio in a Team Project

Importing Team Project media into Adobe Media Encoder for batch export

You can import and use Team Projects media which is visible under Media Browser>Creative Cloud > Team Projects. 

  1. If you have used Premiere, After Effects, or other Adobe applications on the same system, Adobe Media Encoder uses the same credentials to connect to the Team Projects service.

  2. If you are using Adobe Media Encoder as a stand-alone application, you would need to log in to creative cloud if you have not already signed in. 

  3. You can browse the contents available within your Team Projects within the Media Browser, including nested bins and folders. This is like browsing standard Premiere and After Effects projects. 

    Browsing Team Projects within Media Encoder
    Browsing Team Projects within Media Encoder

  4. If you are accessing Team Project media stored on a local system, this media would appear offline when you access the project from a different computer. Use Creative Cloud or other shared storage to store your media.

     

    Saving media to a network location – like the Creative Cloud shared folder – allows media to be accessed from multiple systemsOffline assets themselves will not be importable, but sequences/comps containing offline clips will still import with the "Offline Media" graphic
  5. If you want to view the earlier versions of the team projects, you can use the History slider. Tick marks on the vertical track indicate these earlier versions. To view the most recent version, set the slider to the top. Changes made to Team Projects in other apps are immediately updated in Media Browser under Adobe Media Encoder. 

     

    Using the slider to view earlier versions of team projects
    Using the slider to view earlier versions of team projects

  6. You can import and use assets available in the Team Projects folder the same way you can import and use standard Premiere & After Effects projects.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy