使用手冊 取消

使用「變數」面板進行資料合併

  1. Illustrator 使用手冊
  2. 認識 Illustrator
    1. Illustrator 簡介
      1. Illustrator 新增功能
      2. 常見問題
      3. Illustrator 系統需求
      4. 適用於 Apple Silicon 的 Illustrator
    2. 工作區
      1. 工作區基本介紹
      2. 使用 Illustrator 探索面板加快學習
      3. 建立文件
      4. 工具列
      5. 預設的鍵盤快速鍵
      6. 自訂鍵盤快速鍵
      7. 工作區域簡介
      8. 管理工作區域
      9. 自訂工作區
      10. 屬性面板
      11. 設定偏好設定
      12. 觸控工作區
      13. Illustrator 中的 Microsoft Surface Dial 支援
      14. 還原編輯和管理設計歷史記錄
      15. 旋轉檢視
      16. 尺標、格點和參考線
      17. Illustrator 協助工具
      18. 安全模式
      19. 檢視圖稿
      20. 搭配 Illustrator 使用 Touch Bar
      21. 檔案和範本
    3. Illustrator 中的工具
      1. 工具一覽
      2. 選取工具
        1. 選取範圍
        2. 直接選取
        3. 群組選取
        4. 魔術棒
        5. 套索
        6. 工作區域
      3. 導覽工具
        1. 手形
        2. 旋轉檢視
        3. 縮放顯示
      4. 上色工具
        1. 漸層
        2. 網格
        3. 形狀建立程式
      5. 文字工具
        1. 文字
        2. 路徑文字
        3. 垂直文字
      6. 繪圖工具
        1. 鋼筆
        2. 增加錨點
        3. 刪除錨點
        4. 錨點
        5. 曲線
        6. 線段區段
        7. 矩形
        8. 圓角矩形
        9. 橢圓
        10. 多邊形
        11. 星形
        12. 繪圖筆刷
        13. 點滴筆刷
        14. 鉛筆
        15. Shaper
        16. 切片
      7. 修改工具
        1. 旋轉
        2. 鏡射
        3. 縮放
        4. 傾斜
        5. 寬度
        6. 任意變形
        7. 滴管
        8. 漸變
        9. 橡皮擦
        10. 剪刀
        11. 尺寸
    4. 生成式 AI (在中國大陸無法使用)
      1. 使用文字提示產生向量圖形
      2. 使用文字提示為圖稿重新上色
    5. 快速動作
      1. 復古文字
      2. 霓虹光文字
      3. 老式文字
      4. 重新上色
      5. 將素描轉換為向量
  3. 網頁版 Illustrator (Beta)
    1. 網頁版 Illustrator (Beta) 概觀
    2. 網頁版 Illustrator (Beta) 常見問題集
    3. 疑難排解問題常見問題集
    4. 網頁版 Illustrator (Beta) 鍵盤快速鍵
    5. 在網頁版中建立和合併形狀
    6. 在網頁版中新增及編輯文字
    7. 在網頁版中套用顏色和漸層
    8. 在網頁版中繪製及編輯路徑
    9. 在網頁版中使用雲端文件
    10. 邀請共同作業人員在網頁版中進行編輯
  4. iPad 版 Illustrator
    1. iPad 版 Illustrator 簡介
      1. iPad 版 Illustrator 概觀
      2. iPad 版 Illustrator 常見問題集
      3. 系統需求 | iPad 版 Illustrator
      4. 在 iPad 版 Illustrator 上可以和不可以做的事
    2. 工作區
      1. iPad 版 Illustrator 工作區
      2. 觸控快捷鍵與手勢
      3. iPad 版 Illustrator 鍵盤快捷鍵
      4. 管理您的應用程式設定
    3. 文件
      1. 在 iPad 版 Illustrator 中處理文件
      2. 匯入 Photoshop 和 Fresco 文件
    4. 選取和排列物件
      1. 建立重複物件
      2. 建立漸變物件
    5. 繪圖
      1. 繪製及編輯路徑
      2. 繪製及編輯形狀
    6. 文字
      1. 使用類型和字型
      2. 沿路徑建立文字設計
      3. 新增自有字型
    7. 處理影像
      1. 將點陣圖向量化
    8. 顏色
      1. 套用顏色和漸層
  5. 雲端文件
    1. 基本概念
      1. 使用 Illustrator 雲端文件
      2. 共用 Illustrator 雲端文件並進行共同作業
      3. 共用文件以供審核
      4. 升級 Adobe Illustrator 的雲端儲存空間
      5. Illustrator 雲端文件 | 常見問題
    2. 疑難排解
      1. 疑難排解 Illustrator 雲端文件的建立或儲存問題
      2. 疑難排解 Illustrator 雲端文件問題
  6. 新增並編輯內容
    1. 繪圖與尺寸
      1. 繪圖基本介紹
      2. 編輯路徑
      3. 繪製像素級最佳化線條圖
      4. 使用筆型、曲線或鉛筆工具繪圖
      5. 繪製簡單線條和形狀
      6. 繪製矩形和放射網格
      7. 繪製及編輯反光
      8. 影像描圖
      9. 簡化路徑
      10. 符號工具和符號組
      11. 調整路徑區段
      12. 以 5 個簡單步驟設計花朵
      13. 建立和編輯透視格點
      14. 在透視格點上繪製和修改物件
      15. 使用物件作為重複使用的符號
      16. 繪製網頁工作流程的像素對齊路徑
      17. 測量和繪製尺寸
    2. 3D 物件和素材
      1. 關於 Illustrator 的 3D 效果
      2. 製作 3D 圖形
      3. 將圖稿對應到 3D 物件
      4. 建立 3D 文字
      5. 建立 3D 物件
    3. 顏色
      1. 關於色彩
      2. 選取顏色
      3. 使用及建立色票
      4. 調整顏色
      5. 使用「Adobe Color 主題」面板
      6. 顏色群組 (調協)
      7. 顏色主題面板
      8. 重新上色您的圖稿
    4. 上色
      1. 關於上色
      2. 使用填色與筆畫上色
      3. 即時上色群組
      4. 漸層
      5. 筆刷
      6. 透明度和漸變模式
      7. 將筆畫套用至物件
      8. 建立和編輯圖樣
      9. 網格
      10. 圖樣
    5. 選取和排列物件
      1. 選取物件
      2. 圖層
      3. 群組和展開物件
      4. 移動、對齊和均分物件
      5. 堆疊物件    
      6. 鎖定、隱藏及刪除物件
      7. 複製及重複物件
      8. 旋轉及鏡射物件
      9. 交織物件
      10. 製作擬真的藝術模型
    6. 改變物件外框
      1. 裁切影像
      2. 將物件變形
      3. 組合物件
      4. 剪下、分割和剪裁物件
      5. 操控彎曲
      6. 縮放、傾斜及扭曲物件
      7. 建立漸變物件
      8. 使用封套改變外框
      9. 使用效果改變物件外框
      10. 使用 Shaper 和形狀建立程式工具建立形狀
      11. 使用即時轉角
      12. 增強型改變外框工作流程和觸控支援
      13. 編輯剪裁遮色片
      14. 即時形狀
      15. 使用「形狀建立程式」工具建立形狀
      16. 整體編輯
    7. 文字
      1. 新增文字並使用文字物件
      2. 建立項目符號和編號清單
      3. 管理文字區域
      4. 字型和印刷樣式
      5. 將影像內的文字轉換為可編輯的文字
      6. 新增基本格式至文字
      7. 新增進階格式至文字
      8. 匯入和匯出文字
      9. 格式化段落
      10. 特殊字元
      11. 建立路徑文字
      12. 字元與段落樣式
      13. 定位點
      14. 尋找缺少的字型 (Typekit 工作流程)
      15. 阿拉伯文和希伯來文文字
      16. 字型 | 常見問題集和疑難排解提示
      17. 營造 3D 文字效果
      18. 創意印刷樣式設計
      19. 縮放與旋轉文字
      20. 行和字元間距
      21. 連字和分行符號
      22. 拼字及語言字典
      23. 設定亞洲字元格式
      24. 亞洲撰寫程式字體
      25. 使用漸變物件建立文字設計
      26. 使用影像描圖建立文字海報
    8. 建立特效
      1. 使用效果
      2. 繪圖樣式
      3. 外觀屬性
      4. 建立素描和馬賽克
      5. 陰影、光暈和羽化
      6. 效果摘要
    9. 網頁圖形
      1. 建立網頁圖形的最佳作法
      2. 圖表
      3. SVG
      4. 切片和影像地圖
  7. 匯入、匯出及儲存
    1. 匯入
      1. 置入多個檔案
      2. 管理連結檔案和嵌入的檔案
      3. 連結資訊
      4. 取消嵌入影像
      5. 從 Photoshop 匯入圖稿
      6. 匯入點陣影像
      7. 匯入 Adobe PDF 檔案
      8. 匯入 EPS、DCS 及 AutoCAD 檔案
    2. Illustrator 中的 Creative Cloud Libraries
      1. Illustrator 中的 Creative Cloud Libraries
    3. 儲存
      1. 儲存圖稿
    4. 匯出
      1. 在 Photoshop 中使用 Illustrator 圖稿
      2. 匯出圖稿
      3. 以批次方式收集資產及匯出
      4. 封裝檔案
      5. 建立 Adobe PDF 檔案
      6. 摘取 Extract CSS | Illustrator CC
      7. Adobe PDF 選項
      8. 文件資訊面板
  8. 列印
    1. 準備列印
      1. 設定列印的文件
      2. 變更頁面大小和方向
      3. 指定剪裁或對齊的裁切標記
      4. 開始使用大型畫布
    2. 列印
      1. 疊印
      2. 使用色彩管理進行列印
      3. PostScript 列印
      4. 列印預設集
      5. 印表機的標記和出血
      6. 列印和儲存透明圖稿
      7. 補漏白
      8. 分色列印
      9. 列印漸層、網格及色彩漸變
      10. 白色疊印
  9. 自動化工作
    1. 使用「變數」面板進行資料合併
    2. 以指令碼自動化
    3. 以動作自動化
  10. 疑難排解 
    1. 已知問題
    2. 當機問題
    3. 當機後復原檔案
    4. 檔案問題
    5. 支援的檔案格式
    6. GPU 裝置驅動程式問題
    7. Wacom 裝置問題
    8. DLL 檔案問題
    9. 記憶體問題
    10. 偏好設定檔案問題
    11. 字型問題
    12. 印表機問題
    13. 與 Adobe 分享當機報告
    14. 改善 Illustrator 的效能

使用「變數」面板將 Illustrator 文件與資料來源檔案合併 (CSV 或 XML 檔案),以建立圖稿的多種版本。您可以變更活動徽章上參與者的姓名,或者變換網頁橫幅與明信片上的影像,無須重新繪製您的圖稿。建立一個設計,然後匯入資料來源檔案中的姓名或圖片,即可快速產生變化。

使用「變數」面板,為不同專案的設計範本建立自訂變化,例如印刷海報、網頁橫幅和活動徽章。

在您繼續

您的資料合併僅需資料來源檔及目標文件即可。 

  • 資料來源檔案包含隨目標文件的每種版本而所不同的資訊,例如格式信件收件者的姓名、相片與地址。資料來源檔可以為逗號分隔檔案 (.csv) 或是可延伸標記語言檔案 (.xml)。
  • 目標文件是 Illustrator 的文件,其包含可以做為範本的基底圖稿。此文件可以包含資料欄位的預留位置及在每一合併文件版本中的相同項目。

存取資料合併功能

您可在 Illustrator 的「變數」面板中使用資料合併 (「視窗 > 變數」)。文件中各變數的類型與名稱會列於面板中。如果變數連結到物件,當物件出現在「圖層」面板時,「物件」直欄內就會顯示連結物件的名稱。您可按一下標頭列中項目來排序橫欄: 使用變數名稱、物件名稱或變數類型。

變數面板

A. 資料集 B. 面板選單 C. 在資料集間切換 D. 連結物件名稱 E. 變數名稱 F. 變數類型 G. 鎖定變數 H. 製作物件動態 I. 製作可見度動態 J. 解除連結變數 K. 建立變數 L. 刪除變數 

合併資料的快速步驟

  1. 建立要當作範本使用的 Illustrator 文件。

  2. 設定您的資料來源檔為 CSV 或 XML 格式。如需詳細資訊,請參閱準備資料來源檔案

  3. 使用「變數」面板,在 Illustrator 中匯入資料來源檔案。如需詳細資訊,請參閱匯入資料來源檔案

  4. 在您的範本中將變數連結至物件。如需詳細資訊,請參閱將變數連結至物件

  5. 在您匯出所有檔案之前,請以每個資料集預視文件。如需詳細資訊,請參閱以每個資料集預視文件

  6. 使用 Illustrator 中的「動作」面板從資料匯出一批檔案。如需詳細資訊,請參閱使用「動作」面板匯出檔案

準備資料來源檔案

資料來源檔案應以逗號分隔 (.csv) 或可延伸標記語言 (.xml) 格式儲存。

設定您的 CSV 來源檔案

在逗號分隔 (.csv) 檔案中,記錄是由段落分段所分隔;欄位則是由逗號或 Tab 字元來分隔。資料來源檔案也可包含文字或可檢視磁碟上影像的路徑。在匯入 CSV 檔案之前,請先執行下列動作,讓 Illustrator 識別變數類型。

  1. 開啟您的試算表。

  2. 在您的試算表第一列指定您的資料欄位名稱。接著,按照以下方式執行:

    • 在資料欄位名稱的開端輸入「@」符號,插入文字或參考影像檔案的路徑。「@」符號只有第一行需要;後續行應包含影像的路徑。
    • 同樣地,在資料欄位名稱的開端輸入「百分比」符號 (%) 做為圖表用途,以及「雜湊標記」符號 (#) 以提升可見度。
    • 若要定義物件的可見度,請為每個資料欄位指定 true 或 false。
    註解:
    • 您試算表上的資料欄位名稱不得包含空格。例如,您可以將資料欄位指定為 Company_Name,而不是 Company Name
    • 同樣地,參考影像和圖表檔案的路徑也不得包含空格。例如,影像檔案的路徑應該是  C:\Photos\BillTucker ,而不是 C:\Photos\Bill Tucker
    • 與資料來源檔案相連結的所有圖表檔案應儲存為逗號分隔 (.csv) 檔案。
    • 如果在欄位的開端輸入「@」符號時,出現了錯誤訊息,請在「@」符號前輸入半形單引號 (') (例如 '@Photos) 來驗證該函數。某些應用程式會保留「@」符號以供函數使用,例如 Microsoft Excel。

    (Windows) 資料來源檔案中的影像和圖表參照範例

    Name

    Age

    @相片

    %Graphs

    #可見度

    Bill Tucker

    36

    C:\Photos\BillTucker.jpg

    C:\Photos\BillTucker.csv

    True

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    True

    Maria Ruiz

    26

    C:\Photos\Ruiz.jpg

    C:\Photos\Ruiz.csv

    False

    (macOS)  資料來源檔案中的影像和圖表參照範例

    Name

    Age

    @相片

    %Graphs

    #可見度

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    True

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    True

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

    False

  3. 在試算表中輸入您的資料。

  4. 執行下列任一項動作:

    • 將使用最新版本 (2016 年版) Microsoft Excel 所建立的試算表儲存為以下檔案格式:
      • CSV (逗號分隔) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • 將使用 Apple Numbers 建立的試算表儲存為 CSV 格式並使用 Unicode (UTF-8) 編碼。
    註解:

    目前,Illustrator 支援匯出為上述格式的 CSV 檔案。其他 CSV 檔案格式,例如 Macintosh 的逗號分隔檔 (.csv) 就不支援資料合併。

準備一個 XML 檔案

  1. 在您的文件中定義變數。如需詳細資料,請參閱將變數連結至物件

  2. 選取「變數」面板中的「擷取資料集 」按鈕 。

  3. 建立所需數量的資料集後,從「變數」面板功能表中選取「儲存變數資料庫」,將資料集另存為 XML 檔案。請指定檔名和位置,然後選取「儲存」。

    將您在 Illustrator 中建立的變數匯出成 XML 檔案

  4. 現在,在文字編輯應用程式,如 Notepad ++ (Windows) 或 TextWrangler (macOS) 中,編輯 XML 檔案,將資料集包含在此檔案中。

    範例: 使用任何文字編輯應用程式來編輯 XML 檔案

    A. 取代影像路徑 B. 取代文字字串。  

  5. 從「變數」面板選單選取「載入變數資料庫」,以匯入在 Illustrator 中的 XML 檔案。選取 XML 檔案,然後選取「開啟」。

    將變數匯入至 Illustrator

匯入資料來源檔案

若要將變數連結至想要的資料,請在「變數」面板中匯入資料來源。每份文件只能選取一個資料來源檔案。

  1. 選擇「視窗 > 變數」

  2. 按一下「變數」面板中的「匯入」。

  3. 在「載入變數資料庫」對話框中,選取 CSV 或 XML 格式的資料來源檔案,然後選取「開啟」。

  4. 您可以在稍後從「資料集」下拉式選單中選擇資料集,並編輯其選項,以編輯、重新命名或刪除資料集。

    • 從「變數」面板中的「資料集」清單中選取資料集,以切換資料集。您也可以選取「上一個資料集 」按鈕或「下一個資料集 」按鈕。
    • 若要將工作區域上的資料套用至目前的資料集,請從「變數」面板選擇「更新資料集」。
    • 若要重新名資料集,請直接在「資料集」文字方塊中編輯文字。您可以按兩下「資料集」(在「資料集」文字方塊左邊)、輸入新名稱,並選取「確定」。
    • 若要刪除資料集,請按一下「刪除」圖示。您也可以從「變數」面板選單選取「刪除資料集」。
    註解:

    透過 Excel 建立的 CSV (UTF-8 逗點分隔檔) 檔案 (包含雙位元組字元) 無法在「變數」檔案中匯入。如果您以文字格式開啟同一檔案,然後另存為採用 UTF-8 編碼的 CSV,則可正確匯入檔案。

將變數連結至物件

變數可用來定義範本中變更您想要的元素。您可以定義四種變數類型:「可見度」變數、「文字字串」變數、「連結檔案」變數,以及「圖表資料」變數。變數類型指出哪一個物件屬性為可變 (動態)。文件中各變數的類型與名稱會列於面板中。如果變數連結到物件,當物件出現在「圖層」面板時,「物件」直欄內就會顯示連結物件的名稱。

變數類型

指出變數類型的圖示

定義

「可見度」變數

顯示或隱藏圖稿。

「文字字串」變數

取代文字字串。

「連結檔案」變數

使用其他檔案的物件來取代工作區域中的物件。

「圖表資料」變數

取代圖表中的值。

「無類型」(未連結) 變數

未連結至任何物件。

請依照這些步驟定義 Illustrator 中的變數:

  1. 選取物件。

  2. 在「變數」面板 (視窗 > 變數) 中,選取您要連結的變數。

  3.  選取「製作物件動態 」按鈕,以將物件與變數連結。

請依照以下步驟建立變數,而不將變數與物件連結:

  1. 選取「變數」面板中的「新增變數 」按鈕 。

  2. 如果之後要將物件連結到變數,請選取該物件及變數,然後選取「製作可見度動態 」按鈕或「製作物件動態 」按鈕。

註解:

變數名稱不支援代理字組和 4 位元組字元。如果您在變數名稱中使用這些字元,則會顯示一則錯誤訊息。

處理變數

您可以編輯變數的名稱或類型,解除連結變數,並使用「變數」面板鎖定變數。

解除連結變數會切斷變數與其物件之間的連結。鎖定變數將使您無法建立變數、刪除變數及編輯變數選項。然而,您可以將物件連結至已鎖定的變數,或解除物件連結。

變更變數名稱與類型

  1. 選取「變數」面板中的變數,然後從面板選單中選取「變數選項」。

解除連結變數

  1. 選取「變數」面板中的「解除連結變數 」按鈕 。

鎖定或解除鎖定文件中所有變數

  1. 選取「變數」面板中的「鎖定變數 」按鈕或「解除鎖定」按鈕。

刪除變數

刪除變數,以從「變數」面板移除該變數。如果您刪除連結至某物件的變數,則該物件會變為靜態 (除非該物件也連結至不同類型的變數)。

  1. 選取您要刪除的變數。

  2. 依照下列任一選項操作:

    • 選取「變數」面板中的「刪除變數 」按鈕 。

    • 若要直接刪除變數而不進行確認,請將變數拖移至「刪除變數 」按鈕上。

編輯動態物件

您可以藉由編輯變數連結的物件,變更與變數相關聯的資料。例如,如果正在處理「可見度」變數,可以在「圖層」面板中變更物件的可見度狀態。編輯動態物件可讓您建立多個範本中的資料集。

  1. 在畫板上選取動態物件,或執行下列任一項動作,以自動選取動態物件:

    • 在「變數」面板中,按住 Alt 鍵並按一下變數 (Windows),或按住 Option 鍵並按一下變數。

    • 選取「變數」面板中的變數,然後從「變數」面板選單中選取「選取連結物件」。

    • 從「變數」面板選單選取「所有連結文件 」,以選取所有動態物件。

  2. 依下列方式編輯與該物件相關的資料:

    • 請在工作區域上編輯文字字串。

    • 請使用「連結」面板取代影像,或對連結的檔案使用「檔案 > 置入」命令。

    • 編輯「圖表資料」對話框中圖表的資料。

    • 針對所有含動態可見度的物件,請在「圖層」面板中變更該物件的可見度狀態。

使用 XML ID 來識別動態物件

當動態物件出現於「圖層」面板中時,「變數」面板就會顯示這些動態物件的名稱。如果您以 SVG 格式儲存範本以便與其他 Adobe 產品一起使用,則這些物件的名稱必須符合 XML 的命名規則。例如,XML 名稱必須以字母、底線或冒號開頭,且不能包含空格。

Illustrator 會自動指派有效的 XML ID 至每一個您所建立的動態物件。如果要使用 XML ID 來檢視、編輯及匯出物件名稱,請選擇「編輯 > 偏好設定 > 單位 」(Windows) 或「Illustrator > 偏好設定 > 單位」 (Mac OS),然後選取 XML ID。

以每一個資料集預視文件

若要查看圖像最後的外觀,您可以在匯出之前先預視所有檔案。使用「變數」面板中「資料集」旁邊的方向鍵來導覽並預視您文件中的資料集。

使用「動作」面板匯出檔案

定義了變數以及一或多個資料集之後,您就可以在批次處理模式中,使用資料集數值輸出圖稿。請執行下列動作:

  1. 使用「動作」面板 (「視窗 > 動作」),記錄動作以將您的文件儲存成所需的格式。如需詳細資訊,請參閱藉由動作加以自動化

  2. 從「動作」面板選單中選擇「批次」,然選取您在上一步驟中建立的動作。

  3. 在「來源」中,選取「資料集」來播放目前檔案每一資料集的動作。

  4. 在「目的地」中,指定您想對處理過的檔案進行的動作。您可保持檔案開啟而不儲存變更 (無)、將所有檔案儲存在其目前位置並關閉 (儲存並關閉),或將檔案另存到不同位置 (檔案夾)。

    視所選取的「目的地」選項而定,可設定儲存檔案的其他選項。如需詳細資訊,請檢視在整批檔案上播放動作

  5. 選取「確定」。

儲存資料合併的範本

當您在 Illustrator 文件中定義變數時,即建立了一個資料合併的範本。您可以將範本儲存為 SVG 格式以供其他 Adobe 產品使用,例如 Adobe® Graphics Server。例如,一個使用 Adobe Graphics Server 的開發者可以將 SVG 檔案中的變數直接連結到資料庫或其他資料來源。

  1. 選擇「檔案 > 另存新檔」,輸入檔案名稱,選取 SVG 作為檔案格式,然後按一下「儲存」

  2. 按一下「更多選項」,並選取「包含 Adobe Graphics Server 資料」。此選項包括 SVG 檔案中所有替代變數所需的資訊。

  3. 按一下「確定」

匯入 CSV 檔案時發生問題嗎?

如果您在上傳 CSV 資料來源檔案時收到以下的錯誤訊息: 傳入的變數資料庫無效,請檢查下列項目:

  • 您的 CSV 檔案不是空白檔案。
  • 您使用最新版 Microsoft Excel 建立的試算表已儲存為 CSV (逗號分隔) (*.csv)  或 CSV (MS-DOS) (*.csv) ,且使用 Apple Numbers 建立的那些試算表已儲存為 CSV 格式並使用 Unicode (UTF-8) 編碼。資料來源檔案是否儲存為其他檔案格式,例如 Macintosh 逗號分隔檔 (.csv) 就不支援資料合併。
  • 所有欄位都有資料欄位名稱。例如,資料來源檔案中的欄位包含資料,但沒有資料欄位名稱時,Illustrator 就會顯示錯誤訊息。
  • 資料來源檔案在填滿的欄位間沒有空白欄位。例如,在您的資料來源檔案中,欄位 B 和 D 包含資料,但欄位 C 為空白時,Illustrator 就會顯示錯誤訊息。
範例: 設定 CSV 來源檔案以進行資料合併時發生錯誤

A. 某個欄位沒有資料欄位名稱 B. 填滿的欄位之間出現空白欄位 

  • 試算表上的資料欄位名稱並未包含空格。
  • 來源資料檔案中參考影像和圖表的路徑未包含任何空格。
  • 與資料來源檔案相連結的所有圖表檔案已儲存為逗號分隔 (.csv) 檔案。

相關資源

聯繫我們

我們很樂意聆聽您的意見。與 Adobe Illustrator 社群分享您的想法。

 Adobe

更快、更輕鬆地獲得協助

新的使用者?

Adobe MAX 2024

Adobe MAX
創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX

創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX 2024

Adobe MAX
創意大會

10 月 14 至 16 日邁阿密海灘和線上

Adobe MAX

創意大會

10 月 14 至 16 日邁阿密海灘和線上