Benutzerhandbuch Abbrechen

Arbeiten mit datengesteuerten Animationen

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
    3. Funktionen in der Beta-Version
      1. Bedienfeld „Eigenschaften“ (Beta)
      2. 3D-Modellimport (Beta)
      3. OpenColorIO- und ACES-Farbmanagement (Beta)
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formenpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle und Masken
    3. Spurmasken und Traveling Mattes
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Farb-Management
    3. Effekte zur Farbkorrektur
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekte unter „Simulation“
    4. Effekte unter „Stilisieren“
    5. Effekte unter „Audio“
    6. Effekte unter „Verzerren“
    7. Effekte unter „Perspektive“
    8. Effekte unter „Kanäle“
    9. Effekte unter „Generieren“
    10. Effekte unter „Überblenden“
    11. Der Effekt „Rolling-Shutter-Reparatur“
    12. Effekte unter „Weich- und Scharfzeichnen“
    13. Effekte unter „3D-Kanal“
    14. Effekte unter „Dienstprogramm“
    15. Effekte unter „Matt“
    16. Effekte unter „Störung und Körnung“
    17. Effekt „Hochskalieren mit Detailerhaltung“
    18. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Ausdruck
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Expression-Sprachreferenz
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Tracking der 3D-Kamerabewegung
    5. Arbeiten im 3D-Designraum
    6. 3D-Transformations-Gizmos
    7. Machen Sie mehr mit 3D-Animation
    8. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Mercury 3D-Engine
    9. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. H.264-Codierung in After Effects
    3. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    4. Konvertieren von Filmen
    5. Multi-Frame-Rendering
    6. Automatisches Rendern und Netzwerk-Rendern
    7. Rendern und Exportieren von Standbildern und Standbildsequenzen
    8. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. Cinema 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Frame.io installieren und aktivieren
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau behandelt    
    3. Verbessern der Leistung
    4. Voreinstellungen
    5. Anforderungen an GPU und GPU-Treiber für After Effects

Das Dokument enthält Informationen zur Arbeit mit datengesteuerten Animationen..

Datengesteuerte Animationen werden mithilfe von Live-Daten erstellt, die aus verschiedenen Datenquellen erfasst wurden, um die Animation in Ihrer Komposition zu steuern. Sie können Daten aus mehreren Datenquellen verwenden. Die Daten können statisch sein oder zeitlich variieren. Importieren Sie die Daten in Ihr After Effects-Projekt und verwenden Sie sie als Eingabe, um Diagramme, Figuren, visuelle Effekte, Filmtitel und andere Grafikanimationen zu animieren.

Beispiel für datengesteuerte Animationen
Beispiel für datengesteuerte Animationen

Datenquellen

Sie können Daten aus beinahe allen möglichen Quellen verwenden. Hierzu zählen u. a.:

  • Gerätegenerierte Datendateien – Daten von Geräten wie beispielsweise Fitness-Trackern, die Aktivitäten mithilfe von Sensoren aufzeichnen und sie in verschiedenen Dateiformaten speichern. Zu diesen zeitlich variierenden Daten zählen Geschwindigkeit, Höhe, Entfernung, Herzfrequenz und verschiedene andere Benutzeraktivitätsparameter.
  • Benutzergenerierte statische Daten – Globale statische Daten wie beispielsweise Umfrageergebnisse, die zur Steuerung von Grafiken geändert werden können. Mit einer benutzerdefinierten Datei kann ein Arbeitsablauf für globale Daten bereitgestellt werden.
  • URL – Echtzeitdaten von Websites wie Einstiegs- und Ausstiegspfade von Benutzern, die auf einer Webseite navigieren.
  • Metadaten – Daten, die in Metadaten von Videodateien eingebettet sind.

Eingabeformate

Sie können Datendateien in den folgenden Formaten importieren:

  • JSON
  • MGJSON
  • CSV
  • TSV
  • BVH

Wenn Sie über Datendateien in anderen Formaten verfügen, konvertieren Sie sie in eines der unterstützten Dateiformate und importieren Sie sie anschließend in das After Effects-Projekt. Es gibt verschiedene Werkzeuge zum Konvertieren von Dateien in Formate, die von After Effects unterstützt werden.

Datengesteuerte Animation

Unterstützung für Standard-JSON (.json)

Sie können eine standardmäßige JSON-Datei als Footage in After Effects importieren und die Datendateien arbeiten im Hintergrund. After Effects referenziert die Daten in diesen Datendateien direkt, um Animationen in den Projekten zu steuern. JSON-Footage wird nicht in Form von Datenströmen im Zeitleistenfenster dargestellt. Sie können die Daten mithilfe von Expressions als ausgewertetes JSON-Objekt referenzieren.

Sie können die Expressions ändern, um festzulegen, wie Daten referenziert werden. Sie können die Daten in einen Texteditor schreiben, der von After Effects referenziert wird, um Animationen zu steuern. Die JSON-Unterstützung basiert auf dem JSON-Schema, das angibt und definiert, wie eine Anwendung JSON-Daten verwenden und ändern kann.

Die grundlegenden JSON-Datentypen lauten:

  • Zahl: Eine vorzeichenbehaftete Dezimalzahl.
  • Zeichenfolge: Eine Folge aus null oder mehr Unicode-Zeichen.
  • Boolescher Wert: Einer der Werte „true“ oder „false“.
  • Array: Eine geordnete Liste von null oder mehr Werten.
  • Objekt: Eine ungeordnete Sammlung von Namen- und Wertpaaren, wobei die Namen (Schlüssel) Zeichenfolgen sind.
  • Null: Ein leerer Wert, für den das Wort „null“ angegeben ist.
Hinweis:

Wenn Sie Adobe Media Encoder verwenden oder die Kompositionen mit Premiere Pro verknüpfen möchten, fügen Sie die Datenquellendatei zum Schnittfenster hinzu, anstatt Ausdrücke zu verwenden, um auf Dateneinträge im Bedienfeld Projekt zu verweisen. Das Hinzufügen der Datendatei als Kompositionsebene stellt auch sicher, dass sie kopiert wird, wenn Sie Dateien sammeln.
wählen.

Verwenden von JSON-Dateien in After Effects

Zum Verwenden einer Standard-JSON-Datei gehen Sie wie folgt vor:

  1. Wählen Sie Datei > Importieren > Datei.

  2. Wählen Sie eine .JSON-Datei aus und klicken Sie auf Öffnen.

  3. Die Datei wird dem Projekt hinzugefügt. Erstellen Sie mit dem Footage eine Komposition.

  4. Fügen Sie eine Farbfläche zu einer Komposition hinzu. Um eine Farbfläche hinzufügen, wählen Sie Ebene > Neu > Farbfläche aus.

  5. Öffnen Sie im Schnittfenster die Eigenschaften der Farbflächenebene und öffnen Sie den Parameter Deckkraft. Dies geht wie folgt: Alt + Klick (Windows) bzw.  + Klick (macOS).

  6. Ändern Sie die Daten im Ausdruck, um Ihre Animation zu ändern. Sie können die JSON-Daten und die Datei verwalten, in der alle Informationen gespeichert sind.

  7. Sie können die JSON-Datei auch durch eine andere JSON-Datei ersetzen, um die referenzierten Daten zu ändern. Wählen Sie dazu Footage ersetzen > Datei aus und öffnen Sie die neue Datei von Ihrem Computer.

Um die Daten zu verwenden, können Sie eine Expression für die Eigenschaft anwenden, die durch die Daten gesteuert werden sollen. Gehen Sie anschließend folgendermaßen vor:

  1. Verwenden Sie das source Data-Attribut, um die Daten in einer JSON-Datei zu lesen. Beispiel:

    var sampleData = footage(“sampleson”)ourceData;
  2. Um den Wert zurückzugeben, referenzieren Sie die spezifische Eigenschaft innerhalb der JSON-Daten. Beispiel:

    myData.engineData.RPM or myData.latitude.value.

Unterstützung für Motion Graphics JSON (.mgJSON)

Sie können eine MGJSON-Datei als Filmmaterial in Ihr Projekt importieren. Wenn Sie Datenfootage zu einer Komposition hinzufügen, werden Dateneigenschaftsströme in eine Gruppe der obersten Ebene – in eine Datengruppe – gruppiert. Die Datengruppe zeigt Footagedaten als Eigenschaften an. Jede Eigenschaft in der Datengruppe ist per Expression mit der Footagedatei verknüpft. Der Zugriff auf den Wert der Datendatei erfolgt über die Expression footage("foo.mgjson").dataValue(N). Hier steht N für den Pfad zum Datenstrom in der Datei. MGJSON basiert auf einem Schema, das zur Vereinfachung des Referenzierens und Importierens von Datenströmen in After Effects dient.

Jede einzelne Dateneigenschaft verfügt über eine Expression, die diese Eigenschaft mit den Daten in der MGJSON-Datei verknüpft. Wenn die MGJSON-Datei geändert wird, werden die Dateneigenschaftswerte automatisch aktualisiert.

Sie können die Datenebenen im Zeitleistenfenster öffnen und das Auswahlwerkzeug verwenden, um Parameter mit anderen Parametern zu verknüpfen. Die Angaben zu den Änderungen werden automatisch ausgefüllt.

Verwenden von MGJSON-Footage in After Effects

Zum Verwenden einer MGJSON-Datei gehen Sie wie folgt vor:

  1. Wählen Sie Datei > Importieren > Datei.

  2. Wählen Sie zum Importieren eine MGJSON-Datei aus und klicken Sie dann auf Öffnen.

  3. Die Datei wird dem Projekt hinzugefügt. Erstellen Sie mit dem Footage eine Komposition.

  4. Importieren Sie ein Asset in das Projekt und fügen Sie es zur Komposition hinzu.

  5. Öffnen Sie im Zeitleistenfenster die Eigenschaften des Footage.

  6. Legen Sie mit dem Auswahlwerkzeug eine der Eigenschaften des Assets, z. B. Drehung, auf einen der Datenströme in der Datenebene fest. Die Asseteigenschaft referenziert nun die Daten von der Datenebene. Jeder dargestellte Datenstrom weist eine Expression auf, die seinen Wert aus der Footagedatei bezieht.

  7. Wenn Sie Footage in einer Vorschau anzeigen, wird das Asset anhand des Datenstroms der Datenebene animiert.

Sie können die Datensamples aus der Datei in Keyframes umwandeln. Führen Sie die folgenden Schritte aus, um die Samples in Keyframes umzuwandeln:

  1. Importieren Sie die MGJSON-Datei in Ihr Projekt und ziehen Sie sie ins Zeitleistenfenster.

  2. Klicken Sie mit der rechten Maustaste auf die Datenebene und wählen Sie im Menü Keyframe-Assistent > Keyframes aus Daten erstellen aus.

  3. Öffnen Sie zum Anzeigen der Keyframes die Datenebene.

Hinweis:

Nach der Keyframekonvertierung sind die Daten nicht mehr live und werden nicht von der Datendatei referenziert.

Sie können Live-Daten auch als Diagramm im Diagrammeditor anzeigen. Klicken Sie im Schnittfenster auf das Diagrammeditor-Symbol, um sie anzuzeigen.

Die datengesteuerte Animation stützt sich auf die Expression-Referenz. Weitere Informationen finden Sie unter Datengesteuerte Animation (Expression-Referenz).

Zeitliches Angleichen eines Videos an mgJSON-Daten

Der Befehl Ebene > Zeit > Video an Daten ausrichten verschiebt Videoebenen gemäß der Vorgabe in einer mgJSON-Datei um mehrere Frames. Damit können Sie Videos zeitlich an in einer passenden mgJSON-Datei gespeicherte Daten-Beispiele anpassen. Wenn Sie beispielsweise Daten während eines Rennens aufgezeichnet haben, die Startzeit des Videos jedoch nicht mit der Startzeit der aufgezeichneten Daten übereinstimmt, können Sie einen Versatz festlegen, sodass die Daten automatisch angeglichen werden.

Gehen Sie wie folgt vor, um Videos zeitlich an mgJSON-Daten anzugleichen:

  1. Fügen Sie die .mgJSON-Datei zu einer Komposition hinzu, die auch die Zielebenen enthält.
  2. Wählen Sie sowohl die .mgJSON-Ebene als auch die Zielebenen aus.
  3. Wählen Sie Ebene > Zeit > Video an Daten ausrichten aus.

Damit das gewünschte Ergebnis erzielt werden kann, muss die mgJSON-Datei eine videoSyncTimeList-Gruppe mit folgenden Elementen enthalten:

  • Den Namen mindestens einer Zielebene (fileName)
  • Die Anzahl der Frames (frameNumber), um die diese Ebenen vom Beginn der Datenebene aus versetzt werden sollen

Beispiel:

"videoSyncTimeList": [
  {
    "fileName": "sample1.mp4",
    "frameNumber": 1000
  },

  {
    "fileName": "sample2.mp4",
    "frameNumber": -1000
  }

Der Wert für „fileName“ muss der Ebenenname einer ausgewählten Ebene sein, nicht der Quellname der Ebene. Wenn Sie den Namen einer Ebene mit einer Quelle in Ihrer Komposition bearbeiten, also beispielsweise die Ebene „sample1.mp4“ in „Rennkamera 1“ umbenennen, müssen Sie auch den Wert „fileName“ in der mgJSON-Datei entsprechend anpassen. Von „fileName“ referenzierte Ebenen müssen keine Footage-Elemente mit Quelldatei sein. Es kann sich auch um Farbflächen, verschachtelte Kompositionen oder andere Ebenenarten handeln.

Positive frameNumber-Werte versetzen die Zielebene nach links (vor die Datenebene). Negative frameNumber-Werte versetzen die Zielebene nach rechts (hinter die Datenebene). Ein frameNumber-Wert von 0 gleicht den Beginn der Zielebene an den Beginn der Datenebene an.

Unterstützung für CSV (.csv) und TSV (.tsv oder .txt)

Sie können Dateien mit Komma als Trennzeichen (.csv) und mit Tabstopp als Trennzeichen (.tsv oder .txt) als Footage in After Effects importieren und als Datenquelle verwenden. CSV- und TSV-Dateien speichern tabellarische Daten im Normaltextformat, wobei die Werte entweder durch Kommas oder Tabstopps voneinander getrennt sind. Die CSV- und TSV-Datendateien funktionieren ähnlich wie JSON-Dateien.

Befolgen Sie diese Schritte, um CSV- oder TSV-Datendateien in After Effects zu verwenden:

  1. Importieren Sie eine CSV- oder TSV-Datei auf ähnliche Weise als Filmmaterial in Ihr Projekt, wie Sie Video-, Audio- oder sonstige Dateien importieren. Es gibt folgende Möglichkeiten, Ihre Dateien als Filmmaterial zu importieren:

    • Wählen Sie Datei > Importieren > Datei aus.
    • Klicken Sie mit der rechten Maustaste auf das Bedienfeld Projekte und wählen Sie Importieren > Dateityp aus.
    • Doppelklicken Sie auf das Projektfenster.
  2. Die Datei wird dem Projekt hinzugefügt. Erstellen Sie eine Komposition mit der Datei.

  3. Öffnen Sie im Zeitleistenfenster die Eigenschaften des Footage. Verknüpfen Sie die Dateneigenschaften der Ebene in der Komposition über das Expression-Auswahlwerkzeug oder das Eigenschaften-Link-Auswahlwerkzeug mit einer anderen Ebene. Um das Textfeld für Expressions zu öffnen, halten Sie die Umschalttaste gedrückt und klicken Sie auf das Timer-Symbol neben dem Namen der Ebene. Außerdem können Sie die Dateneigenschaften über den Befehl Bearbeiten > Mit Eigenschaften-Links kopieren verknüpfen.

    Weitere Informationen über Ebenendateneigenschaften in der Zeitleiste finden Sie unter Grundlagen zu Dateneigenschaften.

  4.  Um die Datenfootagedatei zu referenzieren, verwenden Sie eine Expression für die Eigenschaft, die von den Daten gesteuert werden soll. Verwenden Sie das Footage-Attribut dataValue(), um die Daten aus einer bestimmten Zeile und Spalte zu lesen. Zeilen und Spalten haben einen nullbasierten Index. Zum Beispiel gibt footage("sample.tsv").dataValue([15,1]) den Wert in Zeile 16 der zweiten Spalte zurück.

Grundlagen zu Dateneigenschaften

Wenn Sie eine JSON-, CSV- oder TSV-Datei zu einer Komposition hinzufügen und die Eigenschaften öffnen, enthalten sie nur eine Gruppe von Dateneigenschaften anstelle der Eigenschaftengruppe Transformieren. Die Eigenschaftsgruppe Daten enthält die Hierarchie der Daten, die in der Datei definiert ist.

JSON-Dateneigenschaftengruppe im Zeitleistenfenster
JSON-Dateneigenschaftengruppe im Zeitleistenfenster

CSV- und TSV-Dateneigenschaftengruppe im Zeitleistenfenster
CSV- und TSV-Dateneigenschaftengruppe im Zeitleistenfenster

Diese Datengruppe handhabt After Effects ähnlich wie Motion Graphics JSON (.mgJSON)-Dateien. Der Unterschied liegt darin, dass JSON, CSV und TSV lediglich statische Datenwerte enthalten können, während mgJSON dynamische Daten enthalten kann (Daten, die sich mit der Zeit ändern).

Jede einzelne Dateneigenschaft verfügt über einen Ausdruck, der diese Eigenschaft mit den Daten in der JSON-, CSV- oder TSV-Datei verknüpft. Wenn Sie die Quelldatendatei ändern, geben die Dateneigenschaftenwerte die Änderung wieder.

Verknüpfungseigenschaften mit dem Auswahlwerkzeug für Eigenschaftenverknüpfungen

Wenn Sie keine komplexen Ausdrücke schreiben möchten, können Sie das Eigenschaften-Link-Auswahlwerkzeug oder den Befehl Bearbeiten > Mit Eigenschaften-Links kopieren verwenden, um die Dateneigenschaften mit den Eigenschaften anderer Ebenen zu verknüpfen. Wenn Sie die Ebenen verknüpfen, schreibt das Eigenschaften-Link-Auswahlwerkzeug automatisch Ausdrücke für Sie.

Benutzerdefinierte Funktionsbibliotheken für Expressions – JSX

In After Effects 15.0 war es möglich, eine JSON-Datei zu importieren, die benutzerdefinierte JavaScript-Funktionen definierte, die als Bibliothek für benutzerdefinierte Expression-Funktionen verwendet werden konnten. In After Effects 15.1 sind JavaScript-Objekte keine zulässige Syntax für JSON. After Effects 15.1 verwendet einen anderen JSON-Parser. Dieser ist streng und erlaubt keinen Import einer JSON-Datei mit unzulässiger Syntax.

Wenn Sie versuchen, eine JSON-Datei mit einer definierten JavaScript-Funktion in After Effects 15.1 zu importieren oder ein Projekt mit einer solchen Datei zu öffnen, zeigt After Effects eine Fehlermeldung an.

Um dieses Problem zu umgehen, können Sie eine JavaScript-Syntaxerweiterungsdatei (.jsx) in After Effects 15.1 importieren. Der Inhalt der JSX-Datei kann dem der in After Effects 15.0 importierten JSON-Datei entsprechen. Sie müssen lediglich die Dateinamenerweiterung in .jsx ändern. Wenn Sie ein vorhandenes Projekt mit einer JSON-Datei öffnen wollen, die nicht funktioniert, klicken Sie auf Datei > Footage ersetzen, um die JSON-Datei durch die JSX-Datei zu ersetzen. Die Expression-Referenzen zur JSON-Datei werden mit Referenzen zur JSX-Datei ersetzt.

Bekannte Probleme mit der datengesteuerten Animation

Bei der Arbeit mit datengesteuerten Animationen in After Effects können diverse Probleme auftreten. Eine vollständige Liste finden Sie unter Bekannte Probleme mit datengesteuerten Animationen.

Adobe-Logo

Bei Ihrem Konto anmelden