Benutzerhandbuch Abbrechen

Dynamic Link und After Effects

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
    3. Funktionen in der Beta-Version
      1. Bedienfeld „Eigenschaften“ (Beta)
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
    10. Einrichtung und Installation
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Vorgehensweise beim Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formenpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle, Masken und Matten
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Verwenden der Erweiterung „Adobe Color-Designs“
    3. Farb-Management
    4. Effekte zur Farbkorrektur
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekte unter „Simulation“
    4. Effekte unter „Stilisieren“
    5. Effekte unter „Audio“
    6. Effekte unter „Verzerren“
    7. Effekte unter „Perspektive“
    8. Effekte unter „Kanäle“
    9. Effekte unter „Generieren“
    10. Effekte unter „Überblenden“
    11. Der Effekt „Rolling-Shutter-Reparatur“
    12. Effekte unter „Weich- und Scharfzeichnen“
    13. Effekte unter „3D-Kanal“
    14. Effekte unter „Dienstprogramm“
    15. Effekte unter „Matt“
    16. Effekte unter „Störung und Körnung“
    17. Effekt „Hochskalieren mit Detailerhaltung“
    18. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Ausdruck
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Expression-Sprachreferenz
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Tracking der 3D-Kamerabewegung
    5. Arbeiten im 3D-Designraum
    6. 3D-Transformations-Gizmos
    7. Machen Sie mehr mit 3D-Animation
    8. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Real-Time Engine
    9. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    3. Konvertieren von Filmen
    4. Multi-Frame-Rendering
    5. Automatisches Rendern und Netzwerk-Rendern
    6. Rendern und Exportieren von Standbildern und Standbildsequenzen
    7. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. CINEMA 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Installieren und Aktivieren von Frame.io
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Verbessern der Leistung
    3. Voreinstellungen
    4. Anforderungen an GPU und GPU-Treiber für After Effects

Dynamic Link

Früher mussten Sie für die gemeinsame Verwendung von Medienelementen in verschiedenen Post-Produktionsanwendungen Ihre Arbeit aus einer Anwendung rendern und exportieren, bevor Sie sie in eine andere Anwendung importieren konnten. Dies war ein ineffizienter und zeitaufwendiger Arbeitsablauf. Wenn Sie Änderungen am ursprünglichen Element vornehmen wollten, mussten Sie es erneut rendern und exportieren. Für mehrere gerenderte und exportierte Versionen eines Assets wird viel Festplattenspeicher belegt, was zu Schwierigkeiten beim Dateimanagement führen kann.

Dynamic Link bietet eine Alternative für diesen Arbeitsablauf. Sie haben die Möglichkeit, dynamische Links zwischen After Effects und Adobe Premiere Pro zu erstellen. Das Erstellen eines dynamischen Links ist so einfach wie das Importieren aller anderen Assettypen. Dynamisch verknüpfte Assets werden mit eindeutigen Symbolen und Beschriftungsfarben angezeigt, sodass Sie sie leicht erkennen können. Dynamische Links werden in Projekten aus den genannten Anwendungen gespeichert.

Erstellen und Verknüpfen von After Effects-Kompositionen mit Dynamic Link

Sie können neue After Effects-Kompositionen erstellen und von Adobe Premiere Pro aus dynamische Verknüpfungen für diese anlegen. Sie haben auch die Möglichkeit, dynamische Verlinkungen für vorhandene After Effects-Kompositionen über Adobe Premiere Pro zu erstellen.

Erstellen einer Komposition aus Clips in Adobe Premiere Pro

Sie können ausgewählte Clips in Adobe Premiere Pro durch eine auf diesen Clips basierende, dynamisch verknüpfte After Effects-Komposition ersetzen. In der neuen Komposition werden die Sequenzeinstellungen aus Adobe Premiere Pro übernommen.

  1. Öffnen Sie Premiere Pro und wählen Sie die Clips, die Sie ersetzen möchten.

  2. Klicken Sie mit der rechten Maustaste auf einen beliebigen der ausgewählten Clips.
  3. Wählen Sie dazu „Durch After Effects-Komposition ersetzen“.

    After Effects wird geöffnet (sofern es nicht bereits geöffnet ist) und eine neue verlinkte Komposition wird erstellt.

Erstellen einer dynamisch verlinkten Komposition aus Adobe Premiere Pro

Beim Erstellen einer neuen, dynamisch verknüpften Komposition mit Adobe Premiere Pro wird After Effects gestartet. After Effects erstellt dann ein Projekt und eine Komposition mit den Kompositionseinstellungen (Abmessungen, Pixel-Seitenverhältnis, Framerate und Audiosamplerate) des ursprünglichen Projekts. (Wird After Effects bereits ausgeführt, erstellt das Programm eine Komposition im aktuellen Projekt.) Der Name der neuen Komposition basiert auf dem Namen des Adobe Premiere Pro-Projekts, gefolgt von Verlinkte Komposition [x].

  1. Wählen Sie in Adobe Premiere Pro „Datei“ > „Adobe Dynamic Link“ > „Neue After Effects-Komposition“. In der Version 2014 von Premiere Pro können Sie Kompositionen mithilfe von Media-Browser importieren. Weitere Informationen finden Sie in den folgenden Abschnitten in Premiere Pro:

  2. Wenn in After Effects das Dialogfeld Speichern unter angezeigt wird, geben Sie einen Namen und einen Speicherort für das After Effects-Projekt an und klicken Sie auf „Speichern“.

    Hinweis:

    Beim Erstellen einer dynamisch verknüpften After Effects-Komposition wird die Kompositionsdauer auf 30 Sekunden gesetzt. Wenn Sie die Dauer ändern möchten, wählen Sie die Komposition in After Effects aus und klicken Sie dann auf „Komposition“ > „Kompositionseinstellungen“. Klicken Sie auf die Registerkarte „Einfach“ und geben Sie für „Dauer“ einen neuen Wert ein.

Gleichen Sie, um optimale Ergebnisse zu erzielen, die Kompositionseinstellungen (z. B. Maße, Pixel-Seitenverhältnis und Frame-Rate) an die Einstellungen in Adobe Premiere Pro an.

  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie in Adobe Premiere Pro Datei > Adobe Dynamic Link > After Effects-Komposition importieren. Wählen Sie eine After Effects-Projektdatei (.aep) und anschließend eine oder mehrere Kompositionen.

    • Wählen Sie in Adobe Premiere Pro eine After Effects-Projektdatei aus und klicken Sie auf „Öffnen“. Wählen Sie anschließend im angezeigten Dialogfeld eine Komposition und klicken Sie auf „OK“.

    • Ziehen Sie eine oder mehrere Kompositionen aus dem Projektfenster von After Effects in das Projektfenster von Adobe Premiere Pro.

    • Ziehen Sie eine After Effects-Projektdatei in das Projektfenster von Premiere Pro. Falls die After Effects-Projektdatei mehrere Kompositionen enthält, wird das Dialogfeld „Komposition importieren“ geöffnet.

Hinweis:

Sie können eine einzelne After Effects-Komposition mehrmals in einem einzigen Adobe Premiere Pro-Projekt verlinken.

Bearbeiten einer dynamisch verknüpften Komposition in After Effects

Mit dem Befehl Original bearbeiten in Adobe Premiere Pro können Sie eine verknüpfte After Effects-Komposition ändern. Sobald die Komposition in After Effects geöffnet ist, können Sie Änderungen daran vornehmen, ohne den Befehl „Original bearbeiten“ erneut verwenden zu müssen.

  1. Wählen Sie in Adobe Premiere Pro die After Effects-Komposition oder wählen Sie einen verlinkten Clip in der Zeitleiste, und klicken Sie dann auf „Bearbeiten“ > „Original bearbeiten“.

  2. Nehmen Sie die Änderungen an der Komposition in After Effects vor. Wechseln Sie dann wieder zurück zu Adobe Premiere Pro, um die Änderungen anzuzeigen.

Die in After Effects vorgenommenen Änderungen werden in Adobe Premiere Pro angezeigt. Etwaige Vorschaudateien, die vor den Änderungen für den Clip gerendert wurden, werden von Adobe Premiere Pro nicht mehr verwendet.

Hinweis:

Sie können in After Effects den Namen der Komposition ändern, nachdem Sie von Adobe Premiere Pro aus eine dynamische Verknüpfung zu dieser Komposition erstellt haben. Adobe Premiere Pro aktualisiert nicht den Namen der verknüpften Komposition im Projektbereich. Die dynamische Verknüpfung bleibt jedoch in Adobe Premiere Pro bestehen.

Löschen von dynamisch verknüpften Kompositionen oder Clips

In einem Adobe Premiere Pro-Projekt können Sie eine verlinkte Komposition jederzeit löschen, selbst wenn die Komposition in einem Projekt verwendet wird.

Sie können auch jederzeit verlinkte Clips aus der Zeitleiste einer Adobe Premiere Pro-Sequenz oder aus der Zeitleiste löschen.

  1. Wählen Sie dazu in Adobe Premiere Pro die verlinkte Komposition oder den Clip aus und drücken Sie die Entf-Taste.

Erstellen einer verknüpften Sequenz in Adobe Premiere Pro mit Dynamic Link

Beim Erstellen einer Adobe Premiere Pro-Sequenz mit After Effects wird Adobe Premiere Pro gestartet. Adobe Premiere Pro erstellt dann ein Projekt und eine Sequenz mit den Einstellungen (Abmessungen, Pixel-Seitenverhältnis, Framerate und Audiosamplerate) des ursprünglichen Projekts. (Wird Adobe Premiere Pro bereits ausgeführt, erstellt das Programm eine Sequenz im aktuellen Projekt.)

  1. Wählen Sie in After Effects „Datei“ > „Adobe Dynamic Link“ > „Neue Premiere Pro-Sequenz“.

Um optimale Ergebnisse zu erzielen, sollten die Sequenz- und Projekteinstellungen in Adobe Premiere Pro (z. B. Abmessungen, Pixel-Seitenverhältnis und Frame-Rate) den Einstellungen im After Effects-Projekt entsprechen.

Führen Sie einen der folgenden Schritte aus:

  • Wählen Sie in After Effects „Datei“ > „Adobe Dynamic Link“ > „Premiere Pro-Sequenz importieren“. Wählen Sie ein Adobe Premiere Pro-Projekt und dann eine oder mehrere Sequenzen.

  • Ziehen Sie eine oder mehrere Sequenzen aus dem Projektfenster von Adobe Premiere Pro in das Projektfenster von After Effects.

Dynamic Link-Leistung

Ein verknüpfter Clip kann auf eine komplexe Ausgangskomposition verweisen. Aktionen, die Sie in der Quellkomposition ausführen, erfordern daher je nach Komplexität zusätzliche Verarbeitungszeit. After Effects wendet die Aktionen an und macht die endgültigen Daten mithilfe des globalen Leistungs-Cache und des dauerhaften Disk-Cache für Adobe Premiere Pro verfügbar. Diese Funktionen verbessern die Leistung von After Effects, da sie zwischengespeicherte Frames verwenden, wenn diese von Premiere Pro angefordert werden.

Führen Sie einen der folgenden Schritte aus, um Wiedergabeverzögerungen zu reduzieren:

  • Die verlinkte Komposition offline nehmen

  • Einen verlinkten Clip deaktivieren, sodass vorübergehend nicht auf eine Komposition verwiesen wird

  • Ersetzen Sie die dynamisch verlinkte Komposition mithilfe der Funktion „Rendern und Ersetzen“ in Premiere Pro („Clip“ > „Rendern und Ersetzen“) durch die gerenderte Datei.  

Wenn Sie häufig mit komplexen Quellkompositionen arbeiten, sollten Sie Arbeitsspeicher hinzufügen oder einen schnelleren Prozessor verwenden.

Hinweis:

Eine verlinkte After Effects-Komposition unterstützt die Mehrprozessorverarbeitungsoption „Mehrere Frames gleichzeitig rendern“ nicht. Weitere Informationen finden Sie unter Leistung verbessern durch Optimierung der Speicher-, Cache- und Mehrprozessorverarbeitungs-Einstellungen.

Exportieren in Adobe Media Encoder

Um After Effects-Kompositionen zu codieren, müssen Sie das Element zu der Codierungswarteschlange in Adobe Media Encoder hinzufügen und anschließend Codierungsvorgaben auswählen oder eigene benutzerdefinierte Einstellungen für den Render-Vorgang erstellen. In After Effects stehen Ihnen folgende Möglichkeiten zur Verfügung, um eine Komposition zu der Media Encoder-Warteschlange hinzuzufügen:

  • „Datei“ > „Exportieren“ > „Zur Media Encoder-Warteschlange hinzufügen“
  • „Komposition“ > „Zur Media Encoder-Warteschlange hinzufügen“

Wenn Sie der Adobe Media Encoder-Warteschlange eine Komposition oder ein Projekt hinzufügen, startet After Effects das Programm Adobe Media Encoder mit den in der Warteschlange aufgeführten Kompositionen.

Der Codierungsprozess wird in den folgenden Artikeln beschrieben:

Adobe-Logo

Bei Ihrem Konto anmelden