Benutzerhandbuch Abbrechen

Anzeigen detaillierter Leistungsinformationen mit Composition Profiler

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
    3. Funktionen in der Beta-Version
      1. Bedienfeld „Eigenschaften“ (Beta)
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
    10. Einrichtung und Installation
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Vorgehensweise beim Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formenpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle, Masken und Matten
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Verwenden der Erweiterung „Adobe Color-Designs“
    3. Farb-Management
    4. Effekte zur Farbkorrektur
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekte unter „Simulation“
    4. Effekte unter „Stilisieren“
    5. Effekte unter „Audio“
    6. Effekte unter „Verzerren“
    7. Effekte unter „Perspektive“
    8. Effekte unter „Kanäle“
    9. Effekte unter „Generieren“
    10. Effekte unter „Überblenden“
    11. Der Effekt „Rolling-Shutter-Reparatur“
    12. Effekte unter „Weich- und Scharfzeichnen“
    13. Effekte unter „3D-Kanal“
    14. Effekte unter „Dienstprogramm“
    15. Effekte unter „Matt“
    16. Effekte unter „Störung und Körnung“
    17. Effekt „Hochskalieren mit Detailerhaltung“
    18. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Ausdruck
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Expression-Sprachreferenz
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Tracking der 3D-Kamerabewegung
    5. Arbeiten im 3D-Designraum
    6. 3D-Transformations-Gizmos
    7. Machen Sie mehr mit 3D-Animation
    8. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Real-Time Engine
    9. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    3. Konvertieren von Filmen
    4. Multi-Frame-Rendering
    5. Automatisches Rendern und Netzwerk-Rendern
    6. Rendern und Exportieren von Standbildern und Standbildsequenzen
    7. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. CINEMA 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Installieren und Aktivieren von Frame.io
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Verbessern der Leistung
    3. Voreinstellungen
    4. Anforderungen an GPU und GPU-Treiber für After Effects

Mit Composition Profiler können Sie detaillierte Leistungsinformationen für Ihre After Effects-Komposition anzeigen, einschließlich detaillierter vergleichender Aufschlüsselungen der Renderzeit für alle Ebenen, Effekte, Stile und Masken.

Aktivieren von Composition Profiler

Dropdown-Menü für die Spalte „Renderzeit“

So aktivieren Sie Composition Profiler:

  • Klicken Sie auf das Schneckensymbol  im unteren linken Fenster des Bedienfelds Timeline, um die Spalte Renderzeit anzuzeigen.

Oder 

  • Klicken Sie mit der rechten Maustaste auf die Spaltenüberschriften des Timeline-Fensters, und wählen Sie Spalten > Renderzeit aus dem Dropdown-Menü aus.
Hinweis:

Die dauerhafte Anzeige der Option „Renderzeit“ wirkt sich nicht auf die Gesamtleistung von After Effect aus.

Verwenden des Kompositionsprofilierers

Composition Profiler ist eine Visualisierung von Daten, die von After Effects beim Rendern des Frames erzeugt werden. Da der Rendering-Prozess stark optimiert ist, ist es wichtig zu verstehen, wie die verschiedenen Farbcodes und andere Elemente in der Timeline gelesen werden.

Leitfaden zur Farbcodierung

Lesen Sie den Leitfaden zur Farbcodierung, um zu erfahren, welche Farbe die erwartete Renderzeit für eine bestimmte Ebene oder Vorkomposition in Ihrem Projekt darstellt.

Farbcodes für unterschiedliche Renderzeiten

  • Renderzeiten, bei denen es sich um Vorgänge in Echtzeit oder quasi in Echtzeit (basierend auf der Kompositionsbildrate) handelt, werden als Grüntöne angezeigt.
  • Höhere Werte von 100 Millisekunden bis 5 Sekunden werden mit einer zunehmenden Intensität von Gelb bis Rot angezeigt.
  • Wenn die Bildrate Ihrer Komposition zu Echtzeit- oder Halbzeit-Renderzeiten führt, die länger als einer der festen Stopps sind, werden die festen Stopps bis zu dem Punkt übersprungen, an dem die festen Stopps größer als die Halbzeit sind.

Grundlegendes zur Benutzeroberfläche des Kompositionsprofilrs

A. Anzeige der Zeitdauer in Composition Profiler

B. Frame-Renderzeit

A. In der Spalte Renderzeit wird die Zeit (in Millisekunden oder Sekunden) angezeigt, die für das Rendern einer Ebene benötigt wurde. Ebenfalls angezeigt wird ein Balkendiagramm, das einen Vergleich der Zeit mit den Zeiten von anderen Ebenen im selben Frame anzeigt. Jedem dieser Balkendiagramme wird basierend auf der Renderzeit eine Farbe zugewiesen.

B. Die Anzeige „Frame-Renderzeit“ in der Fußzeile der Timeline zeigt die Gesamtzeit für das Rendern des aktuellen Frames an. Diese Anzeige ist standardmäßig immer aktiviert.

Sie können nicht nur sehen, wie lange das Rendern jeder Ebene dauert, sondern auch Ebenen erweitern, um eine Aufschlüsselung zu erhalten, wie viel Masken, Ebenenstile und einzelne Effekte zur Gesamtrenderzeit beitragen.

Composition Profiler-Anzeige für verschiedene Workflows

After Effects rendert jede Einstellung, jeden Workflow und jede Option unterschiedlich, daher variiert auch die Visualisierung des Kompositionsprofilierers entsprechend. Im Folgenden finden Sie einige Beispiele für Situationen und Beschreibungen dafür, wie diese von der Rendering-Pipeline behandelt werden:

-Vorkompositionen

Ebenen, die verschachtelte Kompositionen sind: Vorkompositionen zeigen ihre Renderzeiten genau an. Um genauer zu verstehen, welche Elemente der Vorkomposition zur Ebenenrenderzeit beitragen, müssen Sie möglicherweise die Vorkomposition öffnen und ihre Ebenen mit Composition Profiler untersuchen.

Wenn Sie dieselbe Vorkomposition mehrmals innerhalb einer Komposition verwenden, verwenden die höher im Ebenenstapel platzierten Vorkompositionen den Zwischenspeicher aus den Instanzen weiter unten im Ebenenstapel und zeigen eine schnellere Rendergeschwindigkeit an.

Caching

Ebenen, Effekte, Masken und Stile, die bereits ganz oder teilweise (im Zwischenspeicher) gerendert wurden, zeigen ihren Renderzeitwert mit einem Sternchen an.

In dieser Situation gibt die Renderzeit an, wie lange es dauert, etwas zu rendern, das nicht bereits zwischengespeichert ist, und wie lange es dauert, Elemente aus dem Cache abzurufen. Alle Elemente ohne Sternchen werden gerendert, ohne etwas aus dem Cache zu verwenden.

Da After Effects häufig zwischenspeichert, wählen Sie zum Profilieren eines Frames Bearbeiten > Bereinigen > Gesamten Arbeitsspeicher- und Datenträger-Cache, um zu erzwingen, dass dieser Frame von Grund auf neu berechnet wird.

Von Effekten referenzierte Ebenen

Angenommen, eine Ebene hat ihren Videoschalter ausgeschaltet, wird aber von einem anderen Ebeneneffekt referenziert, z. B. „Matte festlegen“. In diesem Fall umfasst die Renderzeit dieses Effekts die Zeit, die zum Rendern referenzierter Ebenen benötigt wird, und die Renderzeit der referenzierten Ebene ist leer. Dies liegt daran, dass After Effects die referenzierte Ebene nur als Teil des Rendervorgangs des Effekts rendert.

Im folgenden Beispiel melden sowohl „Matte festlegen Quellebene“ als auch „Ebenenübergreif. Weichzeichner Quellebene“ keine Renderzeit. Die Renderzeit für die Effekte „Matte festlegen“ und „Ebenenübergreif. Weichzeichner“ auf der Ebene „Footage mit Effekten“ enthält jedoch die Zeit, die zum Rendern der Ebenen „Matte festlegen Quellebene“ „Ebenenübergreif. Weichzeichner Quellebene“ benötigt wird.

Einstellungen für die Kompositionsansicht

Composition Profiler verwendet die aktuellen Einstellungen des Kompositions-Viewers. Wenn beispielsweise ihr Popup-Fenster „Auflösung/Abwertfaktor“-Anzeige für Kompositions-Viewer auf „Halb“ eingestellt ist, ist die profilierte Zeit schneller als bei einer Auflösung auf „Voll“.

 Wenn Sie Composition Profiler verwenden, empfehlen wir Ihnen, die adaptive Auflösung zu deaktivieren, damit die angezeigten Zeiten für die Vorschauauflösung genau sind.

Expressions

Die Berechnungszeit für Expressions ist in der Spalte „Renderzeit“ für die Eigenschaft verfügbar, die die Expression enthält. Die meisten Expressions laufen ziemlich schnell, sodass Sie für die meisten von ihnen mit einer angezeigten Zeit von „0 ms“ rechnen sollten.

Reduzieren der Renderzeit für eine schnellere Leistung

Mit Composition Profiler können Sie die Elemente Ihrer Komposition aufspüren, die Ihre Renderzeiten erhöhen. Dies hilft Ihnen dabei, intelligente Entscheidungen darüber zu treffen, wie Sie Ihren Arbeitsablauf beschleunigen können. Durch das Deaktivieren von Ebenen, Effekten, Masken und Ebenenstilen können Vorschauen schneller gerendert werden, und Composition Profiler kann Ihnen bei der Auswahl der anzupassenden Elemente helfen.

Sie können sich auch die folgenden Möglichkeiten ansehen, um die Renderzeit zu reduzieren:

Proxys

Um eine Proxy-Datei zu rendern – eine Version mit niedrigerer Auflösung, die für die temporäre Vorschau verwendet wird – klicken Sie im Bedienfeld „Projekt“ mit der rechten Maustaste auf ein Element und wählen Sie Datei > Proxy erstellen > Film oder Datei > Proxy erstellen > Standbild. Bei Projektelementen, die über Proxys verfügen, wird im Bedienfeld „Projekt“ neben dem Element ein spezielles Symbol angezeigt.

Vor-Rendering

Wenn Sie Ebenen oder Kompositionen haben, bei denen Sie keine Änderungen erwarten, können Sie diese Elemente über die Renderliste vorab rendern und in den Einstellungen des Ausgabemoduls die Aktion nach dem Rendern in „Verwendung importieren und ersetzen“ ändern.

Alternative Effekte

Einige Effekte brauchen länger zum Rendern. Probieren Sie alternative Effekte aus, die mit schnelleren Renderzeiten ein ähnliches Aussehen erzielen. Sie können beispielsweise „Feld schnell weichzeichnen“ statt „Gaußscher Weichzeichner“, „Glühen“ statt „VR: Leuchten“ oder „Colorama“ statt „Färbung“ oder „Tritonus“ ausprobieren.

Adobe-Logo

Bei Ihrem Konto anmelden

[Feedback V2 Badge]