Підвищення продуктивності Illustrator у Windows

Дізнайтеся, як забезпечити швидшу й ефективнішу роботу Illustrator в Windows.

На швидкість та ефективність роботи Adobe Illustrator впливають декілька факторів, такі як операційна система, налаштування апаратного забезпечення, робочий процес та обрані опції. Якщо ви помітите, що Illustrator працює повільніше, ніж звичайно, спробуйте наведені нижче техніки для оптимізації продуктивності не тільки Illustrator, але також і інших програм.(Підвищення продуктивності більш помітно при роботі з файлами великих об'ємів).

До початку роботи

До виконання вказаних нижче дій переконайтеся, що у вас встановлена остання версія Illustrator чи всі оновлення версії, що використовується. В оновленнях ПЗ часто усунені проблеми, пов'язані з продуктивністю. 

Якщо ви використовуєте Illustrator, то можете оновити Illustrator, використовуючи програму Creative Cloud для настільних ПК.

Примітка.

Процедури, наведені в цьому документі, передбачають використання стандартного інтерфейсу. Якщо інтерфейс змінений у відповідності до особистих переваг користувача, тоді деякі процедури можуть відрізнятися. Наприклад, шлях до Панелі управління може бути іншим. Виберіть Пуск > Налаштування > Панель керування або Пуск > Панель керування, залежно від версії Windows. Для отримання рекомендацій з усунення проблем та загальної інформації про Windows зв'яжитеся зі службою підтримки Adobe та службою підтримки Microsoft.

Оптимізуйте Windows

Налаштування операційної системи з метою забезпечення ефективності її роботи збільшується об'єм пам'яті, доступної для програм, унаслідок чого забезпечується стабільність роботи. Нижче наведено кілька способів оптимізації Windows і підвищення продуктивності Illustrator.

Збільшіть об'єм доступної пам'яті

Віртуальна пам'ять дозволяє використовувати місце на жорсткому диску для зберігання даних, які звичайно зберігаються в оперативній пам'яті. Проте для доступу до інформації на жорсткому диску необхідно більше часу, ніж для доступу до інформації в пам'яті. Таким чином, якщо системі доводиться використовувати великі об'єми віртуальної пам'яті, це може викликати зниження продуктивності.

Для підвищення продуктивності виберіть правильний розмір файлу підкачки (область жорсткого диску, на якій зберігається віртуальна пам'ять). Для зміни розміру файлу підкачки необхідні права адміністратора. Illustrator працює найкращим чином, коли максимальний розмір файлу підкачки приблизно втричі більше об'єму встановленої оперативної пам'яті.

  1. Вийдіть із всіх програм.

  2. Виберіть Пуск > Панель керування >Система > Додаткові настройки системи.

  3. У діалоговому вікні «Властивості системи» виберіть вкладку Додаткові.

  4. У розділі «Продуктивність» натисніть Налаштування і виберіть вкладку Додаткові.

  5. У розділі «Віртуальна пам’ять» натисніть Змінити.

  6. Зніміть прапорець автоматичного керування розміром файлу підкачки для всіх дисків.

  7. Зі списку драйверів оберіть жорсткий диск, який має щонайменше втричі більший об'єм оперативної пам'яті, встановленої у вашому комп'ютері. Наприклад, якщо ваш комп'ютер має 64 МБ оперативної пам'яті, виберіть жорсткий диск, який має щонайменше 192 МБ вільного простору. Для найкращих результатів виберіть жорсткий диск, що не використовується для тимчасового диску Illustrator.

Відключіть функції драйверу

Деякі драйвери відеоадаптера пропонують розширені налаштування для прискорення чи зміни відображення графіки. Іноді такі налаштування можуть негативно позначитися на швидкодії при перемалюванні екрану в Illustrator. Спробуйте відключити функції, властиві конкретному драйверу, щоб визначити найкращі налаштування для використання з Illustrator. Для отримання додаткових відомостей див. документацію до вашого відеоадаптера.

Управління шрифтами

Кожний шрифт, що використовується, збільшує об'єм оперативної пам'яті, що використовується Windows. Установіть тільки необхідні шрифти, щоб підвищити швидкодію системи та продуктивність додатків, які використовують шрифти. Використовуйте спеціальну утиліту для управління багатьма шрифтами.

Скоротіть кількість додатків, що запускаються.

Додатки, які запускаються автоматично в Windows, «конкурують» з Illustrator по відношенню до доступної оперативної пам'яті. Щоб запобігти автоматичному завантаженню додатків, виконайте наступні дії:

  1. Вийдіть із усіх програм.

  2. Запустіть Windows Explorer.
  3. Відключіть програми автозавантаження поточного користувача, перемістивши всі значки та ярлики з папки автозавантаження (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) в іншу папку.

  4. Перезапустіть Windows.

Щоб закрити додатки в реєстрі, які повинні запускатися автоматично, виконайте наступні дії:

  1. Перезапустіть Windows.
  2. Натисніть Ctrl+Shift+Esc.

  3. Виберіть вкладку Процеси.

  4. Виберіть ім'я програми, а потім натисніть Завершити завдання.

  5. Перезавантаження програми Illustrator. Якщо швидкодія Illustrator підвищується, тоді зв'яжіться з виробником програми і дізнайтеся, як назавжди виключити програму з автозавантаження. Повторіть кроки 2–5 для кожної з програм автозавантаження, що залишилися.

Знову активуйте значки та ярлики

Якщо продуктивність Illustrator не покращується після перезапуску, тоді знову активуйте значки та ярлики в Windows Explorer, повернувши їх в папку автозавантаження.

Якщо продуктивність Illustrator покращилась, тоді виявіть одну чи декілька програм з проблемою продуктивності та повторно активуйте їх значки та ярлики, помістивши їх в папку автозавантаження за допомогою Windows Explorer.

Перезапускайте комп'ютер після повторної активації кожного набору значків та ярликів і тестуйте продуктивність Illustrator.

Повторюйте даний процес до тих пір, поки не знизиться продуктивність Illustrator. Після виявлення значка чи ярлика, що викликає проблему продуктивності, знову видаліть його. Зв'яжитеся з виробником програми, щоб з'ясувати наявність оновлень.

Оптимізуйте апаратне забезпечення

Апаратне забезпечення, що використовується, впливає на продуктивність Illustrator: чим швидше працює процесор або жорсткий диск, тим вище швидкість обробки іформації в Illustrator. Інші вдосконалення апаратного забезпечення, такі як встановлення додаткового об'єму оперативної пам'яті, використання багатопроцесорної системи або оптимізація чи дефрагментація дисків, також можуть підвищити продуктивність. Спробуйте ці способи для оптимізації апаратного забезпечення.

Використання швидшого процесора

Швидкість центрального процесора комп'ютера (CPU) впливає на швидкість Illustrator. Оскільки Illustrator оперує великими об'ємами даних та виконує багато обчислень, його швидкодія залежить від швидкості процесора. Спробуйте використовувати комп'ютер з більш швидким процесором.

Встановлення додаткового об'єму оперативної пам'яті

Якщо Illustrator має недостатній об'єм оперативної пам'яті, то для обробки інформації він використовує місце на жорсткому диску (наприклад, віртуальна пам'ять, тимчасовий диск чи і те, і інше). Illustrator працює з найбільшою швидкістю, якщо може обробити інформацію в пам'яті без використання жорсткого диска.

Оптимізація дискового простору

Нижче наведено декілька способів оптимізації дискового простору:

  • Перевірте свій жорсткий диск на наявність помилок, дефрагментуйте файли і оптимально використайте доступний дисковий простір за допомогою программ CHKDSK.exe і Disk Defragmenter. Для отримання додаткових відомостей див. документацію до Windows або довідку про підвищення продуктивності в Windows.
  • Збережіть файли на диски з більш високою швидкість доступу. Наприклад, використовуйте внутрішній жорсткий диск, а не мережевий сервер (мережевий диск) або зовнішній диск.
  • Якщо ви бажаєте зберегти файл на мережевий або зовнішній диск, спочатку збережіть файл на внутрішній жорсткий диск. Потім закрийте файл і за допомогою Windows Explorer скопіюйте його на мережевий або зовнішній диск.

Використовуйте принтер PostScript

Для отримання найкращих результатів при друку з Illustrator використовуйте принтер PostScript. Більшість принтерів, що не є принтерами PostScript, використовують інформацію дисплею, ресурси хост-комп'ютера та власні драйвери принтера для друку інформації для друку на принтер. Тому для їх друку на принтер PostScript може знадобитися більше часу.

Ефективне використання можливостей Illustrator

Спосіб роботи в Illustrator, особливо по відношенню перегляду своєї графіки, може вплинути на продуктивність Illustrator. Нижче наведено деякі способи ефективного використання функцій Illustrator.

Робота в режимі показу контуру

В режимі «Показ контуру» приховані атрибути фарби, а графіка відображається як незаповнені контури. Робота в режимі показу контуру дає змогу прискорити відображення складної графіки, зокрема об'єктів, що містять градієнти або комбінації об'єктів. Режим «Показ контуру» також дозволяє забезпечити редагування об'єктів, прихованих за іншими заповненими об'єктами.

Для відображення документа Illustrator у режимі «Показ контуру» виберіть Перегляд > Контур.

Створення власних переглядів

Можна створити власні перегляди для свого документа. Власні перегляди дають змогу швидко змінити налаштування режиму перегляду, збільшення зображення, положення прокрутки та шарів.

Щоб створити власний перегляд документа Illustrator, налаштуйте атрибути перегляду, які бажаєте зберегти. Потім виберіть Перегляд > Новий перегляд і введіть ім'я в діалоговому вікні «Новий перегляд». Власний перегляд відобразиться в меню «Перегляд».

Змінення налаштувань растрових ефектів

Можете змінити дозвіл растрових ефектів, щоб оптимізувати продуктивність Illustrator.

Для зміни дозволу растрових ефектів виберіть Ефект > Параметри растрових ефектів документа. У розкривному меню «Роздільна здатність» виконайте одну з перелічених нижче дій.

  • Виберіть Екран, якщо ви редагуєте файли. Illustrator використовує роздільну здатність 72 пікселів на дюйм для растрових ефектів, збільшуючи швидкість відображення.
  • Виберіть Висока, якщо ви друкуєте файли. Illustrator використовує роздільну здатність 300 пікселів на дюйм для растрових ефектів, знижуючи швидкість друку, але підвищуючи якість друку.

Потім натисніть кнопку «OK».

Приховування шарів і видалення ескізів

Використовуйте панель «Шари» для організації та перетворення графіки. При приховуванні шарів, що містять складну графіку чи растрові зображення з високим дозволом, Illustrator виконує перемальовку екрана швидше.

Щоб приховати шар, натисніть на значок ока, розташований зліва від імені шару. Щоб приховати все, крім обраного шару, утримуючи клавішу Alt (Option для Mac), клацніть значок ока.

В панелі «Шари» можуть відображуватися ескізи для шарів верхнього рівня, вкладені шари, групи та об'єкти. Для скорочення кількості ескізів з метою швидшого оновлення екрана в Illustrator виберіть Параметри панелі в меню панелі «Шари», потім скоротіть кількість ескізів.

Вимкнення параметра «Перегляд накладання кольорів»

Попередній перегляд накладення кольору забезпечує «попередній перегляд чорнил», який приблизно показує, як змішування, прозорість і накладення відображаються у друці з відокремленням кольорів. Для підвищення продуктивності уникайте використання «Перегляду накладання кольорів».

Щоб включити або відключити попередній «Перегляд накладання кольорів, виберіть Перегляд > Перегляд накладання кольорів.

Видалення монтажних областей, що не використовуються

Монтажні області – це області, в яких можуть знаходитися ілюстрації для друку. Для оптимізації продуктивності роздивіться варіант видалення монтажних областей, що не використовуються або не потрібні

Щоб керувати монтажними областями, виберіть Вікно > Монтажні області. Потім виберіть монтажну область, яку бажаєте видалити і клацніть Видалити.

Зміни налаштувань для призначеного робочого диска

Коли ви працюєете із вбудованими растровими зображеннями, а ваша система не має достатньої оперативної пам'яті, Illustrator використовує місце на жорсткому диску в якості тимчасового диску. Для доступу до інформації на жорсткому диску необхідно більше часу по рівнянно з доступом до інформаціїи в пам'яті. Тому використання частини жорсткого диску в якості віртуальної пам'яті може знизити продуктивність. Якщо необхідно більше пам'яти для роботи в Illustrator, Adobe рекомендує встановити більший об'єм оперативної пам'яти.

За замовчанням Illustrator використовує системний диск як основний тимчасовий диск. Змініть налаштування, задавши в якості основного тимчасового диска Illustrator найбільш швидкий жорсткий диск.

Щоб змінити налаштування тимчасового диску, виконайте такі дії:

  1. Виберіть Правка > Уподобання (особисті налаштування) > Плагіни і тимчасовий диск.

  2. Виберіть жорсткий диск із розкривного меню Основний. Якщо ви працюєте з великими зображеннями та маєте декілька жорстких дисків, оберіть інший диск у розкривному меню Другорядний.

  3. Клацніть OK і перезапустіть Illustrator.

Видалення елементів, що не використовуються, з профілів документа

Профілі документа Illustrator містять шаблони за замовчанням, градієнти, графічні дизайни, кольори, бібліотеки кольорів та пензлі, які відображаються в нових документах Illustrator. Ці файли також визначають рівень масштабування, розмір вікна, особисті налаштування перегляду, а також положення прокрутки для нових документів. Мінімізуйте розмір файлу для нових документів, видаливши непотрібні палітри та пензлі з профілів нового документу Illustrator.

Видаліть із шаблонів елементи, які не використовуються

Шаблони дають змогу створювати нові документи зі спільними загальними параметрами та елементами дизайну. Ви можете мінімізувати розмір файлу для нових документів, видаливши непотрібні палітри, символи, стилі графіки та пензлі з шаблонів.

Для отримання інструкцій зі створення шаблонів файлів див. Файли та шаблони.

Активація зв'язків із зображеннями

Вбудовані растрові зображення (наприклад, TIFF, BMP або Photoshop EPS) можуть значно збільшити розмір документу Illustrator, негативно позначаючись на швидкодії. Щоб покращити продуктивність, активуйте опцію «Зв'язати» під час розміщення растрового зображення. Під час використання цього параметра розміщуване зображення посилається на жорсткий диск.

  • Виберіть Файл > Розмістити. У діалоговому вікні розміщення виберіть Зв’язати.

Якщо для бюро переддрукової підготовки потрібне вбудоване зображення, то зберігайте копії файлів. Виберіть Включати прив’язані файли в діалоговому вікні Параметри власних форматів Illustrator або Параметри формату EPS.

Попередній перегляд EPS із низькою роздільною здатністю

Якщо документ містить пов'язані зображення EPS, які мають можливість попереднього перегляду з високою роздільною здатністю, Illustrator перемальовує екран повільніше під час редагування графіки. Щоб Illustrator зміг перемалювати екран швидше, використовуйте попередній перегляд з низькою роздільною здатністю EPS. Виконайте такі дії:

  1. Виберіть Правка > Уподобання > Обробка файлів і буфер обміну.

  2. Виберіть Використовувати проксі з низькою роздільною здатністю для пов'язаних файлів EPS і натисніть OK.

Відключення параметра «Показати взаємодію формату DCS і прозорості»

Діалогове вікно «Налаштування панелі зв'язків» містить параметр «Відобразити взаємодію прозорості у форматі DCS». Якщо вибрано цей параметр, на панелі «Зв'язки» відображається жовтий значок, щоб ідентифікувати пов'язану графіку DCS EPS, що є прозорою або такою, що перекриває прозорі об'єкти. Оскільки через цей параметр Illustrator повинен регулярно визначати, чи є взаємодія пов'язаних файлів EPS із прозорістю, це може привести до зниження продуктивності.

Щоб відключити параметр «Відображення взаємодії прозорості», виконайте такі дії:

  1. Виберіть Вікна > Зв'язки. У меню панелі «Зв’язки» виберіть Параметри панелі.

  2. Скасуйте вибір параметра Показати взаємодію формату DCS і прозорості та клацніть OK.

Приховування панелі «Навігатор»

Панель «Навігатор» відображає вид ескізів вашої поточної графіки для зручної навігації. Час обробки, потрібний для оновлення ескізів при кожній зміні документа, залежить від складності графіки. Щоб покращити швидкість перемалювання екрану для складного документу, приховайте панель «Навігатор». У меню «Вікно» скасуйте вибір параметра Навігатор.

Ви можете налаштувати види користувачів, щоб здійснювалось ефективніше масштабування певних частин документа.

Відключення згладжування графіки

Опція Anti-alias Artwork (згладжування графіки) дозволяє згладити текст і графіку шляхом змішування кольорів пікселей по краях об'єкта з кольором сусідніх пікселей. Проте цей процес може призвести до повільного перемалювання екрану. Щоб відключити цей параметр, виконайте такі дії:

  1. Виберіть команду Правка > Уподобання > Загальні.

  2. Очистіть Згладжування графіки та клацніть OK.

Застосування команди «Спростити»

Команда «Спростити» знижує кількість вузлових точок у контурі й формах контуру, зменшуючи розмір файлу й підвищуючи продуктивність. Щоб застосувати команду «Спростити», виберіть потрібний контур чи об'єкт, а потім клацніть Об'єкт > Контур > Спростити.

Для отримання додаткових відомостей про команду «Спростити» див. довідку з Illustrator.

Відключення швидких напрямних

Функція Smart Guides (Швидкі напрямні) дозволяє створювати, вирівнювати, редагувати та перетворювати об'єкти Illustrator в прив'язанні до інших об'єктів. Якщо ваша графіка містить багато об'єктів, для Illustrator потрібно більше часу, щоб відобразити Smart Guides (Швидкі напрямні). Щоб відключити Smart Guides (Швидкі напрямні), клацніть меню View (Перегляд) та скасуйте вибір Smart Guides (Швидкі напрямні).

Для отримання додаткових відомостей про Smart Guides (Швидкі напрямні) див. розділ про лінійки, сітки, напрямні та мітки обрізки.

Растеризація контурів ворсового пензля та відключення можливостей PDF

Мазки ворсового пензля утворені з декількох накладань, між якими прозорі мазки. Ці мазки, як і будь-які інші заповнені мазки в Illustrator, взаємодіють із кольорами інших об'єктів, зокрема із іншими мазками ворсового пензля.

Тестуйте та експериментуйте з пензлем зі щетини та візуалізацією фарби до початку роботы над масштабною графікою. У разі зміни атрибутів пензля та повторного їх використання знову відображуються всі використані пензлі.

Під час використання ворсових пензлів можна знизити складність і розмір файлу документа, виконавши наведені нижче дії.

  • Растеризуйте деякі контури ворсового пензля. Обов'язково збережіть копію вихідної графіки до растеризації.

Якщо графіка містить велику кількість (>30) контурів ворсового пензля, слід знизити складність і кількість таких контурів. Виберіть контури ворсового пензля, а потім — Об'єкт > Растеризувати.

  • Відключіть можливості PDF.

За замовчуванням Illustrator зберігає дані в PDF, які забезпечують сумісність файлів Illustrator (*ai) з іншими програмами Adobe. Виберіть Файл Зберегти або Файл > Зберегти як і натиснітьЗберегти.  У діалоговому вікні «Параметри Illustrator» скасуйте вибір параметра Створити PDF-сумісний файл.

Логотип Adobe

Увійдіть до облікового запису