Benutzerhandbuch Abbrechen

Verwalten und Animieren von Formenpfaden und -masken

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
    3. Funktionen in der Beta-Version
      1. Bedienfeld „Eigenschaften“ (Beta)
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
    10. Einrichtung und Installation
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Vorgehensweise beim Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formenpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle, Masken und Matten
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Verwenden der Erweiterung „Adobe Color-Designs“
    3. Farb-Management
    4. Effekte zur Farbkorrektur
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekte unter „Simulation“
    4. Effekte unter „Stilisieren“
    5. Effekte unter „Audio“
    6. Effekte unter „Verzerren“
    7. Effekte unter „Perspektive“
    8. Effekte unter „Kanäle“
    9. Effekte unter „Generieren“
    10. Effekte unter „Überblenden“
    11. Der Effekt „Rolling-Shutter-Reparatur“
    12. Effekte unter „Weich- und Scharfzeichnen“
    13. Effekte unter „3D-Kanal“
    14. Effekte unter „Dienstprogramm“
    15. Effekte unter „Matt“
    16. Effekte unter „Störung und Körnung“
    17. Effekt „Hochskalieren mit Detailerhaltung“
    18. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Ausdruck
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Expression-Sprachreferenz
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Tracking der 3D-Kamerabewegung
    5. Arbeiten im 3D-Designraum
    6. 3D-Transformations-Gizmos
    7. Machen Sie mehr mit 3D-Animation
    8. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Real-Time Engine
    9. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    3. Konvertieren von Filmen
    4. Multi-Frame-Rendering
    5. Automatisches Rendern und Netzwerk-Rendern
    6. Rendern und Exportieren von Standbildern und Standbildsequenzen
    7. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. CINEMA 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Installieren und Aktivieren von Frame.io
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Verbessern der Leistung
    3. Voreinstellungen
    4. Anforderungen an GPU und GPU-Treiber für After Effects

Maskenpfade und Formenpfade werden größtenteils so wie andere Eigenschaften animiert: Sie legen Keyframes für die Eigenschaft „Maskenpfad“ oder „Pfad“ fest, Sie legen Pfade bei jedem Keyframe fest, und After Effects interpoliert zwischen diesen festgelegten Werten.

Rotoskopieren – Einführung und Ressourcen

Rotoskopieren (auch als Roto bezeichnet) ist das Zeichnen oder Malen auf Frames eines Films, wobei visuelle Elemente im Film als Referenzen verwendet werden. Eine häufige Form des Rotoskopierens ist das Zeichnen eines Pfades um ein Objekt in einem Film und die anschließende Verwendung dieses Pfades als Maske, um das Objekt vom Hintergrund zu trennen. So können Sie das Objekt und den Hintergrund getrennt voneinander bearbeiten und z. B. unterschiedliche Effekte auf das Objekt und den Hintergrund anwenden oder den Hintergrund ersetzen.

Hinweis:

After Effects enthält die Werkzeuge „Roto-Pinsel“ und „Kantenverfeinerung“, mit denen eine Vielzahl derselben Aufgaben wie bei der herkömmlichen Rotoskopie in wesentlich kürzerer Zeit ausgeführt werden kann. Weitere Informationen zur Verwendung des Roto-Pinsel-Werkzeugs finden Sie unter Roto-Pinsel, Kantenverfeinerung und Maske verbessern.

Hinweis:

Wenn ein Hintergrund oder ein Vordergrundobjekt eine konsistente, eindeutige Farbe aufweist, können Sie den Hintergrund oder das Objekt auch mit Color-Keying statt durch Rotoskopieren entfernen. Wenn Sie das Footage bereits im Hinblick auf Color-Keying aufgenommen haben, ist das Color-Keying wesentlich einfacher als das Rotoskopieren. (Siehe Keying – Einführung und Arbeitsablauf.)

Das Rotoskopieren in After Effects erfolgt meistens, indem Sie Masken zeichnen, den Maskenpfad animieren und diese Masken anschließend zum Definieren einer Matte verwenden. Diese Aufgabe kann durch zusätzliche Schritte und Techniken vereinfacht werden, beispielsweise indem Sie Motion-Tracking auf das Objekt anwenden, bevor Sie Masken zeichnen, und dann mithilfe der Motion-Tracking-Daten dafür sorgen, dass eine Maske oder Matte automatisch dem Objekt folgt.

Tipps zum Rotoskopieren

  • Drücken Sie beim Zeichnen einer Maske gleich zu Beginn die Alt-+Umschalttaste+M (Windows) oder die Wahl-+Umschalttaste+M (Mac OS), um Keyframes für die Maske zu aktivieren und einen Keyframe festzulegen. So können Sie es vermeiden, eine Maske minutenlang (oder länger) Frame für Frame zu bearbeiten und anschließend festzustellen, dass alle Änderungen in vorherigen Frames verloren gegangen sind, weil Sie vergessen haben, auf die Stoppuhr-Schaltfläche zu klicken, um den Maskenpfad zu animieren.
  • Zeichnen Sie die Masken auf einer weißen Farbflächenebene mit deaktiviertem Schalter „Video“ (Auge) oberhalb der (geschützten) Footageebene. So riskieren Sie nicht, die Footageebene beim Bearbeiten der Maske versehentlich zu entfernen. Außerdem können Sie so wesentlich einfacher Tracking-Daten auf die Maske anwenden. (Sie wenden die Tracking-Daten auf die unsichtbare Farbflächenebene an, die die Maske enthält.) Dies bedeutet ferner, dass Sie die im zwischengespeicherten Vorschauframes nicht jedes Mal verlieren, wenn Sie die Maske ändern. (Siehe Umschalten der Sichtbarkeit oder des Einflusses einer Ebene oder Eigenschaftsgruppe und Schützen oder Aufheben des Schutzes einer Ebene.)
  • Aktivieren Sie die Voreinstellung „Konstante Scheitelpunktzahl erhalten“. (Siehe Festlegen des ersten Scheitelpunkts für einen Bézier-Pfad.)
  • Transformieren (drehen, skalieren, verschieben) Sie wenn möglich die gesamte Maske oder eine Teilmenge der Maske, anstatt die Scheitelpunkte einzeln zu verschieben. Dies steigert die Effizienz und verhindert Störungen durch inkonsistentes Verschieben über mehrere Frames. (Siehe Verschieben von Scheitelpunkten im Modus „Freies Transformieren“.)
  • Manuelles Motion-Tracking ist weniger zeitaufwändig als manuelles Rotoskopieren. Je mehr Zeit Sie investieren, um gute Tracking-Daten für die verschiedenen Teile von Szenen und Objekten zu erhalten, desto weniger Zeit brauchen Sie für das Zeichnen und Optimieren von Masken. (Siehe Verfolgen und Stabilisieren von Bewegung.)
  • Verwenden Sie die Funktion Weiche Maskenkante mit variabler Breite, um mehr Kontrolle beim Bearbeiten der weichen Kanten von Objekten zu haben.

Anzeigen von Maskenpfaden und -formen

  • Drücken Sie die Taste „M“, um die Maskenpfade für ausgewählte Ebenen im Schnittfenster anzuzeigen.
  • Drücken Sie zweimal die Taste „S“, um ausgewählte Masken oder Formen im Schnittfenster anzuzeigen.
  • Klicken Sie am unteren Rand des Bedienfelds „Komposition“ auf die Schaltfläche „Sichtbarkeit für Maske und Formenpfad ein-/ausschalten“ , um Masken- und Formenpfade im Bedienfeld „Komposition“ anzuzeigen.
  • Wenn Sie Maskenpfade im Bedienfeld „Ebenen“ anzeigen möchten, klicken Sie im Menü „Ansicht“ dieses Bedienfelds auf „Masken“.
  • Soll ein Maskenpfad ausgeblendet werden, während andere Maskenpfade angezeigt werden, schützen Sie die Maske, indem Sie im Schnittfenster zunächst auf den Schalter „Schützen“ und anschließend auf „Ebene“ > „Maske“ > „Geschützte Masken ausblenden“ klicken.
  • Um Masken zu isolieren und andere Masken auszublenden, wählen Sie „Ebene“ > „Maske“ > „Andere Masken schützen“ und wählen Sie anschließend „Ebene“ > „Maske“ > „Geschützte Masken ausblenden“.

Auswählen von Formenpfaden, Formen und Formengruppen

Sie können Formebenen und deren Komponenten in vier Auswahlstufen auswählen, die Auswahlmodi genannt werden:

Auswahlmodus „Ebene“

Die gesamte Formebene wird ausgewählt. Transformationen gelten für die Transformationseigenschaften für die Ebene in der Eigenschaftsgruppe „Transformieren“, die sich auf derselben Ebene befindet wie die Eigenschaftsgruppe „Inhalte“.

Auswahlmodus „Gruppe“

Eine ganze Formgruppe wird ausgewählt. Transformationen gelten für die Transformationseigenschaften für die Gruppe in der Eigenschaftsgruppe „Transformieren“ innerhalb der Formgruppe im Zeitleistenfenster.

Modus „Freies Transformieren“

Auf einem oder mehreren Bézier-Pfaden sind mehrere Scheitelpunkte ausgewählt. Im Kompositionsfenster wird um die Scheitelpunkte ein Begrenzungsrahmen für das freie Transformieren angezeigt. Wenn Sie mit diesem Rahmen arbeiten, können Sie durch eine einzelne Transformation mehrere Scheitelpunkte verschieben. Transformationen gelten für die Scheitelpunkte selbst, die in der Pfadeigenschaft im Zeitleistenfenster enthalten sind.

Modus „Pfadbearbeitung“

Es sind nur Scheitelpunkte ausgewählt. In diesem Modus können Sie Vorgänge zum Bearbeiten von Pfaden durchführen. So können Sie z. B. einem Pfad Scheitelpunkte hinzufügen und individuelle Scheitelpunkte verschieben.

Hinweis:

Wenn ein Zeichenstift-Werkzeug aktiv ist, ist der Pfadbearbeitungsmodus aktiv. Wenn Sie im Modus zur Pfadbearbeitung bleiben möchten, wählen Sie das Zeichenstift-Werkzeug aus. Drücken Sie „V“ oder die Strg-Taste (Windows) bzw. die Befehlstaste (Mac OS), um das Auswahl-Werkzeug bei Bedarf vorübergehend zu aktivieren.

Auswahlmodi für Formen in Formebenen

A. Ebenenauswahl B. Gruppenauswahl C. Freies Transformieren D. Pfadbearbeitung 

Weitere Informationen zum Auswählen von Masken finden Sie unter Auswählen von Masken, Segmenten und Scheitelpunkten.

Hinweis:

Drücken Sie Strg+A (Windows) oder Befehlstaste+A (macOS), wenn ein Scheitelpunkt einer Form ausgewählt ist, um alle Scheitelpunkte auf diesem Pfad auszuwählen. Drücken Sie die Tasten erneut, um alle Formen auszuwählen. Drücken Sie die Tasten erneut, um alle Ebenen auszuwählen.

Auswählen einer Formebene

  • Klicken Sie im Schnittfenster auf den Ebenennamen oder auf den Ebenenzeitbalken.
  • Klicken Sie im Bedienfeld „Komposition“ mit dem Auswahl-Werkzeug innerhalb die Grenzen der Ebene.
  • Möchten Sie die Auswahl für alle Formen in einer Ebene aufheben, die Formebene jedoch ausgewählt lassen, klicken Sie innerhalb den Grenzen der Ebene, aber außerhalb aller Formenpfade.

Auswählen einer Formengruppe im Gruppenauswahlmodus

  • Doppelklicken Sie im Bedienfeld „Komposition“ mit dem Auswahl-Werkzeug auf ein Mitglied der Gruppe. Jedes Mal, wenn Sie doppelklicken, begeben Sie sich auf die darunter liegende Ebene in der Gruppenhierarchie.
  • Wenn Sie das Direktauswahl-Werkzeug  aktivieren möchten, halten Sie die Strg-Taste (Windows) oder die Befehlstaste (macOS) gedrückt, während das Auswahl-Werkzeug ausgewählt ist. Klicken Sie mit dem Direktauswahl-Werkzeug im Bedienfeld „Komposition“ auf eine Form, um die Gruppe dieser Form direkt auszuwählen; unabhängig davon, wie tief die Form in der Gruppenhierarchie verschachtelt ist.
  • Wenn Sie eine Gruppe auswählen möchten, die sich innerhalb derselben Gruppe wie der bereits ausgewählten befindet, klicken Sie auf die auszuwählende Gruppe.
  • Wenn Sie eine Gruppe zu einer Auswahl hinzufügen möchten, halten Sie die Umschalttaste gedrückt, während Sie darauf klicken. Sie können die Umschalttaste mit Doppelklicken und dem Direktauswahl-Werkzeug kombinieren, um stärker verschachtelte Gruppen zur Auswahl hinzuzufügen.

Auswählen von Pfaden und Scheitelpunkten im Pfadbearbeitungsmodus

Hinweis:

Um die Größe der Richtungs-Handles der Bézier-Interpolation und Scheitelpunkte für Masken und Formen anzugeben, wählen Sie „Bearbeiten“ > „Voreinstellungen“ > „Allgemein“ (Windows) bzw. „After Effects“ > „Voreinstellungen“ > „Allgemein“ (macOS) aus und bearbeiten Sie den Wert „Größe des Pfadpunkts“.

  • Wenn Sie einen Scheitelpunkt auswählen möchten, klicken Sie mit dem Auswahl-Werkzeug darauf. Wenn Sie Scheitelpunkte zur Auswahl hinzufügen möchten, klicken Sie bei gedrückter Umschalttaste auf die gewünschten Scheitelpunkte.
  • Wenn Sie ein Pfadsegment auswählen möchten, klicken Sie mit dem Auswahl-Werkzeug auf das Segment. Wenn Sie Segmente zur Auswahl hinzufügen möchten, klicken Sie bei gedrückter Umschalttaste auf die gewünschten Segmente.
  • Wenn Sie einen ganzen Pfad auswählen möchten, halten Sie die Alt-Taste (Windows) oder die Wahltaste (macOS) gedrückt, während Sie mit dem Auswahl-Werkzeug auf ein Segment oder einen Scheitelpunkt des Pfades klicken. Sie können auch einen beliebigen Abschnitt des Pfades auswählen und Strg+A (Windows) oder Befehlstaste+A (macOS) drücken.
  • Wenn Sie Scheitelpunkte durch Ziehen auswählen möchten, wählen Sie einen Pfad oder den Abschnitt eines Pfades aus, um in den Pfadbearbeitungsmodus zu gelangen. Ziehen Sie dann mit dem Auswahlrahmen-Werkzeug , um ein Auswahlrechteck um die auszuwählenden Scheitelpunkte zu ziehen. Zum Hinzufügen weiterer Scheitelpunkte können Sie bei gedrückter Umschalttaste an zusätzlichen Auswahlrahmen ziehen.

Auswählen aller Punkte eines Pfades und Aufrufen des Modus „Freies Transformieren“

  • Doppelklicken Sie auf ein Pfadsegment, während Sie sich im Pfadbearbeitungsmodus befinden. Im Gruppenauswahlmodus können Sie auch auf eine einzelne Form doppelklicken.
  • Wählen Sie die Eigenschaft „Pfad“ im Schnittfenster aus und drücken Sie die Strg+T (Windows) bzw. Befehlstaste+T (macOS).

Auswählen von Masken, Segmenten und Scheitelpunkten

Anders als bei Ebenen gibt es bei Masken mehrere Auswahlstufen. Sie können eine Maske als ganzen Pfad auswählen. Diese Option ist praktisch, wenn Sie eine Maske verschieben oder die Größe einer Maske ändern möchten. Möchten Sie dagegen den Pfad einer Maske ändern, wählen Sie einen oder mehrere Punkte darauf aus. Ausgewählte Punkte werden ausgefüllt angezeigt, nicht ausgewählte Punkte erscheinen leer.

Hinweis:

Um die Größe der Richtungs-Handles der Bézier-Interpolation und Scheitelpunkte für Masken und Formen anzugeben, wählen Sie „Bearbeiten“ > „Voreinstellungen“ > „Allgemein“ (Windows) bzw. „After Effects“ > „Voreinstellungen“ > „Allgemein“ (macOS) aus und bearbeiten Sie den Wert „Größe des Pfadpunkts“.

Aktivieren oder Deaktivieren von Masken im Bedienfeld „Ebenen“ oder „Komposition“

  • Wenn Sie einen Scheitelpunkt in einer Maske auswählen möchten, klicken Sie mit dem Auswahl-Werkzeug  auf den Scheitelpunkt. Wenn Sie Scheitelpunkte zur Auswahl hinzufügen möchten, klicken Sie bei gedrückter Umschalttaste auf die gewünschten Scheitelpunkte.
  • Wenn Sie ein Maskensegment auswählen möchten, klicken Sie mit dem Auswahl-Werkzeug auf das Segment. Wenn Sie Segmente zur Auswahl hinzufügen möchten, klicken Sie bei gedrückter Umschalttaste auf die gewünschten Segmente.
  • Wenn Sie eine vollständige Maske auswählen möchten, klicken Sie bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (macOS) mit dem Auswahl-Werkzeug auf ein Segment, einen Scheitelpunkt oder Handle der gewünschten Maske. Alternativ können Sie einen beliebigen Teil der Maske auswählen und auf „Bearbeiten“ > „Alles auswählen“ klicken oder Strg+A (Windows) bzw. Befehlstaste+A (macOS) drücken. Wenn Sie Masken zur Auswahl hinzufügen möchten, klicken Sie bei gedrückter Alt-+Umschalttaste (Windows) bzw. Wahl-+Umschalttaste (macOS) auf die gewünschten Masken.
  • Wenn Sie Masken durch Ziehen auswählen möchten, wechseln Sie zunächst in den Maskenbearbeitungsmodus, indem Sie eine Maske oder einen Teil davon auswählen. Ziehen Sie dann mit dem Auswahl-Werkzeug ein Auswahlrechteck um alle Scheitelpunkte oder Masken, die in der Auswahl enthalten sein sollen. Zum Hinzufügen weiterer Masken oder Scheitelpunkte zur Auswahl können Sie bei gedrückter Umschalttaste zusätzliche Auswahlrechtecke zeichnen.
  • Wenn Sie alle Masken auf einer Ebene auswählen möchten, wählen Sie eine Maske auf der Ebene aus, und klicken Sie dann auf „Bearbeiten“ > „Alles auswählen“ oder drücken Sie Strg+A (Windows) bzw. Befehlstaste+A (macOS).
  • Wenn Sie die Auswahl für alle Masken aufheben möchten, drücken Sie Strg-+Umschalttaste+A (Windows) bzw. Befehls-+Umschalttaste+A (macOS).
  • Wenn Sie eine benachbarte Maske auf einer Ebene auswählen möchten, drücken Sie zum Auswählen der nächsten Maske Alt+Ü (Windows) bzw. Wahltaste+Ü (macOS) und zum Auswählen der vorherigen Maske Umschalttaste+Alt+Ü (Windows) bzw. Umschalttaste+Wahltaste+Ü (macOS).
  • Wenn Sie die Auswahl einer Maske aufheben möchten, klicken Sie auf eine beliebige Stelle außerhalb der Maske.
  • Wenn Sie einen Scheitelpunkt oder ein Segment aus einer Auswahl entfernen möchten, klicken Sie bei gedrückter Umschalttaste auf den Scheitelpunkt bzw. auf das Segment.
Hinweis:

Wenn Sie das Auswahl-Werkzeug verwenden möchten, während der Zeichenstift aktiv ist, halten Sie die Strg-Taste (Windows) bzw. die Befehlstaste (macOS) gedrückt.

Auswählen von Masken im Schnittfenster

  1. Klicken Sie zum Erweitern einer Ebene auf das Dreieck (nach rechts weisender Pfeil) neben ihrem Namen.
  2. Klicken Sie auf den nach rechts weisenden Pfeil neben der Überschrift „Masken“, um die Masken zu öffnen. Daraufhin werden alle auf der Ebene vorhandenen Masken angezeigt.
  3. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie eine Maske auswählen möchten, klicken Sie auf ihren Namen.
    • Wenn Sie einen zusammenhängenden Bereich von Masken auswählen möchten, klicken Sie bei gedrückter Umschalttaste auf den Namen der ersten und der letzten Maske des Bereichs.
    • Wenn Sie mehrere nicht nebeneinander liegende Masken auswählen möchten, klicken Sie bei gedrückter Strg-Taste (Windows) bzw. Befehlstaste (macOS) auf die Namen der gewünschten Masken.
Hinweis:

Im Schnittfenster können Sie nur ganze Masken auswählen. Einzelne Scheitelpunkte auf einer Maske können nur im Bedienfeld „Ebenen“ oder „Komposition“ ausgewählt werden.

Schützen von Masken bzw. Aufheben des Schutzes von Masken

Wenn eine Maske geschützt ist, kann sie nicht im Schnittfenster, Bedienfeld „Komposition“ oder Bedienfeld „Ebenen“ ausgewählt bzw. im Bedienfeld „Ebenen“ als Ziel eingestellt werden. Verwenden Sie diese Funktion, um ungewollte Änderungen an der Maske zu vermeiden.

  1. Erweitern Sie im Schnittfenster die Eigenschaftengruppe „Masken“.
  2. Klicken Sie in der Spalte mit den A/V-Funktionen neben der Maske, die Sie schützen oder deren Schutz Sie aufheben möchten, auf das Feld unterhalb des Symbols „Schützen“ . Eine Maske ist geschützt und kann nicht ausgewählt werden, wenn Sie auf den Schalter „Schützen“ geklickt haben, d. h. wenn das Symbol „Schützen“ im Feld angezeigt wird.
Hinweis:

Wenn Sie den Schutz für mehrere Masken gleichzeitig aufheben möchten, wählen Sie die Ebenen aus und klicken Sie auf „Ebene“ > „Maskieren“ > „Schutz aller Masken aufheben“.

Hinweis:

Um die ausgewählten Masken zu isolieren und andere Masken auszublenden, wählen Sie „Ebene“ > „Maske“ > „Andere Masken schützen“ und anschließend „Ebene“ > „Maske“ > „Geschützte Masken ausblenden“.

Verschieben von Scheitelpunkten im Modus „Freies Transformieren“

Mit dem Befehl „Freie Transformationspunkte“ können Sie eine ganze Maske oder einen Formenpfad (oder ausgewählte Scheitelpunkte eines oder mehrerer Pfade) skalieren und drehen. Wenn Sie diesen Befehl verwenden, werden die ausgewählten Scheitelpunkte von einem Begrenzungsrahmen für freies Transformieren umgeben, und in der Mitte des Begrenzungsrahmens wird ein Ankerpunkt angezeigt, der den Ankerpunkt für die aktuelle Transformation darstellt. Sie können die ausgewählten Scheitelpunkte skalieren und drehen, indem Sie den Begrenzungsrahmen oder dessen Handles ziehen. Sie können auch den Referenzpunkt ändern, von dem die Scheitelpunkte gedreht oder skaliert werden, indem Sie den Ankerpunkt des Begrenzungsrahmens verschieben. Die Handles und Ankerpunkte des Begrenzungsrahmens für das freie Transformieren bestehen unabhängig von den Handles und vom Ankerpunkt der Ebene.

Hinweis:

Wenn Sie den Befehl „Freie Transformationspunkte“ verwenden, um Drehungen zu animieren, werden die Scheitelpunkte der Maske von Keyframe zu Keyframe in einer geraden Linie interpoliert. Die Ergebnisse fallen daher möglicherweise anders aus als erwartet.

  1. Zeigen Sie im Bedienfeld „Komposition“ oder „Ebenen“ die Ebene an, die die zu transformierenden Pfade enthält.
  2. Führen Sie mit dem Auswahl-Werkzeug einen der folgenden Schritte aus:
    • Wenn Sie eine bestimmte Anzahl Scheitelpunkte transformieren möchten, wählen Sie die gewünschten Scheitelpunkte aus und klicken Sie dann auf „Ebene“ > „Maske und Formenpfad“ > „Freie Transformationspunkte“.
    • Wenn Sie eine ganze Maske oder einen Formenpfad transformieren möchten, wählen Sie diesen im Schnittfenster aus und wählen Sie „Ebene“ > „Maske und Formenpfad“ > „Freie Transformationspunkte“.
  3. Wenn Sie den Ankerpunkt eines Begrenzungsrahmens verschieben möchten, positionieren Sie das Auswahl-Werkzeug über dem Ankerpunkt des Begrenzungsrahmens , sodass statt des Auswahl-Werkzeugs das Symbol zum Verschieben von Ankerpunkten  angezeigt wird. Ziehen Sie den Ankerpunkt an die gewünschte Stelle.
  4. Führen Sie eine beliebige Kombination der folgenden Schritte aus:
    • Wenn Sie den Pfad oder die ausgewählten Scheitelpunkte verschieben möchten, platzieren Sie den Mauszeiger im Begrenzungsrahmen und ziehen Sie die Maus.
    • Wenn Sie den Pfad oder ausgewählte Scheitelpunkte skalieren möchten, platzieren Sie den Mauszeiger an einem Handle am Begrenzungsrahmen und stellen Sie, sobald der Mauszeiger die Form eines geraden Doppelpfeils  annimmt, durch Ziehen eine neue Größe ein. Halten Sie während des Ziehens die Umschalttaste gedrückt, wenn die Proportionen erhalten bleiben sollen. Halten Sie beim Ziehen die Strg-Taste (Windows) oder die Befehlstaste (macOS) gedrückt, um den Ankerpunkt des Begrenzungsrahmens zu skalieren.
    • Wenn Sie den Pfad oder ausgewählte Scheitelpunkte drehen möchten, platzieren Sie den Mauszeiger direkt neben dem Begrenzungsrahmen für das freie Transformieren und führen Sie, sobald der Mauszeiger als gebogener Doppelpfeil  angezeigt wird, durch Ziehen die Drehung durch.
  5. Wenn Sie den Modus „Freies Transformieren“ verlassen möchten, drücken Sie Esc und die Eingabetaste (Windows) oder den Zeilenschalter (macOS).

Konvertieren eines Pfades von einem manuellen Bézier in einen RotoBézier und umgekehrt

Sie können alle manuellen Bézier-Maskenpfade oder Bézier-Formenpfade in RotoBézier-Pfade konvertieren. Wenn der manuelle Bézier-Pfad Richtungs-Handles hat, die angepasst wurden, wird durch diese Konvertierung die Form des Pfades geändert, da After Effects die Krümmung von RotoBézier-Segmenten automatisch berechnet.

Durch die Umwandlung eines RotoBézier-Pfades in einen manuellen Bézier-Pfad wird die Form des Pfades nicht verändert.

  1. Wählen Sie im Bedienfeld „Komposition“, im Bedienfeld „Ebenen“ oder im Schnittfenster eine Maske aus, oder wählen Sie im Bedienfeld „Komposition“ oder im Schnittfenster einen Formenpfad aus.
  2. Wählen Sie „Ebene“ > „Maske und Formenpfad“ > „RotoBézier“.

Ändern eines Bézier-Maskenpfades oder Formenpfades

Einen Bézier-Maskenpfad können Sie mit dem Auswahl-Werkzeug und den Zeichenstift-Werkzeugen im Bedienfeld „Komposition“ oder „Ebenen“ ändern. Einen Bézier-Formenpfad können Sie mit dem Auswahl-Werkzeug und den Zeichenstift-Werkzeugen im Bedienfeld „Komposition“ ändern.

Die Zeichnungs-Werkzeuge „Scheitelpunkt hinzufügen“, „Scheitelpunkt löschen“ und „Scheitelpunkt konvertieren“ sind im Bedienfeld „Werkzeuge“ mit dem Zeichenstift-Werkzeug zu einer Gruppe zusammengefasst. Sie können diese Werkzeuge im Bedienfeld „Werkzeuge“ anzeigen, indem Sie auf das Zeichenstift-Werkzeug klicken und die Maustaste dann gedrückt halten.

Hinweis:

In den meisten Fällen wird das entsprechende Zeichenstift-Werkzeug aktiviert, wenn Sie den Mauszeiger in Form des Zeichenstift-Werkzeugs in einen bestimmten Kontext platzieren. So wird beispielsweise das Scheitelpunkt-löschen-Werkzeug aktiviert, wenn Sie den Zeiger des Zeichenstift-Werkzeugs über einem vorhandenen Scheitelpunkt platzieren. Das Scheitelpunkt-hinzufügen-Werkzeug wird aktiviert, wenn Sie den Zeiger des Zeichenstift-Werkzeugs über einem Pfadsegment platzieren. Drücken Sie die Taste „G“, wenn Sie diese Werkzeuge manuell aktivieren und zwischen ihnen zyklisch wechseln möchten.

Achten Sie beim Ändern eines Pfades darauf, nur auf vorhandene Scheitelpunkte oder Segmente zu klicken, da andernfalls möglicherweise keine Änderung vorgenommen, sondern statt dessen ein neuer Pfad erstellt wird.

Verschieben, Hinzufügen oder Löschen eines Scheitelpunktes

  1. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie einen Scheitelpunkt verschieben möchten, ziehen Sie ihn mit dem Auswahl-Werkzeug .
    Hinweis:

    Wenn Sie vorübergehend vom Zeichenstift zum Auswahl-Werkzeug wechseln möchten, drücken Sie „V“ oder die Strg-Taste (Windows) bzw. die Befehlstaste (macOS).

    • Wenn Sie einen Scheitelpunkt zu einer Maske hinzufügen möchten, klicken Sie mit dem Scheitelpunkt-hinzufügen-Werkzeug  auf das gewünschte Segment zwischen zwei vorhandenen Scheitelpunkten.
    • Wenn Sie einen Scheitelpunkt aus einer Maske löschen möchten, klicken Sie mit dem Scheitelpunkt-löschen-Werkzeug  auf den Scheitelpunkt.

Anpassen eines Pfadsegments

  1. Führen Sie mit dem Auswahl-Werkzeug einen der folgenden Schritte aus:
    • Ziehen Sie einen Scheitelpunkt.
    • Ziehen Sie die Richtungs-Handles, die von einem benachbarten Übergangspunkt ausgehen.
    • Ziehen Sie ein Kurvensegment.
    Hinweis:

    Wenn Sie ein Kurvensegment auf eine RotoBézier-Maske ziehen, werden auch die Scheitelpunkte verschoben.

Umwandeln eines Scheitelpunktes von einem Übergangspunkt in einen Eckpunkt und umgekehrt

  1. Klicken Sie mit dem Scheitelpunkt-konvertieren-Werkzeug  auf den Scheitelpunkt.
    Hinweis:

    Bei ausgewähltem Zeichenstift können Sie vorübergehend das Scheitelpunkt-konvertieren-Werkzeug aktivieren, indem Sie die Alt-Taste (Windows) bzw. die Wahltaste (macOS) gedrückt halten.

Einstellen der Spannung einer RotoBézier-Maske

  1. Wenn Sie die Spannung mehrerer Scheitelpunkte gleichzeitig einstellen möchten, wählen Sie diese Scheitelpunkte aus.
  2. Ziehen Sie einen Scheitelpunkt mit dem Scheitelpunkt-konvertieren-Werkzeug .
    Hinweis:

    Bei ausgewähltem Zeichenstift können Sie vorübergehend das Scheitelpunkt-konvertieren-Werkzeug aktivieren, indem Sie die Alt-Taste (Windows) bzw. die Wahltaste (macOS) gedrückt halten.

    Der Mauszeiger wird in der Form „Spannung anpassen“  angezeigt, wenn Sie einen Scheitelpunkt der RotoBézier-Maske ziehen.

    Wenn Sie einen Scheitelpunkt nicht ziehen, sondern auf ihn klicken, wird der Scheitelpunkt in einen Eckpunkt konvertiert (100 % Spannung). Wenn Sie dann erneut klicken, wird der Punkt in einen Übergangspunkt konvertiert (33 % Spannung). Wenn Sie nach oben oder nach rechts ziehen, nimmt die Spannung der Auswahl ab, und die Kurve der benachbarten Pfadsegmente wird verbreitert. Wenn Sie nach unten oder nach links ziehen, nimmt die Spannung der Auswahl zu, und die Kurve der benachbarten Pfadsegmente wird verengt.

    Hinweis:

    Der Spannungswert eines Scheitelpunkts wird während der Spannungsänderung im Bedienfeld „Info“ angezeigt.

Numerisches Ändern eines Maskenpfades

  1. Wählen Sie die Maske aus.
  2. Öffnen Sie im Zeitleistenfenster die Maskeneigenschaften.
  3. Klicken Sie auf das neben der Eigenschaft „Maskenpfad“ angezeigte unterstrichene Wort und legen Sie im Dialogfeld „Maskenform“ die Änderungen fest.

Festlegen des ersten Scheitelpunktes für einen Bézier-Pfad

Beim Animieren eines Pfades wird der oberste Scheitelpunkt am Anfangs-Keyframe von After Effects als erster Scheitelpunkt gekennzeichnet. Alle folgenden Scheitelpunkte werden ausgehend vom ersten Scheitelpunkt in aufsteigender Reihenfolge nummeriert. After Effects weist dieselben Nummern dann den entsprechenden Scheitelpunkten aller nachfolgenden Keyframes zu. After Effects interpoliert die Bewegung jedes Scheitelpunkts von seiner ursprünglichen Position auf einem Keyframe zu der Position des entsprechend nummerierten Scheitelpunkts auf dem nächsten Keyframe. Während einer Animation können Sie jederzeit einen anderen Scheitelpunkt als den ersten Scheitelpunkt festlegen. Dadurch numeriert After Effects die Scheitelpunkte des Pfades neu. Wenn die Scheitelpunkte neu nummeriert werden, ändert sich die Pfadanimation, denn After Effects ordnet dann die neuen Nummern für die Scheitelpunkte den entsprechenden alten Nummern für die Scheitelpunkte zu, die immer noch in den nachfolgenden Keyframes gespeichert sind.

Beim Kopieren eines geschlossenen Pfads in einen Bewegungspfad wird der als erster Scheitelpunkt des geschlossenen Pfads festgelegte Scheitelpunkt als Start des Bewegungspfads verwendet. Alle Bewegungspfade sind offene Pfade.

Bei einigen Formenpfad-Vorgängen wie „Pfade trimmen“ wird der erste Scheitelpunkt ebenfalls als Eingabe verwendet, um zu ermitteln, wie der Pfad geändert werden soll.

Hinweis:

Wenn Sie einem Pfad einen Scheitelpunkt hinzufügen, wird der neue Scheitelpunkt standardmäßig für die gesamte Dauer des Pfades auf dem Pfad angezeigt. Er formt den Pfad jedoch nur an dem Zeitpunkt um, an dem er hinzugefügt wurde. Wenn Sie einen Scheitelpunkt an einem bestimmten Zeitpunkt von einem Pfad löschen, wird er für die Dauer des Pfades von dem Pfad gelöscht. Sie können After Effects davon abhalten, während der Dauer des Pfades Scheitelpunkte hinzuzufügen oder zu entfernen, indem Sie „Bearbeiten“ > „Voreinstellungen“ > „Allgemein“ (Windows) oder „After Effects“ > „Einstellungen“ > „Allgemein“ (Mac OS) wählen und die Option „Konstante Scheitelpunktzahl bei Maskenbearbeitung erhalten“ deaktivieren.

Hinweis: Die Option „Konstante Scheitelpunktzahl bei Maskenbearbeitung erhalten“ heißt in After Effects CC und CS6 „Konstante Scheitelpunktzahl und Anzahl der weichen Kanten bei Maskenbearbeitung erhalten“.

  1. Erstellen Sie einen animierten Pfad.
  2. Verschieben Sie im Schnittfenster die Zeitmarke für den aktuellen Zeitpunkt an den Punkt, an dem Sie einen neuen ersten Scheitelpunkt festlegen möchten.
  3. Wählen Sie den Scheitelpunkt aus, den Sie als ersten Scheitelpunkt festlegen möchten.
  4. Wählen Sie „Ebene“ > „Maske und Formenpfad“ > „Ersten Scheitelpunkt setzen“.
    Hinweis:

    Der Scheitelpunkt, der als erster Scheitelpunkt festgelegt ist, wird im Bedienfeld „Komposition“ etwas größer angezeigt als die anderen Scheitelpunkte.

Animieren eines Maskenpfades mit der Funktion „Intelligente Masken-Interpolation“

Die Funktion „Intelligente Masken-Interpolation“ bietet präzise Steuerungsmöglichkeiten für das Erstellen von Maskenpfad-Keyframes und flüssigen, realistischen Animationen. Sobald Sie die Maskenpfad-Keyframes ausgewählt haben, zwischen denen Sie interpolieren möchten, werden durch die Funktion „Intelligente Masken-Interpolation“ die dazwischen liegenden Keyframes abhängig von den bereitgestellten Einstellungen erstellt. Im Bedienfeld „Info“ werden der Fortschritt der Interpolation und die Zahl der erstellten Keyframes angezeigt.

  1. Wählen Sie „Fenster“ > „Masken-Interpolation“.
  2. Wählen Sie mindestens zwei benachbarte Maskenpfad-Keyframes aus.
  3. Legen Sie die Optionen im Fenster „Masken-Interpolation“ fest und klicken Sie anschließend auf „Anwenden“.
    Hinweis:

    Wenn Sie den Interpolationsvorgang unterbrechen möchten, drücken Sie die Esc-Taste. Im Bedienfeld „Info“ wird angezeigt, dass der Vorgang unterbrochen wurde; außerdem wird die Zahl der erstellten Keyframes aufgeführt.

    Keyframe-Rate

    Legt fest, wie viele Keyframes pro Sekunde von der Funktion „Intelligente Masken-Interpolation“ zwischen den ausgewählten Keyframes erstellt werden sollen. Der Wert 10 bedeutet beispielsweise, dass jede zehntel Sekunde ein neuer Keyframe eingefügt wird. Wählen Sie „Auto“, wenn die Keyframerate denselben Wert haben soll wie die in Klammern angezeigte Framerate der Komposition. Mit mehr Keyframes wird eine flüssigere Animation erzeugt; bei weniger Keyframes geht das Rendern schneller.

    Hinweis:

    Unabhängig von der gewählten Keyframerate fügt die Funktion „Intelligente Masken-Interpolation“ immer Keyframes am Frame direkt nach dem ersten Maskenpfad-Keyframe sowie am Frame direkt vor dem zweiten Maskenpfad-Keyframe ein. Beispiel: Wenn Sie in einer Komposition mit 30 fps zwischen Keyframes bei 0 Sekunden und 1 Sekunde mit einer Rate von 10 Keyframes pro Sekunde interpolieren, werden Maskenpfad-Keyframes bei den Framenummern 1, 3, 6, 9, 12, 15, 18, 21, 24, 27 und 29 eingefügt.

    Keyframe-Halbbilder

    Verdoppelt die Keyframerate. Wenn diese Option aktiviert ist und „Keyframerate“ auf die Framerate der Komposition eingestellt wurde, wird bei jedem Videohalbbild ein Keyframe hinzugefügt. Aktivieren Sie diese Option zum Erstellen animierter Masken für Interlaced-Video. Wenn die Option deaktiviert ist, verschiebt sich die Maske u. U. von dem Objekt, das Sie auskeyen wollen. Weitere Informationen zu Halbbildern in Interlaced-Video finden Sie unter Interlaced-Video und Trennen von Halbbildern.

    Lineare Scheitelpunktpfade verwenden

    Wenn Sie diese Option aktivieren, verlaufen die Scheitelpunkte im ersten Keyframe auf einem geraden Pfad zu den entsprechenden Scheitelpunkten im zweiten Keyframe. Lassen Sie diese Option deaktiviert, wenn Sie möchten, dass einige Scheitelpunkte Kurvenpfaden folgen, beispielsweise wenn die gewünschte Interpolation sich drehende Elemente enthält. Ist diese Option deaktiviert, wird mit der Funktion „Intelligente Masken-Interpolation“ ein natürlicher Pfad für die Maske erstellt.

    Verbiegungsfestigkeit

    Legt fest, in welchem Verhältnis der interpolierte Maskenpfad auf Verbiegen und Dehnen reagiert. Der Wert 0 bedeutet, dass sich der Maskenpfad bei der Animation stärker verbiegt als dehnt. Bei 100 dehnt sich der Maskenpfad mehr, als er sich verbiegt.

    Qualität

    Legt fest, wie genau die Funktion „Intelligente Masken-Interpolation“ die Scheitelpunkte von einem Keyframe zum nächsten überträgt. Der Wert 0 gibt an, dass ein bestimmter Scheitelpunkt im ersten Keyframe nur dem Scheitelpunkt mit derselben Nummer im zweiten Keyframe entspricht. Zum Beispiel muss der zehnte Scheitelpunkt im ersten Keyframe exakt dem zehnten Scheitelpunkt im zweiten Keyframe entsprechen. Der Wert 100 bedeutet, dass ein Scheitelpunkt im ersten Keyframe praktisch jedem beliebigen Scheitelpunkt im zweiten Keyframe entsprechen kann. Höhere Werte führen üblicherweise zu besseren Interpolationen, allerdings erhöht sich die Verarbeitungszeit mit steigendem Wert.

    Maskenpfadscheitelpunkte hinzufügen

    Wenn diese Option aktiviert ist, fügt die Funktion „Intelligente Masken-Interpolation“ Scheitelpunkte hinzu, um eine höhere Qualität der Interpolation zu gewährleisten. Im Allgemeinen arbeitet die Funktion „Intelligente Masken-Interpolation“ am besten, wenn die Maskenpfade über eine hohe Dichte von Scheitelpunkten verfügen. Außerdem darf ein Scheitelpunkt auf dem ersten Maskenpfad nicht dem Mittelpunkt eines Kurven- oder Geradensegments auf dem zweiten Maskenpfad entsprechen. Daher erhalten Sie manchmal nur dann das gewünschte Ergebnis, wenn Sie vor der Abstimmung Scheitelpunkte hinzufügen. Die Funktion „Intelligente Masken-Interpolation“ führt keine Änderungen an den ursprünglichen Keyframes durch. Nur die neuen Maskenpfad-Keyframes, die von der Funktion „Intelligente Masken-Interpolation“ berechnet werden, besitzen zusätzliche Scheitelpunkte.

    Der festgelegte Wert gibt an, wie fein die Eingabe-Maskenpfade unterteilt werden: „Pixel zwischen Scheitelpunkten“ legt den Abstand in Pixeln zwischen Scheitelpunkten auf dem Maskenpfad mit dem größeren Umfang nach der Unterteilung fest. „Scheitelpunkte gesamt“ legt die Anzahl der Scheitelpunkte fest, die in den interpolierten Maskenpfaden enthalten sind. „Prozentsatz der Kontur“ legt fest, dass bei jedem angegebenen Prozentsatz der Konturlänge des Maskenpfades ein Scheitelpunkt eingefügt wird. Beispiel: Der Wert 5 bedeutet, dass ein Scheitelpunkt an allen Segmenten der Kontur eingefügt wird, die 5 % der Länge des Gesamtumfangs ausmachen. Wenn nur die Scheitelpunkte verwendet werden sollen, die sich auf dem Pfad am ersten Frame befanden, lassen Sie diese Option deaktiviert.

    Hinweis:

    Die Funktion „Intelligente Masken-Interpolation“ fügt möglicherweise Scheitelpunkte an vorhandenen Scheitelpunktpositionen hinzu, selbst wenn „Maskenpfadscheitelpunkte hinzufügen“ nicht aktiviert ist. Wenn zwei Scheitelpunkte eines Maskenpfades einem einzelnen Scheitelpunkt des anderen Maskenpfades entsprechen, wird der einzelne Scheitelpunkt an derselben Position dupliziert, sodass das Segment zwischen den beiden Scheitelpunkten auf einen Punkt verkleinert wird.

    Abstimmungsmethode

    Legt den Algorithmus fest, mit dem die Funktion „Intelligente Masken-Interpolation“ die Scheitelpunkte eines Maskenpfades mit denen eines anderen Maskenpfades abstimmt. Mit „Auto“ wird der Abstimmungsalgorithmus für Kurven angewendet, wenn einer der ausgewählten Keyframes ein Kurvensegment enthält. Ist dies nicht der Fall, wird der Algorithmus für Mehrfachlinien angewendet. Mit „Kurve“ wird der Algorithmus für Maskenpfade mit Kurvensegmenten angewendet. Mit „Mehrfachlinie“ wird der Algorithmus für Maskenpfade angewendet, die nur gerade Segmente enthalten.

    Hinweis:

    Wenn Sie die Methode „Mehrfachlinie“ auswählen, sind die von der Funktion „Intelligente Masken-Interpolation“ hinzugefügten Maskenpfad-Keyframes Mehrfachlinien, selbst wenn der Eingabe-Maskenpfad Kurvensegmente enthält.

    1:1-Übereinstimmung des Scheitelpunkts

    Legt fest, dass bei der Funktion „Intelligente Masken-Interpolation“ auf einem Maskenpfad ein Scheitelpunkt erstellt wird, der mit dem Scheitelpunkt derselben Nummer auf dem anderen Maskenpfad übereinstimmt. Die „Intelligente Masken-Interpolation“ stimmt auf jedem Eingabe-Maskenpfad die jeweils ersten Scheitelpunkte, die zweiten, dritten usw. miteinander ab. Wenn die beiden Pfade eine unterschiedliche Anzahl von Scheitelpunkten haben, kann diese Aktion zu unvorhergesehenen Ergebnissen führen.

    Erste Übereinstimmung der Scheitelpunkte

    Legt fest, dass die Funktion „Intelligente Masken-Interpolation“ die ersten Scheitelpunkte der beiden Maskenpfad-Keyframes aufeinander abstimmt. Wenn die Option deaktiviert ist, sucht die Funktion „Intelligente Masken-Interpolation“ nach der bestmöglichen Übereinstimmung für die ersten Scheitelpunkte der beiden Eingabe-Maskenpfade.

    Hinweis:

    Damit Sie gute Ergebnisse erzielen, sollten Sie darauf achten, dass die ersten Scheitelpunkte der Eingabe-Maskenpfade übereinstimmen. Aktivieren Sie dann die Option „Erste Übereinstimmung der Scheitelpunkte“.

Verschieben von Masken oder horizontales Verschieben von Ebenen hinter Masken

Sie können den Bereich anpassen, der durch eine Maske hindurch sichtbar ist, indem Sie die Maske im Ebenen- oder Kompositionsfenster verschieben oder im Kompositionsfenster die Ebene hinter der Maske horizontal verschieben. Wenn Sie eine Maske verschieben, bleiben die Positionswerte der Maskenebene konstant und die Maske verschiebt sich relativ zu den anderen Objekten im Kompositionsfenster.

Wenn Sie das Ausschnitt-Werkzeug (Ankerpunkt) verwenden, um eine Ebene hinter einer Maske horizontal zu verschieben, bleibt die Position der Maske im Kompositionsfenster konstant, ändert sich jedoch im Ebenenfenster. Die Positionswerte der maskierten Ebene ändern sich im Verhältnis zu der Komposition. Wenn Sie mit der Ebene über die Ränder des Frames hinausgehen, ändern sich auch die Werte für den Maskenpfad der Ebene. Durch Einsatz des Ausschnitt-Werkzeugs (Ankerpunkt) werden Arbeitsschritte eingespart. Ohne das Werkzeug müssten Sie die Werte der Eigenschaften „Position“ und „Maskenpfad“ für die maskierte Ebene manuell ändern. Sie können eine hinter einer anderen Ebene horizontal verschobene Ebene animieren, indem Sie Keyframes für die Eigenschaften „Position“ und „Maskenpfad“ der maskierten Ebene festlegen.

Wenn Sie im Bedienfeld „Komposition“ das Ausschnitt-Werkzeug (Ankerpunkt) verwenden, nimmt After Effects automatisch zwei Anpassungen vor. Im Bedienfeld „Ebenen“ wird die Maske relativ zu ihrer Ebene verschoben (oben), im Bedienfeld „Komposition“ wird die Ebene dagegen relativ zur Komposition verschoben (unten).

Verschieben einer Maske

  1. Wählen Sie die Maske(n) aus, die Sie verschieben möchten.
  2. Ziehen Sie die Maske(n) im Bedienfeld „Komposition“ an die neue Position. Sie können die Verschiebung auf eine horizontale oder vertikale Bewegung einschränken, indem Sie die Umschalttaste drücken, nachdem Sie mit dem Ziehen begonnen haben.

Horizontales Verschieben einer Ebene hinter ihrer Maske

  1. Wählen Sie im Werkzeugfenster das Ausschnitt-Werkzeug (Ankerpunkt) aus.

  2. Klicken Sie im Bedienfeld „Komposition“ in den Maskenbereich und ziehen Sie die Ebene an eine neue Position.

Gesichts-Tracking und Maskenverfolgung

Sie können die Maskenverfolgung verwenden, um eine Maske so zu transformieren, dass sie der Bewegung eines oder mehrerer Objekte in einem Film folgt. Weitere Informationen finden Sie unter Maskenverfolgung.

Sie können die Maskenverfolgung auch verwenden, um menschliche Gesichter präzise zu erkennen und zu verfolgen. Weitere Informationen finden Sie unter Gesichts-Tracking.

Zugriff auf Pfadpunkte auf Masken, Bézier-Formen und Pinselstrichen über Expressions

Sie können Expressions verwenden, um die x/y-Koordinaten von Pfadpunkten oder Scheitelpunkten für die folgenden Elemente zu lesen und zu schreiben:

  • Ebenenmasken,
  • Bézier-Formen,   
  • Pinselstriche auf den Effekten „Malen“ und „Roto-Pinsel und Kantenverfeinerung“

Die Expression-Methoden ähneln dem Zugriff auf Pfadscheitelpunkte per Skripterstellung. Die Expression-Methode lautet points() und nicht vertices(), um einen höheren Wiedererkennungswert zu erzielen.

Zugriff auf Expression-Methoden

Sie können mithilfe der folgenden Schritte auf die Expression-Methoden zugreifen:

  1. Um eine Farbflächenebene zu erstellen, wählen Sie Ebene > Farbfläche aus.

  2. Sobald Sie eine Farbfläche erstellt haben, erstellen Sie eine Maske. Klicken Sie auf das Form-Werkzeug, z. B. ein Polygon, und erstellen Sie eine Maske über der Farbflächenebene.

  3. Öffnen Sie im Schnittfenster die Eigenschaften der Maske und klicken Sie bei gedrückter Alt-Taste auf Maskenpfad.

  4. Das Expression-Feld wird angezeigt. Klicken Sie im Schnittfenster auf das Expression-Sprachmenü und wählen Sie Pfadeigenschaft.

    Expression-Sprachmenü
    Expression-Sprachmenü

  5. Wählen Sie eine Expression-Methode aus der Liste der Expression-Methoden für Pfadpunkte aus.

    Weitere Informationen zu Expression-Methoden finden Sie unter Expression-Zugriff auf Pfadpunkte auf Formen, Masken und Pinselstrichen (Expression-Referenz).

Im Folgenden finden Sie beispielhafte Expression-Methoden für die folgenden Pfadobjekte:

  • Pfade von Ebenenmasken: layer("Dark Gray Solid 1").mask("Mask 1").path or .maskPath
  • Pfade von Bézier-Formen: layer("Shape Layer 1").content("Shape 1").content("Path 1").path
  • Pfade von Maleffektstrichen: layer("Dark Gray Solid 1").effect("Paint").stroke("Brush 1").path
  • Pfade von „Roto-Pinsel und Kantenverfeinerung“-Effektstrichen: layer("Dark Gray Solid 1").effect("Roto Brush & Refine Edge").stroke("Foreground 1").path

Tipps zum Arbeiten mit diesen Expression-Methoden:

  • Punkt- und Tangentenwerte werden als Array aus [x, y]-Zahlpaar-Arrays zurückgegeben, die für die Koordinaten der Scheitelpunkte stehen. Koordinatenwerte werden auf vier Dezimalstellen gerundet.
  • Punkt- und Tangenten-Arrays beginnen mit dem ersten Scheitelpunkt auf dem Pfad. Sie können den ersten Scheitelpunkt von Ebenenmasken- und Bézier-Formenpfaden ändern, indem Sie den Befehl Ebene > Maske und Formenpfad > Ersten Scheitelpunkt setzen verwenden.
  • Koordinaten für Pfadpunkte von Ebenenmasken sind relativ zum Ursprung der Ebene oben links.
  • Koordinaten für Pfadpunkte von Bézier-Formen sind relativ zum Ankerpunkt der Formengruppe des Pfads (z. B. „Transformieren: Form 1 > Ankerpunkt“).
  • Koordinaten für Pfadpunkte von Pinselstrichen sind relativ zum Beginn des Strichs. Der erste Punkt ist [0,0].
  • Die toComp()-Methode oder andere Transformationsmethoden für Ebenen-Räume können hilfreich sein, um Koordinaten von unterschiedlichen Ebenen für einen gemeinsamen Raum umzuwandeln oder um die Koordinaten einfach relativ zum Kompositions-Raum zurückzusetzen.
  • Da Bézier-Formenpfade relativ zum Ankerpunkt ihrer lokalen Formgruppe und nicht zur Ebene sind, können diese Werte versetzt und nicht an der erwarteten Stelle sein. Um dies zu umgehen, setzen Sie alle Eigenschaften von „Transformieren“ in der Formgruppe auf null. Bitte beachten Sie Folgendes: Wenn Sie eine parametrische Form in eine Bézier-Form umwandeln, kann sich dies auf die Position der Formengruppe auswirken.
  • Die createPath()-Methode kann in die points-, tangents- und isClosed-Methoden desselben Pfads oder anderer Pfade überführt werden. Sie können diese Methoden unverändert überführen, um einen Pfad zu duplizieren oder um die Punkt- und Tangentenwerte umzuwandeln, bevor Sie sie zum Ändern oder Animieren des Pfads überführen.

Bedienfeld „Nullebene aus Pfaden erstellen“

Nullebene aus Pfaden erstellen  Das scriptUI- Feld ermöglicht es Ihnen, intuitive Animationen mithilfe von Expressions zu erstellen, ohne die Expressions manuell eingeben zu müssen. Sie können verschiedene Pfade direkt mit Formen, Formen mit Farbflächen usw. verknüpfen. Das Bedienfeld Nullebene aus Pfaden erstellen nutzt den Zugriff auf Pfadpunkte über Expressions, um die Nullebenen automatisch zu verknüpfen, sodass Sie die Expression nicht selbst eingeben müssen.

Das Bedienfeld erstellt Nullebenen für jeden Pfadpunkt in einem Maskenpfad oder Beziér-Formenpfad. Sie können im Bedienfeld die folgenden Schaltflächen verwenden, um festzulegen, wie Nullebenen erstellt werden sollen:

  • Punkte folgen Nullebenen: Durch Klicken auf diese Schaltfläche werden Nullebenen erstellt, die die Position von Pfadpunkten steuern. Die Pfadpunkte werden Nullebenen zugeordnet und Sie können die Nullebenen animieren, um die Pfadpunkte zu steuern.
  • Nullebenen folgen Punkten: Durch Klicken auf diese Schaltfläche werden Nullebenen erstellt, die durch die Position von Pfadpunkten gesteuert werden. Die Nullebenen sind Pfadpunkten zugeordnet, und Sie können die Pfadpunkte animieren, um die Nullebenen zu verschieben.
  • Pfad verfolgen: Durch Klicken auf diese Schaltfläche wird eine einzelne Nullebene erstellt, die dem Pfad folgt. Die Position der Nullebene wird mit den Koordinaten des Pfads verknüpft. Die Drehung der Nullebene wird automatisch am Pfad ausgerichtet. Mit der Option „Pfad verfolgen“ lässt sich steuern, wie die Nullebene auf dem Pfad verschoben wird und ob sie Schleifen formt. Standardmäßig sind die Einstellungen für die Keyframes so festgelegt, dass sie den Pfad in einer Sekunde verfolgen, und „Schleife“ ist aktiviert.

Verwenden des Bedienfelds

  1. Um das Bedienfeld zu öffnen, wählen Sie Fenster > Nullebene aus Pfaden erstellen aus.

  2. Um eine Formmaske hinzuzufügen, wählen Sie Ebene > Neu > Formebene aus. Fügen Sie eine Formmaske zur Ebene hinzu.

    Hinweis:

    Das Bedienfeld verwendet Bézier-Formen. Entsprechend müssen jegliche parametrischen Formen wie Rechtecke, Ellipsen und Sterne in eine Bézier-Form umgewandelt werden. Um eine parametrische Form in eine Bézier-Form zu konvertieren, öffnen Sie die Formebene und klicken Sie mit der rechten Maustaste auf den Pfad der Form, beispielsweise Rechteck 1, und wählen Sie In Bézier-Pfad umwandeln aus.

    Wiederholen Sie Schritt 2, um weitere Formen hinzuzufügen.

  3. Jede Bézier-Form und -Maske verfügt über einen Pfad. Öffnen Sie die Ebenen im Zeitleistenfenster, um die Pfade anzuzeigen. Wenn Sie möchten, dass die Nullebenen Pfadpunkten folgen, wählen Sie im Schnittfenster einen Pfad aus und klicken Sie im Bedienfeld Nullebene aus Pfaden erstellen auf Nullebenen folgen Punkten.

    Das Skript erstellt daraufhin eine Nullebene für jeden Punkt des Pfads. Sie können alle Nullebenen löschen, die Sie nicht benötigen.

    Hinweis:

    Wenn Sie eine parametrische Form in eine Bézier-Form umwandeln, passt After Effects die Eigenschaft „Position“ der Form an. Hierdurch entsteht eine Verschiebung, wenn die Position der Nullebene berechnet wird. Um dieses Problem zu vermeiden, legen Sie vor dem Erstellen von Nullebenen den Wert der Eigenschaft „Transformieren“ einer Form wie „Transformieren: Ellipse 1“ auf null fest.

  4. Wenn Sie möchten, dass die Pfadpunkte Nullebenen folgen, wählen Sie einen Pfad im Schnittfenster aus. Klicken Sie dann im Bedienfeld Nullebene aus Pfaden erstellen auf Punkte folgen Nullebenen.

  5. Nachdem Sie Nullebenen für alle Pfadpunkte erstellt haben, können Sie sie miteinander verknüpfen, um Animationen zu erstellen. Nullebenen, die durch Klicken auf die Schaltfläche Punkte folgen Nullebenen erstellt werden, und Nullebenen, die durch Klicken auf Nullebenen folgen Punkten erstellt werden, haben unterschiedliche Farben. Zum Anhängen von Nullebenen wählen Sie eine Nullebene aus und halten Sie die Umschalttaste gedrückt, während Sie mit dem Auswahlwerkzeug eine übergeordnete Ebene auswählen und die Koordinaten der Nullebene an die übergeordnete Ebene anfügen.

    Nachdem Sie alle Nullebenen miteinander verknüpft haben, zeigen Sie Ihre Animation in der Vorschau an, um sie zu überprüfen.

Adobe-Logo

Bei Ihrem Konto anmelden