Das Dokument enthält Informationen zur Arbeit mit datengesteuerten Animationen.

Datengesteuerte Animationen werden mithilfe von Live-Daten erstellt, die aus verschiedenen Datenquellen erfasst wurden, um die Animation in Ihrer Komposition zu steuern. Sie können Daten aus mehreren Datenquellen verwenden. Die Daten können statisch sein oder zeitlich variieren. Sie können die Daten direkt in Ihr After Effects-Projekt importieren und als Eingabe verwenden, um damit Diagramme, Figuren, optische Effekte, Filmtitel und andere Grafikanimationen zu animieren.

Beispiel für datengesteuerte Animationen
Beispiel für datengesteuerte Animationen

Datenquellen

Sie können Daten aus beinahe allen möglichen Quellen verwenden. Hierzu zählen u. a.:

  • Gerätegenerierte Datendateien – Daten von Geräten wie Fitnesstrackern, die Aktivitäten mithilfe von Sensoren aufzeichnen und in unterschiedlichen Dateiformaten speichern. Zu diesen zeitlich variierenden Daten zählen Geschwindigkeit, Höhe, Entfernung Herzfrequenz und verschiedene andere Benutzeraktivitätsparameter.
  • Benutzergenerierte statische Daten – Globale statische Daten wie Umfrageergebnisse, die geändert werden können, um Grafiken zu steuern. Mit einer benutzerdefinierten Datei kann ein Arbeitsablauf für globale Daten bereitgestellt werden.
  • URL – Echtzeitdaten von Websites wie Einstiegs- und Ausstiegspfade von Benutzern, die auf einer Webseite navigieren.
  • Metadaten – Daten, die in Metadaten von Videodateien eingebettet sind.

Eingabeformate

Sie können Datendateien in den folgenden Formaten importieren:

  • JSON
  • MGJSON
  • CSV
  • TSV

Wenn Sie über Datendateien in anderen Formaten verfügen, konvertieren Sie sie in eines der unterstützten Dateiformate und importieren Sie sie anschließend in das After Effects-Projekt. Es gibt verschiedene Werkzeuge zum Konvertieren von Dateien in Formate, die von After Effects unterstützt werden.

Datengesteuerte Animation

Datengesteuerte Animation

Unterstützung für Standard-JSON (.json)

Sie können eine standardmäßige JSON-Datei als Footage in After Effects importieren und die Datendateien arbeiten im Hintergrund. After Effects referenziert die Daten in diesen Datendateien direkt, um Animationen in den Projekten zu steuern. JSON-Footage wird nicht in Form von Datenströmen im Zeitleistenfenster dargestellt. Sie können die Daten mithilfe von Expressions als ausgewertetes JSON-Objekt referenzieren.

Sie können die Expressions ändern, um festzulegen, wie Daten referenziert werden. Sie können die Daten in einen Texteditor schreiben, der von After Effects referenziert wird, um Animationen zu steuern. Die JSON-Unterstützung basiert auf dem JSON-Schema, das angibt und definiert, wie eine Anwendung JSON-Daten verwenden und ändern kann.

Die grundlegenden JSON-Datentypen lauten:

  • Zahl: Eine vorzeichenbehaftete Dezimalzahl.
  • Zeichenfolge: Eine Folge aus null oder mehr Unicode-Zeichen.
  • Boolescher Wert: Einer der Werte „true“ oder „false“.
  • Array: Eine geordnete Liste von null oder mehr Werten.
  • Objekt: Eine ungeordnete Sammlung von Namen- und Wertpaaren, wobei die Namen (Schlüssel) Zeichenfolgen sind.
  • Null: Ein leerer Wert, für den das Wort „null“ angegeben ist.

Verwenden von JSON-Dateien in After Effects

Zum Verwenden einer Standard-JSON-Datei gehen Sie wie folgt vor:

  1. Wählen Sie Datei > Importieren aus.

  2. Klicken Sie zum Importieren aufeineJSON-Datei und klicken Sie auf Öffnen.

  3. Die Datei wird dem Projekt hinzugefügt. Erstellen Sie mit dem Footage eine Komposition.

  4. Fügen Sie eine Farbfläche zu einer Komposition hinzu. Um eine Farbfläche hinzufügen, wählen Sie Ebene > Farbfläche aus.

  5. Öffnen Sie im Zeitleistenfenster die Eigenschaften für die Farbflächenebene und klicken Sie bei gedrückter Alt-Taste auf den Parameter Deckkraft.

  6. Ändern Sie die Daten in der Expression, um Ihre Animation zu ändern. Sie können die JSON-Daten steuern und die Daten werden von der Datendatei referenziert, in der alle Informationen gespeichert sind.

  7. Sie können die JSON-Datei auch durch eine andere JSON-Datei ersetzen, um die referenzierten Daten zu ändern. Wählen Sie dazu Footage ersetzen > Datei aus und öffnen Sie die neue Datei von Ihrem Computer.

Um die Daten zu verwenden, können Sie eine Expression für die Eigenschaft anwenden, die durch die Daten gesteuert werden soll. Gehen Sie anschließend folgendermaßen vor:

  1. Verwenden Sie das sourceData-Attribut, um die Daten in einer JSON-Datei zu lesen. Beispiel:

    var sampleData = footage("sample.json").sourceData;
  2. Um den Wert zurückzugeben, referenzieren Sie die spezifische Eigenschaft innerhalb der JSON-Daten. Beispiel:

    myData.engineData.RPM or myData.latitude.value.

Unterstützung für Motion Graphics JSON (.mgJSON)

Sie können eine MGJSON-Datei als Footage in Ihr Projekt importieren. Wenn Sie Datenfootage zu einer Komposition hinzufügen, werden Dateneigenschaftsströme in eine Gruppe der obersten Ebene – in eine Datengruppe – gruppiert. Die Datengruppe zeigt Footagedaten als Eigenschaften an. Jede Eigenschaft in der Datengruppe ist per Expression mit der Footagedatei verknüpft. Der Zugriff auf den Wert der Datendatei erfolgt über die Expression footage("foo.mgjson").dataValue(N). Hier steht N für den Pfad zum Datenstrom in der Datei. MGJSON basiert auf einem Schema, das zur Vereinfachung des Referenzierens und Importierens von Datenströmen in After Effects dient.

Jede einzelne Dateneigenschaft verfügt über eine Expression, die diese Eigenschaft mit den Daten in der MGJSON-Datei verknüpft. Wenn die MGJSON-Datei geändert wird, werden die Dateneigenschaftswerte automatisch aktualisiert.

Sie können die Datenebenen im Zeitleistenfenster öffnen und das Auswahlwerkzeug verwenden, um Parameter mit anderen Parametern zu verknüpfen. Die Angaben zu den Änderungen werden automatisch ausgefüllt.

Verwenden von MGJSON-Footage in After Effects

Zum Verwenden einer MGJSON-Datei gehen Sie wie folgt vor:

  1. Wählen Sie Datei > Importieren.

  2. Klicken Sie zum Importieren aufeine MGJSON-Dateiund klicken Sie auf Öffnen.

  3. Die Datei wird dem Projekt hinzugefügt. Erstellen Sie mit dem Footage eine Komposition.

  4. Importieren Sie ein Asset in das Projekt und fügen Sie es zur Komposition hinzu.

  5. Öffnen Sie im Zeitleistenfenster die Eigenschaften des Footage.

  6. Legen Sie mit dem Auswahlwerkzeug eine der Eigenschaften des Assets, z. B. Drehung, auf einen der Datenströme in der Datenebene fest. Die Asseteigenschaft referenziert nun die Daten von der Datenebene. Jeder dargestellte Datenstrom weist eine Expression auf, die seinen Wert aus der Footagedatei bezieht.

  7. Wenn Sie Footage in einer Vorschau anzeigen, wird das Asset anhand des Datenstroms der Datenebene animiert.

Sie können die Datensamples aus der Datei in Keyframes umwandeln. Führen Sie die folgenden Schritte aus, um die Samples in Keyframes umzuwandeln:

  1. Importieren Sie die MGJSON-Datei in Ihr Projekt und ziehen Sie sie ins Zeitleistenfenster.

  2. Klicken Sie mit der rechten Maustaste auf die Datenebene und wählen Sie im Menü Ebenen- und Keyframes-Assistent die Option Keyframe-Assistent > Keyframes aus Daten erstellen aus.

  3. Öffnen Sie zum Anzeigen der Keyframes die Datenebene.

Hinweis:

Nach der Keyframekonvertierung sind die Daten nicht mehr live und werden nicht von der Datendatei referenziert.

Sie können Live-Daten auch als Diagramm im Diagrammeditor anzeigen. Klicken Sie im Zeitleistenfenster auf das Diagrammeditor-Symbol, um das Diagramm anzuzeigen.

Die datengesteuerte Animation stützt sich auf die Expression-Referenz. Weitere Informationen finden Sie unter Datengesteuerte Animation (Expression-Referenz).

Zeitliches Angleichen eines Videos an mgJSON-Daten

Der Befehl Ebene > Zeit > Video an Daten ausrichten versetzt Videoebenen gemäß der Vorgabe in einer mgJSON-Datei um mehrere Frames. Mit diesem Befehl können Sie Videos zeitlich an in einer passenden mgJSON-Datei gespeicherte Datensamples anpassen. Wenn Sie beispielsweise Daten während eines Rennens aufgezeichnet haben, die Startzeit des Videos jedoch nicht mit der Startzeit der aufgezeichneten Daten übereinstimmt, können Sie einen Versatz festlegen, sodass die Daten automatisch angeglichen werden.

Gehen Sie wie folgt vor, um Videos zeitlich an mgJSON-Daten anzugleichen:

  1. Fügen Sie die .mgJSON-Datei zu einer Komposition hinzu, die auch die Zielebenen enthält.
  2. Wählen Sie sowohl die .mgJSON-Ebene als auch die Zielebenen aus.
  3. Wählen Sie Ebene > Zeit > Video an Daten ausrichten aus.

Damit das gewünschte Ergebnis erzielt werden kann, muss die mgJSON-Datei eine videoSyncTimeList-Gruppe mit folgenden Elementen enthalten:

  • Den Namen mindestens einer Zielebene (fileName)
  • Die Anzahl der Frames (frameNumber), um die diese Ebenen vom Beginn der Datenebene aus versetzt werden sollen

Beispiel:

"videoSyncTimeList": [
  {
    "fileName": "sample1.mp4",
    "frameNumber": 1000
  },

  {
    "fileName": "sample2.mp4",
    "frameNumber": -1000
  }

Der Wert für „fileName“ muss der Ebenenname einer ausgewählten Ebene sein. Es darf sich nicht um den Quellnamen der Ebene handeln. Wenn Sie den Namen einer Ebene mit einer Quelle in Ihrer Komposition bearbeiten, also beispielsweise die Ebene „sample1.mp4“ in „Rennkamera 1“ umbenennen, müssen Sie auch den Wert „fileName“ in der mgJSON-Datei entsprechend anpassen. Von „fileName“ referenzierte Ebenen müssen keine Footage-Elemente mit Quelldatei sein. Es kann sich auch um Farbflächen, verschachtelte Kompositionen oder andere Ebenenarten handeln.

Positive frameNumber-Werte versetzen die Zielebene nach links (vor die Datenebene). Negative frameNumber-Werte versetzen die Zielebene nach rechts (hinter die Datenebene). Ein frameNumber-Wert von 0 gleicht den Beginn der Zielebene an den Beginn der Datenebene an.

Unterstützung für CSV (.csv) und TSV (.tsv oder .txt)

Sie können Dateien mit Komma als Trennzeichen (.csv) und mit Tabstopp als Trennzeichen (.tsv oder .txt) als Footage in After Effects importieren und als Datenquelle verwenden. CSV- und TSV-Dateien speichern tabellarische Daten im Normaltextformat, wobei die Werte entweder durch Kommas oder Tabstopps voneinander getrennt sind. Die CSV- und TSV-Datendateien funktionieren ähnlich wie JSON-Dateien.

Befolgen Sie diese Schritte, um CSV- oder TSV-Datendateien in After Effects zu verwenden:

  1. Importieren Sie eine CSV- oder TSV-Datei auf ähnliche Weise als Footage in Ihr Projekt, wie Sie Video-, Audio- oder sonstige Dateien importieren.
    Es gibt folgende Möglichkeiten, Ihre Dateien als Footage zu importieren:
    • Wählen Sie Datei > Importieren aus.
    • Klicken Sie mit der rechten Maustaste auf das Projektfenster und wählen Sie Importieren > Dateityp aus.
    • Doppelklicken Sie auf das Projektfenster.
  2. Die Datei wird dem Projekt hinzugefügt. Erstellen Sie eine Komposition mit der Datei.

  3. Öffnen Sie im Zeitleistenfenster die Eigenschaften des Footage. Verknüpfen Sie die Dateneigenschaften der Ebene in der Komposition über das Auswahlwerkzeug für Expressions oder für Eigenschaftsverknüpfungen mit einer anderen Ebene. Um das Textfeld für Expressions zu öffnen, halten Sie die Umschalttaste gedrückt und klicken Sie auf das Timersymbol neben dem Namen der Ebene. Außerdem können Sie die Dateneigenschaften über den Befehl Bearbeiten > Mit Eigenschaftsverknüpfungen kopieren verknüpfen.

    Weitere Informationen über Ebenendateneigenschaften in der Zeitleiste finden Sie unter Grundlagen zu Dateneigenschaften.

  4.  Um die Datenfootagedatei zu referenzieren, verwenden Sie eine Expression für die Eigenschaft, die von den Daten gesteuert werden soll. Verwenden Sie das Footage-Attribut dataValue(), um die Daten aus einer bestimmten Zeile und Spalte zu lesen. Zeilen und Spalten haben einen nullbasierten Index. Zum Beispiel gibt footage("sample.tsv").dataValue([15,1]) den Wert in Zeile 16 der zweiten Spalte zurück.

Grundlagen zu Dateneigenschaften

Wenn Sie eine JSON-, CSV- oder TSV-Datei zu einer Komposition hinzufügen und die Eigenschaften öffnen, enthalten sie nur eine Gruppe von Dateneigenschaften anstelle der Eigenschaftengruppe Transformieren. Die Gruppe von Dateneigenschaften enthält die Hierarchie der Daten gemäß der entsprechenden Definition in der Datei.

JSON-Dateneigenschaftengruppe im Zeitleistenfenster
JSON-Dateneigenschaftengruppe im Zeitleistenfenster
CSV- und TSV-Dateneigenschaftengruppe im Zeitleistenfenster
CSV- und TSV-Dateneigenschaftengruppe im Zeitleistenfenster

Diese Datengruppe handhabt After Effects ähnlich wie Motion Graphics JSON (.mgJSON)-Dateien. Der Unterschied liegt darin, dass JSON, CSV und TSV lediglich statische Datenwerte enthalten können, während mgJSON dynamische Daten enthalten kann (Daten, die sich mit der Zeit ändern).

Jede einzelne Dateneigenschaft verfügt über eine Expression, die diese Eigenschaft mit den Daten in der JSON-, CSV- oder TSV-Datei verknüpft. Wenn Sie die Quelldatendatei ändern, geben die Dateneigenschaftenwerte die Änderung wieder.

Verknüpfungseigenschaften mit dem Auswahlwerkzeug für Eigenschaftenverknüpfungen

Wenn Sie keine komplexen Expressions schreiben möchten, können Sie das Auswahlwerkzeug Eigenschaftswert oder den Befehl Bearbeiten > Mit Eigenschaftsverknüpfungen kopieren verwenden, um die Dateneigenschaften mit den Eigenschaften anderer Schichten zu verknüpfen. Wenn Sie die Ebenen verlinken, schreibt das Auswahlwerkzeug für Eigenschaftenverknüpfungen automatisch Expressions für Sie.

Benutzerdefinierte Funktionsbibliotheken für Expressions – JSX

In After Effects 15.0 war es möglich, eine JSON-Datei zu importieren, die benutzerdefinierte JavaScript-Funktionen definierte, die als Bibliothek für benutzerdefinierte Expression-Funktionen verwendet werden konnten. In After Effects 15.1 haben JavaScript-Objekte keine zulässige Syntax für JSON. After Effects 15.1 verwendet einen anderen JSON-Parser. Dieser ist streng und erlaubt keinen Import einer JSON-Datei mit unzulässiger Syntax.

Wenn Sie versuchen, eine JSON-Datei mit einer definierten JavaScript-Funktion in After Effects 15.1 zu importieren oder ein Projekt mit einer solchen Datei zu öffnen, zeigt After Effects eine Fehlermeldung an.

Um dieses Problem zu umgehen, können Sie eine JavaScript-Syntaxerweiterungsdatei (.jsx) in After Effects 15.1 importieren. Der Inhalt der JSX-Datei kann dem der in After Effects 15.0 importierten JSON-Datei entsprechen. Sie müssen lediglich die Dateinamenerweiterung in .jsx ändern. Wenn Sie ein vorhandenes Projekt mit einer JSON-Datei öffnen, die nicht funktioniert, verwenden Sie Datei > Footage ersetzen, um die JSON-Datei durch die JSX-Datei zu ersetzen. Die Expression-Referenzen zur JSON-Datei werden mit Referenzen zur JSX-Datei ersetzt.

Bekannte Probleme mit der datengesteuerten Animation

Bei der Arbeit mit datengesteuerten Animationen in After Effects können diverse Probleme auftreten. Eine vollständige Liste finden Sie unter Bekannte Probleme mit datengesteuerten Animationen.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie