Benutzerhandbuch Abbrechen

Gesichts-Tracking

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
    3. Funktionen in der Beta-Version
      1. Bedienfeld „Eigenschaften“ (Beta)
      2. Wählbare Spurmasken-Ebenen (Beta)
      3. Native H.264-Codierung (Beta)
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
    10. Einrichtung und Installation
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formenpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle und Masken
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Farb-Management
    3. Effekte zur Farbkorrektur
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekte unter „Simulation“
    4. Effekte unter „Stilisieren“
    5. Effekte unter „Audio“
    6. Effekte unter „Verzerren“
    7. Effekte unter „Perspektive“
    8. Effekte unter „Kanäle“
    9. Effekte unter „Generieren“
    10. Effekte unter „Überblenden“
    11. Der Effekt „Rolling-Shutter-Reparatur“
    12. Effekte unter „Weich- und Scharfzeichnen“
    13. Effekte unter „3D-Kanal“
    14. Effekte unter „Dienstprogramm“
    15. Effekte unter „Matt“
    16. Effekte unter „Störung und Körnung“
    17. Effekt „Hochskalieren mit Detailerhaltung“
    18. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Ausdruck
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Expression-Sprachreferenz
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Tracking der 3D-Kamerabewegung
    5. Arbeiten im 3D-Designraum
    6. 3D-Transformations-Gizmos
    7. Machen Sie mehr mit 3D-Animation
    8. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Real-Time Engine
    9. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    3. Konvertieren von Filmen
    4. Multi-Frame-Rendering
    5. Automatisches Rendern und Netzwerk-Rendern
    6. Rendern und Exportieren von Standbildern und Standbildsequenzen
    7. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. CINEMA 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Frame.io installieren und aktivieren
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau behandelt    
    3. Verbessern der Leistung
    4. Voreinstellungen
    5. Anforderungen an GPU und GPU-Treiber für After Effects

Übersicht über das Gesichts-Tracking

Mit dem Gesichts-Tracking können Sie menschliche Gesichter präzise erkennen und verfolgen. Mit einfachem Masken-Tracking können Sie schnell Effekte auf ein Gesicht anwenden, wie eine selektive Farbkorrektur, das Verzerren eines Gesichts und vieles mehr.

Mit dem Gesichts-Tracking können Sie jedoch auch bestimmte Stellen des Gesichts wie die Pupillen, den Mund oder die Nase verfolgen und diese Gesichtszüge dadurch isolieren und detaillierter bearbeiten. Ändern Sie z. B. die Augenfarbe oder betonen Sie Mundbewegungen, ohne dass Sie jeden einzelnen Frame anpassen müssen.

Mit After Effects können Sie auch Gesichtszüge messen. Durch das Tracking von Gesichtsmaßen erhalten Sie detaillierte Informationen – z. B. wie weit der Mund oder ein Auge geöffnet ist. Wenn jeder Datenpunkt isoliert ist, können Sie Inhalte optimieren. Zudem können Sie detaillierte Tracking-Daten zur Performance-basierten Zeichenanimation in Adobe Character Animator exportieren.

Der Gesichts-Tracker funktioniert größtenteils automatisch, Sie können jedoch bessere Ergebnisse erzielen, indem Sie die Analyse in einem Frame beginnen, der eine senkrechte Frontalansicht des Gesichts enthält. Ausreichende Beleuchtung auf das Gesicht kann die Genauigkeit des Gesichts-Trackings verbessern.

Im Tracker-Fenster finden Sie zwei Optionen für das Gesichts-Tracking:

  • Gesichts-Tracking (nur Kontur): Verwenden Sie diese Option, wenn Sie lediglich die Kontur des Gesichts verfolgen möchten.
  • Gesichts-Tracking (detaillierte Merkmale): Verwenden Sie diese Option, wenn Sie die Position von Augen (einschließlich Augenbrauen und Pupillen), Nase und Mund verfolgen und optional Maße verschiedener Merkmale extrahieren möchten. Diese Option ist erforderlich, wenn Sie die Tracking-Daten in Character Animator verwenden möchten.

    Wenn Sie die Option „Detaillierte Merkmale“ verwenden, wird ein der Effekt „Gesichts-Track-Punkte“ auf die Ebene angewendet. Der Effekt enthält diverse 2D-Effektsteuerungspunkte mit Keyframes, die jeweils mit dem erkannten Gesichtsmerkmal verbunden werden (z. B. mit den Augen- und Mundwinkeln, der Position der Pupillen oder der Nasenspitze).

Verfolgen der Kontur eines Gesichts

  1. Wählen Sie in After Effects Datei> Importieren > Datei. Navigieren Sie zum Verzeichnis, in dem das Footage gespeichert ist, und fügen Sie es dem Projekt hinzu.

    Projektfenster

  2. Ziehen Sie das Footage aus dem Projektfenster in eine Komposition, um eine Ebene hinzuzufügen.

    Hinzufügen einer Ebene zu einer Komposition

  3. Positionieren Sie die Zeitmarke auf einem Frame, in dem eine Frontalansicht des zu verfolgenden Gesichts zu sehen ist.

    Hinweis:

    Die Gesichtserkennung funktioniert am besten, wenn der Ausgangsframe eine senkrecht ausgerichtete Frontalansicht eines Gesichts enthält.

    Gesichtserkennung

  4. Zeichnen Sie eine grobe geschlossene Maske um das Gesicht, die Augen und Mund enthält. Die Maske definiert die Suchregion für die Gesichtsmerkmale. Wenn mehrere Masken ausgewählt sind, wird die oberste Maske verwendet.

    Zeichnen einer Maske

  5. Wählen Sie bei ausgewählter Maske Fenster > Tracker, um das Tracker-Fenster zu öffnen. Wählen Sie als Tracking-Methode die Option Gesichts-Tracking (nur Kontur).

    Auswählen einer Tracking-Methode

  6. Führen Sie im Tracker-Fenster die Verfolgung jeweils um einen einzelnen Frame vorwärts oder rückwärts durch, um sicherzustellen, dass das Tracking ordnungsgemäß funktioniert, und klicken Sie dann auf die Schaltfläche , um mit der Analyse aller Frames zu beginnen.

  7. Nach Abschluss der Analyse stehen die Gesichts-Tracking-Daten innerhalb der Komposition zur Verfügung.

Verfolgen detaillierter Merkmale und Extrahieren von Gesichtsmaßen

  1. Wählen Sie in After Effects Datei> Importieren > Datei. Navigieren Sie zum Verzeichnis, in dem das Footage gespeichert ist, und fügen Sie es dem Projekt hinzu.

  2. Ziehen Sie das Footage aus dem Projektfenster in eine Komposition, um eine Ebene hinzuzufügen.

  3. Positionieren Sie die Zeitmarke auf einem Frame, in dem eine Frontalansicht des zu verfolgenden Gesichts zu sehen ist.

    Hinweis:

    Die Gesichtserkennung funktioniert am besten, wenn der Ausgangsframe eine senkrecht ausgerichtete Frontalansicht eines Gesichts enthält.

  4. Zeichnen Sie eine grobe geschlossene Maske um das Gesicht, die Augen und Mund enthält. Die Maske definiert die Suchregion für die Gesichtsmerkmale. Wenn mehrere Masken ausgewählt sind, wird die oberste Maske verwendet.

  5. Wählen Sie bei ausgewählter Maske Fenster > Tracker, um das Tracker-Fenster zu öffnen. Wählen Sie als Tracking-Methode die Option Gesichts-Tracking (detaillierte Merkmale).

  6. Führen Sie im Tracker-Fenster die Verfolgung jeweils um einen einzelnen Frame vorwärts oder rückwärts durch, um sicherzustellen, dass das Tracking ordnungsgemäß funktioniert, und klicken Sie dann auf die Schaltfläche , um mit der Analyse aller Frames zu beginnen.

  7. Nach Abschluss der Analyse stehen die Tracking-Daten im neuen Effekt Gesicht-Track-Punkte zur Verfügung. Sie können innerhalb der Komposition oder im Effektfenster (Fenster > Effektfenster) auf Gesichts-Tracking-Daten zugreifen.

    Steuerelemente für den Effekt „Gesichts-Track-Punkte“

  8. Verschieben Sie die Zeitmarke auf einen Frame mit einem neutralen Gesichtsausdruck (die Ruhepose). Gesichtmaße auf anderen Frames verhalten sich relativ zum Ruheposenframe. Klicken Sie im Tracker-Fenster auf Ruhepose festlegen.

  9. Klicken Sie im Tracker-Fenster auf Gesichtsmaße extrahieren und kopieren. Ein Effekt „Gesichtsmaße“ wird der Ebene hinzugefügt und die Keyframes werden basierend auf Berechnungen erstellt, die anhand der Keyframe-Daten unter „Gesichts-Track-Punkte“ durchgeführt wurden. Die Keyframe-Daten für „Gesichtsmaße“ werden zur Verwendung in Character Animator in die Zwischenablage des Systems kopiert.

    Hinweis:

    Die Keyframes für Gesichtsmaße werden auf Basis der Keyframe-Daten der Gesichts-Track-Punkte erstellt und verhalten sich relativ zur Ruhepose (siehe Schritt 8).

    Steuerelemente für den Effekt „Gesichtsmaße“

Informationen zu Gesichts-Track-Daten

Gesichts-Track-Punkte

Der Effekt „Gesichts-Tracker“ erstellt Effektsteuerungspunkte für mehrere Gesichtsmerkmale, die Sie im Zeitleistenfenster anzeigen können.

Gesichtsmaße

Wenn Sie die Option „Detaillierte Merkmale“ verwendet haben, können Sie noch weitere Informationen in Form von den parametrischen Messungen von Gesichtszügen extrahieren. Diese werden als Gesichtsmaße bezeichnet. Alle anzeigten Maße für das verfolgte Gesicht verhalten sich relativ zum Ruheposenframe.

Gesichtsversatz

Gibt die Position des Gesichts bei einem Versatzwert von 0 % im Ruheposenframe an. Die folgenden Datenpunkte stehen auf x-, y- und z-Achsen für Versatzwerte zur Verfügung:

  • Versatz X
  • Versatz Y
  • Versatz Z

Gesichtsausrichtung

Gibt dreidimensionale Ausrichtungen des Gesichts an. Die Ausrichtung wird mit den folgenden Datenpunkten gemessen, die für x-, y- und z-Achsen stehen:

  • Ausrichtung X
  • Ausrichtung Y
  • Ausrichtung Z

Linkes Auge

Gibt verschiedene Messpunkte für das linke Auge an und enthält die folgenden Datenpunkte:

  • Augenbrauenabstand links
  • Öffnung linkes Augenlid
  • Blickrichtung links X
  • Blickrichtung links Y

Rechtes Auge

Gibt verschiedene Messpunkte für das rechte Auge an und enthält die folgenden Datenpunkte:

  • Abstand rechte Augenbraue
  • Augenlid-Öffnung rechts
  • Blickrichtung rechts X
  • Blickrichtung rechts Y

Mund

Gibt verschiedene Messpunkte für den Mund an und enthält die folgenden Datenpunkte:

  • Mund-Versatz X
  • Mund-Versatz Y
  • Breite Mund-Skalierung
  • Höhe Mund-Skalierung
Adobe-Logo

Bei Ihrem Konto anmelden