Ein Skript besteht aus mehreren Befehlen, die nacheinander ausgeführt werden, um verschiedene Arbeitsschritte auszuführen. In den meisten Adobe-Anwendungen können Sie Skripte verwenden, um sich wiederholende Aufgaben zu automatisieren, komplexe Berechnungen durchzuführen und sogar, um Funktionen zu nutzen, die nicht direkt in der grafischen Benutzeroberfläche zur Verfügung stehen. Sie können After Effects z. B. anweisen, die Ebenen in einer Komposition neu anzuordnen, in Textebenen nach Quelltext zu suchen und diesen zu ersetzen oder eine E-Mail zu versenden, sobald das Rendern abgeschlossen ist.

In den Skripts von After Effects wird die Sprache Adobe ExtendScript verwendet, bei der es sich um eine erweiterte Form von JavaScript handelt. ExtendScript-Dateien haben die Dateinamenerweiterung .jsx oder .jsxbin.

Eine Beschreibung der verfügbaren Skriptfunktionen mit After Effects finden Sie im After Effects Scripting Guide (Handbuch für Skriptprogrammierung) im After Effects Developer Center.

Skripte laden und ausführen

Beim Start von After Effects werden Skripte aus dem Ordner „Scripts“ geladen. Standardmäßig befindet sich der Ordner „Skripts“ in After Effects in folgendem Verzeichnis:

  • (Windows) Programme\Adobe\Adobe After Effects <version>\Support Files

  • (Mac OS) /Programme/Adobe After Effects <version>

Skripts werden ab After Effects CC 12.1 auch an Benutzerpfaden installiert.

Im Lieferumfang von After Effects sind mehrere Skripte enthalten, die automatisch im Ordner „Scripts“ installiert werden.

Geladene Skripte stehen im Menü „Datei“ (Windows) bzw. „Ablage“ (Mac OS) > „Skripten“ zur Verfügung. Wenn Sie ein Skript bearbeiten und After Effects dabei gerade ausgeführt wird, müssen Sie die Änderungen speichern, damit sie wirksam werden. Wenn Sie ein Skript im Ordner „Scripts“ ablegen und After Effects dabei ausgeführt wird, wird das Skript erst nach einem Neustart von After Effects im Menü „Skripten“ angezeigt. Sie können das neue Skript jedoch sofort ausführen, wenn Sie den Befehl „Skriptdatei ausführen“ verwenden.

Skripte im ScriptUI Panels-Ordner stehen am unteren Rand des Menüs „Fenster“ zur Verfügung. Wenn ein Skript geschrieben wurde, um eine Benutzeroberfläche in einem andockbaren Fensterbereich bereitzustellen, sollte das Skript im ScriptUI-Ordner abgelegt werden. ScriptUI-Bereiche funktionieren praktisch genauso wie die Standardfensterbereiche der After Effects-Benutzeroberfläche.

Hinweis:

Standardmäßig können Skripte keine Dateien schreiben oder Kommunikation über ein Netzwerk senden oder empfangen. Wenn Sie mit Skripten Dateien schreiben oder die Kommunikation über ein Netzwerk aktivieren möchten, wählen Sie „Bearbeiten“ > „Voreinstellungen“ > „Allgemein“ (Windows) bzw. „After Effects“ > „Einstellungen“ > „Allgemein“ (Mac OS) und aktivieren Sie die Option „Skripten können Dateien schreiben und haben Netzwerkzugang“.

  • Um ein geladenes Skript auszuführen, wählen Sie „Datei“ (Windows) bzw. „Ablage“ (Mac OS) > „Skripten“ > [Skriptname].

  • Wenn Sie ein Skript ausführen möchten, das nicht geladen wurde, wählen Sie „Datei“ (Windows) bzw. „Ablage“ (Mac OS) > „Skripte“ > „Skriptdatei ausführen“, suchen Sie das Skript und klicken Sie auf „Öffnen“.

  • Drücken Sie „Esc“, um ein ausgeführtes Skript anzuhalten.

  • Wenn Sie ein Skript über die Befehlszeile ausführen möchten, geben Sie „afterfx.exe“ in die Befehlszeile ein. Geben Sie bei der Ausführung -r und den vollständigen Pfad des Skripts als Argumente an. Dadurch wird keine neue Instanz von After Effects geöffnet, sondern das Skript wird in der vorhandenen Instanz ausgeführt.

    Beispiel (für Windows):

    afterfx -r c:\script_path\example_script.jsx

Hinweis:

Mit dieser Befehlszeilentechnik und der im Lieferumfang anpassbarer Tastaturen enthaltenen Software können Sie zum Aufrufen eines Skripts einen Tastaturbefehl festlegen.

Sie können die Liste der zehn zuletzt in After Effects ausgeführten Skripten anzeigen. Um die Liste anzuzeigen, wählen Sie Datei > Skripten > Letzte Skriptdateien.

Um eines der zehn zuletzt ausgeführten Skripts erneut auszuführen, drücken Sie Befehls- + Wahl- + Umschalttaste + D (Mac OS) bzw. Strg- + Alt- + Umschalttaste + D (Win).

Jeff Almasol bietet ein Skript an, das ein einfaches Konsolenfenster erstellt. Das Konsolenfenster enthält einen Textbereich, in dem Sie ExtendScript-Befehle zur Bewertung eingeben können. Es gibt keine Fehlererfassung oder Meldungen. Diese Konsole stellt lediglich einen einfachen Weg dar, Befehle einzugeben, ohne zuerst ein Skript erstellen zu müssen. Informationen dazu finden Sie auf Jeff Almasols Redefinery-Website.

Hinweis:

Auf der AE-Skripts-Website gibt Lloyd Alvarez einen Tipp zum Ausführen von .jsxbin-Skripts, wenn Sie keinen Zugang zum Ordner „Skripts“ bzw. „ScriptUI Panels“ haben.

In After Effects bereitgestellte Skripte

After Effects bietet mehrere bereits programmierte Skripte, die Ihnen bei der Durchführung gängiger Aufgaben helfen und die Basis für die Änderung und Erstellung von eigenen Skripten bieten.

Hinweis:

Führen Sie das Beispielskript „Demo Palette.jsx“ aus, um zu sehen, was Sie mit Skripten alles erreichen können.

Skripte schreiben und ändern

Mit dem Skripteditor, der Bestandteil des Toolkits „ExtendScript“ ist, können Sie eigene Skripte für die Verwendung in After Effects schreiben. Das Toolkit „ExtendScript“ bietet eine benutzerfreundliche Oberfläche zum Erstellen, Debuggen und Testen Ihrer eigenen Skripte. Manchmal ist nur eine geringfügige Änderung an einem vorhandenen Skript notwendig, um ein Skript für die von Ihnen gewünschte Funktion zu erstellen. Solche geringfügige Änderungen können oft auch mit nur wenigen Kenntnissen in Computerprogrammierung oder Skriptsprachen ausgeführt werden.

Weitere Informationen finden Sie im After Effects-Handbuch für Skriptprogrammierung.

Zum Öffnen des Skripteditors wählen Sie „Datei“ (Windows) bzw. „Ablage“ (Mac OS) > „Skripten“ > „Skripteditor öffnen“.

Ein Lehrgang im AE Enhancers Forum führt den Leser schrittweise durch die Erstellung eines Skripts.

Jeff Almasol bietet eine Reihe von Dienstprogrammen zur Skripterstellung sowie weitere nützliche Funktionen, die Sie beim Erstellen eigener Skripte unterstützen, auf seiner Redefinery-Website an.

David Torno stellt eine Liste von passenden Namen für After Effects-Skripts bereit.

Skriptzugriff

Skriptzugriff für Animationsvorlagen

Mit Skripten lassen sich Eigenschaften zum Bedienfeld „Essential Graphics“ hinzufügen und Animationsvorlagen exportieren. Dazu können folgende Skripterstellungsmethoden verwendet werden:

  • canAddToMotionGraphicsTemplate()-Methode für Eigenschaft app.project.item(index).layer(index).propertySpec.canAddToMotionGraphicsTemplate(comp) Testet, ob die Eigenschaft zum Bedienfeld „Essential Graphics“ für die angegebene Komposition hinzugefügt werden kann. Gibt den Wert „true“ zurück, wenn die Eigenschaft hinzugefügt werden kann, andernfalls wird der Wert „false“ zurückgegeben. Wenn die Eigenschaft nicht hinzugefügt werden kann, wird entweder ihr Eigenschaftstyp nicht unterstützt oder die Eigenschaft wurde bereits zu dieser Komposition hinzugefügt. After Effects zeigt eine Warnung an. 

Folgende Eigenschaftstypen werden unterstützt:

  • Kontrollkästchen
  • Farbe
  • Numerischer Regler (d. h. eine numerische Eigenschaft mit einem einzelnen Wert, z. B. „Transformieren“ > „Deckkraft“ oder der Effekt „Schieberegler“ unter „Einstellungen für Expressions“)
  • Quelltext

Parameter:

Komposition Die Komposition, für die Sie testweise die Eigenschaft compItem hinzufügen möchten.

Rückgabe:

Boolescher Wert.

  • addToMotionGraphicsTemplate()-Methode für Eigenschaft app.project.item(index).layer(index).propertySpec.addToMotionGraphicsTemplate(comp) Fügt die Eigenschaft zum Bedienfeld „Essential Graphics“ für die angegebene Komposition hinzu. Gibt den Wert „true“ zurück, wenn die Eigenschaft erfolgreich hinzugefügt wurde, andernfalls wird der Wert „false“ zurückgegeben. Wenn die Eigenschaft nicht hinzugefügt wurde, wird entweder ihr Eigenschaftstyp nicht unterstützt oder die Eigenschaft wurde bereits zu dieser Komposition hinzugefügt. After Effects zeigt eine Warnmeldung an. Nutzen Sie die Methode canAddToMotionGraphicsTemplate() zur Überprüfung, ob die Eigenschaft zu einer Animationsvorlage hinzugefügt werden kann.

Parameter:

Komposition Die Komposition, für die Sie testweise die Eigenschaft compItem hinzufügen möchten.

Rückgabe:

Boolescher Wert.

  • motionGraphicsTemplateName-Attribut für CompItem app.project.item(index).motionGraphicsTemplateName Liest oder schreibt die Namenseigenschaft in das Bedienfeld „Essential Graphics“ für die Komposition. Der Name im Bedienfeld „Essential Graphics“ wird als Dateiname für eine exportierte Animationsvorlage verwendet, beispielsweise „Meine Vorlage.mogrt“. Im folgenden Beispiel wird der Name für die aktive Komposition festgelegt und dann als Warnung zurückgegeben: 

app.project.activeItem.motionGraphicsTemplateName = "Meine Vorlage";
alert(app.project.activeItem.motionGraphicsTemplateName);

Typ:

Zeichenfolge. Lesen/Schreiben.

  • exportAsMotionGraphicsTemplate()-Methode für CompItem app.project.item(index).exportAsMotionGraphicsTemplate(doOverWriteFileIfExisting, file_path) Exportiert die Komposition als Animationsvorlage. Gibt den Wert „true“ zurück, wenn die Animationsvorlage erfolgreich exportiert wurde, andernfalls wird der Wert „false“ zurückgegeben. Der Name im Bedienfeld „Essential Graphics“ wird als Dateiname der Animationsvorlage verwendet, beispielsweise „Meine Vorlage.mogrt“. Verwenden Sie das Attribut motionGraphicsTemplateName zum Festlegen des Namens. Geben Sie optional den Pfad zu dem Ordner an, in dem die Animationsvorlage gespeichert ist. Wenn nicht angegeben, wird die Datei im aktuellen Essential Graphics-Ordner des Benutzers gespeichert:

Mac OS:

/Benutzer//Library/Application Support/Adobe/Common/Essential Graphics/

Windows:

C:\Benutzer\AppData\Roaming\Adobe\Common\Essential Graphics\

Wenn das Projekt nach dem letzten Speichern geändert wird, fordert After Effects den Benutzer auf, das Projekt zu speichern. Um das zu verhindern, nutzen Sie die save()-Methode für das Projekt, bevor Sie die Animationsvorlage exportieren.

Parameter:

doOverWriteFileIfExisting Legt fest, ob eine vorhandene Datei mit demselben Namen überschrieben werden soll. Boolescher Wert, erforderlich.
file_path Pfad zu dem Ordner, in dem die Datei gespeichert wird. Optional.

Rückgabe:

Boolescher Wert.

  • openInEssentialGraphics()-Methode für CompItem app.project.item(index).openInEssentialGraphics() Öffnet die Komposition im Bedienfeld „Essential Graphics“.

Parameter:

Ohne

Rückgabe:

Ohne

Weitere nützliche Skripte

Skripts, Projekte und andere nützliche Elemente finden Sie auf der Website Adobe Add-ons.

Dan Ebberts bietet im Skript-Abschnitt seiner Motionscript-Website Lehrgänge zur Skripterstellung und nützliche Skripte an.

Lloyd Alvarez bietet auf seiner After Effects Scripts-Website eine Sammlung nützlicher Skripte an.

Das AE Enhancers Forum enthält Beispielskripte und nützliche Informationen zur Skripterstellung (sowie Expressions und Animationsvorgaben) in After Effects.

Jeff Almasol stellt auf seiner Redefinery-Website eine Reihe nützlicher Skripte zur Verfügung.

Dale Bradshaw bietet Skripte und Tricks auf seiner Creative Workflow Hacks-Website an.

Auf der nabscripts-Website werden viele nützliche Skripte bereitgestellt.

Christopher Green stellt auf seiner Website viele nützliche Skripte bereit.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie