Premiere Pro 中的蒙版

在 Premiere Pro 中,可直接使用 After Effects 功能强大的蒙版与跟踪工作流。

蒙版使您能够在剪辑中定义要模糊、覆盖、高光显示、应用效果或校正颜色的特定区域。

您可以创建和修改不同形状的蒙版,如椭圆形或矩形。或者,您可以使用钢笔工具绘制自由形式的贝塞尔曲线形状。

Premiere Pro 中的蒙版

A. 椭圆形工具 B. 矩形工具 C. 钢笔工具 

您可以在蒙版区域内外应用效果。蒙版的常见用法之一是用于模糊人物的脸部以保护其身份。例如,通过应用模糊效果或马赛克效果可以遮挡人物的脸部。

还能以更具创意的方式使用蒙版功能,例如,应用蒙版以校正特定颜色。可使用反转蒙版选区,将蒙版区域排除在剪辑其余部分所应用的颜色校正之外。此外,还可向剪辑的不同区域添加带有不同效果的多种形状蒙版。

使用形状工具创建蒙版

Premiere Pro 为您提供两种形状工具:创建圆形或椭圆形蒙版的椭圆形工具 ,以及创建四方多边形的矩形工具

 

  1. 在时间轴中,选择包含蒙版区域的剪辑。

  2. “效果”面板中,选择要应用于蒙版区域的效果。

    例如,如要应用“马赛克”效果,请依次选择“视频效果”>“风格化”>“马赛克”

  3. 通过将“效果”面板中的效果图标拖动到“时间轴”面板中的剪辑上,将所选的效果应用至剪辑。或者,先选择剪辑,然后在“效果”面板中双击某个效果以应用该效果。

    注意:

    通过每次使用不同设置,可以多次应用同一效果。

    有关应用效果的更多信息,请参阅向剪辑应用效果

  4. 单击椭圆形工具 可创建一个椭圆形蒙版,或者单击矩形工具 可创建一个矩形蒙版。

    剪辑中出现的形状蒙版显示在节目监视器中,效果则被限制在蒙版区域内。

重要说明

  • Premiere Pro 不会将蒙版保存为效果预设。
  • 变形稳定器效果禁用蒙版。在效果控件面板中,变形稳定器效果不会显示蒙版形状控件。

使用钢笔工具创建自由形式形状

钢笔工具 使您可以围绕目标自由绘制复杂蒙版形状。

单击钢笔工具开始绘制蒙版。您可以通过绘制直线和曲线段来创建不同形状。要绘制平滑曲线,可以绘制贝塞尔曲线路径段,为您提供对蒙版形状的更大控制力度。

用钢笔工具绘制直线路径段

使用钢笔工具可绘制的最简单的路径是具有两个顶点的直线。通过连续单击,可以创建由通过顶点连接的直线段组成的路径。

使用钢笔工具
使用钢笔工具单击可创建直线段

  1. 选择钢笔工具。

  2. 将钢笔工具放在直线段的开始位置,然后单击来定义第一个顶点(不要拖动)。

    注意:

    绘制的第一段要到单击第二个顶点时才能看见。

  3. 在希望线段结束的位置再次单击(按住 Shift 键并单击将线段的角度限制为 45° 的倍数)。

  4. 继续单击为其他直线段设置顶点。

  5. 要闭合路径,请将钢笔工具置于第一个顶点上。如果放置的位置正确,钢笔工具指针 旁将出现一个小圆圈。单击或拖动可闭合路径。

使用钢笔工具
绘制贝塞尔曲线路径段

使用钢笔工具,通过拖动方向线可创建曲线路径段。方向线的长度和方向决定了曲线的形状。

要创建贝塞尔曲线形状,可将光标置于顶点上,同时按 Alt 键,将蒙版上的顶点转换为贝塞尔曲线顶点。此时光标将变为一个反向“V”字形 。然后,单击并松开指针。

贝塞尔曲线手柄提供两个方向的控件,用于更改手柄和任一侧下一个点之间的线段的曲度。

贝塞尔手柄
A. 两个方向贝塞尔曲线手柄可控制曲线形状 B. 贝塞尔曲线蒙版点 
  1. 将钢笔工具放置在您希望开始曲线的位置,然后按下鼠标按键。将出现一个顶点,并且钢笔工具指针将变为一个箭头。

  2. 拖动以修改顶点的两条方向线的长度和方向,然后释放鼠标按钮。

    绘制曲线路径中的第一个顶点
    绘制曲线路径中的第一个顶点

    A. 放置钢笔工具 B. 开始拖动(鼠标按钮按下) C. 拖动以延长方向线 
  3. 将钢笔工具放置到希望曲线段结束的位置,然后执行以下任一操作:

    • 要创建 C 形曲线,请沿与您拖动前一方向线的方向相反的方向进行拖动,然后释放鼠标按键。
    绘制曲线路径中的第二个顶点
    绘制曲线路径中的第二个顶点

    A. 开始拖动 B. 向远离前一条方向线的方向拖动,创建 C 形曲线 C. 松开鼠标按钮后的结果 
    • 要创建 S 形曲线,请按照与前一条方向线相同的方向拖动,然后松开鼠标按键。
    绘制 S 曲线
    绘制 S 曲线

    A. 开始拖动 B. 按照与前一条方向线相同的方向拖动,创建 S 形曲线 C. 松开鼠标按钮后的结果 
  4. 继续从不同的位置拖动钢笔工具以创建一系列平滑曲线。

修改和移动蒙版

蒙版上的顶点使您能够轻松管理蒙版的形状、大小和旋转。

调整蒙版形状
A、B、C、D:调整蒙版形状、大小和旋转的顶点

修改蒙版的形状、大小和旋转

  • 要更改蒙版的形状,请拖动蒙版手柄。
  • 要将椭圆蒙版的形状更改为多边形,请按住 Alt 键并单击椭圆的任一顶点。
  • 要调整蒙版大小,只需将光标置于顶点之外并按 Shift 键(光标将变为一个双向箭头 ),然后在按住 Shift 键时拖动光标。
  • 要旋转蒙版,只需将光标置于顶点之外(光标将变为一个弯曲的双向箭头 ),然后拖动即可。按住 Shift 键的同时拖动光标,可以 22.5 度为单位进行旋转。

移动、添加或移除顶点

  • 要移动顶点,请使用选择工具拖动顶点。请注意,拖动椭圆形状的蒙版时,椭圆形状不会保持。
  • 要添加顶点,可将光标置于蒙版边缘处,同时按 Ctrl 键 (Win) 或 Cmd 键 (Mac)。光标会变成带“+”号的钢笔形状。单击可向蒙版形状添加顶点。
  • 要移除顶点,可将光标置于要移除的点处,同时按 Ctrl 键 (Win) 或 Cmd 键 (Mac)。光标会变成带“-”号的钢笔形状。单击可移除蒙版形状中选定的顶点。

其他重要命令和键盘快捷键

  • 使用键盘上的箭头键将所选控制点微移一个距离单位。
  • 按 Shift 键并使用箭头键将所选控制点微移五个距离单位。
  • 要取消选择所有选定的控制点,请在当前活动的蒙版外单击。
  • 要禁用蒙版的直接操纵功能,请在蒙版外单击。或者,在序列中取消选择该剪辑。
  • 要删除蒙版,请在“效果控件”面板中选择蒙版并按键盘上的 Delete 键。

羽化蒙版边缘或调整蒙版扩展

Premiere Pro 提供一些控件,用于直接在节目监视器上调整蒙版羽化和扩展。

蒙版位置手柄使您能够沿蒙版轮廓一齐移动羽化和扩展手柄。使用蒙版位置手柄,可以将羽化和扩展控件放在蒙版上的方便位置。

羽化蒙版
A. 可控制羽化的羽化手柄 B. 可扩展和收缩蒙版的扩展手柄 C. 可移动控件的蒙版位置手柄 D. 扩展导线 E. 羽化导线 

应用蒙版羽化

羽化蒙版边缘
A. 不使用羽化 B. 使用羽化 

可通过应用羽化使蒙版的边缘变得平滑。羽化可柔化蒙版选区边界,使其混合到选区外的区域,并提供一个美观的效果。

蒙版羽化手柄可让您直接在节目监视器的蒙版轮廓上控制羽化量。Premiere Pro 会显示蒙版轮廓周围的羽化引导线。羽化引导线显示为一条虚线。

也可以在“效果控件”面板中指定一个蒙版羽化值。

将手柄拖离羽化引导线可增加羽化,拖向羽化引导线可减少羽化。

调整蒙版扩展

蒙版扩展使您能够扩展或收缩蒙版区域。蒙版扩展导线在节目监视器上显示为实心蓝线,可帮助您精确扩展或收缩蒙版区域。

将手柄拖离扩展引导线可扩展蒙版区域,拖向扩展引导线可收缩蒙版区域。

您也可以在“效果控件”面板中指定一个蒙版扩展值来将蒙版的边界内移或外移。正值将边界外移,负值将边界内移。

使用“效果控件”面板调整蒙版设置

您可以使用“效果控件”面板指定值来调整蒙版。您可跟踪蒙版、更改不透明度、扩展蒙版、反转蒙版或羽化蒙版边缘。

调整蒙版设置
A. 跟踪蒙版 B. 反转已蒙版和未蒙版的区域 C. 更改蒙版扩展 D. 调整蒙版不透明度 E. 羽化蒙版边缘 

调整蒙版不透明度

要调整蒙版的不透明度,请指定“蒙版不透明度”值。使用滑块可控制蒙版不透明度。当值等于 100 时,蒙版完全不透明并会遮挡图层中位于其下方的区域。不透明度越小,蒙版下方的区域就越清晰可见。

反转蒙版选区

选择“反转”复选框,可交换蒙版区域和未蒙版区域。如要将某个区域保持原样,您可将该区域蒙版,然后选择“反转”复选框将效果应用到未蒙版区域。

使用“反转蒙版选区”将 Lumetri Look 应用至未蒙版的区域
使用“反转蒙版选区”将 Lumetri Look 应用至未蒙版的区域

复制和粘贴蒙版

您可在剪辑或效果之间轻松复制和粘贴蒙版。

在剪辑之间复制和粘贴带蒙版的效果

复制和粘贴含有蒙版的效果时,粘贴后的效果将包含同样的蒙版。

  1. 在“时间轴”面板中,选择内含带有蒙版的效果的剪辑。
  2. “效果控件”面板中,选择要复制的效果。
  3. 选择“编辑”>“复制”。或者使用键盘快捷键 Ctrl+C (Windows) 或 Cmd+C (Mac OS)。
  4. 在时间轴中选择要将蒙版粘贴到其中的另一个剪辑。
  5. 选择“编辑”>“粘贴”。或者使用键盘快捷键 Ctrl+V (Windows) 或 Cmd+V (Mac OS)。

 

在效果之间复制和粘贴蒙版

  1. “效果控件”面板中,单击三角形展开相应效果以显示已应用的面板。
  2. 选择要复制的蒙版。
  3. 选择“编辑”>“复制”。或者使用键盘快捷键 Ctrl+C (Windows) 或 Cmd+C (Mac OS)。
  4. 在“效果控件”中选择要将蒙版粘贴到其中的另一个效果。
  5. 选择“编辑”>“粘贴”。或者使用键盘快捷键 Ctrl+V (Windows) 或 Cmd+V (Mac OS)。

注意:

一次只能复制和粘贴一个蒙版。

Premiere Pro 中的蒙版追踪

将蒙版应用到对象后,Premiere Pro 会让蒙版自动跟随对象,可跟随对象从一帧移动到另一帧。例如,在使用某个蒙版形状模糊脸部之后,Premiere Pro 可自动跟踪人物移动时各帧之间出现的蒙版面部的位置变化。

选择某个蒙版后,“效果控件”面板会显示用于向前或向后跟踪蒙版的控件。跟踪蒙版时,既可选择一次跟踪一帧,也可选择一直跟踪到序列结束。

单击扳手图标 可修改跟踪蒙版的方式。可酌情选择以下选项以提供最有效的跟踪:

位置

只跟踪从帧到帧的蒙版位置

位置和旋转

在跟踪蒙版位置的同时,根据各帧的需要更改旋转情况

位置、缩放和旋转

跟踪蒙版位置的同时,随着帧的移动而自动缩放和旋转

注意:

可通过试验,选择最适合具体剪辑的选项。选择以下选项之一,如果效果不好,则取消并尝试其他选项。

要使用 After Effects 中提供的更加高级的跟踪功能,请使用 Dynamic Link 功能将您的序列发送至 After Effects。有关更多信息,请参阅 After Effects 中的蒙版跟踪

视频教程

如何使用蒙版和跟踪模糊移动的脸

这个 5 分钟的视频教程介绍了如何应用羽化蒙版来保护个人身份,以及如何在场景中实现对于蒙版的跨帧跟踪。

教程中为您提供了样本文件,您可在这些样本文件中尝试自行使用此功能。


本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略