Vytváření a zpracování sad obrázků

Naposledy aktualizováno 29. 10. 2026

Pomocí funkce Smart Objects zkombinujte více obrázků a snižte šum nebo odstraňte nežádoucí objekty v aplikaci Adobe Photoshop pro počítače.

Sady obrázků umožňují přesně řídit způsob, jakým se více expozic spojí do jednoho vylepšeného výsledku.

Sada obrázků spojuje více obrázků s podobnou kompozicí, ale různými vlastnostmi, do jednoho objektu Smart Object. Poté můžete použít možnosti zpracování režimů sady, které analyzují odpovídající pixely ve všech vrstvách a vytvoří kompozici, která eliminuje šum, zkreslení nebo nežádoucí objekty. Sady obrázků fungují nejlépe s obrázky stejných rozměrů pořízenými z pevného místa snímání, jako jsou statické fotografie ze stativu nebo snímky ze stacionární videokamery.

Sady obrázků můžete vytvořit manuálně a získat tak plnou kontrolu nad zarovnáním vrstev a výběrem režimu, nebo použít skript Statistics k automatizaci celého pracovního postupu.

Sloučit obrázky do jednoho vícevrstvého dokumentu

Vyberte Soubor > Skripty > Načíst soubory do sady, nebo zkopírujte každý obrázek manuálně jako novou vrstvu.

Pokud je součástí vrstva Pozadí, převeďte ji na běžnou vrstvu kliknutím pravým tlačítkem a výběrem možnosti Vrstva z pozadí.

Vyberte Výběr > Všechny vrstvy a vyberte tak všechny vrstvy v dokumentu.

Vyberte Úpravy > Automaticky zarovnat vrstvy, poté jako možnost zarovnání vyberte Automaticky a klikněte na OK.

Se všemi stále vybranými vrstvami vyberte Vrstva > Smart Objects > Převést na Smart Object.

Vyberte Vrstva > Smart Objects > Režim sady a zvolte vykreslovací režim, například Průměr pro snížení šumu nebo Medián pro odstranění objektů.

Vykreslování v režimu sady je nedestruktivní. Režimy můžete kdykoli změnit, abyste dosáhli různých efektů a zároveň zachovali původní obrazová data. Mezi běžná použití patří snížení šumu u forenzních, lékařských nebo astrofotografických obrázků a odstranění přechodných elementů, jako jsou chodci nebo vozidla, z architektonické fotografie. Vykreslená kompozice se zobrazí okamžitě.

Vytvoření a vykreslení sady pomocí Skriptu Statistics

Vyberte Soubor > Skripty > Statistics.

Vyberte režim sady z nabídky Choose Stack Mode a potom zadejte zdrojové obrázky výběrem možnosti Procházet pro výběr souborů nebo složky.

Pokud vaše obrázky potřebují registraci, vyberte možnost Pokusit se automaticky zarovnat zdrojové obrázky.

Vyberte možnost OK. Photoshop zkombinuje obrázky do objektu Smart Object a automaticky použije vybraný režim sady.

Skript Statistics dokončí celý pracovní postup vytvoření a vykreslení zásobníku v jediné operaci.

Úprava obsahu zásobníku obrázků

Vyberte vrstvu Smart Object obsahující zásobník a poté vyberte Vrstva > Smart Objects > Upravit obsah.

Proveďte změny v jednotlivých vrstvách dokumentu zásobníku a poté soubor uložte a zavřete, aby se aktualizoval vykreslený kompozit.

Odstranění vykreslení balíčku

Vyberte vrstvu Smart Object a poté vyberte Vrstva > Smart objekty > Režim zásobníku > Žádný.

Odstraněním režimu zásobníku zůstane Smart Object nedotčený, ale vykreslování kompozitu se vypne a zobrazí se pouze horní vrstva.

Převod zásobníku na běžnou vrstvu

Vyberte Vrstva > Smart objekty > Rastrovat a trvale použijte aktuální vykreslení zásobníku a převeďte Smart Object na standardní vrstvu.

Před rastrováním duplikujte vrstvu Smart Object, abyste si zachovali možnost zásobník později znovu vykreslit s jinými režimy.