Maskování efektů inteligentního filtru

Naposledy aktualizováno 29. 10. 2026

Naučte se malovat černou, bílou nebo šedou barvou a selektivně skrývat nebo odhalovat efekty filtrů použité u inteligentních objektů v aplikaci Adobe Photoshop pro počítače.

Masky filtrů vám umožňují přesně řídit, kde se v obrázku zobrazí efekty Inteligentní filtr, takže můžete provádět selektivní přizpůsobení bez trvalé změny původního obsahu.

Když použijete Inteligentní filtr na inteligentní objekt, aplikace Photoshop automaticky vytvoří miniaturu masky filtru na řádku Inteligentní filtry na panelu Vrstvy. Tato maska řídí viditelnost všech inteligentních filtrů použitých u tohoto inteligentního objektu. Jednotlivé inteligentní filtry nemůžete maskovat samostatně. Masky filtrů používají stejné principy jako masky vrstev: bílé oblasti odhalují efekty filtrů, černé oblasti je skrývají a šedé oblasti vytvářejí částečnou průhlednost pro plynulé prolnutí.

Masky filtrů bez problémů fungují se standardními nástroji pro malování a úpravy, takže můžete efekty filtrů dolaďovat se stejnou přesností jako u ostatních úloh maskování. Hustotu masky a prolnutí okrajů můžete upravit na panelu Vlastnosti a masky filtrů se ukládají jako alfa kanály na panelu Kanály pro pokročilé pracovní postupy výběrů.

Malování do masky filtru ke skrytí nebo odhalení efektů

Výběrem miniatury masky filtru na panelu Vrstvy pod vrstvou inteligentního objektu ji aktivujte.

Vyberte nástroj Štětec nebo jiný nástroj pro malování.

Malujte do masky černou barvou, pokud chcete v těchto oblastech skrýt efekty filtru, bílou barvou, pokud je chcete odhalit, a odstíny šedé, pokud chcete vytvořit částečnou průhlednost – tmavší odstíny šedé skryjí větší část efektu, světlejší odstíny šedé odhalí větší část.

Přímo na masky filtrů můžete také použít přizpůsobení obrazu a filtry a vytvářet tak kreativní efekty maskování.

Úprava hustoty masky filtru a prolnutí okrajů

Vyberte miniaturu masky filtru na panelu Vrstvy nebo vrstvu inteligentního objektu a potom na panelu Vlastnosti vyberte možnost Maska filtru.

Na panelu Vlastnosti přetažením posuvníku Hustota upravte krytí masky a posuvníku Prolnutí okrajů změkčete okraje masky, aby přechody byly plynulejší.

Možnost Okraj masky (pracovní plocha Vybrat a maskovat) není pro masky filtrů k dispozici.Místo toho použijte ovládací prvky pro prolnutí okrajů a hustotu.

Převrácení, zobrazení nebo změna polohy masek filtrů

Výběrem miniatury masky filtru na panelu Vrstvy ji aktivujte.

Pokud chcete masku invertovat, vyberte na panelu Vlastnosti možnost Invertovat nebo zvolte Obraz > Přizpůsobení > Invertovat.

Pokud chcete zobrazit jen masku ve stupních šedi, stiskněte klávesu Alt a klikněte (Windows) nebo stiskněte klávesu Option a klikněte (macOS) na miniaturu masky filtru. Opakováním se vrátíte do normálního zobrazení.

Chcete-li přesunout masku na jiný efekt Inteligentní filtr ve stejném inteligentním objektu, přetáhněte miniaturu masky filtru na cílový řádek Inteligentní filtr.

Chcete-li masku zkopírovat, přetáhněte miniaturu masky filtru na jiný řádek Inteligentní filtr se stisknutou klávesou Alt (Windows) nebo Option (macOS).

Zakázání, povolení nebo odstranění masky filtru

Vyberte miniaturu masky filtru v panelu Vrstvy.

Chcete-li masku dočasně zakázat, stiskněte klávesu Shift a klikněte na miniaturu masky filtru, nebo vyberte tlačítko Zakázat/povolit masku v panelu Vlastnosti, případně zvolte Vrstva > Inteligentní filtry > Zakázat masku filtru. Po zakázání se na miniatuře zobrazí červené X.

Chcete-li znovu povolit zakázanou masku, znovu stiskněte klávesu Shift a klikněte na miniaturu masky filtru, nebo použijte přepínač v panelu Vlastnosti.

Chcete-li masku odstranit trvale, přetáhněte miniaturu masky filtru na ikonu Odstranit v panelu Vrstvy, nebo ji vyberte a následně vyberte ikonu Odstranit v panelu Vlastnosti. Můžete také zvolit Vrstva > Inteligentní filtry > Odstranit masku filtru.

Přidat novou masku filtru

Pokud jste masku filtru odstranili nebo ji potřebujete vytvořit ručně, můžete masku přidat kdykoli.

Vyberte vrstvu Smart Object obsahující Smart Filters.

Chcete-li přidat prázdnou bílou masku, která zobrazí všechny efekty, vyberte v panelu Vlastnosti možnost Maska filtru.

Chcete-li přidat masku na základě výběru, nejprve vytvořte výběr, poté klikněte (Windows), nebo klikněte se stisknutou klávesou Control (macOS) na řádek Inteligentní filtry v panelu Vrstvy a zvolte možnost Přidat masku filtru.

Po přidání nové masky ji můžete upravit pomocí libovolné z technik popsaných v tomto článku, včetně malování, přizpůsobení nebo úpravy.