Vytváření a správa kompozic vrstev

Naposledy aktualizováno 29. 10. 2026

Zachyťte více variací návrhu v jednom souboru pomocí snímků viditelnosti, pozice a vzhledu vrstev.

Kompozice vrstev vám umožňují prezentovat klientům více variací návrhu bez vytváření samostatných souborů pro každou verzi.

Kompozice vrstev je snímek panelu Layers v určitém okamžiku.Kompozice vrstev použijte, když potřebujete v jednom dokumentu zobrazit různé možnosti rozvržení, barevná schémata nebo uspořádání obsahu. Každá kompozice může zaznamenat viditelnost vrstvy (zobrazení nebo skrytí vrstev), pozici vrstvy, vzhled vrstvy (styly a režimy prolnutí) a výběry kompozic vrstev Smart Object.Kompozice vrstev fungují nejlépe při zkoumání alternativ návrhu před dokončením kompozice.

Vytvořit novou kompozici vrstev

Výběrem možnosti Window > Layer Comps otevřete panel Layer Comps.

Uspořádejte vrstvy tak, aby odpovídaly stavu návrhu, který chcete zachytit.

V dolní části panelu Layer Comps vyberte tlačítko Create New Layer Comp.

V dialogovém okně New Layer Comp zadejte popisný název a volitelné poznámky.

Vyberte, které vlastnosti vrstvy chcete zaznamenat: Viditelnost, Pozice, Vzhled (Styl vrstvy) nebo Výběr kompozice vrstvy pro Smart Objects.

Vyberte možnost OK.

Vybrané možnosti se stanou výchozím nastavením pro budoucí kompozice vrstev.

Tip

Zduplikujte existující kompozici jejím přetažením na možnost Create New Layer Comp v panelu Layer Comps.

Aplikování a prohlížení kompozic vrstev

Panel Layer Comps otevřete výběrem možnosti Window > Layer Comps.

Z kontextové nabídky Layer Comps vyberte možnost Apply Layer Comp.

Pomocí ovládacích prvků Previous a Next ve spodní části panelu můžete procházet všechny nebo konkrétní kompozice.

Výběrem možnosti Apply Layer Comp obnovte dokument.

Aktualizace kompozice vrstvy

V panelu Layer Comps vyberte kompozici vrstvy, kterou chcete aktualizovat.

Na panelu Layers proveďte změny viditelnosti, pozice nebo vzhledu vrstvy.

Pokud potřebujete změnit, které vlastnosti kompozice zaznamenává, vyberte v nabídce panelu Layer Comps možnost Layer Comp Options.

Vyberte tlačítko Aktualizovat kompozici vrstev v dolní části panelu Kompozice vrstev.

Použití kompozic vrstev v chytrých objektech

Když umístíte dokument obsahující kompozice vrstev jako chytrý objekt do jiného dokumentu, můžete k těmto kompozicím vrstev přistupovat bez otevření zdrojového souboru.Díky tomu můžete přepínat mezi variacemi návrhu na úrovni chytrého objektu.

Vyberte vrstvu Chytrý objekt v panelu Vrstvy dokumentu.

Panel Vlastnosti otevřete výběrem položek Okno > Vlastnosti.

V nabídce Kompozice vrstev v panelu Vlastnosti vyberte kompozici vrstev, kterou chcete zobrazit.

Nabídka kompozic vrstev v panelu Vlastnosti v aplikaci Adobe Photoshop zobrazující seznam kompozic vrstev s příslušnými možnostmi.

Chytrý objekt se aktualizuje tak, aby zobrazoval vybranou kompozici, a zároveň zachová všechny transformace nebo efekty, které jste na něj použili.

Vymazání výstrah kompozic vrstev

Když odstraníte, sloučíte nebo převedete vrstvy, na které kompozice odkazuje, zobrazí se u dané kompozice vrstev ikona upozornění.Kompozici již nelze zcela obnovit do původního stavu.

Vyberte ikonu upozornění vedle názvu kompozice a zobrazte konkrétní problém.

V hlášení vyberte možnost Vymazat, čímž odstraníte upozornění a zachováte zbývající vlastnosti vrstvy.

Klikněte pravým tlačítkem na ikonu upozornění a vyberte možnost Vymazat upozornění na kompozici vrstev pro vymazání jednoho upozornění, nebo Vymazat všechna upozornění na kompozice vrstev pro vymazání všech upozornění najednou.

Kompozici můžete také aktualizovat na aktuální stav nebo upozornění ignorovat, pokud chybějící informace o vrstvě nepotřebujete.

Odstranění kompozice vrstev

Vyberte kompozici vrstev v panelu Kompozice vrstev.

Vyberte ikonu Odstranit v dolní části panelu nebo přetáhněte kompozici na ikonu Odstranit.

Jako alternativní způsob vyberte z nabídky panelu možnost Odstranit kompozici vrstev.

Exportovat kompozice vrstev do souborů

Vyberte položky Soubor > Export > Kompozice vrstev do souborů.

V dialogovém okně zvolte cílovou složku.

Vyberte formát souboru pro exportované kompozice.

Vyberte možnost Run a vytvořte samostatné soubory pro každou kompozici vrstev.

Každá kompozice vrstev se exportuje jako samostatný soubor, k jehož názvu je připojen název kompozice.