Kopírování a vkládání vrstev

Naposledy aktualizováno 29. 10. 2026

Pomocí příkazů Kopírovat, Vložit a Vložit v místě můžete duplikovat vrstvy se zachováním jejich efektů a masek.

Kopírování a vkládání vrstev přenáší mezi dokumenty úplná data vrstvy, včetně bitmapových a vektorových masek, efektů vrstvy a odkazů na Smart Object. Tato metoda zachovává všechny vlastnosti vrstvy a zároveň vytváří nezávislé duplikáty v cílovém dokumentu.

Pomocí kopírování a vkládání můžete přenášet vrstvy mezi dokumenty při zachování všech vlastností vrstvy. Chcete-li duplikovat vrstvy ve stejném dokumentu, použijte příkaz Vrstva > Duplikovat vrstvu. Chcete-li přemístit existující obsah bez vytváření duplikátů, přetáhněte vrstvy mezi okny dokumentů pomocí nástroje Přesun.

Kopírování a vkládání vrstev

V panelu Vrstvy vyberte vrstvy, které chcete zkopírovat.

Vyberte příkaz Úpravy > Kopírovat nebo stiskněte klávesy Ctrl + C (Windows) nebo Command + C (macOS).

Přepněte se do cílového dokumentu nebo vytvořte nový dokument.

Vyberte příkaz Úpravy > Vložit nebo stiskněte klávesy Ctrl + V (Windows) nebo Command + V (macOS).

Vložená vrstva se zobrazí uprostřed plochy cílového dokumentu. Vložená vrstva se zobrazí tak, že alespoň část je viditelná na ploše.

Vložit vrstvy na původní pozici

V panelu Vrstvy vyberte vrstvy, které chcete zkopírovat.

Vyberte příkaz Úpravy > Kopírovat nebo stiskněte klávesy Ctrl + C (Windows) nebo Command + C (macOS).

Přepněte se do cílového dokumentu.

Vyberte příkaz Úpravy > Vložit jinak > Vložit v místě nebo stiskněte klávesy Ctrl + Shift + V (Windows) nebo Command + Shift + V (macOS).

Příkaz Vložit v místě zachová zkopírovaný obsah ve stejné pozici vzhledem k okrajům plochy.

Vytvořit dokument s velikostí podle zkopírovaných vrstev

Vyberte a zkopírujte jednu nebo více vrstev.

Vyberte možnost Soubor > Nový.

V dialogovém okně Nový dokument vyberte z možností předvoleb položku Schránka.

Vyberte možnost Vytvořit a vygenerujte nový dokument, jehož rozměry odpovídají zkopírovaným vrstvám.

Vyberte příkaz Úpravy > Vložit nebo stiskněte klávesy Ctrl + V (Windows) nebo Command + V (macOS).

Předvolba Schránka vytvoří dokument s rozměry odpovídajícími ohraničovacímu rámečku všech kopírovaných vrstev.

Spravovat barvy a rozlišení

Při vkládání mezi dokumenty může aplikace Photoshop zobrazit dialogové okno s nesouladem profilů barev, pokud zdrojový a cílový dokument používají různé profily barev.Barvy můžete převést tak, aby odpovídaly cílovému dokumentu, nebo zachovat původní barvy.Nastavení správy barev v nabídce Úpravy > Nastavení barev určuje, kdy se tyto pokyny zobrazí.

Pokud vkládáte vrstvy mezi dokumenty s různým rozlišením, vložený obsah si zachová pixelové rozměry.To může způsobit, že vložené prvky budou v cílovém dokumentu vypadat větší nebo menší, než ve skutečnosti jsou.Chcete-li zachovat vizuální konzistenci, použijte příkaz Obraz > Velikost obrazu k sladění rozlišení před kopírováním a vkládáním, nebo použijte příkaz Úpravy > Libovolná transformace ke změně velikosti vloženého obsahu.

Porozumění chování při kopírování a vkládání chytrých objektů

Výstraha

Úpravy zkopírované a vložené vrstvy chytrého objektu neaktualizují původní vrstvu chytrého objektu, a naopak.Zkopírované a vložené chytré objekty vytvářejí nezávislé vložené instance.

Chcete-li zachovat propojení mezi instancemi chytrých objektů mezi dokumenty, použijte propojené chytré objekty.Propojené chytré objekty odkazují na externí zdrojové soubory, což zajišťuje, že se všechny instance aktualizují při úpravě zdroje.

Kopírovat sloučený obsah

Příkaz Kopírovat sloučené vytvoří zploštělou kopii všech viditelných vrstev v rámci vybrané oblasti.

Vytvořte výběr pomocí libovolného nástroje Výběr, nebo nic nevybírejte, chcete-li zkopírovat veškerý viditelný obsah.

Vyberte příkaz Úpravy > Kopírovat sloučené, nebo stiskněte klávesy Ctrl + Shift + C (Windows) nebo Command + Shift + C (macOS).

Vložte sloučený obsah do libovolného dokumentu.Sloučený obsah se zobrazí na jedné vrstvě.

Kopírovat sloučené respektuje viditelnost vrstev – do sloučeného výsledku se zahrnou pouze viditelné vrstvy.Skryté vrstvy jsou vyloučeny, i když jsou vybrané.

Práce s chováním specifickým pro cesty

Při kopírování vrstev, které obsahují vektorové cesty, včetně vrstev tvaru a vektorových masek, závisí chování při kopírování a vkládání na tom, zda jsou na plátně vybrané cesty.

Kopírování tvarových vrstev a vektorových masek

Pokud na plátně nejsou vybrané žádné cesty:

  • Kopírování vrstvy tvaru nebo vrstvy s vektorovou maskou zkopíruje celou vrstvu do schránky.
  • Vložení vytvoří duplicitní vrstvu se všemi maskami, efekty a daty cesty beze změny.

Pokud máte na plátně vybrané cesty:

  • Kopírování vrstvy tvaru s vybranými cestami zkopíruje do schránky pouze data cesty.
  • Způsob vložení dat cesty závisí na typu cílové vrstvy (viz níže).

Vložení dat cesty

Způsob vložení dat cesty se liší podle vybraného typu vrstvy:

  • Do bitmapové vrstvy (bez cest): Vytvoří novou vektorovou masku z vložených dat cesty
  • Do vrstvy tvaru bez vybraných cest: Nahradí stávající tvar vloženou cestou
  • Do vrstvy tvaru s vybranými cestami: Zkombinuje vloženou cestu se stávajícími cestami ve vrstvě tvaru
  • Do vrstvy s vektorovou maskou (maska není vybraná): Nahradí cestu vektorové masky vloženými daty
  • Do vrstvy s vektorovou maskou (maska je vybraná): Zkombinuje vloženou cestu se stávající cestou vektorové masky
Poznámka

Příkaz Vyjmout (Úpravy > Vyjmout) není k dispozici, pokud jsou vybrané vrstvy.Chcete-li vrstvy při kopírování odstranit, použijte příkaz Kopírovat a potom smažte původní vrstvy v panelu Vrstvy.