Vytváření řezů

Naposledy aktualizováno 29. 10. 2026

Naučte se používat nástroj Nástroj řez, Příručky nebo vrstvy k rozdělení obrázků na exportovatelné oblasti pro optimalizaci pro web v aplikaci Adobe Photoshop pro počítače.

Řezy rozdělí obrázek na menší části, které můžete jednotlivě vylepšit nebo jim před exportem pro web přiřadit různé odkazy URL.

Vytvoření řezů pomocí nástroje Nástroj řez

Když vytvoříte uživatelské řezy, Photoshop automaticky vyplní nezakryté oblasti automatickými řezy. Uživatelské řezy mají plné ohraničení, zatímco automatické řezy mají tečkované ohraničení.

Pokud chcete řezy zarovnat k příručkám nebo jiným řezům, před kreslením vyberte Zobrazení > Přichytit k.

Vyberte nástroj Nástroj řez .{4}

Na panelu možností vyberte z rozevírací nabídky styl:

  • Normální: Kreslí řezy libovolného tvaru.
  • Pevný poměr stran: Zachová proporce.
  • Pevná velikost: Určuje přesné rozměry v pixelech.

Přetáhněte přes oblast obrázku, kde chcete vytvořit řez.

Poznámka

Můžete podržet klávesu Shift a tažením omezit řez na čtverec nebo podržet klávesu Alt a táhnout (Windows) nebo podržet klávesu Option a táhnout (macOS), chcete-li kreslit od středu.

Opakováním vytvoříte další řezy.

Vytvoření řezů z vodítek

Vytvořením řezů z Guides odstraníte všechny existující řezy v dokumentu.Pokud chcete zachovat aktuální konfiguraci řezů, uložte kopii souboru.

Vyberte Zobrazení > Příručky > Nová příručka, potom Svislá nebo Vodorovná příručka, které určují požadované hranice řezů, a vyberte OK.

Vyberte nástroj Nástroj řez.

Na panelu možností vyberte Řezy z Guides.

Vytvoření řezů z vrstev

Řezy vytvořené z vrstev automaticky upravují své hranice při přesunu nebo úpravě vrstvy, takže jsou užitečné pro dynamické návrhy. Zobrazují se s plným ohraničením a ikonou vrstvy a nemůžete měnit jejich velikost, dokud je nepřevedete na uživatelské řezy.

Nepoužívejte řezy založené na vrstvách u vrstev, které plánujete animovat v aplikaci Animate přes velké oblasti, protože rozměry řezu by mohly být neprakticky velké.

V panelu Vrstvy vyberte vrstvu s obsahem, který chcete rozdělit na řezy.

Vyberte možnost Vrstva > Nový řez založený na vrstvě.

Po vytvoření řezů je můžete vybrat pomocí nástroje Výběr řezu a přesouvat je, měnit jejich velikost nebo upravovat jejich vlastnosti.Uživatelské řezy poskytují největší flexibilitu. Chcete-li zobrazit hranice řezů, vyberte možnost Zobrazení > Zobrazit > Řezy.

Vyberte možnost Soubor > Export > Uložit pro web, nastavte možnosti exportu pro každý řez a uložte soubor. Photoshop exportuje každý řez jako samostatný obrazový soubor a vygeneruje kód HTML nebo CSS potřebný k zobrazení řezů na webové stránce.