Farbtiefe und HDR-Farben

Die Farbtiefe (bzw. Bittiefe) gibt die Anzahl der Bits pro Kanal (bpc) an, die zum Darstellen der Farbe eines Pixels verwendet wird. Je mehr Bits für einen RGB-Kanal (Rot, Grün und Blau) verwendet werden, desto mehr Farben lassen sich durch jedes Pixel darstellen.

In After Effects können Sie 8-Bit-, 16-Bit- oder 32-Bit-Farben verwenden.

Neben der Farbtiefe weisen die zur Darstellung von Pixelwerten verwendeten Zahlen ein weiteres Kriterium auf, nämlich, ob es sich um Ganzzahlen oder Gleitkommazahlen handelt. Bei Verwendung von Gleitkommazahlen kann mit derselben Bitanzahl ein größerer Zahlenbereich ausgedrückt werden. In After Effects sind die 32-Bit-Pixelwerte Gleitkommawerte.

8-Bit-Pixel können für jeden Farbkanal einen Wert zwischen 0 (Schwarz) und 255 (reine, gesättigte Farbe) annehmen. 16-Bit-Pixel können für jeden Farbkanal einen Wert zwischen 0 (Schwarz) und 32.768 (reine, gesättigte Farbe) annehmen. Wenn alle drei Farbkanäle auf den Maximalwert (reine Farbe) eingestellt sind, ergibt sich die Farbe Weiß. 32-Bit-Pixel können Werte unter 0,0 und über 1,0 (reine, gesättigte Farbe) annehmen. Dadurch entspricht die 32-Bit-Farbtiefe in After Effects zugleich High Dynamic Range (HDR)-Farben. HDR-Werte können wesentlich heller als Weiß sein.

Festlegen der Farbtiefe und Ändern der Farbanzeigeeinstellungen

Die Farbtiefeneinstellung für ein Projekt bestimmt die Tiefe der Farbwerte des Projektes.

So legen Sie die Farbtiefe für ein Projekt fest:

  • Klicken Sie im Projektfenster bei gedrückter Alt-Taste (Windows) bzw. Wahltaste (Mac OS) auf die Schaltfläche „Projekteinstellungen“.

  • Wählen Sie „Datei“ (Windows) bzw. „Ablage“ (Mac OS) > „Projekteinstellungen“ oder klicken Sie im Projektfenster auf die Schaltfläche „Projekteinstellungen“ und wählen Sie im Menü „Tiefe“ eine Farbtiefe.

Für jedes Renderelement kann eine Farbtiefe angegeben werden, die beim Rendern für die endgültige Ausgabe die Projektfarbtiefe außer Kraft setzt. In den Einstellungen für Ausgabemodule kann auch die Farbtiefe für die einzelnen Ausgabeelemente angegeben werden. (Siehe Rendereinstellungen und Ausgabemodule und Einstellungen für Ausgabemodule.)

Hinweis:

Um das Format zu ändern, in dem die Farbwerte im Infofenster und in einigen Effektfenstern angezeigt werden, wählen Sie im Menü des Infofensters eine Option wie „Prozent“ oder „Web“. Bei Auswahl der Option „Automatische Farbanzeige“ wechselt After Effects je nach Farbtiefe des Projekts automatisch zwischen 8 Bit, 16 Bit und 32 Bit pro Kanal.

Während viele Effekte bei allen Farbtiefen eingesetzt werden können, gelten manche Effekte jedoch nur für geringere Farbtiefen. Sie können festlegen, dass im Effekte- und Vorgabenfenster nur Effekte angezeigt werden, die für die Farbtiefe des aktuellen Projekts geeignet sind. (Siehe Effekte- und Vorgabenfenster.)

Vergleich der Vorteile der einzelnen Farbtiefen

Der dynamische Wertebereich (d. h. das Verhältnis zwischen dunklen und hellen Bereichen) der physischen Welt geht weit über den vom menschlichen Auge wahrnehmbaren sowie über den auf Papier gedruckten oder am Bildschirm angezeigten Bildern dargestellten Bereich hinaus. 8-Bit- und 16-Bit-Farbwerte mit niedrigem dynamischem Wertebereich können nur RGB-Tonwerte von Schwarz bis Weiß darstellen, was nur einen kleinen Teil des dynamischen Wertebereichs der realen Welt ausmacht.

Mit 32-Bit-HDR-Gleitkomma-Farbwerten können Helligkeitswerte dargestellt werden, die weit über die Farbe Weiß hinausgehen, z. B. Objekte mit der Helligkeit einer Kerzenflamme oder der Sonne.

Anwendung der Effekte „Leuchten“ und „Gaußscher Weichzeichner“ auf ein Bild in einem 32-Bit-Projekt und in einem 16-Bit-Projekt
Anwendung der Effekte „Leuchten“ und „Gaußscher Weichzeichner“ auf ein Bild in einem 32-Bit-Projekt (links) und in einem 16-Bit-Projekt (rechts)

Stellen Sie die Farbtiefe auf 32 Bit ein, wenn Sie mit HDR-Footage arbeiten oder Helligkeitswerte über 1,0 (Weiß) verwenden wollen (im 8- oder 16-Bit-Modus nicht unterstützt). Mit diesen Werten bleibt die Intensität von Lichtern erhalten. Dies ist sowohl beim Arbeiten mit synthetischen Effekten wie Licht-, Weichzeichnungs- und Leuchteffekten als auch beim Arbeiten mit HDR-Footage von Vorteil. Der Spielraum, den Sie beim Arbeiten mit 32-Bit-Farben haben, verhindert viele Arten von Datenverlust bei den verschiedenen Vorgängen, wie z. B. bei der Farbkorrektur und der Farbprofilkonvertierung.

Selbst wenn Sie 8-Bit-Footage verwenden und Filme in 8-Bit-Formaten erstellen, können Sie bessere Ergebnisse erzielen, indem Sie die Projektfarbtiefe auf 16 Bit oder 32 Bit einstellen. Das Arbeiten mit einer höheren Farbtiefe führt zu einer größeren Präzision bei Berechnungen und einer starken Verringerung von Quantisierungsartefakten, z. B. von bandartigen Effekten bei Farbverläufen.

Hinweis:

Auch bei einer höheren Farbtiefe in einem Projekt kann es jedoch zu Farbverläufen kommen, wenn das Ausgabeformat eine niedrige Bittiefe aufweist. Um bandartige Effekte zu minimieren, wendet After Effekts Dithering für die Farben an, wenn diese zu 8-Bit-Farben konvertiert werden. Das geschieht auch beim Rendern und Exportieren im 8-Bit-Format. Dieses Dithering wird nicht für die Vorschau angewendet. Um Dithering für eine Vorschau zu erzwingen, wenden Sie auf eine Einstellungsebene einen 8-Bit-Effekt an, der keine Auswirkungen hat, z. B. den Effekt „Arithmetik“ mit den Standardwerten.

Da 16-Bit-Frames nur halb so viel Arbeitsspeicher benötigen wie 32-Bit-Frames, erfolgt das Rendern der Vorschau in einem 16-Bit-Projekt schneller und die Vorschau kann länger dauern als bei einem 32-Bit-Projekt. Für 8-Bit-Frames wird noch weniger Arbeitsspeicher benötigt. Allerdings kann bei einer Projektfarbtiefe von 8 Bit pro Kanal bei manchen Bildern der Kompromiss zwischen Qualität und Leistung deutlich sichtbar werden.

Spezielle Überlegungen für das Arbeiten mit HDR-Farben

Der Effekt „HDR Compander“ gibt Ihnen die Möglichkeit, den dynamischen Wertebereich einer Ebene mit einem HDR-Footageelement als Quelle zu komprimieren. Auf diese Weise können Sie Werkzeuge einsetzen, die keine Unterstützung für HDR bieten, z. B. 8-Bit- und 16-Bit-Effekte. Verwenden Sie nach Abschluss der Bearbeitung den Effekt „HDR Compander“ dazu, die Komprimierung des dynamischen Wertebereichs wieder rückgängig zu machen. Der Effekt „Helligkeit in HDR-Bildern komprimieren“ gibt Ihnen die Möglichkeit, die Helligkeitswerte in einem HDR-Bild so zu komprimieren, dass sie in den Bereich eines Bildes mit niedrigem dynamischem Wertebereich fallen.

Da wir in einem HDR-Bild auf dem Bildschirm nur eine Teilmenge der Luminanzwerte einer realen Szene sehen können, ist es beim Arbeiten mit HDR-Bildern mitunter erforderlich, die Belichtung (die in einem Bild erfasste Lichtmenge) anzupassen. Die Belichtungsanpassung bei einem HDR-Bild gleicht der Belichtungsanpassung beim Fotografieren einer Szene in der Realität, d. h., die Detailwiedergabe lässt sich sowohl in dunklen als auch hellen Bereichen verbessern. Mit dem Effekt „Belichtung“ können Sie die Farbwerte einer Ebene für die endgültige Ausgabe ändern oder die Belichtung in einer bestimmten Anzeige für die Vorschau anpassen.

Hinweis:

Da einige Operationen (z. B. Leuchten, Verwischen und einige Füllmethoden) im 32-Bit-Modus anders ausgeführt werden als im 8-Bit- oder 16-Bit-Modus kann Ihre Komposition erheblich abweichen, wenn die Projekteinstellungen zwischen High Dynamic Range und Low Dynamic Range geändert werden.

Weitere Ressourcen zu HDR-Farben

Chris Meyer erläutert in einem Video-Überblick auf der Website Lynda.com die Vorteile von 32-Bit-HDR-Gleitkomma-Farbwerten.

Andrew Kramer demonstriert in einem Video-Lehrgang auf seiner Video Copilot-Website die Vorteile der Verwendung von 32-bpc-Farbe mit Bewegungsunschärfe.

Auf seiner fnord-Website erläutert Brendan Bolles, wie Sie mit dem Effekt „Farbprofil konvertieren“ und mit Film-Farbprofilen Farben anpassen und Tonzuordnungen durchführen, sodass HDR-Bilder wie Spielfilmaufnahmen aussehen.

Auswählen einer Farbe oder Bearbeiten eines Verlaufs

In verschiedenem Kontext können Sie auf eine Pipettenschaltfläche klicken, um die Pipette zu aktivieren, oder Sie können auf ein Farbfeld klicken, um einen Farbwähler zu öffnen. Wenn Sie den Adobe-Farbwähler verwenden, können Sie die Pipette auch über das Dialogfeld „Adobe-Farbwähler“ aktivieren.

Wenn Sie auf ein Verlaufsfeld (Linearer Verlauf oder Flächenverlauf) für eine Kontur oder eine Fläche in einer Formebene klicken, wird der Adobe-Farbwähler als Verlaufseditor geöffnet, der oben im Dialogfeld zusätzliche Steuerelemente für die Bearbeitung von Farbverläufen enthält. Außerdem können Sie im Zeitleistenfenster auf „Verlauf bearbeiten“ klicken, um den Verlaufseditor zu öffnen.

Andrew Devis zeigt in einem Video auf der Creative COW-Website, wie Sie Verlaufsfüllungen und Konturen von Formebenen anpassen sowie welche Optionen hierbei verfügbar sind.

Hinweis:

Die sampleImage Expression-Methode bietet eine weitere Möglichkeit, Farbwerte auszuwählen. Verwenden Sie diese Methode, um Farbwerte bestimmter Pixel als Eingabe für eine Expression zu verwenden. (Siehe Objekttyp „Ebene allgemein“: Attribute und Methoden (Expression-Referenz).)

Verlaufseditor Bildschirm
A. Deckkraftstopp B. Farbstopp C. Deckkraft-Mittelpunkt D. Pipette E. Neue Farbe F. Ursprüngliche Farbe 

Auswählen eines Farbwählers

  • Um die Systemfarbe auszuwählen, wählen Sie Bearbeiten > Voreinstellungen > Allgemeine Voreinstellungen (Windows) bzw. After Effects > Voreinstellungen > Allgemeine Voreinstellungen (Mac OS) und aktivieren Sie das Kontrollkästchen System-Farbwähler verwenden.
  • Um den Adobe-Farbwähler zu verwenden, lassen Sie das Kontrollkästchen System-Farbwähler verwenden deaktiviert und wählen Sie Fenster > Erweiterungen > Adobe Color-Themen.

Hinweis:

Jeff Almasol bietet auf seiner Redefinery-Website das Skript PickerSwitcher an, das die Einstellung „System-Farbwähler verwenden“ umschaltet. Verwenden Sie dieses Skript, wenn Sie für bestimmte Aufgaben den Adobe-Farbwähler und für andere den Farbwähler des Betriebssystems nutzen und die entsprechende Einstellung deshalb schnell ändern möchten. 

Auswählen einer Farbe mit der Pipette

  1. Klicken Sie auf die Schaltfläche „Pipette“ und bewegen Sie den Zeiger auf den Pixel, den Sie aufnehmen möchten. Das Farbfeld neben der Schaltfläche „Pipette“ passt sich dynamisch der jeweiligen Farbe unter der Pipette an.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wenn Sie die Farbe eines einzelnen Pixels auswählen möchten, klicken Sie auf einen Pixel.

    • Wenn Sie die durchschnittliche Farbe eines 5 x 5 Pixel großen Bereichs aufnehmen möchten, klicken Sie bei gedrückter Strg-Taste (Windows) bzw. Befehlstaste (Mac OS) auf den Bereich.

    Hinweis:

    Wenn Sie von einer Stelle innerhalb des Kompositionsframes Farbe aufnehmen, wird die Hintergrundfarbe der Komposition von der Pipette standardmäßig ignoriert und es werden nur die direkten Farbkanäle aufgenommen. Halten Sie beim Klick mit der Pipette die Umschalttaste gedrückt, um mit der Hintergrundfarbe der Komposition integrierte Farbkanäle auszuwählen. Durch Klicken mit der Pipette bei gedrückter Umschalttaste werden die Farben so ausgewählt, wie sie im Kompositionsrahmen des Kompositionsfensters erscheinen.

Hinweis:

Drücken Sie die Esc-Taste, um die Pipette zu deaktivieren.

Auswählen einer Farbe mit dem Adobe Farbwähler

Im Adobe-Farbwähler können Sie Farben mit einem der Farbmodelle auswählen oder den Farbregler und das Farbfeld zur Auswahl der Farbe verwenden.

Die folgenden Farbmodelle sind verfügbar:

  • HSB
  • RGB
  • Lab
  • CMYK
  • Hex

Verwenden Sie den Farbregler, um eine Farbe auszuwählen:

  • Ziehen Sie die Dreiecke entlang des Farbreglers oder klicken Sie in den Farbregler, um die im Farbspektrum angezeigten Farben zu ändern.
  • Klicken oder ziehen Sie im großen rechteckigen Farbspektrum, um eine Farbe auszuwählen. Eine kreisförmige Markierung gibt die Position der Farbe im Farbspektrum an.
  1. Klicken auf Fenster > Erweiterungen > Adobe Color-Themen, um den Adobe-Farbwähler anzuzeigen.

  2. (Optional) Um zu verhindern, dass das Ergebnis Ihrer Farbauswahl im Fenster angezeigt wird, bevor Sie die Farbe durch Klicken auf „OK“ bestätigen, deaktivieren Sie die Option „Vorschau“ im Dialogfeld „Farbwähler“. Die Option „Vorschau“ ist nicht in jedem Kontext verfügbar.

    Hinweis:

    Das Aktivieren der Vorschau ist hilfreich, da Sie das Ergebnis Ihrer Farbauswahl bereits sehen können, bevor Sie diese übernehmen. Allerdings kann dadurch auch die Leistung beeinträchtigt werden, wenn neue Bilder im Kompositionsfenster oder Ebenenfenster für die Vorschau gerendert werden.

  3. Geben Sie die Werte für die Komponente in die Textfelder ein. Wählen Sie die Komponente aus, auf der die Anzeige des Farbspektrums beruhen soll:

    HSB

    Geben Sie für den Farbton (H) einen Winkel von 0° bis 360° an, der einem Punkt auf dem Farbkreis entspricht. Geben Sie für die Sättigung (S) und die Helligkeit (B) Prozentwerte (0 bis 100) ein.

    H

    Zeigt alle Farbtöne im Farbregler an. Wenn Sie im Farbregler einen Farbton auswählen, wird der Sättigungs- und Helligkeitsbereich dieses Farbtons im Farbspektrum angezeigt, wobei die Sättigung von links nach rechts zunimmt und die Helligkeit von unten nach oben.

    S

    Zeigt alle Farbtöne im Farbspektrum an, wobei die Sättigung von oben nach unten vom maximalen zum minimalen Wert abnimmt. Im Farbregler sehen Sie die im Farbspektrum ausgewählte Farbe, wobei die Sättigung von oben nach unten vom maximalen zum minimalen Wert abnimmt.

    B

    Zeigt alle Farbtöne im Farbspektrum an, wobei die Helligkeit von oben nach unten vom maximalen zum minimalen Wert abnimmt. Im Farbregler sehen Sie die im Farbspektrum ausgewählte Farbe, wobei die Helligkeit von oben nach unten vom maximalen zum minimalen Wert abnimmt.

    RGB

    Geben Sie für RGB Komponentenwerte ein. In einem HDR-Projekt können die Farben auf untere bzw. obere Extremwerte außerhalb des Bereichs 0,0 bis 1,0 eingestellt werden.

    R

    Zeigt die rote Farbkomponente im Farbregler an, wobei die Helligkeit von oben nach unten vom maximalen Wert zum minimalen Wert abnimmt. Wenn der Farbregler auf den minimalen Helligkeitswert eingestellt ist, setzen sich die im Farbspektrum angezeigten Farben nur aus grünen und blauen Komponenten zusammen. Wenn Sie mit dem Farbregler die Helligkeit der roten Komponente erhöhen, wird den im Farbspektrum angezeigten Farben immer mehr Rot beigemischt.

    G

    Zeigt die grüne Farbkomponente im Farbregler an, wobei die Helligkeit von oben nach unten vom maximalen Wert zum minimalen Wert abnimmt. Wenn der Farbregler auf den minimalen Helligkeitswert eingestellt ist, setzen sich die im Farbspektrum angezeigten Farben nur aus roten und blauen Komponenten zusammen. Wenn Sie mit dem Farbregler die Helligkeit der grünen Komponente erhöhen, wird den im Farbspektrum angezeigten Farben immer mehr Grün beigemischt.

    B

    Zeigt die blaue Farbkomponente im Farbregler an, wobei die Helligkeit von oben nach unten vom maximalen Wert zum minimalen Wert abnimmt. Wenn der Farbregler auf den minimalen Helligkeitswert eingestellt ist, setzen sich die im Farbspektrum angezeigten Farben nur aus roten und grünen Komponenten zusammen. Wenn Sie mit dem Farbregler die Helligkeit der blauen Komponente erhöhen, wird den im Farbspektrum angezeigten Farben immer mehr Blau beigemischt.

    CMYK

    Geben Sie den Wert jeder Komponente im Textfeld als Prozentwert von Cyan, Magenta, Gelb und Schwarz an, um eine bestimmte Farbe zu erhalten.  

    Lab

    L

    Bezeichnet die Luminanz einer Farbe (von 0 bis 100)

    a

    Der Anteil von Rot oder Grün in einer Farbe (von –128 bis +127)

    b

    Der Anteil von Blau oder Gelb in einer Farbe (von –128 bis +127)

    Hex

    Geben Sie Werte im Hexadezimal-Format ein. Die Werte können zwischen #000000 und #ffffff liegen. #000000 steht beispielsweise für Schwarz und #ffffff für Weiß.

Bearbeiten eines Verlaufs

Ein Verlauf wird durch Farbstopps und Deckkraftstopps definiert. Jedem Stopp ist eine Position entlang des Verlaufs und ein Wert für Farbe oder Deckkraft zugeordnet. Die Werte zwischen den Stopps werden interpoliert. Die Interpolation ist standardmäßig linear, der Deckkraft-Mittelpunkt bzw. der Farbmittelpunkt zwischen zwei Stopps kann aber gezogen werden, um die Interpolation zu ändern.

  • Klicken Sie zum Hinzufügen eines Deckkraft-Mittelpunkts bzw. Farbmittelpunkts unterhalb oder oberhalb des Verlaufsbalkens im Dialogfeld des Verlaufseditors.
  • Wenn Sie einen Stopp entfernen möchten, ziehen Sie diesen aus dem Verlaufsbalken heraus oder wählen Sie den Stopp aus und klicken Sie auf „Löschen“.
  • Zum Bearbeiten eines Stoppwerts den Stopp auswählen und den Deckkraftwert anpassen oder die Einstellungen des Adobe-Farbwählers unterhalb der Verlaufseditor-Einstellungen verwenden.
  • Zur Auswahl eines Verlaufstyps klicken Sie auf die Schaltfläche „Linearer Verlauf“ oder „Radialer Verlauf“ in der linken oberen Ecke des Verlaufseditor-Dialogfelds.

Hinweis:

Wählen Sie über die Stileigenschaft einen Verlaufstyp für den Ebenenstil „Verlaufsüberlagerung“ aus.  

Lernprogramm

Sie können Farbthemen erstellen und speichern, bereits vorhandene Themen anzeigen und gespeicherte Farbthemen über das Adobe Creative Cloud-Profil durchsuchen. In diesem Lernprogramm erfahren Sie, wie Sie Adobe Color in After Effects verwenden.

Farbkorrektur, Farbabstimmung und Farbanpassung

Wenn Sie eine Komposition zusammenstellen, müssen Sie oft die Farben einzelner Ebenen anpassen bzw. korrigieren. Solche Anpassungen können aus verschiedenen Gründen durchgeführt werden. Hier einige Beispiele:

  • Sie möchten den Eindruck erwecken, dass mehrere Footageelemente unter denselben Bedingungen aufgenommen wurden, sodass sie kombiniert oder gemeinsam bearbeitet werden können.

  • Sie müssen die Farben einer Aufnahme so anpassen, dass es scheint, als sei die Aufnahme bei Nacht statt bei Tag gemacht worden.

  • Sie müssen die Belichtung eines Bildes anpassen, um Details an überbelichteten Stellen sichtbar zu machen.

  • Sie müssen eine Farbe in einer Aufnahme verstärken, da Sie ein Grafikelement mit derselben Farbe über das Bild legen möchten.

  • Sie müssen Farben auf einen bestimmten Bereich beschränken, beispielsweise auf den übertragungssicheren Bereich.

Die Begriffe Farbkorrektur und Farbanpassung werden oft synonym verwendet. Der Begriff Farbanpassung wird manchmal jedoch für Farbanpassungen verwendet, die aus kreativen Gründen vorgenommen werden, und nicht, um Probleme mit Farben zu korrigieren. Der Begriff Farbkorrektur wird in After Effects in einem umfassenden und allgemeinen Sinn verwendet.

After Effects bietet zahlreiche integrierte Effekte für die Farbkorrektur, darunter auch die Effekte „Kurven“, „Tonwertkorrektur“ sowie andere Farbkorrektur-Effekte. Wenn Sie die Farbzuordnung in einer Farbtabelle für Farbkorrekturen anwenden möchten, können Sie dazu auch den Effekt „Farb-LUT anwenden“ verwenden. (Siehe Effekte unter „Farbkorrektur“ und Effekt „Farb-LUT zuweisen“.)

Das Plug-in „Camera Raw“ kann zum Korrigieren und Anpassen von Standbildern in den Formaten JPEG und TIFF sowie in verschiedenen Camera Raw-Formaten verwendet werden.

Das im Lieferumfang von After Effects enthaltene Plug-in „Synthetic Aperture Color Finesse“ umfasst hervorragende Farbkorrekturwerkzeuge. After Effects CC und CS6 enthalten Synthetic Aperture Color Finesse 3. (Siehe Ressourcen für Synthetic Aperture Color Finesse.)

Weitere Ressourcen zu Farbkorrektur und -anpassung

Dieser Artikel im Adobe-Blog enthält mehrere Video-Tutorials und weitere Ressourcen zur Farbkorrektur und Farbabstimmung in After Effects und Premiere Pro.

John Dickinson bietet auf seiner Motionworks-Website visuelle Hilfen an, die veranschaulichen, wie die Effekte „Kurven“ und „Tonwertkorrektur“ zur Farbanpassung verwendet werden können:

Dieses Video aus der Serie After Effects: Learn By Video zeigt, wie Sie Motion-Tracking und Rotoskopieren kombinieren, um das Gesicht eines Schauspielers zu isolieren und anschließend einer Farbkorrektur zu unterziehen.

Die Animationsvorgabe „Rebel CC“ ist ein einfaches Farbkorrekturwerkzeug im Telecine-Stil zum Kolorieren oder Verbessern der Farbabstufungen eines Films. Bei dieser Animationsvorgabe werden Expressions zur Steuerung des Effekts „Tonwerte (Einzelne Steuerungen)“ eingesetzt. Weitere Informationen finden Sie im Stu Maschwitz's ProLost-Blog. Dort können Sie auch eine Vorgabeanimation herunterladen.

Stu Maschwitz hat in seinem ProLost-Blog einen Beitrag veröffentlicht, in dem die Farbkorrektur von Hauttönen erörtert wird. Außerdem sind Links zu einigen Ressourcen über Test-Setups enthalten, in denen verschiedene Hauttöne auf einem Vektorskop gezeigt werden.

Mark Christiansen bietet auf der Peachpit Press-Website unter After Effects Studio Techniques (After Effects Studio-Techniken) im Kapitel „Color Correction in Adobe After Effects“ (Farbkorrektur in Adobe After Effects) einige Tipps und detaillierte Methoden zur Farbkorrektur, Farbanpassung und Farbübereinstimmung an.

Histogramm zur Farbanpassung verwenden

Ein Histogramm ist eine Darstellung der Anzahl von Pixeln mit den jeweiligen Luminanzwerten in einem Bild. Wenn ein Histogramm für jeden Luminanzwert einen Wert ungleich Null aufweist, nutzt das zugrunde liegende Bild den vollen Tonwertbereich. Ein Histogramm, in dem nicht der volle Tonwertbereich genutzt wird, entspricht einem trüben Bild mit wenig Kontrast.

Eine typische Farbkorrektur verteilt die Pixelwerte gleichmäßiger im Histogramm und vermeidet deren Häufung auf einer Seite. Durch Zuweisen einer Tonwertkorrektur und Änderung der Eigenschaften „Eingabe: Lichter“ und „Eingabe: Tiefen“ im Histogramm ist dies für die meisten Bilder problemlos durchzuführen.

Histogramm für ein Bild, das nicht den vollen Tonwertbereich nutzt
Histogramm für ein Bild, das nicht den vollen Tonwertbereich nutzt

Reglerstellungen korrigiert, damit im Ergebnis der volle Tonwertbereich genutzt wird
Reglerstellungen korrigiert, damit im Ergebnis der volle Tonwertbereich genutzt wird

Histogramm mit Beschneidung heller Bereiche
Histogramm mit Beschneidung heller Bereiche

Histogramm mit Beschneidung dunkler Bereiche
Histogramm mit Beschneidung dunkler Bereiche

Bedienfeld „Lumetri-Scopes“

Das Bedienfeld „Lumetri-Scopes“ verfügt über integrierte Videoscopes, die die Farbeigenschaften Ihres Videos darstellen. Diese Videoscopes umfassen:

  • Vektorscopes
  • Histogramme
  • Parade
  • Wellenform
Videoscopes im Bedienfeld Lumetri-Scopes
Videoscopes im Bedienfeld Lumetri-Scopes

Jeder Videoframe besteht aus Pixeln und jedes Pixel besitzt die Farbeigenschaften Chrominanz, Luminanz und Sättigung. Diese Farbeigenschaften können Sie analysieren, um gezielte Farbkorrekturen Ihres Videos vorzunehmen und die Konsistenz mehrerer Videosequenzen sicherzustellen.

Lumetri-Scopes-Unterstützung für Fernsehproduktionen

Das Bedienfeld „Lumetri-Scopes“ wurde für Farbmanagement-Arbeitsabläufe bei Fernsehproduktionen entwickelt. Das Bedienfeld erfasst Farben in den Farbräumen Rec. 601, Rec. 709 und Rec. 2020. Um die Farbräume zu öffnen, klicken Sie mit der rechten Maustaste in das Bedienfeld „Lumetri-Scopes“ und wählen Sie Farbraum

  • Rec. 601: Wird zur Codierung von analogen Videosignalen in digitales Video verwendet.
  • Rec. 709: Wird für normale HDTV-Arbeitsabläufe eingesetzt.
  • Rec 2020: Wird für HDR und UHDTV (UHD 4k und UHD 8k) genutzt.

Wenn Sie Ihrem After Effects-Projekt einen anderen Farbraum zugewiesen haben, zeigen die Videoscopes die Darstellung Ihrer Komposition im gewählten Farbraum, konvertiert in den Farbraum (601, 709 oder 2020), der im Bedienfeld „Lumetri-Scopes“ konfiguriert ist.

Weitere Informationen zu Arbeitsabläufen für Fernsehproduktionen finden Sie unter Sendefähige Farben

Arbeitsbereich für das Arbeiten mit Farbwerkzeugen

In After Effects steht ein neuer Arbeitsbereich mit dem Namen „Farbe“ für das Arbeiten mit dem Bedienfeld „Lumetri-Scopes“ und dem Effekt „Lumetri Color“ zur Verfügung. Um den Arbeitsbereich zu öffnen, wählen Sie das Menü Fenster > Arbeitsbereich.

Öffnen des Arbeitsbereichs für das Arbeiten mit Farbwerkzeugen
Öffnen des Arbeitsbereichs für das Arbeiten mit Farbwerkzeugen

Synchronisierung des aktuellen Anzeigefensters

Das Bedienfeld „Lumetri-Scopes“ analysiert und stellt die Änderungen im aktuellen Anzeigefenster dar. Es misst die Farben des jeweils aktiven Kompositions-, Ebenen- oder Footagefensters. Sie können unterschiedliche Ergebnisse miteinander vergleichen, indem Sie zwischen verschiedenen Anzeigefenstern wechseln. Um die Lumetri-Scopes-Anzeige auf ein bestimmtes Anzeigefenster zu fixieren, aktivieren Sie die Option Primäre Anzeige im jeweiligen Anzeigefenster. Beispiel: Wenn Sie die RGB-Farbkurven der Komposition ändern, nimmt die Wellenform eine entsprechende Farbe an und spiegelt die geänderten Farbinformationen wider.

Weitere Informationen zu Bedienfeldern finden Sie unter Bedienfelder und Arbeitsbereiche.

Vor der Anwendung von Lumetri-Scopes zur Messung von Farbinformationen
Vor der Anwendung von Lumetri-Scopes zur Messung von Farbinformationen

Nach Änderungen an der Komposition anhand von Lumetri-Scopes-Farbinformationen
Nach Änderungen an der Komposition anhand von Lumetri-Scopes-Farbinformationen


Bedienfeld „Lumetri-Scopes“ in After Effects

Bedienfeld „Lumetri-Scopes“ in After Effects
In diesem Video erfahren Sie, wie Sie mithilfe des Bedienfelds „Lumetri-Scopes“ in After Effects Farbkorrekturen vornehmen.

Das Bedienfeld „Lumetri-Scopes“ ist mit dem gleichnamigen Bedienfeld in Premiere Pro identisch. Weitere Informationen zum Bedienfeld finden Sie unter Lumetri-Scopes in Premiere Pro.

Ressourcen für Synthetic Aperture Color Finesse

Das im Lieferumfang von After Effects enthaltene Plug-in „Synthetic Aperture Color Finesse“ umfasst hervorragende Farbkorrekturwerkzeuge. Synthetic Aperture bieten auf ihrer Website Übungen und weitere Informationen zur Verwendung von Color Finesse an.

Die Dokumentation von Color Finesse wird im Ordner „Plug-ins“ im Unterordner des Plug-ins installiert. After Effects beinhaltet Synthetic Aperture Color Finesse 3. (Siehe Plug-ins.)

Farbmodelle und Farbräume

Durch ein Farbmodell werden Farben auf spezielle Weise in Form von Zahlen ausgedrückt, sodass sie von einem Computer verarbeitet werden können. In After Effects wird das RGB-Farbmodell verwendet, bei dem jede Farbe durch Rot-, Grün- und Blauwerte ausgedrückt wird, die durch Addition eine Farbe ergeben. Weitere Farbmodelle sind CMYK, HSB, YUV und XYZ.

Ein Farbraum ist eine Variante eines Farbmodells. Ein Farbraum ist durch einen Farbumfang, einen Satz von Primärfarben, einen Weißwert und eine Tonreaktion definiert. So gibt es z. B. innerhalb des RGB-Farbmodells verschiedene Farbräume (nach abnehmendem Farbumfang geordnet): ProPhoto RGB, Adobe RGB, sRGB IEC61966-2.1 und Apple RGB. In jedem dieser Farbräume werden Farben mithilfe derselben drei Achsen (R, G und B) definiert, ihr Farbumfang und ihre Tonreaktionskurven sind jedoch unterschiedlich.

Viele Geräte verwenden die Komponenten Rot, Grün und Blau zum Aufzeichnen oder Anzeigen von Farbe. Diese Komponenten können sich jedoch in ihren Eigenschaften unterscheiden, wodurch das Blau einer Kamera beispielsweise nicht genau dem Blau einer anderen Kamera entspricht. Jedes Gerät, das Farbe aufzeichnet oder anzeigt, verfügt über einen eigenen Farbraum. Wenn Sie ein Bild von einem Gerät auf ein anderes verschieben, können die Bildfarben plötzlich ganz anders aussehen, da jedes Gerät die RGB-Werte entsprechend dem eigenen Farbraum interpretiert.

Das Farbmanagement verwendet Farbprofile, um Farben von einem Farbraum in einen anderen zu konvertieren, damit die Farben auf allen Geräten gleich aussehen.

Gamma und Tonreaktion

Die Tonreaktion eines Farbraums ist das Verhältnis der Lichtstärke zum Signal, das das Licht erzeugt bzw. aufzeichnet (wahrnimmt).

Das menschliche Auge reagiert auf Licht nicht linear. Das heißt, wir nehmen eine Lichtquelle nicht als doppelt so hell wahr, wenn doppelt so viele Photonen in einem bestimmten Zeitraum auf unsere Augen treffen. Außerdem senden die Display-Elemente eines CRT-Bildschirms nicht doppelt so helles Licht aus, wenn doppelt so hohe elektrische Spannung angelegt wird. Das Verhältnis der Lichtstärke zur Signalstärke eines Anzeigegeräts wird durch eine Potenzfunktion ausgedrückt. Der Exponent dieser Potenzfunktion wird als Gamma bezeichnet. Das Verhältnis der Lichtstärke zur Signalstärke eines Eingabegeräts ist die Umkehrfunktion des Verhältnisses der Lichtstärke zur Signalstärke eines Ausgabegeräts. Zum Ausgleich der Unterschiede zwischen Szenenbeleuchtung und der Beleuchtung der Betrachtungsumgebung können die Gammawerte von Eingabe- und Ausgabegeräten jedoch voneinander abweichen.

Hinweis:

Das Verschieben des Mitteltonreglers (z. B. des Gamma-Reglers des Effekts „Tonwertkorrektur“) in einem Farbkorrektur-Histogramm hat dieselbe Auswirkung wie eine Änderung des Gammawerts: Es verändert die Tonreaktionskurve, ohne den Weißwert zu verschieben. Eine Veränderung der Kurve im Effekt „Kurven“ bewirkt ebenfalls eine Veränderung der Tonreaktionskurve, allerdings nicht unbedingt mit einer Gammakurve.

Charles Poynton bietet auf seiner Website ausgezeichnete Ressourcen zu Gamma und weiteren Farbtechnologien an.

Lineare Tonreaktion: Gamma gleich 1.

Bei Potenzierung einer Zahl mit 1 entspricht das Ergebnis der ursprünglichen Zahl. Ein Gammawert von 1,0 wird verwendet, um das Verhalten von Licht in der natürlichen Welt, außerhalb des Kontexts unserer nichtlinearen Wahrnehmung, auszudrücken. Ein System mit einem Gammawert von 1,0 verwendet ein so genanntes lineares Licht. Dagegen wird ein System mit einem Gammawert ungleich 1,0 zur Anpassung an die Eigenschaften des menschlichen Auges als perzeptiv bezeichnet.

Wenn Sie das Farbmanagement aktiviert haben (durch Angabe eines Arbeitsfarbraums), können Sie alle Farbänderungen bei linearem Licht vornehmen, indem Sie den Arbeitsfarbraum linearisieren. Ein linearisierter Farbraum verwendet dieselben Primärfarben und denselben Weißwert wie die nichtlineare Version. Es wird nur die Tonreaktionskurve zu einer geraden Linie begradigt.

Hinweis:

Viele Kompositionsoperationen, z. B. das Kombinieren von Farben mit Füllmethoden, können in einem linearen Farbraum effektiver durchgeführt werden. Arbeiten Sie daher in einem linearen Farbraum, um Farbfüllungen möglichst natürlich und realistisch umzusetzen. Wenn Sie das Farbmanagement nicht aktiviert haben, können Sie dennoch Füllvorgänge mit einem Gammawert von 1,0 durchführen. (Siehe Linearisieren des Arbeitsfarbraums und Aktivieren der linearen Füllmethode.)

Systemgamma, Gerätegamma und der Unterschied zwischen Szene und Betrachtungsumgebung

Der Gammawert für ein komplettes System (von der Aufnahme, über die Produktion bis zur Anzeige in der Betrachtungsumgebung) ist das Produkt der für die einzelnen Systemphasen verwendeten Gammawerte. Dieses Produkt ergibt nicht immer 1,0, wie es zu erwarten wäre, wenn die Kodierungsvorgänge genau den (umgekehrten) Dekodierungsvorgängen entsprächen. Ein Grund für ein vom Wert 1,0 abweichendes Systemgamma ist, dass sich die Beleuchtungsbedingungen der Szenenaufnahme oft von den Beleuchtungsbedingungen unterscheiden, unter denen die Szene betrachtet wird. (So wird ein Film in der Regel in einer verdunkelten Umgebung angesehen, während die Szenen normalerweise nicht in einer derartigen Umgebung aufgenommen werden.)

Das Gerätegamma für eine HD-Kamera beträgt z. B. etwa 1:1,9, während das Gerätegamma eines HD-Displays etwa 2,2 beträgt. Die Multiplikation dieser Werte ergibt ein Systemgamma von etwa 1,15. Dieser Wert ist für die in der Regel leicht verdunkelten Fernsehbedingungen in einem typischen Wohnzimmer angemessen. Bei der Produktion von Kinofilmen ist das Systemgamma wesentlich höher (etwa 1,5 bis 2,5), um den dunkleren Bedingungen eines Kinos zu entsprechen. Das Gamma für den Negativfilm liegt etwa bei 1:1,7, das Gamma für den Projektionsfilm etwa bei 3 bis 4.

Farbprofile werden als szenenbezogen bezeichnet, wenn die Tonreaktionskurven auf den Bedingungen in der typischen Szene basieren. Farbprofile werden als Ausgabenfarbprofile bezeichnet, wenn die Tonreaktionskurven auf den Bedingungen in der typischen Anzeigeumgebung basieren.

Mit Farbmanagement passt After Effects standardmäßig den Kontrast eines Bildes beim Konvertieren zwischen Szenen- und Ausgabenfarbprofilen automatisch an. Diese automatische Konvertierung (Anpassung des Bildzustands) basiert auf den im HDTV-Videostandard angegebenen Gamma-Werten.

  • Deaktivieren Sie diese automatische Farbtransformation, indem Sie im Dialogfeld unter „Datei“ > „Projekteinstellungen“ die Option „Szeneprofile ausgleichen“ auswählen.

Die Funktion „Szeneprofile ausgleichen“ ist auch in Adobe Photoshop CS4 und höher verfügbar, nicht jedoch in anderen Anwendungen. Um die Farben in anderen Anwendungen (einschließlich After Effects CS3 und früher) abzugleichen, deaktivieren Sie diese automatische Konvertierung. Wenn Sie ein Projekt öffnen, das in After Effects CS3 oder einer früheren Version erstellt wurde, ist die Option „Szeneprofile ausgleichen“ deaktiviert.

Jede Instanz des Farbprofilkonvertierungseffekts kann so eingestellt werden, dass Szeneprofile wahlweise ausgeglichen oder nicht ausgeglichen werden; alternativ kann die für das Projekt festgelegte Einstellung der Option „Szeneprofile ausgleichen“ verwendet werden. (Siehe Effekt „Farbprofil konvertieren“.)

Zusätzliche Informationen zum Ausgleich von Szeneprofilen finden Sie in diesem Blog-Post von Todd Kopriva und Peter Constable auf der Adobe-Website.

QuickTime und Gamma in Projekten ohne Farbverwaltung

In After Effects 7.0 und früheren Versionen wurden QuickTime-Codecs verwendet, um verschiedene Arten von Medien zu dekodieren. Unter Windows wurden von QuickTime andere Gamma-Anpassungen durchgeführt als unter Mac OS. Die in After Effects CS3 und höheren Versionen ausgeführten Gamma-Anpassungen unterscheiden sich von den Gamma-Anpassungen, die mit diesen QuickTime-Codecs vorgenommen wurden. Die Gamma-Anpassungen in After Effects CS3 und höheren Versionen unter Windows stimmen mit den Gamma-Anpassungen in After Effects CS3 und höheren Versionen unter Mac OS überein. Da in After Effects keine QuickTime-Codecs mehr verwendet werden, bleiben Extremwerte in 32-Bit-Projekten erhalten.

Um eines der folgenden Ergebnisse zu erzielen, wählen Sie im Dialogfeld „Projekteinstellungen“ die Option „QuickTime Gamma-Anpassung wie in früheren Versionen von After Effects“:

  • Vermeiden von Farbverschiebungen beim Arbeiten mit Projekten, die in After Effects 7.0 oder früher erstellt wurden

  • Verwenden derselben Farben wie in einem Projekt, das in After Effects 7.0 oder früher erstellt wurde

  • Sicherstellen, dass die Farben im Kompositionsfenster mit den Farben im QuickTime-Player übereinstimmen

Bei Projekten, die in After Effects 7.0 oder früheren Versionen erstellt wurden, ist die Option „QuickTime Gamma-Anpassung wie in früheren Versionen von After Effects“ standardmäßig aktiviert. Wenn Sie neue Projekte erstellen, sollten Sie diese Option nicht aktivieren.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie