Erstellen von Masken

Sie können für jede Ebene in einer Komposition eine oder mehrere Masken erstellen. Sie haben dabei folgende Möglichkeiten:

Wenn Sie Masken auf einer Ebene erstellen, werden die Maskennamen in der Ebenenliste des Zeitleistenfensters in der Reihenfolge angezeigt, in der die Masken erstellt wurden. Benennen Sie die Masken um, damit sie sich leichter verwalten lassen und Sie den Überblick behalten.

Hinweis:

Wenn eine Maske umbenannt werden soll, wählen Sie sie aus und drücken Sie die Eingabetaste (Windows) bzw. den Zeilenschalter (Mac OS) oder klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf den Namen und wählen Sie „Umbenennen“.

Achten Sie beim Erstellen zusätzlicher Masken für eine Ebene im Ebenenfenster darauf, dass das Menü „Ziel“ im Ebenenfenster auf „Ohne“ eingestellt ist. Andernfalls wird die als Ziel ausgewählte Maske ersetzt und keine neue Maske erstellt. Sie können eine Maske auch schützen, um Änderungen an der Maske zu verhindern.

Menüauswahl zum Festlegen einer Maske als Ziel im Ebenenfenster
Menüauswahl zum Festlegen einer Maske als Ziel im Ebenenfenster

A. Menü „Ansicht“ B. Menü „Ziel“ 

Achten Sie beim Erstellen oder Bearbeiten von Masken im Informationsfenster auf Informationen, beispielsweise auf den Maskennamen und die Anzahl der Scheitelpunkte in der Maske.

Hinweis:

Um eine Maske zu erstellen, die Sie unabhängig von der maskierten primären Ebene verschieben können, gehen Sie wie folgt vor:

  1. Erstellen Sie die Maske auf einer separaten weißen Farbflächenebene und verwenden Sie diese Farbflächenebene als bewegte Maske für die primäre Ebene.
  2. Erstellen Sie anhand der hierarchischen Anordnung aus der Farbflächenebene eine untergeordnete Ebene der primären Ebene, damit sich die Maske mit der primären Ebene bewegt, so als wäre sie direkt darauf angewendet. Da die Farbflächenebene eine untergeordnete Ebene ist, kann sie auch unabhängig vom übergeordneten Element animiert werden.
  3. Mit Motion-Tracking können Sie die Farbflächenebene (und somit die Maske) dazu veranlassen, beweglichen Objekten in der primären Ebene zu folgen. (Siehe Konvertieren einer Ebene in eine bewegte Maske und Über- und untergeordnete Ebenen.)

Numerisches Erstellen einer rechteckigen oder elliptischen Maske

  1. Wählen Sie im Kompositionsfenster eine Ebene aus oder zeigen Sie im Ebenenfenster eine Ebene an.
  2. Wählen Sie „Ebene“ > „Maskieren“ > „Neue Maske“. Im Kompositions- oder Ebenenfenster wird eine neue Maske mit Griffen an den Außenkanten des Rahmens angezeigt.
  3. Wählen Sie „Ebene“ > „Maskieren“ > „Maskenform“.
  4. Wählen Sie „Zurücksetzen auf“, wählen Sie im Menü „Form“ entweder „Rechteck“ oder „Ellipse“ und geben Sie die Größe und Position des Begrenzungsrahmens für die Maske an.

Erstellen einer Maske aus Kanalwerten mit dem Befehl „Pausstift“

  1. Mit dem Befehl „Pausstift“ können Sie den Alphakanal, den roten, grünen oder blauen Kanal oder den Luminanzkanal einer Ebene in eine oder mehrere Masken konvertieren.
  2. Mit dem Befehl „Pausstift“ werden so viele Bézier-Masken wie notwendig erstellt, um die angegebenen Kanalwerte mit einer Kontur zu versehen.
  3. Außerdem werden Masken mit der geringsten Anzahl Scheitelpunkte erstellt, die bei Einhaltung der von Ihnen gewählten Einstellungen möglich ist.
  4. Sie können eine mit dem Befehl „Pausstift“ erstellte Maske wie jede andere Maske ändern und ihren Pfad mithilfe von Expressions auch mit anderen Pfadtypen verknüpfen, beispielsweise mit Formenpfaden auf einer Formebene.

Wenn Sie „Pausstift“ anwenden, werden betroffene Ebenen automatisch auf „Beste Qualität“ eingestellt, um exakte Ergebnisse zu gewährleisten.

Hinweis:

Wenn Sie die Anzahl der mit dem Befehl „Pausstift“ erstellten Masken verringern möchten, wenden Sie vor dem Befehl „Pausstift“ einen Keying-Effekt auf die Ebene an, um Ihr Motiv zu isolieren.

  1. Führen Sie im Zeitleistenfenster einen der folgenden Schritte aus:
    • Wenn Sie bei einem einzelnen Frame Masken-Keyframes erstellen möchten, ziehen Sie die Zeitmarke für den aktuellen Zeitpunkt zu dem gewünschten Frame.
    • Wenn Sie in einem Bereich von Frames Masken-Keyframes erstellen möchten, legen Sie einen Arbeitsbereich fest, der sich über die gewünschten Frames erstreckt.
  2. Wählen Sie eine oder mehrere Ebenen aus.
  3. Wählen Sie „Ebene“ > „Pausstift“.
  4. Wählen Sie eine der folgenden Optionen:

    Aktueller Frame

    Erstellt nur Masken-Keyframes im aktuellen Frame.

    Arbeitsbereich

    Erstellt Masken-Keyframes für Frames innerhalb des Arbeitsbereichs.

  5. Legen Sie folgende Optionen fest:

    Umkehren

    Invertiert vor dem Suchen nach Kanten die Eingabeebene.

    Weichzeichnen

    Zeichnet vor dem Generieren des Pausstiftergebnisses das Originalbild weich. Wenn Sie diese Option aktivieren, werden im Pausstiftergebnis kleine Artefakte reduziert und gezackte Kanten geglättet. Wenn Sie diese Option deaktivieren, werden Details in einem Bild mit starken Kontrasten exakt nachgezeichnet. Legen Sie den Pixelradius des Weichzeichnungsbereichs fest. Höhere Werte bewirken eine stärkere Weichzeichnung.

    Toleranz

    Legt fest, wie weit (in Pixeln) der abgepauste Pfad von den Umrissen des Kanals abweichen darf.

    Schwellenwert

    Legt in Prozent fest, welchen Wert der Kanal eines Pixels haben muss, damit der Pixel als Kantenpixel betrachtet wird. Pixel mit Kanalwerten oberhalb des Schwellenwerts werden Weiß zugeordnet und sind deckend; Pixel mit Werten unterhalb des Schwellenwerts werden Schwarz zugeordnet und sind transparent.

    Mindestbereich

    Elemente bis zur hier angegebenen Größe werden im Originalbild abgepaust. Bei einem Wert von 4 werden beispielsweise alle Elemente aus dem Pausstift-Ergebnis entfernt, die weniger als 2 Pixel breit und 2 Pixel hoch sind.

    Eckenrundung

    Gibt die Rundheit der Maskenkurve an Scheitelpunkten an. Mit höheren Werten entstehen weich fließende Kurven.

    Auf neue Ebene anwenden

    Wendet die Maske auf eine neue Farbfläche an, die dieselbe Größe wie die ausgewählte Ebene hat. Bei Ebenen, für die „Transformationen falten“ aktiviert ist, wird diese Option automatisch aktiviert. Sie bewirkt die Erstellung einer neuen Ebene, die dieselbe Größe wie die Komposition hat, die die Ebene enthält.

    Vorschau

    Wählen Sie diese Option, um eine Vorschau der Maskenergebnisse und der Ergebnisse der verschiedenen Optionen des Befehls „Pausstift“ anzuzeigen.

Erstellen von Formen und Formebenen

Eine Formebene wird erstellt, indem Sie im Kompositionsfenster mit einem Formwerkzeug oder dem Zeichenstift zeichnen. Dann können Sie Formattribute zu vorhandenen Formen hinzufügen oder innerhalb dieser Formebene neue Formen erstellen. Wenn Sie bei ausgewählter Formebene im Kompositionsfenster zeichnen, wird innerhalb dieser Formebene standardmäßig eine neue Form erstellt, oberhalb der ausgewählten Formen bzw. der Gruppe von Formen. Wenn Sie im Kompositionsfenster mit einem Formwerkzeug oder dem Zeichenstift zeichnen, während eine andere Bildebene als eine Formebene ausgewählt ist, erstellen Sie eine Maske.

Hinweis:

Drücken Sie F2, um die Auswahl für alle Ebenen aufzuheben, bevor Sie im Kompositionsfenster zeichnen, um eine neue Formebene zu erstellen.

Formen und Formebenen lassen sich mit einer der folgenden Methoden erstellen:

Eine neue Form hat zumeist eine Fläche und eine Kontur, die mit den Einstellungen für Fläche und Kontur im Werkzeugfenster zu dem Zeitpunkt übereinstimmen, an dem die Form gezeichnet wird. Sie können dieselben Steuerungen im Werkzeugfenster verwenden, um diese Attribute für eine ausgewählte Form zu ändern, nachdem sie gezeichnet wurde. Aus Text erstellte Formen erhalten Flächen und Konturen, die mit denen des Originaltexts übereinstimmen.

Hinweis:

Wenn Sie eine Maske auf eine Formebene zeichnen möchten, klicken Sie im Werkzeugfenster bei aktiviertem Formwerkzeug oder Zeichenstift-Werkzeug auf die Schaltfläche „Werkzeug erstellt Maske“ . Weitere Informationen zum Erstellen von Masken finden Sie unter Erstellen von Masken.

Umwandeln von Vektorgrafik-Footage in Formen | CC, CS6

In früheren Versionen von After Effects war es möglich, eine Illustrator- (.ai), EPS- (.eps) oder PDF-Datei (.pdf) zu importieren. Änderungen an Dateien durften jedoch nicht vorgenommen werden.Man durfte jedoch keine Änderungen an der Datei vornehmen. Jetzt können Sie aus einer Vektorgrafik-Footage-Ebene eine Formebene erstellen und diese anschließend ändern.

Dank der Möglichkeit, in Objekte abzuschrägen und zu extrudieren, können Sie Grafiken ebenfalls extrudieren (z. B. extrudierte Logos). Siehe Extrudieren von Text- und Formebenen.

So wandeln Sie eine Vektorgrafik-Footage-Ebene in eine Formebene um:

  • Wählen Sie „Ebene“ > „Formen aus Vektorebene erstellen“. Eine entsprechende Formebene wird über der Footageebene angezeigt, und die Footageebene wird ausgeschaltet.

    Folgende Probleme sind bekannt:

    • Derzeit bleiben nicht alle Eigenschaften der Illustrator-Dateien erhalten. Beispiele: Deckkraft, Bilder und Verläufe.
    • Umgewandelte Formen ignorieren PAR-Überschreibungen, die im Dialogfenster „Footage interpretieren“ festgelegt wurden.
    • Verläufe und nicht unterstützte Typen werden möglicherweise als zu 50% graue Formen angezeigt.
    • Der Import von Dateien mit Tausenden von Pfaden kann unter Umständen sehr langsam sein und keine Rückmeldung geben.
    • Der Menübefehl kann immer nur jeweils auf eine einzelne ausgewählte Ebene angewandt werden.
    • Wenn Sie eine Illustrator-Datei als Komposition (d. h. mehrere Ebenen) importieren, können Sie alle diese Ebenen nicht in einem Durchgang konvertieren. Sie können die Datei jedoch als Footage importieren und dann den Befehl zum Umwandeln der einzelnen Footageebene in Formen verwenden.

Dieses Video von Todd Kopriva und video2brain veranschaulicht, wie Vektorgrafiken aus Illustrator schnell konvertiert werden können, um Ebenen zu formen und Pfade in After Effects CS6 zu animieren. Dieser Vorgang ist jetzt viel einfacher als in früheren Versionen von After Effects.

Erstellen einer Form oder Maske durch das Ziehen von Formwerkzeugen

Bei den Formwerkzeugen handelt es sich um die Werkzeuge „Rechteck , „Abgerundetes Rechteck“ , „Ellipse“ , „Polygon“  und „Stern“ .

Hinweis:

Drücken Sie die Taste „Q“, wenn Sie die Formwerkzeuge aktivieren und dazwischen wechseln möchten.

Ein Polygon ist ein Stern ohne die Eigenschaften „Innerer Radius“ oder „Innere Rundheit“, sodass der Name für ein Polygon oder einen Stern derselbe ist: Sternengruppe.

Sie können eine Maske erstellen, indem Sie im Kompositionsfenster oder im Ebenenfenster ein Formwerkzeug auf eine ausgewählte Ebene ziehen. Sie können eine Form erstellen, indem Sie im Kompositionsfenster oder im Ebenenfenster ein Formwerkzeug auf eine ausgewählte Ebene ziehen. Wenn Sie im Kompositionsfenster ein Formwerkzeug ziehen und keine Ebene ausgewählt ist, erstellen Sie eine Form auf einer neuen Formebene.

Hinweis:

Wenn Sie eine Maske auf eine Formebene zeichnen möchten, klicken Sie im Werkzeugfenster bei aktiviertem Formwerkzeug auf die Schaltfläche „Werkzeug erstellt Maske“ .

Wenn Sie eine Form erstellen, indem Sie im Kompositionsfenster ein Formwerkzeug ziehen, erstellen Sie einen parametrischen Formenpfad. Wenn Sie stattdessen einen Bézier-Formenpfad erstellen möchten, drücken Sie die Alt-Taste (Windows) oder Wahltaste (Mac OS), bevor Sie klicken, um mit dem Ziehen zu beginnen. Sie können die Taste loslassen, bevor Sie das Ziehen abgeschlossen haben. Alle Maskenpfade sind Bézier-Pfade. (Siehe Einführung in Formen und Formebenen.)

Das Ziehen beginnt, wenn Sie in das Kompositionsfenster bzw. Ebenenfenster klicken, um mit dem Zeichnen zu beginnen, und es endet, wenn Sie die Maustaste loslassen. Wenn Sie bei einem einzigen Zieh-Vorgang zu unterschiedlichen Zeiten Modifikatortasten drücken, erhalten Sie unterschiedliche Ergebnisse:

  • Wenn Sie eine Form oder Maske neu positionieren möchten, während Sie zeichnen, halten Sie beim Ziehen die Leertaste oder die mittlere Maustaste gedrückt.

  • Wenn Sie einen Kreis, eine Ellipse, ein Quadrat, ein abgerundetes Quadrat, ein Rechteck oder ein abgerundetes Rechteck während des Zeichnens von seinem Mittelpunkt ausgehend skalieren möchten, halten Sie die Strg-Taste (Windows) oder Befehlstaste (Mac OS) gedrückt, nachdem Sie mit dem Ziehen begonnen haben. Halten Sie die Taste gedrückt, bis Sie die Maustaste loslassen, um das Zeichnen zu beenden.

  • Drücken Sie Esc, um den Zeichenvorgang abzubrechen.

Hinweis:

Jedes Formwerkzeug behält die Einstellungen des letzten Zeichenvorgangs mit diesem Werkzeug bei. Wenn Sie beispielsweise einen Stern zeichnen und die Anzahl der Zacken in 10 ändern, hat der nächste Stern, den Sie zeichnen, ebenfalls 10 Zacken. Wenn Sie die Einstellungen eines Werkzeugs zurücksetzen und eine Form mit den Standardeinstellungen erstellen möchten, doppelklicken Sie im Werkzeugfenster auf das Werkzeug. (Siehe Erstellen einer Form oder Maske in der Größe der Ebene.)

Zeichnen von Rechtecken, abgerundeten Rechtecken, Quadraten und abgerundeten Quadraten

  1. Wählen Sie entweder das Rechteck-Werkzeug  oder das Abgerundetes-Rechteck-Werkzeug , und führen Sie einen der folgenden Schritte aus:
    • Wenn Sie ein Rechteck oder ein abgerundetes Rechteck zeichnen möchten, ziehen Sie die Maus diagonal.
    • Wenn Sie ein Quadrat oder ein abgerundetes Quadrat zeichnen möchten, halten Sie die Umschalttaste gedrückt, während Sie die Maus diagonal ziehen.
  2. (Optional) Wenn Sie ein abgerundetes Rechteck oder Quadrat zeichnen, tun Sie Folgendes, bevor Sie die Maustaste loslassen:
    • Um die Eckenrundung zu vergrößern bzw. zu verkleinern, drücken Sie die Nach-oben- bzw. die Nach-unten-Taste, oder rollen Sie das Mausrad vorwärts oder rückwärts.
    • Um für die Eckenrundung das Minimum oder Maximum einzustellen, drücken Sie die Nach-rechts- oder Nach-links-Taste.
  3. Lassen Sie die Maustaste los, um das Zeichnen zu beenden. Wenn Sie ein Quadrat oder ein abgerundetes Quadrat zeichnen, lassen Sie die Umschalttaste los, nachdem Sie die Maustaste losgelassen haben.

Hinweis:

Quadrate werden so erstellt, dass sie gemäß des Pixel-Seitenverhältnisses der Komposition quadratisch sind. Wenn das Pixel-Seitenverhältnis der Komposition nicht 1 ist, erscheinen Quadrate im Kompositionsfenster nur dann quadratisch, wenn die Schaltfläche „Pixel-Seitenverhältnis-Korrektur aktivieren/deaktivieren“ am unteren Rand des Kompositionsfensters ausgewählt ist.

Zeichnen von Ellipsen und Kreisen

  1. Aktivieren Sie das Ellipse-Werkzeug , und führen Sie einen der folgenden Schritte aus:
    • Wenn Sie eine Ellipse zeichnen möchten, ziehen Sie die Maus diagonal.
    • Wenn Sie einen Kreis zeichnen möchten, halten Sie die Umschalttaste gedrückt, während Sie die Maus diagonal ziehen.
  2. Lassen Sie die Maustaste los, um das Zeichnen zu beenden. Wenn Sie einen Kreis zeichnen, lassen Sie die Umschalttaste los, nachdem Sie die Maustaste losgelassen haben.

Hinweis:

Kreise werden so erstellt, dass sie gemäß des Pixel-Seitenverhältnisses der Komposition kreisförmig sind. Wenn das Pixel-Seitenverhältnis der Komposition nicht 1 ist, erscheinen Quadrate im Kompositionsfenster nur dann quadratisch, wenn die Schaltfläche „Pixel-Seitenverhältnis-Korrektur aktivieren/deaktivieren“ am unteren Rand des Kompositionsfensters ausgewählt ist.

Zeichnen von Polygonen und Sternen

  1. Wählen Sie entweder das Polygon-Werkzeug  oder das Stern-Werkzeug , und führen Sie einen der folgenden Schritte aus:
    • Ziehen Sie die Maus, um das Polygon bzw. den Stern während des Zeichnens zu skalieren.
    • Halten Sie beim Ziehen die Umschalttaste gedrückt, um das Polygon oder den Stern beim Zeichnen zu skalieren und eine Drehung zu verhindern.
  2. (Optional) Führen Sie Folgendes aus, bevor Sie die Maustaste loslassen:
    • Wenn Sie Zacken hinzufügen oder entfernen möchten, drücken Sie die Nach-oben- oder Nach-unten-Taste, oder rollen Sie das Mausrad vorwärts oder rückwärts.
    • Wenn Sie die äußere Rundheit vergrößern oder verkleinern möchten, drücken Sie die Nach-rechts- oder Nach-links-Taste.
    • Um den inneren Radius eines Sterns konstant zu halten, während Sie die Maus bewegen, um den äußeren Radius zu vergrößern, halten Sie die Strg-Taste (Windows) oder Befehlstaste (Mac OS) gedrückt.
    • Wenn Sie die innere Rundheit eines Sterns vergrößern oder verkleinern möchten, drücken Sie die Nach-oben- oder Nach-unten-Taste.
  3. Lassen Sie die Maustaste los, um das Zeichnen zu beenden. Wenn Sie beim Ziehen die Umschalttaste gedrückt halten, um eine Drehung zu vermeiden, lassen Sie die Umschalttaste los, nachdem Sie die Maustaste losgelassen haben.

Erstellen einer Bézier-Form oder -Maske mit dem Zeichenstift

Im Kompositionsfenster oder Ebenenfenster können Sie auf einer ausgewählten Ebene mit dem Zeichenstift eine Bézier-Maske erstellen. Im Kompositionsfenster können Sie auf einer ausgewählten Ebene mit dem Zeichenstift eine Form mit einem Bézier-Pfad erstellen. Wenn Sie im Kompositionsfenster mit dem Zeichenstift zeichnen und keine Ebene ausgewählt ist, erstellen Sie eine Form auf einer neuen Formebene.

Das Erstellen eines RotoBézier-Pfades ähnelt dem Erstellen eines manuellen Bézier-Pfades. Der Hauptunterschied besteht darin, dass die Grifflinien für Scheitelpunkte und die Krümmung der Pfadsegmente automatisch berechnet werden.

Erstellen eines manuellen Bézier-Pfades mit dem Zeichenstift

  1. Wenn im Werkzeugfenster der Zeichenstift ausgewählt und die Option „RotoBézier“ deaktiviert ist, klicken Sie im Kompositionsfenster an die Stelle, an der Sie den ersten Scheitelpunkt platzieren möchten.
  2. Klicken Sie auf die Stelle, an der der nächste Scheitelpunkt liegen soll. Wenn Sie ein gekrümmtes Segment erstellen möchten, ziehen Sie den Richtungsgriff, um die gewünschte Kurvenform zu erstellen.

    Hinweis:

    Wenn Sie einen Scheitelpunkt neu positionieren möchten, nachdem Sie zum Platzieren darauf geklickt, doch bevor Sie die Maustaste losgelassen haben, halten Sie beim Ziehen die Leertaste gedrückt.

    Der letzte Scheitelpunkt, den Sie hinzufügen, wird als immer ausgefülltes Quadrat und somit als markierter Punkt angezeigt. Zuvor hinzugefügte Scheitelpunkte werden leer und deaktiviert angezeigt, wenn Sie weitere Scheitelpunkte hinzufügen.

  3. Wiederholen Sie Schritt 2 so oft, bis Sie die Pfaderstellung abschließen möchten.
  4. Schließen Sie die Pfaderstellung ab, indem Sie einen der folgenden Schritte ausführen:
    • Um den Pfad zu schließen, platzieren Sie den Zeiger über dem ersten Scheitelpunkt. Klicken Sie auf diesen Scheitelpunkt, sobald neben dem Zeiger ein Kreissymbol  angezeigt wird.

    Hinweis:

    Sie können einen Pfad auch schließen, indem Sie den letzten Scheitelpunkt doppelklicken oder „Ebene“ > „Maske und Formenpfad“ > „Geschlossen“ wählen.

    • Wenn Sie den Pfad offen lassen möchten, aktivieren Sie ein anderes Werkzeug, oder drücken Sie F2, um die Auswahl für den Pfad aufzuheben.

Zeichnen gerader manueller Bézier-Pfadsegmente mit dem Zeichenstift

Der einfachste Pfad, den Sie mit dem Zeichenstift-Werkzeug erstellen können, ist eine gerade Linie. Setzen Sie dazu durch Klicken mit dem Zeichenstift zwei Scheitelpunkte. Wenn Sie erneut klicken, erstellen Sie einen Pfad, der aus geraden, durch Eckpunkte miteinander verbundenen Liniensegmenten besteht.

Gerade Segmente werden durch Klicken mit dem Zeichenstift-Werkzeug erstellt
Gerade Segmente werden durch Klicken mit dem Zeichenstift-Werkzeug erstellt.

  1. Platzieren Sie den Zeichenstift an der Stelle, an der das gerade Segment beginnen soll. Klicken Sie, um einen Scheitelpunkt zu platzieren. (Ziehen Sie die Maus nicht.)
  2. Klicken Sie an die Stelle, an der das Segment enden soll. (Klicken Sie bei gedrückt gehaltener Umschalttaste, um den Winkel am Eckpunkt zwischen den Segmenten auf ein ganzes Vielfaches von 45° zu beschränken.)
  3. Setzen Sie durch weiteres Klicken Scheitelpunkte für zusätzliche gerade Segmente.

Zeichnen gekrümmter manueller Bézier-Pfadsegmente mit dem Zeichenstift

Ein gekrümmtes Pfadsegment wird erstellt, indem Sie Grifflinien zeichnen. Die Form der Krümmung wird durch die Länge und Richtung der Grifflinien bestimmt.

Hinweis:

Halten Sie beim Ziehen die Umschalttaste gedrückt, um den Winkel der Grifflinien auf ganze Vielfache von 45° zu beschränken. Halten Sie beim Ziehen die Alt-Taste (Windows) oder Wahltaste (Mac OS) gedrückt, um nur die ausgehende Grifflinie zu ändern.

  1. Positionieren Sie den Zeichenstift an der Stelle, an der die Kurve beginnen soll, und halten Sie die Maustaste gedrückt.

    Ein Scheitelpunkt wird angezeigt, und der Zeiger des Zeichenstifts verwandelt sich in eine Pfeilspitze.

  2. Ziehen Sie die Maus, um die Länge und Richtung beider Grifflinien für einen Scheitelpunkt zu ändern, und lassen Sie dann die Maustaste los.
    Zeichnen des ersten Scheitelpunkts in einem gekrümmten Pfad
    Zeichnen des ersten Scheitelpunkts in einem gekrümmten Pfad

    A. Platzieren des Zeichenstift-Werkzeugs B. Beginn des Ziehens (Maustaste gedrückt) C. Grifflinie auf gewünschte Länge ziehen 
  3. Setzen Sie das Zeichenstift-Werkzeug auf den Punkt, an dem das Kurvensegment enden soll, und führen Sie einen der folgenden Schritte aus:
    • Wenn Sie eine C-förmige Krümmung erstellen möchten, ziehen Sie in die entgegengesetzte Richtung, in der Sie die vorherige Grifflinie gezogen haben, und lassen Sie die Maustaste los.
    Zeichnen des zweiten Scheitelpunkts in einem gekrümmten Pfad
    Zeichnen des zweiten Scheitelpunkts in einem gekrümmten Pfad

    A. Beginn des Ziehens B. Von der vorherigen Grifflinie weg ziehen, um eine C-Krümmung zu erstellen C. Ergebnis nach dem Loslassen der Maustaste 
    • Wenn Sie eine S-förmige Krümmung erstellen möchten, ziehen Sie in dieselbe Richtung wie die vorherige Grifflinie, und lassen Sie dann die Maustaste los.
    S-Kurve zeichnen
    S-Kurve zeichnen

    A. Beginn des Ziehens B. In derselben Richtung wie die vorhergehende Grifflinie ziehen, um eine S-Kurve zu erstellen C. Ergebnis nach dem Loslassen der Maustaste 
  4. Wenn Sie das Zeichenstift-Werkzeug weiter von verschiedenen Positionen aus ziehen, erstellen Sie eine Reihe glatter Kurven.

Erstellen einer Form oder Maske in der Größe der Ebene

  1. Wählen Sie das Ziel für die neue Maske oder Form aus:
    • Wenn Sie eine Form auf einer vorhandenen Formebene erstellen möchten, wählen Sie die Formebene aus.
    • Wenn Sie eine Form mit den Abmessungen der Komposition auf einer neuen Formebene erstellen möchten, heben Sie die Auswahl für alle Ebenen auf, indem Sie F2 drücken.
    • Wenn Sie eine Maske erstellen möchten, wählen Sie im Zeitleistenfenster, Ebenenfenster oder Kompositionsfenster eine Ebene aus. Wenn Sie eine Maske auf einer Formebene erstellen möchten, wählen Sie im Werkzeugfenster bei aktiviertem Formwerkzeug die Option „Werkzeug erstellt Maske“ .
    • Wenn Sie einen Maskenpfad ersetzen möchten, wählen Sie die Maske im Zeitleistenfenster, Ebenenfenster oder Kompositionsfenster aus.
    • Wenn Sie einen Formenpfad ersetzen möchten, wählen Sie den Formenpfad (nicht die Gruppe) im Kompositionsfenster oder im Zeitleistenfenster aus.
  2. Doppelklicken Sie im Werkzeugfenster auf das Werkzeug Rechteck , Abgerundetes Rechteck , Ellipse , Polygon oder Stern .

Erstellen von Formen und Masken aus Textzeichen

Mit dem Befehl „Formen aus Text erstellen“ werden für jedes Zeichen die Konturen extrahiert, Formen aus den Konturen erstellt und die Formen auf einer neuen Formebene platziert. Sie können diese Formen dann wie jede andere Form verwenden.

Mit dem Befehl „Masken aus Text erstellen“ werden für jedes Zeichen die Konturen extrahiert, Masken aus den Konturen erstellt und die Masken auf einer neuen Farbflächenebene platziert. Sie können diese Masken dann wie jede andere Maske verwenden.

Hinweis:

Einige Schriftfamilien, z. B. Webdings, enthalten Zeichen, die eher Grafiken als Text sind. Das Konvertieren von Text aus diesen Schriftfamilien ist eine gute Methode, um mit einfachen Grafikelementen in Formebenen zu beginnen.

Erstellen von Formen aus Text

  1. Wählen Sie den Text aus, der in Formen konvertiert werden soll:
    • Wenn Sie für alle Zeichen in einer Textebene Formen erstellen möchten, wählen Sie die Textebene im Zeitleistenfenster oder im Kompositionsfenster aus.
    • Wenn Sie für bestimmte Zeichen Formen erstellen möchten, wählen Sie die Zeichen im Kompositionsfenster aus.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie „Ebene“ > „Formen aus Text erstellen“.
    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf die Ebene oder den Text und wählen Sie im Kontextmenü „Formen aus Text erstellen“.

Der Schalter „Video“  für die Textebene ist deaktiviert.

Die neue Formebene wird oben auf der Stapelreihenfolge von Ebenen erstellt. Die neue Ebene enthält eine Formgruppe für jedes ausgewählte Zeichen sowie Füll- und Kontureigenschaften, die mit denen des Texts übereinstimmen.

Bei Zeichen, die aus zusammengesetzten Pfaden bestehen, z. B. i und e, werden mehrere Pfade erstellt und mit dem Pfad-Vorgang „Pfade zusammenführen“ kombiniert.

Effekte, Masken, Ebenenstile sowie Keyframes und Expressions für Eigenschaften in der Eigenschaftsgruppe „Transformieren“ der Textebene werden in die neue Formebene oder Farbflächenebene kopiert.

Erstellen von Masken aus Text

  1. Wählen Sie den Text aus, der in Masken konvertiert werden soll:
    • Wenn Sie für alle Zeichen in einer Textebene Masken erstellen möchten, wählen Sie die Textebene im Zeitleistenfenster oder im Kompositionsfenster aus.
    • Wenn Sie für bestimmte Zeichen Masken erstellen möchten, wählen Sie die Zeichen im Kompositionsfenster aus.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie „Ebene“ > „Masken aus Text erstellen“.
    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf die Ebene oder den Text und wählen Sie im Kontextmenü „Masken aus Text erstellen“.

Der Schalter „Video“  für die Textebene ist deaktiviert.

Die neue Farbflächenebene wird oben auf der Stapelreihenfolge von Ebenen erstellt.

Bei Zeichen, die aus zusammengesetzten Pfaden bestehen, z. B. i und e, werden mehrere Masken erstellt und mit dem Maskenmodus „Subtrahieren“ kombiniert.

Kopieren eines Pfades aus Illustrator, Photoshop oder Fireworks

Sie können einen Pfad aus Illustrator, Photoshop oder Fireworks kopieren und als Maskenpfad oder Formenpfad in After Effects einfügen.

Damit die aus Illustrator kopierten Daten mit After Effects kompatibel sind, muss in Adobe Illustrator im Dialogfeld „Voreinstellungen“ im Bereich „Dateien und Zwischenablage“ die Option „AICB“ aktiviert sein.

Damit ein aus Photoshop importierter Pfad ordnungsgemäß skaliert wird, muss das Photoshop-Dokument eine Auflösung von 72 dpi aufweisen. Dies ist die Auflösungseinstellung von Dokumenten, die in Photoshop mit einer Film- und Videovorgabe erstellt wurden.

Hinweis:    Sie können einen kopierten Illustrator-, Photoshop- oder Fireworks-Pfad auch als After Effects-Bewegungspfad verwenden. Weitere Informationen finden Sie unter Bewegungspfade.

In Adobe Illustrator gezeichneter Pfad (links) und in After Effects als Maske eingefügter Pfad (rechts)
In Adobe Illustrator gezeichneter Pfad (links) und in After Effects als Maske eingefügter Pfad (rechts)

  1. Wählen Sie in Illustrator, Photoshop oder Fireworks einen ganzen Pfad aus, und wählen Sie dann „Bearbeiten“ > „Kopieren“.
  2. Führen Sie in After Effects einen der folgenden Schritte aus, um ein Ziel für den Einfügevorgang festzulegen:
    • Zum Erstellen einer neuen Maske wählen Sie eine Ebene aus.
    • Zum Ersetzen eines vorhandenen Maskenpfads oder Formenpfads wählen Sie dessen Pfadeigenschaft aus.

    Hinweis:

    Zum Einfügen eines Pfads als Formenpfad müssen Sie die Pfadeigenschaft einer vorhandenen Form in einer Formebene auswählen. Durch diese Auswahl erkennt After Effects das Ziel des Einfügevorgangs. Sollte das Ziel nicht auf diese Weise festgelegt werden, geht After Effects davon aus, dass die gesamte Ebene als Ziel dient und erstellt deshalb eine neue Maske. Liegt keine Pfadeigenschaft vor, weil beispielsweise die Formenebene leer ist, können Sie mit dem Zeichenstift-Werkzeug einen Platzhalterpfad zeichnen und den Pfad von Illustrator anschließend dort einfügen.

  3. Wählen Sie „Bearbeiten“ > „Einfügen“ (Windows) bzw. „Bearbeiten“ > „Einsetzen“ (Mac OS).

    Wenn Sie mehrere Pfade in einen Formenpfad einfügen, wird der erste Pfad in den Formenpfad eingefügt, während die anderen Pfade in neue Maskenpfade eingefügt werden. Das liegt daran, dass die restlichen Pfade im Gegensatz zum ersten kein klar definiertes Ziel aufweisen. Deshalb werden sie der gesamten Ebene als Masken hinzugefügt.

Andrew Devis zeigt in diesem Video auf der Creative COW-Website, wie Pfade aus Illustrator als Bewegungspfade in After Effects verwendet werden.

Erstellen einer Maske oder Form aus einem Bewegungspfad

Sie können Positions-Keyframes, Ankerpunkt-Keyframes oder Positions-Keyframes eines Effektsteuerungspunkts kopieren und diese Keyframes in den Pfad ausgewählter Masken oder Formen einfügen. Achten Sie beim Erstellen von Masken- oder Formenpfaden aus Bewegungspfaden darauf, dass Sie nur Keyframes einer einzigen Positionseigenschaft kopieren, und nicht die Keyframes einer anderen Eigenschaft.

Hinweis:

Zeichnen Sie einen Bewegungspfad mit „Bewegung skizzieren“ und fügen Sie diesen Pfad in einen Maskenpfad oder Formenpfad ein.

Erstellen einer Maske oder Form aus einem Bewegungspfad
Der Bewegungspfad des Raumschiffs (oben) wird auf die Hintergrundebene kopiert (unten links) und vom Effekt „Vegas“ (unten rechts) verwendet.

Hinweis:

Denken Sie beim Kopieren von einem Maskenpfad zu einem Bewegungspfad daran, dass die Werte des Maskenpfads im Koordinatensystem der Ebene (Ebenen-Raum) definiert sind, während die Werte des Bewegungspfads im Koordinatensystem der Komposition (Kompositions-Raum) definiert sind. Aufgrund dieses Unterschieds ist der eingefügte Pfad möglicherweise versetzt, sodass Sie ihn nach dem Einfügen neu positionieren müssen. (Siehe Koordinatensysteme: Kompositions-Raum und Ebenen-Raum.)

Erstellen eines Maskenpfads aus einem Bewegungspfad

  1. Klicken Sie im Zeitleistenfenster auf den Namen der Eigenschaft „Position“ oder „Ankerpunkt“, deren Bewegungspfad Sie kopieren möchten. (Hiermit werden alle Keyframes ausgewählt. Klicken Sie bei gedrückter Umschalttaste, um nur einige Keyframes eines Bewegungspfades auszuwählen.)
  2. Wählen Sie „Bearbeiten“ > „Kopieren“.
  3. Wenn Sie eine neue Maske erstellen möchten, wählen Sie die Ebene aus, auf der Sie die Maske erstellen möchten und klicken Sie anschließend auf „Ebene“ > „Maske“ > Neue Maske.
  4. Klicken Sie im Zeitleistenfenster der Maske, in die Sie die Keyframes des Bewegungspfades einfügen möchten, auf den Namen der Eigenschaft „Maskenpfad“.
  5. Wählen Sie „Bearbeiten“ > „Einfügen“ (Windows) bzw. „Bearbeiten“ > „Einsetzen“ (Mac OS).
    Auswählen und Kopieren von Keyframes für die Eigenschaft „Position“
    Auswählen und Kopieren von Keyframes für die Position (links) und anschließendes Einfügen in die ausgewählte Eigenschaft „Maskenpfad“ (rechts)

Erstellen eines Formenpfads aus einem Bewegungspfad

  1. Klicken Sie im Zeitleistenfenster auf den Namen der Eigenschaft „Position“ oder „Ankerpunkt“, deren Bewegungspfad Sie kopieren möchten. (Hiermit werden alle Keyframes ausgewählt. Klicken Sie bei gedrückter Umschalttaste, um nur einige Keyframes eines Bewegungspfades auszuwählen.)
  2. Wählen Sie „Bearbeiten“ > „Kopieren“.
  3. Wenn Sie eine neue Formebene erstellen möchten, drücken Sie F2, um die Auswahl aller Ebenen aufzuheben, und klicken Sie anschließend mit dem Zeichenstift-Werkzeug in das Kompositionsfenster, um einen Bézier-Pfad für einen bestimmten Punkt zu erstellen.
  4. Drücken Sie zweimal die Taste „S“, um die Eigenschaft „Pfad“ der Form anzuzeigen. Klicken Sie auf den Namen der Eigenschaft „Pfad“, in die Sie die Keyframes des Bewegungspfades einfügen möchten.
  5. Wählen Sie „Bearbeiten“ > „Einfügen“ (Windows) bzw. „Bearbeiten“ > „Einsetzen“ (Mac OS).

Duplizieren einer Formgruppe während der Transformation

Wenn im Gruppenauswahlmodus eine Formgruppe ausgewählt ist, können Sie die Gruppe duplizieren, während Sie sie im Kompositionsfenster verschieben, drehen oder skalieren.

  • Halten Sie die Alt-Taste (Windows) oder Wahltaste (Mac OS) gedrückt, während Sie die Maus ziehen, um eine Gruppe zu transformieren.

    Der Zeiger nimmt die Form eines Duplizierungszeigers ( oder ) an, während Sie die Taste gedrückt halten und den Zeiger in der Nähe des Gruppentransformationsfeldes platzieren.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™ und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie