Benutzerhandbuch Abbrechen

Arbeitsspeicher und Speicherung

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
    3. Funktionen in der Beta-Version
      1. Bedienfeld „Eigenschaften“ (Beta)
      2. Wählbare Spurmasken-Ebenen (Beta)
      3. Native H.264-Codierung (Beta)
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
    10. Einrichtung und Installation
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formenpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle und Masken
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Farb-Management
    3. Effekte zur Farbkorrektur
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekte unter „Simulation“
    4. Effekte unter „Stilisieren“
    5. Effekte unter „Audio“
    6. Effekte unter „Verzerren“
    7. Effekte unter „Perspektive“
    8. Effekte unter „Kanäle“
    9. Effekte unter „Generieren“
    10. Effekte unter „Überblenden“
    11. Der Effekt „Rolling-Shutter-Reparatur“
    12. Effekte unter „Weich- und Scharfzeichnen“
    13. Effekte unter „3D-Kanal“
    14. Effekte unter „Dienstprogramm“
    15. Effekte unter „Matt“
    16. Effekte unter „Störung und Körnung“
    17. Effekt „Hochskalieren mit Detailerhaltung“
    18. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Ausdruck
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Expression-Sprachreferenz
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Tracking der 3D-Kamerabewegung
    5. Arbeiten im 3D-Designraum
    6. 3D-Transformations-Gizmos
    7. Machen Sie mehr mit 3D-Animation
    8. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Real-Time Engine
    9. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    3. Konvertieren von Filmen
    4. Multi-Frame-Rendering
    5. Automatisches Rendern und Netzwerk-Rendern
    6. Rendern und Exportieren von Standbildern und Standbildsequenzen
    7. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. CINEMA 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Frame.io installieren und aktivieren
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau behandelt    
    3. Verbessern der Leistung
    4. Voreinstellungen
    5. Anforderungen an GPU und GPU-Treiber für After Effects

Verwendung von Arbeitsspeicher (RAM) in After Effects (64-Bit)

Speicher-Voreinstellungen

Legen Sie Voreinstellungen für den Arbeitsspeicher fest, indem Sie Bearbeiten > Voreinstellungen > Speicher (Windows) oder After Effects > Voreinstellungen > Speicher (macOS) auswählen.

Wenn Sie die Einstellungen im Dialogfeld „Arbeitsspeicher“ ändern, aktualisiert After Effects den Hilfetext im Dialogfeld dynamisch und meldet, wie der Arbeitsspeicher und die CPUs zugeordnet und verwendet werden.

Die Voreinstellung „Für andere Anwendungen reservierter RAM“ ist unabhängig davon relevant, ob die Option „Mehrere Frames gleichzeitig rendern“ ausgewählt wurde.

Für andere Anwendungen reservierter RAM

Erhöhen Sie diesen Wert, damit für das Betriebssystem und andere Applikationen sowie für die Applikation, die sich im selben Speicherbereich wie After Effects befindet, eine höhere RAM-Kapazität zur Verfügung steht. Wenn Sie wissen, dass Sie neben After Effects eine bestimmte andere Anwendung verwenden werden, prüfen Sie deren Systemanforderungen und stellen diesen Wert auf mindestens das Minimum des für diese Anwendung erforderlichen RAM ein. Da die Leistung am besten ist, wenn ausreichend Speicher für das Betriebssystem zur Verfügung steht, können Sie diesen Wert nicht unter einen minimalen Basiswert setzen.

Von After Effects, Premiere Pro, Prelude, Media Encoder, Photoshop, und Audition gemeinsam verwendeter Speicherbereich

After Effects verwendet denselben Speicherbereich wie andere Adobe CC-Anwendungen. Dies wird im Voreinstellungsfenster für den Arbeitsspeicher durch die Symbole der einzelnen Anwendungen im oberen Bereich des Fensters angezeigt. Die Symbole aktuell ausgeführter Anwendungen werden verdunkelt dargestellt.

Ein Speicherausgleicher verhindert durch die dynamische Verwaltung des Speichers aller einzelnen Anwendungen den Austausch von RAM-Speicher zur Festplatte. Der Speicherausgleicher verfügt für jede Anwendung über die folgenden Basisinformationen: Mindestarbeitsspeicheranforderungen, maximal verwendbare Arbeitsspeicherkapazität, aktuell verwendeter Speicher und Priorität. Für die Priorität sind drei Einstellungen möglich: niedrig, normal und hoch. Die höchste Prioritätseinstellung ist gegenwärtig für After Effects und Premiere Pro reserviert, wenn diese Anwendungen aktiv sind. Normal ist für After Effects als Hintergrundanwendung oder Adobe Media Encoder als Vordergrundanwendung bestimmt. Die niedrige Prioritätseinstellung ist für Hintergrund-Server von Premiere Pro oder Adobe Media Encoder bestimmt, die im Hintergrund laufen.

Hinweis:

Ein Beispiel für ein praktisches Ergebnis der Verwendung eines gemeinsamen Speicherbereichs ist, dass sich die für Vorschauen in After Effects verfügbare RAM-Kapazität beim Starten von Premiere Pro verringert; beim Beenden von Premiere Pro wird sofort RAM-Speicher für After Effects frei, wodurch sich die mögliche Dauer für Vorschauen verlängert.

Dialogfeld „Speicher“

Das Dialogfeld „Detailangaben zum Arbeitsspeicher“ enthält zusätzliche Informationen zum installierten RAM-Speicher und der aktuellen und zulässigen RAM-Verwendung. Es enthält auch eine mehrspaltige Tabelle, in der die mit den Anwendungen zusammenhängenden Prozesse aufgeführt sind. Die Tabelle enthält Informationen zu den einzelnen Prozessen, z. B. ID, Programmname, benötigter Mindestarbeitsspeicher, maximal verwendbarer Arbeitsspeicher, maximal zulässiger Arbeitsspeicher, aktueller Arbeitsspeicher und aktuelle Priorität.

Klicken Sie zum Öffnen des Dialogfelds auf Bearbeiten > Voreinstellungen > Speicher (Windows) oder After Effects > Voreinstellungen > Speicher (macOS) und klicken Sie dann unten im Dialogfeld „Einstellungen“ auf die Schaltfläche „Details“.

Sie können die Informationen mit der Schaltfläche Kopieren in die Zwischenablage kopieren.

Speicheranforderungen (RAM) für das Rendern

Die Arbeitsspeicheranforderungen zum Rendern eines Frames (zur Vorschau oder Endausgabe) erhöhen sich mit der Arbeitsspeicheranforderung der arbeitsspeicherintensivsten Ebene in der Komposition.

Frames in einer Komposition werden von After Effects ebenenweise gerendert. Aus diesem Grund ist die Arbeitsspeicheranforderung der einzelnen Ebenen bei der Bestimmung, ob ein vorhandener Frame mit dem verfügbaren Arbeitsspeicher gerendert werden kann, relevanter als die Dauer der Komposition oder die Anzahl der Ebenen in der Komposition. Die Menge des für eine Komposition benötigten Arbeitsspeichers entspricht der Menge des Arbeitsspeichers, der für die speicherintensivste Einzelebene in der Komposition erforderlich ist.

Die Arbeitsspeicheranforderungen eines Layers erhöhen sich unter bestimmten Bedingungen, z. B. durch:

  • Erhöhung der Farb-Bit-Tiefe des Projekts

  • Erhöhung der Kompositionsauflösung

  • Verwenden eines größeren Quellbildes

  • Aktivieren von Farbmanagement

  • Hinzufügen einer Maske

  • Hinzufügen von 3D-Eigenschaften pro Zeichen

  • Unterkomponieren ohne Zuklappen der Transformationen

  • Anwenden von bestimmten Füllmethoden, Ebenenstilen oder Effekten, insbesondere Effekten mit mehreren Ebenen

  • Anwenden von bestimmten Ausgabeoptionen wie z. B. 3:2 Pulldown, Beschneiden und Größenänderung

  • Hinzufügen von Schatten- oder Tiefenschärfeeffekten bei der Verwendung von 3D-Ebenen

In After Effects muss jeder Frame in einem zusammenhängenden Speicherblock gespeichert werden. Das verteilte Speichern in einzelnen Speicherfragmenten ist nicht möglich. Für Informationen Informationen dazu, wie viel RAM zum Speichern eines unkomprimierten Frames erforderlich ist, siehe Speicher Anforderungen an Ausgabedateien.

Hinweis:

Tipps zum Verringern der Speicheranforderungen und Steigern der Leistung finden Sie unter Verbessern der Leistung durch Vereinfachung des Projekts.

Freigeben von Arbeitsspeicher (RAM)

Eventuell weist After Effects Sie in einer Warnmeldung darauf hin, dass zum Anzeigen oder Rendern einer Komposition mehr Arbeitsspeicher benötigt wird. Wenn eine solche Warnmeldung angezeigt wird, geben Sie Speicherplatz frei oder reduzieren Sie die Arbeitsspeicheranforderungen der speicherintensivsten Ebenen. Versuchen Sie es dann erneut.

Sie können mithilfe der Befehle im Menü „Bearbeiten“ > „Entleeren“ sofort Speicherplatz freigeben:

  • Gesamter Speicher
  • Bild-Cache-Speicher
  • Gesamter Speicher und Disk-Cache
  • Letzte Aktion rückgängig machen
  • Schnappschuss

Das Freigeben von Arbeitsspeicher nimmt bei größeren Projekten weniger Zeit in Anspruch. Beim Freigeben von Arbeitsspeicher wird die Projektdatenbank nicht synchronisiert. Wenn Sie die Synchronisierung der Projektdatenbank erzwingen möchten, drücken Sie die Wahl- (Mac OS) bzw. Alt-Taste (Windows) und wählen Sie „Bearbeiten“ > „Entleeren“ > „Gesamter Speicher“. Sie können diesen Vorgang durchführen, wenn Sie feststellen, dass das Bedienfeld „Komposition“ nicht korrekt aktualisiert wird, und der Befehl „Entleeren“ > „Gesamter Speicher“ bzw. „Gesamter Speicher und Disk-Cache“ nicht funktioniert.

Fehlerbehebung bei Problemen mit dem Arbeitsspeicher

Fehler: „Für das Rendern des aktuellen Frames kann nicht genügend Speicher zugewiesen werden...“

Verringern Sie entweder die Speicheranforderungen für das Rendern dieses Frames oder installieren Sie weiteren RAM.

Fehler: „[n] MB Speicher können nicht zugewiesen werden...“

Verringern Sie entweder die Speicheranforderungen für das Rendern dieses Frames oder installieren Sie weiteren RAM.

Fehler: „Bildpuffer der Größe [Breite]x[Höhe] @ [Tiefe] Bit pro Kanal ([n] GB) überschreiten die internen Beschränkungen...“

Senken Sie die Speicheranforderungen zum Rendern dieses Frames.

Hinweis:

Die maximale von einem Frame belegbare Speicherkapazität beträgt 2 GB.

Fehler: „Eine Speicherzuweisung von [n] GB überschreitet die internen Beschränkungen...“

Senken Sie die Speicheranforderungen zum Rendern dieses Frames.

Hinweis:

Die maximale Größe für eine einzelne Speicherzuweisung liegt bei 2 GB.

Speicheranforderungen für Ausgabedateien

Ermitteln Sie anhand der folgenden Formel, wie viel MB Arbeitsspeicher (RAM) erforderlich sind, um einen nicht komprimierten Frame mit voller Auflösung zu speichern:

(Höhe in Pixel) x (Breite in Pixel) x (Bit pro Kanal) / 2.097.152

Hinweis:

Der Wert 2.097.152 ist ein Konvertierungsfaktor, der die Byte pro Megabyte (220), die Bit pro Byte (8) und die Kanäle pro Pixel (4) berücksichtigt.

Nachstehend werden einige Beispiele für Frame-Größen und Speicheranforderungen in Megabyte (MB) pro Frame genannt:

  • DV NTSC (720x480)-Frame in einem Projekt mit 8 Bit pro Kanal: 1,3 MB

  • D1/DV PAL (720x576)-Frame in einem Projekt mit 8 Bit pro Kanal: 1,6 MB

  • HDTV (1920x1080)-Frame in einem Projekt mit 16 Bit pro Kanal: 16 MB

  • 4K Digital Cinema (4096x2304)-Frame in einem Projekt mit 32 Bit pro Kanal: 144 MB

Da Video in der Regel durch die Kodierung beim Rendern der Endausgabe komprimiert wird, können Sie den für einen einzelnen Frame erforderlichen Arbeitsspeicher nicht einfach mit der Framerate und Kompositionsdauer multiplizieren, um den Festplattenspeicher zu ermitteln, den Sie zur Speicherung des fertigen Films benötigen. Durch eine solche Berechnung erhalten Sie jedoch einen Richtwert bezüglich des u. U. maximal erforderlichen Speicherplatzes. Für eine Sekunde (ca. 30 Frames) eines unkomprimierten Standard Definition 8-Bit-Videos sind etwa 40 MB erforderlich. Ein abendfüllender Film mit einer solchen Datenrate würde einen Speicherplatz von mehr als 200 GB benötigen. Selbst mit DV-Kompression, wodurch die Dateigröße auf 3,6 MBit/s Video reduziert wird, sind damit für einen typischen abendfüllenden Film immer noch mehr als 20 GB erforderlich.

Für ein Spielfilmprojekt ist es aufgrund der höheren Farbtiefe, der größeren Frames und der deutlich geringeren Kompressionsverhältnisse nicht ungewöhnlich, dass zum Speichern des Footage und der gerenderten Filme sogar Terabytes für die Speicherung erforderlich sind.

Caches: RAM-Cache, Disk-Cache und Medien-Cache

Beim Arbeiten an einer Komposition speichert After Effects einige der gerenderten Frames und Quellbilder zeitweise im RAM, um die Vorschau und Bearbeitung zu beschleunigen. Frames, die schnell gerendert werden können, werden in After Effects nicht zwischengespeichert. Die Frames verbleiben unkomprimiert im Bildcache.

In After Effects werden auch Footageelemente und die einzelnen Ebenen zwischengespeichert, um eine schnellere Vorschau zu ermöglichen. Veränderte Ebenen werden während der Vorschau gerendert und unveränderte Ebenen werden aus dem Bildcache kombiniert.

Wenn der RAM-Cache voll ist, werden bereits zwischengespeicherte Frames durch neue zwischengespeicherte Frames ersetzt. Wenn After Effects Frames für eine Vorschau kompiliert, fügt es dem Bild-Cache keine weiteren Frames hinzu, falls er voll ist, und gibt nur die Frames wieder, die in den RAM-Cache passen.

Grüne Balken im Zeitlineal des Zeitleisten-, Ebenen- und Footagefensters kennzeichnen Frames, die im RAM zwischengespeichert sind. Blaue Balken im Zeitleistenfenster kennzeichnen Frames, die auf der Festplatte zwischengespeichert sind.

Ebenen-Cache-Indikatoren

Ebenencache-Indikatoren ermöglichen die frameweise Visualisierung von Frames im Cache. Dies ist nützlich, wenn Sie bestimmten möchten, welche Ebenen einer Komposition sich im Cache befinden.

Aktivieren Sie die Option zum Anzeigen der Ebenencache-Indikatoren, indem Sie die Strg-Taste (Windows) bzw. Befehlstaste (Mac OS) drücken, und dann im Menü „Zeitleistenfenster“ „Cache-Indikatoren“ wählen. Die Option „Ebenen-Cache-Indikatoren anzeigen“ muss aktiviert sein, damit Sie die Indikatoren sehen können.

Hinweis:

Durch die Anzeige der Cache-Indikatoren wird die Leistung leicht reduziert.

Der Inhalt des RAM-Cache wird automatisch gelöscht, wenn Sie After Effects schließen.

Sie können wählen, ob Sie den RAM-Cache oder den RAM-Cache und den Disk-Cache entleeren möchten. Wählen Sie die Menüoption Bearbeiten > Entleeren.

Klicken Sie auf „Bearbeiten“ > „Entleeren“ > „Gesamter Speicher und Disk-Cache“, um die Inhalte aller RAM-Caches (wie der bereits vorhandene Befehl „Gesamter Speicher“) und die Inhalte des Disk-Caches (wie die bereits vorhandene Schaltfläche „Disk-Cache leeren“ in den Einstellungen „Medien- und Disk-Cache“) zu löschen.

Das Freigeben von Arbeitsspeicher nimmt in After Effects bei größeren Projekten weniger Zeit in Anspruch. Beim Freigeben von Arbeitsspeicher wird die Projektdatenbank nicht synchronisiert. Wenn Sie die Synchronisierung der Projektdatenbank erzwingen möchten, drücken Sie die Wahl- (Mac OS) bzw. Alt-Taste (Windows) und wählen Sie „Bearbeiten“ > „Entleeren“ > „Gesamter Speicher“. Sie können diesen Vorgang durchführen, wenn Sie feststellen, dass das Bedienfeld „Komposition“ nicht korrekt aktualisiert wird und der Befehl „Entleeren“ > „Gesamter Speicher“ bzw. „Gesamter Speicher und Disk-Cache“ nicht funktioniert.

Hinweis:

Beim Entleeren des Disc-Caches für eine Version von After Effects wird der Cache für andere Versionen nicht entleert. Beispielsweise wirkt sich das Entleeren des Disc-Caches von After Effects CC nicht auf den Disc-Cache für After Effects CS6 aus.

Die globale Leistungs-Cache

Der globale Leistungs-Cache besteht aus den folgenden Elementen:

Globaler RAM-Cache: Wenn Sie eine Komposition bearbeiten, werden die Frames im RAM-Cache nicht automatisch gelöscht und wiederverwendet, falls Sie die Änderung rückgängig machen oder den vorherigen Status der Komposition wiederherstellen. Wenn der RAM-Cache voll ist und After Effects neue Frames zwischenspeichern muss, werden die ältesten Frames im RAM-Cache gelöscht.
Dauerhafter Disk-Cache: Auf der Festplatte zwischengespeicherte Frames sind auch nach dem Schließen von After Effects noch verfügbar.

Video: Globaler Leistungs-Cache

In diesem Video von Brian Maffitt und Total Training sehen Sie, wie mit den Funktionen des globalen Leistungs-Cache beim Zusammenstellen Zeit gespart werden kann.

Brian Maffitt und Total Training

http://www.totaltraining.com
Hinweis:

Der Disk-Cache wird nicht für die Vorschau verwendet. Wird nur für Vorschauen mit Echtzeit-Wiedergabe zwischengespeicherter Frames und Audio verwendet. (Siehe Vorschau.)

Der Disk-Cache ist standardmäßig aktiviert. Über die folgenden Optionen können Sie Disk-Cache-Einstellungen festlegen und den Disk-Cache aktivieren bzw. deaktivieren:

  1. Wählen Sie Bearbeiten > Voreinstellungen > Medien- & Disk-Cache (Windows) oder After Effects > Voreinstellungen > Medien- & Disk-Cache (Mac OS), und aktivieren bzw. deaktivieren Sie "Disk-Cache aktivieren".

Über die Disk-Cache-Einstellungen können Sie den Ordner für den Cache auswählen.

  1. Klicken Sie auf die Schaltfläche „Ordner wählen“, und klicken Sie dann auf „OK“ (Windows) bzw. „Wählen“ (Mac OS).

So leeren Sie den Disk-Cache:

  1. Klicken Sie auf die Schaltfläche „Leerer Disk-Cache“ oder wählen Sie im Menü „Bearbeiten“ die Optionen „Entleeren“ > „Gesamter Speicher & Disk-Cache“.

Hinweis:

Selbst bei aktiviertem Disk-Cache muss jeder Frame in den nächsten RAM-Block übertragen werden können. Die Aktivierung des Disk-Cache löst keine Beschränkungsprobleme bei unzureichender RAM-Kapazität, mit der ein einzelner Frame Ihrer Komposition gehalten oder gerendert werden kann.

Damit eine optimale Leistung der Speicherung im Disk-Cache gewährleistet ist, sollte sich der ausgewählte Ordner nicht auf derselben Festplatte wie das Quellfootage befinden. Es empfiehlt sich, den Ordner auf einer Festplatte anzulegen, die einen anderen Festplattencontroller als die Festplatte mit dem Quellfootage verwendet. Für den Disk-Cache-Ordner wird eine schnelle Festplatte oder SSD mit möglichst umfangreichem zugewiesenem Speicherplatz empfohlen. Der Stammordner der Festplatte kann nicht als Disk-Cache-Ordner verwendet werden.

Ebenso wie beim RAM-Cache verwendet After Effects den Disk-Cache nur dann zum Speichern eines Frame, wenn es schneller ist, den Frame vom Cache abzurufen als ihn neu zu rendern.

Die Einstellung „Maximale Disk-Cache-Größe“ bestimmt, wie viel Speicherplatz auf der Festplatte verwendet werden kann. Die standardmäßige Disk-Cache-Größe wird auf 10 % der Gesamtgröße des Volumes und bis zu 100 GB eingestellt.

Hinweis:

Die Anwendung prüft, dass mindestens 10 GB mehr frei sind als der unter Voreinstellungen > Medien- & Disk-Cache eingestellte Wert. After Effects warnt Sie, wenn im Disk-Cache nicht genügend Speicherplatz vorhanden ist.

Globaler RAM-Cache

Der globale RAM-Cache bietet folgende Vorteile:

  • Im Cache zwischengespeicherte Frames werden nach einem Rückgängig/Wiederholen-Vorgang wiederhergestellt.
  • Im Cache zwischengespeicherte Frames werden wiederhergestellt, wenn eine Komposition oder Ebene in einen früheren Zustand zurückversetzt wird, wie z. B. beim Deaktivieren und späteren Aktivieren der Sichtbarkeit einer Ebene.
  • Wiederverwendbare Frames werden an jeder Stelle der Zeitleiste erkannt (z. B. beim Verwenden von Schleife-Expressions, Zeit-Neuzuordnung oder Kopieren/Einfügen von Keyframes), nicht nur benachbarte Frames.
  • Wiederverwendbare Frames werden auf kopierten Ebenen oder in kopierten Kompositionen erkannt.
  • Der Cache wird durch das Rendern einer Render-Liste an anderen Stellen als „Aktuelle Einstellungen“ nicht automatisch gelöscht.

Dieses Video von Learn by Video veranschaulicht, wie mit dem Arbeitsspeicher und den Festplatten-Caches Zeit gespart werden kann und wie Sie Kompositionen im Hintergrund rendern können, damit Sie nicht warten müssen, bis eine Vorschau gerendert wurde, bevor Sie Ihre Arbeit fortsetzen können.

Dauerhafter Disk-Cache

Nachdem Sie ein Projekt gespeichert haben, werden Frames im Cache beibehalten, selbst nachdem Sie das Projekt oder After Effects geschlossen haben. Dieses Protokoll wird als dauerhafter Disk-Cache bezeichnet.Der Disk-Cache wird am Ende einer Sitzung nicht mehr geleert. Mit der dauerhaften Disk-Cache-Funktion werden im Disk-Cache gespeicherte Frames zwischen den Sitzungen gespeichert. Dadurch sparen Sie Renderzeit, während Sie an einem Projekt oder anderen Projekten arbeiten, die dieselben zwischengespeicherten Frames verwenden.

Nach dem Öffnen eines Projekts wird der Disk-Cache nach Frames durchsucht, die denen im Projekt entsprechen, und sie werden für die Verwendung bereitgestellt. Der Disk-Cache enthält Frames aus allen Projekten, die Sie in der gleichen oder in früheren Sitzungen geöffnet haben. Daher werden im Disk-Cache gespeicherte Frames eines Projekts zur Wiederverwendung in anderen Projekten abgerufen, die die gleichen Frames benötigen. Während der Cache gescannt wird, füllt sich die Zeitleiste allmählich mit blauen Marken.

Hinweis:

Da in früheren Versionen von After Effects nicht alles, was für dieses Feature erforderlich ist, auf der Festplatte gespeichert wurde, müssen Sie Projekte aus CS5.5 und früheren Versionen erneut speichern, um mit dem dauerhaften Cache arbeiten zu können.

Hinweis:

Roto-Pinsel-Frames werden nicht dauerhaft im Cache gespeichert.

Hinweis:

„Arbeitsbereich im Hintergrund zwischenspeichern“ verwendet ebenfalls den Disk-Cache zum Speichern von Frames. Siehe Verbessern der Leistung mithilfe des Global Performance Cache.

Videoschulung: So optimieren Sie After Effects für die Höchstleistung

Sie erfahren von Senior-Produkt-Manager Steve Forde, wie Sie After Effects für Höchstleistungen optimieren.

Steve Forde

Medien-Cache

Beim Importieren von Video- und Audiodateien in bestimmten Formaten verarbeitet und speichert After Effects Versionen dieser Elemente zwischen, auf die es bei der Erstellung von Vorschauen rasch zugreifen kann. Dabei werden importierte Audiodateien jeweils an eine neue .cfa-Datei angepasst, MPEG-Dateien werden in eine neue .mpgindex-Datei indiziert. Der Medien-Cache verbessert die Leistung bei Vorschauen erheblich, da die Audio- und Videoelemente nicht für jede Vorschau neu verarbeitet werden.

Hinweis:

Beim ersten Importieren einer Datei kann es aufgrund des Verarbeitens und Zwischenspeicherns der Medien zu Verzögerungen kommen.

Verknüpfungen zu den einzelnen Mediendateien im Cache werden in einer Datenbank festgehalten. Auf diese Medien-Cache-Datenbank greifen auch Adobe Media Encoder, Premiere Pro, Encore und Soundbooth zu, sodass all diese Anwendungen aus demselben Satz zwischengespeicherter Mediendateien Daten lesen und auch dort schreiben können. Wenn Sie den Speicherort der Datenbank von einer dieser Anwendungen aus ändern, wird er auch für die übrigen Anwendungen aktualisiert. Jede Anwendung kann einen eigenen Cacheordner nutzen, doch alle werden von derselben Datenbank verwaltet.

  1. Wählen Sie Bearbeiten > Voreinstellungen > Medien- und Disk-Cache (Windows) oder After Effects > Voreinstellungen > Medien- und Disk-Cache (Mac OS), und führen Sie einen der folgenden Schritte aus:

    • Klicken Sie auf eine der Schaltflächen „Ordner wählen“, um den Speicherort der Medien-Cache-Datenbank oder des Medien-Cache selbst zu ändern.
    • Klicken Sie auf „Datenbank & Cache bereinigen“, um angepasste, indizierte Dateien aus dem Cache zu entfernen und die entsprechenden Einträge in der Datenbank zu löschen. Mit diesem Befehl werden nur die Dateien gelöscht, die mit den Footage-Elementen verknüpft sind, für welche die Quelldatei nicht länger zur Verfügung steht.
    Hinweis:

    Bevor Sie auf die Schaltfläche „Datenbank & Cache bereinigen“ klicken, sollten Sie sicherstellen, dass alle Speichergeräte, die aktuell verwendete Quellmedien verwenden, mit Ihrem Computer verbunden sind. Falls Footage als fehlend erachtet wird, weil das Speichergerät, auf dem es sich befindet, nicht verbunden ist, werden die verknüpften Dateien im Medien-Cache entfernt. Dadurch wird es erforderlich, das Footage neu anzupassen bzw. neu zu indizieren, wenn Sie es später wiederverwenden möchten.

Im folgenden Video sehen Sie schnelle Möglichkeiten zum Löschen der Medien-Cache-Dateien in After Effects.

Laufzeit: 26 Sek.

Hinweis:

Durch die Bereinigung der Datenbank und des Cache mit der Schaltfläche „Datenbank & Cache bereinigen“ werden keine Dateien gelöscht, die mit Footage-Elementen verknüpft sind, deren Quelldateien weiterhin verfügbar sind. Um angepasste und indizierte Dateien manuell zu entfernen, navigieren Sie zum Medien-Cache-Ordner und löschen die Dateien. Der Speicherort des Medien-Cache-Ordners wird in den Voreinstellungen für den Angepassten Medien-Cache angezeigt. Ist der Pfad abgeschnitten, können Sie mithilfe der Schaltfläche „Ordner wählen“ den vollständigen Pfad anzeigen.

Adobe-Logo

Bei Ihrem Konto anmelden