Benutzerhandbuch Abbrechen

Alphakanäle und Masken

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
      5. Schneller und einfacher animieren mithilfe des Bedienfelds „Eigenschaften“
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle und Masken
    3. Spurmasken und Traveling Mattes
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Farb-Management
    3. Effekte zur Farbkorrektur
    4. OpenColorIO- und ACES-Farbmanagement
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekt-Manager
    4. Effekte unter „Simulation“
    5. Effekte unter „Stilisieren“
    6. Effekte unter „Audio“
    7. Effekte unter „Verzerren“
    8. Effekte unter „Perspektive“
    9. Effekte unter „Kanäle“
    10. Effekte unter „Generieren“
    11. Effekte unter „Überblenden“
    12. Der Effekt „Rolling-Shutter-Reparatur“
    13. Effekte „Weich- und Scharfzeichnen“
    14. Effekte unter „3D-Kanal“
    15. Effekte unter „Dienstprogramm“
    16. Effekte unter „Matt“
    17. Effekte unter „Störung und Körnung“
    18. Effekt „Details erhalten (Vergrößerung)“
    19. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Expressions
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Sprachreferenz für Expressions
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Erweiterter 3D-Renderer
    5. Importieren und Hinzufügen von 3D-Modellen zu Ihrer Komposition
    6. Importieren von 3D-Modellen aus Creative Cloud Libraries
    7. Bildbasierte Beleuchtung
    8. Extrahieren und Animieren von Lichtern und Kameras aus 3D-Modellen
    9. Tracking von 3D-Kamerabewegungen
    10. Werfen und Akzeptieren von Schatten
    11. Eingebettete 3D-Modell-Animationen
    12. Schattenfänger
    13. Extraktion von 3D-Tiefendaten
    14. Ändern der Materialeigenschaften einer 3D-Ebene
    15. Arbeiten im 3D-Designraum
    16. 3D-Transformations-Gizmos
    17. Machen Sie mehr mit 3D-Animation
    18. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Mercury 3D-Engine
    19. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. H.264-Codierung in After Effects
    3. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    4. Konvertieren von Filmen
    5. Multi-Frame-Rendering
    6. Automatisches Rendern und Netzwerk-Rendern
    7. Rendern und Exportieren von Standbildern und Standbildsequenzen
    8. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. Cinema 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Frame.io installieren und aktivieren
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau behandelt    
    3. Verbessern der Leistung
    4. Voreinstellungen
    5. Anforderungen an GPU und GPU-Treiber für After Effects
  21. Wissensdatenbank
    1. Bekannte Probleme
    2. Behobene Probleme
    3. Häufig gestellte Fragen
    4. After Effects und macOS Ventura
    5. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau handhabt

Farbinformationen in After Effects sind in drei Kanälen enthalten: rot (R), grün (G) und blau (B). Darüber hinaus kann ein Bild einen unsichtbaren vierten Kanal umfassen, den so genannten Alphakanal, der Transparenzinformationen enthält. Manchmal wird ein solches Bild als RGBA-Bild bezeichnet, was darauf hinweist, dass es einen Alphakanal enthält.

Auf einen Blick: Kanäle

A. Separate Farbkanäle B. Als Graustufenbild angezeigter Alphakanal C. Kombination aller vier Kanäle mit einem Hintergrund, der durch die transparenten Bereiche hindurch sichtbar ist 

Viele Dateiformate können einen Alphakanal enthalten, darunter Adobe Photoshop, ElectricImage, FLV, TGA, TIFF, EPS, PDF und Adobe Illustrator. AVI und QuickTime (gespeichert mit einer Bittiefe von Millionen von Farben+) können ebenfalls Alphakanäle enthalten. Dies ist abhängig von dem Codec (Encoder), der zum Generieren der in diesen Containern gespeicherten Bilder verwendet wurde. Bei Adobe Illustrator-, EPS- und PDF-Dateien wandelt After Effects leere Bereiche automatisch in Alphakanäle um.

Beim Festlegen der Farbtiefe für ein Ausgabebild weist das Pluszeichen (wie bei „Millionen von Farben+“) auf einen Alphakanal hin. Ähnlich ist es bei der Ausgabe mit 32 Bit pro Pixel, was eine Ausgabetiefe von 8 Bit pro Kanal für jeden von vier Kanälen bedeutet: RGBA.

Manche Programme können mehrere Alphakanäle in einem Bild speichern. After Effects interpretiert jedoch nur den vierten Kanal als Alphakanal.

Hinweis:

Der Begriff Alphakanal meint im technischen Sinne den vierten Kanal (A) in einer RGBA-Bilddatei, unabhängig davon, ob über diesen Kanal Transparenzinformationen weitergegeben werden. Da dieser vierte Kanal jedoch sehr häufig für die Weitergabe von Transparenzinformationen verwendet wird, werden die Begriffe Alpha und Transparenz im Allgemeinen nahezu synonym verwendet. Beachten Sie jedoch, dass diese Gleichsetzung willkürlich ist. Einigen Formate verwenden möglicherweise andere Kanäle für die Transparenzinformationen, wogegen andere Formate den vierten Kanal vielleicht für andere Daten als die Transparenzinformationen nutzen.

Das Knoll Unmult-Plug-in kann verwendet werden, um einen Alphakanal aus den dunklen Bereichen einer Ebene zu erstellen. Dies funktioniert vor allem gut, wenn Sie eine Ebene mit einem Lichteffekt (z. B. Blendenfleck oder Feuer) über einer anderen Ebene kombinieren möchten. Informationen dazu erhalten Sie auf der Website von Red Giant Software.

Wenn Sie einen Alphakanal im Kompositionsfenster anzeigen, stehen Weiß für vollständige Deckkraft, Schwarz für vollständige Transparenz und Grautöne für teilweise Transparenz.

Eine Farbfläche ist eine Ebene (oder einer der Kanäle einer Ebene), die die transparenten Bereiche dieser Ebene oder einer anderen Ebene definiert. Weiß definiert deckende Bereiche, und Schwarz definiert transparente Bereiche. Ein Alphakanal wird häufig als Maske verwendet, aber Sie können auch eine andere Maske als den Alphakanal verwenden, wenn Sie einen Kanal oder eine Ebene haben, der/die den gewünschten Transparenzbereich besser definiert als der Alphakanal, oder wenn das Quellbild keinen Alphakanal enthält.

Masken

Als Maske wird in After Effects ein Pfad bezeichnet, der als Parameter dient, um Ebenenattribute, -effekte und -eigenschaften zu ändern. Am häufigsten werden Masken zum Ändern des Alphakanals einer Ebene verwendet, wodurch die Transparenz der Ebene bei jedem Pixel festgelegt wird. Zudem werden Masken häufig als Pfade eingesetzt, um Text zu animieren. (Siehe Erstellen und Animieren von Text auf einem Pfad.)

Weitere Informationen zu Pfaden im Allgemeinen finden Sie unter Pfade.

Standardwirkung einer gezeichneten Maske (links); dieselbe Maske umgekehrt (rechts)

Mit Masken, die aus geschlossenen Pfaden bestehen, können Sie transparente Bereiche für Ebenen erstellen. Mit offenen Pfaden lassen sich keine transparenten Ebenenbereiche erstellen, sie sind jedoch als Parameter für einen Effekt praktisch. Bei einigen Effekten können Sie einen offenen oder geschlossenen Maskenpfad als Eingabe verwenden. Hierzu gehören „Strich“, „Pfadtext“, „Audio-Wellenform“, „Audiospektrum“ und „Vegas“. Zu den Effekten, die geschlossene Masken (jedoch keine offenen) als Eingabe verwenden können, gehören „Füllen“, „Schmieren“, „Umformen“, „Partikelsimulation“ und „Innerer/Äußerer Key“.

Jede Maske gehört zu einer bestimmten Ebene. Jede Ebene kann mehrere Masken enthalten.

Sie können mit den Form-Werkzeugen Masken in allgemeinen geometrischen Formen einschließlich Polygonen, Ellipsen und Sternen zeichnen oder Sie können mit dem Zeichenstift einen frei definierten Pfad zeichnen.

Wenn Sie Maskenpfade zeichnen, ist der Vorgang in vielerlei Hinsicht derselbe, als wenn Sie Formenpfade auf Formebenen zeichnen, obwohl die Bearbeitung und Interpolation von Maskenpfaden einige zusätzliche Funktionen bieten. Sie können einen Maskenpfad mithilfe von Expressions mit einem Formenpfad verknüpfen. Dadurch lassen sich die Vorzüge von Masken auf Formebenen übertragen und umgekehrt. Siehe Erstellen von Formen und Masken und Bearbeiten und Animieren von Formenpfaden und -masken.

Die Position einer Maske in der Stapelreihenfolge des Zeitleistenfensters beeinflusst, wie sie mit anderen Masken interagiert. Im Zeitleistenfenster können Sie eine Maske innerhalb der Eigenschaftsgruppe „Masken“ an andere Positionen ziehen.

Die Eigenschaft „Maskendeckkraft“ einer Maske bestimmt den Einfluss, den eine geschlossene Maske auf den Alphakanal der Ebene innerhalb des Maskenbereichs hat. Eine Maskendeckkraft von 100 % entspricht einer vollständig deckenden Innenfläche. Die Fläche außerhalb der Maske ist stets transparent. Wenn Sie den Innen- und Außenbereich einer bestimmten Maske umkehren möchten, klicken Sie im Bedienfeld „Zeitleiste“ neben dem Maskennamen auf „Umkehren“.

Kopieren, Ausschneiden, Speichern, Wiederverwenden und Löschen von Masken

Sie können Masken in anderen Ebenen und Kompositionen wiederverwenden. Dies ist insbesondere bei Bézier-Masken nützlich, deren Fertigstellung sehr viel Zeit in Anspruch nehmen kann. Maskenpfade werden innerhalb einer Komposition in einer Projektdatei gespeichert.

Kopieren, Ausschneiden, Duplizieren oder Einfügen einer Maske

Hinweis:

Beim Arbeiten mit einem Maskenpfad (statt der gesamten Maske mit allen anderen Eigenschaften) wählen Sie die Eigenschaft „Maskenpfad“ aus. Dies ist besonders dann wichtig, wenn Sie Maskenpfade auf Formpfade, Bewegungspfade und dergleichen übertragen.

  • Um ausgewählte Masken in die Zwischenablage zu kopieren bzw. zu verschieben, klicken Sie auf Bearbeiten > Kopieren oder Bearbeiten > Ausschneiden.
  • Wenn Sie ausgewählte Masken duplizieren möchten, klicken Sie auf Bearbeiten > Duplizieren.
  • Um eine Maske in eine Ebene einzufügen, wählen Sie die Ebene aus und klicken Sie anschließend auf Bearbeiten > Einfügen. Wenn eine Maske ausgewählt ist, wird die ausgewählte Maske durch diesen Vorgang ersetzt.

Speichern von Masken

  1. Öffnen Sie in der Zeitleiste für die Komposition mit der zu speichernden Ebene und Maske die Ebene und ihre Maskeneigenschaften.
  2. Führen Sie einen der folgenden Schritte aus:

    • Wenn Sie eine animierte Maske speichern möchten, wählen Sie die Masken-Keyframes aus, die Sie speichern möchten.
    • Wenn Sie eine nicht animierte Maske speichern möchten, wählen Sie die Maske aus.
  3. Kopieren Sie die Maske oder die Keyframes und fügen Sie sie in eine neue Ebene ein. Bei der Ebene kann es sich um eine einfache Farbfläche handeln.
Hinweis:

Erstellen Sie ein Projekt mit Kompositionen, die nur dem Speichern komplexer Masken dienen. Wenn Sie eine Maske aus einem anderen Projekt verwenden möchten, importieren Sie das entsprechende Projekt in Ihr aktuelles Projekt.

Hinweis:

Sie können Masken auch als Animationsvorgaben speichern. (Siehe Animationsvorgaben.)

Wiederverwenden von Masken

  1. Öffnen Sie die Komposition mit der Maske, die erneut verwendet werden soll. Wenn Sie die Maske in einem anderen Projekt gespeichert haben, importieren Sie das Projekt und öffnen dann die Komposition mit der Maske.
  2. Erweitern Sie in der Zeitleiste die Ebene und die Maskeneigenschaften für die Maske.
  3. Wählen Sie die Maske oder die Keyframes aus.
  4. Kopieren Sie die Maske oder die Keyframes und fügen Sie sie in die Ebene ein, auf die Sie die Maske anwenden möchten.

Löschen von Masken

  • Wenn Sie eine Maske löschen möchten, wählen Sie sie im Schnittfenster aus und drücken Sie die Entf-Taste.
  • Wenn Sie alle Masken löschen möchten, wählen Sie die Ebene aus, die die zu löschenden Masken enthält, und klicken Sie dann auf Ebene > Masken > Alle Masken entfernen.

Steuern von Maskenpfadfarben

Damit Sie Masken leichter identifizieren und einsetzen können, wird dem Maskenpfad in den Bedienfeldern „Komposition“ und „Ebenen“ eine farbige Kontur zugewiesen. Diese Farbe wird im Schnittfenster neben dem Maskennamen angezeigt. In After Effects wird für alle Masken als Farbe standardmäßig Gelb verwendet. Wenn Sie die einzelnen Masken auffälliger gestalten möchten, können Sie die Maskenfarbe im Zeitleistenfenster manuell ändern. Sie können After Effects außerdem so einstellen, dass neuen Masken zyklisch andere Farben zugewiesen werden.

Wenn die Voreinstellung Kontrastfarbe für Maskenpfad verwenden (unter Voreinstellungen > Erscheinungsbild) aktiviert ist, analysiert After Effects die Farben in der Umgebung des Punktes, von dem aus Sie eine Maske zeichnen. After Effects wählt dann eine Beschriftungsfarbe, die sich von den Farben in diesem Bereich unterscheidet. Die Farbe der letzten gezeichneten Maske wird vermieden.

Ändern von Maskenpfadfarben

  1. Wählen Sie die Maske im Zeitleistenfenster aus.
  2. Klicken Sie auf das Farbfeld links neben dem Maskennamen, wählen Sie eine neue Farbe und klicken Sie auf OK.

Wechseln durch die Maskenpfadfarben

  1. Wählen Sie Bearbeiten > Voreinstellungen > Darstellung.

  2. Aktivieren Sie die Option Neue Farbe für jede neue Maske.

Maskenmodi

Füllmethoden für Masken (auch als Maskenmodi bezeichnet) steuern, wie verschiedene Masken innerhalb einer Ebene miteinander interagieren. Standardmäßig sind alle Masken auf „Addieren“ eingestellt – hiermit werden Transparenzwerte aller Masken, die sich in einer Ebene überlappen, kombiniert. Sie können jeder Maske einen Modus zuweisen. Sie können den Modus einer Maske jedoch nicht animieren, d. h. es können keine Keyframes oder Expressions für eine Maskenmoduseigenschaft festgelegt werden, durch die der Maskenmodus im Zeitverlauf geändert werden würde.

Im Zeitleistenfenster können Sie im Menü neben dem Maskennamen einen Modus für eine Maske auswählen.

Die erste Maske, die Sie erstellen, interagiert mit dem Alphakanal der Ebene. Wenn dieser Kanal nicht das ganze Bild als deckend definiert, interagiert die Maske mit dem Ebenen-Frame. Jede weitere von Ihnen erstellte Maske interagiert mit den Masken, die sich im Schnittfenster in der Stapelreihenfolge oberhalb der Maske befinden. Die Ergebnisse der Maskenmodi hängen von den Modi ab, die für die in der Stapelreihenfolge weiter oben liegenden Masken festgelegt wurden. Maskenmodi werden nur zwischen Masken auf derselben Ebene angewendet.

Sie können komplexe zusammengesetzte Masken mit mehreren transparenten Bereichen mithilfe von Maskenmodi erstellen. Sie können zum Beispiel einen Maskenmodus einstellen, der zwei Masken miteinander kombiniert und als deckenden Bereich die Überschneidungsfläche der beiden Masken festlegt.

mask-mode-original-masks

Original

Ursprünglicher Satz Formen.

mask-mode-none

Ohne

Die Maske wirkt sich nicht direkt auf den Alphakanal der Ebene aus. Diese Option ist hilfreich, wenn Sie den Maskenpfad nur für Effekte wie „Strich“ oder „Füllen“ oder als Basis für einen Formenpfad verwenden.

mask-mode-add

Addieren

Die Maske wird zu den Masken addiert, die in der Stapelreihenfolge darüber liegen. Der Einfluss der Maske wird zu den darüber liegenden Masken addiert.

maskenmodus-subtrahieren

Subtrahieren

Der Einfluss der Maske wird von den darüber liegenden Masken subtrahiert. Diese Option ist hilfreich, wenn Sie ein Loch in der Mitte einer anderen Maske erstellen möchten.

maskenmodus-schnitt

Überschneiden

Die Maske wird zu den Masken addiert, die in der Stapelreihenfolge darüber liegen. In Bereichen, in denen sich die Maske mit den darüber liegenden Masken überlappt, wird der Einfluss der Maske zu den darüber liegenden Masken addiert. In Bereichen, in denen sich die Maske nicht mit den darüber liegenden Masken überlappt, ist das Ergebnis vollständige Deckung.

maskenmodus-aufhellen

Aufhellen

Die Maske wird zu den Masken addiert, die in der Stapelreihenfolge darüber liegen. Wenn sich mehrere Masken überschneiden, wird der höchste Transparenzwert verwendet.

Maskenmodus-Abdunkeln

Abdunkeln

Die Maske wird zu den Masken addiert, die in der Stapelreihenfolge darüber liegen. Wenn sich mehrere Masken überschneiden, wird der geringste Transparenzwert verwendet.

Maskenmodus-Abdunkeln

Differenz

Die Maske wird zu den Masken addiert, die in der Stapelreihenfolge darüber liegen. In Bereichen, in denen sich die Maske nicht mit den darüber liegenden Masken überlappt, übt der Einfluss der Maske die alleinige Kontrolle aus. In Bereichen, in denen sich die Maske mit den darüber liegenden Masken überlappt, wird der Einfluss der Maske von den darüber liegenden Masken subtrahiert.

Verwenden Sie die folgenden Tastaturbefehle, um den Modus einer geschlossenen Maske zu ändern, während Sie sie zeichnen oder ändern:

Funktion

Mac

Windows

Ohne

Z

Z

Subtrahieren

S

S

Addieren

A

A

Überschneiden

I

I

Abdunkeln

D

D

Differenz

F

F

Aufhellen

L

L

Anmerkungen:

  • Wenn Sie eine neue Maske mit Formwerkzeugen wie Rechteck- und Ellipsenwerkzeug zeichnen, können Sie diese Tastaturbefehle zusammen mit der Maus drücken.
  • Wenn Sie eine neue Maske mit dem Zeichenstift zeichnen, können Sie diese Tastaturbefehle nur dann verwenden, wenn Sie die Maske schließen. Um den Zeiger über dem schließenden Scheitelpunkt (normalerweise der erste Scheitelpunkt) zu platzieren, halten Sie die Maustaste gedrückt, damit die Maske geschlossen werden kann. Dann drücken Sie den Maskenmodus-Tastaturbefehl, bevor Sie die Maustaste loslassen. Offene Masken haben keinen Modus. Diese Tastaturbefehle funktionieren nicht, wenn Sie offene Masken mit dem Zeichenstift zeichnen.
  • Wenn Sie eine geschlossene Maske ändern möchten, können Sie diese Tastaturbefehle jederzeit drücken, während Sie die Maustaste gedrückt halten.

Erweitern oder Verkleinern der Kanten einer Maske

Wenn Sie den durch eine Maske beeinflussten Bereich erweitern oder verkleinern möchten, verwenden Sie die Eigenschaft Maskenausweitung.

Die Maskenausweitung hat Auswirkungen auf den Alphakanal, jedoch nicht auf den zugrunde liegenden Maskenpfad. Die Maskenausweitung ist im Grunde ein Versatz, der angibt, wie weit entfernt vom Maskenpfad (in Pixeln) sich der Einfluss der Maske auf den Alphakanal erstreckt.

Sie können die Maskenausweitungswerte auf 32.000 nach oben und auf –32.000 nach unten scrubben. Frühere Versionen von After Effects erlaubten das Scrubben der Werte auf 1.000, und jeder Wert über 1.000 wurde manuell eingegeben.

  1. Öffnen Sie im Schnittfenster die Maskeneigenschaften der Ebene, die Sie einstellen möchten.

  2. Ziehen Sie den unterstrichenen Wert für Maskenausweitung.

Glätten der Kanten einer Maske

Eine weiche Maskenkante bildet auf einer vom Benutzer festgelegten Strecke einen Übergang zwischen stark transparenten und weniger stark transparenten Bereichen. Mit der Eigenschaft „Weiche Maskenkante“ können Sie für Maskenkanten harte oder weiche Ränder einstellen. Standardmäßig liegt der Übergangsbereich einer weichen Maskenkante halb innerhalb und halb außerhalb der Maske. Wenn Sie zum Beispiel eine weiche Kante mit einer Breite von 25 Pixeln festlegen, reicht der Übergangsbereich 12,5 Pixel in die Maske hinein und erstreckt sich 12,5 Pixel über sie hinaus.

Sie können die Werte für „Weiche Maskenkante“ mithilfe des Reglers bis auf 32.000 scrubben.

Ergebnisse für verschiedene Werte für die Option „Weiche Maskenkante“

A. Maskierte Ebene mit 5-Pixel-Übergangsbereich B. Maskierte Ebene mit 40-Pixel-Übergangsbereich C. Ergebnis mit 5-Pixel-Übergangsbereich D. Ergebnis mit 40-Pixel-Übergangsbereich 

Mit der Eigenschaft „Maskenausweitung“ können Sie die Maskenkanten verbreitern oder verschmälern, um zu steuern, wie weit der Übergangsbereich reicht. (Siehe Erweitern oder Verkleinern der Kanten einer Maske.)

Der Übergangsbereich einer weichen Kante befindet sich nur innerhalb der Abmessungen der Ebene. Ein Maskenpfad mit weichen Kanten sollte daher immer etwas kleiner sein als der Ebenenbereich und nicht direkt am Rand der Ebene liegen. Wenn der Übergangsbereich über den Ebenenbereich hinausragt, endet die weiche Kante abrupt.

  1. Um die Eigenschaft Weiche Maskenkante für ausgewählte Ebenen anzuzeigen, drücken Sie die Taste „F“.

  2. (Optional) Wenn sich der Übergangsbereich der weichen Maskenkanten in horizontaler und vertikaler Richtung proportional ändern soll, klicken Sie auf den Umschalter zur Beschränkung der Seitenverhältnisse neben der Eigenschaft Weiche Maskenkante.

  3. Die Eigenschaft Weiche Maskenkante können Sie wie jede andere Eigenschaft ändern: Ziehen Sie dazu den unterstrichenen Wert, oder klicken Sie darauf und geben Sie einen Wert in das Texteingabefeld ein.

Hinweis:

Da die weiche Maskenkante dazu führt, dass die Deckkraftwerte gemäß einer Gaußschen Verteilung variieren, erstreckt sich der durch die weiche Maskenkante beeinflusste Bereich tatsächlich über die festgelegte Anzahl der Pixel hinaus. Die Auswirkung des Übergangsbereichs über den festgelegten Bereich hinaus ist sehr gering. Diese stufenweise Gaußsche Abnahme erscheint natürlicher, als das bei einer linearen Abnahme der Fall wäre.

Weiche Maskenkanten mit variabler Breite

Frühere Versionen von After Effects boten die Möglichkeit, einer geschlossenen Maske eine weiche Kante hinzuzufügen, aber die Breite (Ausdehnung) der weichen Kante war die ganze Maske entlang gleich. Eini neues Werkzeug Weiche Maskenkante (verfügbar in demselben Menü „Werkzeuge“ wie das Zeichenstift-Werkzeug) wurde hinzugefügt, um Punkte entlang einer geschlossenen Maske zu definieren, die unterschiedliche Breiten haben soll.

So erstellen Sie einen Punkt für eine weiche Kante:

Ein ausgewählter Punkt auf der weichen Kante hat einen kleinen schwarzen Punkt am Griff.

Punkte auf der weichen Kante definieren die äußere und innere Grenze der weichen Kante. Wenn keine Kantenausdehungsgriffe innerhalb der Maske liegen, ist die innere Grenze der weichen Kante der Maskenpfad. Die weiche Maskenkante reicht von der inneren zur äußeren Grenze der weichen Maskenkante.

So wählen Sie mehrere Punkte für die weiche Kante aus:

Verwenden Sie das Werkzeug Auswahl oder Weiche Maskenkante und klicken Sie bei gedrückter Umschalttaste auf die Ausdehnungs-Handles der Kantenpunkte.

So wechseln Sie die Auswahl eines Punktes für die weiche Kante:

Klicken Sie bei gedrückter Umschalttaste auf den Punkt für die weiche Kante.

Um einen Punkt auf der weichen Kante zu verschieben, führen Sie einen der folgenden Schritte aus:

  • Verwenden Sie das Werkzeug Auswahl oder Weiche Maskenkante und ziehen Sie den Ausdehnungs-Handle der Kante.

Sie können mehrere ausgewählte Punkte für die weiche Kante gleichzeitig verschieben, indem Sie einen von ihnen ziehen, und mehrere Ausdehnungen für Punkte der weichen Kante skalieren, indem Sie an einem der Kantenausdehnungs-Handles ziehen.

Sie können Punkte für die weiche Kante um Scheitelpunkte auf einer Maske „biegen“.

  • Bei aktivem Werkzeug Weiche Maskenkante klicken Sie auf den Pfeil nach links oder rechts, um die weiche Kante entlang dem Pfad zu verschieben, oder klicken Sie auf den Pfeil nach oben oder nach unten, um die Breite der weichen Kante zu verlängern bzw. zu verkürzen.

Wenn Sie die Umschalttaste gedrückt halten, können Sie mehrere ausgewählte weiche Kanten verschieben und größere Entfernungen/Breiten verschieben.

So lassen Sie einen Punkt für die weiche Kante am Maskenpfad einrasten:

Ziehen Sie den Ausdehnungsgriff der weichen Kante über den Maskenpfad. Er stoppt am Maskenpfad.

So steuern Sie den Abfall der weichen Kante:

Wählen Sie Ebene > Maske > Abfall der weichen Kante, und wählen Sie dann eine der folgenden Optionen:

  • Glätten (Standard)
  • Linear

So passen Sie die Spannung (Glätte oder Krümmung) einer Grenze der weichen Kante durch einen Punkt der weichen Kante an:

Halten Sie die Alt-Taste (Windows) bzw. Wahltaste (macOS) gedrückt, während Sie einen Kantenausdehnungs-Handle ziehen, um die Spannung anzupassen. Das Infofenster zeigt die aktuelle Spannung für einen Griff an.

So legen Sie die Interpolation „Unterdrücken“ für einen Punkt für die weiche Kante fest (für konstanten Kantenradius bis zum nächsten Punkt der weichen Kante):

Halten Sie die Alt-Taste (Windows) bzw. Wahltaste (macOS) gedrückt, während Sie einen Kantenausdehnungs-Handle ziehen, um die Spannung anzupassen. Das Infofenster zeigt die aktuelle Spannung für einen Griff an.

Aktivieren Sie die Option „Unterdrücken“ aus dem Kontextmenü über dem Punkt für die weiche Kante. Der Kantenpunktgriff ändert sich zu einer Spitze in Richtung des konstanten Radius.

So erstellen Sie schnell eine weiche Kante für ein spezifisches Maskensegment:

Halten Sie die Umschalttaste gedrückt, während Sie auf das Maskensegment klicken (zwischen Scheitelpunkten, nicht darüber). Der Zeiger ändert sich, um anzugeben, dass Sie in diesem Modus sind. Ziehen Sie vom Segment weg, um die Ausdehnung anzupassen. Beachten Sie folgendes Verhalten:

  • Wenn nur zwei Maskenscheitelpunkte ausgewählt sind, wird die weiche Kante von den dazwischen liegenden angrenzenden Segmenten gebildet.
  • Wenn beide Scheitelpunkte des angeklickten Segments ausgewählt sind (also das Segment ausgewählt ist), wird die weiche Kante ausgedehnt, um die angrenzenden ausgewählten Segmente einzuschließen.
  • Wenn alle oder keine Scheitelpunkte auf der Maske ausgewählt oder die ersten beiden Bedingungen nicht anwendbar sind, ist die weiche Kante nur das angeklickte Segment.

So löschen Sie einen Punkt auf der weichen Kante:

Wählen Sie mit dem Auswahlwerkzeug oder dem Werkzeug „Weiche Maskenkante“ einen Ausdehnungs-Handle einer weichen Kante aus und drücken Sie dann die Entf-Taste. Sie können mehrere ausgewählte Punkte für die weiche Kante löschen.

Hinweis:

Befindet sich der Zeiger auf einem Maskenscheitelpunkt, wechselt er vom Modus „Scheitelpunkt löschen“ in den Auswahlmodus.

Tipps für weiche Maskenkanten mit variabler Breite (Werkzeug „Weiche Maskenkante“)

  • Schalten Sie kurz zwischen den Werkzeugen Zeichenstift und Weiche Maskenkante um, indem Sie den Tastaturbefehl „G“ drücken. Sie können dieses Verhalten unter Bearbeiten > Voreinstellungen > Allgemein (Windows) oder Nachwirkungen > Voreinstellungen > Allgemein (macOS) deaktivieren.
  • Zeigen Sie Informationen über die Anzahl der weichen Kantenpunkte auf einer Maske, die Ausdehnungslänge, Position und Spannung einer weichen Kante sowie die Einstellung „Abfall der weichen Kante“ im Infofenster an.
  • Blenden Sie die Grenzen der weichen Kante für eine bestimmte Ansicht aus, indem Sie die Option Grenzen für „Weiche Maskenkante“ im Dialogfeld Anzeigeoptionen deaktivieren. Sie können immer noch mit den Grenzen interagieren (also z. B. neue Punkte auf der weichen Kante hinzufügen), wo diese gezeichnet worden wären.
  • Bestimmen Sie die Anzahl der weichen Kantenpunkte für die Maskenpfad-Keyframes, indem Sie die Option Konstante Scheitelpunktzahl und Anzahl der weichen Kanten bei Maskenbearbeitung erhalten in den allgemeinen Voreinstellungen entsprechend festlegen.
  • Ändern Sie den Wert der Spannung eines Punkts auf der weichen Kante, des Radius und des Eckwinkels über ein Dialogfeld, indem Sie die Befehle im Kontextmenü für einen Punkt auf der weichen Kante verwenden. Halten Sie die Strg-Taste (Windows) bzw. Befehlstaste (macOS) gedrückt, während Sie den Mauszeiger über einen Maskenscheitelpunkt halten, um zum Verhalten des Auswahl-Werkzeugs zu wechseln.
  • Halten Sie die Strg-Taste (Windows) bzw. Befehlstaste (macOS) gedrückt, während Sie den Cursor über einen Tangentengriff halten, um zum Scheitelpunkt-konvertieren-Werkzeug zu wechseln.

Jede Ebene in Ihrer Komposition, unabhängig davon, wo sie sich im Ebenenstapel befindet, kann als Spurmaskenquelle für jede andere Ebene verwendet werden. Sie können sogar mehrere Ebenen für ihre Maske auf eine einzelne Ebene verweisen lassen. Sie können auch die Alpha- oder Luma-Kanäle der Maskenebene verwenden und diese bei Bedarf umkehren.

 Adobe

Schneller und einfacher Hilfe erhalten

Neuer Benutzer?

Adobe MAX 2024

Adobe MAX
Die Konferenz für Kreative

14. bis 16. Oktober in Miami Beach und online

Adobe MAX

Die Konferenz für Kreative

14. bis 16. Oktober in Miami Beach und online

Adobe MAX 2024

Adobe MAX
Die Konferenz für Kreative

14. bis 16. Oktober in Miami Beach und online

Adobe MAX

Die Konferenz für Kreative

14. bis 16. Oktober in Miami Beach und online