Benutzerhandbuch Abbrechen

Skripte

  1. Benutzerhandbuch –After Effects
  2. Beta-Versionen
    1. Übersicht über das Beta-Programm
    2. After Effects Beta Home
  3. Erste Schritte
    1. Erste Schritte mit After Effects
    2. Neue Funktionen in After Effects 
    3. Versionshinweise | After Effects
    4. Systemanforderungen für After Effects
    5. Tastaturbefehle in After Effects
    6. Unterstützte Dateiformate | After Effects
    7. Hardware-Empfehlungen
    8. After Effects für Apple-Chip
    9. Planung und Einrichtung
  4. Arbeitsbereiche
    1. Allgemeine Elemente der Benutzeroberfläche
    2. Lernen Sie die After Effects-Oberfläche kennen
    3. Arbeitsabläufe
    4. Arbeitsbereiche, Bedienfelder und Anzeigen
  5. Projekte und Kompositionen
    1. Projekte
    2. Kompositionen – Grundlagen
    3. Erstellen von Unterkompositionen, Verschachteln und Vor-Rendern
    4. Anzeigen detaillierter Leistungsinformationen mit Composition Profiler
    5. CINEMA 4D-Kompositions-Renderer
  6. Importieren von Footage
    1. Vorbereiten und Importieren von Standbildern
    2. Importieren aus After Effects und Adobe Premiere Pro
    3. Importieren und Interpretieren von Video und Audio
    4. Vorbereiten und Importieren von 3D-Bilddateien
    5. Importieren und Interpretieren von Footage-Elementen
    6. Arbeiten mit Footage-Elementen
    7. Erkennen von Bearbeitungspunkten mithilfe der Szenenbearbeitungs-Erkennung
    8. XMP-Metadaten
  7. Text und Grafiken
    1. Text
      1. Formatieren von Zeichen und das Bedienfeld „Zeichen“
      2. Effekte unter „Text“
      3. Erstellen und Bearbeiten von Textebenen
      4. Formatieren von Absätzen und das Bedienfeld „Absatz“
      5. Extrudieren von Text- und Formebenen
      6. Animieren von Text
      7. Beispiele und Ressourcen zur Textanimation
      8. Live-Text-Vorlagen
    2. Animationen
      1. Arbeiten mit Animationsvorlagen in After Effects
      2. Verwenden von Expressions zum Erstellen von Dropdown-Listen in Animationsvorlagen
      3. Verwenden von erforderlichen Eigenschaften zum Erstellen von Animationsvorlagen
      4. Ersetzen von Bildern und Videos in Animationsvorlagen und erforderlichen Eigenschaften
      5. Schneller und einfacher animieren mithilfe des Bedienfelds „Eigenschaften“
  8. Zeichnen, Malen und Pfade
    1. Überblick über Formebenen, Pfade und Vektorgrafiken
    2. Malwerkzeuge: Pinsel, Kopierstempel und Radiergummi
    3. Verjüngen von Formenkonturen
    4. Formenattribute, Malvorgänge und Pfadvorgänge bei Formebenen
    5. Verwenden des Formeneffekts „Offset-Pfade“ zum Ändern von Formen
    6. Erstellen von Formen
    7. Erstellen von Masken
    8. Entfernen von Objekten aus Videos mit dem Bedienfeld „Inhaltsbasierte Füllung“
    9. „Roto-Pinsel“ und „Maske verbessern“
  9. Ebenen, Marken und Kamera
    1. Auswählen und Anordnen von Ebenen
    2. Füllmethoden und Ebenenstile
    3. 3D-Ebenen
    4. Ebeneneigenschaften
    5. Erstellen von Ebenen
    6. Verwalten von Ebenen
    7. Ebenenmarken und Kompositionsmarken
    8. Kameras, Lichter und Interessenbereiche
  10. Animation, Keyframes, Motion-Tracking und Keying
    1. Animation
      1. Animation – Grundlagen
      2. Animation mit Marionettenwerkzeugen
      3. Verwalten und Animieren von Formpfaden und -masken
      4. Animieren von Formen aus Sketch und Capture mit After Effects
      5. Ausgewählte Animationswerkzeuge
      6. Arbeiten mit datengesteuerten Animationen
    2. Keyframe
      1. Keyframe-Interpolation
      2. Festlegen, Auswählen und Löschen von Keyframes
      3. Bearbeiten, Verschieben und Kopieren von Keyframes
    3. Bewegungs-Tracking
      1. Tracking und Stabilisieren von Bewegung
      2. Gesichts-Tracking
      3. Masken-Tracking
      4. Maskenreferenz
      5. Geschwindigkeit
      6. Zeitdehnungen und Zeitverzerrungen
      7. Timecode und Zeitanzeigeeinheiten
    4. Keying
      1. Keying
      2. Effekte unter „Keying“
  11. Transparenz und Komposition
    1. Erstellen von Kompositionen und Transparenz – Überblick und Ressourcen
    2. Alphakanäle und Masken
    3. Spurmasken und Traveling Mattes
  12. Anpassen der Farbe
    1. Farben – Grundlagen
    2. Farb-Management
    3. Effekte zur Farbkorrektur
    4. OpenColorIO- und ACES-Farbmanagement
  13. Effekte und Animationsvorgaben
    1. Überblick über Effekte und Animationsvorgaben
    2. Effektliste
    3. Effekt-Manager
    4. Effekte unter „Simulation“
    5. Effekte unter „Stilisieren“
    6. Effekte unter „Audio“
    7. Effekte unter „Verzerren“
    8. Effekte unter „Perspektive“
    9. Effekte unter „Kanäle“
    10. Effekte unter „Generieren“
    11. Effekte unter „Überblenden“
    12. Der Effekt „Rolling-Shutter-Reparatur“
    13. Effekte „Weich- und Scharfzeichnen“
    14. Effekte unter „3D-Kanal“
    15. Effekte unter „Dienstprogramm“
    16. Effekte unter „Matt“
    17. Effekte unter „Störung und Körnung“
    18. Effekt „Hochskalieren mit Detailerhaltung“
    19. Veraltete Effekte
  14. Ausdrücke und Automatisierung
    1. Expressions
      1. Expressions – Grundlagen
      2. Verstehen der Sprache für Expressions
      3. Verwenden von Einstellungen für Expressions
      4. Syntaxunterschiede zwischen den Expression-Engines für JavaScript und das veraltete ExtendScript
      5. Bearbeiten von Expressions
      6. Fehler bei Expressions
      7. Verwenden des Expressions-Editors
      8. Verwenden von Expressions zum Bearbeiten und Zugreifen auf Texteigenschaften
      9. Sprachreferenz für Expressions
      10. Beispiele für Expressions
    2. Automatisierung
      1. Automatisierung
      2. Skripte
  15. Immersives Video, VR und 3D
    1. Erstellen von VR-Umgebungen in After Effects
    2. Anwenden von immersiven Videoeffekten
    3. Kompositionswerkzeuge für VR/360-Grad-Videos
    4. Erweiterter 3D-Renderer
    5. Importieren und Hinzufügen von 3D-Modellen zu Ihrer Komposition
    6. Importieren von 3D-Modellen aus Creative Cloud Libraries
    7. Bildbasierte Beleuchtung
    8. Extrahieren und Animieren von Lichtern und Kameras aus 3D-Modellen
    9. Tracking von 3D-Kamerabewegungen
    10. Werfen und akzeptieren von Schatten
    11. Eingebettete 3D-Modellanimationen
    12. Arbeiten im 3D-Designraum
    13. 3D-Transformations-Gizmos
    14. Machen Sie mehr mit 3D-Animation
    15. Vorschau von Änderungen an 3D-Designs in Echtzeit mit der Mercury 3D-Engine
    16. Hinzufügen von responsiven Designs zu Grafiken 
  16. Ansichten und Vorschau
    1. Vorschau
    2. Videovorschau mit Mercury Transmit
    3. Ändern und Verwenden von Ansichten
  17. Rendern und Exportieren
    1. Grundlagen zum Rendern und Exportieren
    2. H.264-Codierung in After Effects
    3. Exportieren eines After Effects-Projekts als Adobe Premiere Pro-Projekt
    4. Konvertieren von Filmen
    5. Multi-Frame-Rendering
    6. Automatisches Rendern und Netzwerk-Rendern
    7. Rendern und Exportieren von Standbildern und Standbildsequenzen
    8. Verwenden des GoPro CineForm-Codecs in After Effects
  18. Arbeiten mit anderen Programmen
    1. Dynamic Link und After Effects
    2. Arbeiten mit After Effects und anderen Programmen
    3. Synchronisationseinstellungen in After Effects
    4. Creative Cloud-Bibliotheken in After Effects
    5. Plug-ins
    6. Cinema 4D und Cineware
  19. Zusammenarbeit: Frame.io und Team Projects
    1. Zusammenarbeit in Premiere Pro und After Effects
    2. Frame.io
      1. Frame.io installieren und aktivieren
      2. Verwenden von Frame.io mit Premiere Pro und After Effects
      3. Häufig gestellte Fragen
    3. Team Projects
      1. Erste Schritte mit Team Projects
      2. Erstellen eines Team-Projekts
      3. Zusammenarbeiten mit Team Projects
  20. Arbeitsspeicher, Speicherung und Leistung
    1. Arbeitsspeicher und Speicherung
    2. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau behandelt    
    3. Verbessern der Leistung
    4. Voreinstellungen
    5. Anforderungen an GPU und GPU-Treiber für After Effects
  21. Wissensdatenbank
    1. Bekannte Probleme
    2. Behobene Probleme
    3. Häufig gestellte Fragen
    4. After Effects und macOS Ventura
    5. Wie After Effects Probleme mit unzureichendem Arbeitsspeicher bei der Vorschau handhabt

Ein Skript besteht aus mehreren Befehlen, die nacheinander ausgeführt werden, um verschiedene Arbeitsschritte auszuführen. In den meisten Adobe-Anwendungen können Sie Skripte verwenden, um sich wiederholende Aufgaben zu automatisieren, komplexe Berechnungen durchzuführen und sogar, um Funktionen zu nutzen, die nicht direkt in der grafischen Benutzeroberfläche zur Verfügung stehen. Sie können After Effects z. B. anweisen, die Ebenen in einer Komposition neu anzuordnen, Quelltext in Textebenen zu suchen und zu ersetzen oder eine E-Mail-Nachricht zu senden, wenn das Rendering abgeschlossen ist.

After Effects-Skripte verwenden die Adobe ExtendScript-Sprache, die eine erweiterte Form von JavaScript ist. ExtendScript-Dateien haben die Dateinamenerweiterung .jsx oder .jsxbin.

Eine Beschreibung der verfügbaren Skriptfunktionen mit After Effects finden Sie im After Effects Scripting Guide (Handbuch für Skriptprogrammierung) im After Effects Developer Center.

Skripte laden und ausführen

Beim Start von After Effects werden Skripte aus dem Ordner „Skripte geladen. Standardmäßig befindet sich der Ordner Skripte für After Effects an den folgenden Speicherorten:

  • Windows: Programme\Adobe\Adobe After Effects <version>\Support Files

  • macOS: Programme/Adobe After Effects <version>

Im Lieferumfang von After Effects sind mehrere Skripte enthalten, die automatisch im Ordner Skripte installiert werden. und alle geladenen Skripte stehen im Menü Datei > Skripte zur Verfügung.

Hinweis:
  • Wenn Sie ein Skript bearbeiten und After Effects dabei gerade ausgeführt wird, müssen Sie die Änderungen speichern, damit sie wirksam werden.
  • Wenn Sie ein Skript im Ordner Skripte ablegen und After Effects dabei ausgeführt wird, wird das Skript erst nach einem Neustart von After Effects im Menü Skripte angezeigt. Sie können das neue Skript jedoch sofort ausführen, indem Sie den Befehl Skriptdatei ausführen verwenden.

Skripte im Ordner ScriptUI Panels sind unten im Menü Fenster verfügbar. Wenn ein Skript geschrieben wurde, um eine Benutzeroberfläche in einem andockbaren Bedienfeld bereitzustellen, sollte das Skript im Ordner ScriptUI abgelegt werden. ScriptUI Panels funktionieren praktisch genauso wie die Standardbedienfelder der After Effects-Benutzeroberfläche.

Hinweis:

Standardmäßig ist es Skripten nicht gestattet, Dateien zu schreiben oder Kommunikation über ein Netzwerk zu senden oder zu empfangen. Damit Skripte Dateien schreiben und über ein Netzwerk kommunizieren können, tun Sie Folgendes:

  • Windows: Wählen Sie Bearbeiten > VoreinstellungenSkripterstellung und Expressions > Skripte können Dateien schreiben und haben Netzwerkzugriff aus.
  • macOS: Wählen Sie After Effects > VoreinstellungenSkripterstellung und Expressions > Skripte können Dateien schreiben und haben Netzwerkzugriff aus.
  • Um ein geladenes Skript auszuführen, wählen Sie Datei > Skripte > [Skriptname] aus.

  • Wenn Sie ein Skript ausführen möchten, das nicht geladen wurde, wählen Sie Datei > Skripte > Skriptdatei ausführen aus, wählen Sie ein Skript aus und klicken Sie dann auf Öffnen.

  • Um ein laufendes Skript zu stoppen, drücken Sie Esc.

  • Wenn Sie ein Skript über die Befehlszeile ausführen möchten, geben Sie afterfx.exe in die Befehlszeile ein. Geben Sie bei der Ausführung als Argumente -r und den vollständigen Pfad des Skripts an. Dadurch wird keine neue Instanz von After Effects geöffnet, sondern das Skript wird in der vorhandenen Instanz ausgeführt.

    Beispiel (Windows): afterfx -r c:\script_path\example_script.jsx

Hinweis:

Sie können diese Befehlszeilentechnik – zusammen mit der Software, die mit einer anpassbaren Tastatur geliefert wird –verwenden, um zum Aufrufen eines Skripts einen Tastaturbefehl festzulegen.

Sie können die Liste der zehn zuletzt in After Effects ausgeführten Skripte anzeigen. Um die Liste anzuzeigen, wählen Sie Datei > Skripte > Letzte Skriptdateien aus.

Um eines der zehn zuletzt ausgeführten Skripte erneut auszuführen, verwenden Sie Folgendes:

  • macOS: Cmd+Wahltaste+Umschalttaste+D
  • Windows: Ctrl+Alt+Umschalt+D
Hinweis:

Auf der AE-Skripts-Website gibt Lloyd Alvarez einen Tipp zum Ausführen von .jsxbin-Skripts, wenn Sie keinen Zugang zum Ordner „Skripte“ bzw. „ScriptUI Panels“ haben.

In After Effects bereitgestellte Skripte

After Effects bietet mehrere bereits programmierte Skripte, die Ihnen bei der Durchführung gängiger Aufgaben helfen und die Basis für die Änderung und Erstellung von eigenen Skripten bieten.

Tipp:

Führen Sie das Beispielskript Demo Palette.jsx aus, um zu sehen, was Sie mit Skripten alles tun können.

Skripte schreiben und ändern

Mit dem Skripteditor, der Bestandteil des Toolkits „ExtendScript“ ist, können Sie eigene Skripte für die Verwendung in After Effects schreiben. Das Toolkit „ExtendScript“ bietet eine benutzerfreundliche Oberfläche zum Erstellen, Debuggen und Testen Ihrer eigenen Skripte. Manchmal ist nur eine geringfügige Änderung an einem vorhandenen Skript notwendig, um ein Skript für die von Ihnen gewünschte Funktion zu erstellen. Solche geringfügige Änderungen können oft auch mit nur wenigen Kenntnissen in Computerprogrammierung oder Skriptsprachen ausgeführt werden.

Um den Skripteditor zu starten, wählen Sie Datei > Skripte > Skripteditor öffnen aus.

Weitere Informationen finden Sie im Handbuch zur Skripterstellung in After Effects.

Skriptzugriff

Skriptzugriff für Animationsvorlagen

Mit Skripten lassen sich Eigenschaften zum Bedienfeld Essential Graphics hinzufügen und Animationsvorlagen exportieren, indem die folgenden Skripterstellungsmethoden verwendet werden:

  • Methode canAddToMotionGraphicsTemplate() für Eigenschaft
app.project.item(index).layer(index).propertySpec.canAddToMotionGraphicsTemplate(comp) 

Testen Sie, ob die Eigenschaft für die angegebene Komposition zum Bedienfeld Essential Graphics hinzugefügt werden kann oder nicht. Gibt den Wert „true“ zurück, wenn die Eigenschaft hinzugefügt werden kann, andernfalls wird der Wert „false“ zurückgegeben. Wenn die Eigenschaft nicht hinzugefügt werden kann, wird entweder ihr Eigenschaftstyp nicht unterstützt oder die Eigenschaft wurde bereits zu dieser Komposition hinzugefügt. After Effects zeigt eine Warnung an. 

Unterstützte Eigenschaftstypen:

  • Kontrollkästchen
  • Farbe
  • Numerischer Schieberegler (d. h. eine numerische Eigenschaft mit einem einzelnen Wert), z. B. Transformieren > Deckkraft oder der Expression-Steuerungseffekt Schieberegler).
  • Quelltext

Parameter:

Komposition

Die Komposition, für die Sie testweise die Eigenschaft „compItem“ hinzufügen möchten.

Gibt zurück: Boolescher Wert.


  • Methode addToMotionGraphicsTemplate() für Eigenschaft
app.project.item(index).layer(index).propertySpec.addToMotionGraphicsTemplate(comp)

Fügen Sie die Eigenschaft für die angegebene Komposition zum Bedienfeld Essential Graphics hinzu. Gibt den Wert „true“ zurück, wenn die Eigenschaft erfolgreich hinzugefügt wurde, andernfalls wird der Wert „false“ zurückgegeben. Wenn die Eigenschaft nicht hinzugefügt wurde, wird entweder ihr Eigenschaftstyp nicht unterstützt oder die Eigenschaft wurde bereits zu dieser Komposition hinzugefügt. After Effects zeigt eine Warnmeldung an. Nutzen Sie die Methode canAddToMotionGraphicsTemplate(), um zu testen, ob die Eigenschaft zu einer Animationsvorlage hinzugefügt werden kann.

Parameter:

Komposition

Die Komposition, für die Sie testweise die Eigenschaft „compItem“ hinzufügen möchten.

Gibt zurück: Boolescher Wert.


  • Attribut MotionGraphicsTemplateName für CompItem 
app.project.item(index).motionGraphicsTemplateName

Lesen oder schreiben Sie die Namens-Eigenschaft für die Komposition in das Bedienfeld Essential Graphics. Der Name im Bedienfeld Essential Graphics wird als Dateiname für eine exportierte Animationsvorlage verwendet, beispielsweise Meine Vorlage.mogrt. Im folgenden Beispiel wird der Name für die aktive Komposition festgelegt und dann als Warnhinweis zurückgegeben: 

app.project.activeItem.motionGraphicsTemplateName = “Meine Vorlage”; 
alert(app.project.activeItem.motionGraphicsTemplateName);

Typ: Zeichenfolge; Lese-/Schreibzugriff.


  • Methode exportAsMotionGraphicsTemplate() für CompItem
app.project.item(index).exportAsMotionGraphicsTemplate(doOverWriteFileIfExisting, file_path)

Exportieren Sie Ihre Komposition als Animationsvorlage. Gibt den Wert „true“ zurück, wenn die Animationsvorlage erfolgreich exportiert wurde, andernfalls wird der Wert „false“ zurückgegeben. Der Name im Bedienfeld Essential Graphics wird als Dateiname der Animationsvorlage verwendet, beispielsweise Meine Vorlage.mogrt. Verwenden Sie das Attribut motionGraphicsTemplateName, um den Namen festzulegen. Geben Sie optional den Pfad zu dem Ordner an, in dem die Animationsvorlage gespeichert ist. Wenn nicht angegeben, wird die Datei im aktuellen Ordner „Essential Graphics“ des Benutzers gespeichert:

  • macOS: /Benutzer//Library/Application Support/Adobe/Common/Essential Graphics/
  • Windows: C:\Benutzer\\AppData\Roaming\Adobe\Common\Essential Graphics\

Wenn das Projekt seit dem letzten Speichern geändert wurde, fordert After Effects den Benutzer auf, das Projekt zu speichern. Um dies zu vermeiden, verwenden Sie die Methode save() für das Projekt, bevor Sie die Animationsvorlage exportieren.

Parameter:

doOverWriteFileIfExisting

Legt fest, ob eine vorhandene Datei mit demselben Namen überschrieben werden soll. Boolescher Wert, erforderlich.

file_path

Pfad zu dem Ordner, in dem die Datei gespeichert wird. Optional.

Gibt zurück: Boolescher Wert.


  • Methode openInEssentialGraphics() für CompItem
app.project.item(index).openInEssentialGraphics() 

Weitere nützliche Skripte

Skripte, Projekte und andere nützliche Elemente finden Sie auf der Website Adobe Add-ons.

Das AE Enhancers Forum enthält Beispielskripte und nützliche Informationen zur Skripterstellung (sowie Expressions und Animationsvorgaben) in After Effects.

 Adobe

Schneller und einfacher Hilfe erhalten

Neuer Benutzer?