Bewegungspfade

Beim Animieren räumlicher Eigenschaften, z. B. „Position“, „Ankerpunkt“ und Eigenschaften für Effektankerpunkte, wird die Bewegung als Bewegungspfad angezeigt. Bewegungspfade werden als Folge von Punkten dargestellt, wobei jeder Punkt eine Position der Ebene im jeweiligen Frame kennzeichnet. Ein Kästchen im Pfad zeigt an, dass sich an dieser Position ein Keyframe befindet.

Zusätzlich zum Zeitleistenfenster stellen Bewegungspfade ganz einfach eine Alternative zur optischen und räumlichen Darstellung von und dem Arbeiten mit räumlichen Eigenschaften und den zugehörigen Keyframes dar. Sie können einen Bewegungspfad ändern, indem Sie einen vorhandenen Keyframe ändern oder einen neuen Keyframe hinzufügen. Sie können die Form eines Bewegungspfads ändern, indem Sie die Methoden für die räumliche Interpolation seiner Keyframes ändern. (Siehe Räumliche und zeitliche Keyframe-Interpolation.)

Die Dichte der Punkte zwischen den Rahmen in einem Bewegungspfad gibt die relative Geschwindigkeit der Ebene oder des Effektankerpunkts an. Wenn die Punkte dicht nebeneinander liegen, bedeutet dies eine geringe Geschwindigkeit. Wenn die Punkte weiter auseinander liegen, ist die Geschwindigkeit höher.

Hinweis:

Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf einen Keyframe, um das zugehörige Kontextmenü anzuzeigen.

Das Bearbeiten von Keyframes für eine räumliche Eigenschaft mit dem Zeichenstift oder dem Auswahl-Werkzeug im Kompositions- oder Ebenenfenster ähnelt dem Bearbeiten eines Bézier-Pfades für eine Maske oder für eine Form auf einer Formebene. (Siehe Pfade.)

Ein Bewegungspfad ist weniger komplex und in der Regel einfacher zu bearbeiten, wenn Sie zur Pfadbeschreibung nur wenige Keyframes verwenden. Mit dem Befehl „Glätten“ können Sie überflüssige Keyframes aus dem Pfad entfernen.

Anzeigen der Bewegungspfadsteuerungen

Die Bewegungspfade für „Position“ werden im Kompositionsfenster und die Bewegungspfade für „Ankerpunkt“ und für Effektankerpunkte im Ebenenfenster angezeigt.

  • Für die Anzeige der Bewegungspfadsteuerungen im Kompositionsfenster wählen Sie „Ansicht“ > „Anzeigeoptionen“ und anschließend die Optionen „Effekteinstellungen“, „Keyframes“, „Bewegungspfade“ und „Bewegungsgriffe“ aus. Um „Position“-Bewegungspfade im Kompositionsfenster anzuzeigen, muss die Eigenschaft „Position“ ausgewählt sein.
  • Um die Bewegungspfadsteuerungen im Ebenenfenster anzuzeigen, wählen Sie die jeweilige Eigenschaft oder den Effekt im Menü „Ansicht“ im unteren Bereich des Ebenenfensters aus.
  • Um die Anzahl der Keyframes festzulegen, die für einen Bewegungspfad angezeigt werden sollen, wählen Sie „Bearbeiten“ > „Voreinstellungen“ > „Anzeige“ (Windows) bzw. „After Effects“ > „Einstellungen“ > „Anzeige“ (Mac OS) und eine Option im Abschnitt „Bewegungspfad“ aus.
  • Um die Größe der Richtungsgriffpunkte der Bézier-Interpolation für Bewegungspfade anzugeben, wählen Sie „Bearbeiten“ > „Voreinstellungen“ > „Allgemein“ (Windows) bzw. „After Effects“ > „Einstellungen“ > „Allgemein“ (MacOS) aus, und bearbeiten Sie den Wert „Größe des Pfadpunkts“.

Verschieben von Bewegungspfad-Keyframes

  1. Wählen Sie im Zeitleistenfenster die Ebene aus, für die der Bewegungspfad geändert werden soll.
  2. Wenn Sie den Keyframe, den Sie ändern möchten, nicht im Kompositions- oder Ebenenfenster sehen können, verschieben Sie die Zeitmarke für den aktuellen Zeitpunkt auf den Keyframe.
  3. Verwenden Sie im Kompositions- oder Ebenenfenster das Auswahl-Werkzeug, um den Keyframe oder dessen Griffe zu ziehen.

    Hinweis:

    Die Zeitmarke für den aktuellen Zeitpunkt muss sich beim Beginn des Ziehens nicht auf einem Keyframe befinden.

    Ziehen Sie einen Keyframe im Kompositionsfenster, um einen „Position“-Keyframe zu verschieben
    Ziehen Sie einen Keyframe im Kompositionsfenster, um einen „Position“-Keyframe zu verschieben.

    Sie können mehrere Keyframes gleichzeitig verschieben, indem Sie diese im Zeitleistenfenster auswählen, bevor Sie sie im Kompositions- oder Ebenenfenster ziehen. Um den gesamten Bewegungspfad zu verschieben, wählen Sie alle Keyframes aus, indem Sie auf den Eigenschaftsnamen im Zeitleistenfenster klicken, bevor Sie den Keyframe im Kompositionsfenster ziehen.

    Ziehen aller Keyframes auf einem Bewegungspfad um einen Keyframe
    Ziehen aller Keyframes auf einem Bewegungspfad um einen Keyframe

Hinzufügen eines Keyframes zu einem Bewegungspfad mit dem Zeichenstift

  1. Zeigen Sie den zu ändernden Bewegungspfad im Kompositions- oder Ebenenfenster an.
  2. Wählen Sie aus der Werkzeugpalette den Zeichenstift  oder das Scheitelpunkt-hinzufügen-Werkzeug aus.
  3. Platzieren Sie den Zeichenstift im Kompositionsfenster über dem Bewegungspfad, dem der neue Keyframe hinzugefügt werden soll, und klicken Sie, um den Keyframe hinzuzufügen.

    An dem Frame, auf den Sie geklickt haben, wird auf dem Bewegungspfad und im Zeitleistenfenster ein neuer Keyframe angezeigt. Verwenden Sie zum Verschieben des Keyframes das Auswahl-Werkzeug.

    Hinweis:

    Die Techniken zum Bearbeiten von Bewegungspfadkurven mit dem Zeichenstift funktionieren ähnlich wie die Techniken zum Erstellen bzw. Ändern anderer Bézier-Pfade (z. B. Masken- und Formenpfade), wenn auch die Ergebnisse unterschiedlich sind.

Skizzieren eines Bewegungspfades mit „Bewegung skizzieren“

Mithilfe von Bewegungsskizzen können Sie einen Pfad für die Bewegung der ausgewählten Ebene zeichnen, der die Position der Ebene und die Geschwindigkeit, mit der Sie zeichnen, aufzeichnet. Während Sie zeichnen, wird an jedem Frame ein „Position“-Keyframe erstellt.

Bewegungsskizzen wirken sich nicht auf Keyframes aus, die Sie für andere Eigenschaften gesetzt haben. Wenn Sie zum Beispiel „Drehung“-Keyframes für das Bild eines Balls einrichten, können Sie Bewegungsskizzen verwenden, um „Position“-Keyframes zu erstellen, sodass der Ball am von Ihnen erstellten Pfad entlang zu rollen scheint.

John Dickinson stellt eine Demonstration der Bewegungsskizzierung in einem Video-Tutorial auf seiner Motionworks-Website bereit.

  1. Wählen Sie im Kompositions- oder im Zeitleistenfenster die Ebene aus, für die Sie einen Bewegungspfad skizzieren möchten.
  2. Stellen Sie die Arbeitsbereichsmarken im Zeitleistenfenster auf die Dauer ein, in der Sie die Bewegung skizzieren möchten.
  3. Wenn Sie während des Skizzierens die Audiodaten in Ihrer Komposition hören möchten, stellen Sie sicher, dass im Vorschaufenster die Schaltfläche „Ton ausschalten“ nicht aktiviert ist.
  4. Wählen Sie „Fenster“ > „Bewegung skizzieren“.
  5. Aktivieren Sie anschließend eine der folgenden Optionen:

    Anzeigen: Drahtgitter

    Zeigt beim Skizzieren des Bewegungspfads eine Drahtgitteransicht der Ebene an.

    Anzeigen: Hintergrund

    Zeigt beim Skizzieren den statischen Inhalt des Frames an, bei dem Sie mit dem Skizzieren begonnen haben. Diese Option ist hilfreich, wenn Sie Bewegungen im Verhältnis zu anderen Bildern in Ihrer Komposition skizzieren möchten.

    Glätten

    Entfernt unnötige Keyframes aus dem Bewegungspfad. Diese Einstellung erzielt dasselbe Ergebnis wie die Einstellung „Toleranz“ bei Verwendung des Befehls „Glätten“. Höhere Werte führen zu glatteren Kurven; bei zu hohen Werten kann es jedoch vorkommen, dass die ursprüngliche Form der gezeichneten Kurve nicht beibehalten wird.

    Hinweis:

    Sie können einen Pfad nach seiner Erstellung glätten, indem Sie die smooth-Expression (Glätten) oder den Befehl „Glätten“ anwenden.

    Aufnahmegeschwindigkeit bei

    Das Verhältnis der Geschwindigkeit der aufgezeichneten Bewegung zur Wiedergabegeschwindigkeit. Wenn „Aufnahmegeschwindigkeit bei“ auf 100 % eingestellt ist, wird die Bewegung mit der Geschwindigkeit wiedergegeben, mit der sie aufgenommen wurde. Wenn „Aufnahmegeschwindigkeit bei“ auf mehr als 100 % eingestellt ist, wird die Bewegung langsamer wiedergegeben als sie aufgenommen wurde.

  6. Klicken Sie auf „Aufnahme beginnen“ und ziehen Sie dann im Kompositionsfenster, um den Bewegungspfad zu erstellen. Lassen Sie die Maustaste los, um die Aufnahme anzuhalten.

    Hinweis:

    After Effects beendet die Aufnahme automatisch, wenn das Ende des Arbeitsbereichs (standardmäßig ist dies die Kompositionsdauer) erreicht wird.

Erstellen eines Bewegungspfades aus Masken, Formen oder Konturpfaden

Sie können einen Bewegungspfad aus verschiedenen Pfadtypen erstellen:

  • der Eigenschaft „Maskenpfad“

  • der Formeigenschaft „Pfad“ auf einer Formebene

  • der Eigenschaft „Pfad“ für eine Kontur

  • einem Pfad, der aus Illustrator oder Photoshop kopiert wurde

Jeder dieser Pfade kann in die Ebeneneigenschaft „Position“ bzw. „Ankerpunkt“ oder in die Eigenschaft „Position“ eines Effektankerpunktes eingefügt werden. Die eingefügten Keyframes, mit Ausnahme des ersten und des letzten, sind zeitlich nicht fixiert, um eine konstante Geschwindigkeit entlang des Pfades zu erzielen.

Standardmäßig beträgt die Dauer des eingefügten Bewegungspfades 2 Sekunden. Sie können die Dauer durch Ziehen des ersten oder letzten Keyframes im Zeitleistenfenster anpassen.

  1. Kopieren eines Pfades in die Zwischenablage:
    • Wählen Sie eine Pfadeigenschaft im Zeitleistenfenster und anschließend „Bearbeiten“ > „Kopieren“ aus.

    • Wählen Sie einen Pfad in Illustrator oder Photoshop und anschließend „Bearbeiten“ > „Kopieren“ aus.

  2. Wählen Sie im Zeitleistenfenster die Eigenschaft aus, in die der Pfad eingefügt werden soll.
  3. Setzen Sie die Zeitmarke für den aktuellen Zeitpunkt auf die Zeit für den ersten Keyframe des Bewegungspfades.
  4. Wählen Sie „Bearbeiten“ > „Einfügen“ (Windows) bzw. „Bearbeiten“ > „Einsetzen“ (Mac OS).

Andrew Devis zeigt in diesem Video auf der Creative COW-Website , wie Pfade aus Illustrator als Bewegungspfade in After Effects verwendet werden.

Bewegungsunschärfe

Wenn Sie einen einzelnen Frame eines Kino- oder Videofilms betrachten, in dem ein bewegtes Objekt enthalten ist, wirkt das Bild oft verschwommen, da der Frame einen Zeitausschnitt abbildet (bei Filmen ist ein Frame beispielsweise 1/24 Sekunde lang). In dieser Zeit befindet sich das Objekt an mehreren Positionen auf seinem Weg innerhalb des Frames, es wird also nicht als scharf abgegrenztes Standobjekt angezeigt. Je schneller sich das Objekt bewegt, desto unschärfer erscheint es. Der Verschlusswinkel und die Verschlussphase der Kamera wirken sich ebenfalls auf die Unschärfe aus. Sie bestimmen, wie lange der Verschluss geöffnet bleibt und wann der Verschluss relativ zum Anfang des Frames geöffnet wird.

Im Unterschied dazu können Sie bei einem einzelnen Frame einer mit dem Computer erstellten Animation u. U. nicht sagen, welche Objekte sich bewegen, weil alle sich bewegenden Objekte genauso scharf und deutlich erscheinen wie die sich nicht bewegenden Objekte. Ohne Bewegungsunschärfe entsteht bei der Ebenenanimation statt eines kontinuierlichen Ablaufs ein stroboskopähnlicher Effekt, bei dem die Bewegung „abgehackt“ aussieht. Wenn Sie den Ebenen, die Sie in After Effects animieren, Bewegungsunschärfe hinzufügen, erscheint die Bewegung glatter und natürlicher.

Sie aktivieren die Bewegungsunschärfe für jede einzelne Ebene und Sie bestimmen, ob die Bewegungsunschärfe für Vorschauen oder für die endgültige Ausgabe gerendert wird. Mit dem Kompositionenschalter „Bewegungsunschärfe aktivieren“ im oberen Bereich des Zeitleistenfensters können Sie das Rendern der Bewegungsunschärfe für Vorschauen aktivieren oder deaktivieren. Ändern der Rendereinstellungen im Renderlistenfenster, um das Rendern der Bewegungsunschärfe für die endgültige Ausgabe zu aktivieren oder zu deaktivieren. Wenn die Einstellung „Schalter beeinflussen verschachtelte Kompositionen“ im Bereich „Allgemeine Voreinstellungen“ aktiviert ist, unterliegen verschachtelte Kompositionen der Einstellung der Kompositionen, in denen sie enthalten sind. (Siehe Erstellen von Unterkompositionen und Verschachteln.)

Da die Bewegungsunschärfe das Rendern verlangsamt, sollten Sie den Kompositionsschalter während der Arbeit deaktivieren und nur dann aktivieren, wenn Sie das endgültige Ergebnis anzeigen möchten.

Um die Bewegungsschärfe für eine Ebene zu aktivieren, führen Sie einen der folgenden Schritte aus:

  • Klicken Sie im Zeitleistenfenster auf den Ebenenschalter „Bewegungsunschärfe“ für die jeweilige Ebene.
  • Wählen Sie die Ebene und „Ebene“ > „Schalter“ > „Bewegungsunschärfe“ aus.

Die Anzahl von Samples in After Effects für die Berechnung der Bewegungsunschärfe wird jeder Ebene angepasst und richtet sich nach der Bewegung der jeweiligen Ebene. Diese Anpassbarkeit sorgt für eine hochwertige Bewegungsunschärfe. Bei einer sich langsam bewegenden Ebene ist dabei kein so häufiges Sampling erforderlich wie bei einer sich schnell bewegenden Ebene. Hohe Sampleraten vermindern die Render-Leistung.

Wenn „Bewegungsunschärfe“ für eine Komposition aktiviert und das Zeitleistenfenster eingezoomt ist, sodass Sie einzelne Frames erkennen können, gibt ein hellgrauer Bereich um die Zeitmarke die Verschlussphase und den Verschlusswinkel an. In der Spaltenbreite finden Sie den Verschlusswinkel und im Spaltenversatz die Verschlussphase an. Diese optische Darstellung zeigt, wie einzelne Frames für die Berechnung der Bewegungsunschärfe in dieser Komposition aufgenommen werden.

Beim Animieren einer Ebene können Sie mit Bewegungsunschärfe arbeiten, z. B. wenn Sie eine Textebene über den Bildschirm laufen lassen. Einer Bewegung, die bereits in einer Ebene vorhanden ist, können Sie mit dem Ebenenschalter „Bewegungsunschärfe“ und dem Kompositionsschalter „Bewegungsunschärfe aktivieren“ keine Bewegungsunschärfe hinzufügen.

Wenn Sie die Bewegungsabläufe in Videos glätten möchten, denen Sie eine Framerate zugewiesen haben, die weit unter oder über der des Originals liegt, verwenden Sie die Option „Frame-Überblendung“ und nicht „Bewegungsunschärfe“.

Informationen zum Erstellen einer gefälschten Bewegungsunschärfe finden Sie unter Anwenden von Bewegungsunschärfe.

Bewegungsunschärfeeinstellungen auf der Registerkarte „Erweitert“ der Kompositionseinstellungen

Samples pro Frame

Die Mindestanzahl von Samples. Dies ist die Mindestanzahl an Samples für Frames, für die eine adaptive Samplerate, die auf der Ebenenbewegung basiert, in After Effects nicht definiert werden kann. Diese Samplerate wird für 3D-Ebenen und Formebenen verwendet.

Grenzwert für adaptive Samples

Die Höchstanzahl von Samples.

Verschlusswinkel

Der Verschlusswinkel wird in Grad angegeben und simuliert die durch einen sich drehenden Verschluss erzeugte Belichtung. Der Verschlusswinkel verwendet die Footage-Framerate, um die simulierte Belichtung zu bestimmen, die sich auf die Bewegungsunschärfe auswirkt. Wenn Sie z. B. für 24-fps-Footage „90°“ (25 % von 360°) eingeben, ergibt sich eine effektive Belichtung von 1/96 einer Sekunde (25 % von 1/24 Sekunde). Wenn Sie 1° festlegen, wird fast keine Bewegungsunschärfe angewendet, während bei 720° eine sehr hohe Bewegungsunschärfe angewendet wird.

Verschlussphase

Die Verschlussphase wird ebenfalls in Grad gemessen. Sie bestimmt, wann der Verschluss relativ zum Frame-Anfang geöffnet wird. Das Anpassen dieses Wertes kann helfen, wenn ein Objekt mit angewendeter Bewegungsunschärfe scheinbar hinter der Position eines Objekts zurückbleibt, auf das keine Bewegungsschärfe angewendet wurde.

Hinweis:

Für eine Ebene, die unter Verwendung von Motion-Tracking-Daten über eine andere Ebene gelegt wird, ist ein Verschlussphasenwert von -1/2 des Verschlusswinkelwerts optimal. (Beispiel: Verschlussphase = -90, Verschlusswinkel = 180.) Durch diese Einstellungskombination entsteht eine auf dem ursprünglichen Objekt zentrierte Unschärfe.

Anwenden von Bewegungsunschärfe auf eine Maske

Mit Bewegungsunschärfe erzeugen Sie eine Unschärfe basierend auf der Bewegung einer Maske in der Komposition. Sie können Bewegungsunschärfe auf einzelne Masken anwenden. Sie müssen für jede Ebene oder Maske innerhalb einer Ebene auf den Schalter „Bewegungsunschärfe aktivieren“ der Komposition klicken, um Bewegungsunschärfe auf die Ebene oder Maske anzuwenden.

  1. Wählen Sie eine oder mehrere Masken aus.
  2. Wählen Sie „Ebene“ > „Maskieren“ > „Bewegungsunschärfe“ und klicken Sie dann auf eine der folgenden Optionen:

    Wie Ebene

    Auf die Maske wird nur dann Bewegungsunschärfe angewendet, wenn auf den Schalter „Bewegungsunschärfe“ der Ebene geklickt wurde.

    Ein

    Auf die Maske wird Bewegungsunschärfe unabhängig von der Einstellung des Schalters „Bewegungsunschärfe“ der Ebene angewendet.

    Aus

    Auf die Maske wird keine Bewegungsunschärfe angewendet.

Weitere Ressourcen zur Bewegungsunschärfe

Wenn Sie ein Objekt aufnehmen, das sich schnell bewegt, entsteht beim Rendern des Objekts eine Bewegungsunschärfe. Wenn Sie sich bewegende Objekte mit einer hohen Verschlussgeschwindigkeit aufnehmen, scheinen die Objekte zwischen Frames zu springen, was zu einer „stotternden“ Bewegung führt.

Der Effekt „Pixel-Bewegungsunschärfe“ in After Effects CC verfolgt die Bewegung von Pixeln zwischen Frames. Der Effekt analysiert einen Clip, um festzustellen, welche Teile sich bewegen, erstellt eine Reihe von Bewegungsvektoren und verwendet diese Informationen dann, um die BewegungsunschärfeimFrame hinzuzufügen.

Wenn sich das Objekt zu schnell bewegt, erhöhen Sie den Wert von Verschluss-Samples, um mehr Zwischenframes zu erstellen. Erhöhen Sie den Wert von Vektordetail, um Fehler zu vermeiden, wenn Pixelgruppen zwischen Frames analysiert werden. 

Chris und Trish Meyer haben ein Video-Tutorial zum Effekt „Pixel-Bewegungsunschärfe“ auf der ProVideo Coalition-Website bereitgestellt.

Todd Kopriva schreibt in seinem offiziellen After Effects-Blog über diesen Effekt.

Weitere Informationen zu anderen Zeiteffekten in After Effects finden Sie unter Zeiteffekte.

Mark Christiansen erläutert auf der ProVideo Coalition-Website einige Konzepte im Zusammenhang mit Bewegungsunschärfe, Verschlussgeschwindigkeit und Verschlusswinkel.

Andrew Kramer demonstriert in einem Video-Lehrgang auf seiner Video Copilot-Website die Vorteile der Verwendung von 32-bpc-Farbe mit Bewegungsunschärfe. (Siehe Farbtiefe und HDR-Farben.)

Glätten von Bewegungen und Geschwindigkeit durch Entfernen zusätzlicher Keyframes

Sie können Bewegungspfade, Wertkurven und Geschwindigkeitskurven glätten und so unruhige Stellen oder überflüssige Keyframes beseitigen. Verwenden Sie dazu das Glätten-Werkzeug, mit dem Keyframes hinzugefügt bzw. nicht benötigte Keyframes entfernt werden können.

Hinweis:

Sie können für diesen Zweck aber ebenso gut auch die Expression-Methode Glätten verwenden, ohne Keyframes zu entfernen. (Siehe Eigenschaftsattribute und -methoden (Expression-Referenz).)

Mit dem Glätten-Werkzeug können Sie zwar Kurven für jede Eigenschaft glätten, aber besonders hilfreich ist dieses Werkzeug, wenn es auf Kurven angewendet wird, die mit der Funktion „Bewegung skizzieren“ automatisch erstellt wurden, wobei überflüssige Keyframes entstehen können. Wenn Sie das Glätten-Werkzeug auf Keyframes anwenden, die manuell erstellt wurden, kann es allerdings zu unerwarteten Änderungen der Kurve kommen.  

Hinweis:

Damit der Befehl „Glätten“ nicht nachträglich auf einen Pfad angewendet werden muss, der mit „Bewegung skizzieren“ erstellt wurde, stellen Sie die Option „Glätten“ im Feld „Bewegung skizzieren“ ein, bevor Sie den Bewegungspfad skizzieren.

Wenn Sie das Glätten-Werkzeug auf Eigenschaften anwenden, die sich räumlich ändern (z. B. die Eigenschaft „Position“), können Sie lediglich die räumliche Kurve glätten (also die Kurve, die durch die Bewegung definiert wird). Wenn Sie das Glätten-Werkzeug hingegen auf Eigenschaften anwenden, die sich nur zeitlich ändern (z. B. die Eigenschaft „Deckkraft“), können Sie nur die Wert- und die Geschwindigkeitskurve glätten (also die Kurve, die durch den Wert bzw. die Geschwindigkeit definiert wird).

Außer dem Hinzufügen oder Entfernen überflüssiger Keyframes wendet das Glätten-Werkzeug beim Glätten der zeitlichen Kurve auch auf jeden Keyframe die Bézier-Interpolation an. (Siehe Keyframe-Interpolationsmethoden.)

  1. Wählen Sie im Zeitleistenfenster entweder alle Keyframes für eine Eigenschaft aus, um eine ganze Kurve zu glätten, oder wählen Sie mindestens drei Keyframes aus, wenn nur ein bestimmter Teil einer Kurve geglättet werden soll.
  2. Wählen Sie „Fenster“ > „Glätten“. Im Menü „Anwenden auf“ wählt das Glätten-Werkzeug je nach dem Typ der Eigenschaft, für die Sie in Schritt 1 Keyframes ausgewählt haben, automatisch die Option „Bewegungspfad“ oder „Zeitliche Kurve“ aus.
  3. Legen Sie einen Wert unter „Toleranz“ fest. Die Toleranzeinheiten stimmen mit den Einheiten der Eigenschaft überein, für die Sie die Glättung vornehmen. Neue Keyframe-Werte weichen nicht mehr als der festgelegte Wert von der Originalkurve ab. Höhere Werte führen zu glatteren Kurven; bei zu hohen Werten kann es jedoch passieren, dass die Originalform der Kurve nicht beibehalten wird.
  4. Klicken Sie auf „Anwenden“ und sehen Sie sich die Ergebnisse in der Vorschau an.
  5. Wählen Sie ggf. „Bearbeiten“ > „Rückgängig: Glätten“ (Windows) bzw. „Widerrufen: Glätten“ (Mac OS), um die Keyframes zurückzusetzen, ändern Sie den Wert für „Toleranz“ und klicken Sie dann erneut auf „Anwenden“.

Versehen einer Eigenschaft mit Zufälligkeit durch „Verwackeln“

Mit „Verwackeln“ haben Sie die Möglichkeit, jeder Eigenschaft Zufälligkeit in Form von Schwankungen im Zeitverlauf hinzuzufügen.

Hinweis:

Sie können aber ebenso gut auch die Expression-Methode Verwackeln zu diesem Zweck verwenden. In den meisten Fällen ist es einfacher, die Expression zu verwenden, als die Funktion „Verwackeln“. (Siehe Eigenschaftsattribute und -methoden (Expression-Referenz).)

Je nach der Eigenschaft und den von Ihnen festgelegten Optionen sorgt „Verwackeln“ für eine bestimmte Anzahl von Abweichungen bei einer Eigenschaft. Dies geschieht durch Hinzufügen von Keyframes und Anwenden von Zufallsparametern auf Interpolationen zu oder von vorhandenen Keyframes. Wenn Sie „Verwackeln“ einsetzen möchten, benötigen Sie mindestens zwei Keyframes.

Mit „Verwackeln“ können Sie natürliche Bewegungen innerhalb festgelegter Grenzen realistischer simulieren. Beispielsweise könnten Sie einen animierten Schmetterling mit Zufälligkeit versehen, um die Illusion zu erwecken, dass der Schmetterling flattert. Setzen Sie Zufälligkeit z. B. bei Helligkeit oder bei Deckkraft ein, um das Flackern eines alten Projektors zu simulieren.

  1. Wählen Sie einen Bereich von Keyframes für die Eigenschaft aus.
  2. Wählen Sie „Fenster“ > „Verwackeln“.
  3. Wählen Sie bei „Anwenden auf“ die Art der Kurve, die durch „Verwackeln“ geändert werden soll. Wenn Sie Keyframes für eine Eigenschaft mit räumlichen Schwankungen ausgewählt haben, können Sie wahlweise „Bewegungspfad“ aktivieren, um die Bewegung mit Abweichungen zu versehen, oder „Zeitliche Kurve“ wählen, wenn Sie der Geschwindigkeit Abweichungen hinzufügen möchten. Wenn Sie Keyframes für eine Eigenschaft ohne räumliche Schwankungen ausgewählt haben, können Sie nur „Zeitliche Kurve“ auswählen.
  4. Wählen Sie unter „Störung“ eine Option, um die Art der Abweichung durch zufällig verteilte Pixelwerte (also die Art der Störung) festzulegen:

    Glätten

    Erstellt Abweichungen, die allmählich ohne plötzliche Änderungen eintreten.

    Eckige Störung

    Erstellt abrupte Änderungen.

  5. Wählen Sie die Dimension der Eigenschaft, die Sie beeinflussen möchten:

    X, Y oder Z

    Fügt nur einer Richtung der ausgewählten Eigenschaft Abweichungen hinzu. Wählen Sie die Richtung aus dem Menü.

    Alle unabhängig

    Fügt jeder Richtung unabhängig einen anderen Satz Abweichungen hinzu.

    Alle gleich

    Fügt allen Richtungen denselben Satz Abweichungen hinzu.

  6. Geben Sie einen Wert unter „Häufigkeit“ an, um festzulegen, wie viele Abweichungen (Keyframes) pro Sekunde den ausgewählten Keyframes in After Effects hinzugefügt werden sollen. Bei einem niedrigen Wert werden nur gelegentliche Abweichungen erzeugt, während ein hoher Wert zu sprunghaften, ungleichmäßigen Ergebnissen führt. Bei einem Wert kleiner 1 werden Keyframes in Intervallen von weniger als einem Keyframe pro Sekunde erzeugt. bei einem Wert von 0,5 ergibt sich z. B. alle 2 Sekunden ein neuer Keyframe.
  7. Legen Sie unter „Stärke“ die maximale Größe der Abweichungen fest. After Effects stimmt die festgelegte Stärke auf die Einheiten der ausgewählten Eigenschaft ab, sodass ein Wert bei einer bestimmten Eigenschaft zu ganz anderen Ergebnissen als bei anderen Eigenschaften führen kann.
  8. Klicken Sie auf „Anwenden“ und sehen Sie sich die Ergebnisse in der Vorschau an.
  9. Wählen Sie, falls notwendig, „Bearbeiten“ > „Rückgängig: Verwackeln“ (Windows) bzw. „Widerrufen: Verwackeln“ (Mac OS), um die Keyframes zurückzusetzen. Stellen Sie die Werte für „Häufigkeit“ und „Stärke“ ein und wenden Sie dann erneut „Verwackeln“ an.

Konvertieren von Audio in Keyframes

Der Keyframe-Assistent „Audio in Keyframes konvertieren“ analysiert die Audioamplitude im Arbeitsbereich und erstellt Keyframes für diese Audioamplitude.

  1. Wählen Sie bei aktiver Komposition im Kompositions- oder Zeitleistenfenster die Option „Animation“ > „Keyframe-Assistent“ > „Audio in Keyframes konvertieren“.

Dabei legt der Keyframe-Assistent eine Audioamplituden-Ebene an, die alle Audioquellen in der Komposition repräsentiert. Drei Effekte unter „Einstellungen für Expressions“ mit Reglersteuerung enthalten dabei die folgenden Keyframes: „Linker Kanal“, „Rechter Kanal“ und „Beide Kanäle“.

Um die vom Keyframe-Assistenten erstellten Keyframes nutzen zu können, verknüpfen Sie die Änderungen der Audioamplitude mit anderen Ebeneneigenschaften. Verwenden Sie beispielsweise eine Expression, um die Audio-Keyframes mit der Eigenschaft „Skalierung“ einer Ebene zu verknüpfen und dafür zu sorgen, dass sich die Ebene bei größer werdender Amplitude vergrößert und bei kleiner werdender Amplitude verkleinert.

Online-Ressourcen zum Konvertieren von Audiodaten in Keyframes

Aharon Rabinowitz zeigt in einem Video-Tutorial auf der Creative COW-Website, wie die Audioamplituden-Keyframes mit anderen Eigenschaft verknüpft werden – in diesemFallden Eigenschaften des Effekts „Komplexe Wellen“ –, um Animationen mit Sound zu synchronisieren.

Nathan Gambles stellt auf der Video Copilot-Website eine Expression zur Verfügung, mit der die Lautstärke von Audio auf einer Ebene abgesenkt (reduziert) wird, wenn sie auf einer anderen Ebene erhöht wird. Diese Methode ist hilfreich, wenn etwa die Lautstärke eines Soundtracks reduziert werden soll, während etwas gesagt wird. Die Expression für den Effekt „Stereo-Mischpult“ ist abhängig vom Keyframe-Assistent für „Audio in Keyframes exportieren“, der auf die anderen Audioebenen angewendet wurde.

Lloyd Alvarez hat auf seiner After Effects Scripts-Website ein Skript veröffentlicht, das Marken hinzufügt, Ebenen aufteilt oder eine neue Textebene mit ansteigender Nummerierung je nach Audiointensität hinzufügt.

Andrew Devis stellt zwei Video-Tutorials auf der Creative COW-Website bereit, in denengezeigtwird, wie die lineare Expression-Methode mit dem Befehl „Audio in Keyframes konvertieren“ verwendet wird.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie