Übersicht über das Gesichts-Tracking

Mit dem Gesichts-Tracking können Sie menschliche Gesichter präzise erkennen und verfolgen. Mit einfachem Masken-Tracking können Sie schnell Effekte auf ein Gesicht anwenden, wie eine selektive Farbkorrektur, das Verzerren eines Gesichts und vieles mehr.

Mit dem Gesichts-Tracking können Sie jedoch auch bestimmte Stellen des Gesichts wie die Pupillen, den Mund oder die Nase verfolgen und diese Gesichtszüge dadurch isolieren und detaillierter bearbeiten. Ändern Sie z. B. die Augenfarbe oder betonen Sie Mundbewegungen, ohne dass Sie jeden einzelnen Frame anpassen müssen.

Mit After Effects können Sie auch Gesichtszüge messen. Durch das Tracking von Gesichtsmaßen erhalten Sie detaillierte Informationen – z. B. wie weit der Mund oder ein Auge geöffnet ist. Wenn jeder Datenpunkt isoliert ist, können Sie Inhalte optimieren. Zudem können Sie detaillierte Tracking-Daten zur Performance-basierten Zeichenanimation in Adobe Character Animator exportieren.

Der Gesichts-Tracker funktioniert größtenteils automatisch, Sie können jedoch bessere Ergebnisse erzielen, indem Sie die Analyse in einem Frame beginnen, der eine senkrechte Frontalansicht des Gesichts enthält. Ausreichende Beleuchtung auf das Gesicht kann die Genauigkeit des Gesichts-Trackings verbessern.

Im Tracker-Fenster finden Sie zwei Optionen für das Gesichts-Tracking:

  • Gesichts-Tracking (nur Kontur): Verwenden Sie diese Option, wenn Sie lediglich die Kontur des Gesichts verfolgen möchten.
  • Gesichts-Tracking (detaillierte Merkmale): Verwenden Sie diese Option, wenn Sie die Position von Augen (einschließlich Augenbrauen und Pupillen), Nase und Mund verfolgen und optional Maße verschiedener Merkmale extrahieren möchten. Diese Option ist erforderlich, wenn Sie die Tracking-Daten in Character Animator verwenden möchten.

    Wenn Sie die Option „Detaillierte Merkmale“ verwenden, wird ein der Effekt „Gesichts-Track-Punkte“ auf die Ebene angewendet. Der Effekt enthält diverse 2D-Effektsteuerungspunkte mit Keyframes, die jeweils mit dem erkannten Gesichtsmerkmal verbunden werden (z. B. mit den Augen- und Mundwinkeln, der Position der Pupillen oder der Nasenspitze).

Verfolgen der Kontur eines Gesichts

  1. Wählen Sie in After Effects Datei> Importieren > Datei. Navigieren Sie zum Verzeichnis, in dem das Footage gespeichert ist, und fügen Sie es dem Projekt hinzu.

    Projektfenster
  2. Ziehen Sie das Footage aus dem Projektfenster in eine Komposition, um eine Ebene hinzuzufügen.

    Hinzufügen einer Ebene zu einer Komposition
  3. Positionieren Sie die Zeitmarke auf einem Frame, in dem eine Frontalansicht des zu verfolgenden Gesichts zu sehen ist.

    Hinweis:

    Die Gesichtserkennung funktioniert am besten, wenn der Ausgangsframe eine senkrecht ausgerichtete Frontalansicht eines Gesichts enthält.

    Gesichtserkennung
  4. Zeichnen Sie eine grobe geschlossene Maske um das Gesicht, die Augen und Mund enthält. Die Maske definiert die Suchregion für die Gesichtsmerkmale. Wenn mehrere Masken ausgewählt sind, wird die oberste Maske verwendet.

    Zeichnen einer Maske
  5. Wählen Sie bei ausgewählter Maske Fenster > Tracker, um das Tracker-Fenster zu öffnen. Wählen Sie als Tracking-Methode die Option Gesichts-Tracking (nur Kontur).

    Auswählen einer Tracking-Methode
  6. Führen Sie im Tracker-Fenster die Verfolgung jeweils um einen einzelnen Frame vorwärts oder rückwärts durch, um sicherzustellen, dass das Tracking ordnungsgemäß funktioniert, und klicken Sie dann auf die Schaltfläche , um mit der Analyse aller Frames zu beginnen.

  7. Nach Abschluss der Analyse stehen die Gesichts-Tracking-Daten innerhalb der Komposition zur Verfügung.

    Gesichts-Tracking-Daten in der Komposition

Verfolgen detaillierter Merkmale und Extrahieren von Gesichtsmaßen

  1. Wählen Sie in After Effects Datei> Importieren > Datei. Navigieren Sie zum Verzeichnis, in dem das Footage gespeichert ist, und fügen Sie es dem Projekt hinzu.

  2. Ziehen Sie das Footage aus dem Projektfenster in eine Komposition, um eine Ebene hinzuzufügen.

  3. Positionieren Sie die Zeitmarke auf einem Frame, in dem eine Frontalansicht des zu verfolgenden Gesichts zu sehen ist.

    Hinweis:

    Die Gesichtserkennung funktioniert am besten, wenn der Ausgangsframe eine senkrecht ausgerichtete Frontalansicht eines Gesichts enthält.

  4. Zeichnen Sie eine grobe geschlossene Maske um das Gesicht, die Augen und Mund enthält. Die Maske definiert die Suchregion für die Gesichtsmerkmale. Wenn mehrere Masken ausgewählt sind, wird die oberste Maske verwendet.

  5. Wählen Sie bei ausgewählter Maske Fenster > Tracker, um das Tracker-Fenster zu öffnen. Wählen Sie als Tracking-Methode die Option Gesichts-Tracking (detaillierte Merkmale).

  6. Führen Sie im Tracker-Fenster die Verfolgung jeweils um einen einzelnen Frame vorwärts oder rückwärts durch, um sicherzustellen, dass das Tracking ordnungsgemäß funktioniert, und klicken Sie dann auf die Schaltfläche , um mit der Analyse aller Frames zu beginnen.

  7. Nach Abschluss der Analyse stehen die Tracking-Daten im neuen Effekt Gesicht-Track-Punkte zur Verfügung. Sie können innerhalb der Komposition oder im Effektfenster (Fenster > Effektfenster) auf Gesichts-Tracking-Daten zugreifen.

    Steuerelemente für den Effekt „Gesichts-Track-Punkte“
  8. Verschieben Sie die Zeitmarke auf einen Frame mit einem neutralen Gesichtsausdruck (die Ruhepose). Gesichtmaße auf anderen Frames verhalten sich relativ zum Ruheposenframe. Klicken Sie im Tracker-Fenster auf Ruhepose festlegen.

  9. Klicken Sie im Tracker-Fenster auf Gesichtsmaße extrahieren und kopieren. Ein Effekt „Gesichtsmaße“ wird der Ebene hinzugefügt und die Keyframes werden basierend auf Berechnungen erstellt, die anhand der Keyframe-Daten unter „Gesichts-Track-Punkte“ durchgeführt wurden. Die Keyframe-Daten für „Gesichtsmaße“ werden zur Verwendung in Character Animator in die Zwischenablage des Systems kopiert.

    Hinweis:

    Die Keyframes für Gesichtsmaße werden auf Basis der Keyframe-Daten der Gesichts-Track-Punkte erstellt und verhalten sich relativ zur Ruhepose (siehe Schritt 8).

    Steuerelemente für den Effekt „Gesichtsmaße“

Informationen zu Gesichts-Track-Daten

Gesichts-Track-Punkte

Der Effekt „Gesichts-Tracker“ erstellt Effektsteuerungspunkte für mehrere Gesichtsmerkmale, die Sie im Zeitleistenfenster anzeigen können.

Gesichtsmaße

Wenn Sie die Option „Detaillierte Merkmale“ verwendet haben, können Sie noch weitere Informationen in Form von den parametrischen Messungen von Gesichtszügen extrahieren. Diese werden als Gesichtsmaße bezeichnet. Alle anzeigten Maße für das verfolgte Gesicht verhalten sich relativ zum Ruheposenframe.

Gesichtsversatz

Gibt die Position des Gesichts bei einem Versatzwert von 0 % im Ruheposenframe an. Die folgenden Datenpunkte stehen auf x-, y- und z-Achsen für Versatzwerte zur Verfügung:

  • Versatz X
  • Versatz Y
  • Versatz Z

Gesichtsausrichtung

Gibt dreidimensionale Ausrichtungen des Gesichts an. Die Ausrichtung wird mit den folgenden Datenpunkten gemessen, die für x-, y- und z-Achsen stehen:

  • Ausrichtung X
  • Ausrichtung Y
  • Ausrichtung Z

Linkes Auge

Gibt verschiedene Messpunkte für das linke Auge an und enthält die folgenden Datenpunkte:

  • Augenbrauenabstand links
  • Öffnung linkes Augenlid
  • Blickrichtung links X
  • Blickrichtung links Y

Rechtes Auge

Gibt verschiedene Messpunkte für das rechte Auge an und enthält die folgenden Datenpunkte:

  • Abstand rechte Augenbraue
  • Augenlid-Öffnung rechts
  • Blickrichtung rechts X
  • Blickrichtung rechts Y

Mund

Gibt verschiedene Messpunkte für den Mund an und enthält die folgenden Datenpunkte:

  • Mund-Versatz X
  • Mund-Versatz Y
  • Breite Mund-Skalierung
  • Höhe Mund-Skalierung

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie