Code opmaken

U kunt uw code automatisch opmaken en laten inspringen bij het typen. Als u dynamische lettertypetoewijzing gebruikt, weet u zeker dat de juiste lettertypen worden gebruikt voor meertalige teksten.

Opties voor Automatisch opmaken instellen

  1. Ga als volgt te werk:
    • Selecteer Voorkeuren in het optiemenu  (in de rechterbovenhoek van het deelvenster Handelingen).

    • U kunt ook Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh) selecteren in het Script-venster.

  2. Selecteer Automatisch opmaken in het dialoogvenster Voorkeuren.
  3. Selecteer een van de opties voor automatisch opmaken.

    Nadat u opties voor Automatisch opmaken hebt ingesteld, worden de instellingen automatisch toegepast op de code die u schrijft, maar niet op bestaande code. Hiervoor moet u de instellingen handmatig toepassen.

Code opmaken volgens de instellingen voor Automatisch opmaken

  • Klik op de werkbalk van het deelvenster Handelingen of het Script-venster op Automatisch opmaken.
  • Selecteer Automatisch opmaken in het optiemenu (in de rechterbovenhoek van het deelvenster Handelingen).
  • Druk op Ctrl+Shift+F (Windows) of op Cmd+Shift+F (Macintosh).
  • Selecteer Gereedschappen > Automatisch opmaken in het Script-venster.

Dynamische lettertypetoewijzing gebruiken

  1. Als u dynamische lettertypetoewijzing wilt in- of uitschakelen, selecteert u in het dialoogvenster Voorkeuren Dynamische lettertypetoewijzing gebruiken of heft op de selectie op.

    Dynamische lettertypetoewijzing is standaard uitgeschakeld omdat de prestaties dan worden verbeterd wanneer u uw scripts uitvoert. Wanneer u werkt met meertalige tekst, moet u dynamische lettertypetoewijzing inschakelen, omdat deze optie ervoor zorgt dat de juiste lettertypen worden gebruikt.

Automatisch inspringen gebruiken

  1. Als u automatisch inspringen wilt in- of uitschakelen, selecteert u Automatische inspringing in het dialoogvenster Voorkeuren of heft u de selectie op.

    Wanneer Automatische inspringing is ingeschakeld, springt de tekst die u typt na haakjes openen '(' of na accolades openen '{' automatisch in volgens de instelling Tabgrootte in de voorkeuren voor ActionScript.

    U kunt in uw scripts een regel inspringen door de regel te selecteren en op Tab te drukken. Als u de inspringing wilt verwijderen, selecteert u de regel en drukt u op Shift+Tab.

Opmerkingen plaatsen bij codegebieden

Opmerkingen in de code zijn delen in de code die door de ActionScript-compiler worden genegeerd. In een opmerking kunt u uitleggen wat de code doet, of u kunt code die u niet wilt verwijderen tijdelijk uitschakelen. U start een opmerking voor een coderegel met een dubbele slash (//). De compiler negeert alle tekst na de dubbele slash. U kunt ook opmerkingen plaatsen voor grotere blokken code door een slash en een asterisk (/*) aan het begin van het blok en een asterisk en een slash (*/) aan het eind van het blok te typen.

U kunt deze markeringen handmatig typen, maar u kunt ook de knoppen bovenin het deelvenster Handelingen of het Script-venster gebruiken.

Een opmerking typen voor een coderegel

  1. Plaats het invoegpunt aan het begin van de regel of voor het teken waar de opmerking moet beginnen.
  2. Klik met de rechtermuisknop en selecteer Opmerkingen toevoegen. U kunt ook de sneltoetsen Ctrl + M (Windows) of Command + M gebruiken of naar Bewerken > Opmerkingen bij selectie toevoegen gaan.

Er wordt een dubbele slash (//) op het invoegpunt geplaatst.

Een opmerking typen voor meerdere coderegels

  1. Selecteer de regels waarvoor u een opmerking wilt opgeven. (De eerste en de laatste regel in de selectie hoeven geen hele regel te zijn.)
  2. Klik met de rechtermuisknop en selecteer Opmerkingen toevoegen. U kunt ook de sneltoetsen Ctrl + M (Windows) of Command + M gebruiken of naar Bewerken > Opmerkingen bij selectie toevoegen gaan.

De tekens voor de blokopmerking worden aan het begin (/*) en het eind (*/) van de selectie geplaatst.

Opmerking:

Als er opmerkingen zijn tussen de geselecteerde tekstregels, wordt een regelopmerking toegepast op alle geselecteerde regels.

Een opmerking verwijderen

  1. Plaats het invoegpunt in de regel met de opmerking of selecteer het codeblok waarvoor u de opmerking hebt getypt.
  2. Klik met de rechtermuisknop en selecteer Opmerkingen verwijderen. U kunt ook de sneltoetsen Ctrl + Shift + M (Windows) of Command + Shift + M gebruiken of naar Bewerken > Opmerkingen bij selectie verwijderen gaan.

Syntaxiskleuren gebruiken

Zoals in elke taal is in ActionScript syntaxis de manier waarop elementen worden geordend om betekenis te genereren. Wanneer u onjuiste ActionScript-syntaxis gebruikt, werken de scripts niet.

Als u syntaxisfouten wilt markeren, moet u een kleurcode instellen voor uw scripts. Stel dat u de syntaxiskleuren zodanig instelt dat gereserveerde woorden in blauw worden weergegeven. Als u var typt, wordt het woord var in blauw weergegeven. Als u echter per ongeluk vae typt, blijft het woord vae zwart, zodat u ziet dat u een typefout hebt gemaakt.

Ga als volgt te werk:

  • Selecteer Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh), klik op Code-editor in de categorielijst en geef de gewenste syntaxiskleuren op.

  • Terwijl het invoegpunt in het Script-veld staat, drukt u op Ctrl-U (Windows) of op Cmd-U (Macintosh).

Opmerking:

Als u scripts schrijft in het deelvenster Handelingen, worden de opdrachten die niet worden ondersteund door de versie van de speler waarvoor u het script schrijft in de werkset Handelingen geel weergegeven. Als de SWF-bestandsversie van Flash Player bijvoorbeeld is ingesteld op Flash 7, wordt ActionScript die alleen wordt ondersteund door Flash Player 8 geel weergegeven in de werkset Handelingen.

De lijsten met id's en trefwoorden gebruiken bij runtime

Bij het opstarten van Animate worden de lijsten met id's en trefwoorden gelezen vanaf het resourcebestand en in de cache opgeslagen. Behalve het lezen van de standaardlijsten vanaf de resource, wordt ook gescand op bijkomende lijsten met id's en trefwoorden in de map Voorkeuren. U kunt ook bijkomende trefwoorden en id's toevoegen door "TXT-bestanden" in de volgende mappen toe te voegen:

  • C:\Users\<Gebruikersnaam>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<Gebruikersnaam>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<Gebruikersnaam>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<Gebruikersnaam>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Regelnummers en tekstomloop gebruiken

Als u code gaat bewerken of aanpassen, maakt het gebruik van regelnummers de code overzichtelijker. Tekstomloop zorgt ervoor dat u niet horizontaal door lange regels code hoeft te schuiven (dat is met name belangrijk als u in de ontwerpomgeving of met een lage beeldschermresolutie werkt).

Regelnummers in- of uitschakelen

  • Selecteer Weergave > Regelnummers in het Script-venster.
  • Druk op Ctrl+Shift+L (Windows) of op Cmd+Shift+L (Macintosh).

Een specifieke regel markeren

  • Selecteer Bewerken > Ga naar regel in het Script-venster.

Tekstomloop in- of uitschakelen

  • Selecteer Weergave > Tekstomloop in het Script-venster.
  • Druk op Ctrl+Shift+W (Windows) of op Cmd+Shift+W (Macintosh).

Verborgen tekens weergeven

Tekens zoals spaties, tabs en regeleinden worden in de ActionScript-code verborgen. Soms moet u deze tekens weergeven, bijvoorbeeld als u double-bytespaties wilt zoeken en verwijderen die geen deel uitmaken van een tekenreekswaarde, omdat die compilerfouten veroorzaken.

  • Druk op Ctrl+Shift+8 (Windows) of op Cmd+Shift+8 (Macintosh).

De volgende symbolen worden gebruikt voor het weergeven van verborgen tekens:

Verborgen teken

Symbool

Single-bytespatie

.

Double-bytespatie

l

Tab

>>

regeleinde


Tekst in een script zoeken

Met het gereedschap Zoeken kunt u tekst in uw scripts zoeken en vervangen.

Opmerking:

Als u in de tekst van alle scripts van een Animate-document wilt zoeken, moet u de Filmverkenner gebruiken.

Tekst zoeken

  1. Selecteer in het deelvenster Handelingen of in het Script-venster het gereedschap Zoeken of druk op Ctrl+F (Windows) of op Cmd+F (Macintosh).
  2. Geef de tekst op waarnaar u wilt zoeken.
  3. Klik op Volgende Zoeken.

Tekst in een script zoeken en vervangen

  1. Selecteer in het deelvenster Handelingen of in het Script-venster het gereedschap Zoeken of druk op Ctrl+F (Windows) of op Cmd+F (Macintosh).
  2. Geef de tekst op waarnaar u wilt zoeken.
  3. Geef in het tekstvak Vervangen de nieuwe tekst op.
  4. Klik op Volgende Zoeken.
  5. Klik op Vervangen om de tekst te vervangen, of klik op Alles vervangen om alle instanties van de opgegeven tekst te vervangen.

(Verouderd in Animate) Een zoekopdracht herhalen in het deelvenster Handelingen

  1. Selecteer Opnieuw zoeken in het optiemenu  (in de rechterbovenhoek van het deelvenster Handelingen).

(Verouderd in Animate) Een zoekopdracht herhalen in het deelvenster Script

  1. Selecteer Bewerken> Opnieuw zoeken.

(Verouderd in Animate) Syntaxis en leestekens controleren

U kunt de ActionScript-code snel controleren zonder dat u het FLA-bestand publiceert.

Wanneer u de syntaxis controleert, wordt het huidige script gecontroleerd. Als het huidige script ActionScript-klassen aanroept, worden deze klassen eveneens gecontroleerd. Eventuele andere scripts in het FLA-bestand worden niet gecontroleerd.

Bij de syntaxiscontrole van ActionScript 2.0-bestanden wordt de code uitgevoerd via de compiler om syntaxis- en compilerfouten te genereren.

Bij de syntaxiscontrole van ActionScript 3.0-bestanden worden alleen syntaxisfouten gegenereerd. Als u compilatiefouten wilt genereren zoals niet-overeenkomend typen, onjuiste retourwaarden en verkeerd gespelde variabele- of methodenamen, moet u de opdracht Besturing > Testen gebruiken.

Syntaxis controleren

Voer een van de volgende handelingen uit om de syntaxis te controleren:

  • Klik in het deelvenster Handelingen of het Script-venster op Syntaxis controleren .
  • Klik in het Script-veld en druk vervolgens op Ctrl + T (Windows) of Cmd + T (Macintosh). Het Script-veld krijgt de focus als u hierin klikt of typt. Als een object in het werkgebied de focus heeft, wordt het deelvenster Transformeren geopend.

Syntaxisfouten worden in het deelvenster Compilerfouten weergegeven.

Opmerking:

In een extern ActionScript-klassenbestand in het Script-venster beïnvloedt het algemene klassepad (AS2) of het bronpad (AS3) de syntaxiscontrole. Zelfs als het algemene klassepad juist is ingesteld, kunnen er fouten worden gegenereerd omdat de compiler niet weet dat deze klasse wordt gecompileerd.

Evenwicht van leestekens controleren

  1. Klik tussen accolades {}, vierkante haakjes [] of ronde haakjes () in het script.
  2. Druk in Windows op Control+' (enkel aanhalingsteken) of op een Macintosh op Cmd+' (enkel aanhalingsteken). De tekst tussen de accolades, vierkante haakjes of ronde haakjes wordt gemarkeerd en u kunt controleren of de leestekens openen bijbehorende leestekens sluiten hebben.

(Verouderd in Animate) Scripts importeren en exporteren

U kunt een script in het deelvenster Handelingen of het Script-venster importeren. U kunt uw scripts ook uit het deelvenster Handelingen naar externe ActionScript-bestanden exporteren. (Wanneer u het Script-venster gebruikt, is exporteren niet nodig omdat u het AS-bestand kunt opslaan.)

Als de tekst in uw scripts er anders uitziet dan u had verwacht wanneer u een bestand opent of importeert, wijzigt u de voorkeur voor importcodering.

Een extern AS-bestand importeren

  1. Plaats in het Script-veld het invoegpunt op de plek waar de eerste regel van het externe script moet komen.
  2. Ga als volgt te werk:
    • Selecteer Script importeren in het optiemenu van het deelvenster Handelingen of druk op Ctrl+Shift+I (Windows) of op Cmd+Shift+I (Macintosh).

    • Selecteer Bestand > Script importeren in het Script-venster of druk op Ctrl+Shift+I (Windows) of op Cmd+Shift+I (Macintosh).

Een script exporteren vanuit het deelvenster Handelingen

  1. Selecteer het script dat u wilt exporteren. Selecteer vervolgens Script exporteren in het optiemenu van het deelvenster Handelingen of druk op Ctrl+Shift+X (Windows) of op Cmd+Shift+X (Macintosh).
  2. Sla het ActionScript-bestand (AS) op.

Tekstcoderingsopties instellen

  1. Selecteer Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh) en selecteer vervolgens ActionScript in de categorielijst.

  2. U kunt de volgende opties instellen:

    Openen/importeren

    Selecteer UTF-8-codering voor openen of importeren met Unicode-codering. U kunt ook Standaardcodering selecteren voor openen of importeren met de coderingsindeling van de taal die momenteel wordt gebruikt door het systeem.

    Opslaan/exporteren

    Selecteer UTF-8-codering voor opslaan of exporteren met Unicode-codering. U kunt ook Standaardcodering selecteren voor opslaan of exporteren met de coderingsindeling van de taal die momenteel wordt gebruikt door het systeem.

De waarschuwing voor exportcodering in- of uitschakelen

  1. Selecteer Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh) en selecteer vervolgens Waarschuwingen in de categorielijst.

  2. Selecteer Waarschuwing bij coderingsconflicten bij exporteren ActionScript-bestanden, of hef de selectie op.

(Verouderd in Animate) Codering voor geïmporteerde en geëxporteerde scripts

U kunt in ActionScript het type codering opgeven dat u wilt gebruiken voor geïmporteerde of geëxporteerde ActionScript-bestanden. UTF-8-codering is een 8-bits Unicode-indeling waarmee u tekst in meerdere talen in uw bestanden kunt opnemen. Standaardcodering is de codering die wordt ondersteund door de taal die uw systeem momenteel gebruikt. Deze codering wordt ook wel de traditionele codepagina genoemd.

Opmerking:

Wanneer u een niet-Engelse toepassing gebruikt op een Engels systeem, mislukt de opdracht Film testen wanneer een deel van het SWF-bestandspad tekens bevat die niet kunnen worden weergegeven met het coderingsschema Multibyte Character Sets (MBCS). Japanse paden die op een Japans systeem werken, werken bijvoorbeeld niet op een Engels systeem. Gebruik daarom uitsluitend Engelse padnamen op Engelse systemen. Deze beperking is van toepassing op alle gebieden van de toepassing die de testfilmspeler gebruiken.

Scripts vastzetten in het deelvenster Handelingen

Gebruik de functie Script vastzetten om tabbladen met afzonderlijke scripts vast te zetten in het deelvenster Script en ze dienovereenkomstig te verplaatsen. Deze functie is handig als u de code in een FLA-bestand niet op één centrale locatie hebt geordend, of als u meerdere scripts gebruikt.

U kunt een script vastzetten om de geopende locatie van de code in het deelvenster Handelingen te behouden en om te schakelen tussen de verschillende geopende scripts. Dat is vooral handig bij het opsporen van fouten. 

U kunt ook een of meerdere scripts losmaken als u een geselecteerd script (of alle scripts) wilt losmaken van het deelvenster Handelingen.

In de volgende afbeelding bevindt het script dat aan de huidige locatie op de tijdlijn is gekoppeld zich op frame1 van de laag met de naam Verwijderen. (De tab uiterst links volgt altijd de locatie op de tijdlijn.) Het script wordt ook vastgezet zoals getoond in het meest rechtse tabblad. De volgende twee scripts zijn vastgezet:

  • In frame 1 
  • In frame 15 van de laag met de naam Intro

Gebruik sneltoetsen of klik op de tabbladen om tussen de vastgezette scripts te schakelen. Wanneer u van het ene vastgezette script naar het andere gaat, wordt uw huidige positie op de tijdlijn niet gewijzigd. Als u een nieuw script selecteert in de scriptnavigator, verplaatst de focus zich naar het eerste frame, dat wil zeggen: Frame 1.

Opmerking:

Als de inhoud in het Script-veld niet wordt aangepast aan de locatie die u op de tijdlijn selecteert, wordt in het Script-veld waarschijnlijk een vastgezet script weergegeven. Klik op de huidige tab linksboven in het Script-veld om het script weer te geven dat is gekoppeld aan uw locatie op de tijdlijn.

as_pin_scripts
Een vastgezet script

Een script vastzetten

  1. Klik op de Tijdlijn zodat het script op de huidige tab linksboven in het Script-veld in het deelvenster Handelingen wordt weergegeven.

  2. Ga als volgt te werk:
    • Klik op het pictogram met een punaise rechts van het tabblad.
    • Selecteer Weergave>Script vastzetten om het script vast te spelden.

     

Alle scripts vrijmaken

  1. Selecteer het vastgezette script in het deelvenster Handelingen.

  2. Selecteer Beeld > Script vrijmaken om het geselecteerde script in het deelvenster Handelingen los te maken.

  3. SelecteerBeeld > Alle scripts vrijmaken om alle scripts in het deelvenster Handelingen los te maken.

pinscript4
Opties voor vrijmaken

sneltoetsen voor vastgezette scripts

Als het invoegpunt in het Script-veld staat, kunt u de volgende sneltoetsen gebruiken om met vastgezette scripts te werken.

Handeling

Windows 

Macintosh

Script vastzetten

Control + Shift + = (gelijkteken)

Cmd+Shift+=

Script vrijmaken

Control+Shift+- (minteken)

Cmd+Shift+-

Doelpaden invoegen

Veel scripthandelingen zijn gericht op het beïnvloeden van filmclips, knoppen en andere symboolinstanties. In uw code kunt u naar symboolinstanties op een tijdlijn verwijzen door een doelpad in te voegen. Een doelpad is het adres van de instantie die u als doel wilt gebruiken. U kunt een absoluut of een relatief doelpad instellen. Een absoluut pad bevat het volledige adres van de instantie. Een relatief pad bevat slechts het deel van het adres dat afwijkt van het adres van het script in het FLA-bestand. Een relatief pad werkt dan ook niet als u het script naar een andere locatie verplaatst.

  1. Klik in het deelvenster Handelingen op een handeling in het script.
  2. Klik op Doelpad .
  3. Geef het pad op van de instantie die u als doel wilt gebruiken of selecteer een doel in de lijst.
  4. Selecteer de optie Absoluut of Relatief pad.

Codehints gebruiken

Wanneer u in het deelvenster Handelingen of in het Script-venster werkt, kan de software detecteren welke handeling u invoert en op basis daarvan een codehint weergeven. Er bestaan twee soorten codehints: knopinfo met de complete syntaxis voor de handeling en een pop-upmenu waarin mogelijke ActionScript-elementen worden weergegeven, zoals namen van methoden of eigenschappen (soms wordt dit een vorm van codevoltooiing genoemd).

Codehints zijn standaard ingeschakeld. Door voorkeuren in te stellen, kunt u codehints uitschakelen of bepalen hoe snel ze moeten worden weergegeven. Wanneer u codehints bij de voorkeuren hebt uitgeschakeld, kunt u toch handmatig een codehint weergeven voor een specifieke opdracht.

Opmerking:

Als u geen codehints kunt weergeven voor een variabele of een object dat u in ActionScript 2.0 hebt gemaakt, terwijl codehints wel zijn ingeschakeld in de voorkeuren van ActionScript, moet u controleren of u de variabele of het object het juiste achtervoegsel hebt gegeven, of dat u strikte invoer voor de variabele of het object hebt gebruikt.

Codehints inschakelen

U kunt codehints op verschillende manieren activeren.

Strikte invoer voor objecten

Als u ActionScript 2.0 in combinatie met strikte invoer gebruikt voor een variabele die is gebaseerd op een ingebouwde klasse (zoals Button, Array, enzovoort), worden in het Script-veld codehints voor de variabele weergegeven. Stel dat u de volgende twee coderegels invoert:

var foo:Array = new Array(); 
foo.

Zodra u de punt (.) typt, toont Animate een lijst met methoden en eigenschappen die beschikbaar zijn voor Array-objecten in een pop-upmenu, omdat u de variabele als een array hebt getypt.

Achtervoegsels en codehints

Als u ActionScript 1.0 gebruikt of als u codehints wilt weergeven voor objecten zonder deze strikt in te voeren, moet u een achtervoegsel aan de naam van elk object toevoegen op het moment dat u het object maakt. Het achtervoegsel dat codehints activeert voor de klasse Camera is bijvoorbeeld _cam. Stel dat u de volgende code typt: var my_array = new Array(); var my_cam = Camera.get();

Als u vervolgens my_cam typt gevolgd door een punt, worden codehints voor het object Camera weergegeven.

Gebruik voor de objecten die in het werkgebied worden weergegeven het achtervoegsel in het vak Instantienaam in Eigenschapcontrole. Als u bijvoorbeeld codehints wilt weergeven voor objecten MovieClip, gebruikt u Eigenschapcontrole om aan alle objecten MovieClip instantienamen toe te wijzen met het achtervoegsel _mc. Wanneer u vervolgens de instantienaam typt, gevolgd door een punt, worden codehints weergegeven.

var my_array = new Array(); 
var my_cam = Camera.get();

Opmerking:

Achtervoegsels zijn niet vereist voor het activeren van codehints wanneer u strikte invoer voor objecten gebruikt, maar consistent gebruik van achtervoegsels maakt de code wel begrijpelijker.

In de volgende tabel worden de achtervoegsels weergegeven die codehints activeren in ActionScript 2.0:

Type object

Achtervoegsel variabele

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Opmerkingen en codehints

U kunt ook ActionScript-opmerkingen gebruiken om de klasse van een object op te geven voor codehints. In het volgende voorbeeld wordt via een opmerking aangegeven dat de klasse van de instantie theObject Object is, enzovoort.

// Object theObject;// Array theArray;// MovieClip theMC;

Als u vervolgens theMC invoert gevolgd door een punt, worden codehints weergegeven met de lijst met MovieClip-methoden en -eigenschappen. Als u vervolgens theArray invoert gevolgd door een punt, worden codehints weergegeven met de lijst met Array-methoden en -eigenschappen, enzovoort.

Adobe raadt echter aan in plaats van deze techniek strikte gegevensinvoer of achtervoegsels te gebruiken, omdat deze technieken codehints automatisch activeren waardoor uw code begrijpelijker wordt.

Voorkeurinstellingen opgeven voor automatische codehints

  • Selecteer Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh) in het deelvenster Handelingen of in het Script-venster, klik in de categorielijst op Code-editor en schakel vervolgens Codehints in of uit.

(Verouderd in Animate) Een vertraging voor codehints opgeven

  1. Selecteer in het deelvenster Handelingen of het Script-venster Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh).

  2. Klik op ActionScript in de categorielijst.
  3. Gebruik de schuifregelaar om de vertraging in seconden op te geven.

Codehints in knopinfostijl gebruiken

  1. Geef de codehint weer door een haakje openen '(' te typen na een element waarvoor haakjes nodig zijn (bijvoorbeeld na een methodenaam of een opdracht, zoals if of do..while, enzovoort).
    as_code_hint_paren1
    Een haakje openen activeert de codehints

  2. Voer een waarde in voor de parameter.

    Als u meerdere parameters hebt, moet u de waarden scheiden met komma's. Voor functies of instructies, zoals de lus for, scheidt u de parameters met een puntkomma.

    Overbelaste opdrachten (functies of methoden die kunnen worden aangeroepen met verschillende parametersets), zoals gotoAndPlay() of for, geven een indicator weer waarmee u de gewenste parameter kunt selecteren. Als u een parameter wilt selecteren, klikt u op het pijltje of drukt u op Control+Pijl-links en Control+Pijl-rechts.

    as_code_hint_paren3
    Een codehint met meerdere parametersets

  3. U kunt de codehint op de volgende manieren sluiten:
    • Typ een haakje sluiten ')'.

    • Klik buiten de instructie.

    • Druk op Escape.

Codehints in menustijl gebruiken

  1. Geef de codehint weer door een punt te typen na de naam van een variabele of een object.
    as_code_hint_dot1
    Codehints in menustijl

  2. Als u door de codehints wilt navigeren, gebruikt u de toetsen Pijl-omhoog en Pijl-omlaag.
  3. Als u een item in het menu wilt selecteren, drukt u op Enter of op Tab of dubbelklikt u op het item.
  4. U kunt de codehint op de volgende manieren sluiten:
    • Selecteer een van de menu-items.

    • Klik boven of onder het menuvenster.

    • Typ een haakje sluiten ')' als u al een haakje openen '(' hebt getypt.

    • Druk op Escape.

Een codehint handmatig weergeven

  1. Klik op een locatie in de code waar codehints worden weergegeven, zoals op de volgende locaties:
    • Na de punt (.) die volgt op een instructie of een opdracht waar een eigenschap of een methode moet worden ingevoerd

    • Tussen haakjes [()] in een methodenaam

  2. Ga als volgt te werk:
    • Selecteer Weergeven > Codehint weergeven om codehints handmatig in te schakelen.

    • Druk op Control+spatiebalk (Windows) of Cmd+spatiebalk (Macintosh).

Codehints voor aangepaste klassen

Als u aangepaste ActionScript 3.0-klassen maakt, parseert Animate de klassen en wordt er eveneens bepaald welke objecten, eigenschappen en methoden in de klassen worden opgenomen. Animate kan vervolgens codehints bieden wanneer u code schrijft die naar de aangepaste klassen verwijst. Voltooiing van aangepaste klassencode wordt automatisch uitgevoerd voor alle klassen die u aan andere code hebt gekoppeld met de opdracht import.

Met codehints kunnen ontwikkelaars sneller werken omdat ze niet hoeven te onthouden welke objecten, methoden en eigenschappen er allemaal door de klasse worden gebruikt. Ook kunnen ontwerpers hierdoor werken met klassen die ze niet zelf hebben geschreven, omdat ze niet precies hoeven te weten hoe de klasse in elkaar zit.

Codehints kunnen onder meer voor de volgende items worden gegeven:

  • Codehints voor geneste klasseverwijzingen

    Bij het schrijven van geneste verwijzingen is het handig als u voortdurend codehints krijgt.

  • Codehints voor "this"

    Als u "this" in een klassenbestand typt, krijgt u codehints voor de desbetreffende klasse.

  • Codehints voor "new+<spatie>"

    Als u "new+<spatie>" typt, geeft Animate een lijst met beschikbare klassen en pakketten weer.

  • Codehints voor "import"

    Als u "import+<spatie>" typt, geeft Animate een lijst met alle ingebouwde en aangepaste pakketten weer.

  • Codehints voor SWC-bibliotheken

    Als u een SWC-bibliotheek toevoegt aan het bibliotheekpad of het externe bibliotheekpad, schakelt Animate codehints in voor alle klassen die in het SWC-bestand zijn opgenomen.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid