Aan de slag met ActionScript

Met de scripttaal ActionScript® kunt u complexe interactiviteit, besturingselementen en weergave van gegevens in uw toepassing opnemen. Met behulp van het deelvenster Handelingen, het Script-venster of een externe editor kunt u in de Flash-ontwerpomgeving ActionScript toevoegen.

ActionScript kent zijn eigen syntaxisregels en gereserveerde woorden. Met ActionScript kunt u variabelen gebruiken voor het opslaan en ophalen van gegevens. ActionScript bevat een grote bibliotheek met ingebouwde klassen waarmee u objecten kunt maken voor het uitvoeren van veel verschillende taken. Zie de volgende secties in Help voor meer informatie over ActionScript.

U hoeft niet elk element van ActionScript te begrijpen om te kunnen beginnen met het schrijven van scripts. Als u een duidelijk doel hebt, kunt u met eenvoudige handelingen beginnen met het maken van scripts.

ActionScript en JavaScript vinden beide hun oorsprong in de ECMA-262-standaard, de internationale standaard voor de scripttaal ECMAScript. Voor ontwikkelaars die bekend zijn met JavaScript, kan ActionScript daarom meteen bekend voorkomen. Ga voor meer informatie over ECMAScript naar ecma-international.org.

Welke versie van ActionScript kunt u gebruiken?

Animate bevat meer dan één versie van ActionScript om tegemoet te komen aan de behoeften van verschillende ontwikkelaars en afspeelomgevingen. ActionScript 3.0 en 2.0 zijn niet compatibel met elkaar.

 

  • ActionScript 3.0 wordt snel uitgevoerd. Voor deze versie is meer kennis nodig van de concepten van objectgeoriënteerd programmeren dan voor eerdere versies van ActionScript. ActionScript 3.0 is volledig compatibel met de ECMAScript-specificatie, biedt betere XML-verwerking, een verbeterd gebeurtenismodel en een verbeterde architectuur voor werken met elementen op het scherm. FLA-bestanden die ActionScript 3.0 gebruiken kunnen geen eerdere versies van ActionScript bevatten.

  • (Alleen verouderd in Animate ) ActionScript 2.0 is eenvoudiger te leren dan ActionScript 3.0. Hoewel Flash Player gecompileerde ActionScript 2.0-code trager uitvoert dan gecompileerde ActionScript 3.0-code, kunt u ActionScript 2.0 nog steeds gebruiken voor allerlei projecten. ActionScript 2.0 is ook handig voor projecten die niet computerintensief zijn. Dit kunnen bijvoorbeeld projecten met meer ontwerpgeoriënteerde inhoud zijn. ActionScript 2.0 is ook gebaseerd op de ECMAScript-specificatie, maar is niet volledig compatibel.

  • (Verouderd in Animate) ActionScript 1.0 is de eenvoudigste versie van ActionScript en wordt nog steeds gebruikt door sommige versies van de Adobe Flash Lite Player. ActionScript 1.0 en 2.0 kunnen samen in één FLA-bestand worden gebruikt.

  • (Verouderd in Animate) ActionScript voor Flash Lite 2.x is een subset van ActionScript 2.0 die door Flash Lite 2.x wordt ondersteund op mobiele telefoons en andere mobiele apparaten.

  • (Verouderd in Animate) ActionScript voor Flash Lite 1.x is een subset van ActionScript 1.0 die door Flash Lite 1.x wordt ondersteund op mobiele telefoons en andere mobiele apparaten.

 

De documentatie van ActionScript gebruiken

Omdat er meerdere versies bestaan van ActionScript (2.0 en 3.0) en omdat er meerdere manieren bestaan om ActionScript in uw FLA-bestanden op te nemen, kunt u op een aantal manieren leren werken met ActionScript.

Er is een beschrijving beschikbaar van de gebruikersinterface voor het werken met ActionScript. Deze interface bevat het deelvenster Handelingen, het Script-venster, de modus Scriptassistentie, het deelvenster Gedragingen, het deelvenster Uitvoer en het deelvenster Compilerfouten. Deze onderwerpen hebben betrekking op alle versies van ActionScript.

In andere ActionScript-documentatie van Adobe vindt u meer informatie over de afzonderlijke versies van ActionScript.

Manieren om met ActionScript te werken

U kunt op verschillende manieren met ActionScript werken.

  • (Verouderd in Animate) Met de modus Scriptassistentie kunt u ActionScript aan een FLA-bestand toevoegen zonder dat u zelf de code hoeft te schrijven. U selecteert de handelingen en vervolgens wordt er een speciale gebruikersinterface geopend waarin u de vereiste parameters voor iedere handeling kunt opgeven. U moet wel iets weten van de functies die u voor het verwezenlijken van specifieke taken moet gebruiken, maar u hoeft de syntaxis niet te leren. Deze modus wordt veel door ontwerpers en niet-programmeurs gebruikt.

  • (Verouderd in Animate) U kunt ook gedragingen gebruiken om code aan een bestand toe te voegen zonder dat u de code zelf hoeft te schrijven. Gedragingen zijn vooraf geschreven scripts voor veelvoorkomende taken. Nadat u een gedrag hebt toegevoegd, kunt u het gedrag eenvoudig in het deelvenster Gedragingen configureren. Gedragingen zijn alleen beschikbaar voor ActionScript 2.0 en lager.

  • Als u uw eigen ActionScript schrijft, hebt u de meeste flexibiliteit en controle over uw document, maar dan moet u zich wel de ActionScript-taal en -conventies eigen maken.

  • Componenten zijn vooraf gebouwde filmclips waarmee u complexe functionaliteit kunt implementeren. Een component kan een eenvoudig gebruikersinterface-element zijn, zoals een selectievakje, of een gecompliceerd element, zoals een schuifvenster. U kunt de functionaliteit en de weergave van een component aanpassen en u kunt componenten downloaden die door andere ontwikkelaars zijn gemaakt. Voor de meeste componenten moet u wel zelf aanvullende ActionScript-code schrijven om een component te activeren of in te stellen. Zie ActionScript 3.0-componenten gebruiken voor meer informatie.

 

ActionScript schrijven

Als u ActionScript-code schrijft in de ontwerpomgeving, gebruikt u het deelvenster Handelingen of het Script-venster. Het deelvenster Handelingen en het venster Script bevatten een volledig functionele code-editor met onder andere functies voor codehints en -kleuren, codeopmaak en syntaxismarkering. Daarnaast biedt de editor mogelijkheden voor foutopsporing, regelnummers, tekstomloop en ondersteuning voor Unicode.

  • Gebruik het deelvenster Handelingen om scripts te schrijven die deel uitmaken van een Animate-document (scripts die in het FLA-bestand zijn ingesloten). Het deelvenster Handelingen biedt onder andere de werkset Handelingen, waarmee u snel toegang krijgt tot de kernelementen van de ActionScript-taal. Er worden vragen weergegeven voor de elementen waarvoor scripts moeten worden gemaakt.

  • Gebruik het Script-venster als u externe scripts wilt schrijven. Dat zijn scripts of klassen die in externe bestanden worden opgeslagen. (U kunt ook een tekstverwerker gebruiken om een extern AS-bestand te maken). Het Script-venster bevat assistentiefuncties voor de code zoals codehints en codekleuren, syntaxiscontrole en automatische opmaak.

Meer aanbevolen community-inhoud

De volgende artikelen en zelfstudies bieden meer gedetailleerde informatie over het werken met ActionScript:

Overzicht van het deelvenster Uitvoer

Wanneer u een documenttype uitvoert, worden in het deelvenster Uitvoer informatie of waarschuwingen weergegeven over bewerkingen, zoals documentconversies en publiceren. Als u deze informatie wilt weergeven, voegt u instructies trace() aan uw code toe of gebruikt u de opdrachten Objecten weergeven en Variabelen weergeven.

Wanneer u de instructie trace() gebruikt in uw scripts, kunt u bij uitvoering van het SWF-bestand bepaalde informatie verzenden naar het deelvenster Uitvoer. Denk hierbij aan opmerkingen over de status van het SWF-bestand of de waarde van een expressie. 

Output_panel
Deelvenster Uitvoer

Het deelvenster Uitvoer bevat de volgende menu-items:

  • Kopiëren: hiermee kopieert u de volledige inhoud van het deelvenster Uitvoer naar het klembord van de computer. Als u slechts een specifiek deel uit het deelvenster Uitvoer wilt kopiëren, selecteert u het gedeelte dat u wilt kopiëren en selecteert u vervolgens Kopiëren.
  • Wissen: hiermee wordt de inhoud van het deelvenster Uitvoer gewist.
  • Uitvoer weergeven: hiermee toont u de inhoud van het deelvenster Uitvoer.
  • Vergrendelen: hiermee vergrendelt u het deelvenster. U kunt het deelvenster alleen groter of kleiner maken; u kunt het deelvenster niet verplaatsen of slepen. 
  • Help: hiermee laadt u de online Help voor het deelvenster Uitvoer.
  • Sluiten: sluit het deelvenster Uitvoer.
  • Groep sluiten: sluit de gehele deelvenstergroep. U kunt meerdere deelvensters tegelijk koppelen, bijvoorbeeld de deelvensters Tijdlijn, Uitvoer en Compilerfouten.

Als u het deelvenster Uitvoer wilt weergeven of verbergen, selecteert u Venster > Uitvoer of drukt u op F2.

Deelvenster Handelingen

Op zoek naar de Naslaggids?

Ga op een van de volgende manieren te werk om naslagmateriaal te zoeken over een specifiek ActionScript-taalelement:

Opmerking:

Als u de Help in een webbrowser wilt openen, in plaats van in de Community Help-toepassing, leest u het artikel: http://kb2.adobe.com/community/publishing/916/cpsid_91609.html.

ActionScript leren gebruiken

Gebruik de volgende bronnen om te leren hoe u ActionScript schrijft:

Opmerking:

ActionScript 3.0 en 2.0 zijn niet compatibel met elkaar. Kies slechts één versie voor elk FLA-bestand dat u maakt.

Overzicht van het deelvenster Handelingen

Als u scripts wilt maken die zijn ingesloten in een FLA-bestand, typt u ActionScript rechtstreeks in het deelvenster Handelingen (Venster > Handelingen of druk op F9).

actions-frame-view
Deelvenster Handelingen

Het deelvenster Handelingen bevat twee vensters:

Script-veld

Hiermee kunt u ActionScript-code invoeren die is gekoppeld aan het momenteel geselecteerde frame.

Scriptnavigator

Hier wordt een lijst met de scripts in uw Animate-document vermeld en kunt u snel tussen de scripts navigeren. Als u het script in het deelvenster Script wilt weergeven, klikt u op een item in de scriptnavigator.

Het deelvenster Handelingen biedt u toegang tot de functies voor code-assistentie waarmee u eenvoudig en efficiënt codeert in ActionScript. Hiermee kunt u niet-framespecifieke, algemene scripts en scripts van derde partijen toevoegen die op de hele animatie kunnen worden toegepast in Animate. Voor meer informatie raadpleegt u het gedeelte Globale scripts en scripts van derde partijen toevoegen op deze pagina. 

  • Script uitvoeren: hiermee wordt het script uitgevoerd
  • Script vastzetten: het script wordt vastgezet op de tabbladen van afzonderlijke scripts in het Script-venster en dienovereenkomstig verplaatst. Deze functie is handig als u de code in uw FLA-bestand niet op één centrale locatie hebt georganiseerd. Het is ook handig als u meerdere scripts gebruikt. U kunt een script vastzetten om de geopende locatie van de code in het deelvenster Handelingen te behouden en om te schakelen tussen de verschillende geopende scripts. Deze functie kan handig zijn bij het opsporen van fouten.
  • Pad en naam van instantie invoegen: hiermee kunt u een absoluut of relatief pad instellen voor een handeling in het script.
  • Zoeken: hiermee zoekt en vervangt u tekst in uw script.
  • Code opmaken: hiermee kunt u de code opmaken.
  • Codefragmenten: hiermee opent u het deelvenster Codefragmenten met voorbeeldcode.
  • Toev. m. wizard: klik op deze knop om handelingen via een gebruiksvriendelijke wizard toe te voegen zonder code te hoeven schrijven. 
  • Help: geeft informatie weer over het ActionScript-element dat in het Script-veld is geselecteerd. Als u bijvoorbeeld klikt op een importeren-instructie en vervolgens op Help, wordt informatie over importeren in het deelvenster Help weergegeven.

De codewizard voor handelingen gebruiken

U kunt interactiviteit toevoegen aan HTML5-composities met de opties onder Toev. m. wizard in het deelvenster Handelingen. Toevoegen met wizard is een vereenvoudigde gebruikersinterface waarin u code aan uw composities kunt toevoegen.

  1. Maak een HTML5 Canvas-document en klik op Venster > Handelingen.

  2. Klik op Toevoegen met wizard in het deelvenster Handelingen, zoals in de onderstaande schermafbeelding wordt getoond.

    addusingwizard-button
    Deelvenster Handelingen met de knop Toevoegen met wizard
  3. Selecteer een handeling waarvoor u code wilt maken met de codewizard.

    Een voorbeeld van een schermafbeelding met wizardopties voor handelingen

    In de schermafbeelding hierboven is de handeling Framenummer ophalen geselecteerd en is de bijbehorende code bijgewerkt in het venster Handelingen.

    Op basis van het type handeling dat u selecteert, kunt u ook het betreffende object selecteren waarop u de handeling wilt toepassen. Als het object een instantienaam heeft, kunt u zoeken naar het specifieke object op het werkgebied. U kunt de bewerking ook toepassen op de huidige selectie. 

    actions-code-currentselection
    Lijst met objecten waarop de handeling moet worden toegepast
  4. Klik op Volgende om een activeringsgebeurtenis te kiezen. In het venster wordt een verzameling activeringsgebeurtenissen weergegeven, op basis van het type handeling en object dat u in voorgaande stappen hebt geselecteerd. 

    action-trigger
    Lijst met activeringsgebeurtenissen
  5. Kies een geschikte activeringsgebeurtenis gevolgd door de bijbehorende activeringsobjecten, indien van toepassing, en klik vervolgens op de knop Volt. en toev.

U kunt de optie Huidige selectie kiezen in het menu wanneer u een object in het werkgebied selecteert en de codewizard voor handelingen uitvoert. U kunt ook de tijdlijn en de handelingen van de componenten voor de code kiezen.

De interactiviteit van een animatie verbeteren

Interactiviteit is een essentieel onderdeel van een animatie die de visuele ervaring voor het publiek versterkt. Wilt u leren hoe u handelingen aan de video kunt toevoegen zonder codes? Bekijk de tutorial aan het einde van dit voorbeeld en voer de volgende stappen uit.

  1. Selecteer in de Tijdlijn de actieclip.

  2. Klik op Windows > Handelingen.

  3. Klik op Toevoegen met wizard in het deelvenster Handelingen.

  4. Selecteer in Huidig frame de volgende opties:

    • Selecteer een handeling: selecteer Afspelen.
    • Object waarop de handeling moet worden toegepast: selecteer het gewenste object.
  5. Klik op Volgende.

Interactiviteit aan uw animaties toevoegen

Interactiviteit aan uw animaties toevoegen
Bekijk de video om meer acties te ontdekken zoals objecten afspelen, verticaal verplaatsen en positioneren.

Script-venster gebruiken

In het Script-venster kunt u externe scriptbestanden maken die u in uw toepassing kunt importeren. Deze scripts kunnen ActionScript- of Animate JavaScript-bestanden zijn.

U kunt ook globale scripts en scripts van derde partijen toevoegen aan HTML5 Canvas-documenten ook toevoegen. Voor meer informatie raadpleegt u het gedeelte Globale scripts en scripts van derde partijen toevoegen in HTML5 Canvas-documenten maken en publiceren in Animate .

actions-add-script
Script-venster

Als u meer dan een extern bestand hebt geopend, worden de bestandsnamen in de tabs bovenin het Script-venster weergegeven.

In het Script-venster kunt u functies voor PinScript, zoeken en vervangen, syntaxiskleuren, opmaakcode, codehints en het samenvouwen van code gebruiken. U kunt ook opties voor foutopsporing (alleen ActionScript-bestanden) en tekstomloop gebruiken. In het Script-venster kunt u ook regelnummers en verborgen tekens weergeven.

Een extern bestand maken in het Script-venster

  1. Selecteer Bestand > Nieuw.

    Nieuw document
    Nieuw document
  2. Selecteer de juiste bestemming op de tabbladen boven aan het scherm, zoals Karakteranimatie, Social, Game, Educatie, Advertenties, Web en Geavanceerd. Selecteer het type extern bestand dat u wilt maken (ActionScript-bestand of Animate JavaScript-bestand).

Een bestaand bestand bewerken in het Script-venster

  • Als u een bestaand script wilt openen, selecteert u Bestand > Openen en opent u een bestaand AS-bestand.

  • Als u een script wilt bewerken dat al is geopend, klikt u op de tab met de naam van het script.

Gereedschappen in het deelvenster Handelingen en het Script-venster

Het deelvenster Handelingen biedt u toegang tot de functies voor code-assistentie waarmee u eenvoudig en efficiënt codeert in ActionScript.

Zoeken 

Hiermee zoekt en vervangt u tekst in het script.

 

Doelpad invoegen 

(Alleen deelvenster Handelingen) Hiermee kunt u een absoluut of relatief pad opgeven voor een handeling in het script.

 

Help 

Hiermee geeft u informatie weer over het ActionScript-element dat in het deelvenster Script is geselecteerd. Als u bijvoorbeeld op een instructie importeren klikt en vervolgens op Help, wordt informatie over importeren in het deelvenster Help weergegeven.

 

Codefragmenten

Hiermee opent u het deelvenster Codefragmenten waarin voorbeeldcodefragmenten worden weergegeven.

 

Toev. m. wizard

Hiermee kunt u code voor handelingen via een interface toevoegen en hoeft u geen code te schrijven. 

Contextgevoelige Help openen vanuit het deelvenster Handelingen

  1. U kunt als volgt een item voor referentie selecteren:
    • Selecteer een ActionScript-term in de werkset Handelingen (links in het deelvenster Handelingen).

    • Selecteer een ActionScript-term in het deelvenster Handelingen in het Script-veld.

    • Plaats het invoegpunt voor een ActionScript-term in het deelvenster Handelingen in het Script-veld.

  2. U kunt de referentiepagina van het deelvenster Help voor het geselecteerde item als volgt openen:
    • Druk op F1.

    • Klik met de rechtermuisknop op het item en selecteer Help weergeven.

    • Klik op Help  boven het Script-veld.

Voorkeuren voor ActionScript instellen

Wanneer u code bewerkt in het deelvenster Handelingen of in het Script-venster, kunt u een set voorkeuren instellen en wijzigen.

  1. Selecteer Bewerken > Voorkeuren (Windows) of Animate > Voorkeuren (Macintosh) en klik vervolgens op Code-editor in de lijst Categorie.

  2. U kunt de volgende voorkeuren instellen:

    Automatische inspringing

    Wanneer Automatische inspringing is ingeschakeld, springt de tekst die u typt na haakjes openen '(' automatisch in op basis van de instelling bij Tabgrootte. Ditzelfde gedrag treedt op wanneer u accolades openen '{' gebruikt.

    Tabgrootte

    Geeft het aantal tekens aan waarmee een nieuwe regel wordt ingesprongen.

    Codehints

    Hiermee schakelt u codehints in voor het Script-veld.

    Vertraging

    Hiermee geeft u de vertraging op (in seconden) voordat codehints worden weergegeven. De optie is verouderd in Animate.

    Lettertype

    Hier geeft u het lettertype op dat in uw script moet worden gebruikt.

    Openen/importeren

    Hier kunt u de tekencodering opgeven die moet worden gebruikt als u ActionScript-bestanden opent of importeert.

    Opslaan/exporteren

    Hier kunt u de tekencodering opgeven die moet worden gebruikt als u ActionScript-bestanden opslaat of exporteert.

    Gewijzigde bestanden opnieuw laden

    Hier kunt u aangeven wat er moet gebeuren als u een script hebt gewijzigd, verplaatst of verwijderd. U kunt kiezen uit Altijd, Nooit of Vragen.

    Altijd

    Er wordt geen waarschuwing weergegeven en het bestand wordt automatisch opnieuw geladen.

    Nooit

    Er wordt geen waarschuwing weergegeven en het bestand wordt niet opnieuw geladen.

    Vragen

    (Standaard) Er wordt een waarschuwing weergegeven en u kunt aangeven of het bestand al dan niet opnieuw moet worden geladen.

    Wanneer u toepassingen ontwikkelt met externe scripts, kunt u deze voorkeur gebruiken om te voorkomen dat u een script overschrijft. Tevens wordt voorkomen dat u de toepassing publiceert met oudere versies van scripts. Via deze waarschuwingen kunt u een script automatisch sluiten en de nieuwere, gewijzigde versie openen.

    Syntaxiskleuren

    Hier kunt u de codekleuren voor uw scripts opgeven.

    Instellingen ActionScript 3.0

    Met deze knoppen opent u de dialoogvensters met instellingen voor ActionScript. In deze vensters kunt u een bronpad, een bibliotheekpad en een extern bibliotheekpad voor ActionScript 3.0 instellen.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid