Objecten stapelen

In Animate worden objecten in een laag in de volgorde gestapeld waarop ze zijn gemaakt, waarbij het recentst gemaakte object boven aan de stapel komt. De stapelvolgorde van objecten bepaalt hoe ze worden weergegeven wanneer ze overlappen. U kunt de stapelvolgorde van objecten altijd wijzigen.

Getekende lijnen en vormen worden altijd onder groepen en symbolen in de stapel weergegeven. U kunt deze omhoog verplaatsen in de stapel door ze te groeperen of tot symbolen te maken.

Lagen beïnvloeden ook de stapelvolgorde. Alles op laag 2 wordt vóór alles op laag 1 weergegeven, enzovoort. U kunt de volgorde van lagen wijzigen door de laagnaam in de tijdlijn naar een nieuwe positie te slepen.

  1. Selecteer het object.
  2. Ga als volgt te werk:
    • Selecteer Wijzigen > Rangschikken > Naar voorgrond of Naar achtergrond om het object of de groep naar boven of naar onder in de stapelvolgorde te verplaatsen.

    • Selecteer Wijzigen > Rangschikken > Naar voren of Naar achteren om het object of de groep één positie naar voren of naar achteren in de stapelvolgorde te verplaatsen.

Wanneer u meerdere groepen hebt geselecteerd, worden deze voor of achter alle niet-geselecteerde groepen geplaatst, waarbij hun volgorde ten opzichte van elkaar behouden blijft.

Objecten uitlijnen

Via het deelvenster Uitlijnen kunt u geselecteerde objecten langs de horizontale of verticale as uitlijnen. U kunt objecten verticaal langs de rechterrand, tussen de randen of langs de linkerrand van de geselecteerde objecten uitlijnen, maar ook horizontaal langs de bovenrand, tussen de randen of langs de onderrand van de geselecteerde objecten.

Zie het onderwerp over het gebruik van lay-outgereedschappen op de webpagina met Animate-zelfstudies voor een zelfstudie over lay-outgereedschappen in Animate.

  1. Selecteer de objecten die u wilt uitlijnen.
  2. Selecteer Venster > Uitlijnen.
  3. Selecteer Op werkgebied in het deelvenster Uitlijnen om uitlijningswijzigingen toe te passen ten opzichte van de afmetingen van het werkgebied.
  4. Selecteer de uitlijningsknoppen om de geselecteerde objecten te wijzigen.

Objecten groeperen

Wanneer u elementen als een enkel object wilt manipuleren, moet u deze groeperen. U kunt bijvoorbeeld na het maken van een tekening de elementen van de tekening groeperen, zodat u de tekening als een geheel eenvoudig kunt selecteren en verplaatsen.

Wanneer u een groep selecteert, worden in Eigenschapcontrole de x- en y-coördinaten van de groep en de pixelafmetingen weergegeven.

U kunt groepen bewerken zonder de groepering ervan op te heffen. U kunt ook een afzonderlijk object in een groep selecteren om het te bewerken zonder de groepering van de objecten op te heffen.

  1. Selecteer de objecten die u wilt groeperen. U kunt vormen, andere groepen, symbolen, tekst, enzovoort selecteren.
    • Selecteer Wijzigen > Groeperen of druk op Ctrl+G (Windows) of Cmd+G (Macintosh) om objecten te groeperen.

    • Selecteer Wijzigen > Groep opheffen of druk op Ctrl+Shift+G (Windows) of Cmd+Shift+G (Macintosh) om de groepering van objecten op te heffen.

Groep of object binnen een groep bewerken

  1. Selecteer de groep en selecteer vervolgens Bewerken > Selectie bewerken of dubbelklik op de groep met het gereedschap Selecteren.

    Alles op de pagina dat niet onderdeel is van groep, wordt gedimd weergegeven om aan te geven dat elementen buiten de groep niet toegankelijk zijn.

  2. Bewerk elementen binnen de groep.
  3. Selecteer Bewerken > Alles bewerken of dubbelklik met het gereedschap Selecteren op een lege plek in het werkgebied.

    De groep wordt door Animate teruggezet naar de status als enkelvoudige entiteit, waarna u met andere elementen in het werkgebied kunt werken.

Groepen en objecten splitsen

U kunt groepen, instanties en bitmaps afscheiden tot ongegroepeerde, bewerkbare elementen door ze te splitsen. Op die manier wordt de bestandsgrootte van geïmporteerde afbeeldingen aanzienlijk verkleind.

Hoewel u Bewerken > Ongedaan maken kunt selecteren direct nadat u een groep of object hebt gesplitst, is splitsen niet geheel omkeerbaar. Splitsen heeft het volgende effect op objecten:

  • De koppeling van de symboolinstantie naar het hoofdsymbool wordt verbroken.

  • Alle frames, met uitzondering van het huidige frame, in een bewegend symbool worden genegeerd.

  • Een bitmap wordt omgezet in een vulling

  • Elk teken wordt in een afzonderlijk tekstblok geplaatst bij toepassing op tekstblokken.

  • Tekens worden omgezet in contouren bij toepassing op een enkel tekstteken.

    U moet de opdracht Splitsen niet verwarren met de opdracht Groep opheffen. Met de opdracht Groep opheffen worden gegroepeerde objecten afgescheiden en teruggezet naar de status die ze hadden voordat ze werden gegroepeerd. Bitmaps, instanties of typen worden niet gesplitst en typen worden niet in contouren omgezet.

  1. Selecteer de groep, de bitmap of het symbool dat u wilt splitsen.
  2. Selecteer Wijzigen > Splitsen.

Opmerking:

het splitsen van bewegende symbolen of groepen in een geïnterpoleerde animatie wordt afgeraden en kan onvoorspelbare resultaten opleveren. Het splitsen van complexe symbolen en grote blokken tekst kan veel tijd in beslag nemen. Mogelijk moet u de geheugentoewijzing van de toepassing vergroten om complexe objecten te kunnen splitsen.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid