Handboek Annuleren

Geïmporteerde bitmaps in Animate

  1. Adobe Animate-handboek
  2. Inleiding tot Animate
    1. Nieuw in Animate
    2. Visuele verklarende woordenlijst
    3. Systeemvereisten voor Animate
    4. Animate-sneltoetsen
    5. Werken met meerdere bestandstypen in Animate
  3. Animatie
    1. Grondbeginselen voor animaties in Animate
    2. Frames en hoofdframes gebruiken in Animate
    3. Frame-voor-frame-animaties in Animate
    4. Werken met klassieke tween-animaties in Animate
    5. De tool Penseel
    6. Hulplijnen voor bewegingen
    7. Bewegings-tween en ActionScript 3.0
    8. Informatie over animaties met bewegings-tween
    9. Animaties met bewegings-tweens
    10. Een animatie met bewegings-tween maken
    11. Eigenschapshoofdframes gebruiken
    12. Een positie animeren met een tween
    13. Bewegings-tweens bewerken in de Bewegingseditor
    14. Het bewegingspad van een tween-animatie bewerken
    15. Bewegings-tweens manipuleren
    16. Aangepaste versnellingen toevoegen
    17. Voorinstellingen voor beweging maken en toepassen
    18. Animatietween-reeksen instellen
    19. Werken met als XML-bestanden opgeslagen bewegings-tweens
    20. Bewegings-tweens en klassieke tweens
    21. Vormen tweenen
    22. De tool Bone-animatie gebruiken in Animate
    23. Werken met structuren voor personages in Animate
    24. Maskeerlagen gebruiken in Adobe Animate
    25. Werken met scènes in Animate
  4. Interactiviteit
    1. Knoppen maken met Animate
    2. Animate-projecten converteren naar andere documentindelingen
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Interactiviteit toevoegen met codefragmenten in Animate
    5. Aangepaste HTML5-componenten maken
    6. Componenten in HTML5 Canvas gebruiken
    7. Maken van aangepaste componenten: Voorbeelden
    8. Codefragmenten voor aangepaste componenten
    9. Tips en trucs: Adverteren met Animate
    10. Ontwerp en publicatie van virtual reality
  5. Werkruimte en workflow
    1. Penselen maken en beheren
    2. Google-lettertypen gebruiken in HTML5 Canvas-documenten
    3. Creative Cloud Libraries en Adobe Animate gebruiken
    4. Het werkgebied en het deelvenster Tools voor Animate gebruiken
    5. Workflow en werkruimte in Animate
    6. Weblettertypen gebruiken in HTML5 Canvas-documenten
    7. Tijdlijnen en ActionScript
    8. Werken met meerdere tijdlijnen
    9. Voorkeuren instellen
    10. Deelvensters voor ontwerp in Animate gebruiken
    11. Tijdlijnlagen maken met Animate
    12. Animaties exporteren voor mobiele apps en game-engines
    13. Objecten verplaatsen en kopiëren
    14. Sjablonen
    15. Zoeken en vervangen in Animate
    16. Ongedaan maken, Opnieuw en het deelvenster Historie
    17. Sneltoetsen
    18. De tijdlijn gebruiken in Animate
    19. HTML-extensies maken
    20. Optimalisatieopties voor afbeeldingen en geanimeerde GIF-bestanden
    21. Exportinstellingen voor afbeeldingen en GIF-bestanden
    22. Deelvenster Elementen in Animate
  6. Multimedia en video
    1. Grafische objecten transformeren en combineren in Animate
    2. Symboolinstanties maken in Animate en ermee werken
    3. Afbeeldingen overtrekken
    4. Geluid gebruiken in Adobe Animate
    5. SVG-bestanden exporteren
    6. Videobestanden maken voor gebruik in Animate
    7. Een video toevoegen in Animate
    8. Werken met videoactiepunten
    9. Objecten tekenen en maken met Animate
    10. Lijnen en vormen omvormen
    11. Streken, verlopen en vullingen met Animate CC
    12. Werken met Adobe Premiere Pro en After Effects
    13. Deelvensters voor kleuren in Animate CC
    14. Flash CS6-bestanden openen met Animate
    15. Werken met klassieke tekst in Animate
    16. Illustraties opnemen in Animate
    17. Geïmporteerde bitmaps in Animate
    18. 3D-afbeeldingen
    19. Werken met symbolen in Animate
    20. Lijnen en vormen tekenen met Adobe Animate
    21. Werken met bibliotheken in Animate
    22. Geluiden exporteren
    23. Objecten selecteren in Animate CC
    24. Werken met Illustrator AI-bestanden in Animate
    25. Patronen toepassen met het sproeipenseel
    26. Overvloeimodi toepassen
    27. Objecten rangschikken
    28. Taken automatiseren met het menu Opdrachten
    29. Meertalige tekst
    30. De camera gebruiken in Animate
    31. Animate gebruiken met Adobe Scout
    32. Werken met Fireworks-bestanden
    33. Grafische filters
    34. Geluid en ActionScript
    35. Tekenvoorkeuren
    36. Tekenen met de pen
  7. Platforms
    1. Animate-projecten converteren naar andere documentindelingen
    2. Ondersteuning voor aangepaste platforms
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Een WebGL-document maken en publiceren
    5. Toepassingen verpakken voor AIR voor iOS
    6. AIR voor Android-toepassingen publiceren
    7. Publiceren voor Adobe AIR voor desktop
    8. Publicatie-instellingen voor ActionScript
    9. Tips en trucs: ActionScript organiseren in een toepassing
    10. ActionScript gebruiken met Animate
    11. Tips en trucs: Richtlijnen voor toegankelijkheid
    12. Toegankelijkheid in de Animate-werkruimte
    13. Scripts schrijven en beheren
    14. Ondersteuning voor aangepaste platforms inschakelen
    15. Overzicht van ondersteuning voor aangepaste platforms
    16. Toegankelijke inhoud maken
    17. Werken met plug-in voor ondersteuning voor aangepaste platforms
    18. Foutopsporing in ActionScript 3.0
    19. Ondersteuning voor aangepaste platforms inschakelen
  8. Exporteren en publiceren
    1. Bestanden exporteren uit Animate CC
    2. OAM-publicatie
    3. SVG-bestanden exporteren
    4. Afbeeldingen en video's exporteren met Animate
    5. AS3-documenten publiceren
    6. Animaties exporteren voor mobiele apps en game-engines
    7. Geluiden exporteren
    8. QuickTime-videobestanden exporteren
    9. Afspelen van externe video met ActionScript beheren
    10. Tips en trucs: Tips voor het maken van inhoud voor mobiele apparaten
    11. Tips en trucs: Videoconventies
    12. Tips en trucs: Richtlijnen voor het ontwerpen van SWF-toepassingen
    13. Tips en trucs: Structuur geven aan FLA-bestanden
    14. Beste werkwijzen voor het optimaliseren van FLA-bestanden voor Animate
    15. Publicatie-instellingen voor ActionScript
    16. Publicatie-instellingen opgeven voor Animate
    17. Projectorbestanden exporteren
    18. Afbeeldingen en geanimeerde GIF-bestanden exporteren
    19. HTML-publicatiesjablonen
    20. Werken met Adobe Premiere Pro en After Effects
    21. Snel uw animaties delen en publiceren

Werken met geïmporteerde bitmaps

Wanneer u een bitmap importeert in Animate, kunt u de bitmap wijzigen en op verschillende manieren in uw Animate-document gebruiken.

Als de geïmporteerde bitmap in een Animate-document een formaat groter wordt weergegeven dan het origineel, is de afbeelding mogelijk vervormd. Controleer geïmporteerde bitmaps om er zeker van te zijn dat afbeeldingen correct worden weergegeven.

Wanneer u een bitmap in het werkgebied selecteert, worden in Eigenschapcontrole de symboolnaam en de pixelafmetingen en -positie in het werkgebied weergegeven. Met Eigenschapcontrole kunt u een instantie van een bitmap omwisselen. Met andere woorden, u kunt de instantie vervangen door een instantie van een andere bitmap in het huidige document.

 

Eigenschapcontrole weergeven met bitmapeigenschappen

  1. Selecteer een instantie van een bitmap in het werkgebied.

  2. Selecteer Venster > Eigenschappen.

Een instantie van een bitmap vervangen door een instantie van een andere bitmap

  1. Selecteer een bitmapinstantie in het werkgebied.

  2. Selecteer Venster > Eigenschappen en klik op Omwisselen.

  3. Selecteer de bitmap die de bitmap moet vervangen die momenteel is toegewezen aan de instantie.

Bitmapeigenschappen instellen

U kunt anti-aliasing op een geïmporteerde bitmap toepassen om de randen in de afbeelding vloeiender te maken. U kunt ook een compressieoptie selecteren om de grootte van het bitmapbestand te verkleinen voor weergave op het web.

  1. Selecteer een bitmap in het deelvenster Bibliotheek en klik op het pictogram Eigenschappen onder in het deelvenster Bibliotheek.
  2. Selecteer Effenen toestaan. Effenen verbetert de kwaliteit van bitmapafbeeldingen wanneer deze worden geschaald.
  3. Selecteer bij Compressie een van de volgende opties:

    Foto (JPEG)

    De afbeelding wordt gecomprimeerd in JPEG-indeling. Als u de standaardcompressiekwaliteit wilt gebruiken die voor de geïmporteerde afbeelding is opgegeven, selecteert u Standaarddocumentkwaliteit gebruiken. Als u een nieuwe kwaliteitsinstelling voor compressie wilt opgeven, heft u de selectie van Standaarddocumentkwaliteit gebruiken op en voert u in het tekstveld Kwaliteit een waarde in tussen 1 en 100. (Een hogere instelling resulteert in een hogere afbeeldingskwaliteit, maar levert ook een groter bestand op.)

    Zonder verlies (PNG/GIF)

    De afbeelding wordt zonder verlies gecomprimeerd en er worden geen gegevens van de afbeelding genegeerd.

    Opmerking: Gebruik fotocompressie voor afbeeldingen met complexe kleur- of tintvariaties, zoals foto's of afbeeldingen met verlopende vullingen. Gebruik een compressie zonder verlies voor afbeeldingen met eenvoudige vormen en relatief weinig kleuren.

  4. Klik op Testen om de resultaten van de bestandscompressie te bepalen. Vergelijk de oorspronkelijke bestandsgrootte met de grootte van het gecomprimeerde bestand om te bepalen of de geselecteerde compressie-instelling acceptabel is.
  5. Klik op OK.
Opmerking:

De instellingen voor JPEG-kwaliteit in het dialoogvenster Publicatie-instellingen hebben geen invloed op geïmporteerde JPEG-bestanden. Geef in het dialoogvenster Bitmapeigenschappen een kwaliteitsinstelling op voor elk geïmporteerd JPEG-bestand.

(Alleen Animate ) Meerdere bitmaps wisselen

Met de optie Bitmaps wisselen kunt u symbolen en bitmaps omwisselen voor geselecteerde symbolen of bitmaps.

  1. Selecteer meerdere bitmaps in het werkgebied van Animate.

  2. Klik op Wisselen in het deelvenster Eigenschappen.
  3. In het dialoogvenster Symbool wisselen selecteert u de bitmap die u wilt gebruiken ter vervanging van alle geselecteerde symbolen/bitmaps.
  4. Klik op OK.

Bitmaps importeren bij uitvoering

Als u bitmaps tijdens uitvoering wilt toevoegen aan een document, gebruikt u de ActionScript® 2.0- of ActionScript 3.0-opdracht BitmapData. Geef hiervoor een koppelings-id op voor de bitmap. Zie Koppelingen toewijzen aan elementen in de bibliotheek in ActionScript 2.0 leren of Bibliotheeksymbolen voor ActionScript exporteren in de ActionScript 3.0-ontwikkelaarsgids voor meer informatie.

  1. Selecteer de bitmap in het deelvenster Bibliotheek.
  2. Ga als volgt te werk:
    • Selecteer Koppeling in het menu Deelvenster in de rechterbovenhoek van het deelvenster.

    • Klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op de naam van de bitmap in het deelvenster Bibliotheek en selecteer Eigenschappen in het contextmenu.

      Als de koppelingseigenschappen niet worden weergegeven in het dialoogvenster Eigenschappen klikt u op Geavanceerd.

  3. Selecteer Exporteren voor ActionScript bij Koppeling.
  4. Voer in het tekstveld een tekenreeks-id in en klik op OK.

Een bitmap als vulling toepassen

Als u een bitmap als vulling wilt toepassen op een grafisch object, gebruikt u het deelvenster Kleur. Wanneer u een bitmap toepast als een vulling, wordt het object gevuld met tegels van de bitmap. Met het gereedschap Verlooptransformatie kunt u een afbeelding en de bitmapvulling schalen, roteren of scheeftrekken.

  1. Wanneer u de vulling op een bestaande illustratie wilt toepassen, selecteert u een of meer grafische objecten in het werkgebied.
  2. Selecteer Venster > Kleur.
  3. Selecteer Bitmap in het pop-upmenu rechtsboven in het deelvenster.
  4. Als u een groter voorbeeldvenster wilt gebruiken om meer bitmaps in het huidige document weer te geven, klikt u op de pijl in de rechterbenedenhoek om het deelvenster Kleur uit te vouwen.
  5. Klik op een bitmap om deze te selecteren.

    De bitmap wordt de huidige vulkleur. Als u een illustratie hebt geselecteerd in stap 1, wordt de bitmap als vulling toegepast op de illustratie.

Bitmaps bewerken in een externe editor

Als u een Fireworks PNG-bestand wilt bewerken dat is geïmporteerd als een afgevlakte afbeelding, moet u het PNG-bronbestand voor de bitmap bewerken, indien beschikbaar.

Opmerking:

U kunt geen bitmaps uit Fireworks PNG-bestanden bewerken die zijn geïmporteerd als bewerkbare objecten in een extern beeldbewerkingsprogramma.

Wanneer u Fireworks 3 of hoger, of een andere beeldbewerkingstoepassing op uw systeem hebt geïnstalleerd, kunt u de toepassing vanuit Animate starten om een geïmporteerde bitmap te bewerken.

Een bitmap bewerken met Photoshop CS5 of hoger

Opmerking:

Als u CS5.5 gebruikt, moet u Photoshop CS5.1 gebruiken om deze functie toegankelijk te maken.

  1. Klik in het deelvenster Bibliotheek met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt (Macintosh) en klik op het pictogram van de bitmap. Selecteer vervolgens Bewerken met Photoshop CS5.

  2. Voer de gewenste wijzigingen in het bestand door in Photoshop.

  3. Selecteer Bestand > Opslaan in Photoshop. (U mag de bestandsnaam en -indeling niet wijzigen.)

  4. Ga terug naar Animate.

    Het bestand wordt automatisch bijgewerkt in Animate.

Een bitmap bewerken met Fireworks 3 of hoger

  1. Klik in het deelvenster Bibliotheek met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt (Macintosh) en klik op het pictogram van de bitmap. Selecteer vervolgens Bewerken met Fireworks 3.

  2. Geef op of het PNG-bronbestand of het bitmapbestand moet worden geopend.

  3. Voer de gewenste wijzigingen in het bestand door in Fireworks.

  4. In Fireworks selecteert u Bestand > Bijwerken.

  5. Ga terug naar Animate.

    Het bestand wordt automatisch bijgewerkt in Animate.

Een bitmap bewerken met een andere beeldbewerkingstoepassing

  1. Klik in het deelvenster Bibliotheek met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op het pictogram van de bitmap. Selecteer vervolgens Bewerken met.

  2. Selecteer een beeldbewerkingstoepassing om het bitmapbestand te openen en klik op OK.

  3. Voer de gewenste wijzigingen in het bestand door in de beeldbewerkingstoepassing.

  4. Sla het bestand op in de beeldbewerkingstoepassing.

    Het bestand wordt automatisch bijgewerkt in Animate.

  5. Ga terug naar Animate om het document verder te bewerken.

Een bitmap splitsen en een bitmapvulling maken

Als u in het werkgebied een bitmap splitst, wordt de werkgebiedafbeelding gescheiden van het bibliotheekelement en wordt dit van een bitmapinstantie omgezet in een vorm. Wanneer u een bitmap splitst, kunt u de bitmap wijzigen met de teken- en schildergereedschappen in Animate. Als u het gereedschap Toverstaf gebruikt, kunt u gebieden van de bitmap selecteren die dezelfde of gelijkaardige kleuren bevatten.

Als u wilt schilderen met een gesplitste bitmap, selecteert u de bitmap met het pipet en past u de bitmap als vulling toe met het emmertje of een ander tekengereedschap.

Een bitmap splitsen

  1. Selecteer een bitmap in de huidige scène.

  2. Selecteer Wijzigen > Splitsen.

De vulling van gebieden van een gesplitste bitmap wijzigen

  1. Selecteer het gereedschap Toverstaf in het deelvenster Gereedschappen. Als het gereedschap Toverstaf niet zichtbaar is, klikt u op het gereedschap Lasso en selecteert u het gereedschap Toverstaf in het pop-upmenu. Stel in de Eigenschapcontrole de volgende opties in:

    • Voer bij Drempel een waarde tussen 1 en 200 in om te bepalen in welke mate de kleur van naastgelegen pixels moet overeenkomen om te worden opgenomen in de selectie. Bij een hogere waarde wordt een groter kleurbereik opgenomen. Wanneer u 0 invoert, worden alleen pixels geselecteerd die exact dezelfde kleur hebben als het eerste pixel waarop u klikt.

    • Selecteer bij Effenen een optie om te bepalen in welke mate de randen van de selectie vloeiend moeten worden gemaakt.

  2. Klik op de bitmap om een gebied te selecteren. Blijf klikken als u de selectie wilt uitbreiden.

  3. Als u de geselecteerde gebieden in de bitmap wilt opvullen, selecteert u de gewenste vulling in het besturingselement voor vulkleuren.

  4. U past de nieuwe vulling toe door het verfemmertje te selecteren en in het geselecteerde gebied te klikken.

Bitmaps omzetten in vectorafbeeldingen

Met de opdracht Bitmap overtrekken wordt een bitmap omgezet in een vectorafbeelding met bewerkbare, discrete kleurgebieden. U bewerkt de afbeelding als een vectorafbeelding en u kunt de bestandsgrootte beperken.

Wanneer u een bitmap omzet in een vectorafbeelding, wordt de koppeling tussen de vectorafbeelding en het bitmapsymbool in het deelvenster Bibliotheek verbroken.

Opmerking:

Als de geïmporteerde bitmap complexe vormen en een groot aantal kleuren bevat, is het bestand met de omgezette vectorafbeelding mogelijk groter dan het bestand met de oorspronkelijke bitmap. Probeer verschillende instellingen in het dialoogvenster Bitmap overtrekken om een balans te vinden tussen bestandsgrootte en afbeeldingskwaliteit.

U kunt een bitmap ook splitsen om de afbeelding te wijzigen met de teken- en schildergereedschappen in Animate.

  1. Selecteer een bitmap in de huidige scène.

  2. Selecteer Wijzigen > Bitmap > Bitmap overtrekken.

  3. Voer een waarde in bij Kleurdrempel.

    Wanneer twee pixels worden vergeleken en het verschil in de RGB-kleurwaarden kleiner is dan de kleurdrempel, worden de kleuren van de twee pixels beschouwd als identiek. Hoe hoger de drempelwaarde, hoe kleiner het aantal kleuren.

  4. Voer bij Minimumgebied een waarde in om in te stellen met hoeveel omringende pixels rekening moet worden gehouden wanneer er een kleur wordt toegewezen aan een pixel.

  5. Selecteer bij Curvepasvorm een optie om te bepalen hoe vloeiend de contouren worden getekend.

  6. Selecteer bij Hoekdrempel een optie om te bepalen of scherpe randen behouden moeten blijven of vloeiend moeten worden gemaakt.

    Voer de volgende waarden in als u een vectorafbeelding wilt maken die zoveel mogelijk lijkt op de originele bitmap:

    • Kleurdrempel: 10

    • Minimumgebied: 1 pixel

    • Curvepasvorm: Pixels

    • Hoekdrempel: Veel hoeken

Bitmapvulling toepassen met het pipet

  1. Selecteer het pipet en klik op de gesplitste bitmap in het werkgebied. Met het pipet wordt de bitmap ingesteld als de huidige vulling en wordt het verfemmertje ingesteld als het actieve gereedschap.

  2. Ga als volgt te werk:

    • Als u de bitmap wilt toepassen als een vulling, klikt u met het verfemmertje op een bestaand grafisch object.

    • Selecteer het gereedschap Ovaal, Rechthoek of Pen en teken een nieuw object. Het object wordt gevuld met de gesplitste bitmap.

      Als u de bitmapvulling wilt schalen, roteren of schuintrekken, gebruikt u het gereedschap Vrije transformatie.

 Adobe

Krijg sneller en gemakkelijker hulp

Nieuwe gebruiker?