Frames en hoofdframes gebruiken in Animate

  1. Adobe Animate-handboek
  2. Inleiding tot Animate
    1. Nieuw in Animate
    2. Visuele verklarende woordenlijst
    3. Systeemvereisten voor Animate
    4. Animate-sneltoetsen
    5. Werken met meerdere bestandstypen in Animate
  3. Animatie
    1. Grondbeginselen voor animaties in Animate
    2. Frames en hoofdframes gebruiken in Animate
    3. Frame-voor-frame-animaties in Animate
    4. Werken met klassieke tween-animaties in Animate
    5. De tool Penseel
    6. Hulplijnen voor bewegingen
    7. Bewegings-tween en ActionScript 3.0
    8. Informatie over animaties met bewegings-tween
    9. Animaties met bewegings-tweens
    10. Een animatie met bewegings-tween maken
    11. Eigenschapshoofdframes gebruiken
    12. Een positie animeren met een tween
    13. Bewegings-tweens bewerken in de Bewegingseditor
    14. Het bewegingspad van een tween-animatie bewerken
    15. Bewegings-tweens manipuleren
    16. Aangepaste versnellingen toevoegen
    17. Voorinstellingen voor beweging maken en toepassen
    18. Animatietween-reeksen instellen
    19. Werken met als XML-bestanden opgeslagen bewegings-tweens
    20. Bewegings-tweens en klassieke tweens
    21. Vormen tweenen
    22. De tool Bone-animatie gebruiken in Animate
    23. Werken met structuren voor personages in Animate
    24. Maskeerlagen gebruiken in Adobe Animate
    25. Werken met scènes in Animate
  4. Interactiviteit
    1. Knoppen maken met Animate
    2. Animate-projecten converteren naar andere documentindelingen
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Interactiviteit toevoegen met codefragmenten in Animate
    5. Aangepaste HTML5-componenten maken
    6. Componenten in HTML5 Canvas gebruiken
    7. Maken van aangepaste componenten: Voorbeelden
    8. Codefragmenten voor aangepaste componenten
    9. Tips en trucs: Adverteren met Animate
    10. Ontwerp en publicatie van virtual reality
  5. Werkruimte en workflow
    1. Penselen maken en beheren
    2. Google-lettertypen gebruiken in HTML5 Canvas-documenten
    3. Creative Cloud Libraries en Adobe Animate gebruiken
    4. Het werkgebied en het deelvenster Tools voor Animate gebruiken
    5. Workflow en werkruimte in Animate
    6. Weblettertypen gebruiken in HTML5 Canvas-documenten
    7. Tijdlijnen en ActionScript
    8. Werken met meerdere tijdlijnen
    9. Voorkeuren instellen
    10. Deelvensters voor ontwerp in Animate gebruiken
    11. Tijdlijnlagen maken met Animate
    12. Animaties exporteren voor mobiele apps en game-engines
    13. Objecten verplaatsen en kopiëren
    14. Sjablonen
    15. Zoeken en vervangen in Animate
    16. Ongedaan maken, Opnieuw en het deelvenster Historie
    17. Sneltoetsen
    18. De tijdlijn gebruiken in Animate
    19. HTML-extensies maken
    20. Optimalisatieopties voor afbeeldingen en geanimeerde GIF-bestanden
    21. Exportinstellingen voor afbeeldingen en GIF-bestanden
    22. Deelvenster Elementen in Animate
  6. Multimedia en video
    1. Grafische objecten transformeren en combineren in Animate
    2. Symboolinstanties maken in Animate en ermee werken
    3. Afbeeldingen overtrekken
    4. Geluid gebruiken in Adobe Animate
    5. SVG-bestanden exporteren
    6. Videobestanden maken voor gebruik in Animate
    7. Een video toevoegen in Animate
    8. Werken met videoactiepunten
    9. Objecten tekenen en maken met Animate
    10. Lijnen en vormen omvormen
    11. Streken, verlopen en vullingen met Animate CC
    12. Werken met Adobe Premiere Pro en After Effects
    13. Deelvensters voor kleuren in Animate CC
    14. Flash CS6-bestanden openen met Animate
    15. Werken met klassieke tekst in Animate
    16. Illustraties opnemen in Animate
    17. Geïmporteerde bitmaps in Animate
    18. 3D-afbeeldingen
    19. Werken met symbolen in Animate
    20. Lijnen en vormen tekenen met Adobe Animate
    21. Werken met bibliotheken in Animate
    22. Geluiden exporteren
    23. Objecten selecteren in Animate CC
    24. Werken met Illustrator AI-bestanden in Animate
    25. Patronen toepassen met het sproeipenseel
    26. Overvloeimodi toepassen
    27. Objecten rangschikken
    28. Taken automatiseren met het menu Opdrachten
    29. Meertalige tekst
    30. De camera gebruiken in Animate
    31. Animate gebruiken met Adobe Scout
    32. Werken met Fireworks-bestanden
    33. Grafische filters
    34. Geluid en ActionScript
    35. Tekenvoorkeuren
    36. Tekenen met de pen
  7. Platforms
    1. Animate-projecten converteren naar andere documentindelingen
    2. Ondersteuning voor aangepaste platforms
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Een WebGL-document maken en publiceren
    5. Toepassingen verpakken voor AIR voor iOS
    6. AIR voor Android-toepassingen publiceren
    7. Publiceren voor Adobe AIR voor desktop
    8. Publicatie-instellingen voor ActionScript
    9. Tips en trucs: ActionScript organiseren in een toepassing
    10. ActionScript gebruiken met Animate
    11. Tips en trucs: Richtlijnen voor toegankelijkheid
    12. Toegankelijkheid in de Animate-werkruimte
    13. Scripts schrijven en beheren
    14. Ondersteuning voor aangepaste platforms inschakelen
    15. Overzicht van ondersteuning voor aangepaste platforms
    16. Toegankelijke inhoud maken
    17. Werken met plug-in voor ondersteuning voor aangepaste platforms
    18. Foutopsporing in ActionScript 3.0
    19. Ondersteuning voor aangepaste platforms inschakelen
  8. Exporteren en publiceren
    1. Bestanden exporteren uit Animate CC
    2. OAM-publicatie
    3. SVG-bestanden exporteren
    4. Afbeeldingen en video's exporteren met Animate
    5. AS3-documenten publiceren
    6. Animaties exporteren voor mobiele apps en game-engines
    7. Geluiden exporteren
    8. QuickTime-videobestanden exporteren
    9. Afspelen van externe video met ActionScript beheren
    10. Tips en trucs: Tips voor het maken van inhoud voor mobiele apparaten
    11. Tips en trucs: Videoconventies
    12. Tips en trucs: Richtlijnen voor het ontwerpen van SWF-toepassingen
    13. Tips en trucs: Structuur geven aan FLA-bestanden
    14. Beste werkwijzen voor het optimaliseren van FLA-bestanden voor Animate
    15. Publicatie-instellingen voor ActionScript
    16. Publicatie-instellingen opgeven voor Animate
    17. Projectorbestanden exporteren
    18. Afbeeldingen en geanimeerde GIF-bestanden exporteren
    19. HTML-publicatiesjablonen
    20. Werken met Adobe Premiere Pro en After Effects
    21. Snel uw animaties delen en publiceren

Overzicht

In Adobe Animate-documenten wordt de tijdsduur opgedeeld in frames, net als bij films. Frames zijn de kern van elke animatie en bepalen elk segment van tijd en beweging. Het totale aantal frames in uw film en de snelheid waarmee ze worden afgespeeld, bepalen samen de totale lengte van uw film. Hieronder vindt u een korte beschrijving van enkele frameconcepten ter referentie.

Frames

In de tijdlijn werkt u met deze frames om de inhoud van uw document te ordenen en beheren. U plaatst frames in de tijdlijn in de volgorde waarin u de frameobjecten in de uiteindelijke inhoud wilt weergeven.

Hoofdframe

Een hoofdframe is een frame waarbij een nieuwe symboolinstantie in de tijdlijn verschijnt. Een hoofdframe kan ook een frame met ActionScript®-code zijn waarmee een bepaald aspect van het document wordt beheerd. U kunt ook een leeg hoofdframe toevoegen aan de tijdlijn als een tijdelijke aanduiding voor symbolen die u later wilt toevoegen, of om het frame leeg te laten.

Met hoofdframes kunt u een positie instellen en ankerpunten, handelingen, opmerkingen enzovoort toevoegen. 

Bereik

Met op bereik gebaseerde frameselectie kunt u met één klik een aantal frames tussen twee hoofdframes selecteren.

Bereik voor statische frames

Met dit type bereik is dezelfde inhoud beschikbaar voor de volledige duur van het bereik. Gebruik deze optie wanneer u afbeeldingen voor een vaste tijdsduur moet weergeven. 

Bereik met getweende frames

In een bereik met getweende frames verandert de inhoud voor elk frame binnen het bereik. Gebruik dit type voor animaties. 

Frames toevoegen of invoegen in de tijdlijn

  • Selecteer Invoegen > Tijdlijn > Frame (F5) om een nieuw frame in te voegen.

  • Als u een hoofdframe wilt maken, selecteert u Invoegen > Tijdlijn > Hoofdframe (F6). U kunt ook met de rechtermuisknop (Windows) of met Control‑klik (Macintosh) klikken op het frame waar u een hoofdframe wilt plaatsen en vervolgens Hoofdframe invoegen selecteren in het contextmenu.

  • Als u een leeg hoofdframe wilt maken, selecteert u Invoegen > Tijdlijn > Leeg hoofdframe. U kunt ook met de rechtermuisknop (Windows) of met Control-klik (Macintosh) klikken op het frame waar u een hoofdframe wilt plaatsen en vervolgens Leeg hoofdframe invoegen selecteren in het contextmenu.

Effecten voor frames

De filters en kleureffecten konden vroeger alleen worden toegepast op filmclips en grafische symbolen. Met de geavanceerde lagen kunnen filters en kleureffectten nu worden toegepast op een of meerdere geselecteerde frames, die op hun beurt worden toegepast op alle inhoud, waaronder vormen, tekenobjecten, grafische symbolen enzovoort. Laageffecten kunnen ook worden getweend met behulp van klassieke, vorm- en IK-tweens op verschillende frames.

Zie Laageffecten toepassen voor meer informatie. 

Frames selecteren en labels aan frames toevoegen in de tijdlijn

In Animate kunt u op twee manieren een frame selecteren. U kunt frames ook voorzien van een label om de inhoud van het frame te ordenen. 

In Animate kunt u op twee manieren een frame in de tijdlijn selecteren. In een op frames gebaseerde selectie (standaard) selecteert u individuele frames in de tijdlijn. In een op bereik gebaseerde selectie, wordt de gehele framereeks, van hoofdframe naar hoofdframe, geselecteerd wanneer u op een frame in de reeks klikt. 

Frames in de tijdlijn selecteren

Enkele of meerdere frames selecteren

  • Klik op een frame om het te selecteren. 
  • Als u meerdere opeenvolgende frames wilt selecteren, sleept u de cursor over de frames of houdt u de Shift-toets ingedrukt terwijl u op de extra frames klikt.

  • Als u meerdere, niet-opeenvolgende frames wilt selecteren, klikt u op de frames terwijl u de toets Ctrl (Windows) of Command (Macintosh) ingedrukt houdt.

  • Als u alle frames in de tijdlijn wilt selecteren, kiest u Bewerken > Tijdlijn > Alle frames selecteren.

Op bereik gebaseerde frameselectie

Als u het op bereik gebaseerde selectietype wilt gebruiken, moet u dit type opgeven in de Animate-tijdlijn door op het hamburgerpictogram rechtsboven te klikken en vervolgens het menu-item Op bereik gebaseerde selectie te selecteren. 

  • Als u een heel framebereik wilt selecteren (bewegings-tween of omgekeerde bewegingen), klikt u op het frame. 
  • Als u meerdere reeksen wilt selecteren, klikt u op de desbetreffende reeksen terwijl u de Shift-toets ingedrukt houdt.

Labels toevoegen aan frames in de tijdlijn

Door framelabels toe te voegen in de tijdlijn kunt u de inhoud van frames beter ordenen. U kunt ook een framelabel toevoegen als u (via het label) naar een bepaald frame wilt verwijzen in ActionScript. Op die manier verwijst ActionScript telkens naar hetzelfde framelabel en hoeft u de code niet bij te werken wanneer u de tijdlijn opnieuw rangschikt en het label naar een ander framenummer verplaatst.

U kunt framelabels ook toepassen op hoofdframes. Het is vaak erg handig om een aparte laag met framelabels te maken in de tijdlijn. Met een afzonderlijke laag kunt u de inhoud en de hoofdframes beter indelen. 

Een framelabel toevoegen:

  1. Selecteer het frame waaraan u een label wilt toevoegen in de tijdlijn.

  2. Selecteer het frame en geef de naam van het label op in het gedeelte Label van Eigenschapscontrole. Druk op Enter of Return.

  3. We raden u aan om een afzonderlijke laag te maken voor alle labels in het frame. 

Op bereik gebaseerde frameselectie inschakelen

Met op bereik gebaseerde frameselectie kunt u met één klik een aantal frames tussen twee hoofdframes selecteren.

  1. Klik op het hamburgerpictogram in de rechterbovenhoek van de tijdlijnsectie. 

    Een pop-upmenu wordt weergegeven. 

  2. Selecteer Op bereik gebaseerde selectie in het pop-upmenu. 

Distribueren naar hoofdframes

Met de optie Distribueren naar hoofdframes kunt u meerdere objecten (symbolen en bitmaps) in het werkgebied elk naar afzonderlijke hoofdframes distribueren.

  1. Selecteer meerdere objecten van een willekeurige laag op het werkgebied.
  2. Klik met de rechtermuisknop in het werkgebied en selecteer Distribueren naar hoofdframes.

Een frame of framereeks kopiëren, plakken, verwijderen, of verplaatsen

Een hoofdframe en de reeks van standaardframes die erop volgt, staat ook wel bekend als een hoofdframereeks. De tijdlijn kan een willekeurig aantal hoofdframereeksen bevatten.

Wanneer u een frame of framereeks wilt kopiëren of plakken, voert u een van de volgende handelingen uit:

Frame of framereeks kopiëren of plakken

  • Selecteer het frame of de reeks en kies Bewerken > Tijdlijn > Frames kopiëren. Selecteer het frame of de reeks die u wilt vervangen en kies Bewerken > Tijdlijn > Frames plakken.

  • Houd de Alt-toets (Windows) of Option-toets (Macintosh) ingedrukt en sleep het hoofdframe naar de plek waar u het frame wilt kopiëren.

Frame of framereeks verwijderen

Een frame, hoofdframe of framereeks verwijderen

Selecteer het frame of de reeks en kies Bewerken > Tijdlijn > Frame verwijderen. U kunt ook met de rechtermuisknop (Windows) of met Control‑klik (Macintosh) klikken op het frame of de reeks en vervolgens Frame verwijderen selecteren in het contextmenu.

De omringende frames blijven ongewijzigd.

Een hoofdframe verwijderen

Selecteer het hoofdframe en kies Bewerken > Tijdlijn > Hoofdframe verwijderen. U kunt ook met de rechtermuisknop (Windows) of met Control‑klik (Macintosh) klikken op het hoofdframe en vervolgens Hoofdframe verwijderen selecteren in het contextmenu.

Een hoofdframe of framereeks verplaatsen

Selecteer een hoofdframe of framereeks en sleep het frame of de reeks naar de gewenste locatie.

De Lengte van een reeks statische frames wijzigen

Sleep het eerste of laatste frame van het bereik naar links of naar rechts terwijl u Ctrl (Windows) of Cmd (Macintosh) ingedrukt houdt.

Zie Frame-voor-frame animaties maken om de lengte van een frame-voor-frame animatiereeks te wijzigen.

Voorvertoning van de inhoud van het frame in de tijdlijn

Kies Voorvertoning in het optiemenu rechtsboven in het deelvenster Tijdlijn.

In elk hoofdframe van de tijdlijn wordt een voorbeeldminiatuur van de items in het hoofdframe weergegeven.

Adobe-logo

Aanmelden bij je account