Para criar um conteúdo do tipo apresentação de slides que pode ser reproduzido no Flash Player, você poderá exportar para SWF ou FLA. A principal diferença é que os arquivos SWF estão prontos para visualização e não podem ser editados, enquanto os arquivos FLA podem ser editados no Adobe Flash Professional para serem visualizados no Adobe Flash Player.

SWF

Um arquivo SWF exportado está pronto para visualização no Adobe Flash Player e pode incluir elementos interativos, tais como transição de página, hiperlinks, filmes, clipes de som, animações e botões de navegação.

FLA

Um arquivo FLA exportado inclui somente alguns elementos interativos. O arquivo FLA pode ser aberto no Flash Pro, onde você ou o desenvolvedor do Flash pode adicionar efeitos avançados antes da exportação para SWF.

Exportar para Flash
Exportar para Flash

A. Exportar diretamente para SWF B. Exportar para FLA para editar no Flash Professional 

Criar arquivos SWF (Flash) interativos para a Web

Quando você exporta para SWF, você cria um arquivo interativo que está pronto para ser visualizado no Adobe Flash Player ou em um navegador da Web. O arquivo SWF pode incluir botões, transições de página, filmes, arquivos de áudio, animações e hiperlinks adicionados no InDesign. Exportar para SWF é uma ótima forma de criar uma apresentação de slides interativa ou um flip book, com base em um documento do InDesign.

Se você deseja editar o documento em Flash Pro antes de criar um arquivo SWF, exporte para FLA ao invés de SWF. Consulte Criar arquivos FLA para a Web.

Exportação de SWF
Exportação de SWF

A. Documento no InDesign antes da exportação de SWF B. Arquivo SWF interativo no navegador da Web 
  1. Crie ou edite o documento do InDesign para prepará-lo para exportação em Flash. Para obter mais informações detalhadas sobre como configurar o documento para exportação, consulte Problemas ao exportar para Flash.

    • Adicione botões de navegação que permitem aos usuários se mover entre páginas no arquivo SWF exportado. Você pode criar botões ao desenhar um objeto e convertê-lo em um botão usando o painel Botões (escolha Janela > Interativo > Botões). É também possível usar o painel Botões de amostra para arrastar botões de navegação pré-definidos para o documento. Consulte Criar botões.

    • Use o painel Transições de página (escolha Janela > Interativo > Transições de página) para adicionar a transição de página como revelar ou dissolver. Ao exportar pra SWF, você também pode selecionar a opção Incluir ondulação da página interativa, o que permite que os visualizadores arrastem a aresta de uma página para virar a página.

    • Use o painel Animação (escolha Janela > Interativo > Animação) para adicionar predefinições de movimento. Consulte Animação.

  2. Para exportar o documento para o formato SWF, escolha Arquivo > Exportar.

  3. Selecione Usar o nome do documento do InDesign como nome do arquivo de saída, se deseja que o arquivo exportado tenha o mesmo nome do nome do documento na próxima exportação.

  4. Escolha Flash Player (SWF) no menu Salvar como tipo (Windows) ou Formato (Mac OS) e clique em Salvar.

  5. Na caixa de diálogo Exportar SWF, especifique as seguintes opções e clique em OK. Consulte as opções de exportação de SWF.

Ao exportar um arquivo SWF, os arquivos HTML e SWF são criados separadamente. Se o arquivo SWF inclui filmes ou clipes de som, uma pasta Recursos é criada. Para entregar ou carregar os arquivos na Web, certifique-se de enviar todos os ativos.

Opções de exportação de SWF

As opções a seguir aparecem nas guias Geral e Avançado da caixa de diálogo Exportar SWF.

Exportação

Indique se a seleção atual, todas as páginas no documento ou o intervalo de página está incluído. Escolhe Seleção é muito útil se você deseja salvar o arquivo SWF exportado para ser usado em um arquivo PDF exportado. Se você selecionar Intervalo, especifique um intervalo de página, por exemplo 1-7, 9 para imprimir páginas de 1 a 7 e 9. Consulte Especificar as páginas a serem impressas.

Gerar arquivo HTML

Selecione esta opção para gerar uma página HTML que reproduza o arquivo SWF. Essa opção é especialmente útil para visualizar rapidamente o arquivo SWF no navegador da Web.

Exibir SWF após exportação

Selecione esta opção para reproduzir o arquivo SWF em seu navegador da Web padrão. Essa opção somente estará disponível se você gerar um arquivo HTML.

Tamanho (pixels)

Especifique se o arquivo SWF é dimensionado de acordo com uma porcentagem, ajustado a um tamanho de monitor determinado ou dimensionado de acordo com a largura e a altura determinadas.

Fundo

Especifique se o plano de fundo do SWF é transparente ou se usa a Cor de papel atual no painel Amostras. Selecionar Transparente desativa as opções Transições de página e Ondulação de página interativa.

Interatividade e mídia

Selecione Incluir tudo para permitir que os filmes, sons, botões e animações seja interativos no arquivo SWF exportado. Selecione Somente aparência para incluir o estado normal dos botões e os pôsteres de vídeo como elementos estáticos. Se Somente aparência for selecionado, as animações são exportadas conforme são exibidas no layout no momento da exportação. Somente aparência é selecionada se Mesclar transparência for escolhida no painel Avançado.

Transições de página

Especifique uma transição de página para ser aplicada em todas as páginas durante a exportação. Se você usar o painel Transições de página para especificar as transições, escolha a opção Do documento para usar essas configurações.

Incluir Ondulação de página interativa

Se essa opção for selecionada, os usuários que estiverem reproduzindo um arquivo SWF poderão arrastar uma aresta da página para virá-la, dando a impressão de estar virando a página de um livro real.

Taxa de quadros

Taxas mais altas de quadros criam animações mais suaves, mas podem aumentar o tamanho do arquivo. Alterar a taxa de quadros não afeta a duração da reprodução.

Texto

Especifique o modo da saída do texto do InDesign. Escolha Texto clássico do Flash para gerar o texto para pesquisa que resulta no menor tamanho de arquivo. Escolha Converter em contornos para gerar o texto como uma série de linhas retas suaves, como converter texto em contornos. Escolha Converter em pixels para gerar o texto em uma imagem bitmap. O texto convertido em pixels pode aparecer irregular quando mais zoom for aplicado.

Rasterizar páginas

Esta opção converte todos os itens de página do InDesign em bitmap. A seleção dessa opção resulta em um arquivo SWF maior. Além disso, é possível que os itens de página sejam exibidos de forma irregular ao serem ampliados com zoom.

Nivelar transparência

Essa opção remove a transparência Live do SWF e preserva a aparência transparente. Entretanto, toda a interatividade é removida do arquivo SWF exportado se essa opção for selecionada.

Compactação

Escolha Automática para que o InDesign determine a melhor qualidade para imagens coloridas e em escala de cinza. Na maioria dos arquivos, essa opção produz resultados satisfatórios. Escolher JPEG (com perdas) é adequado para imagens em escala de cinza ou coloridas. A compactação JPEG apresenta perdas, ou seja, ela remove dados de imagem e possivelmente reduz sua qualidade. Porém, ela tenta reduzir o tamanho do arquivo com o mínimo de perda de informação. Como a compactação JPEG elimina dados, ela pode atingir tamanhos de arquivo muito menores. Escolher PNG (sem perda) exporta o arquivo sem perdas na compactação.

Observação:

Caso perceba perda de qualidade de imagem em imagens transparentes ao exportar para SWF, escolha PNG (sem perda) para melhorar a qualidade.

Qualidade JPEG

Especifica a quantidade de detalhes na imagem exportada. Quanto melhor a qualidade, maior será o tamanho do arquivo. Essa opção é esmaecida se você escolher PNG (sem perda) para compactação.

Resolução

Especifique a resolução de imagens bitmap no arquivo SWF exportado. Escolher uma resolução maior é importante para permitir que os visualizadores apliquem zoom no conteúdo com base em pixel dentro do arquivo SWF exportado. Escolher uma resolução maior pode aumentar de forma significante o tamanho do arquivo.

Criar arquivos FLA para a Web

Ao exportar um documento do InDesign para o formato de arquivo FLA, é possível abrir o arquivo no Adobe Flash® CS5 Professional para editar os conteúdos. Exportar para o formato FLA no InDesign CS5 substitui a exportação XFL no InDesign CS4. Use o ambiente de criação Flash para editar ou adicionar vídeo, áudio, animação e interatividade complexa.

Caso deseje exportar o documento do InDesign diretamente para um formato que pode ser aberto diretamente em um navegador da Web, use o formato SWF em vez do FLA. Consulte Criar arquivos SWF (Flash) interativos para a Web.

Exportação de FLA
Exportação de FLA

A. Documento no InDesign antes da exportação de FLA B. Arquivo FLA aberto no Flash Pro 
  1. Crie ou edite o documento do InDesign para prepará-lo para exportação em Flash. Para obter mais informações detalhadas sobre como configurar o documento para exportação, consulte Problemas ao exportar para Flash.

  2. Para exportar o documento para o formato FLA, escolha Arquivo > Exportar. Escolha Flash CS5 Professional (FLA) em Salvar Como Tipo (Windows) ou Formato (Mac OS) e clique em Salvar.

  3. Na caixa de diálogo Exportar Flash CS5 Professional (FLA), especifique as opções e, em seguida, clique em OK. Para obter informações sobre opções de exportação, consulte Opções de exportação de FLA.

  4. Abra o arquivo FLA exportado no Flash Professional.

Opções de exportação de FLA

As opções a seguir são exibidas na caixa de diálogo Exportar Flash CS5 Professional (FLA).

Exportação

Indique se a seleção atual, todas as páginas no documento ou o intervalo de página está incluído. Se você selecionar Intervalo, especifique um intervalo de página, por exemplo 1-7, 9 para imprimir páginas de 1 a 7 e 9. Consulte Especificar as páginas a serem impressas.

Rasterizar páginas

Esta opção converte todos os itens de página do InDesign em bitmap. Selecionar essa opção resulta em um arquivo FLA maior, e em itens da página irregulares quando mais zoom é aplicado.

Nivelar transparência

A seleção desta opção nivela todos os objetos com transparência. Talvez seja difícil animar os objetos nivelados no Adobe Flash Pro.

Tamanho (pixels)

Especifique se o arquivo FLA é dimensionado de acordo com uma porcentagem, ajustado a um tamanho de monitor determinado ou dimensionado de acordo com uma largura e uma altura determinadas.

Interatividade e mídia

Selecione Incluir tudo para permitir que filmes, sons, botões e animações sejam incluídos no arquivo FLA exportado. Caso o documento inclua um objeto de vários estados, ele é convertido em um símbolo de clipe de filme no qual cada estado é exibido em seu próprio quadro na linha do tempo.

Selecione Somente aparência para incluir o estado normal dos botões e os pôsteres de vídeo como elementos estáticos. Se Somente aparência for selecionado, as animações são exportadas conforme são exibidas no layout no momento da exportação. Somente aparência é selecionado se Mesclar transparência for escolhida.

Texto

Especifique o modo da saída do texto do InDesign. Escolha Texto Flash TLF para aproveitar o conjunto sofisticado de atributos da Estrutura de Layout do Texto do Flash Professional. Se essa opção for selecionada, escolha Inserir pontos de hifenização do dicionário para permitir a hifenização. Escolha Texto do Flash Classic para gerar um texto pesquisável que resulte em um tamanho de arquivo pequeno. Escolha Converter em contornos para gerar o texto como uma série de linhas retas suaves, como converter texto em contornos. Escolha Converter em pixels para gerar o texto em uma imagem bitmap. O texto convertido em pixels pode aparecer irregular quando mais zoom for aplicado.

Compactação

Escolha Automática para que o InDesign determine a melhor qualidade para imagens coloridas e em escala de cinza. Na maioria dos arquivos, essa opção produz resultados satisfatórios. Escolher JPEG (com perdas) é adequado para imagens em escala de cinza ou coloridas. A compactação JPEG apresenta perdas, ou seja, ela remove dados de imagem e possivelmente reduz sua qualidade. Porém, ela tenta reduzir o tamanho do arquivo com o mínimo de perda de informação. Como a compactação JPEG elimina dados, ela pode atingir tamanhos de arquivo muito menores. Escolher PNG (sem perda) exporta o arquivo sem perdas na compactação.

Qualidade JPEG

Especifica a quantidade de detalhes na imagem exportada. Quanto melhor a qualidade, maior será o tamanho do arquivo. Essa opção é esmaecida se você escolher PNG (sem perda) para compactação.

Resolução

Especifique a resolução de imagens bitmap no arquivo FLA exportado. Escolher uma alta resolução é especialmente importante para permitir que os usuários aumentem o zoom em um conteúdo baseado em pixels. Escolher uma resolução maior pode aumentar de forma significante o tamanho do arquivo.

Problemas de exportação para Flash

Considere os fatores a seguir ao projetar seu documento do InDesign para saída no formato SWF ou FLA.

Problemas de configuração de documento

Como as páginas do InDesign são convertidas

Quando você exporta para SWF ou FLA, as páginas espelhadas do InDesign tornam-se clipes separados em uma linha do tempo, como slides em uma apresentação de slides. Cada página espelhada é mapeada para um novo quadro chave. No Flash Player, para avançar pelas páginas espelhadas do documento exportado, pressione as teclas de direção ou clique nos botões interativos.

Observação:

Ao criar um documento planejado para a Web, escolha Web no menu Propósito da caixa de diálogo Novo documento.

Tamanho da página

Ao criar um documento, você pode escolher uma resolução específica, como 800 x 600, no menu Tamanho da página na caixa de diálogo Novo documento. Durante a exportação, você também pode ajustar a escala ou a resolução do arquivo SWF ou FLA exportado.

Recursos de interatividade

Botões, transições de página, hiperlinks, animações e arquivos de mídia podem ser incluídos em arquivos SWF e FLA exportados.

Botões

Para botões em um arquivo SWF ou FLA exportado, as ações Próxima página e Página anterior são controles especialmente úteis para reprodução no Flash Player. Entretanto, algumas ações que funcionam em arquivos PDF interativos não têm efeito no Flash Player. Quando escolher uma ação no painel Botões, não selecione uma opção na seção PDF apenas.

Observação:

É possível adicionar botões de navegação pré-formatados com as ações Ir para próxima página e Ir para página anterior. Escolha Botões de amostra no menu do painel Botões. Consulte Adicionar um botão do painel Botões de amostra.

Transições de página

Todas as transições de página funcionam bem no Flash Player. Além das transições de página exibidas quando a página é ativada, você pode incluir uma ondulação de página interativa durante a exportação que permite arrastar cantos de páginas para ativá-las.

Hiperlinks

Cria vínculos com sites ou com outras páginas do documento. Hiperlinks estão desfeitos em arquivos FLA.

Filmes e clipes de som

Filmes e clipes de som serão incluídos em um arquivo SWF exportado se estiverem em um formato compatível, como SWF, FLV, F4V e MP4 para filmes e MP3 para clipes de som.

Quando você exporta para FLA, somente a imagem de pôster é incluída no arquivo FLA. Os arquivos de mídia compatíveis aparecem em uma pasta de recursos salva no mesmo local do arquivo FLA exportado.

Problemas de conversão

Cor

Arquivos SWF e FLA usam cores RGB. Quando um documento é exportado para SWF ou FLA, o InDesign converte todos os espaços de cor (como CMYK e LAB) em sRGB. O InDesign converte as cores especiais em cores de escala RGB equivalentes.

Para evitar alterações de cor indesejadas na arte contendo texto com transparência, escolha Editar > Espaço de mistura de transparência > RGB do documento. Para evitar alterações de cor indesejadas em imagens com transparência, evite usar uma compactação com perdas durante a exportação.

Texto

Ao exportar para SWF ou FLA, você pode determinar se o texto é gerado como texto do Flash ou convertido em contornos ou pixels. O texto exportado como Texto do Flash Classic permanecerá totalmente editável quando o arquivo FLA for aberto no Adobe Flash CS5 Professional, podendo ser pesquisado em navegadores da Web quando for salvo como arquivo SWF.

Imagens

Ao exportar imagens para SWF ou FLA, você pode alterar as configurações de compactação de imagem, qualidade JPEG e resolução durante a exportação.

Quando imagens são exportadas para FLA, uma imagem inserida várias vezes no documento do InDesign é salva como um único ativo de imagem com um local compartilhado. Observe que um grande número de imagens vetoriais no documento do InDesign podem causar problemas de desempenho no arquivo exportado.

Para reduzir o tamanho do arquivo, insira as imagens repetidas nas páginas-mestre e evite copiar e colar imagens. Se a mesma imagem for inserida várias vezes no documento e não for transformada nem recortada, apenas uma cópia do arquivo será exportada no arquivo FLA. As imagens copiadas e coladas são tratadas como objetos separados.

Por padrão, um arquivo inserido do Illustrator é tratado como uma única imagem no arquivo FLA, ao passo que um arquivo do Illustrator copiado e colado gera vários objetos individuais. Para obter melhores resultados, insira a imagem do Illustrator como um arquivo PDF em vez de copiar e colar do Illustrator. O procedimento de cópia e colagem resulta em vários caminhos editáveis.

Observação:

Você pode alterar as opções de preferência para garantir que os objetos do Illustrator sejam colados como um único objeto, e não como um conjunto de pequenos vetores. No Illustrator, em preferências de Manuseio de arquivos e área de transferência, selecione PDF e desmarque AICB (sem suporte a transparência). No InDesign, em preferências de Tratamento da área de transferência, selecione Preferir PDF ao colar e Copiar PDF para a área de transferência.

Transparência

Antes de exportar para SWF, certifique-se de que não haja objetos transparentes sobrepondo algum elemento interativo, como botões ou hiperlinks. Se um objeto com transparência sobrepuser um elemento interativo, poderá haver perda de interatividade durante a exportação. É recomendável nivelar a transparência antes de exportar para FLA.

Em alguns casos, a escolha de uma compactação com perdas reduz a qualidade de imagens com transparência. Ao exportar, escolha PNG (sem perdas) para melhorar a qualidade.

Atributos de 3D

Não há suporte para atributos de 3D em arquivos SWF e FLA exportados.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online