Výukové video: Propojené inteligentní objekty

Výukové video: Propojené inteligentní objekty
Infinite Skills

Vysvětlení inteligentních objektů

Inteligentní objekty jsou vrstvy, které obsahují obrazová data z rastrových nebo vektorových obrazů, například ze souborů aplikace Photoshop nebo Illustrator. Inteligentní objekty zachovávají zdrojový obsah obrazu se všemi původními charakteristikami a umožňují provádět nedestruktivní úpravy vrstvy.

V aplikacích Photoshop CC a CS6 můžete vložit obsah obrazu do dokumentu aplikace Photoshop. V aplikaci Photoshop CC můžete také vytvořit propojené inteligentní objekty, jejichž obsah je odkazován z externích obrazových souborů. Obsah propojeného inteligentního objektu se aktualizuje, když se změní jeho zdrojový obrazový soubor.

Propojené inteligentní objekty se liší od duplikovaných instancí inteligentního objektu v dokumentu aplikace Photoshop. Pomocí propojených inteligentních objektů můžete jeden sdílený zdrojový soubor používat ve více dokumentech Photoshop. Tuto možnost určitě uvítají například webdesignéři.

Výhody inteligentních objektů

S použitím inteligentních objektů můžete:

  • Provádět nedestruktivní transformace. Můžete měnit velikost, otáčet, provádět zkosení, deformovat, perspektivně transformovat nebo deformovat vrstvu bez ztráty původních obrazových dat nebo kvality, protože transformace neovlivňuje originální data.

  • Pracovat s vektorovými daty, například vektorovými kresbami z aplikace Illustrator, která by se jinak v aplikaci Photoshop rastrovala.

  • Provádět nedestruktivní filtrování. Filtry aplikované na inteligentní objekty můžete kdykoliv upravit.

  • Upravit jeden inteligentní objekt a automaticky aktualizovat všechny jeho propojené instance.

  • Použít masku vrstvy, která buď je, nebo není propojena s vrstvou inteligentního objektu.

  • Vyzkoušet různé návrhy se zástupnými obrazy s nízkým rozlišením, které později nahradíte finálními verzemi.

Nemůžete provádět operace, které mění data obrazových bodů – například malování, zesvětlení, ztmavení nebo klonování – přímo ve vrstvě inteligentního objektu, pokud nebyla nejdříve převedena na normální vrstvu, která se bude rastrovat. Chcete-li provést operace, které mění data obrazových bodů, můžete upravit obsah inteligentního objektu, klonovat novou vrstvu nad vrstvu inteligentního objektu, upravit duplikáty inteligentního objektu nebo vytvořit novou vrstvu.

Poznámka:

Když transformujete inteligentní objekt, na který byl aplikován inteligentní filtr, Photoshop efekt filtru během provádění transformace vypne. Efekty filtru se aplikují znovu po dokončení transformace. Viz Aplikování inteligentních filtrů.

Photoshop: Výhody inteligentních objektů
Normální vrstva a inteligentní objekt v panelu Vrstvy. Ikona v levém dolním rohu miniatury označuje inteligentní objekt.

Photoshop: Inteligentní objekt v panelu Vrstvy
Propojený inteligentní objekt v panelu Vrstvy (Photoshop CC)

Vytvoření vložených inteligentních objektů

Vložené inteligentní objekty je možné vytvářet několika metodami: příkazem Otevřít jako inteligentní objekt, umístěním souboru (CS6) nebo umístěním souboru jako vloženého (CC, CS6), vložením dat z aplikace Illustrator nebo převodem jedné nebo více vrstev aplikace Photoshop na inteligentní objekty.

  1. Proveďte libovolný z následujících úkonů:
    • (CC) Vyberte možnost Soubor > Umístit vložený, chcete-li importovat soubory jako inteligentní objekty do otevřeného dokumentu aplikace Photoshop.
    • Vyberte možnost Soubor > Otevřít jako inteligentní objekt, vyberte soubor a klikněte na tlačítko Otevřít.
    • (CS6) Vyberte možnost Soubor > Umístit, chcete-li importovat soubory jako inteligentní objekty do otevřeného dokumentu aplikace Photoshop.

    Poznámka:

    Přestože je možné umísťovat soubory JPEG, je lepší umístit soubory PSD, TIFF nebo PSB, protože pak můžete přidat vrstvy, změnit obrazové body a soubor znovu uložit bez ztráty dat. (Uložení upraveného souboru JPEG vyžaduje sloučení nových vrstev a novou kompresi obrazu, což sníží kvalitu obrazu.)

    • Vyberte možnost Vrstva > Inteligentní objekt > Převést na inteligentní objekt, čímž převedete vybranou vrstvu na inteligentní objekt.
    • V aplikaci Bridge vyberte možnost Soubor > Umístit > Do Photoshopu, chcete-li soubor importovat jako inteligentní objekt do otevřeného dokumentu aplikace Photoshop.

    Poznámka:

    Snadný způsob jak pracovat se soubory Camera Raw je otevřít je jako inteligentní objekty. Můžete kdykoliv poklikat na vrstvu inteligentního objektu, která obsahuje soubor Camera Raw, a upravit nastavení modulu Camera Raw.

    Podívejte se na video Otevření obrázku jako inteligentního objektu.

    • Vyberte jednu nebo více vrstev a zvolte Vrstva > Inteligentní objekty > Převést na inteligentní objekt. Vrstvy se seskupí do jednoho inteligentního objektu.

    • Přetáhněte vrstvy nebo objekty z PDF nebo aplikace Adobe Illustrator do dokumentu aplikace Photoshop.

    • Vložte kresbu z aplikace Illustrator do dokumentu aplikace Photoshop a v dialogovém okně Vložit zvolte Inteligentní objekt. Chcete-li dosáhnout co největší pružnosti, v sekci Zpracování souborů a Schránka v dialogovém okně Předvolby v aplikaci Adobe Illustrator zapněte obě volby, PDF i AICB (bez podpory průhlednosti).

Vytváření propojených inteligentních objektů | Photoshop CC

Poznámka:

Funkce propojeného inteligentního objektu je k dispozici ve verzích aplikace Photoshop 14.2 (Photoshop CC | Leden 2014) a novějších.

V aplikaci Photoshop CC je možné vytvářet propojené inteligentní objekty. Obsah propojených inteligentních objektů se aktualizuje, když se změní zdrojový obrazový soubor. Propojené inteligentní objekty jsou obzvlášť užitečné pro týmy nebo v případech, kdy je nutné opakovaně používat datové zdroje ve více návrzích.

Propojený inteligentní objekt vytvoříte tímto postupem:

  1. Vyberte možnost Soubor > Umístit propojený.
  2. Vyberte příslušný soubor a klikněte na tlačítko Umístit.

Vytvoří se propojený inteligentní objekt a zobrazí se na panelu Vrstvy s ikonou propojení ().

Poznámka:

Propojený inteligentní objekt můžete v otevřeném dokumentu vytvořit i tak, že podržíte následující klávesu a potom přetáhnete požadovaný soubor:

(Windows) klávesa Alt
(Mac) klávesa Option/Alt

Chcete-li změnit výchozí chování, vypněte volbu Předvolby > Všeobecné > Při umísťování vždy vytvářet inteligentní objekty.

Snižování velikosti souborů použitím propojených inteligentních objektů

Protože propojené inteligentní objekty nevkládají do aktuálního dokumentu zdrojový soubor, ale udržují závislost na externím souboru, často vznikají významně menší soubory. Přestože propojené inteligentní objekty neuchovávají v aktuálním dokumentu původní soubor, uchovávají verzi obrazových dat z původního souboru sloučenou do jedné vrstvy a se změněným měřítkem. V některých případech může být objem těchto dat mnohem větší než objem původního souboru, takže se úspora velikosti souboru jeví jako zanedbatelná.

Aktualizace propojených inteligentních objektů

Pokud se změní externí zdrojový soubor, když je dokument, který na něj odkazuje, otevřený, příslušný propojený inteligentní objekt se automaticky aktualizuje. Když ale otevřete dokument aplikace Photoshop, který obsahuje nesynchronizované propojené inteligentní objekty, můžete tyto inteligentní objekty aktualizovat:

  • Klikněte pravým tlačítkem na vrstvu propojeného inteligentního objektu a vyberte Aktualizovat změněný obsah.
  • Klikněte na Vrstva > Inteligentní objekty > Aktualizovat změněný obsah.

Propojené inteligentní objekty, jejichž zdrojové obrazy se změnily, se opticky zvýrazní na panelu Vrstvy:

Photoshop: Nesynchronizované propojené inteligentní objekty zvýrazněné na panelu Vrstvy
Nesynchronizované propojené inteligentní objekty jsou na panelu Vrstvy zvýrazněné.

Poznámka:

Všechny propojené inteligentní objekty v aktuálním dokumentu Photoshop můžete aktualizovat kliknutím na Vrstva > Inteligentní objekty > Aktualizovat všechen změněný obsah.

Photoshop: Propojené inteligentní objekty s chybějícími externími zdrojovými soubory zvýrazněné na panelu Vrstvy
Propojené inteligentní objekty s chybějícími externími zdrojovými soubory zvýrazněné na panelu Vrstvy.

Poznámka:

Aplikace Photoshop během zjišťování změn propojených inteligentních objektů nebo aktualizace propojeného inteligentního objektu sleduje pouze bezprostředně připojený soubor. Propojení vnořená uvnitř inteligentních objektů se neaktualizují.

Řešení neplatné vazby inteligentního objektu

Chcete-li vyřešit propojený inteligentní objekt s chybějícím externím zdrojem, postupujte takto:

  1. Klikněte pravým tlačítkem na ikonu vrstvy propojeného inteligentního objektu a vyberte Vyřešit neplatnou vazbu.
  2. Přejděte do nového umístění chybějícího objektu.
  3. Klikněte na položku Umístit.

Zobrazení vlastností propojeného inteligentního objektu

Na panelu Vrstvy vyberte vrstvu propojeného inteligentního objektu a klikněte na Okna > Vlastnosti.

Zobrazí se tyto vlastnosti:

  • Cesta externího zdrojového souboru pro propojený inteligentní objekt
  • Velikost a souřadnice polohy propojeného inteligentního objektu (X, Y)

Přímo na panelu Vlastnosti můžete provést tyto akce:

  • Upravit obsah externího obrazového souboru. Pokud je to nezbytné, aplikace Photoshop spustí externí aplikaci, která se zdrojovým obrazovým souborem může pracovat. Aplikace Photoshop například spustí Adobe Illustrator, pokud je externím zdrojovým obrazem soubor .ai.
  • Vložit propojený inteligentní objekt do aktuálního dokumentu.

Vložení propojených inteligentních objektů

Proveďte jeden z následujících úkonů:

  • Na panelu Vrstvy klikněte pravým tlačítkem na vrstvu propojeného inteligentního objektu a vyberte Vložit propojený.
  • Zvolte Vrstva > Inteligentní objekty > Vložit propojený.
  • Na panelu Vlastnosti klikněte na tlačítko Vložit.

Poznámka:

Výběrem volby Vrstva > Inteligentní objekty > Vložit všechny propojené vložíte do daného dokumentu Photoshop všechny propojené inteligentní objekty.

Sbalení propojených inteligentních objektů

Propojené inteligentní objekty v dokumentu aplikace Photoshop je možné sbalit tak, aby se jejich zdrojové soubory uložily do složky v počítači. Do této složky se spolu se zdrojovými soubory uloží kopie dokumentu aplikace Photoshop.

  1. Zvolte Soubor > Balíček.
  2. Vyberte umístění, kam chcete vložit zdrojové soubory a kopii dokumentu aplikace Photoshop.

Sbalí se i případné propojené inteligentní objekty zvuku nebo videa v dokumentu.

Poznámka:

Před sbalením propojených inteligentních objektů je nutné uložit soubor, který je obsahuje.

Jak aplikace Photoshop vyhledává propojené soubory

Photoshop vždy hledá propojené soubory v posledním známém relativním umístění. Pokud propojený soubor v tomto umístění nenajde, hledá ho:

  • v posledním známém absolutním umístění,
  • pomocí uloženého aliasu (pouze na Macu),
  • ve složce, která obsahuje nadřazený dokument.

Toto chování umožňuje přesouvat, kopírovat a sdílet složky a soubory projektů s minimálním rizikem výskytu neplatných vazeb.

Poznámka:

V dialogu pro řešení chybějících datových zdrojů se vždy zobrazí poslední známá absolutní cesta k chybějícím zdrojovým souborům.

Převod vloženého inteligentního objektu na propojený inteligentní objekt

Vložený inteligentní objekt lze převést na propojený inteligentní objekt. Transformace, filtry a další efekty aplikované na vložený inteligentní objekt zůstávají po převodu zachovány.

Postupujte takto:

  1. Vyberte v dokumentu aplikace Photoshop vrstvu vloženého inteligentního objektu.
  2. Zvolte Vrstva > Inteligentní objekt > Převést na propojené.
  3. Vyberte v počítači umístění, kam chcete uložit zdrojový soubor. Zadejte název souboru včetně podporované přípony, například vazba_soubor.jpg.

Filtrování panelu Vrstvy podle inteligentních objektů | Photoshop CC

  1. V rozbalovací nabídce filtrování na panelu Vrstvy vyberte Inteligentní objekt.
Photoshop: Filtrování vrstev podle inteligentních objektů
Filtrování vrstev podle inteligentních objektů

  1. Klikněte na jednu z následujících ikon:
  •     Filtr pro aktuální propojené inteligentní objekty
  •     Filtr pro nesynchronizované propojené inteligentní objekty
  •     Filtr pro chybějící propojené inteligentní objekty
  •     Filtr pro vložené inteligentní objekty

Poznámka:

Filtrování vrstev lze vypnout pomocí přepínače ().

Duplikování vloženého inteligentního objektu

  1. Na panelu Vrstvy vyberte vrstvu inteligentního objektu a proveďte jeden z následujících úkonů:
    • Chcete-li vytvořit duplikát inteligentního objektu, který bude svázaný s originálem, zvolte Vrstva > Nová > Vrstva kopírováním, nebo přetáhněte vrstvu inteligentního objektu na ikonu Vytvořit novou vrstvu dole v panelu Vrstvy. Úpravy, které provedete v originálu, ovlivní kopii a naopak.

    • Chcete-li vytvořit duplikát automatického objektu, který nebude svázaný s originálem, zvolte Vrstva > Inteligentní objekty > Nový inteligentní objekt kopírováním. Úpravy, které provedete v originálu, neovlivní tuto kopii.

    Na panelu Vrstvy se objeví nový inteligentní objekt se stejným názvem jako originál a s příponou „kopie“.

Úpravy obsahu inteligentního objektu

Když upravíte inteligentní objekt, zdrojový obsah se otevře buď v aplikaci Photoshop (pokud jsou obsahem rastrová data nebo soubor Camera Raw), nebo ve výchozí aplikaci pro zpracování umístěného formátu (například Adobe Illustrator nebo Adobe Acrobat). Když uložíte změny zdrojového obsahu, úpravy se projeví ve všech propojených instancích inteligentního objektu v dokumentu aplikace Photoshop.

  1. Vyberte inteligentní objekt v panelu Vrstvy a proveďte jeden z následujících úkonů:
    • Zvolte Vrstva > Inteligentní objekty > Upravit obsah.
    • Dvakrát klikněte na miniaturu inteligentního objektu na panelu Vrstvy.
    • Na panelu Vlastnosti klikněte na tlačítko Upravit obsah.
  2. Kliknutím na tlačítko OK dialogové okno zavřete.
  3. Proveďte úpravy zdrojového souboru obsahu, pak zvolte Soubor > Uložit.

    Photoshop aktualizuje inteligentní objekt, aby se projevily provedené změny. (Pokud změny nevidíte, přepněte zobrazení na dokument Photoshop, který obsahuje daný inteligentní objekt.)

Nahrazení obsahu inteligentního objektu

Můžete nahradit obrazová data v jednom inteligentním objektu nebo ve více navázaných instancích. Tato funkce umožňuje rychlou aktualizaci vizuálního návrhu nebo nahrazení zástupných obrazů s nízkým rozlišením finálními verzemi.

Poznámka:

Když nahradíte inteligentní objekt, všechny změny velikosti, pokřivení nebo efekty, které jste použili na první inteligentní objekt, se zachovají.

  1. Vyberte inteligentní objekt a zvolte Vrstva > Inteligentní objekty > Nahradit obsah.
  2. Najděte soubor, který chcete použít, a klikněte na Umístit.
  3. Klikněte na tlačítko OK.

    Do inteligentního objektu se umístí nový obsah.

Převedení vloženého nebo propojeného inteligentního obsahu na vrstvu

Při převedení inteligentního objektu na normální vrstvu se obsah rastruje ve své současné velikosti. Inteligentní objekt převeďte na normální vrstvu pouze v případě, že už nepotřebujete data inteligentního objektu upravovat. Transformace, pokřivení a filtry aplikované na inteligentní objekt již nebude možné upravit, až bude inteligentní objekt rastrovaný.

  • Vyberte inteligentní objekt a vyberte možnost Vrstva > Inteligentní objekty > Rastrovat.  

Poznámka:

Pokud pak chcete znovu vytvořit inteligentní objekt, vyberte znovu jeho původní vrstvy a začněte od začátku. Pro nový inteligentní objekt se nezachovají transformace, které jste aplikovali na původní inteligentní objekt.

Export obsahu vloženého inteligentního objektu

  1. Na panelu Vrstvy vyberte inteligentní objekt a vyberte možnost Vrstva > Inteligentní objekty > Exportovat obsah.
  2. Zvolte umístění pro obsah inteligentního objektu a pak klikněte na Uložit.

    Photoshop exportuje inteligentní objekt v původním formátu, ve kterém byl umístěn (JPEG, AI, TIF, PDF nebo jiné formáty). Pokud jste inteligentní objekt vytvořili z vrstev, exportuje se ve formátu PSB.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online