사용 안내서 취소

Animate에서 클래식 트윈 애니메이션을 사용하여 작업하는 방법

  1. Adobe Animate 사용 안내서
  2. Animate 소개
    1. Animate의 새로운 기능
    2. 시각적 용어집
    3. Animate 시스템 요구 사항
    4. Animate 키보드 단축키
    5. Animate에서 여러 파일 유형을 사용하여 작업하기
  3. 애니메이션
    1. Animate의 애니메이션 기본 사항
    2. Animate에서 프레임 및 키프레임을 사용하는 방법
    3. Animate의 프레임별 애니메이션
    4. Animate에서 클래식 트윈 애니메이션으로 작업하는 방법
    5. 브러시 도구
    6. 모션 안내선
    7. 모션 트윈 및 ActionScript 3.0
    8. 모션 트윈 애니메이션 정보
    9. 모션 트윈 애니메이션
    10. 모션 트윈 애니메이션 만들기
    11. 속성 키프레임 사용
    12. 트윈으로 위치에 애니메이션 적용
    13. 모션 편집기를 사용하여 모션 트윈을 편집하는 방법
    14. 트윈 애니메이션의 모션 경로 편집
    15. 모션 트윈 조작
    16. 사용자 정의 속도 추가
    17. 모션 사전 설정 만들기 및 적용
    18. 애니메이션 트윈 범위 설정
    19. XML 파일로 저장한 모션 트윈을 사용한 작업
    20. 모션 트윈과 클래식 트윈의 비교
    21. 모양 트윈 만들기
    22. Animate에서 뼈 도구 애니메이션 사용하기
    23. Animate에서 캐릭터 리깅으로 작업하기
    24. Adobe Animate에서 마스크 레이어를 사용하는 방법
    25. Animate에서 장면으로 작업하는 방법
  4. 대화형 기능
    1. Animate로 버튼을 만드는 방법
    2. Animate 프로젝트를 다른 문서 유형 포맷으로 변환
    3. Animate에서 HTML5 Canvas 문서를 만들고 게시하기
    4. Animate에서 코드 조각을 사용하여 대화형 기능 추가하기
    5. 사용자 정의 HTML5 구성 요소 만들기
    6. HTML5 Canvas의 구성 요소 사용
    7. 사용자 정의 구성 요소 만들기: 예제
    8. 사용자 정의 구성 요소의 코드 조각
    9. 모범 사례 - Animate를 사용한 광고
    10. 가상 현실 제작 및 게시
  5. 작업 영역 및 작업 과정
    1. 칠 브러시 만들기 및 관리
    2. HTML5 Canvas 문서에서 Google Fonts 사용
    3. Creative Cloud 라이브러리와 Adobe Animate 사용
    4. Animate의 스테이지 및 도구 패널 사용
    5. Animate 작업 과정 및 작업 영역
    6. HTML5 Canvas 문서에서 웹 글꼴 사용
    7. 타임라인과 ActionScript
    8. 여러 타임라인을 사용한 작업
    9. 환경 설정
    10. Animate 제작 패널 사용
    11. Animate로 타임라인 레이어 만들기
    12. 모바일 앱 및 게임 엔진용으로 애니메이션 내보내기
    13. 객체 이동 및 복사
    14. 템플릿
    15. Animate의 찾기 및 바꾸기
    16. 실행 취소, 다시 실행 및 작업 내역 패널
    17. 키보드 단축키
    18. Animate에서 타임라인을 사용하는 방법
    19. HTML 확장 만들기
    20. 이미지 및 애니메이션 GIF에 대한 최적화 옵션
    21. 이미지 및 GIF에 대한 내보내기 설정
    22. Animate의 에셋 패널
  6. 멀티미디어 및 비디오
    1. Animate의 그래픽 객체 변형 및 결합
    2. Animate에서 심볼 인스턴스를 만들고 작업하기
    3. 이미지 추적
    4. Adobe Animate에서 사운드를 사용하는 방법
    5. SVG 파일 내보내기
    6. Animate에서 사용할 비디오 파일 만들기
    7. Animate에서 비디오를 추가하는 방법
    8. 비디오 큐 포인트를 사용한 작업
    9. Animate로 객체 그리고 만들기
    10. 선 및 모양 변형
    11. Animate CC의 획, 채우기 및 그래디언트
    12. Adobe Premiere Pro 및 After Effects 작업
    13. Animate CC의 색상 패널
    14. Animate에서 Flash CS6 파일 열기
    15. Animate의 클래식 텍스트 작업
    16. Animate에 아트워크 가져오기
    17. Animate의 가져온 비트맵
    18. 3D 그래픽
    19. Animate의 심볼 작업
    20. Adobe Animate로 선 및 모양 그리기
    21. Animate의 라이브러리 작업
    22. 사운드 내보내기
    23. Animate CC의 객체 선택
    24. Animate의 Illustrator AI 파일 작업
    25. 스프레이 브러시 도구로 패턴 적용하기
    26. 블렌드 모드 적용
    27. 객체 배열
    28. 명령 메뉴를 사용한 작업 자동화
    29. 다국어 텍스트
    30. Animate에서 카메라 사용하기
    31. Animate를 Adobe Scout와 함께 사용하기
    32. Fireworks 파일 작업
    33. 그래픽 필터
    34. 사운드 및 ActionScript
    35. 드로잉 환경 설정
    36. 펜 도구로 그리기
  7. 플랫폼
    1. Animate 프로젝트를 다른 문서 유형 포맷으로 변환
    2. 사용자 정의 플랫폼 지원
    3. Animate에서 HTML5 Canvas 문서 만들고 게시하기
    4. WebGL 문서 만들고 게시하기
    5. iOS용 AIR에 맞추어 애플리케이션을 패키징하는 방법
    6. Android용 AIR 애플리케이션 게시
    7. 데스크톱용 Adobe AIR에 맞춘 게시
    8. ActionScript 게시 설정
    9. 모범 사례 - 애플리케이션에서 ActionScript 구성
    10. Animate에서 ActionScript를 사용하는 방법
    11. 모범 사례 - 액세스 가능성 지침
    12. Animate 작업 영역의 액세스 가능성
    13. 스크립트 작성 및 관리
    14. 사용자 정의 플랫폼에 대한 지원 활성화
    15. 사용자 정의 플랫폼 지원 개요
    16. 액세스 가능한 콘텐츠 만들기
    17. 사용자 정의 플랫폼 지원 플러그인 작업
    18. ActionScript 3.0 디버깅
    19. 사용자 정의 플랫폼에 대한 지원 활성화
  8. 내보내기 및 게시
    1. Animate CC에서 파일을 내보내는 방법
    2. OAM 게시
    3. SVG 파일 내보내기
    4. Animate를 사용하여 그래픽 및 비디오 내보내기
    5. AS3 문서 게시
    6. 모바일 앱 및 게임 엔진용으로 애니메이션 내보내기
    7. 사운드 내보내기
    8. QuickTime 비디오 파일 내보내기
    9. ActionScript로 외부 비디오 재생 제어하기
    10. 모범 사례 - 모바일 장치 콘텐츠 만들기 팁
    11. 모범 사례 - 비디오 규칙
    12. 모범 사례 - SWF 애플리케이션 제작 지침
    13. 모범 사례 - FLA 파일 구조화
    14. Animate용 FLA 파일을 최적화하는 모범 사례
    15. ActionScript 게시 설정
    16. Animate용 게시 설정 지정
    17. 프로젝터 파일 내보내기
    18. 이미지 및 애니메이션 GIF 내보내기
    19. HTML 게시 템플릿
    20. Adobe Premiere Pro 및 After Effects 작업
    21. 애니메이션의 빠른 공유 및 게시

클래식 트윈은 Animate에서 애니메이션을 만드는 오래된 방법입니다. 클래식 트윈은 새로운 모션 트윈과 비슷하지만 만들기에 좀 더 복잡하고 좀 덜 유연합니다. 하지만 클래식 트윈은 모션 트윈과 달리 애니메이션을 제어할 수 있는 몇 가지 유형의 기능을 제공합니다. 대부분의 사용자는 새로운 모션 트윈을 사용하여 작업하는 것을 선호하겠지만, 일부는 여전히 클래식 트윈을 사용하기를 원할 수 있습니다. 차이에 대한 자세한 내용은 모션 트윈과 클래식 트윈의 차이를 참조하십시오.

시작하기 전에:

클래식 트윈을 사용하여 작업하기 전에 다음 사항을 염두에 두십시오.

  • 클래식 트윈은 Animate에서 트위닝된 애니메이션을 만드는 오래된 방법입니다. 좀 더 새롭고 쉬운 방법은 모션 트윈을 사용하는 것입니다. 모션 트윈 애니메이션을 참조하십시오.

  • 클래식 트윈으로 3D 속성을 트위닝할 수는 없습니다.

클래식 트윈 애니메이션의 샘플은 Animate 샘플 페이지(www.adobe.com/go/learn_fl_samples_kr)를 참조하십시오. 다음과 같은 샘플을 사용할 수 있습니다.

  • 그림자 애니메이션: 샘플 ZIP 파일을 다운로드하여 압축을 풀고 Graphics\AnimatedDropShadow 폴더로 이동한 다음 샘플에 액세스하십시오.

  • 애니메이션 및 그래디언트: 샘플 ZIP 파일을 다운로드하여 압축을 풀고 Graphics\AnimationAndGradients 폴더로 이동한 다음 샘플에 액세스하십시오.

 Animate의 요소 대부분과 마찬가지로 애니메이션에는 ActionScript가 필요하지 않습니다. 하지만 원하는 경우에는 ActionScript를 사용하여 애니메이션을 만들 수 있습니다.

클래식 트윈 애니메이션에 대한 키프레임 만들기 및 편집

클래식 트윈 애니메이션의 변경 사항은 키프레임에서 정의됩니다. 트위닝된 애니메이션에서 애니메이션의 중요한 지점에 키프레임을 정의하면 Animate가 그 사이의 프레임 내용을 만듭니다. 트위닝된 애니메이션에 삽입된 프레임은 키프레임 사이에 화살표가 그려진 연한 파란색으로 표시됩니다. Animate 문서에서는 각 키프레임에 모양이 저장되므로 아트워크에서 변경 사항이 있는 지점에만 키프레임을 만드십시오.

키프레임은 타임라인에 구분되어 표시됩니다. 즉, 색이 칠해진 원은 내용이 있는 키프레임을 나타내고 프레임 앞에 빈 원이 있으면 빈 키프레임을 나타냅니다. 같은 레이어에 추가된 후속 프레임의 내용은 키프레임의 내용과 같습니다.

키프레임만 클래식 트윈에서 편집할 수 있습니다. 트위닝된 프레임은 볼 수 있지만 직접 편집할 수는 없습니다. 트위닝된 프레임을 편집하려면 정의 키프레임 하나를 변경하거나 시작 키프레임과 끝 키프레임 사이에 새 키프레임을 삽입합니다. [라이브러리] 패널에서 스테이지로 항목을 드래그하여 현재 키프레임에 항목을 추가합니다.

두 개 이상의 프레임을 동시에 표시 및 편집하려면 어니언 스키닝 사용을 참조하십시오.

 이 항목에서는 예전 방식인 클래식 트윈에 대한 키프레임을 만드는 방법을 설명합니다. 새로운 모션 트윈의 속성 키프레임에 대해서는 트윈 애니메이션 만들기를 참조하십시오.

키프레임 만들기

  1. 다음 중 하나를 수행합니다.
    • 타임라인에서 프레임을 선택하고 삽입 > 타임라인 > 키프레임을 선택합니다.

    • 타임라인의 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)한 다음 [키프레임 삽입]을 선택합니다.

타임라인에 프레임 삽입

  • 새 프레임을 삽입하려면 삽입 > 타임라인 > 프레임을 선택합니다.

  • 키프레임을 만들려면 삽입 > 타임라인 > 키프레임을 선택하거나 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하여 키프레임을 배치합니다. 키프레임 삽입을 선택합니다.

  • 빈 키프레임을 만들려면 삽입 > 타임라인 > 빈 키프레임을 선택하거나 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하여 키프레임을 배치합니다. 빈 키프레임 삽입을 선택합니다.

프레임/키프레임 삭제 또는 수정

  • 프레임, 키프레임 또는 프레임 시퀀스를 삭제하려면 해당 항목을 선택하고 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)한 다음 [프레임 제거]를 선택합니다. 주변의 프레임은 변경되지 않습니다.

  • 키프레임이나 프레임 시퀀스 및 해당 내용을 이동하려면 해당 항목을 선택한 다음 원하는 위치로 드래그합니다.

  • 키프레임의 지속 기간을 연장하려면 Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 키프레임을 새로운 시퀀스의 마지막 프레임으로 드래그합니다.

  • 프레임 또는 프레임 시퀀스를 복사하여 붙여넣으려면 해당 항목을 선택하고 편집 > 타임라인 > 프레임 복사를 선택합니다. 그런 다음 프레임 또는 시퀀스를 선택하고 편집 > 타임라인 > 프레임 붙여넣기를 선택합니다. 복사한 프레임의 정확한 수를 대상 타임라인에 붙여넣고 대체하려면 프레임 붙여넣기 및 덮어쓰기 옵션을 사용합니다.

  • 키프레임을 프레임으로 변환하려면 키프레임을 선택하고 수정 > 타임라인 > 키프레임 지우기를 선택합니다. 또는 키프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)한 다음 키프레임 지우기를 선택합니다. 지운 키프레임과 다음 키프레임까지의 모든 프레임은 지운 키프레임 앞에 있는 프레임의 내용으로 바뀝니다.

  • 드래그하여 키프레임이나 프레임 시퀀스를 복사하려면 해당 항목을 선택한 다음 Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 새로운 위치로 드래그합니다.

  • 트위닝된 시퀀스의 길이를 바꾸려면 시작 또는 끝 키프레임을 왼쪽이나 오른쪽으로 드래그합니다.

  • 현재 키프레임에 라이브러리 항목을 추가하려면 [라이브러리] 패널에서 스테이지로 항목을 드래그합니다.

  • 애니메이션 시퀀스의 순서를 반대로 하려면 하나 이상의 레이어에서 해당 프레임을 선택하고 수정 > 타임라인 > 프레임 반전을 선택합니다. 키프레임은 시퀀스의 시작과 끝에 있어야 합니다.

인스턴스, 그룹 또는 텍스트에 클래식 트윈 애니메이션 추가

 이 항목에서는 예전 방식인 클래식 트윈을 만드는 방법을 설명합니다. 새로운 모션 트윈을 만드는 방법에 대해서는 트윈 애니메이션 만들기를 참조하십시오.

인스턴스, 그룹 및 유형의 속성에서 변경 사항을 트위닝하려면 클래식 트윈을 사용할 수 있습니다. Animate는 인스턴스, 그룹 및 유형의 위치, 크기, 회전, 기울이기를 트위닝할 수 있습니다. 또한 Animate는 단계적인 색상 변화 효과를 만들거나 인스턴스에 페이드 인 또는 페이드 아웃 효과를 적용하여 인스턴스 및 유형의 색상을 트위닝할 수 있습니다.

그룹 또는 유형의 색상을 트위닝하기 전에 해당 항목을 심볼로 만들고, 텍스트 블록의 각 문자에 개별적으로 애니메이션 효과를 적용하기 전에 각 문자를 별도의 텍스트 블록에 배치하십시오.

클래식 트윈을 변경하고 두 키프레임 사이의 프레임 수를 변경하면 프레임이 자동으로 다시 트위닝됩니다. 또는 두 키프레임 중 하나에서 그룹 또는 심볼을 이동하면 프레임이 자동으로 다시 트위닝됩니다.

 

클래식 트윈 애니메이션 만들기

  1. 레이어를 활성 레이어로 만들려면 레이어 이름을 클릭하고 레이어에서 빈 키프레임을 선택하여 시작합니다. 이 빈 프레임이 클래식 트윈의 첫 프레임입니다.

  2. 클래식 트윈의 첫 프레임에 내용을 추가하려면 다음 중 하나를 수행합니다.
    • [펜], [타원형], [사각형], [연필] 또는 [브러시] 툴을 사용하여 그래픽 객체를 만든 다음 심볼로 변환합니다.

    • 스테이지에서 인스턴스, 그룹 또는 텍스트 블록을 만듭니다.

    • [라이브러리] 패널에서 심볼의 인스턴스를 드래그합니다.

     트윈을 만들려면 레이어에 항목이 하나만 있어야 합니다.

  3. 애니메이션을 끝낼 두 번째 키프레임을 만들고 새로운 키프레임은 선택한 채로 둡니다.
  4. 끝 프레임에 있는 항목을 수정하려면 다음 중 하나를 수행합니다.
    • 항목을 새 위치로 이동합니다.

    • 항목의 크기, 회전 또는 기울이기를 수정합니다.

    • 항목의 색상을 수정합니다(인스턴스 또는 텍스트 블록만 해당). 인스턴스 또는 텍스트 블록이 아닌 요소의 색상을 트위닝하려면 모양 트위닝을 사용합니다.

  5. 클래식 트윈을 만들려면 다음 중 하나를 수행합니다.
    • 트윈의 프레임 범위에서 원하는 프레임을 클릭하고 삽입 > 클래식 트윈을 선택합니다.

    • 트윈의 프레임 범위에서 원하는 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 [클래식 트윈 만들기]를 선택합니다.

    2단계에서 그래픽 객체를 만든 경우 Animate는 자동으로 객체를 심볼로 변환하고 tween1이라는 이름을 지정합니다.

  6. 선택한 항목의 크기를 트위닝하려면 속성 관리자의 [트위닝] 섹션에서 [크기 조절]을 선택합니다. 이렇게 하려면 먼저 4단계에서 항목의 크기를 수정해야 합니다.

  7. 모션을 보다 사실적으로 표현하려면 클래식 트윈에 부드럽게를 적용합니다. 클래식 트윈에 부드럽게를 적용하려면 속성 관리자의 [트위닝] 섹션에서 [부드럽게] 필드를 사용합니다. 사용자 정의 부드럽게 대화 상자에서 클래식 트윈의 속도를 보다 정확하게 제어할 수 있습니다.

    트위닝된 프레임 사이의 변경 속도를 조정하려면 [부드럽게] 필드에서 값을 드래그하거나 값을 입력합니다.

    • 클래식 트윈을 느리게 시작하여 애니메이션 끝으로 갈수록 트위닝 속도를 높이려면 -1과 -100 사이의 음수 값을 입력합니다.

    • 클래식 트윈을 빠르게 시작하여 애니메이션 끝으로 갈수록 트위닝 속도를 늦추려면 1과 100 사이의 양수 값을 입력합니다.

    • 트윈의 프레임 범위 내에서 더 복잡한 변경 속도를 생성하려면 [부드럽게] 필드 옆의 [편집] 버튼을 클릭합니다. 사용자 정의 부드럽게 대화 상자가 열립니다.

      기본적으로 트위닝된 프레임 사이의 변화 속도 값은 상수입니다. 속도를 지정하면 변화 속도가 단계적으로 조정되어 속도를 늘리거나 줄일 때 보다 자연스러운 모양이 나타납니다.

  8. 트위닝 중 선택한 항목을 회전시키려면 속성 관리자의 [회전] 메뉴에서 옵션을 선택합니다.
    • 회전되지 않도록 하려면 [없음](기본 설정)을 선택합니다.

    • 모션이 가장 적은 방향으로 한 번만 객체를 회전하려면 [자동]을 선택합니다.

    • 지정한 방향으로 객체를 회전한 다음 숫자를 입력하여 회전 횟수를 지정하려면 [시계 방향(CW)] 또는 [반시계 방향(CCW)]을 선택합니다.

     4단계에서 끝 프레임에 적용한 모든 회전에 8단계에서 지정한 회전이 추가되어 적용됩니다.

  9. 모션 경로를 사용하는 경우 속성 관리자에서 [경로 방향으로]를 선택하여 트위닝된 요소의 기준선 방향을 모션 경로에 맞춥니다.
  10. 그래픽 심볼 인스턴스의 애니메이션을 기본 타임라인에 동기화하려면 속성 관리자에서 동기화 옵션을 선택합니다.

     심볼 동기화를 선택하거나 동기화 옵션을 선택하면 트윈의 프레임 수가 타임라인에서 할당된 프레임 수와 일치하도록 다시 계산됩니다. 애니메이션 시퀀스의 프레임 수가 그래픽 인스턴스에 있는 프레임 수의 짝수 배수가 아닐 경우 동기화 옵션을 사용합니다.

  11. 모션 경로를 사용하는 경우 물리기를 선택하여 트위닝된 요소를 등록 포인트를 기준으로 모션 경로에 연결합니다.

클래식 트윈을 사용하여 캐릭터에 활기를 불어넣기

캐릭터가 클래식 트위닝를 통해 살아납니다. 애니메이션에 생동감을 불어넣으시겠습니까? 이 예제의 끝에 있는 자습서를 보고 다음 단계를 따르십시오:

  1. 개체를 선택하고 수정을 클릭합니다.

  2. 심볼로 변환...을 선택하고 다음 옵션을 선택합니다.

    • 이름 : 심볼의 이름을 입력합니다.
    • 유형 : 드롭다운 목록에서 그래픽을 선택합니다.
  3. 확인을 클릭하고 무료 변환 도구를 선택합니다.

  4. 가운데에 있는 흰색 점을 드래그하여 개체를 기울입니다.

  5. 프레임을 마우스 오른쪽 버튼으로 클릭하고 클래식 트윈 만들기를 선택합니다.

클래식 트윈을 사용하여 캐릭터에 활기를 불어넣는 방법

비디오에서 애니메이션에 모션을 만드는 방법을 확인합니다.

XML 파일로 저장된 클래식 트윈을 사용한 작업

Animate에서는 XML 파일로 저장된 클래식 트윈을 사용하여 작업할 수 있습니다. 기본적으로 Animate에서는 모든 클래식 트윈에 다음 명령을 적용할 수 있습니다.

  • XML로 모션 복사

  • XML로 모션 내보내기

  • XML로 모션 가져오기

XML로 모션 복사

지정된 프레임에서 스테이지에 있는 객체에 적용된 모션 속성을 복사할 수 있습니다. 

  1. 클래식 트윈을 만듭니다.

  2. 타임라인에서 키프레임을 선택합니다.

  3. 명령 > XML로 모션 복사로 이동합니다.

모션 속성이 XML 데이터로 클립보드에 복사됩니다. 그런 다음 텍스트 편집기를 사용하여 XML 파일에 대한 작업을 할 수 있습니다.

XML로 모션 내보내기

스테이지의 객체에 적용되는 모션 속성을 저장이 가능한 XML 파일로 내보낼 수 있습니다.

 

  1. 클래식 트윈을 만듭니다. 

  2. 명령 > XML로 모션 내보내기로 이동합니다.

  3. 파일을 저장할 적합한 위치를 찾아봅니다.

  4. XML 파일 이름을 입력하고 저장을 클릭합니다.

    클래식 트윈이 지정한 위치에 XML 파일로 내보내집니다.

XML로 모션 가져오기

모션 속성이 정의된 기존 XML 파일을 가져올 수 있습니다.

  1. 스테이지에서 객체를 선택합니다.

  2. 명령 > XML로 모션 가져오기로 이동합니다.

  3. 위치를 찾아보고 XML 파일을 선택합니다. 확인을 클릭합니다.

  4. 모션 선택하여 붙여넣기 대화 상자에서 선택한 객체에 적용하려는 속성을 선택합니다.

  5. 확인을 클릭합니다.

모션 안내선 레이어 만들기

클래식 트윈 애니메이션에서 객체의 이동을 제어하려면 모션 안내선 레이어를 만듭니다.

모션 트윈 레이어 또는 역기구학 포즈 레이어를 안내선 레이어로 드래그할 수 없습니다.

  1. 일반 레이어를 안내선 레이어로 드래그합니다. 이 작업은 안내선 레이어를 모션 안내선 레이어로 변환하고 일반 레이어를 새 모션 안내선 레이어에 연결합니다.

     안내선 레이어를 실수로 변환하지 않도록 모든 안내선 레이어를 레이어 순서에서 아래쪽에 배치합니다.

경로를 따라 클래식 트윈 애니메이션 만들기

 이 항목에서는 예전 방식인 클래식 트윈을 사용하여 작업하는 방법을 설명합니다. 모션 경로가 있는 새로운 모션 트윈을 사용하는 방법에 대해서는 트윈 애니메이션의 모션 경로 편집을 참조하십시오.

모션 안내선 레이어를 사용하면 트위닝된 인스턴스, 그룹 또는 텍스트 블록에 애니메이션 적용의 기준이 되는 경로를 그릴 수 있습니다. 모션 안내선 레이어에 여러 레이어를 링크하여 여러 객체가 같은 경로를 따라 이동하도록 할 수 있습니다. 모션 안내선 레이어에 링크되는 일반 레이어는 안내선이 적용됩니다.

모션 경로
이 예제에서는 별도의 레이어에 있는 두 객체가 동일한 모션 경로에 연결됩니다.

클래식 트위닝된 애니메이션에 대한 모션 경로 만들기

  1. 클래식 트위닝된 애니메이션 시퀀스를 만듭니다.

    속성 관리자에서 경로 방향으로를 선택하면 트위닝된 요소의 기준선 방향이 모션 경로에 맞춰집니다. [물리기]를 선택하면 트위닝된 요소의 등록 포인트가 모션 경로에 물립니다.

  2. 클래식 트윈이 포함된 레이어의 레이어 이름을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)하고 [표준 모션 안내선 추가]를 선택합니다.

    Animate는 모션 안내선 레이어를 클래식 트윈 레이어 위에 추가하고 클래식 트윈 레이어의 이름을 들여씁니다. 이는 클래식 트윈 레이어가 모션 안내선 레이어에 바인딩되어 있음을 나타냅니다.

     타임라인에 안내선 레이어가 이미 있는 경우 클래식 트윈이 포함된 레이어를 안내선 레이어 아래로 드래그하면 됩니다. 이 작업은 안내선 레이어를 모션 레이어로 변환하고 클래식 트윈을 모션 레이어에 바인딩합니다.

    모션 안내선 레이어
    클래식 트윈이 포함된 레이어 위의 모션 안내선 레이어

  3. 모션 안내선 레이어에 경로를 추가하려면 모션 안내선 레이어를 선택하고 [펜], [연필], [선], [원], [직사각형] 또는 [브러시] 툴을 사용합니다.

    모션 안내선 레이어에 획을 붙여넣을 수도 있습니다.

  4. 트위닝할 객체를 드래그하여 첫 번째 프레임의 시작 부분 또는 마지막 프레임의 끝 부분에 물립니다.

    안내선 획의 시작 부분에 물린 그래픽
    안내선 획의 시작 부분에 물린 자동차를 표현한 그래픽

     최상의 물리기 결과를 얻으려면 변형점을 기준으로 심볼을 드래그합니다.

  5. 모션 안내선 레이어 및 경로를 숨기려면 모션 안내선 레이어에서 눈 모양 아이콘 열을 클릭합니다. 숨기면 작업하는 동안 객체의 움직임만 표시됩니다. 

    애니메이션을 재생할 때 그룹이나 심볼은 모션 경로를 따라 이동합니다.

가변 폭 획 및 가변 획 색상에 기반한 애니메이션 안내선에 대한 자세한 내용은 애니메이션 안내선을 참조하십시오.

  1. 다음 중 하나를 수행합니다.
    • 기존 레이어 모션 안내선 레이어 아래로 드래그합니다. 레이어는 모션 안내선 레이어에서 안쪽으로 조금 들어갑니다. 이 레이어의 모든 객체는 모션 경로에 자동으로 물립니다.

    • 모션 안내선 레이어 아래에 레이어를 만듭니다. 이 레이어에서 트위닝하는 객체는 모션 경로를 따라 자동으로 트위닝됩니다.

    • 모션 안내선 레이어 아래의 레이어를 선택합니다. 수정 > 타임라인 > 레이어 속성을 선택한 다음 안내선을 선택합니다.

  1. 링크를 해제하려면 레이어를 선택하고 다음 중 하나를 수행합니다.

    • 레이어를 모션 안내선 레이어 위로 드래그합니다.

    • 수정 > 타임라인 > 레이어 속성을 선택한 다음 레이어 유형으로 보통을 선택합니다.

클래식 트윈 애니메이션 속성 붙여넣기

 이 항목에서는 예전 방식인 클래식 트윈의 속성을 붙여넣는 방법을 설명합니다. 새로운 모션 트윈의 속성을 붙여넣는 방법에 대해서는 트윈 애니메이션 속성 복사 및 붙여넣기를 참조하십시오.

[모션 붙여넣기] 명령을 사용하면 클래식 트윈을 복사하고 다른 객체에 적용할 특정 속성만 붙여넣을 수 있습니다.

  1. 타임라인에서 복사할 클래식 트윈이 포함된 프레임을 선택합니다. 선택한 프레임은 같은 레이어에 있어야 하지만 단일 클래식 트윈 내에 포함되지 않아도 됩니다. 선택 항목은 트윈, 빈 프레임 또는 두 개 이상의 트윈에 포함될 수 있습니다.
  2. 편집 > 타임라인 > 모션 복사를 선택합니다.

  3. 복사한 클래식 트윈을 받으려면 심볼 인스턴스를 선택합니다.

  4. 편집 > 타임라인 > 모션 선택하여 붙여넣기를 선택합니다. 심볼 인스턴스에 붙여넣을 특정 클래식 트윈 속성을 선택합니다. 클래식 트윈 속성은 다음과 같습니다.

    X 위치

    객체가 x 방향으로 이동한 거리입니다.

    Y 위치

    객체가 y 방향으로 이동한 거리입니다.

    수평 비율

    객체의 현재 크기와 가로 방향(X)에서의 "기본 크기" 간 비율입니다.

    수직 비율

    객체의 현재 크기와 세로 방향(Y)에서의 "기본 크기" 간 비율을 지정합니다.

    회전 및 기울이기

    객체의 회전 및 기울이기입니다. 이 두 속성은 객체에 함께 적용해야 합니다. 기울이기는 회전 각도를 나타내는 치수입니다. 객체를 회전하고 기울이면 각 속성이 서로에게 영향을 줍니다.

    색상

    농도, 밝기 및 알파와 같은 모든 색상 값을 객체에 적용할 수 있습니다.

    필터

    선택한 범위의 모든 필터 값 및 변경 사항입니다. 객체에 필터를 적용하면 모든 값이 유지된 상태로 필터가 붙여넣어지며 필터의 상태(활성화 또는 비활성화)도 새 객체에 적용됩니다.

    블렌드 모드

    객체의 블렌드 모드를 적용합니다.

    대상 크기 조절 속성 무시

    선택 해제하면 모든 속성이 대상 객체에 상대적으로 붙여넣어집니다. 이 옵션을 선택하면 대상의 크기 조절 속성이 무시됩니다.

    대상 회전 및 기울이기 속성 무시

    선택 해제하면 모든 속성이 대상 객체에 상대적으로 붙여넣어집니다. 선택하면 객체의 기존 회전 및 크기 조절 속성이 붙여넣은 속성으로 재정의됩니다.

    원본 트윈과 동일하게 만드는 데 필요한 프레임, 트윈 및 심볼 정보가 삽입됩니다.

    심볼의 클래식 트윈을 [액션] 패널에 복사하거나 다른 프로젝트에서 ActionScript로 사용하려면 [ActionScript 3.0으로 모션 복사] 명령을 사용하십시오.

부드럽게 사전 설정 만들기

부드럽게 사전 설정은 스테이지의 객체에 적용할 수 있는 사전 구성된 부드럽게 효과입니다.

흔히 사용하는 부드럽게 사전 설정 세트를 클래식 트윈에 사용할 수 있습니다. 부드럽게 사전 설정 목록에서 사전 설정을 선택하여 선택된 속성에 적용할 수 있습니다.

  1. Animate의 타임라인에서 트윈을 포함하는 레이어를 클릭합니다.

  2. 트위닝 속성을 열려면 속성 패널에서 트위닝 범주를 클릭합니다. 부드럽게 유형 드롭다운을 사용하여 속성 수준 부드럽게에 액세스할 수 있습니다.

    클래식 트윈에 대해 속성 수준 부드럽게 사전 설정을 적용할 수 있습니다. 속성 패널에서 속성 수준 부드럽게를 선택하는 옵션이 제공됩니다. 각 속성을 별도로 선택하여 각 속성에 대해 서로 다른 부드럽게 사전 설정을 적용할 수 있습니다. 

    속성 수준 사전 설정
    속성 수준 사전 설정

    클래식 트윈의 위치, 회전, 크기 조절, 색상 및 필터 속성에 대해 고유한 부드럽게 사전 설정을 선택할 수 있습니다. 

    위치 스테이지에서 애니메이션 객체의 위치에 대한 부드럽게 설정을 지정합니다. 

    회전 스테이지에서 애니메이션 객체의 회전에 대한 부드럽게 설정을 지정합니다.  

    크기 조절 스테이지에서 애니메이션 객체의 크기 조절에 대한 부드럽게 설정을 지정합니다. 

    색상 스테이지에서 애니메이션 객체에 적용된 색상 전환에 대한 부드럽게 설정을 지정합니다. 

    필터 스테이지에서 애니메이션 객체에 적용된 필터에 대한 부드럽게 설정을 지정합니다. 

  3. 또는 트윈의 모든 속성에서 동일한 부드럽게를 적용하려면 모든 속성을 함께 적용 옵션을 선택합니다. 부드럽게 유형 팝업 대화 상자에서 원하는 각 부드럽게 사전 설정을 선택하고 두 번 클릭하여 적용합니다. 

    클래식 부드럽게를 적용하기로 선택하는 경우에는 슬라이더를 움직여서 부드럽게 정도를 높이거나 낮출 수도 있습니다. 

    부드럽게 사전 설정 목록
    부드럽게 사전 설정 목록

  4. 사용자 정의 부드럽게를 적용하려면 부드럽게 옆에 있는 [편집] 아이콘을 클릭합니다. 

HTML 5 Canvas 문서 유형을 사용하는 경우 부드럽게 사전 설정에 최적화된 js 출력 파일을 얻을 수 있습니다. HTML5 Canvas는 출력을 만드는 동안 트윈 JS의 부드럽게 함수를 사용합니다. 

클래식 트윈 애니메이션에 사용자 정의 부드럽게 적용

 이 항목에서는 예전 방식인 클래식 트윈에 부드럽게를 추가하는 방법을 설명합니다. 새로운 모션 트윈에 부드러움을 추가하는 방법에 대해서는 트윈 애니메이션 부드럽게를 참조하십시오.

사용자 정의 부드럽게 대화 상자에는 시간 경과에 따른 모션 정도를 나타내는 그래프가 표시됩니다. 수평 축은 프레임을 나타내고 수직 축은 변경률을 나타냅니다. 첫 번째 키프레임은 0%, 마지막 키프레임은 100%로 나타납니다.

그래프의 곡선 경사는 객체의 변경 속도를 나타냅니다. 곡선이 수평(경사 없음)이면 속도가 0이고, 곡선이 수직이면 즉각적인 속도 변화를 나타냅니다.

사용자 정의 부드럽게 저장

버튼을 클릭하여 사용자 정의 부드럽게를 저장하고 사용자 정의 목록에서 사용자 정의 부드럽게를 선택하여 다시 사용할 수 있습니다. 변경한 후에 편집 모드에서 저장 및 적용을 클릭합니다. 아래 스크린샷에서 이름이 MyEase1인 사용자 정의된 부드럽게 사전 설정을 확인할 수 있습니다. 

 사용자 정의된 부드럽게 사전 설정은 동일한 문서 유형 내에서만 다시 사용할 수 있습니다.

타임라인에서 여러 범위에 걸쳐 적용된 부드럽게 사전 설정을 사용하려면 해당 범위를 선택하고 부드럽게를 적용합니다.

사용자 정의 부드럽게 대화 상자용 추가 컨트롤

재생 및 중단 버튼

[사용자 정의 부드럽게] 대화 상자에 정의된 현재의 모든 속도 곡선을 사용하여 스테이지의 애니메이션을 미리 볼 수 있습니다.

삭제

현재 사용자 정의 부드럽게를 삭제합니다. 

저장 및 적용

부드럽게 사전 설정에 대해 수행한 변경 내용을 저장 및 적용합니다. 

재설정 버튼

속도 곡선을 기본값인 직선 상태로 재설정합니다.

선택한 제어점의 위치

대화 상자의 오른쪽 아래 모서리에 키프레임과 선택한 제어점의 위치가 수치값으로 표시됩니다. 선택된 제어점이 없으면 값이 표시되지 않습니다.

선에 제어점을 추가하려면 대각선을 한 번 클릭합니다. 객체의 모션을 아주 정확하게 제어하려면 제어점의 위치를 드래그합니다.

프레임 표시기(사각형 핸들로 표시됨)를 사용하여 객체의 속도를 늘리거나 줄일 지점을 클릭합니다. 제어점의 사각형 핸들을 클릭하면 해당 제어점이 선택되고 제어점 양쪽에 접선 포인트가 표시됩니다. 접선 포인트는 속이 빈 원으로 나타납니다. 제어점을 배치하려면 마우스 또는 키보드 화살표를 사용하여 제어점 또는 해당 접선 포인트를 드래그합니다.

: 기본적으로 제어점은 격자에 물립니다. 제어점을 드래그하면서 X 키를 눌러 물리기를 해제할 수 있습니다.

제어점에서 멀리 떨어진 곡선 영역을 클릭하면 곡선의 해당 지점에 제어점이 추가됩니다. 이 작업은 곡선의 모양을 변경하지 않습니다. 곡선과 제어점에서 멀리 떨어진 곳을 클릭하면 현재 선택되어 있는 제어점 선택이 취소됩니다.

사용자 정의 부드럽게 추가

  1. 타임라인에서 클래식 트윈이 적용된 레이어를 선택합니다.

  2. 프레임 속성 관리자에서 [부드럽게] 슬라이더 옆의 [편집] 버튼을 클릭합니다.
  3. 제어점을 추가하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 대각선을 클릭합니다.
  4. 객체의 속도를 빠르게 하려면 제어점을 위로 드래그하고 객체의 속도를 느리게 하려면 제어점을 아래로 드래그합니다.
  5. 속도 곡선을 세부 조절하고 트윈의 속도 값을 세밀하게 조절하려면 꼭지점 핸들을 드래그합니다.
  6. 스테이지에서 애니메이션을 보려면 왼쪽 아래 모서리에 있는 [재생] 버튼을 클릭합니다.

  7. 원하는 효과를 얻을 때까지 컨트롤을 조절합니다.

[사용자 정의 부드럽게] 대화 상자를 사용할 경우 편집 필드가 --를 표시합니다. 편집 또는 팝업 슬라이더를 사용할 경우 사용자 정의 부드럽게 그래프가 해당 곡선으로 설정됩니다. 또한 모든 속성에 단일 설정 사용 확인란이 선택됩니다.

부드럽게 곡선 복사 및 붙여넣기

  • 현재의 부드럽게 곡선을 복사하려면 Ctrl+C(Windows) 또는 Command+C(Macintosh)를 누릅니다.

  • 복사한 곡선을 다른 부드럽게 곡선에 붙여넣으려면 Ctrl+V(Windows) 또는 Command+V(Macintosh)를 누릅니다.

    부드럽게 곡선을 복사하여 붙여넣을 수 있습니다. 복사한 곡선은 Animate 애플리케이션을 종료할 때까지 사용할 수 있는 상태로 유지됩니다.

지원되지 않는 속도 곡선

특정 유형의 속도 곡선은 지원되지 않습니다. 또한 그래프에서 비선형 곡선(예: 원)은 나타낼 수 없습니다.

[사용자 정의 부드럽게] 대화 상자에서는 잘못된 곡선을 렌더링할 위치로 제어점이나 접선 핸들을 자동으로 옮길 수 없습니다.

  • 모든 점이 그래프에 있어야 합니다. 제어점은 그래프의 경계를 벗어나 이동할 수 없습니다.

  • 곡선의 모든 선분이 그래프 내에 있어야 합니다. 그래프의 경계를 벗어나 확장할 수 없도록 곡선의 모양이 병합됩니다.

 Adobe

쉽고 빠르게 지원 받기

신규 사용자이신가요?