Animate에서 라이브러리를 사용한 작업

  1. Adobe Animate 사용 안내서
  2. Animate 소개
    1. Animate의 새로운 기능
    2. 시각적 용어집
    3. Animate 시스템 요구 사항
    4. Animate 키보드 단축키
    5. Animate에서 여러 파일 유형을 사용하여 작업하기
  3. 애니메이션
    1. Animate의 애니메이션 기본 사항
    2. Animate에서 프레임 및 키프레임을 사용하는 방법
    3. Animate의 프레임별 애니메이션
    4. Animate에서 클래식 트윈 애니메이션으로 작업하는 방법
    5. 브러시 도구
    6. 모션 안내선
    7. 모션 트윈 및 ActionScript 3.0
    8. 모션 트윈 애니메이션 정보
    9. 모션 트윈 애니메이션
    10. 모션 트윈 애니메이션 만들기
    11. 속성 키프레임 사용
    12. 트윈으로 위치에 애니메이션 적용
    13. 모션 편집기를 사용하여 모션 트윈을 편집하는 방법
    14. 트윈 애니메이션의 모션 경로 편집
    15. 모션 트윈 조작
    16. 사용자 정의 속도 추가
    17. 모션 사전 설정 만들기 및 적용
    18. 애니메이션 트윈 범위 설정
    19. XML 파일로 저장한 모션 트윈을 사용한 작업
    20. 모션 트윈과 클래식 트윈의 비교
    21. 모양 트윈 만들기
    22. Animate에서 뼈 도구 애니메이션 사용하기
    23. Animate에서 캐릭터 리깅으로 작업하기
    24. Adobe Animate에서 마스크 레이어를 사용하는 방법
    25. Animate에서 장면으로 작업하는 방법
  4. 대화형 기능
    1. Animate로 버튼을 만드는 방법
    2. Animate 프로젝트를 다른 문서 유형 포맷으로 변환
    3. Animate에서 HTML5 Canvas 문서를 만들고 게시하기
    4. Animate에서 코드 조각을 사용하여 대화형 기능 추가하기
    5. 사용자 정의 HTML5 구성 요소 만들기
    6. HTML5 Canvas의 구성 요소 사용
    7. 사용자 정의 구성 요소 만들기: 예제
    8. 사용자 정의 구성 요소의 코드 조각
    9. 모범 사례 - Animate를 사용한 광고
    10. 가상 현실 제작 및 게시
  5. 작업 영역 및 작업 과정
    1. 칠 브러시 만들기 및 관리
    2. HTML5 Canvas 문서에서 Google Fonts 사용
    3. Creative Cloud 라이브러리와 Adobe Animate 사용
    4. Animate의 스테이지 및 도구 패널 사용
    5. Animate 작업 과정 및 작업 영역
    6. HTML5 Canvas 문서에서 웹 글꼴 사용
    7. 타임라인과 ActionScript
    8. 여러 타임라인을 사용한 작업
    9. 환경 설정
    10. Animate 제작 패널 사용
    11. Animate로 타임라인 레이어 만들기
    12. 모바일 앱 및 게임 엔진용으로 애니메이션 내보내기
    13. 객체 이동 및 복사
    14. 템플릿
    15. Animate의 찾기 및 바꾸기
    16. 실행 취소, 다시 실행 및 작업 내역 패널
    17. 키보드 단축키
    18. Animate에서 타임라인을 사용하는 방법
    19. HTML 확장 만들기
    20. 이미지 및 애니메이션 GIF에 대한 최적화 옵션
    21. 이미지 및 GIF에 대한 내보내기 설정
    22. Animate의 에셋 패널
  6. 멀티미디어 및 비디오
    1. Animate의 그래픽 객체 변형 및 결합
    2. Animate에서 심볼 인스턴스를 만들고 작업하기
    3. 이미지 추적
    4. Adobe Animate에서 사운드를 사용하는 방법
    5. SVG 파일 내보내기
    6. Animate에서 사용할 비디오 파일 만들기
    7. Animate에서 비디오를 추가하는 방법
    8. 비디오 큐 포인트를 사용한 작업
    9. Animate로 객체 그리고 만들기
    10. 선 및 모양 변형
    11. Animate CC의 획, 채우기 및 그래디언트
    12. Adobe Premiere Pro 및 After Effects 작업
    13. Animate CC의 색상 패널
    14. Animate에서 Flash CS6 파일 열기
    15. Animate의 클래식 텍스트 작업
    16. Animate에 아트워크 가져오기
    17. Animate의 가져온 비트맵
    18. 3D 그래픽
    19. Animate의 심볼 작업
    20. Adobe Animate로 선 및 모양 그리기
    21. Animate의 라이브러리 작업
    22. 사운드 내보내기
    23. Animate CC의 객체 선택
    24. Animate의 Illustrator AI 파일 작업
    25. 스프레이 브러시 도구로 패턴 적용하기
    26. 블렌드 모드 적용
    27. 객체 배열
    28. 명령 메뉴를 사용한 작업 자동화
    29. 다국어 텍스트
    30. Animate에서 카메라 사용하기
    31. Animate를 Adobe Scout와 함께 사용하기
    32. Fireworks 파일 작업
    33. 그래픽 필터
    34. 사운드 및 ActionScript
    35. 드로잉 환경 설정
    36. 펜 도구로 그리기
  7. 플랫폼
    1. Animate 프로젝트를 다른 문서 유형 포맷으로 변환
    2. 사용자 정의 플랫폼 지원
    3. Animate에서 HTML5 Canvas 문서 만들고 게시하기
    4. WebGL 문서 만들고 게시하기
    5. iOS용 AIR에 맞추어 애플리케이션을 패키징하는 방법
    6. Android용 AIR 애플리케이션 게시
    7. 데스크톱용 Adobe AIR에 맞춘 게시
    8. ActionScript 게시 설정
    9. 모범 사례 - 애플리케이션에서 ActionScript 구성
    10. Animate에서 ActionScript를 사용하는 방법
    11. 모범 사례 - 액세스 가능성 지침
    12. Animate 작업 영역의 액세스 가능성
    13. 스크립트 작성 및 관리
    14. 사용자 정의 플랫폼에 대한 지원 활성화
    15. 사용자 정의 플랫폼 지원 개요
    16. 액세스 가능한 콘텐츠 만들기
    17. 사용자 정의 플랫폼 지원 플러그인 작업
    18. ActionScript 3.0 디버깅
    19. 사용자 정의 플랫폼에 대한 지원 활성화
  8. 내보내기 및 게시
    1. Animate CC에서 파일을 내보내는 방법
    2. OAM 게시
    3. SVG 파일 내보내기
    4. Animate를 사용하여 그래픽 및 비디오 내보내기
    5. AS3 문서 게시
    6. 모바일 앱 및 게임 엔진용으로 애니메이션 내보내기
    7. 사운드 내보내기
    8. QuickTime 비디오 파일 내보내기
    9. ActionScript로 외부 비디오 재생 제어하기
    10. 모범 사례 - 모바일 장치 콘텐츠 만들기 팁
    11. 모범 사례 - 비디오 규칙
    12. 모범 사례 - SWF 애플리케이션 제작 지침
    13. 모범 사례 - FLA 파일 구조화
    14. Animate용 FLA 파일을 최적화하는 모범 사례
    15. ActionScript 게시 설정
    16. Animate용 게시 설정 지정
    17. 프로젝터 파일 내보내기
    18. 이미지 및 애니메이션 GIF 내보내기
    19. HTML 게시 템플릿
    20. Adobe Premiere Pro 및 After Effects 작업
    21. 애니메이션의 빠른 공유 및 게시

라이브러리를 사용한 작업

Animate 문서의 라이브러리에는 Animate 제작 환경에서 만들거나 문서에서 사용하기 위해 가져온 미디어 에셋이 저장됩니다. Animate에서 직접 벡터 아트워크 또는 텍스트를 만들고, 벡터 아트워크, 비트맵, 비디오 및 사운드를 가져오고, 심볼을 만들 수 있습니다. 심볼은 한 번 만들어 여러 번 다시 사용할 수 있는 그래픽, 버튼, 동영상 클립 또는 텍스트입니다. ActionScript를 사용하여 문서에 미디어 내용을 동적으로 추가할 수도 있습니다.

라이브러리에는 문서에 추가한 구성 요소도 들어 있습니다. 구성 요소는 컴파일된 클립 또는 MovieClip 기반 구성 요소일 수 있습니다.

Animate에서 작업하는 동안 임의 Animate 문서의 라이브러리를 열어 해당 파일의 라이브러리 항목을 현재 문서에서 사용할 수 있습니다. 이름 또는 ActionScript 링크 이름으로 라이브러리의 심볼을 검색할 수 있습니다.

Animate 애플리케이션에서 Animate를 실행할 때마다 사용 가능한 영구 라이브러리를 만들 수 있습니다. Animate에는 버튼, 그래픽, 동영상 클립 및 사운드가 포함된 샘플 라이브러리도 여러 개 들어 있습니다.

라이브러리 에셋을 SWF 파일로 URL에 내보내면 런타임 공유 라이브러리를 만들 수 있습니다. 그러면 런타임 공유를 통해 심볼을 가져오는 Animate 문서에서 라이브러리 에셋으로 연결할 수 있습니다.

[라이브러리] 패널([윈도우] > [라이브러리])에는 라이브러리의 모든 항목 이름에 대한 스크롤 목록이 표시되므로 작업할 때 이러한 요소를 보거나 구성할 수 있습니다. [라이브러리] 패널에서 항목 이름 옆에 있는 아이콘은 항목의 파일 유형을 나타냅니다.

참고:

객체를 스테이지에서 [라이브러리] 패널로 드래그하여 심볼로 변환하는 기능은 더 이상 사용되지 않으며, Animate에서 작동하지 않습니다.

고정되지 않은 두 문서를 가로질러 객체를 스테이지로 드래그하는 기능은 더 이상 사용되지 않으며, Animate에서 작동하지 않습니다.

다른 Animate 파일의 라이브러리 열기

  1. 현재 문서에서 [파일] > [가져오기] > [외부 라이브러리 열기]를 선택합니다.
  2. 열려는 라이브러리가 있는 Animate 파일을 찾아 [열기]를 클릭합니다.

    선택한 파일의 라이브러리가 현재 문서에서 열립니다. 이때 파일의 이름은 [라이브러리] 패널의 위쪽에 표시됩니다. 선택한 파일의 라이브러리에 있는 항목을 현재 문서에서 사용하려면 항목을 현재 문서의 [라이브러리] 패널이나 스테이지로 드래그합니다.

라이브러리 패널 크기 조절

  1. 다음 중 하나를 수행합니다.
    • 패널의 오른쪽 아래 모서리를 드래그합니다.

    • 모든 열이 표시되도록 [라이브러리] 패널의 크기를 늘리려면 [라이브러리 넓게 보기] 버튼을 클릭합니다.

    • [라이브러리] 패널의 폭을 줄이려면 [라이브러리 좁게 보기] 버튼을 클릭합니다.

열 폭 변경

  1. 열 머리글 사이에 포인터를 놓은 다음 드래그하여 크기를 조절합니다.

라이브러리 패널에서 폴더를 사용한 작업

폴더를 사용하여 [라이브러리] 패널의 항목을 구성할 수 있습니다. 새 심볼을 만들면 선택한 폴더에 저장됩니다. 폴더를 선택하지 않으면 라이브러리의 루트에 심볼이 저장됩니다.

또한 Animate는 애니메이션 GIF 파일을 라이브러리 루트 폴더 아래 별도의 폴더에 배치하고 순서에 따라 연관된 모든 비트맵의 이름을 지정하여 효과적으로 구성된 방식으로 가져옵니다. 

새 폴더 만들기

  1. [라이브러리] 패널의 아래쪽에서 [새 폴더] 버튼 을 클릭합니다.

폴더 열기 또는 닫기

  1. 폴더를 두 번 클릭하거나, 폴더를 선택하고 [라이브러리] 패널의 패널 메뉴에서 [폴더 확장] 또는 [폴더 축소]를 선택합니다.

모든 폴더 열기 또는 닫기

  1. [라이브러리] 패널의 패널 메뉴에서 [모든 폴더 확장] 또는 [모든 폴더 축소]를 선택합니다.

폴더 간 항목 이동

  1. 한 폴더에서 다른 폴더로 항목을 드래그합니다.

    새 위치에 같은 이름의 항목이 있으면 Animate에 항목을 교체할 것인지 여부를 묻는 메시지가 표시됩니다.

라이브러리 패널에서 항목 정렬

[라이브러리] 패널의 열에는 항목의 이름, 유형, 파일에서 사용된 횟수, 링크 상태와 식별자(항목이 공유 라이브러리와 연결된 경우 또는 ActionScript에 대해 내보내진 경우) 및 최근에 수정된 날짜가 나열됩니다.

[라이브러리] 패널에서는 모든 열에 대해 영숫자 순으로 항목을 정렬할 수 있습니다. 항목은 폴더 안에서 정렬됩니다.

Animate 라이브러리는 가져온 애니메이션 GIF 파일을 라이브러리 루트 폴더 아래 별도의 폴더에 구성하고 순서에 따라 연관된 모든 비트맵의 이름을 지정합니다. 

  1. 정렬하려는 열의 머리글을 클릭합니다. 역순으로 정렬하려면 열 머리글의 오른쪽에 있는 삼각형 버튼을 클릭합니다.

라이브러리 에셋 간 충돌

이름이 같은 다른 에셋이 포함되어 있는 문서에 라이브러리 에셋을 가져오거나 복사할 때 기존 항목을 새 항목으로 바꿀지 여부를 선택합니다. 이 옵션은 라이브러리 에셋을 가져오거나 복사하는 모든 방법에 사용할 수 있습니다.

문서의 기존 항목과 충돌을 일으키는 항목을 배치하려고 하면 [라이브러리 충돌 해결] 대화 상자가 나타납니다. 대상 문서에 이미 있고 수정한 날짜가 다른 항목을 소스 문서에서 복사하면 충돌이 발생합니다. 이러한 이름 충돌 문제가 발생하지 않도록 하려면 해당 문서의 라이브러리에 있는 폴더에서 에셋을 구성합니다. 심볼이나 구성 요소를 문서의 스테이지에 붙여넣을 때 해당 심볼이나 구성 요소의 수정 날짜와 수정 날짜가 다른 사본이 이미 있는 경우에도 이 대화 상자가 나타납니다.

기존 항목을 바꾸지 않으려는 경우 Animate에서는 붙여넣는 충돌 항목 대신 기존 항목을 사용합니다. 예를 들어, 심볼 1이라는 심볼을 복사하여 이 사본을 같은 이름의 심볼이 이미 포함되어 있는 문서의 스테이지에 붙여넣으면 Animate에서 기존 심볼 1의 인스턴스가 만들어집니다.

기존 항목을 바꾸기로 선택한 경우 Animate에서 기존 항목과 이들의 모든 인스턴스가 같은 이름의 새 항목으로 바뀝니다. [가져오기] 또는 [복사] 작업을 취소할 경우 대상 문서에서 충돌을 일으키는 항목을 비롯한 모든 항목에 대한 작업이 취소됩니다.

동일한 유형의 라이브러리 항목만 서로 바꿀 수 있습니다. 즉, 테스트라는 이름의 사운드는 테스트라는 비트맵으로 바꿀 수 없습니다. 이 경우 새로운 항목은 이름에 사본이라는 단어가 덧붙여져 라이브러리에 추가됩니다.

참고:

이 방법으로 라이브러리 항목을 바꾸면 실행 취소할 수 없습니다. 충돌을 일으키는 라이브러리 항목을 바꿔 문제를 해결해야 하는 복잡한 붙여넣기 작업을 할 경우 FLA 파일의 백업 파일을 미리 저장해 두도록 합니다.

라이브러리 에셋을 문서로 가져오거나 복사할 때 [라이브러리 충돌 해결] 대화 상자가 나타나면 이름 충돌 문제를 해결합니다.

라이브러리 에셋 간의 이름 충돌 해결

  1. [라이브러리 충돌 해결] 대화 상자에서 다음 중 하나를 수행합니다.

    • 대상 문서에서 기존 에셋을 유지하려면 [기존 항목 교체 안 함]을 클릭합니다.

    • 기존 에셋과 인스턴스를 이름이 같은 새 항목으로 바꾸려면 [기존 항목 교체]를 클릭합니다.

라이브러리 항목을 사용한 작업

[라이브러리] 패널의 항목을 선택하면 항목의 축소판 미리 보기가 [라이브러리] 패널의 위쪽에 표시됩니다. 선택한 항목이 애니메이션이나 사운드 파일이면 라이브러리 미리 보기 윈도우 또는 [컨트롤러]에서 [재생] 버튼을 사용하여 항목을 미리 볼 수 있습니다.

링크 이름으로 라이브러리 항목 검색

이름 또는 ActionScript 링크 이름을 기준으로 라이브러리 검색 패널에서 심볼을 검색할 수 있습니다.

  • 라이브러리 항목을 검색하려면 라이브러리 항목의 심볼 이름 또는 ActionScript 링크 이름의 처음 몇 문자를 입력합니다. 문자를 입력하면 라이브러리 패널에 일치하는 심볼 목록이 나타납니다.

현재 문서에서 라이브러리 항목 사용

  1. [라이브러리] 패널에서 스테이지로 항목을 드래그합니다.

    그러면 현재 레이어에 항목이 추가됩니다.

스테이지의 객체를 라이브러리 심볼로 변환

  1. 스테이지의 객체를 선택하고 마우스 오른쪽 버튼을 클릭한 다음 [심볼로 변환]을 선택합니다.

현재 문서의 라이브러리 항목을 다른 문서에서 사용

  1. [라이브러리] 패널이나 스테이지의 항목을 다른 문서의 [라이브러리] 패널이나 스테이지로 드래그합니다.

다른 문서에서 라이브러리 항목 복사

  1. 라이브러리 항목이 포함된 문서를 선택합니다.
  2. [라이브러리] 패널에서 라이브러리 항목을 선택합니다.
  3. [편집] > [복사]를 선택합니다.
  4. 라이브러리 항목을 복사할 문서를 선택합니다.
  5. 해당 문서의 [라이브러리] 패널을 선택합니다.
  6. [편집] > [붙여넣기]를 선택합니다.

라이브러리 항목 편집하기

  1. [라이브러리] 패널에서 항목을 선택합니다.
  2. [라이브러리] 패널의 패널 메뉴에서 다음 중 하나를 선택합니다.
    • Animate에서 항목을 편집하려면 [편집]을 선택합니다.

    • 다른 애플리케이션에서 항목을 편집하려면 [편집기 선택]을 선택한 다음 외부 애플리케이션을 선택합니다.

참고:

지원되는 외부 편집기를 시작하면 Animate가 가져온 원래 문서를 엽니다.

라이브러리 항목 이름 변경

가져온 파일의 라이브러리 항목 이름을 변경해도 파일 이름은 변경되지 않습니다.

  1. 다음 중 하나를 수행합니다.
    • 항목 이름을 두 번 클릭합니다.

    • 항목을 선택하고 [라이브러리] 패널의 패널 메뉴에서 [이름 변경]을 선택합니다.

    • 항목을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Command 키를 누른 상태에서 클릭(Macintosh)한 다음 컨텍스트 메뉴에서 [이름 변경]을 선택합니다.

  2. 상자에 새 이름을 입력합니다.

라이브러리 항목 삭제

라이브러리에서 항목을 삭제하면 문서에서 해당 항목의 인스턴스도 모두 삭제됩니다.

  1. 항목을 선택한 다음 [라이브러리] 패널의 아래쪽에 있는 [휴지통] 아이콘을 클릭합니다.

사용하지 않은 라이브러리 항목 찾기

문서를 구성하기 위해 사용하지 않은 라이브러리 항목을 찾아 삭제할 수 있습니다.

참고:

사용하지 않은 라이브러리 항목은 SWF 파일에 포함되지 않으므로 Animate 문서의 파일 크기를 줄이기 위해 사용하지 않은 라이브러리 항목을 삭제할 필요는 없습니다. 그러나 내보내기 위해 연결한 항목은 SWF 파일에 포함됩니다.

  1. 다음 중 하나를 수행합니다.
    • [라이브러리] 패널의 패널 메뉴에서 [사용하지 않은 항목 선택]을 선택합니다.

    • 항목이 사용 중인지 여부를 나타내는 [사용 횟수] 열을 기준으로 라이브러리 항목을 정렬합니다.

가져온 파일을 라이브러리에서 업데이트

Animate로 가져온 비트맵이나 사운드 파일 등의 파일을 외부 편집기를 사용하여 수정하는 경우 다시 가져오지 않고도 Animate에서 파일을 업데이트할 수 있습니다. 외부 Animate 문서에서 가져온 심볼도 업데이트할 수 있습니다. 가져온 파일을 업데이트하면 해당 내용이 외부 파일의 내용으로 바뀝니다.

참고: 라이브러리 루트 폴더 아래 별도의 폴더에서 순서에 따라 이름이 지정된 연관된 모든 비트맵과 함께 효과적으로 구성된 가져온 애니메이션 GIF 파일을 찾을 수 있습니다.

  1. [라이브러리] 패널에서 가져온 파일을 선택합니다.
  2. [라이브러리] 패널의 패널 메뉴에서 [업데이트]를 선택합니다.

문서 간에 라이브러리 에셋 복사

다양한 방법을 사용하여 소스 문서에서 대상 문서로 라이브러리 에셋을 복사할 수 있습니다. 또한 제작 중 또는 런타임 시에 여러 문서에서 심볼을 공유 라이브러리 에셋으로 공유할 수 있습니다.

대상 문서에 기존 에셋과 이름이 같은 에셋을 복사할 경우 [라이브러리 충돌 해결] 대화 상자에서 기존 에셋을 덮어쓸지 또는 유지하면서 이름을 수정하여 새 에셋으로 추가할지 선택할 수 있습니다. 라이브러리 에셋을 폴더로 구성하면 문서 간에 에셋을 복사할 때 이름이 충돌하는 것을 최소화할 수 있습니다.

복사하고 붙여넣어 라이브러리 에셋 복사

  1. 소스 문서의 스테이지에서 에셋을 선택합니다.

  2. [편집] > [복사]를 선택합니다.

  3. 대상 문서를 활성 문서로 만듭니다.

  4. 보이는 페이스트보드의 가운데에 에셋을 붙여넣으려면 스테이지에 포인터를 놓은 상태에서 [편집] > [가운데에 붙여넣기]를 선택합니다. 소스 문서에서와 같은 위치에 에셋을 삽입하려면 [편집] > [제자리에 붙여넣기]를 선택합니다.

드래그하여 라이브러리 에셋 복사

  1. 대상 문서가 열려 있는 상태에서 소스 문서의 [라이브러리] 패널에서 에셋을 선택한 후 대상 문서의 [라이브러리] 패널로 드래그합니다.

대상 문서에서 소스 문서 라이브러리를 열어 라이브러리 에셋 복사

  1. 대상 문서를 활성화한 상태에서 [파일] > [가져오기] > [외부 라이브러리 열기]를 선택합니다.

  2. 소스 문서를 선택하고 [열기]를 클릭합니다.

  3. 소스 문서 라이브러리에서 스테이지 또는 대상 문서의 라이브러리로 에셋을 드래그합니다.

Adobe 로고

내 계정 로그인