역기구학

역기구학(IK)은 부모-자식 관계에서 선형 또는 분기형 뼈대로 연결된 뼈를 사용하여 객체에 애니메이션을 적용하는 방법입니다. 한 뼈가 이동하면 연결된 뼈가 그에 맞춰 움직입니다..

역기구학을 사용하면 자연스러운 모션을 쉽게 만들 수 있습니다. 역기구학을 사용하여 애니메이션을 적용하려면 타임라인에서 뼈의 시작 및 끝 위치를 지정하면 됩니다. Animate가 시작 및 종료 프레임 사이의 뼈대에서 뼈의 위치를 자동으로 보간합니다.

IK는 다음과 같은 방법으로 사용할 수 있습니다.

  • 모양을 여러 뼈의 컨테이너로 사용합니다. 예를 들어 뱀 드로잉 안에 뼈를 추가하여 사실적으로 미끄러지듯 움직이게 만들 수 있습니다. 이러한 모양은 객체 드로잉 모드에서 그릴 수 있습니다.

  • 심볼 인스턴스를 연결합니다. 예를 들어 몸통, 상박, 하박, 손을 보여 주는 동영상 클립을 연결하여 서로 연결되어 자연스럽게 움직이는 것처럼 만들 수 있습니다. 각 인스턴스에는 하나의 뼈만 있습니다.

작업 중인 뼈 도구 애니메이션
 

뼈 스타일

Animate의 스테이지에서 뼈를 그릴 수 있는 방법에는 네 가지가 있습니다.

  • 단색. 기본 스타일입니다.
  • 와이어. 단색 스타일이 뼈 밑에 있는 아트워크를 너무 많이 가릴 때 유용합니다.
  • 선. 보다 작은 뼈대에 유용합니다.
  • 없음. 뼈를 숨겨서 그 밑에 있는 아트워크만 표시합니다.


[뼈 스타일]을 설정하려면 타임라인에서 IK 범위를 선택한 후에 [속성] 패널의 [옵션] 섹션에 있는 [스타일] 메뉴에서 스타일을 선택합니다.

참고: [뼈 스타일]을 [없음]으로 설정하여 문서를 저장하는 경우 다음에 문서를 열면 자동으로 뼈 스타일이 [선]으로 변경됩니다.

포즈 레이어

심볼 인스턴스 또는 모양에 뼈를 추가하면 Animate가 타임라인에서 뼈에 대한 새 레이어를 만듭니다. 이러한 새 레이어를 포즈 레이어라고 합니다. Animate에서 포즈 레이어를 기존 레이어 사이의 타임라인에 추가하므로 스테이지에서 객체가 이전에 쌓인 순서가 유지됩니다.

심볼에 뼈 추가

동영상 클립, 그래픽 및 버튼 인스턴스에 IK 뼈를 추가할 수 있습니다. 텍스트를 사용하려면 먼저 심볼로 변환하십시오. 뼈를 추가하기 전에 심볼 인스턴스가 다른 레이어에 있을 수 있습니다. Animate는 이러한 심볼 인스턴스를 포즈 레이어에 추가합니다.

참고: 수정 > 분리를 통해 텍스트를 별도의 모양으로 분리하고 각 모양에서 뼈를 사용할 수도 있습니다.

객체를 연결할 때는 만들려는 부모-자식 관계를 고려하십시오(예: 어깨에서 팔꿈치 그리고 손목으로).

  1. 스테이지에 심볼 인스턴스를 만듭니다. 나중에 시간을 절약하려면 원하는 공간 구성에 가깝도록 인스턴스를 정돈합니다.

  2. [도구] 패널에서 [뼈] 도구를 선택합니다.

    툴바의 뼈 도구
    툴바의 뼈 도구

  3. 뼈대의 루트 뼈로 설정할 심볼 인스턴스를 클릭합니다. 뼈를 심볼에 연결할 지점을 클릭합니다.

     

    기본적으로 Animate는 마우스 클릭 위치에 뼈를 만듭니다. 보다 정밀하게 뼈를 추가하려면 [IK 뼈 도구](편집 > 환경 설정)에서 [변형점 자동 설정]을 해제하십시오. [변형점 자동 설정]이 해제되어 있으면 한 심볼에서 다른 심볼로 클릭할 때 뼈가 심볼 변형점에 물립니다.

  4. 다른 심볼 인스턴스로 드래그하고 연결할 지점에서 마우스 버튼을 놓습니다.

  5. 뼈대에 다른 뼈를 추가하려면 첫 번째 뼈의 꼬리 부분에서 다음 심볼 인스턴스로 드래그합니다.

     

    객체에 물리기 기능을 끄면 꼬리 부분을 정교하게 배치하기가 쉬워집니다([보기] > [물리기] > [객체에 물리기]).

  6. 분기형 뼈대를 만들려면 분기가 시작되도록 할 기존 뼈의 머리 부분을 클릭합니다. 그런 다음 드래그하여 새 분기의 첫 번째 뼈를 만듭니다.

     

    뼈대에는 필요한 만큼 원하는 수의 분기를 만들 수 있습니다.

    참고: 루트를 제외하고는 분기를 다른 분기에 연결할 수 없습니다.

  7. 완료된 뼈대의 요소를 재배치하려면 뼈 또는 인스턴스 자체를 드래그합니다.

    • 뼈를 드래그하면 연관된 인스턴스가 움직이지만 뼈를 기준으로 회전하지는 않습니다.
    • 인스턴스를 드래그하면 인스턴스가 움직이고 뼈를 기준으로 회전합니다.
    • 분기 가운데의 인스턴스를 드래그하면 부모 뼈를 연결점 회전으로 구조화할 수 있습니다. 자식 뼈는 연결점 회전 없이 움직입니다.

    뼈대를 만든 후에도 다른 레이어에서 뼈대로 새 인스턴스를 추가할 수 있습니다. 새 뼈를 새 인스턴스로 드래그하면 Animate에서 인스턴스를 뼈대의 포즈 레이어로 이동합니다.

모양에 뼈 추가

단일 모양에 또는 같은 레이어에 있는 모양 그룹에 뼈를 추가합니다. 어떤 경우이든 첫 번째 뼈를 추가하기 전에 모든 모양을 선택해야 합니다. 뼈가 추가된 후에는 Animate에서 모든 모양 및 뼈를 IK 모양 객체로 변환하고 객체를 새 포즈 레이어로 이동합니다.

모양에 뼈를 추가한 후에는 해당 모양에 다음과 같은 제한이 적용됩니다.

  • IK 모양을 모양 밖에 있는 다른 모양과 병합할 수 없습니다.
  • [자유 변형 도구]를 사용하여 모양을 회전하거나, 크기 조절하거나, 기울일 수 없습니다.
  • 모양의 제어점을 편집하는 것이 바람직하지 않습니다.
  1. 스테이지에 채워진 모양을 만듭니다.

    모양에는 여러 색상과 획이 포함될 수 있습니다. 가능한 최종 형태에 근접하도록 모양을 편집합니다. 모양에 뼈를 추가하면 모양을 편집하는 옵션이 훨씬 제한됩니다.

    모양이 너무 복잡한 경우에는 뼈를 추가하기 전에 동영상 클립으로 변환하라는 메시지가 나타납니다.

  2. 스테이지에서 전체 모양을 선택합니다.

    모양에 여러 개의 색상 영역이나 획이 있는 경우 모양 주변의 선택 사각형을 드래그하여 전체 모양이 선택되도록 합니다.

  3. [도구] 패널에서 [뼈] 도구를 선택합니다.

  4. 뼈 도구로 모양 내부를 클릭하고 모양 내 다른 위치로 드래그합니다.

  5. 다른 뼈를 추가하려면 첫 번째 뼈의 꼬리를 모양 내 다른 위치로 드래그합니다.

    두 번째 뼈는 루트 뼈의 자식이 됩니다. 만들려는 부모-자식 관계 순서대로 모양의 영역을 뼈와 연결합니다. 어깨에서 팔꿈치 그리고 손목으로의 연결을 예로 들 수 있습니다.

  6. 분기형 뼈대를 만들려면 분기가 시작되도록 할 기존 뼈의 머리 부분을 클릭합니다. 그런 다음 드래그하여 새 분기의 첫 번째 뼈를 만듭니다.

    뼈대에는 필요한 만큼 원하는 수의 분기를 만들 수 있습니다.

    참고: 루트를 제외하고는 분기를 다른 분기에 연결할 수 없습니다.

  7. 뼈대를 이동하려면 선택 도구로 IK 모양 객체를 선택한 다음 뼈를 드래그하여 이동합니다.

모양이 IK 모양이 된 후에는 다음과 같은 제한이 적용됩니다.

  • 더 이상 모양을 변형(크기 조절 또는 기울이기)할 수 없습니다.
  • 모양에 새 획을 추가할 수 없습니다. 모양의 기존 획에서 제어점을 추가하거나 제거하는 것은 여전히 가능합니다.
  • 배치된 모양을 편집할 수 없습니다(스테이지에서 두 번 클릭하는 방법으로).
  • 모양에는 고유의 등록 포인트, 변형점 및 경계 상자가 있습니다.

온-스테이지 컨트롤

온-스테이지 컨트롤을 사용하면 회전 범위 및 정밀도 컨트롤을 표시하는 안내선의 도움을 받으면서 스테이지 위에서 회전 및 평행 이동을 쉽게 조정할 수 있습니다. 또한 온-스테이지 컨트롤을 사용하면 회전을 조정하기 위해 속성 관리자로 되돌아갈 필요 없이 스테이지 위에서 계속 작업을 수행할 수 있습니다.

온-스테이지 컨트롤 사용 방법 설명
온-스테이지 컨트롤 사용 방법 설명

이미지 작업에서 뼈 도구의 온-스테이지 컨트롤은 다음과 같이 설명됩니다.
  1. 온-스테이지 컨트롤을 사용하여 작업하기 시작하려면 뼈를 선택하고 뼈의 머리 부분을 사용합니다.  
  2. 온-스테이지 컨트롤을 보려면 뼈의 머리 부분에 마우스 커서를 올려 놓습니다. 머리가 4방향 화살표 또는 원 안의 더하기 심볼(X축 및 Y축)로 바뀝니다. 화살표는 평행 이동 특성을 나타내고 원은 회전 특성을 나타냅니다.
  3. 뼈의 머리 부분을 클릭하고 원을 선택하여 회전을 편집하거나 더하기 심볼을 선택하여 평행 이동 특성을 편집합니다.  
  4. 언제든지 회전 및 평행 이동용 대화형 핸들을 표시하려면 뼈의 머리 부분에 마우스 커서를 올려 놓습니다.  
  5. 회전 또는 평행 이동 옵션을 클릭하면 제약 조건을 설정하는 온-스테이지 컨트롤이 표시됩니다.  

회전 컨트롤 사용

회전 컨트롤 설명
회전 컨트롤 설명

회전 컨트롤을 사용하여 작업하려면 다음을 수행합니다.

  1. 뼈 머리를 클릭하여 회전 도구 및 평행 이동 도구를 표시합니다.
  2. 회전 도구를 나타내는 원 위에 마우스 커서를 올려 놓은 후 클릭합니다. 원이 빨간색으로 바뀝니다.
  3. 자물쇠 아이콘을 클릭하여 자유 회전을 활성화합니다. 자물쇠 아이콘이 점으로 바뀝니다.
  4. 중심으로부터 멀리 마우스 커서를 이동하면 회전 반경의 한쪽 끝이 표시됩니다. 회전을 시작할 지점을 클릭합니다.
  5. 원 안의 커서를 다시 이동하여 회전 반경의 다른 쪽 끝을 선택합니다. 해당 포인트가 위치할 곳을 클릭합니다.
  6. 원을 클릭하여 반경 정의를 확인합니다.

참고: 이미 정의한 회전을 편집하는 경우 선을 클릭하고 드래그하는 방식으로 테두리를 증가 또는 감소시킬 수 있습니다.

평행 이동 컨트롤 사용

평행 이동 컨트롤 설명
평행 이동 컨트롤 설명

평행 이동 컨트롤을 다음과 같이 사용할 수 있습니다.

  1. 4방향 화살표가 있는 더하기 기호 위에 마우스 커서를 올린 후 클릭하여 평행 이동 컨트롤을 선택합니다.
  2. 자물쇠를 클릭하여 평행 이동 컨트롤을 활성화합니다. 자물쇠 아이콘이 점으로 바뀝니다.
  3. 화살표 머리를 클릭하고 확장할 이동 범위 지점까지 드래그합니다.

IK 뼈대 및 객체 편집

포즈 레이어가 타임라인의 첫 번째 프레임 뒤에 있는 포즈를 포함하는 경우 IK 뼈대를 편집할 수 없습니다. 편집하기 전에 타임라인에서 뼈대의 첫 번째 프레임 뒤에 있는 추가 포즈를 삭제합니다.

애니메이션을 만들 목적으로 간단히 뼈대를 재배치하는 경우 포즈 레이어의 원하는 프레임에서 위치를 변경할 수 있습니다. Animate에서 프레임을 포즈 프레임으로 변환합니다.

뼈 및 연관된 객체 선택

  • 개별 뼈를 선택하려면 선택 도구로 뼈를 클릭합니다. 뼈를 여러 개 선택하려면 Shift 키를 누른 상태에서 클릭합니다.
  • 선택 항목을 인접 뼈로 이동하려면 속성 관리자에서 [부모], [자식] 또는 [다음/이전] 형제 버튼을 클릭합니다.
  • 뼈대에서 뼈를 모두 선택하려면 뼈를 두 번 클릭합니다.
  • 전체 뼈대를 선택하고 뼈대 및 해당 포즈 레이어의 속성을 표시하려면 뼈대를 포함하는 포즈 레이어에서 프레임을 클릭합니다.
  • IK 모양을 선택하려면 모양을 클릭합니다.
  • 뼈에 연결된 심볼 인스턴스를 선택하려면 인스턴스를 클릭합니다.

뼈 및 연관된 객체 재배치

  • 선형 뼈대를 재배치하려면 뼈대의 뼈를 드래그합니다. 연결된 심볼 인스턴스가 뼈대에 포함되어 있으면 인스턴스를 드래그할 수도 있습니다. 이 방법으로 뼈에 맞춰 인스턴스를 회전할 수 있습니다.
  • 뼈대의 분기를 재배치하려면 분기의 뼈를 드래그합니다.
  • 해당 분기의 뼈가 모두 이동합니다. 뼈대에 있는 다른 분기의 뼈는 이동하지 않습니다.
  • 부모 뼈는 움직이지 않고 자식 뼈와 함께 뼈를 회전하려면 Shift 키를 누른 상태에서 뼈를 드래그합니다.
  • IK 모양을 스테이지의 새 위치로 이동하려면 모양을 선택하고 속성 관리자에서 X 및 Y 속성을 변경합니다. Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 채로 모양을 드래그할 수도 있습니다.

뼈 삭제

다음 중 하나를 수행합니다.

  • 개별 뼈와 해당 자식을 모두 삭제하려면 뼈를 클릭하고 Delete 키를 누릅니다.
  • Shift 키를 누른 상태에서 각 뼈를 클릭하면 삭제할 뼈를 여러 개 선택할 수 있습니다.
  • 타임라인의 IK 모양 또는 심볼 뼈대에서 모든 뼈를 삭제하려면 타임라인에서 IK 뼈대 모양을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 [뼈대 제거]를 선택합니다.
  • 스테이지의 IK 모양 또는 심볼 뼈대에서 모든 뼈를 삭제하려면 뼈대에서 뼈를 두 번 클릭하여 모든 뼈를 선택합니다. 그런 다음 Delete 키를 누릅니다. IK 모양이 일반 모양으로 되돌아갑니다.

연관된 모양 또는 심볼을 기준으로 뼈 이동

  • IK 모양 내 뼈의 한쪽 끝 위치를 이동하려면 세부 선택 도구로 뼈 끝을 드래그합니다.

참고: IK 범위에 여러 개의 포즈가 있는 경우에는 [세부 선택 도구]가 작동하지 않습니다. 편집하기 전에 타임라인에서 뼈대의 첫 번째 프레임 뒤에 있는 추가 포즈를 삭제합니다.

  • 심볼 인스턴스 내 뼈 연결점, 머리 또는 꼬리의 위치를 이동하려면 인스턴스의 변형점을 이동합니다. 자유 변형 도구 사용. 변형점과 함께 뼈가 이동합니다.
  • 다른 연결된 인스턴스는 이동하지 않고 개별 심볼 인스턴스를 이동하려면 Alt 키(Windows) 또는 Command 키(Macintosh)를 누른 상태에서 인스턴스를 드래그하거나 자유 변형 도구로 드래그합니다. 인스턴스에 연결된 뼈 길이가 인스턴스의 새 위치에 맞게 늘어나거나 줄어듭니다.

IK 모양 편집

세부 선택 도구를 사용하여 IK 모양의 윤곽선 제어점을 추가, 삭제 및 편집할 수 있습니다.

  • IK 모양을 변경하지 않고 뼈의 위치를 이동하려면 뼈의 끝점을 드래그합니다.
  • IK 모양 경계의 제어점을 표시하려면 모양의 획을 클릭합니다.
  • 제어점을 이동하려면 제어점을 드래그합니다.
  • 새 제어점을 추가하려면 획에서 제어점이 없는 부분을 클릭합니다.
  • 기존 제어점을 삭제하려면 제어점을 클릭하여 선택한 다음 Delete 키를 누릅니다.

참고: IK 모양은 변형(크기 조절 또는 기울이기)될 수 없습니다.

모양 점에 뼈 바인딩

기본적으로 모양의 제어점은 가장 가까운 뼈에 연결되어 있습니다. 바인딩 도구를 사용하여 개별 뼈와 모양 제어점 간의 연결을 편집할 수 있습니다. 이 방법으로 각 뼈가 움직일 때 획이 어떻게 왜곡되는지를 제어할 수 있습니다. 이 기술은 뼈대가 움직일 때 모양의 획이 원하는 대로 왜곡되지 않는 경우에 유용합니다.

여러 제어점을 한 뼈에 바인딩할 수 있고 여러 뼈를 한 제어점에 바인딩할 수도 있습니다.

  • 뼈에 연결된 제어점을 강조 표시하려면 [바인딩] 도구를 사용하여 뼈를 클릭합니다.

    연결된 지점이 노란색으로 강조 표시되고 선택된 뼈가 빨간색으로 강조 표시됩니다. 하나의 뼈에만 연결된 제어점은 사각형으로 나타납니다. 여러 개의 뼈에 연결된 제어점은 삼각형으로 나타납니다.

  • 선택한 뼈에 제어점을 추가하려면 강조되지 않은 제어점을 Shift 키를 누른 상태로 클릭합니다.

    Shift 키를 누른 상태에서 드래그하면 선택된 뼈에 추가할 제어점을 여러 개 선택할 수도 있습니다.

  • 뼈에서 제어점을 제거하려면 Ctrl 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 노란색으로 강조 표시된 제어점을 클릭합니다.

    Ctrl 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 드래그하여 선택된 뼈에서 여러 개의 제어점을 제거할 수도 있습니다.

  • 제어점에 연결된 뼈를 강조 표시하려면 [바인딩] 도구를 사용하여 제어점을 클릭합니다.

    연결된 뼈가 노란색으로 강조 표시되고 선택된 제어점이 빨간색으로 강조 표시됩니다.

  • 선택된 제어점에 다른 뼈를 추가하려면 Shift 키를 누른 상태에서 뼈를 클릭합니다.

  • 선택된 제어점에서 뼈를 제거하려면 Ctrl 키(Windows) 또는 Option 키(Macintosh)를 누른 상태에서 노란색으로 강조 표시된 뼈를 클릭합니다.

IK 뼈의 모션 제한

IK 뼈대의 모션을 더욱 실감나게 만들기 위해 특정 뼈의 모션 자유도를 제어할 수 있습니다. 예를 들어 팔꿈치가 잘못된 방향으로 구부러지지 않도록 팔의 두 뼈를 제한할 수 있습니다.

기본적으로 각 IK 뼈에는 뼈가 만들어질 때 고정된 길이가 할당됩니다. 뼈는 상위 연결점을 중심으로 그리고 x축 및 y축을 따라 회전할 수 있습니다. 하지만 x축 또는 y축 모션이 활성화된 경우가 아니라면 부모 뼈의 길이가 변경되어야 하는 방법으로는 이동할 수 없습니다. 기본적으로 뼈 회전은 활성화되어 있고 x축 및 y축 모션은 비활성화되어 있습니다.

뼈에 가중 효과를 만들기 위해 뼈의 모션 속도를 제한할 수도 있습니다.

여러 개의 뼈가 줄줄이 연결된 뼈대에서는 뼈대의 분기에 있는 마지막 연결점의 모션을 제한할 수 없습니다. 마지막 연결점을 제한하는 것처럼 보이게 하려면 동영상 클립이 있는 뼈를 사용하고 마지막 뼈를 알파 속성이 0으로 설정되어 있는 동영상 클립에 연결하십시오. 그런 다음 마지막 뼈 대신 마지막에서 두 번째 뼈를 제한하십시오.

예제:

  • 팔의 경우 팔뚝의 정상적인 모션 범위를 벗어나 회전하지 않도록 팔꿈치의 회전 각도를 제한할 수 있습니다.

  • 캐릭터가 스테이지를 건너서 이동할 수 있도록 하려면 루트 뼈에서 X 또는 Y 평행 이동을 설정합니다. 보다 정확한 움직임을 위해 X 및 Y 평행 이동을 사용할 때는 회전을 해제하십시오.

하나 이상의 뼈가 선택되어 있을 때 속성 관리자에서 이러한 속성을 설정합니다.

  • 선택된 뼈가 x축 및 y축을 따라 움직이고 부모 뼈의 길이가 바뀌도록 하려면 속성 관리자의 [연결점: X 평행 이동] 또는 [연결점: Y 평행 이동] 섹션에서 [활성화]를 선택합니다.

    연결점의 뼈와 수직으로 양방향 화살표가 표시되면 x축 모션이 활성화되어 있음을 나타냅니다. 연결점의 뼈와 수평으로 양방향 화살표가 표시되면 y축 모션이 활성화되어 있음을 나타냅니다. 뼈에 대해 x 및 y 평행 이동을 모두 활성화하면 뼈에 대해 회전이 비활성화되어 있을 때 뼈를 배치하는 작업이 간단해집니다.

  • x축 및 y축을 따라 활성화되는 모션의 양을 제한하려면 속성 관리자의 [연결점: X 평행 이동] 또는 [연결점: Y 평행 이동] 섹션에서 [제한]을 선택하고 뼈가 움직일 수 있는 최소 및 최대 길이 값을 입력합니다.

  • 선택된 뼈가 연결점 주위로 회전하지 못하도록 하려면 속성 관리자의 [연결점: 회전] 섹션에서 [활성화] 체크 상자를 선택 취소합니다.

    이 체크 상자는 기본적으로 선택되어 있습니다.

  • 뼈의 회전을 제한하려면 속성 관리자의 [연결점: 회전] 섹션에서 최소 및 최대 회전 각도를 입력합니다.

    회전 각도는 부모 뼈 기준의 상대적인 값입니다. 뼈 연결점 맨 위에 회전 자유도를 나타내는 부채꼴이 나타납니다.

  • 선택된 뼈가 부모 뼈를 기준으로 고정되도록 하려면 회전 및 x, y축 평행 이동을 비활성화합니다.

    뼈가 경직되고 부모의 모션을 따릅니다.

  • 선택된 뼈의 모션 속도를 제한하려면 속성 관리자의 [연결점 속도] 필드에 값을 입력합니다.

    연결점 속도는 뼈에 가중 효과를 줍니다. 최대값 100%는 무제한 속도에 해당합니다.

뼈에 반동 추가

두 가지 뼈 속성을 사용하여 IK 뼈에 반동을 추가할 수 있습니다. 뼈의 강도 및 반동 속성은 뼈 IK 시스템에 동적 물리학을 통합하여 IK 뼈에 현실감 있는 물리적 움직임을 부여해 줍니다. 이러한 속성을 이용하면 물리적으로 향상된 애니메이션을 보다 쉽게 만들 수 있습니다. 강도 및 감폭 속성은 뼈 애니메이션에 구성 수준이 높은 실제적인 움직임을 제공합니다. 포즈 레이어에 포즈를 추가하기 전에 이러한 속성을 설정하는 것이 가장 좋습니다.

강도: 반동의 강도입니다. 값이 높을수록 반동 강도가 세집니다.

감폭: 반동 효과의 감소율입니다. 값이 높을수록 반동이 더 빠르게 감소됩니다. 값이 0이면 포즈 레이어의 프레임 전체에서 반동이 전체 강도로 유지됩니다.

반동을 설정하려면 뼈를 하나 이상 선택하고 속성 관리자의 반동 섹션에서 강도 및 감폭 값을 설정합니다. 강도가 높아질수록 반동은 보다 경직됩니다. 감폭은 반동 효과의 감소율을 결정합니다. 따라서 감폭 값이 높을수록 애니메이션은 보다 빨리 끝납니다.

강도 및 감폭 속성을 해제하려면 타임라인에서 포즈 레이어를 선택하고 속성 관리자의 반동 섹션에서 [사용] 체크 상자의 선택을 해제합니다. 이렇게 하면 반동 속성 효과 없이 포즈 레이어에 정의한 포즈가 스테이지에 표시됩니다.

반동 속성을 사용할 경우 뼈 애니메이션의 최종 모양에 영향을 주는 요소는 다음과 같습니다. 원하는 최종 모양을 얻을 수 있도록 이러한 각 요소를 조정하여 실험해 보십시오.

  • 강도 속성 값

  • 감폭 속성 값

  • 포즈 레이어의 포즈 사이에 있는 프레임 수

  • 포즈 레이어의 총 레이어 수

  • 최종 포즈와 포즈 레이어의 마지막 프레임 사이의 프레임 수

뼈대 애니메이션 만들기

IK 뼈대 애니메이션을 만드는 방법은 Animate의 다른 객체들과 다릅니다. 뼈대에서는 간단히 포즈 레이어에 프레임을 추가하고 스테이지에 뼈대를 재배치하여 키프레임을 만들기만 하면 됩니다. 포즈 레이어의 키프레임을 포즈라고 합니다. IK 뼈대는 일반적으로 애니메이션 목적으로 사용되므로 각 포즈 레이어는 자동으로 트윈 레이어의 역할을 담당합니다.

그러나 IK 포즈 레이어에서는 뼈 위치 외의 속성을 트위닝할 수 없다는 점에서 트윈 레이어와 다릅니다. 위치, 변형, 색상 효과, 필터 등의 다른 IK 객체 속성을 트위닝하려면 동영상 클립이나 그래픽 심볼 안에 뼈대 및 연관된 객체가 포함되도록 합니다. 그러면 [삽입] > [모션 트윈] 명령과 [모션 편집기] 패널을 사용하여 심볼의 속성에 애니메이션 효과를 적용할 수 있습니다.

또한 런타임 시 ActionScript 3.0으로 IK 뼈대에 애니메이션을 적용할 수도 있습니다. ActionScript로 뼈대에 애니메이션을 적용하려는 경우 타임라인에서는 애니메이션을 적용할 수 없습니다. 뼈대는 포즈 레이어에 포즈를 하나만 가질 수 있습니다. 해당 포즈는 포즈 레이어에서 뼈대가 나타나는 첫 번째 프레임에 있어야 합니다.

애니메이션 도중 편집 컨트롤 숨기기

모든 온-스테이지 컨트롤을 활성화한 상태로 계속 유지하면 뼈대의 위치와 속성을 부주의하게 변경할 수도 있습니다. 애니메이션의 뼈와 뼈대를 만든 후 속성 관리자에서 [뼈대 편집 컨트롤 및 힌트 숨기기] 체크 상자를 선택하여 뼈대 편집 컨트롤 및 힌트를 해제할 수 있습니다.

타임라인에서 뼈대 애니메이션 만들기

IK 뼈대는 타임라인의 포즈 레이어에 존재합니다. 타임라인에서 뼈대 애니메이션을 만들려면 포즈 레이어에서 프레임을 마우스 오른쪽 버튼으로 클릭하고 [포즈 삽입]을 선택하여 포즈를 삽입합니다. 선택 도구를 사용하여 뼈대 구성을 변경합니다. Animate에서 자동으로 포즈 사이의 프레임에 뼈 위치를 보간합니다.

  1. 필요한 경우 타임라인에서 뼈대의 포즈 레이어에 프레임을 추가하여 만들려는 애니메이션을 위한 공간을 확보합니다.

    포즈 레이어에서 기존 프레임의 오른쪽에 있는 프레임을 마우스 오른쪽 버튼(Windows)으로 클릭하거나 Option 키(Macintosh)를 누른 상태에서 클릭하고 [프레임 삽입]을 선택하여 프레임을 추가합니다. 나중에 언제든지 프레임을 추가하거나 삭제할 수 있습니다.

  2. 포즈 레이어의 프레임에 포즈를 추가하려면 다음 중 하나를 수행합니다.
    • 포즈를 추가하려는 프레임에 재생 헤드를 배치한 다음 스테이지에 뼈대를 재배치합니다.

    • 포즈 레이어의 프레임을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Option 키를 누른 상태에서 클릭(Macintosh)하고 [포즈 삽입]을 선택합니다.

    • 포즈를 추가하려는 프레임에 재생 헤드를 배치한 다음 F6 키를 누릅니다.

    Animate에서 현재 프레임의 포즈 레이어에 포즈를 삽입합니다. 프레임에 있는 마름모 모양의 포즈 표시자는 새 포즈를 나타냅니다.

  3. 별도의 프레임에 다른 포즈를 추가하여 만족스러우면 애니메이션을 완료합니다.
  4. 타임라인에서 애니메이션의 길이를 변경하려면 크기 조정 커서가 나타날 때까지 뼈대의 마지막 프레임 위에 마우스 커서를 올려놓습니다. 그런 다음 포즈 레이어의 마지막 프레임을 오른쪽 또는 왼쪽으로 드래그하여 프레임을 추가하거나 제거합니다.

    Animate에서 레이어의 기간 변경에 비례하여 포즈 프레임을 재배치하고 그 사이 프레임을 보간합니다. 포즈 프레임의 위치에 영향을 주지 않고 타임라인에서 뼈대 범위의 크기를 조정하려면 Shift 키를 누른 채로 뼈대 범위의 마지막 프레임을 드래그합니다.

작업을 마쳤으면 타임라인에서 재생 헤드를 이동하여 애니메이션을 미리 봅니다. 포즈 프레임 사이에 보간된 뼈대 위치를 볼 수 있습니다.

언제든지 포즈 프레임에서 뼈대를 재배치하거나 새 포즈 프레임을 추가할 수 있습니다.

뼈대에서 포즈의 위치 편집

다음과 같은 방법으로 포즈의 위치를 편집할 수 있습니다.

  • 포즈를 새 위치로 이동하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 채로 포즈를 클릭한 후에 포즈를 뼈대에서 새 위치로 드래그합니다.

  • 포즈를 새 위치에 복사하려면 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 채로 포즈를 클릭한 후에 Alt 키(Windows) 또는 Option 키(Macintosh)를 누른 채로 포즈를 뼈대에서 새 위치로 드래그합니다.

  • 잘라내기, 복사 및 붙여넣기. Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 채로 잘라내거나 복사할 포즈를 클릭하고 컨텍스트 메뉴에서 [포즈 잘라내기] 또는 [포즈 복사]를 선택합니다.

    그런 다음 Ctrl 키(Windows) 또는 Command 키(Macintosh)를 누른 채로 붙여넣을 뼈대 범위에서 프레임을 클릭하고 컨텍스트 메뉴에서 [포즈 붙여넣기]를 선택합니다.

IK 객체 속성에 트위닝된 효과 추가 적용

뼈 위치 이외의 IK 객체 속성에 트위닝된 효과를 적용하려면 동영상 클립 또는 그래픽 심볼 안에 객체를 포함해야 합니다.

  1. IK 뼈대 및 연관된 모든 객체를 선택합니다.

    IK 모양의 경우 간단히 모양을 클릭할 수 있습니다. 연결된 심볼 인스턴스 집합의 경우 타임라인에서 포즈 레이어를 클릭하거나 스테이지에서 연결된 모든 심볼 주위의 선택 윤곽을 드래그합니다.

  2. 선택 항목을 마우스 오른쪽 버튼으로 클릭(Windows)하거나 Control 키를 누른 상태에서 클릭(Macintosh)하고 컨텍스트 메뉴에서 [심볼로 변환]을 선택합니다.
  3. [심볼로 변환] 대화 상자에서 심볼의 이름을 입력하고 [유형] 메뉴에서 [동영상 클립] 또는 [그래픽]을 선택합니다. [확인]을 클릭합니다.

    Animate에서 해당 뼈대의 포즈 레이어를 포함하는 고유의 타임라인으로 심볼을 만듭니다.

  4. FLA 파일의 기본 타임라인에서 새 심볼을 사용하려면 라이브러리에서 스테이지로 심볼을 드래그합니다.

    이제 스테이지에서 새 심볼 인스턴스에 모션 트윈 효과를 추가할 수 있습니다.

원하는 효과를 만들기 위해 필요한 만큼 다른 중첩된 심볼의 여러 레이어 안에 IK 뼈대를 포함하는 심볼을 중첩할 수 있습니다.

ActionScript 3.0의 런타임 애니메이션을 위한 뼈대 준비

ActionScript 3.0을 사용하여 모양 또는 동영상 클립 인스턴스에 연결된 IK 뼈대를 제어할 수 있습니다. 하지만 그래픽 또는 버튼 심볼 인스턴스에 연결된 뼈대는 ActionScript를 사용하여 제어할 수 없습니다.

단일 포즈를 가진 뼈대만 ActionScript로 제어할 수 있습니다. 여러 개의 포즈를 가진 뼈대는 타임라인에서만 제어할 수 있습니다.

  1. [선택 도구]로 포즈 레이어에서 뼈대가 포함된 프레임을 선택합니다.
  2. 속성 관리자의 [유형] 메뉴에서 [런타임]을 선택합니다.

이제 런타임에 ActionScript 3.0으로 계층 구조를 조작할 수 있습니다.

기본적으로 속성 관리자의 뼈대 이름은 포즈 레이어 이름과 같습니다. 이 이름을 사용하여 ActionScript에서 뼈대를 참조합니다. 속성 관리자에서 이름을 변경할 수 있습니다.

IK 애니메이션에 부드러움 추가

부드럽게는 보다 실감나는 모션을 위해 각 포즈 주위의 프레임에서 애니메이션 속도를 조정하는 것입니다.

  1. 포즈 레이어에서 두 포즈 프레임 사이에 있는 프레임을 선택하거나 포즈 프레임을 선택합니다.
    • 중간 프레임: 부드럽게가 선택된 프레임의 왼쪽과 오른쪽에 있는 포즈 프레임 사이의 프레임에 영향을 줍니다.
    • 포즈 프레임: 부드럽게가 레이어에서 선택된 포즈와 그 다음 포즈 사이에 있는 프레임에 영향을 줍니다.
  2. 속성 관리자의 [부드럽게] 메뉴에서 부드럽게 유형을 선택합니다. 
    • 간단한 곡선 부드럽게: 선택한 프레임 직후 또는 직전의 프레임에서 모션을 느리게 만드는 네 개의 부드럽게 옵션입니다. 
    • 시작 및 중지 부드럽게: 이전 포즈 프레임 직후의 프레임 및 다음 포즈 프레임 직전의 프레임에서 모션을 느리게 만듭니다. 
  3. 참고: 이와 같은 부드럽게 유형은 모션 트윈을 사용할 때 모션 편집기에서 사용 가능합니다. 타임라인에서 모션 트윈을 선택할 때 모션 편집기에서 각 부드럽게 유형의 곡선을 볼 수 있습니다.

  4. 속성 관리자에서 부드럽게의 [강도] 값을 입력합니다.

    기본 [강도]는 0이며 부드럽게가 없는 것에 해당합니다. 최대값은 100이며 포즈 프레임 앞의 프레임에 가장 뚜렷한 부드럽게 효과를 적용합니다. 최소값은 -100이며 이전 포즈 프레임 바로 뒤의 프레임에 가장 뚜렷한 부드럽게 효과를 적용합니다. 작업을 마쳤으면 스테이지에서 부드럽게가 적용된 모션을 미리 봅니다. 타임라인에서 부드럽게를 적용한 두 포즈 프레임 사이로 재생 헤드를 이동합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책