사용 안내서 취소

데스크톱 Adobe AIR용 제작

  1. Adobe Animate 사용 안내서
  2. Animate 소개
    1. Animate의 새로운 기능
    2. 시각적 용어집
    3. Animate 시스템 요구 사항
    4. Animate 키보드 단축키
    5. Animate에서 여러 파일 유형을 사용하여 작업하기
  3. 애니메이션
    1. Animate의 애니메이션 기본 사항
    2. Animate에서 프레임 및 키프레임을 사용하는 방법
    3. Animate의 프레임별 애니메이션
    4. Animate에서 클래식 트윈 애니메이션으로 작업하는 방법
    5. 브러시 도구
    6. 모션 안내선
    7. 모션 트윈 및 ActionScript 3.0
    8. 모션 트윈 애니메이션 정보
    9. 모션 트윈 애니메이션
    10. 모션 트윈 애니메이션 만들기
    11. 속성 키프레임 사용
    12. 트윈으로 위치에 애니메이션 적용
    13. 모션 편집기를 사용하여 모션 트윈을 편집하는 방법
    14. 트윈 애니메이션의 모션 경로 편집
    15. 모션 트윈 조작
    16. 사용자 정의 속도 추가
    17. 모션 사전 설정 만들기 및 적용
    18. 애니메이션 트윈 범위 설정
    19. XML 파일로 저장한 모션 트윈을 사용한 작업
    20. 모션 트윈과 클래식 트윈의 비교
    21. 모양 트윈 만들기
    22. Animate에서 뼈 도구 애니메이션 사용하기
    23. Animate에서 캐릭터 리깅으로 작업하기
    24. Adobe Animate에서 마스크 레이어를 사용하는 방법
    25. Animate에서 장면으로 작업하는 방법
  4. 대화형 기능
    1. Animate로 버튼을 만드는 방법
    2. Animate 프로젝트를 다른 문서 유형 포맷으로 변환
    3. Animate에서 HTML5 Canvas 문서를 만들고 게시하기
    4. Animate에서 코드 조각을 사용하여 대화형 기능 추가하기
    5. 사용자 정의 HTML5 구성 요소 만들기
    6. HTML5 Canvas의 구성 요소 사용
    7. 사용자 정의 구성 요소 만들기: 예제
    8. 사용자 정의 구성 요소의 코드 조각
    9. 모범 사례 - Animate를 사용한 광고
    10. 가상 현실 제작 및 게시
  5. 작업 영역 및 작업 과정
    1. 칠 브러시 만들기 및 관리
    2. HTML5 Canvas 문서에서 Google Fonts 사용
    3. Creative Cloud 라이브러리와 Adobe Animate 사용
    4. Animate의 스테이지 및 도구 패널 사용
    5. Animate 작업 과정 및 작업 영역
    6. HTML5 Canvas 문서에서 웹 글꼴 사용
    7. 타임라인과 ActionScript
    8. 여러 타임라인을 사용한 작업
    9. 환경 설정
    10. Animate 제작 패널 사용
    11. Animate로 타임라인 레이어 만들기
    12. 모바일 앱 및 게임 엔진용으로 애니메이션 내보내기
    13. 객체 이동 및 복사
    14. 템플릿
    15. Animate의 찾기 및 바꾸기
    16. 실행 취소, 다시 실행 및 작업 내역 패널
    17. 키보드 단축키
    18. Animate에서 타임라인을 사용하는 방법
    19. HTML 확장 만들기
    20. 이미지 및 애니메이션 GIF에 대한 최적화 옵션
    21. 이미지 및 GIF에 대한 내보내기 설정
    22. Animate의 에셋 패널
  6. 멀티미디어 및 비디오
    1. Animate의 그래픽 객체 변형 및 결합
    2. Animate에서 심볼 인스턴스를 만들고 작업하기
    3. 이미지 추적
    4. Adobe Animate에서 사운드를 사용하는 방법
    5. SVG 파일 내보내기
    6. Animate에서 사용할 비디오 파일 만들기
    7. Animate에서 비디오를 추가하는 방법
    8. 비디오 큐 포인트를 사용한 작업
    9. Animate로 객체 그리고 만들기
    10. 선 및 모양 변형
    11. Animate CC의 획, 채우기 및 그래디언트
    12. Adobe Premiere Pro 및 After Effects 작업
    13. Animate CC의 색상 패널
    14. Animate에서 Flash CS6 파일 열기
    15. Animate의 클래식 텍스트 작업
    16. Animate에 아트워크 가져오기
    17. Animate의 가져온 비트맵
    18. 3D 그래픽
    19. Animate의 심볼 작업
    20. Adobe Animate로 선 및 모양 그리기
    21. Animate의 라이브러리 작업
    22. 사운드 내보내기
    23. Animate CC의 객체 선택
    24. Animate의 Illustrator AI 파일 작업
    25. 스프레이 브러시 도구로 패턴 적용하기
    26. 블렌드 모드 적용
    27. 객체 배열
    28. 명령 메뉴를 사용한 작업 자동화
    29. 다국어 텍스트
    30. Animate에서 카메라 사용하기
    31. Animate를 Adobe Scout와 함께 사용하기
    32. Fireworks 파일 작업
    33. 그래픽 필터
    34. 사운드 및 ActionScript
    35. 드로잉 환경 설정
    36. 펜 도구로 그리기
  7. 플랫폼
    1. Animate 프로젝트를 다른 문서 유형 포맷으로 변환
    2. 사용자 정의 플랫폼 지원
    3. Animate에서 HTML5 Canvas 문서 만들고 게시하기
    4. WebGL 문서 만들고 게시하기
    5. iOS용 AIR에 맞추어 애플리케이션을 패키징하는 방법
    6. Android용 AIR 애플리케이션 게시
    7. 데스크톱용 Adobe AIR에 맞춘 게시
    8. ActionScript 게시 설정
    9. 모범 사례 - 애플리케이션에서 ActionScript 구성
    10. Animate에서 ActionScript를 사용하는 방법
    11. 모범 사례 - 액세스 가능성 지침
    12. Animate 작업 영역의 액세스 가능성
    13. 스크립트 작성 및 관리
    14. 사용자 정의 플랫폼에 대한 지원 활성화
    15. 사용자 정의 플랫폼 지원 개요
    16. 액세스 가능한 콘텐츠 만들기
    17. 사용자 정의 플랫폼 지원 플러그인 작업
    18. ActionScript 3.0 디버깅
    19. 사용자 정의 플랫폼에 대한 지원 활성화
  8. 내보내기 및 게시
    1. Animate CC에서 파일을 내보내는 방법
    2. OAM 게시
    3. SVG 파일 내보내기
    4. Animate를 사용하여 그래픽 및 비디오 내보내기
    5. AS3 문서 게시
    6. 모바일 앱 및 게임 엔진용으로 애니메이션 내보내기
    7. 사운드 내보내기
    8. QuickTime 비디오 파일 내보내기
    9. ActionScript로 외부 비디오 재생 제어하기
    10. 모범 사례 - 모바일 장치 콘텐츠 만들기 팁
    11. 모범 사례 - 비디오 규칙
    12. 모범 사례 - SWF 애플리케이션 제작 지침
    13. 모범 사례 - FLA 파일 구조화
    14. Animate용 FLA 파일을 최적화하는 모범 사례
    15. ActionScript 게시 설정
    16. Animate용 게시 설정 지정
    17. 프로젝터 파일 내보내기
    18. 이미지 및 애니메이션 GIF 내보내기
    19. HTML 게시 템플릿
    20. Adobe Premiere Pro 및 After Effects 작업
    21. 애니메이션의 빠른 공유 및 게시

Adobe AIR

Adobe® AIR™는 운영 체제에 상관없이 사용 가능한 런타임으로, 기존 웹 개발 기술(Adobe® Animate®, Adobe® Flex™, Adobe® Flash Builder™ HTML, JavaScript®, Ajax)을 활용하여 RIA(Rich Internet Application)를 만들고 데스크톱에 배포할 수 있도록 합니다. AIR를 사용하면 익숙한 환경에서 작업하면서 가장 편안한 도구와 접근 방식을 활용하고 Animate, Flex, HTML, JavaScript 및 Ajax 지원을 기반으로 필요에 맞는 최적의 환경을 구축할 수 있습니다.

사용자는 기본 데스크톱 애플리케이션과 상호 작용할 때와 같은 방식으로 AIR 애플리케이션과 상호 작용합니다. 런타임이 사용자의 컴퓨터에 설치되면 AIR 애플리케이션이 설치되고 다른 데스크톱 애플리케이션과 마찬가지로 실행됩니다. 런타임은 애플리케이션을 배포하기 위한 일관된 크로스 운영 체제 플랫폼과 프레임워크를 제공하므로 데스크톱 전반에서 일관된 기능과 상호 작용을 보장하여 크로스 브라우저 테스트를 제거합니다. 특정 운영 체제용이 아닌 런타임용으로 개발하십시오.

AIR는 애플리케이션 만들기, 배포 및 사용 방법을 동적으로 변경합니다. 독창적인 제어 기능을 활용하여 기존의 데스크톱 개발 기술을 익히지 않고도 Animate, Flex, HTML 및 Ajax 기반 애플리케이션을 데스크톱으로 확장할 수 있습니다.

데스크톱 및 모바일 AIR 애플리케이션의 하드웨어 및 소프트웨어 요구 사항에 대한 자세한 내용은 AIR 시스템 요구 사항을 참조하십시오.

Adobe AIR™ 애플리케이션 개발에 대한 자세한 내용은 Adobe AIR 애플리케이션 만들기를 참조하십시오.

Adobe AIR 파일 만들기

Animate 시작 화면 또는 [파일] > [새로 만들기] 명령을 사용하여 Adobe AIR Animate 문서를 만들거나, ActionScript® 3.0 Animate 파일을 만든 후 [제작 설정] 대화 상자를 통해 Adobe AIR 파일로 변환할 수 있습니다.

Adobe AIR 파일을 만들려면 다음 중 하나를 수행합니다.

  • Animate를 시작합니다. 그러면 시작 화면이 나타납니다. Animate를 이미 시작한 경우 열려 있는 문서를 모두 닫아 시작 화면으로 돌아갑니다. 시작 화면에서 [Adobe AIR 2(CS5)] 또는 [AIR(CS5.5)]를 선택합니다.

    참고: Animate 시작 화면을 비활성화한 경우 [편집] > [환경 설정]을 선택하고 [일반] 범주의 [실행할 때] 팝업 메뉴에서 [시작 화면]을 선택하여 다시 표시할 수 있습니다.

  • 화면 위쪽에서 [파일] > [새로 만들기] > 고급을 선택하고 [Adobe AIR 2 (CS5)] 또는 [AIR (CS5.5)]를 선택하고 [확인]을 클릭합니다.

Template_air
템플릿 Air

  • [제작 설정] 대화 상자([파일] > [제작 설정])의 [Animate] 탭에 있는 [플레이어] 메뉴에서 [Adobe AIR]를 선택하여 기존 Animate 파일을 열고 AIR 파일로 변환합니다.
참고:

(Flash CS5만 해당) Flash CS5 AIR 파일을 Flash CS4 포맷으로 저장하는 경우 Flash CS4에서 파일을 열 때 [제작 설정] 대화 상자에서 수동으로 플레이어 버전을 AIR 1.5로 설정하십시오. Flash CS4는 [제작 설정]을 AIR 1.5으로만 지정하도록 지원합니다.

Adobe AIR 애플리케이션 미리 보기 또는 제작

AIR 애플리케이션 윈도우에 나타나는 모양 그대로 AIR SWF 파일을 미리 볼 수 있습니다. 미리 보기는 애플리케이션을 패키지화하여 설치하지 않은 상태에서 애플리케이션의 시각적 모양을 확인하려는 경우 유용합니다.

  1. [제작 설정] 대화 상자의 [Animate] 탭에서 [대상] 설정을 [Adobe AIR]로 설정했는지 확인합니다.

  2. [컨트롤] > [동영상 테스트] > [테스트]를 선택하거나 Ctrl+Enter를 누릅니다.

[AIR - 애플리케이션 및 설치 프로그램 설정] 대화 상자를 통해 애플리케이션 설정을 지정하지 않은 경우 SWF 파일이 작성되는 폴더와 동일한 폴더에 기본 애플리케이션 설명자 파일(swfname-app.xml)이 생성됩니다. [AIR 애플리케이션 및 설치 프로그램 설정] 대화 상자를 사용하여 애플리케이션 설정을 지정한 경우 애플리케이션 설명자 파일에 해당 설정이 반영됩니다.

AIR 파일을 제작하려면 다음 중 하나를 수행합니다.

  • [제작 설정] 대화 상자에서 [제작] 버튼을 클릭합니다.

  • [AIR 애플리케이션 및 설치 프로그램 설정] 대화 상자에서 [제작] 버튼을 클릭합니다.

  • [파일] > [제작]을 선택합니다.

  • [파일] > [제작 미리 보기]를 선택합니다.

AIR 파일을 제작하면 Animate는 애플리케이션에 이미 추가된 다른 파일과 함께 SWF 파일, XML 애플리케이션 설명자 파일 및 두 파일의 패키지 복사본을 AIR 설치 프로그램 파일(swfname.air)에 만듭니다.

참고:

(Windows만 해당) 파일 이름에 영어가 아닌 문자가 포함된 경우 AIR 애플리케이션 제작이 실패합니다.

AIR 애플리케이션 및 설치 프로그램 파일 만들기

애플리케이션 개발이 끝난 후에는 배포에 필요한 AIR 애플리케이션 설명자 및 설치 프로그램 파일에 대한 설정을 지정합니다. 그러면 사용자가 AIR 파일을 제작할 때 Animate에서 SWF 파일과 함께 설명자 및 설치 프로그램 파일을 만듭니다.

[AIR - 애플리케이션 및 설치 프로그램 설정] 대화 상자에서 이러한 파일에 대한 설정을 지정합니다. AIR 파일을 만든 경우 속성 관리자 또는 [제작 설정] 대화 상자의 [Animate] 탭에서 [플레이어] 메뉴 [설정] 버튼을 통해 이 대화 상자를 열 수 있습니다.

Adobe AIR 애플리케이션 및 설치 프로그램 파일 만들기

  1. Animate에서 Adobe AIR 애플리케이션을 구성하는 FLA 파일 또는 파일 집합을 엽니다.

  2. [AIR 설정] 대화 상자를 열기 전에 Adobe AIR FLA 파일을 저장합니다.

  3. [파일] > [AIR 2 설정]을 선택합니다.

  4. [AIR 설정] 대화 상자를 완료한 다음 [제작]을 클릭합니다.

    [제작] 버튼을 클릭하면 SWF 파일, 애플리케이션 설명자 파일, 애플리케이션 아이콘 파일 및 [포함된 파일] 텍스트 상자에 나열되는 파일이 패키지화됩니다. 디지털 인증서를 아직 만들지 않은 경우 [제작] 버튼을 클릭하면 [디지털 서명] 대화 상자가 표시됩니다.

[AIR 애플리케이션 및 설치 프로그램 설정] 대화 상자는 [일반], [서명], [아이콘] 및 [고급]의 4가지 탭으로 나뉩니다. 이러한 설정에 대한 자세한 내용은 다음 단원을 참조하십시오.

일반 설정

[AIR 애플리케이션 및 설치 프로그램 설정] 대화 상자의 [일반] 탭에는 다음과 같은 옵션이 포함됩니다.

출력 파일

[제작] 명령을 사용할 때 만들 .air 파일의 이름 및 위치입니다.

출력 형식

만들 패키지의 유형입니다.

  • AIR 패키지 - AIR 런타임을 설치 중에 따로 다운로드할 수 있거나 AIR 런타임이 이미 대상 장치에 설치되어 있다고 가정하는 표준 AIR 설치 프로그램 파일을 만듭니다.
  • Mac 설치 프로그램 - 완전한 Macintosh 설치 프로그램 파일을 만듭니다.
  • 런타임이 포함된 애플리케이션 - 추가 다운로드가 필요 없도록 AIR 런타임이 포함된 AIR 설치 프로그램 파일을 만듭니다.

Windows 설치 프로그램

플랫폼에 독립적인 AIR 설치 프로그램(.air) 대신에 플랫폼별 기본 Windows 설치 프로그램(.exe)을 컴파일하려면 이 옵션을 선택합니다.

이름

애플리케이션의 주 파일 이름이며, 기본적으로 FLA 파일의 이름이 사용됩니다.

버전

선택 사항입니다. 애플리케이션의 버전 번호를 지정합니다. 기본값은 1.0입니다.

애플리케이션 ID

고유한 ID로 애플리케이션을 식별합니다. 원하는 대로 기본 ID를 변경할 수 있습니다. ID에 공백 또는 특수 문자를 사용하지 마십시오. 문자로는 0-9, a-z, A-Z, .(도트) 및 -(대시)만 사용할 수 있고, 문자열 길이는 1-212자여야 합니다. 기본적으로 com.adobe.example.applicationName이 사용됩니다.

설명

선택 사항입니다. 사용자가 애플리케이션을 설치할 때 설치 프로그램 윈도우에 표시될 애플리케이션에 대한 설명을 입력할 수 있습니다. 기본적으로 비어 있습니다.

저작권

선택 사항입니다. 저작권 고지 사항을 입력할 수 있습니다. 기본적으로 비어 있습니다.

윈도우 스타일

사용자가 컴퓨터에서 애플리케이션을 실행할 때 사용자 인터페이스에 사용할 윈도우 스타일(또는 크롬)을 지정합니다. 운영 체제에서 사용하는 표준 윈도우 시각적 스타일을 가리키는 [시스템 크롬](기본값)을 지정하거나 [사용자 정의 크롬(불투명)] 또는 [사용자 정의 크롬(투명)]을 지정할 수 있습니다. 시스템 크롬을 사용하지 않고 애플리케이션을 표시하려면 [없음]을 선택하십시오. [시스템 크롬]을 지정하면 애플리케이션에 운영 체제의 표준 윈도우 제어가 사용됩니다. [사용자 정의 크롬(불투명)]을 지정하면 애플리케이션에 표준 시스템 크롬을 사용하는 대신 사용자 정의 크롬을 만들 수 있습니다. 사용자 정의 크롬은 FLA 파일에서 직접 만듭니다. [사용자 정의 크롬(투명)]은 [사용자 정의 크롬(불투명)]과 유사하지만 페이지 가장자리에 투명 기능을 추가합니다. 이러한 기능을 통해 애플리케이션 윈도우가 정사각형이나 직사각형 모양이 되지 않게 만들 수 있습니다.

렌더링 모드

AIR 런타임이 그래픽 내용을 렌더링하는 데 사용하는 방법을 지정할 수 있습니다. 다음과 같은 옵션이 있습니다.

  • 자동 - 호스트 장치에서 사용할 수 있는 가장 빠른 렌더링 방법을 자동으로 감지하여 사용합니다.
  • CPU - CPU를 사용합니다.
  • 직접 - Stage3D를 사용하여 렌더링합니다. 이것이 가장 빠른 렌더링 방법입니다.

[직접] 모드를 지원하지 않는 프로세스 목록은 Stage3D 지원되지 않는 칩셋, 드라이버 | Flash Player 11, AIR 3을 참조하십시오.


프로파일

AIR 파일을 만들 때 포함할 프로파일입니다. AIR 애플리케이션을 특정 프로파일로 제한하려면 필요하지 않은 프로파일을 선택 취소하십시오. 

포함된 파일

애플리케이션 패키지에 포함시킬 추가 파일 및 폴더를 지정합니다. 파일을 추가하려면 더하기(+) 버튼을 클릭하고, 폴더를 추가하려면 폴더 버튼을 클릭합니다. 목록에서 파일 또는 폴더를 삭제하려면 해당 파일이나 폴더를 선택하고 빼기(-) 버튼을 클릭합니다.

기본적으로 애플리케이션 설명자 파일과 주 SWF 파일이 패키지 목록에 자동으로 추가됩니다. Adobe AIR FLA 파일을 아직 제작하지 않은 경우에도 패키지 목록에 이러한 파일이 표시됩니다. 패키지 목록에서 파일과 폴더는 단일 구조로 표시됩니다. 폴더의 파일은 나열되지 않으며 파일의 전체 경로 이름이 표시됩니다. 단, 필요에 따라 파일의 경로 이름이 잘립니다.

AIR 기본 확장 파일을 ActionScript 라이브러리 경로에 추가한 경우 해당 파일도 이 목록에 나타납니다.

아이콘 파일은 목록에 포함되지 않습니다. 파일이 패키지화될 때 SWF 파일 위치에 상대적인 임시 폴더에 아이콘 파일이 복사되고, 패키지화가 완료된 후 해당 폴더가 삭제됩니다.

서명 설정

[AIR 애플리케이션 및 설치 프로그램 설정] 대화 상자의 [서명] 탭에서는 애플리케이션의 코드 서명 인증서를 지정할 수 있습니다.

디지털 서명에 대한 자세한 내용은 애플리케이션에 서명AIR 파일에 디지털 서명을 참조하십시오.

아이콘 설정

[AIR 애플리케이션 및 설치 프로그램 설정] 대화 상자의 [아이콘] 탭에서는 애플리케이션의 아이콘을 지정할 수 있습니다. 애플리케이션 설치 후 Adobe AIR 런타임에서 애플리케이션을 실행하면 아이콘이 표시됩니다. 아이콘이 표시될 다양한 보기에 허용되는 네 가지 아이콘 크기(128, 48, 32 및 16픽셀)를 지정할 수 있습니다. 예를 들어, 파일 브라우저에서 아이콘을 축소판 보기, 자세히 보기 및 바둑판식 보기로 표시할 수 있습니다. 또한 데스크톱 아이콘으로 표시하거나 AIR 애플리케이션 윈도우의 제목 및 기타 위치에도 표시할 수 있습니다.

다른 아이콘 파일이 지정되지 않은 경우 기본적으로 샘플 AIR 애플리케이션 아이콘의 아이콘 이미지가 사용됩니다(Flash CS5만 해당).

아이콘을 지정하려면 [아이콘] 탭의 위쪽에서 아이콘 크기를 클릭한 다음 해당 크기에 사용할 파일로 이동합니다. 파일은 PNG(Portable Network Graphics) 포맷이어야 합니다.

이미지를 지정하는 경우 크기가 128x128, 48x48, 32x32 또는 16x16으로 정확해야 합니다. 특정 아이콘 크기에 대한 이미지를 지정하지 않을 경우 Adobe AIR는 제공된 이미지 중 하나의 크기를 조절하여 누락된 아이콘 이미지를 만듭니다.

고급 설정

[고급] 탭에서는 애플리케이션 설명자 파일의 추가 설정을 지정할 수 있습니다.

AIR 애플리케이션에서 처리해야 하는 모든 연결된 파일 유형을 지정할 수 있습니다. 예를 들어, 애플리케이션이 HTML 파일을 처리하는 주 애플리케이션으로 사용되도록 설정하려면 [연결된 파일 유형] 텍스트 상자에서 해당 내용을 지정하면 됩니다.

애플리케이션에 대해 다음과 같은 특성을 지정할 수도 있습니다.

  • 초기 윈도우의 크기 및 배치

  • 애플리케이션 설치 폴더

  • 애플리케이션을 배치할 프로그램 메뉴 폴더

대화 상자에는 다음 옵션이 포함되어 있습니다.

연결된 파일 유형

AIR 애플리케이션에서 처리할 연결된 파일 유형을 지정할 수 있습니다. 더하기(+) 버튼을 클릭하면 텍스트 상자에 새 파일 유형이 추가됩니다. 또한 더하기(+) 버튼을 클릭하면 [파일 유형 설정] 대화 상자가 표시됩니다. 빼기(-) 버튼을 클릭하면 텍스트 상자에서 선택한 항목이 제거됩니다. 연필모양 버튼을 클릭하면 [파일 유형 설정] 대화 상자가 표시되며 텍스트 상자에서 선택한 항목을 편집할 수 있습니다. 빼기(-) 버튼과 연필모양 버튼은 기본적으로 흐리게 표시됩니다. 텍스트 상자에서 항목을 선택하면 빼기(-) 버튼과 연필모양 버튼이 활성화되어 항목을 제거하거나 편집할 수 있습니다. 텍스트 상자의 기본값은 [없음]입니다.

윈도우 초기값 설정

초기 애플리케이션 윈도우에 대한 크기 및 배치 설정을 지정할 수 있습니다.

  • 폭: 윈도우의 초기 폭(픽셀 단위)을 지정합니다. 기본적으로 이 값은 비어 있습니다.

  • 높이: 윈도우의 초기 높이(픽셀 단위)를 지정합니다. 기본적으로 이 값은 비어 있습니다.

  • X: 윈도우의 초기 가로 위치(픽셀 단위)를 지정합니다. 기본적으로 이 값은 비어 있습니다.

  • Y: 윈도우의 초기 세로 위치(픽셀 단위)를 지정합니다. 기본적으로 이 값은 비어 있습니다.

  • 최대 폭 및 최대 높이: 윈도우의 최대 크기(픽셀 단위)를 지정합니다. 기본적으로 이러한 값은 비어 있습니다.

  • 최소 폭 및 최소 높이: 윈도우의 최소 크기(픽셀 단위)를 지정합니다. 기본적으로 이러한 값은 비어 있습니다.

  • 최대화 가능: 사용자의 윈도우 최대화 가능 여부를 지정할 수 있습니다. 기본적으로 이 옵션은 선택되어 있습니다(true).

  • 최소화 가능: 사용자의 윈도우 최소화 가능 여부를 지정할 수 있습니다. 기본적으로 이 옵션은 선택되어 있습니다(true).

  • 크기 조절 가능: 사용자의 윈도우 크기 조절 가능 여부를 지정할 수 있습니다. 이 옵션을 선택하지 않으면 [최대 폭], [최대 높이], [최소 폭], [최소 높이]가 흐리게 표시됩니다. 기본적으로 이 옵션은 선택되어 있습니다(true).

  • 표시 가능: 애플리케이션 윈도우를 초기에 표시할지 여부를 지정할 수 있습니다. 기본적으로 이 옵션은 선택되어 있습니다(true).

기타 설정

애플리케이션 설치와 관련하여 다음과 같은 추가 정보를 지정할 수 있습니다.

  • 설치 폴더: 애플리케이션이 설치되는 폴더를 지정합니다.

  • 프로그램 메뉴 폴더(Windows만 해당): 애플리케이션의 프로그램 메뉴 폴더 이름을 지정합니다.

  • 사용자 정의 업데이트 UI 사용: 사용자가 AIR 설치 프로그램 파일을 기존에 설치된 애플리케이션으로 열 때 발생하는 내용을 지정합니다. 기본적으로 AIR는 설치된 버전을 AIR 파일의 버전으로 업데이트할 수 있는 대화 상자를 표시합니다. 사용자가 결정할 수 없도록 하고 애플리케이션이 해당 업데이트에 대한 전체 제어 권한을 갖도록 하려면 이 옵션을 선택합니다. 이 옵션을 선택하면 기본 비헤이비어가 무시되고 애플리케이션이 고유 업데이트에 대한 제어 권한을 갖습니다.

언어 설정

[언어] 창에서는 애플리케이션 스토어 또는 마켓플레이스에서 애플리케이션이 사용할 언어를 선택할 수 있습니다. 언어를 선택함으로써 해당 언어의 운영 체제 사용자가 애플리케이션을 다운로드하도록 할 수 있습니다. 이 언어 설정은 애플리케이션 사용자 인터페이스를 현지화하는 것 외에는 아무런 영향이 없습니다.

언어를 선택하지 않으면 지원되는 모든 언어로 애플리케이션이 제작됩니다. 따라서 모든 언어를 일일이 선택할 필요가 없습니다. 목록에 나온 언어는 Adobe AIR에서 지원하는 언어입니다. Android는 추가 언어를 지원할 수 있습니다.

파일 유형 설정

[고급] 탭의 [연결된 파일 유형] 섹션에서 AIR 애플리케이션의 연결된 파일 유형을 추가하거나 편집하기 위해 더하기(+) 버튼 또는 연필 버튼을 클릭하면 [파일 유형 설정] 대화 상자가 표시됩니다.

이 대화 상자에서는 [이름]과 [확장명]이 필수 필드입니다. 이 두 필드를 비워둔 상태로 [확인]을 클릭하면 오류 대화 상자가 표시됩니다.

연결된 파일 유형에 대해 다음 설정을 지정할 수 있습니다.

이름

파일 유형 이름(예: Hypertext Markup Language, Text File 또는 Example)입니다.

확장명

파일 이름 확장명(예: html, txt 또는 xmpl), 최대 39자의 기본 영숫자 문자(A-Za-z0-9)로 선행 마침표 없이 지정할 수 있습니다.

설명

선택 사항입니다. 파일 유형에 대한 설명(예: Adobe 비디오 파일)입니다.

내용 유형

선택 사항입니다. 파일에 대해 MIME 유형을 지정합니다.

파일 유형 아이콘 설정

선택 사항입니다. 파일 유형과 연결된 아이콘을 지정할 수 있습니다. 아이콘이 표시될 다양한 보기에 허용되는 네 가지 아이콘 크기(128x128, 48x48, 32x32 및 16x16픽셀)를 지정할 수 있습니다. 예를 들어, 파일 브라우저에서 아이콘을 축소판 보기, 자세히 보기 및 바둑판식 보기로 표시할 수 있습니다. 이미지를 지정하는 경우 이미지의 크기는 지정한 크기여야 합니다. 특정 크기에 대한 파일을 지정하지 않으면 AIR에서 가장 근사한 크기의 이미지를 사용하고 지정된 발생 수에 맞게 크기를 조절합니다. 아이콘을 지정하려면 아이콘 크기에 대한 폴더를 클릭하고 사용할 아이콘 파일을 선택하거나 프롬프트 옆에 있는 텍스트 상자에 아이콘 파일에 대한 경로와 파일 이름을 입력합니다. 아이콘 파일은 PNG 포맷이어야 합니다. 새 파일 유형이 만들어지면 [고급 설정] 대화 상자의 [파일 유형] 목록 상자에 표시됩니다.

애플리케이션 및 설치 프로그램 파일 만들기 실패

다음과 같은 경우 애플리케이션 및 설치 프로그램 파일을 만들지 못합니다.

  • 애플리케이션 ID 문자열의 길이가 잘못되었거나 이 문자열에 잘못된 문자가 포함된 경우. 애플리케이션 ID 문자열은 1-212자여야 하며 0-9, a-z, A-Z, .(도트) 및 -(하이픈)만 포함할 수 있습니다.

  • [포함된 파일] 목록에 파일이 없는 경우

  • 사용자 정의 아이콘 파일의 크기가 잘못된 경우

  • AIR 대상 폴더에 쓰기 권한이 없는 경우

  • 애플리케이션에 서명하지 않았거나 Adobe AIRI 애플리케이션에 나중에 서명하도록 지정하지 않은 경우

애플리케이션에 서명

다른 시스템에 설치할 모든 Adobe AIR 애플리케이션에는 서명이 필요합니다. 그러나 Animate에서는 애플리케이션에 나중에 서명할 수 있도록 서명되지 않은 Adobe AIR 설치 프로그램 파일을 만드는 기능을 제공합니다. 이러한 서명되지 않은 Adobe AIR 설치 프로그램 파일을 AIRI(AIR Intermediate) 패키지라고 합니다. 인증서가 다른 시스템에 있거나 서명이 애플리케이션 개발과는 별도로 처리되는 경우 이 기능을 사용합니다.

루트 인증 기관에서 미리 구입한 디지털 인증서로 Adobe AIR 애플리케이션에 서명

  1. [파일] > [AIR 2 설정]을 선택한 다음 [서명] 탭을 클릭합니다.

    이 탭에 있는 두 개의 라디오 버튼을 사용하여 디지털 인증서로 Adobe AIR 애플리케이션에 서명하거나 AIRI 패키지를 준비할 수 있습니다. AIR 애플리케이션에 서명할 경우 루트 인증 기관에서 받은 디지털 인증서를 사용하거나 자체 서명된 인증서를 만들 수 있습니다. 자체 서명된 인증서는 만들기 쉽지만 루트 인증 기관에서 받은 인증서만큼 신뢰성 있지는 않습니다.

  2. 팝업 메뉴에서 인증서 파일을 선택하거나 [찾아보기] 버튼을 클릭하여 인증서 파일을 찾습니다.

  3. 인증서를 선택합니다.

  4. 암호를 입력합니다.

  5. [확인]을 클릭합니다.

AIR 애플리케이션에 서명하는 방법에 대한 자세한 내용은 AIR 파일에 디지털 서명을 참조하십시오.

자체 서명된 디지털 인증서 만들기

  1. [만들기] 버튼을 클릭합니다. 그러면 [자체 서명된 디지털 인증서] 대화 상자가 열립니다.

  2. [제작자 이름], [조직 구성 단위], [조직 이름], [전자 메일], [국가], [암호] 및 [암호 확인] 필드에 값을 입력합니다. [국가]에 대해서는 메뉴에서 값을 선택할 수도 있고, 메뉴에 나타나지 않는 2자의 국가 코드를 입력할 수도 있습니다. 유효한 국가 코드 목록은 http://www.iso.org/iso/country_codes를 참조하십시오.

  3. 인증서 유형을 지정합니다.

    [유형] 옵션은 인증서의 보안 수준을 가리킵니다. [1024-RSA]는 1024비트 키(보안 수준 낮음)를 사용하고, [2048-RSA]는 2048비트 키(보안 수준 높음)를 사용합니다. 기본값은 2048-RSA입니다. 

    참고:

    Animate에서는 1024 RSA 인증서가 2017.2 버전까지만 지원됩니다. 문제 해결에 대한 자세한 내용을 확인하려면 여기를 클릭하십시오. 

  4. [다른 이름으로 저장] 필드에 값을 입력하거나 [찾아보기] 버튼을 클릭하고 폴더 위치를 찾아 인증서 파일의 정보를 저장합니다.

  5. [확인]을 클릭합니다.

  6. [디지털 서명] 대화 상자에 본 절차의 2단계에서 지정한 암호를 입력하고 [확인]을 클릭합니다.

이 세션에 사용한 암호를 저장하려면 [이 세션에 대한 암호 기억]을 클릭합니다.

[확인]을 클릭할 때 [타임스탬프] 옵션이 선택되지 않은 경우 디지털 인증서 만료 시 애플리케이션을 설치하지 못함을 알리는 경고 대화 상자가 표시됩니다. 경고에 대한 응답으로 [예]를 클릭하면 타임스탬프가 비활성화됩니다. [아니오]를 클릭하면 [타임스탬프] 옵션이 자동으로 선택되어 타임스탬프가 활성화됩니다.

자체 서명된 디지털 인증서를 만드는 방법에 대한 자세한 내용은 AIR 파일에 디지털 서명을 참조하십시오.

디지털 서명 없이 AIRI(AIR Intermediate) 애플리케이션을 만들 수도 있습니다. 단, 사용자는 디지털 서명이 추가될 때까지 데스크톱에 애플리케이션을 설치할 수 없습니다.

나중에 서명할 AIRI 패키지 준비

  1. [서명] 탭에서 [나중에 서명할 AIRI(AIR Intermediate) 파일 준비]를 선택한 다음 [확인]을 클릭합니다.

    디지털 서명 상태가 나중에 서명할 AIRI 패키지를 준비하도록 선택했음을 나타내는 상태로 변경되고 [설정] 버튼이 [변경] 버튼으로 바뀝니다.

나중에 애플리케이션에 서명하도록 선택할 경우 Animate 및 AIR SDK에 포함된 명령줄 AIR Developer Tool을 사용해야 합니다. 자세한 내용은 Adobe AIR 애플리케이션 만들기를 참조하십시오.

타임스탬프 서버 URL

Animate는 사용자 정의 타임스탬프 서버의 URL을 추가할 수 있는 옵션을 통해 최신 타임스탬프 서버를 지원합니다. 

AIR SDK의 버전 추가 또는 제거

AIR SDK의 새 릴리스 및 사용자 정의 버전을 Animate에 추가할 수 있습니다. 추가된 새 SDK는 [제작 설정]에 있는 대상 플레이어 목록에 나타납니다.

SDK의 새 버전을 추가하려면

  1. 새 AIR SDK 폴더를 다운로드합니다.
  2. Animate에서 [도움말] > [AIR SDK 관리]를 선택합니다.
  3. [AIR SDK 관리] 대화 상자에서 더하기 "+" 버튼을 클릭하고 새 AIR SDK 폴더를 찾습니다. [확인]을 클릭합니다.
  4. [AIR SDK 관리] 대화 상자에서 [확인]을 클릭합니다.

새 SDK가 [제작 설정]에 있는 대상 플레이어 목록에 나타납니다. 허용되는 가장 낮은 SDK 버전은 SDK에 포함된 버전보다 높아야 합니다.

SDK의 버전을 제거하려면

  1. Animate에서 [도움말] > [AIR SDK 관리]를 선택합니다.
  2. [AIR SDK 관리] 대화 상자에서 제거하려는 SDK를 선택합니다.
  3. 빼기 "-" 버튼을 클릭합니다. [확인]을 클릭합니다.
Adobe 로고

내 계정 로그인